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Contact Center Solutions
Mitel Contact Center Solutions is designed for the 3300 IP Communications Platform (ICP), SX-200 ICP,
5000, and Axxess telephone systems. Contact Center Management is the core Contact Center Solutions
product.

Contact Center Management
l Provides a browser-based user interface (UI) that works across all 32-bit Windows platforms.
l Operates in conjunction with familiar Microsoft Office productivity tools.
l Is installed on the server only.
l Instantly deploys configuration changes from the server to authorized intranet and Internet users.
l Enables you to log on to any computer andmanage contact center operations and configure system

features.

What’s new in Version 6.0.2?
The following features and product enhancements have been introduced with Contact Center Solutions
Version 6.0.2.

Improvements to server-based alarms:
Contact Center Solutions Version 6.0.2 expands upon the centralized alarming system and is entirely
configured in YourSite Explorer. TheMaintenance Alarm Dispatcher service performs server maintenance
activities as well as controlling all alarming within the network. Alarm notifications can be set up to deliver by
email, RSS, SNMP, or within the YourSite Explorer Start Page.

For more information about server-side alarms, see "Monitoring and alarming subsystem" on page 171.

Web callback support:
Web callbacks are now supported in a virtual environment.

Russian localization
Core Contact Center Solutions products are now available in Russian.

IVR Routing queue resiliency enhancements
Dynamic call flows in IVR Routing are dependent on real-time queue statistics for accurate call routing. If the
Enterprise Server goes offline and real-time connectivity is lost cached data is used as the reference for call
statistics. Any call flow components that depend on data derived from real-time queue statistics are affected,
for example, prompts, queue condition activities, and Updated Position in Queue (UPiQ)messages. To
mitigate this, IVR Routing now offers a new level of queue resiliency that, when configured, detects if the
Enterprise Server is offline and routes calls to a static call flow that you have configured for that purpose.

For more information, see "Building resilient call flows" on page 455.

IVR Routing variable masking
IVR Routing variables can now be configured to hide their contents, enabling variables to be delivered either
entirely or partially masked. This limits the risk of potentially exposing confidential information, such as credit
card or social insurance numbers in logs, call notes, databases, and screen pops.
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Auto-absence on no answer
Available as of MCD 5.0 SP2, if an agent does not answer an offered call after a preconfigured amount of time
they are removed from their agent group(s) rather than being logged out of their agent group(s).

Technology changes
Contact Center Solutions and Call Accounting now support the following:

l Windows Server 2012
l Windows 8 Client
l Windows 8 Server (supported as a server for Contact Center Business Edition or Call Accounting only)
l MCD 6.0
l Salesforce.comWinter 2013
l Verint Impact 360 V.10 SP4 or greater and Verint Impact 360 V.11.0 or greater as Third-Party

WorkforceManagement Connectors

NOTE:Contact Center Solutions Version 6.0.2 is not compatible with Verint Impact 360 releases before V.10
SP4. Customers requiring support for other Verint Impact 360 releases must contact prairieFyre for support.

Contact Center Enterprise Edition and Contact Center
Business Edition
The Contact Center Solutions portfolio comprises Contact Center Enterprise Edition and Contact Center
Business Edition. Contact Center Business Edition is for individual contact centers with 50 or fewer agents.
When customers purchase Contact Center Business Edition, they can select from a number of applications
including historical reporting, real-timemonitoring, dynamic agent and queue control, screen pops, and
intelligent messaging.

Contact Center Enterprise Edition (formerly Contact Center Solutions) is for sophisticated contact centers
and supports all forms of communication including voice, email, web chat, fax, and walk-in customer
distribution. This scalable, resilient solution combines robust IP communications platforms, Automatic Call
Distribution (ACD), and amodular suite of feature-rich, web-based applications for streamlining contact center
management and enabling agent productivity.

The Contact Center Solutions applications and contact center devices available to you depend on whether
you have Contact Center Business Edition or Enterprise Edition.

Contact Center Solutions includes the following applications:
l Contact Center Management
l Interactive Contact Center
l Interactive Visual Queue
l Contact Center PhoneSet Manager
l Contact Center Softphone*
l Contact Center Screen Pop*
l Flexible Reporting
l Intelligent Queue*
l Salesforce.com Connector
l Workforce Scheduling
l Schedule Adherence
l Traffic Analysis*
l Multimedia Contact Center
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l Enterprise Node
l Mitel Border Gateway Connector*
l CTI Developer Toolkit*

* Not currently supported for theMitel 5000 and Axxess telephone systems. Support will bemade available in
a future release of Contact Center Solutions.

Licensing
An employee is a physical person you track in your contact center. In the YourSite database, youmust create
an employee ID for each employee whoworks in your contact center. Employees can havemultiple agent
IDs, but only one employee ID. You can run reports on licensed employees only. The number of employees
you license in YourSite Configurationmust be consistent with your software license.

To view details on your software license
l Click Help=>About your Mitel applications.

To view details on applications installed by Professional Services
l Click Help=>About your Mitel applications=>Professional Services

About this user guide
This user guide provides information on how tomanage your contact center using the Contact Center
Solutions applications. Tomake full use of Contact Center Solutions, youmust have a working knowledge of
theMicrosoft Windows operating environment andMicrosoft Excel 2003 or greater. The tutorials that
accompany Microsoft Windows and Excel provide information on basic use.

To report an issue with this document, please email techpubs@prairiefyre.com.

Chapter 1 Contact Center Solutions
Chapter 1 describes

l The features and benefits of Contact Center Management
l Licensing
l The layout of the user guide
l Document conventions
l Information on how to install client applications from the Contact Center Management website

Chapter 2 Contact Center Concepts
Chapter 2 describes

l The inbound contact center environment
l How resources interact to process contacts

Chapter 3 Contact Center Planning and Management
Chapter 3 provides information on how to plan andmanage your contact center, including how to

l Establish a corporate Service Level objective
l Collect data.
l Forecast the Call Load.
l Calculate the resources required.
l Schedule agents.
l Determine contact center costs.
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Chapter 4 Getting Started
Chapter 4 describes how to

l Register your software
l View multiple Contact Center Management sessions
l Back up and restore the YourSite database and raw telephone system data files
l Set up client computers to use Contact Center Management
l Specify user preferences

Chapter 5 Services and Database Administration
Chapter 5 describes how to

l Start and stop the Contact Center Management services
l Perform database andmaintenance functions

Management Console resides in the Contact Center Client real-time application. UsingManagement
Console, you can

l Back up and restore YourSite database configuration data
l Update the server IP address
l Import configuration data used to configure the YourSite database
l Run themaintenance routine
l Summarize data for running reports
l Create a support package

Chapter 6 Configuration
Chapter 6 describes how to

l Configure contact center devices in the YourSite database so you can view real-time activity and
generate reports on these devices

l Configure the YourSite database using Synchronization
l Create business hour schedules
l Configuremedia server alarms
l Implement security measures to restrict user access to specific Contact Center Solutions application

areas and contact center devices
l Configure call recordings

Chapter 7 Real-time Monitors and device control
Chapter 7 describes how to

l View real-time agent and queue statistics on real-timemonitors.
l Configure alarms for agent and queue performance
l Customizemonitor display characteristics
l Build marqueemonitors and broadcast statistics andmessages
l Chat online with agents or supervisors
l Configure and display real-time statistics on one or more wall signs
l Set up support for teleworking
l Add and view call notes appended to calls

Chapter 8 Reports
Chapter 8 describes how to

l Generate on-demand reports
l Set up timetables for generating reports
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Chapter 9 Forecasting
Chapter 9 describes how to

l Create forecasts
l Export forecasts to Excel

Chapter 10 Data-mining Tools
Chapter 10 describes how to

l Search for specific contact center events
l View the historical real-time events that occurred on a particular date, in the sequence they occurred

Chapter 11 Data Collection
Chapter 11 describes how to

l View data and system alarms
l Verify media servers are receiving telephone system data

Chapter 12 Interactive Contact Center
Chapter 12 describes how to

l Control the availability of agents and ACD queues

Chapter 13 Interactive Visual Queue
Chapter 13 describes how to

l View calls within queues andmove calls from busy queues to less active queues
l Call back abandoned callers

Chapter 14 Contact Center PhoneSet Manager and Contact Center Softphone
Chapter 14 describes how to

l Enable agents to use their desktop computers as IP-based phones

Chapter 15 Contact Center Screen Pop
Chapter 15 describes how to

l Launch applications orWeb pages when agents receive calls
l Provide agents with caller and account information via pop-ups on their computer monitors when they

receive calls

Chapter 16 Flexible Reporting
Chapter 16 describes how to

l Design your own report templates and customize existing reports

Chapter 17 IVR Routing
Chapter 17 describes how to

l Install and configure IVR Routing

Chapter 18 Intelligent Queue
Chapter 18 describes how to

l Provide static messaging, intelligent messaging, voice and web callbacks, and call recording

Chapter 19 Workforce Scheduling
Chapter 19 describes how to

l Schedule agents
l Measure employee adherence to schedules
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Chapter 20 Traffic Analysis
Chapter 20 describes how to

l Set up the telephone system and YourSite database so you can collect data and run reports on the
traffic data stream

Chapter 21 Multimedia Contact Center
Chapter 21 describes how to

l Configure Contact Center Management so you can track and run reports onmultimedia contacts
l ConfigureMultimedia Contact Center so you can control your availability to receivemultimedia

contacts and handle them

Chapter 22 Enterprise Node
Chapter 22 describes how to

l Configure data collection nodes inmulti-site enterprises

Chapter 23 CTI Developer Toolkit
Chapter 23 describes

l Common uses of the CTI Developer Toolkit
l Examples of how to use the CTI Developer Toolkit to customize applications

Chapter 24 Salesforce.com Connector
Chapter 24 describes how to

l Integrate your Mitel phone directly into the Salesforce.com user interface

Locating the latest version of our guides
prairieFyre recommends you obtain the latest version of theMitel Contact Center Solutions User Guide.

To obtain theContact Center Solutions User Guide:
l Start Internet Explorer and type

http://www.prairiefyre.com/wp-content/rscs/documentation/ContactCenterSolutions_
UserGuide.pdf

To obtain theCall Accounting User Guide:
l Start Internet Explorer and type

http://www.prairiefyre.com/wp-content/rscs/documentation/CallAccounting_UserGuide.pdf

Document conventions
This document uses the following conventions.

UI syntax
The following terms apply to actions you perform on the UI:

l Click precedes options you select with themouse, such as buttons, menus, and items in list boxes.
l Press precedes keys you use on the keyboard.
l Select or clear precedes options you turn on or turn off, such as check boxes.
l Select precedes options you select in combo boxes (text boxes with attached list boxes).
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For example,
 1. Click OK.
 2. Press Enter.
 3. Select thePFdatabase check box.
 4. Drag and drop the name to theAvailable list.

Italics
Italic typeface is used

l For emphasis (for example, hot desking)
l To set off words, letters, and numbers referred to as themselves in the text (for example, overflow is the

routing of calls to more than one queue; the application saves text files as MMDDYYYY.sql)

Bold
Bold typeface designates paths you select in your root directory and items you click, press, type, or select.

For example,
 1. Click OK.
 2. Delete 50 and type 60.
 3. Select theCheck database integrity check box.

UI Menu items
UI menu items you select are separated by an arrow [=>]. For example, File=>Open tells you to select the
Open submenu on the File menu.

Note
The wordNOTE: designates essential user information.

Searching for key words and definitions
The Help Documentationmenu displays the user guides and installation guides available. The documents are
in .pdf format and will open in your browser in Adobe Reader or Adobe Acrobat. The first time a key word or
acronym is used in the guide it is defined.

To search for a key word or definition in the guide, such as ACD
 1. Click Help=>Documentation.
 2. Select theContact Center Solutions User Guide.
 3. On the Adobe toolbar, click theBinocular icon to search for key words or definitions.
 4. AfterWhat word or phrase would you like to search for? typeACD.
 5. Click Search.
 6. UnderResults, click the ACD hypertext link to locate the next instance of ACD.

Required and optional software components
Contact Center Solutions applications have a number of required and optional applications you install on client
computers. You can download these applications from the prairieFyre FTP Server. For details, see
http://www.prairiefyre.com, log in to the Dealer Portal, and click Download Center.
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Required components
In order to use Contact Center Solutions and Call Accounting applications, the following components must be
installed on client computers.

l Microsoft .NET Framework enables your computer to run applications created with .NET. All client
computers must have the latest version of .NET Framework installed.

l Microsoft Internet Explorer updates your browser software to the latest version. All client computers
require IE 6.0 or greater.

l Microsoft Report Viewer 2005 Redistributable Package includes Windows Forms and ASP.NETWeb
server controls for viewing reports designed usingMicrosoft reporting technology.

l WebServices Enhancements (WSE) 3.0 for Microsoft .NET is theMicrosoft .NET Framework version
3.0 redistributable package that installs the common language runtime and associated files required to
run applications developed to target the .NET Framework.

l Microsoft DirectX significantly enhances graphics, sound, music, and 3-D animation inWindows
applications.

Optional components
You can install the following application on client computers.

l Adobe Reader enables you to view documents and reports in .pdf format. You require Acrobat Reader
to view the online user guide, user tutorial, reporting guide, and reports. If you haveMicrosoft Excel or
Microsoft Excel Viewer, you can also use it to view reports.

l Remote Server installs media servers (for voice, email, fax, or chat), and selected prairieFyre services
on a computer other than the Enterprise Server. For more information on the services included with
Remote Server installation, see theMitel Contact Center Solutions Installation Guide.

l WebChat Server installs theMultimedia Contact CenterWebChat Server. You install this software on
the public Web server only.
NOTE: If you are upgrading from a previous version of WebChat Server to version 5.4 or later, you
must upgrade yourWebChat Server software to the same version as your Contact Center Solutions
software.

Client Component Pack
Client Component Pack contains all of the Contact Center Management, Flexible Reporting, Multimedia
Contact Center, andWorkforce Scheduling software components that contact center employees could need
on their computers. You require administrator privileges to run this installation.

You can install Client Component Pack on individual client computers or servers running Citrix Terminal
Services.

You can install the following software components.
l Contact Center Client enables you tomonitor devices in real time, run Contact Center PhoneSet

Manager or Contact Center Softphone, Management Console, and Network Monitor.
l Flexible Reporting enables you to run reports, create new report templates, redesign report templates

based on existing Contact Center Management voice reports, andmodify report templates available in
Flexible Reporting.

l TheMultimedia Contact Center Outlook Extensions download enables you to use theMultimedia
Contact Center Outlook Extensions download to runMultimedia Contact Center on client computers.

l Salesforce.com Connector enables you to integrate Contact Center Solutions with Salesforce.com
l TheWorkforce Scheduling download enables you to runWorkforce Scheduling on client computers.
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Contact Center Concepts
Contact centers process a high volume of contacts to meet marketing, sales, customer service, technical
support, and other business objectives. A fine-tuned contact center distributes contacts efficiently and
optimizes the use of agents and other resources. This section describes the inbound contact center
environment and how resources interact to process voice contacts.

Automatic Call Distribution (ACD)
Automatic Call Distribution (ACD) is a specializedmechanism for distributing incoming calls. The primary
goal of ACD is to ration calls to agents in a cost-effectivemanner that provides acceptable service to callers.

To optimize the use of agents, you cross-train them so they can handle a variety of inquiries. Rather than
distributing calls to a number of small, specialized agent or extension groups, ACD distributes them efficiently
among the entire pool of available agents. When you consolidate resources (use the Pooling Principle), the
same number of contact center agents handlemore calls while maintaining Service Levels.

Typically, you program ACD to ensure the first call to arrive reaches the first available agent or the agent who
has been idle the longest. However, you can vary the order of calls and agents to provide superior service to
preferred customers, and skills-based routing.

Understanding ACD call flow
The path of an incoming call is as follows. A caller telephones your contact center via the Public Switched
Telephone Network (PSTN). (The PSTN is a global collection of Central Offices (COs) interconnected by
long-distance telephone switching systems.) The local CO directs the call to one of your trunk groups. An
available trunk picks up the call. Typically, calls from the PSTN arrive to the contact center over incoming
trunks and calls from the contact center to the PSTN travel over outgoing trunks. If no trunks are available, the
call does not get through to the system (it is blocked) and the caller receives a busy signal.

When a trunk picks up a call, it forwards it through to a group of agents handling calls, or to some other
answering point. The call arrives at the ACD queue of an agent group. The queue delays the call rather than
blocking the call from entering the system. The length of time the caller waits in queue is the queue time.
While waiting in queue, the caller listens to product features, announcements, or other messages provided by
a Recorded Announcement Device (RAD). The caller can wait patiently in queue for an available agent, leave
a voicemail message, or hang up (abandon) the call. (See Figure 2 - 1.)

An agent handles the call. The time the caller spends talking to the agent is the ACD Handling Time (including
the hold time). If the agent calls the supervisor in search of more information (while the caller is on hold) and/or
transfers or conferences the call, these times are added to the ACD Handling Time value.

For example, an agent speaks to a caller for twominutes and then puts the caller on hold for threeminutes and
tries to solve the problem. This may include a call to the supervisor. The agent then initiates a conference call
with the caller and a third party and they speak for threeminutes and resolve the issue. Therefore, the ACD
Handling Time for the agent is 2 + 3 + 3 = 8minutes.

When the call is completed, the agent might need to perform additional work associated with the call. The time
taken to perform this work is theWrap Up Time.
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Figure 2 - 1 Call flow

Monitoring the call flow process
Second-by-second (real-time) statistics presented on wall signs and desktopmonitors enable you tomonitor
the service provided to callers. You canmonitor the number of incoming calls, the time it takes to process
them, the queue load, and the availability of agents using aManagement Information System (MIS). TheMIS
refers processes data produced by the telephone system. TheMIS uses telephone system records to provide
forecasting, real-timemonitoring, and reporting functions.

Ensuring traffic-carrying efficiency
To optimize traffic-carrying efficiency ensure

l Sufficient trunks are available to carry incoming calls.
l Callers experience a delay in queue.
l There is a random distribution of calls among available agents.

Scheduling to optimize call flow
You schedule agents so the number of incoming calls at any given time typically exceeds the number of
agents currently available. The intent is that callers experience a slight delay before agents answer their calls.
The expected number of incoming calls forecasted for the time of day, and day of the week influence
scheduling decisions.

Routing calls
Call routing options you program in the telephone system provide a set of instructions that automate the
movement of calls to their intended answering points. You can define options—for example, if the caller dials
1, the system forwards the caller to customer service. You can specify re-routing for calls not answered after
a set period of time and parse incoming Automatic Number Identification (ANI) and Dialed Number
Identification Service (DNIS) data to direct call routing. (See Figure 2 - 2.)
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Figure 2 - 2 Call routing

Dialing an agent’s extension
In the simplest call scenario, a single trunk picks up an incoming call to your contact center. The telephone
system presents the caller with options to dial various answering points. The caller dials an individual agent at
an extension through a queue number. A queue number is an address mechanism for a queue or other
answering point. The programming associated with the queue number defines the routing and timing features
of the call. The telephone system collects data on the agent and trunk involved in the call. The ACD
management reporting application produces reports on agent and trunk activity.

Dialing a queue
In the next call scenario a trunk group picks up an incoming call to your contact center. The system presents
the caller with options to dial various answering points. The caller dials queue number 1 to reach queue 1
(Customer Service). The system forwards the call to the first available agent in the agent or extension group
associated with queue 1. The call is an ACD call because one dialable number represents all of the agents in
the group. The telephone system collects data records for the call. The ACD management software produces
Queue Reports on queue 1.

Overflowing calls
An ACD call that is not answered immediately is placed in a queue. If an agent does not pick up the call after a
set amount of time (the overflow time) the system places the call in the queue of another agent group, in
addition to keeping it in the first queue. The first available agent in either group handles the call. The overflow
feature limits the delay faced by callers by queuing calls against two or more agent groups. (See Figure 2 - 3.)
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Figure 2 - 3 Multiple queue routing

Interflowing calls
You can program the telephone system to direct a queue delayed call to voicemail or to another answering
point. The interflow timer runs independently of the overflow timer. If the interflow timer expires, the system
removes the call from the queue and re-directs it to another answering point, such as a trunk or voicemail.

The inbound call environment
The inbound contact center environment has unique characteristics that must be considered in effective
planning andmanagement.

Predicting call arrivals
Calls arrive randomly to contact centers. You cannot predict theminute-to-minute arrival of calls. This results
in unanticipated increases in workload, and impacts staffing calculations and the load carried by system and
network resources.

You can predict the pattern of call arrivals for 15-minute or longer intervals. For example, you can predict that
next Monday between 1:00 P.M. and 1:30 P.M. you will receive 60 phone calls. However, you cannot predict
how many calls will arrive in the first fiveminutes, the second fiveminutes, and so on.

Understanding caller tolerance
Several factors influence a caller’s tolerance to queue delays:

l The immediacy of the caller’s requirement
l The availability of similar products or services
l The caller’s expectations for service
l The time available to make the call
l Whether or not the caller is paying for the call
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Contact Center Planning and Management
Effective contact center management involves having the right resources in place at the right times to handle
an accurately forecasted workload at the desired level of service. Commitment to a systematic planning and
management strategy is essential. The strategy is based on corporate objectives that you continually assess
and refine.

Whether you aremanaging a start-up contact center or refining the performance of an existing operation, the
process illustrated in Figure 3 - 1 applies. It is the basic framework for achieving andmaintaining your service
objectives.

Figure 3 - 1 Planning cycle
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The objective of contact center management is to find the right balance between the agents scheduled and the
service provided to customers. This involves assessing and re-assessing trade-offs between the Service
Level, agents scheduled, and average call duration for a knownCall Load for each 15-minute or half-hour
interval of the day. Collecting, properly interpreting, and applying ACD and other information allows you to
accurately forecast the workload and schedule sufficient agents to meet your service objectives.

Step #1 Establish a corporate service objective
The Service Level % is a performancemetric contact center managers use to determine what proportion of
customers, that contact you by voice/email/chat/fax, receive “good” service. Using the Service Level %, you
can gauge the level of service customer's experience, from a historical and a real-time perspective.

Defining and adequately funding a service objective should be closely tied to your corporatemission. The
service objective identifies the average length of time a caller who has obtained a trunk waits for an available
agent. It is the basis for planning and budgeting and links the resources you require to your service objectives.
Choosing a service objective is the first step in a comprehensive planning andmanagement solution. Once
you set a service objective, you should routinely access it to see how consistently you aremeeting it, on a 15-
minute or half-hour basis.

Contact centers in different industries use different criteria for measuring service. Your service objective
should reflect the type of service being provided and the expectations of callers seeking the service. For
example, a company that sells magazine subscriptions has less to lose in the outcome of any one call than a
car dealership does. A caller to a credit card “lost or stolen” linemight expect different service than a caller to a
customer service department at a bank. Contact center metrics across industries are designed to reflect this.

Performance targets must suit the primary function of a contact center. In revenue-based contact centers
where agents sell products or services, the net revenue per call is considered when defining a service
objective. Revenue-based contact centers strive to provide a high level of service with minimal blocking and
delays.

Understanding the Service Level
The Service Level applies to all of themedia types (voice/email/chat/fax) and is expressed as a percentage of
a statistical goal: it specifies the Service Level Time and the Service Level % goals for the queue or agent
group.

TheService Level is expressed as X percent of calls handled in Y seconds or less, such as 80 percent of calls
handled in less than 20 seconds. Why is Service Level the standardmeasurement of service? Service Level
provides themost accurate representation of the callers’ experience. It is ultimately the caller who decides
what constitutes good service, and whether or not to end a call. It applies to inbound transactions that must be
addressed as they arrive.

When a caller enters a queue, the call is processed in one of three ways:
l An agent answers the contact (handled contact).
l The client disconnects before an agent answers (abandoned contact) (for calls and chats only).
l The contact is removed from the queue, and sent to another handling point (for example, to voicemail,

an automated attendant, or another queue), (Interflowed contact).

For detailed information on Calls Offered, Calls Handled, Calls Abandoned, Calls Interflowed, and other
Service Level parameters see "Choosing a Service Level goal" on page 19.
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Understanding why the Service Level is the most meaningful
statistic
The Service Level is one of many ACD statistics used tomeasure performance. Each statistic has its
purpose. For example, theGrade of Service (GOS) statistic relates the number of trunks to the level of traffic
and indicates the likelihood an attempted call will receive a busy signal. It is expressed as a decimal fraction.
For example, a GOS of P.02means a caller will have a two percent chance of receiving a busy signal. Since
trunk costs are insignificant compared to agent costs contact centers are well advised to schedule sufficient
trunks, abandons should beminimal.

A delayed call is a call placed in the ACD queue because it cannot be answered immediately by an agent. The
probability of delay statistic relates the number of agents or extensions to the level of traffic carried by the
trunks and indicates the likelihood and amount of delay experienced. TheGOS, probability of delay, and
Quality of Service rendered by agents provide vital information about the callers’ experience. (See Figure 3 -
2.)

Figure 3 - 2 Service criteria

TheGOS and probability of delay contribute to our understanding of what happens to the calls not answered in
Y seconds, and givemeaning to Service Level. Service Level is the primary statistic used in planning and
budgeting because it is themost stable measurement of queue activity.

The following statistics are alsomeaningful contact center indicators:

ASA
TheAverage Speed of Answer (ASA) is an ACD statistic that measures how long the average caller waits on
hold before the call is picked up by an agent. ASA is a valuablemeasure of service quality, but is often
misinterpreted. The average does not represent what is typically experienced by individual callers. Most calls
are answered by agents more quickly than the average, but a small percentage of callers wait several minutes
in queue. ASA is a useful parameter, but Service Level is amore reliable indicator of what callers experience.
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Abandonment
ACDs collect statistics on how long callers wait before abandoning calls, and what percentage of calls are
abandoned. Unfortunately, abandonment is difficult to forecast because it is impossible to predict caller
behavior with any reliability. Sometimes when the Service Level is highmore callers abandon than expected.
There are no industry standards for abandonment. It is a somewhat unreliable measure of contact center
performance. However, abandonment statistics assist in planning Service Levels, and provide valuable
information used to create in-queue andmessage-on-hold announcements.

Choosing a Service Level goal
Contrary to popular belief, there is no industry standard Service Level. Some contact centers base their
Service Level goal on the targets of same-industry companies. In doing so, they assume these companies are
actually meeting their intended targets. Companies are setting increasingly rigorous Service Level targets in
sectors where outstanding customer service is the norm. In a survey of over 100 UK contact centers Opta
Consulting was surprised to find an average performance target of 90 percent of calls answered in 15
seconds. They found that companies setting extremely rigorous targets did not necessarily meet them, and
the investment required to achieve “best in class” targets was difficult to justify.

Setting an appropriate Service Level goal for your contact center is not easy. Themotivation and expectations
of your customers, the availability of similar goods or services, the Service Level targets of same-industry
companies, and the value of calls are things to consider. It may be useful to run some calculations to
determine the trade-offs in Service Level associated with adding or removing an agent, and implement
customer satisfaction surveys. When defining your corporate Service Level, consider several factors and rate
their relative importance.

An appropriate Service Level is one that
l Satisfies callers’ expectations for service
l Keeps abandonment in check (at less than five percent)
l Minimizes expenses andmaximizes revenue
l Meets with the approval and support of agents, supervisors, and senior management

Consider this modest objective. For a Service Level of 80 percent of calls answered in less than 20 seconds,
callers receive the following service:

l Approximately 30 percent of callers experience a delay in queue.
l The longest wait time is approximately threeminutes.
l The average speed of answer is approximately 12 seconds.

Is this acceptable service for you and for your callers?

Understanding Quality of Service
Agent statistics reflect the time agents spend in various states and are used to assess agent performance.
The average time an agent spends handling contacts, and in theMake Busy, Do Not Disturb, Unavailable,
andWrap Up states directly affects the agent’s availability and the Service Level provided to callers.

Service Level alone does not ensure customer satisfaction. The quality of the interaction between the caller
and agent leaves a lasting impression.TheQuality of Service reflects an agent’s ability to provide excellent
service to each customer. The knowledge of the agent, the accuracy and completeness of the information
provided, and the courtesy extended to the caller contribute to the caller’s experience.
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Monitoring call handling techniques
Silent monitoring systems complement ACD statistics by providing a snapshot of quality and productivity in
your contact center. You can track call handling techniques and determine where improvements can bemade
in individual performance. Advanced systems capture the voice conversations between agents and callers
and record agent data tables for a complete picture of call handling. They provide online evaluation forms so
you can annotate recordings with feedback.

Silent monitoring takes the bias out of performance evaluation. Silent monitoring provides a systematic
process for monitoring and grading agent calls. You can schedule sessions across different times of the day,
days of the week, and evaluators promoting fairness and consistency. Showing agents where improvement is
needed is more effective than just telling them. Silent monitoring can contribute to a reduction in call time, a
reduction in monitoring time and personnel, and increased training efficiency.

You can use pre-recorded conversations between agents and customers to train agents and for ongoing
evaluation.

You can use the information to
l Provide recorded examples of exceptional service and unacceptable service to agents in training.
l Record, review, annotate with feedback, and forward call records to agents who then review your

comments within the context of the actual call.
l Calibrate and routinely access the scoring consistency of call monitors.
l Assess the effectiveness of current training programs.
l Assess the efficiency of themonitoring and assessment process.

Defining scoring parameters
The parameters used to evaluate how well agents handle calls are based on the purpose of the calls. Goals
vary across calls for inbound and outbound services. For example, in an outbound sales environment quality
may be based on whether or not the agent made the sale, took advantage of cross-sell opportunities, and
adhered to a pre-defined script. In an inbound environment quality may be based on the completeness and
accuracy of the information and whether or not the caller’s questions were answered satisfactorily. Agents are
also evaluated on “soft skills”, such as voice quality, pausing at regular intervals, rate of speech, use of
positive language, and other listening and communication skills.

Setting performance standards and goals
Once you determine appropriate scoring parameters, you define standards for exceptional and acceptable
levels of performance. Assessment standards are based on consensus andmust be clearly defined and
communicated tomonitors and agents. Collaborate with agents in setting performance goals and clearly
define exceptional service and interim performance steps. Determine a baseline of current performance and
set performance steps for an agent group. Provide agents in the group whomeet or exceed the interim target
with rewards and recognition commensurate with their performance. When systematically used in training and
coaching recorded sessions positively impact productivity. Fair assessment is good for moral andmotivation,
and contributes to an environment in which agents can learn and grow.

Monitoring frequency
The frequency of monitoring sessions is determined by individual companies and ranges from once amonth to
15 or 20 sessions amonth. Implementing five to 10monitoring sessions per month is common practice.
Trainees and agents with consistently low scores aremonitoredmore frequently than other agents. Resource
limitations typically influence the frequency of monitoring.
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Monitoring systems and tools
The followingmonitoring systems and tools help you evaluate the performance andmanage the quality of
service of your contact center.

Silent monitoring systems
Silent monitoring systems range from tape recorders to client/server based recording systems. Advanced
systems schedule, record, and store voice files in a compressed digital format using a real-time link to your
telephone system. They capture any data tables accessed by the agent in addition to voice data. Silences are
eliminated to optimizemonitoring efficiency. Recording sessions can be played back from any telephone,
anywhere, at anytime. You can customize agent evaluation forms and define parameters for quality with
advanced systems. They provide activity, status, andmanagement reports for evaluating agents and
observation practices.

IT support systems
Information Technology (IT) support systems are commonplace in contact centers. Contact center agents
divide their time between listening to customer requests, entering and updating customer information and
other entries, searching for required information, and providing feedback to customers. In order to provide
prompt and complete information, agents must have immediate online access to information including
customer records and case histories, products and services, and company policies and procedures.

The push to increase agent efficiency and customer service has placed new demands on computer
information systems and information technology. Information products that enhance agent productivity are
continually being developed. Contact center systems are designed to incorporate some, or all of the following
specialized support functions.

CTI
Computer telephony integration (CTI) is themerging of computers and telephone systems. Today’s computer-
based telephone systems deliver synchronized voice and data, voice and data conferencing, automatic
information retrieval for calls, caller-basedmessaging and routing, and desktop productivity tools. You can
use customer databases in call handling to enhance customer service and agent productivity. When
databases are shared between contact center departments each agent can access a caller’s contact
information, purchasing records, call history, and preferences by a caller ID number.

ANI
Automatic Number Identification (ANI) identifies the telephone numbers of callers to your contact center, so
agents can receive screen pops with calls. You can connect a database to your telephone system to
simultaneously send calls and caller information. The telephone system forwards the caller’s telephone
number to a software application that relays database records on the caller to the agent. Alternately, the caller
enters an ID number that the database associates with a set of records for the caller and the agent is sent the
information.

ANI saves agents time since they do not have to ask for and enter a name for a caller, and wait for the
database to respond. This time savings significantly impacts staffing requirements and telephone service
charges. ANI also identifies telephone numbers of callers who abandon calls so they can be contacted later
for potential business.

Reports can identify the volume of usage and costs of internal line numbers, and help you track the long
distance distribution per line number andmaximize long distance efficiency.
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DNIS
Dialed Number Identification Service (DNIS) is a feature of toll-free lines that identifies the telephone number
the caller dials. This assists agents who handle calls for more than one business or product line. Each
business or product line has its own toll-free number. When a caller dials a toll-free number, the telephone
system forwards information to the agent so the agent can identify who the caller dialed. For example, a caller
dials a toll-free number for a cruise line. The telephone system sends a script to the agent along with the call.
The agent then knows to answer “Goodmorning. Thank you for calling Southern Cruises,” instead of the name
of another cruise line serviced by the center.

Automating help desk workflow
Agents at IT help desks require quick access to customer information and call history, and the ability to rapidly
log all of the support calls and incidents. Advanced help desk packages offer automated desk help workflow
systems. They assist agents in logging service requests (tickets), dispatching them to prioritized queues or
agents, tracking them, and documenting activities.

External applications, help desk operators, or end users (in web-based applications) generate tickets. The
system generates themmanually, or in some cases automatically, in response to system events. It can
correlate multiple incidents with single tickets, andmultiple problems with a single call.

Automated help desk workflow systems track each step taken in answering a call, with automatic time
stamping of all of the referrals, escalations, reminders, alerts, and email notifications. Calls are prioritized and
referred to other departments without reassignment, reassigned (escalated) to other technicians or
specialized staff, and placed in an alert condition when they are not resolved promptly. Activities are date and
time stamped automatically. Most help desks offer outgoing email notification and paging. Some help desks
offer automated logging of incoming emails, and automated call acknowledgment emails to clients.

Step #2 Collect data
Telephone systems generate an enormous amount of real-time and historical data used in planning and
management of your contact center. You use real-time data tomonitor the current Call Load and agent
availability sominute-to-minute adjustments can bemade. You use historical information in forecasting,
staffing, and scheduling. Other critical management information comes from customer surveys, market
studies, employees, external departments, telephone networks, workforcemanagement systems,
competitors, and themedia. Data collection is a continuous process you implement as soon as your
telephone system is up and running.

Telephone systems provide detailed report data on every aspect of call transactions. You can program
computer-based telephone systems connected to a Local Area Network (LAN). Users on the LAN can view or
print real-time and historical reports. Using web-enabled telephone systems, you can view and generate
reports in aWeb browser. You canmonitor contact center activities remotely, and distribute reports to people
on different networks.

Collecting data on call handling
Contact center reporting software displays real-time telephone system data on desktopmonitors and wall
signs. Using real-time data, you canmanage current conditions and ensure agents respond to changing
contact center events. The telephone system provides information on call activity, agent activity, and queue
activity.
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You can use historical data in forecasting and in assessing the performance of your resources. Historical
reports provide vital information on load activity, resource activity, and queue activity. For example, resource
activity reports on trunks can tell you the highest number of trunks used during peak traffic periods, and the
total duration of calls handled by each trunk for the reporting period. You can determine how busy your trunks
are, and whether or not you have the right number of trunks scheduled.

CTI provides in-depth information on call transactions. Detailed information on keystroke sequences,
databases searched on, and on-screen assistance provides a clear picture of agent activities. Using ANI
data, you can identify callers by area code and collate information on demographic trends in caller behavior.

Workforcemanagement systems use telephone system data to forecast and schedule agents. Some
packages monitor the real-time adherence of agents to scheduled activities, so you know the number of
agents currently logged on and available to handle calls. Workforcemanagement systems collect and store
real-time adherence data. This data provides a historical account of adherence used in agent assessment.

Customer surveys provide valuable supporting information on callers’ tolerance to delay, and expectations for
service. They address some of the following questions: Was the agent accessible?Was the caller put on hold
for too long?Was the agent courteous and responsive tomy request?Was the agent well informed? Did the
agent provide the correct information and keep commitments? Contact centers use this information to
estimate the repercussions of poor service: escalated costs, duplication of work, lost customers.

As the economy moves towards individual, personalized services, new ways of handing calls continue to
emerge. These new features add to the complexity of collecting andmeasuring information. It is vital you
establish an integrated, reliable system for measuring the key indicators of performance: the efficiency of call
handling, the service callers experience, and their perceptions of that service.

Step #3 Forecast the Call Load
Finding the right balance between resources and traffic volumes is a critical step in effective contact center
management. Estimating resource requirements is particularly challenging as the number of calls and the total
duration of calls expected for a given time interval is difficult to predict.

Forecasting impacts contact center operations and performance in the following ways:
l The number of blocked and abandoned calls
l The level of service provided to callers and callers’ perception of service
l Agent workload, call behavior, and retention
l The accuracy and usefulness of schedules
l The success of periodic sales campaigns

Forecasting accurately
Forecasting is an imprecise science. The accuracy of your forecast increases markedly with the size of your
data sample. You take a year (or preferably two or three years) of ACD queue traffic data, examine trends in
Call Load patterns, break down the information, and determine the ACD Handling Times of the calls. You then
modify the forecast based on current contact center activities and other considerations, such as absenteeism,
agent breaks, holidays, and training.
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The range of forecast dates you specify depends on the purpose of the forecast. Using long-term forecasts,
you can estimate future budgets and expansion opportunities, and establish corporate objectives. Using
short-term forecasts (of one to threemonths) you can determine seasonal staffing requirements, plan for
short-term sales campaigns, and assess upcoming hiring needs. You can use weekly, daily, hourly and half-
hour forecasts to tweak agent schedules and adjust for absenteeism.

Conducting forecasts
Conducting a forecast involves accurately estimating the three components of Call Load: the ACD Handling
Time, Wrap Up Time, and Calls Offered. After you run a forecast, it is useful to examine the data andmake
adjustments based on present contact center conditions. You tweak the forecast by adding or reducing calls
based on your intuition and on information gathered by yourself and others.

To forecast the agent requirement, you
 1. Examine trends in Call Load patterns.
 2. Break the information down in tomonthly, weekly, daily, half-hour, and 15-minute intervals that reflect

Call Load patterns.
 3. Determine the handling times of calls.
 4. Modify the forecast based on current contact center activities and other considerations, such as

absenteeism, agent breaks, holidays, and training.

Youmay need to consider the following issues: hardware or software system changes, expected callers,
advertising andmedia, changes to your products, services, or pricing, new products, product performance,
competitors actions, and international, national, and corporate events. It is vital to have a systematic
forecasting process in place that all of the departments support. For detailed information on Call Load, ACD
Handling time, Wrap Up Time parameters, see "Forecasting terms" on page 292.

Step #4 Calculate the resources required
You calculate the agent requirement in conjunction with the trunking requirement. The number of available
agents affects the likelihood and length of delay experienced by callers. The delay affects the load trunks
must carry. Because the number of available agents impacts the number of trunks required, you calculate the
agent requirement first.

The Erlang C formula uses your historical Call Load and Average Talk Time data to predict the agent
requirement for the time interval and date range in the forecast. The resultant spreadsheet displays the Call
Load and agents required across time intervals.

Predicting agent requirements
Agent costs account for over 60 percent of all of the contact center costs. Accurately predicting the agent
requirement, making themost effective use of agents, and standardizing andmonitoring agent activities are
paramount to achieving your service objectives. Agents are your most valuable resource: make team building
and teammanagement a high priority.

You can predict the agent requirement for your Service Level Percentage and Service Level Time targets by
applying the Erlang C equation to the estimated Call Load and Average Talk Time.
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Understanding Erlang C
Staffingmodels consider important factors unique to the inbound contact center environment:

l Call arrival is random.
l Consolidating resources allows the same number of contact center agents to handlemore calls while

maintaining Service Levels.
l Maintaining high Service Level targets requires staffing a large number of agents that will be idle a

significant portion of the day.

The industry standard Erlang C equation operates on these principals. Most contact center reporting
packages use Erlang C. An Erlangmeasures telephone traffic, or the flow of calls and call attempts to your
contact center during a given period. One Erlang equals one hour or 60 x 60 = 3,600 seconds of telephone
conversation. This could be one call lasting one hour, six calls lasting 10minutes, or any combination of calls
and call durations that equal 60minutes. The Erlang formulas provide amathematical basis for making
predictions about randomly arriving workloads.

A.K. Erlang, a Danish engineer who worked for the Copenhagen Telephone Company, developed Erlang C in
1917. Agent and delay calculations use the Erlang C equation. It predicts the resources required to keep delay
times within your Service Level objective. Three variables influence the delay time: the number of agents, the
number of waiting callers, and the average time it takes to handle each call.

Limitations of Erlang C
Erlang C has fundamental principles that do not reflect real-world circumstances. It assumes all of the calls
reach the contact center and all of the callers wait indefinitely to reach agents. Because Erlang C assumes no
blocking or abandons, it may overestimate the agents you need. Erlang C requires accurate information on
call flow where voicemessaging and call overflow are employed, assumes your Call Load prediction is
extremely accurate, and assumes you have the same number of agents handling calls the entire half hour.

Although Erlang C has its limitations, it is the preferred planning tool as it provides reasonable traffic
estimates for contact centers that maintain good service-minimal blocking and few abandons.

Considerations when predicting resource requirements
Erlang C provides theoretical numbers for staffing that you need to assess in light of the following contact
center realities:

l The contact center blocks a certain proportion of calls and some callers abandon their calls.
l Talk time is unpredictable, and althoughmost calls may last two to threeminutes, a few calls can last

upwards of an hour.
l Agents in trainingmay require more time to process calls.
l Agents may use wrap up (after-call paperwork) time inconsistently during busy periods.
l Not all of the agents within an agent group are available at all times to handle calls offered to the agent

group.

Erlang C predicts staffing needs fairly accurately. However, contact centers that use skills-based routing,
overflow, interflow, and advanced routing options need to use intuition and experience in adjusting the final
numbers.

The Erlang C formula uses your historical Call Load and Average Talk Time data to predict the agent
requirement for the time interval and date range in the forecast. The resultant spreadsheet displays the Call
Load and agents required across time intervals.
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Performing “what-if” scenarios
After you run a forecast, you can perform “what-if” scenarios on the resultant data by changing the value of
forecast parameters and recalculating the results. You can enter values for the ACD Calls Offered, average
ACD Handling Time, Wrap Up Time, and Service Level Percent and Time and recalculate the number of
agents required. For example, you can reduce the average handling time and recalculate the agents required
and the calls handled across 15-minute time intervals for the shift.

Understanding the relationship between agents and trunks
You are already familiar with the terms GOS (probability of blockage) and Service Level (average wait time).

The following definitions are essential to understanding the relationship between agents and trunks.

Delay
Trunk calculations assume no queueing. For trunk calculations, the delay includes the time from when a trunk
picks up a call until an agent answers it.

Agent Load
TheAgent Load includes the ACD Handling Time andWrap Up Time.

Trunk Load
The Trunk Load includes the time from when a trunk picks up a call until the agent finishes speaking to the
caller and disconnects. The Trunk Load does not includeWrap Up Time.

Callers expect to have a 95 percent or better chance of obtaining a free trunk in to your contact center, and
expect to connect to an agent within a reasonable amount of time. Theremust be sufficient trunks available to
pick up calls, and sufficient agents available to handle the level of traffic carried by the trunks. Themore
agents handling a given Call Load, the less delay callers’ experience. Callers experience a delay if there are
insufficient agents available. If the delay is considerable, calls back up and some calls do not reach the
contact center.

Traffic engineering involves estimating the number of trunks and amount of communications equipment
needed to service an anticipated number of callers. It revolves around basic questions concerning the
relationships between service parameters and trunk and agent resources. How much traffic can a particular
number of trunks handle for a particular GOS?What is the GOS for a particular number of trunks and traffic
level? How many trunks are required to handle a particular traffic level andGOS?What is the probability of
delay and length of delay experienced for a particular traffic level and number of agents? How many agents
are required to handle a particular traffic level for a given set of delay characteristics?

Understanding Erlang B
Contact centers use the Erlang B equation to estimate the number of trunks required. Erlang B assumes calls
are not queued and that callers who receive a busy signal do not attempt to call again. It can underestimate
the trunks required. One Erlang equals one hour or 60 x 60 = 3,600 seconds of telephone conversation.

Predicting your trunk requirement involves
l Determining your Busy Hour Traffic (BHT)
l Deciding how many blocked calls you can tolerate, or Grade of Service (GOS)
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BHT
TheBusy Hour Traffic (BHT) statistic, measured in Erlangs, is the number of hours of call traffic (or trunk
traffic) you experience during the busiest hour of operation. It is important that your busy hour figure represent
the busiest Call Load your trunks will ever receive, and not just today’s peak traffic. BHT is the (average call
duration + average delay) x calls per hour ÷ 3600. This value represents the highest Trunk Load (occupancy) in
hours.

The call center traffic is the average number of trunks busy during the hour in question. One Erlang equals one
hour, or 60 x 60 = 3,600 seconds of telephone conversation. If a contact center experiences 6.12 erlangs (or
6.12 hours of telephone conversation) during an hour, an average of six trunks were busy.

GOS
TheGrade of Service (GOS) value is a decimal fraction. A GOS of P.02means a caller has a two percent
chance of receiving a busy signal. Contact centers useGOS in calculating the number of trunks required. It is
important to specify a GOS that is right for you in order for the trunk calculation to be realistic.

Predicting trunk requirements
The number of trunks you require reflects the level of traffic expected during your busiest hour of operation.
The busy hour is the hour during the workday in which a trunk group carries themost traffic. You calculate the
Trunk Load after you forecast the Call Load for the busiest hour and determine the number of agents required
to handle the Call Load for your Service Level objective.

Traffic calculators used to predict contact center resource requirements are available on theWeb from
companies such as erlang.com. You can obtain basic calculators at no cost. Calculators that display and print
results or calculations made during the previous week are available at amodest cost.

To calculate the trunks required you simply input two of the figures and calculate the third. For example, if you
know that your Busy Hour Traffic is 10 erlangs and you want to determine how many trunks are required when
two calls are blocked in every 100 call attempts, you input the busy hour time (10) and your target rate of
blocking (0.02). The calculator displays a value for the trunks required (17).

Figure 3 - 3 illustrates the trunks required across a spectrum of GOS values. Whether you chose aGOS of
0.01, 0.05, or somewhere in between these values reflects how may calls per 100 call attempts you can afford
to lose. In revenue-based contact centers minimal blocking and delay is a priority.
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Figure 3 - 3 Estimating the trunk requirement

Although some contact centers base the trunk requirement on a staff-to-trunk ratio, such as 1.5 trunks per
agent, many use the Erlang B equation. Whatever ratio results will be the right one for you.

It is better to slightly overestimate than slightly underestimate the number of trunks required: trunks are
inexpensive, compared to agent costs. You can always cancel a trunk if periodic Trunk Load calculations
show low occupancy on the trunk.

No staffing approach is absolute. You need to acknowledge the assumptions implicit in your calculations and
use common sense when estimating your resource requirements. When you schedule resources, they must
be closely monitored to ensure you aremaking full use of them.

Step #5 Schedule agents
Scheduling involves accurately forecasting the workload and determining which agents should work which
shifts. This has traditionally been a labor-intensivemanual process for contact center supervisors. You can
schedule agents for breaks, split shifts, ACD and non-ACD work periods, repeating work patterns, holidays,
and on call work. You can categorize agents by pay level, overtime eligibility, skill level, employment status
(part time or full time), and scheduling preferences. Matching these shift and agent variables to the anticipated
workload, and re-allocating agents in response to employee absenteeism can be a daunting task.

Scheduling is becoming increasingly challenging, as contact centers support a wider range of products and
services, and agents require more frequent and specialized training. Advances in technology have automated
many agent tasks and have resulted in more varied and challenging calls and responsibilities.

Accurately forecasting and building schedules that reflect the workload as it changes across intervals for days
of the week, weeks of themonth, and seasons of the year is essential in meeting your service objectives. You
need a schedule that accurately matches agents to the anticipated workload and agents who aspire to adhere
to the activities scheduled.
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You can track the availability and activities of agents throughout the day and verify agents are performing the
duties for which they are scheduled. Not adhering to the schedule, such as forgetting to log out for a break, or
performing non-ACD work when scheduled to perform ACD work adversely affects your Service Level and
themoral of other agents whomust compensate for the unavailable agent.

Understanding the Shrinkage Factor
Accurately forecasting the workload and scheduling agents to satisfy your Service Level objective is a good
start, but does not account for the activities that prevent agents from sitting at their desks and handling
telephones.

Agents scheduled for ACD work can be involved in some of the following activities:
l On a bathroom break
l Making or receiving personal calls
l Conferring with the supervisor or another agent
l On the phone with other departments
l Sending emails or faxes
l Involved in a lengthy, difficult call
l Prolonged in after-call work
l Absent due to illness or compassionate leave

To account for short-term or daily unscheduled absences, you can calculate the rostered staff factor
(Shrinkage Factor). TheShrinkage Factor is a numerical value that defines the percentage of time agents are
scheduled to work but are unavailable to handle calls. It tells you the number of agents youmust schedule in
addition to the base number of agents required tomeet your Service Level.

Calculating the Shrinkage Factor
You calculate the Shrinkage Factor for one or more agent groups as follows:
 1. Determine the base staff forecasted by hour or half hour for the day.
 2. Make a list of activities that prevent ACD agents from handling calls.
 3. Add the base staff to the number of agents who are unavailable to handle calls because they are absent,

on break, at a unanticipatedmeeting, etcetera.
 4. Calculate the Shrinkage Factor for each time interval by dividing the scheduled staff by the base staff

required to handle telephones.
The result is a set of Shrinkage Factors that represent the expected shrinkage by half hour.
See Figure 3 - 4.
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Figure 3 - 4 Calculating the Shrinkage Factor

Youmultiply shrinkage values against the base staff required on telephones when setting future schedules. If
your agent requirements vary considerably on certain days of the week, you can calculate a separate set of
Shrinkage Factors for these days. Youmust use your good judgement in identifying absences that are
relevant to include in your Shrinkage Factor calculations. Anticipating higher absenteeism on Fridays and
Mondays is a safe bet while factoring in daily compassionate leave is not. As with all of the steps in contact
center planning, routinely assess the accuracy of your shrinkage predictions and adjust them as required.

Optimizing schedules
Now that you have adjusted your agent requirement to account for unanticipated absences, the next step is to
design a schedule that makes themost of your resources.

The following examples illustrate ways to adequately staff a contact center without having agents sit idle
during slower periods.

Scheduling split shifts
Although not everyone likes to take a long break in themiddle of a shift, for some agents split shifts fit well
with priorities outside of work. For contact centers that experience heavy call traffic in themorning and
evening, split shifts prevent overstaffing during these periods.

Staggering shifts
Staggering shifts allows you tomaintain staffing levels over busy periods or periods when agents are on
breaks. For example, one set of agents could start at 8:00 A.M., a second group at 9:00 A.M., and a third
group at 10:00 A.M. so the contact center is fully staffed when it starts getting busy midmorning. Alternately,
you could schedulemorning and afternoon shifts that overlap from noon until 1:00 P.M. to enable themorning
shift to break for lunch while the afternoon shift handles calls.

Staggering breaks
Making slight adjustments to the timing of morning, lunch, and afternoon breaks has a tremendous effect on
call handling. The Erlang C equation predicts 28 agents can handle 300 calls, each lasting 280 seconds and
delayed 20 seconds. (See Figure 3-5.)
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Figure 3-5 illustrates that changing the availability by one agent decreases the average delay time by five
seconds, and allows the contact center to handle 16 additional calls.

Figure 3 - 5 Staggering breaks to optimize call handling

Forecasting non-ACD work
Not all of the non-ACD work must be performed immediately. For example, call-backs to clients, emails, and
discussions with staff and supervisors can sometimes wait until less busy periods. Forecast and schedule
non-ACD work for slow times to ensure sufficient agents are available during peak periods. Set availability
priorities and regularly communicate them to agents.

Scheduling part-time agents and agents on call
When practical, scheduling part-time agents and agents on call can be an effective strategy for topping up
your pool of available agents. Scheduling agents on call is particularly useful for days of the week and
seasons when absenteeism is noticeably higher.

Routing calls to optimize coverage
To optimize service, you can use the following routing strategies that involve resources outside of the target
agent group.

Overflowing calls to less busy agent groups
You can overflow calls from busy agent groups to less busy agent groups during peak periods. You can route
calls to agents who primarily perform non-ACD work but act as reinforcements during busy periods, and to
supervisors.

Employing call-back messaging
You can program the ACD to forward calls to voicemail so callers can leavemessages instead of waiting for
live agents. Call-back messaging helps to balance agent workloads between peak call periods and slow
periods.
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Contracting calls to customer care bureaus
Contracting calls is a growing industry. During peak periods, you can route simple, routine calls externally to
customer care bureaus. Service bureaus collaborate with contact centers to set up scheduling andmonitoring
practices, and train agents to handle calls that vary in complexity.

Employing ACD enterprise call routing
Contact centers that provide extended, or around-the-clock service, can interflow calls to other sites. For
example, you can interflow mid-day calls received by a busy center in San Francisco to agents working the
late-afternoon shift at a center in Philadelphia. This optimizes call handling without scheduling additional
agents.

Scheduling considerations
Scheduling should be a collaborative effort. Agents have schedule preferences, and want to know when they
are working well in advance. Agents aremore likely to adhere to schedules if they are involved in defining the
conditions of schedule adherence and non-adherence, and in other areas of the planning process.

Producing long-term schedules is less efficient than producingmonthly schedules, as contact center
conditions and agent availability are continually changing. Short-term scheduling is more accurate, but less
popular with agents. It is important to find a good balance.

Measuring scheduling accuracy
You canmeasure the effectiveness of your scheduling process. Create a line graph of the Service Level for
each half-hour interval for each day over the past week. Draw a horizontal line across the graph to indicate
your service objective. Look for inconsistencies in the service provided for different time intervals across
days, and how far you stray from your service objective.

If the Service Level is erratic, youmay have enough resources in place, but they may not be consistently
available to handle calls. If the Service Level is inconsistent at certain time intervals across the week, or you
are not meeting your Service Level objective, investigate to see if you are adequately staffed at these times
and aremaking the best use of resources. Try to assess how consistently the agents are responding to real-
time information displays. Determine if they are restricting non-ACD activities to slow periods and adhering to
the schedule.

Scheduling agents with workforce management tools
Workforcemanagement tools assist you in scheduling agents for work and holiday periods. Many packages
offer an integrated forecasting component that uses historical data to partially automate the scheduling
process for established agents. Scheduling is not entirely automated: youmust tweak agent schedules and
enter shift and agent variables for agents manually.

Step #6 Determine contact center costs
An effective budget conveys what is currently happening in the contact center, projections for the upcoming
year, and business objectives. It is important to highlight the trade-offs between the service provided to callers
and costs to the organization by developing at least two budgets that reflect different scenarios.

You need to provide a clear indication of how themoney is being spent, what you are doing to reduce or curb
spending, and what equipment is required tomeet service objectives and expected growth over the next year.
Budgeting is on-going process that needs continuous refinement.
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Breaking down expenses
The costs associated with contact center operations include

l Loaded labor costs
Loaded labor costs include wages, fringe benefits, and facilities, and account for over 60 percent of
contact center costs. This is a significant cost and underlines the importance of accurate forecasting
and scheduling.

l Equipment and automation costs
Equipment and automation costs include the cost of the telephone system, computer systems, and
furniture, and account for about five percent of total expenses.

l Transmission costs
Transmission costs include costs incurred for voice (telephone lines) and data (email, fax, andmodem)
transmission, and account for 25 to 30 percent of contact center costs. Transmission costs have
decreased considerably in the past few years and are continuing to drop. In revenue-based contact
centers, toll-free lines cost approximately 15 cents per minute, or nine dollars per hour, per line.

The following statistics help you breakdown and analyze your contact center costs:
l Cost of Delay

When insufficient agents are available to handle a given Call Load, the delay increases as does the
Trunk Load. Calls are queued. For toll-free services each call delayed in queue is a cost to the
organization. You are charged for the toll-free service from the time a trunk picks up a call until an agent
completes the call and hangs up. The expense of queuing callers is known as theCost of Delay.
Staffing affects toll-free service costs: if insufficient agents are available and the Service Level is
continually low, network costs will be high. You need to consider the Cost of Delay when estimating the
agent requirement, and closely monitor it.

l Cost per Call
You use a cost-per-call analysis to measure contact center profitability and performance. The cost per
callmeasures labor, communication, and equipment costs against the revenue generated. You
calculate it by dividing the total cost by the total calls for a particular period of time.

l Average Call Value
You use theAverage Call Value in revenue-based contact centers. You calculate it by dividing the total
revenue by the number of calls received for a given period. Sales and reservations environments use
the Average Call Value. The value of each call is balanced against the service provided to customers.

Anticipating growth
Predicting company growth is a challenging and essential aspect of contact center costing. Growth
predictions impact budgeting considerations andmust be clearly communicated to senior management. It is
useful to map out your projected costs and time frames for the upcoming year and substantiate them with
statistics and graphs. Determine when and how many resources you require, and lead-time issues.
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Getting Started
After you install Contact Center Management on the Enterprise Server, youmust set up the Enterprise Server
and client computers to use Contact Center Management. This section provides basic information on post-
installation procedures. For detailed information on installation and post-installation procedures, see the
Contact Center Management Installation Guide.

Registering Contact Center Management
NOTE:

l If you have not registered your Contact Center Management software, seven days after you install it
you will no longer be able to log on to Contact Center Management and will be required to contact
prairieFyre software to register the software. After you register your contact center prairieFyre emails
permanent license files to you. You implement these license files on the Enterprise Server to activate
your software.

l Registration information is processed during regular business hours only (Monday to Friday from 8:00
A.M. to 8:00 P.M. ET).

When you initially register your software with prairieFyre, for one year you receive
l The latest Contact Center Management software updates.
l A quarterly newsletter.
l Free technical support.

To register with prairieFyre
l Call prairieFyre at (613)-599-0045 (North American customers) or your approvedMitel vendor (for

customers residing in Latin America, Europe, theMiddle East, Africa, and Asia Pacific).. The turn
around is immediate. (Recommended)

l Visit the www.prairiefyre.com website, fill out a registration form, and submit the form. The turn around
time is four hours.

l In Contact Center Management, click Help=>Register Now, fill out a registration form, and submit,
email, or courier the form to prairieFyre.

Activating Contact Center Management
If you did not activate Contact Center Management during installation, you can activate it now. If you have
access to the Internet, you can rerun the InstallationWizard at any time to register Contact Center
Management online. If you do not have access to the Internet or if you cannot access our license server, you
can register offline.

To activate the Contact Center Managementsoftware online
 1. On the Enterprise Server, navigate to theMitel program folder and openMitel Contact Center

Management Licensing.
 2. Click Register Online.

TheOnline Registration window opens.
 3. Type your 26-digit site serial number and click Register.
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To activate the Contact Center Management software
 1. On the Enterprise Server, navigate to theMitel program folder and openMitel Contact Center

Management Licensing.
 2. Click Register Offline.

TheOffline Registration window opens.
 3. Click the here link in the first step to open the directory that contains the license package.
 4. Email the license package to support@prairiefyre.com.

prairieFyre will sign the license files and send them back to you.
 5. After you receive the signed license files, save them to a directory.

NOTE:We recommend you place the license files in the original directory.
 6. Repeat steps 1-2 to open theOffline registration window.
 7. Type your 26-digit site serial number.
 8. Click Browse and specify the directory that contains your .dlsc license file.
 9. Click Apply License.

The license registration is complete.

Updating license files on the Enterprise Server
Youmust update the license files on your Enterprise Server with the new license files prairieFyre sends you.

To implement new license files
 1. On the Enterprise Server, start Windows Explorer.
 2. Save the new license files in the following directory, <drive>:\program files\prairiefyre

software\CCM.
 3. Click Yes to overwrite the existing files.

Setting up Contact Center Management on the
Enterprise Server
After you install the Contact Center Management software on the Enterprise Server, you need to set up the
server and client computers to use Contact Center Management. To view detailed installation procedures,
click Help=>Documentation and click theContact Center ManagementInstallation Guide to open it.

Setting up Contact Center Management on client
computers
NOTE:

l The date format for Contact Center Management is tied to the regional settings on your client computer.
For example, if you configure your computer to display the date as mm/dd/yyyy, when you browse to
the Contact Center Management WebUI, the Contact Center Management applications and any
reports you generate display the date as mm/dd/yyyy.

l The system administrator must provide all of the Contact Center Management users with a user name
and password.

To set up a client computer to use Contact Center Managementon the client computer
 1. Start Contact Center Management.

See "Starting Contact Center Management" on page 37.
 2. Install Client Component Pack.
 3. Use Client Role Selector to select your Contact Center Client role.
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Starting Contact Center Management
To start Contact Center Management on the Enterprise Server or on a client computer
 1. Start Internet Explorer type your Enterprise Server IP address http://[your Enterprise Server IP

address]/CCMWeb/. Otherwise, click the Contact Center Management desktop icon.
 2. If you do not see the Contact Center Management desktop icon, to create a shortcut to Contact Center

Management, move the Contact Center Management Web address to your desktop using a drag-and-
drop operation.

Viewing multiple Contact Center Management sessions
Sometimes you will need to view two or more instances of Contact Center Management simultaneously. For
example, you need to open two or more Contact Center Management sessions to perform multiple searches
for event records, and to compare report data to SMDR search results.

To view multiple Contact Center Management sessions using Favorites
 1. Start Internet Explorer and type your Enterprise Server IP address http://[your Enterprise Server IP

address]/CCMWeb/. Otherwise, click theContact Center Management desktop icon.
 2. Click Favorites=>Add to Favorites to add the Enterprise Server IP address to your list of favorite

addresses.
 3. Click OK.
 4. Click Favorites, click Contact Center Management (at the bottom of the list), andmove it to the top of

the list using a drag-and-drop operation.
 5. To start an additional Contact Center Management session, open Internet Explorer and select Contact

Center Management from your list of favorites.
You start the first instance of Contact Center Management by clicking the Contact Center Management
desktop icon. You start the second (and subsequent) sessions of Contact Center Management by
opening Internet Explorer, clicking Favorites, and clicking Contact Center Management.

NOTE: You can switch between Contact Center Management sessions and desktop applications by holding
down the Alt key and pressing the Tab key until you locate the desired session.

Installing the latest version of Client Component Pack
Microsoft .NET Framework 4.0must be installed on your system before you install Client Component Pack. If
you attempt to install Client Component Pack, and .NET Framework is not installed, Client Component Pack
will prompt you to install a list of required components, including .NET Framework.

You can install Client Component Pack on individual client computers or servers running Citrix Terminal
Services.

NOTE: If the client is on an external network, you can either:
l VPN to the internal network and install the Contact Center Client, or
l Copy the Contact Center Client from the server to the client using a CD or USB key
l Use an administrative procedure to silently install Client Component Pack on remote desktops

See "Installing Client Component Pack using an administrative procedure" on page 38.
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To install Client Component Pack on the client computer
 1. On the client computer, start Internet Explorer and type http://[your Enterprise Server IP

address]/CCMWeb.
 2. If prompted, type your user name and password and click Submit.
 3. Click Help=>Software downloads/Installations.
 4. Click Client Component Pack.

The File Download - Security Warning window opens.
 5. Click Run.
 6. Close the Software downloads window.

The Internet Explorer - Security Warning window opens.
 7. Click Run.

TheMitel Contact Center Solutions Client Component Pack Se... window opens.
 8. To install Updater Service Clean Up, click Install.

TheMitel Contact Center Solutions Client Component Pack - InstallShieldWizard opens.
 9. Click Next.
 10. AfterEnterprise IP Address, type the IP address of the Enterprise Server.
 11. If your Enterprise uses SSL, select theSSL check box.
 12. Click Install.

The program features you selected are installed.
 13. Click Finish.

The Select role window opens.

Installing Client Component Pack using an administrative
procedure
You can install Client Component Pack silently on remote desktops using anMSI (Microsoft Installer)
administrative installation procedure. A silently installed program is a program that can be installed with no
user interaction.

To install client software silently on remote desktops
 1. Install the prerequisite software.
 2. Locate the client_setup_x86_x64.exe and extract Client Component Pack.msi.
 3. Perform the .msi procedure for the administrative installation.
 4. Run the silent installations.

Installing the prerequisite software
Before you install client software, youmust install the prerequisite software.

To install the prerequisite software
 1. Go to the src folder located in your Contact Center Solutions Installation folder.

NOTE: The default location of this folder is C:\CCM\src.
 2. Open theWindows Installer 3_1 folder.
 3. InstallWindows Installer 3.1.
 4. Go back to the src folder.
 5. Open the vcredist_x86 folder.
 6. Install vcredist_x86.
 7. Log onto your Contact Center Management Enterprise Server.
 8. Click Help.
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 9. Click on the Software downloads/Installations tab.
 10. Click Software Downloads.
 11. Install the following components:

l Microsoft .NET Framework 4.0.
l WebServices Enhancements (WSE) 3.0 for Microsoft .NET.
l Microsoft Report View Redistributable 2005.

Locating the client_setup_x86_x63.exe and extracting Client Component
Pack.msi
To locate the client_setup_x86_x64.exe and extract Client Component Pack.msi
 1. Go to the src folder located in your Contact Center Solutions Installation folder.

NOTE: The default location of this folder is C:\CCM\src.
 2. Open client_setup_x86_x64.exe.
 3. Open the folder that was modified the same day you extracted client_setup.exe. The folder naming

format will be xxx_xxxx.
Client Component Pack.msi will be in that folder.

Performing the MSI procedure for the administrative installation
NOTE:See "Installing the prerequisite software" on page 38 for a list of programs that must be installed on
each computer before you install Client Component Pack.

Youmust create a command for the administrative installation that is similar to the following example:
msiexec /a”\\Mitel Installations\Setup\Client Component Pack.msi” SSLSTATUS=0
ENTERPRISEIPADDRESS=10.1.4.12

To perform theMSI procedure for the silent installation
 1. Open the command prompt window.
 2. Open the folder where themsi file is located.
 3. TypeMsiExec.exe /a.
 4. Press the spacebar.
 5. Drag themsi file from the folder where it is located to the command prompt window.
 6. Press the spacebar.
 7. TypeSSLSTATUS=.
 8. If the Enterprise Server uses a secure socket layer, type 1. If it does not, type 0.
 9. Press the spacebar.
 10. TypeENTERPRISEIPADDRESS=.
 11. Type the Enterprise Server IP address or DNS name.
 12. Press Enter.

The InstallShieldWizard opens.
 13. Follow the instructions of theWizard.
 14. Ensure the file is saved to a network drive.

Running the silent installation
NOTE:Subsequent updates are done via the prairieFyre Updater Service.

To silently install Client Component Pack
 1. InWindows, open theRun command.
 2. Type “\\<path to administrative installation package>\Client Component Pack.msi” /qb

Contact Center Client and the prairieFyre Updater Service are installed.
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Using the Client Role Selector to select your Contact Center
Client role
The Contact Center Management client installation includes the Client Role Selector. It is a wizard that helps
you select a Contact Center Client role based on the functions you perform. The roles are as follows:

l Supervisor is designed for supervisors andmanagers whomonitor devices (for example agents and
queues) and schedule agents.

l Agent is designed for agents whomonitor themselves and/or other agents and queues.
l Administrator is designed for employees whomanage the Enterprise Server.
l Power user is designed for employees whomay perform the functions of a supervisor, agent, and

administrator.

You can re-run the Client Role Selector on a client computer at any time to change the components and
applications installed on the client computer.

NOTE:
l If you want to customize the client installation, select Power User. For example, if a supervisor also

performs administrative functions, select the Power User role and choose the components and
applications the supervisor will need.

l For Version 6.0.1 and greater of Contact Center Solutions support for the 5000 and Axxess telephone
systems, client applications are limited to Real-timemonitors, Management Console, Network Monitor,
Multimedia Contact Center, and YourSite Explorer. All other client applications will bemade available in
a future release of Contact Center Solutions.

Table 4 - 1 lists the components and applications available for installation with each client role installation.
Only those applications for which you have a license are listed here.
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Table 4 - 1 Client role installation

Components/Applications Supervisor Agent Administrator Power
User

Real-timemonitors x x x

Flexible Reporting*1 x x

Contact Center Softphone*1/2 x x x

Mitel Border Gateway Connector*1/2 x x x x

Management Console x x

Network Monitor x x

Salesforce.com Connector*1/2 x x x x

Workforce Scheduling*1 x x

Schedule Adherence1 x x x x

Employee Portal*1 x x x x

Multimedia Contact Center*1

(requires Outlook)

x x

YourSite Explorer x x

*1Flexible Reporting, Contact Center Softphone, Mitel Border Gateway Connector, Salesforce.com
Connector, Workforce Scheduling, Employee Portal, andMultimedia Contact Center are optional applications
to Contact Center Management that you purchase separately.
*2Contact Center Softphone, Mitel Border Gateway Connector, and Salesforce.com Connector are not
currently supported with theMitel 5000 and Axxess telephone systems.

Running Client Role Selector
To run Client Role Selector:

 1. If you are installing software on the client computer for the first time, go to step 2. Otherwise, open the
Client Role Selector.

 2. Click a client role.
 3. Click Next.
 4. Select the check boxes of the features to be installed.

l Real-timemonitors
l Flexible Reporting
l Contact Center Softphone
l Mitel Border Gateway Connector
l Management Console
l Network Monitor
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l Salesforce Integration
l Workforce Scheduling
l Multimedia Contact Center (requires Outlook)
l YourSite Explorer

 5. Click Finish.
After the wizard installs the features you selected, the Contact Center Client log on window opens.

 6. Close the Contact Center Client log on window.

Disabling the IE security warning
When you browse Contact Center Management, youmay see an Internet Explorer (IE) security warning. You
can disable the warning.

To disable the IE security warning
 1. Start Internet Explorer in your browser.
 2. Click Tools=>Internet Options=>Security.
 3. Select theWeb content zone used to access the site.

TheWeb contact zone is typically Internet.
 4. Click Custom Level.
 5. UnderSettings selectMiscellaneous.
 6. UnderMiscellaneous, afterDisplay mixed content, click Enable.
 7. Click OK.

Configuring the SMTP server
The SMTP mail server settings for Reporting Service are typically configured during the installation process.
However, if the server information is not entered during installation or the information is incorrect, the settings
can be configured in YourSite Explorer, as follows.

To configure an SMTP mail server
 1. In YourSite Explorer, click SMTP Servers.
 2. Click Add.
 3. UnderSMTP Server, type the IP address or name of themail server (for example, PFEXCHANGE).
 4. UnderSMTP Port, type the port number of the SMTP mail server.

NOTE: The default value of this port is 25.
 5. If theMail server uses Secure Sockets Layer, select theUse SSL check box.
 6. Under Logon Information, select the Is SMTP Authentication Required check box if the email

server requires authentication and type theUsername, Password, andDomain.
 7. UnderUser Information, type the name and email address from which all Contact Center Management

reports will bemailed.
NOTE: The email address field is mandatory as some email servers will not relay mail messages
without a valid sender.

 8. To send a test email, click the Test Email button.
 9. Click Save.
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Providing Mitel Border Gateway functionality to remote
employees
In Version 6.0, theMitel Border Gateway Connector replaces what was formerly called Teleworker support for
Contact Center Solutions and Call Accounting software. UsingMitel Border Gateway Version 7 or greater,
remote employees can connect to the Enterprise Server using a VPN-like connection, and use all Contact
 Center Solutions and Call Accounting applications as if they were in the office. Customers who useMitel
Border Gateway Version 6 can still benefit from remote agent support, however, only Contact Center Client
real time, soft phone, and Contact Center Management / Call Accounting website functionality is supported.

With theMitel Border Gateway Connector, customers can now optionally configure connections tomultiple
instances of theMitel Border Gateway. When employees connect to the system using theMitel Border
Gateway Connector, they can specify whichMitel Border Gateway they will connect to. After remote
employees attempt to connect to the system for the first time, aMitel Border Gateway system administrator
must approve theMitel Border Gateway certificate from theMitel Border Gateway web application. Once
approved, remote users are connected and have access to all of the Contact Center Solutions and Call
Accounting applications for which they are licensed and have the required security permissions. While active,
theMitel Border Gateway Connector is visible in theWindows system tray and displays the name of the
active connection. Only one connection can bemade at a time. The name of theMitel Border Gateway
connection will become the address in all application login windows and users sign in with their normal
username and password.

TheMitel Border Gateway Connector offers the same trusted characteristics as with a standardMitel Border
Gateway deployment: local streaming, secure RTP, jitter buffering and packet handling QoS, andG.729 and
G.711 encoding. For more information on how to configure Contact Center and Call Accounting software to
support Mitel Border Gateway, see theContact Center Management Installation Guide.

NOTE:
l TheMitel Border Gateway Connector supports Mitel Border Gateway V6 and V7 or greater.
l The following corporate firewall ports must be open in order to take advantage of the full features and

functionality provided by theMitel Border Gateway Connector: 80, 443, 1433, 5024, 5025, 5026, 5030,
7001, 7003, 8083, 8084, 36000-36004, 35001-35007, and 42440.

l Youmust disable IIS and SQL Server Reporting Service services as they consume port 80, which is
required for theMitel Border Gateway Connector. Any other applications or services that consume port
80 should also be disabled or shut down.

l You cannot use theWindows Authentication sign-in model for Contact Center Solutions and Call
 Accounting

l Ensure the Start button is enabled at all times on theMitel Border Gateway web application user
interface or theMitel Border Gateway Connector will fail.

l Youmust be logged in as an administrator on a client computer in order to configure a connection to a
Mitel Border Gateway. Once the connection has beenmade, any user on the computer can connect
using theMitel Border Gateway Connector.

Setting up phones for remote agents and employees
If you are working at the office and select Remembermy credentials when you log on to Contact Center
Client, and then subsequently attempt to log on at home, your log on will fail. Contact Center Client does not
recognize your office IP address when you log on remotely.
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NOTE:Before you set up the soft phone on your client computer, ensure your network administrator has
configured your soft phone as a 5020 IP phone on the telephone system.

To set up Contact Center Softphone and Contact Center PhoneSet Manager to support theMitel Border
Gateway Connector, youmust
 1. Register your phones for use with Mitel Border Gateway V6 or V7.
 2. Approve theMitel Border Gateway V6 or V7 certificate.
 3. Log in to client computers using an administrative account and set up the connection to theMitel Border

Gateway from theMitel Border Gateway Connector.

Registering phones for use with Mitel Border Gateway
The system administrator must register your phone before you can use theMitel Border Gateway Connector.
Contact Center PhoneSet Manager treats new extensions like new phones; each time you enter a new
extension youmust use the dial pad to type the password (provided by your system administrator) to register
the phone.

To register your phone with Mitel Border Gateway
 1. Ensure you have completed the steps listed under "ConfiguringMitel Border Gateway on theMitel

Application Server" in theContact Center Management Installation Guide and that you have added an
ICP to theMitel Border Gateway.

 2. On theMitel Border Gateway server, underApplications, click Mitel Border Gateway.
 3. On the Status tab, ensure that theMitel Border Gateway status is enabled. If it is not, afterStart or stop

MBG, click Start.
 4. Click Services=>MiNet Devices.
 5. Click Add a MiNet device.
 6. For Contact Center Softphone phones, afterDevice ID, type a1:21:00:00:xx:xx, where xx:xx is the

extension.
 7. For Contact Center PhoneSet Manager phones, afterDevice ID, type theMAC address located under

the agent’s Mitel phone.
 8. If required, specify other optional settings.
 9. Click Save.

Approving the Mitel Border Gateway certificate
TheMitel Border Gateway system administrator must approve theMitel Border Gateway V6 or 7 certificate
before agents and employees can use theMitel Border Gateway Connector.

To approve theMitel Border Gateway certificate
 1. Log on to theMitel Border Gateway server.
 2. In the left pane under Security, select Certificate Management.

TheManage Certificates window opens.
 3. UnderQueued CSRs, select the certificate that needs approval.
 4. Select Approve orRevoke.
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Running the Mitel Border Gateway Connector
In order to use Contact Center Solutions and Call Accounting applications with Mitel Border Gateway, you
must run theMitel Border Gateway Connector and configure the connection to theMitel Border Gateway.

NOTE:A user with administrative credentials must be logged in to client computers when configuring
connections to theMitel Border Gateway for the first time. After this is complete, any user can sign in to the
computer, run theMitel Border Gateway Connector, and connect to aMitel Border Gateway.

To install and configure theMitel Border Gateway Connector
 1. If this is not the first time you have run theMitel Border Gateway Connector, skip to step 9. Otherwise,

consult your network administrator to confirm your soft phone extension number.
 2. Ensure your headphone is connected.
 3. Run Client Component Pack.

See theContact Center Management Installation Guide.
 4. If you are installing software on the client computer for the first time, go to step 5. Otherwise, open the

Client Role Selector.
 5. Click a client role.

l Supervisor—The Supervisor role is for supervisors andmanagers whomonitor devices, such as
agents and queues, and schedule agents.

l Agent—The Agent role is for agents whomonitor themselves and/or other agents and queues.
l Power user—The Power user role is for employees whomay perform the functions of a

supervisor, agent, and administrator.
 6. Click Next.
 7. SelectMitel Border Gateway Connector and all other options you need, such as Contact Center

Softphone.
 8. Click Finish.
 9. InWindows, open theMitel Border Gateway Connector.

Ensure you are logged in to the computer with administrative credentials.
 10. Click New.
 11. AfterName, type a name for the connection to theMitel Border Gateway.
 12. After IP address, type the IP address of theMitel Border Gateway.
 13. AfterMAC address

l If you have a desk phone, type theMAC address located on the sticker under your desk phone.
l If you have a soft phone, click Extension, type your soft phone extension number, and click OK.

 14. If you are connecting to a pre-Version 7Mitel Border Gateway, enable the checkbox afterConnect to
legacy MBG (pre v7).

 15. Click OK.
The connection to theMitel Border Gateway you just created will display in theMitel Border Gateway
Connector list.
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To run the Mitel Border Gateway Connector
 1. Start theMitel Border Gateway Connector.
 2. Select a connection to aMitel Border Gateway from the list.
 3. Optionally, enable theConnect automatically checkbox.

Enabling this checkbox will automatically connect you to the configuredMitel Border Gateway when
you launch theMitel Border Gateway Connector.

 4. Click Connect.
A message displays stating "Waiting for certificate approval." If the request is rejected, contact your
system administrator to approve the certificate.
Once your certificate has been approved, you can begin using all Contact Center Solutions and Call
Accounting applications remotely as if you were in the office. Any user configured with administrative
credentials on the computer can change theMitel Border Gateway connection settings and delete
connections from theMitel Border Gateway Connector at any time.

Setting up user preferences
You can change your user preferences at any time. They can be found on the Contact Center Management
website, on theMy options link. With these preferences you can

l Specify your language preference
l Specify the number of records displayed on a page
l Change your password
l View your security role properties
l Configure email contacts

Specifying your language preference
To specify your language preference
 1. On theMy options tab, click My preferences.
 2. AfterDisplay this language, select a language.
 3. Click Save.

Specifying the number of records displayed on a page
Contact Center Management enables you to configure the number of items that will display in the
YourSite=>Configuration.

To specify the number of records that display on a page
 1. On theMy options tab, click My preferences.
 2. AfterDisplay this number of records, select a number.
 3. Click Save.

Changing your password
To change the password for your login
 1. On theMy options tab, click My password.
 2. AfterOld password, type your old password.
 3. AfterNew password, type your new password.
 4. AfterConfirm new password, type your new password.
 5. Click Save.
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Viewing security role properties
You can view your security role properties. They describe the application areas to which you can gain access.
Only employees with access to YourSite=>Configuration can change the security role properties of
employees.

To view the security role properties of the credentials with which you logged in
l Click My options=>My security role.

Configuring email contacts
You can create a list of email contacts and contact groups to whom you email reports.

NOTE: Youmust configure SMTP settings in YourSite Explorer before you can configure email contacts. See
"Configuring the SMTP server" on page 42.

To create a contact group
 1. Add email contacts
 2. Add contact groups
 3. Add email contacts to the groups

Adding email contacts
To add an email contact
 1. On theMy contacts tab, click My email contacts.
 2. Click Add.
 3. After First name, type the first name of your contact.
 4. After Last name, type the last name of your contact.
 5. AfterEmail address, type the email address of your contact.
 6. Click Save.

Adding contact groups
To add a contact group
 1. On theMy contacts tab, click My email contact groups.
 2. Click Add.
 3. AfterName, type the name of the contact group.
 4. AfterDescription, type the description of the contact group.
 5. Click Save.

Adding email contacts to contact groups
To add an email contact to a contact group
 1. On theMy contacts tab, click My email contact groups.
 2. Click Members for the contact group with which you want to associate agents.
 3. UnderAvailable contacts, select the check boxes of themembers you want to add to the group and

click Add >>.
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Chapter 5

Services and Database
Administration

Backing up data
Management Console
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Services and Database Administration
This chapter includes a description of how to back up data and of the functions available in Management
Console (updating server IP addresses, running themaintenance routine immediately, summarizing data,
creating a support package, controlling services, and converting Toolbox and Contact Center Solutions data
files to prairieFyre data files).

Backing up data
NOTE:We recommend you back up the SQL server data files, YourSite Database configuration data files,
and raw phone data files to an off-boardmedia type (DVD, CD, tape, alternate network drive) each day as a
precaution in case of server failure.

In the event of server failure, you can restore your company history and configuration with
l A backup copy of .xml files.
l A backup copy of the SQL server data files.
l A backup copy of the YourSite database.
l The raw telephone system data files stored on the local hard drive.

Backing up .xml files
Themaintenance routine automatically backs up an .xml file of the YourSite database every night. This
backup file is stored in the directory: <drive>:\program files\prairiefyre software inc\CCM\Backup Files. The
maintenance routine keeps an .xml file for each of the last 30 days maintenance ran.

To back up or restore the .xml files
 1. Start Contact Center Client.
 2. Click View=>Administration.
 3. Click Management.
 4. Click Configuration.
 5. Click Back up/Restore configuration data.
 6. Follow the steps in the Backup and RestoreWizard to back up or restore the .xml file.

Backing up SQL Server data files
You back up SQL Server data files to ensure you can replace corrupted or lost data as a result of media
problems, user errors, hardware failures, and natural disasters. Please review Microsoft procedure for creating
a recovery model that controls the backup and restores operations for a database. See
http://www.exforsys.com/tutorials/sql-server-2005/sql-server-backing.html

Understanding SQL Server recovery models
The following section details SQL Server recovery models and how they relate to backups and disk space
usage. There are three recovery models available for use with SQL Server:
 1. Simple
 2. Full
 3. Bulk logged

For detailed information on backing up SQL Server through SQL Server Management Studio, see
http://msdn.microsoft.com/en-us/library/ms187510.aspx.
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For a complete overview of SQL Server recovery models, see
http://msdn.microsoft.com/en-us/library/ms175987(SQL.90).aspx

By default, SQL Server Express uses the Simple recovery model. Retail versions of SQL Server use the Full
recovery model. There are two things youmust consider when deciding which recovery model to use:
 1. The importance of the data being stored in the SQL Server database.
 2. The amount of disk space used by the transaction log file.

The only way to recover a SQL Server database is to restore it from a SQL Server backup. The type of
recovery model you use impacts the ability to restore the database.

The Simple recovery model is recommended for customers who do not have an IT department upon which to
rely for regular backups and who believe the summarization process is sufficient to re-generate historical data.
There are several things that should be considered when using the Simple recovery model:

l The log file does not continually grow and is truncated each time a successful transaction is completed.
l When the log file is 80% full, the log will automatically clear out old transactions and rewrite the log file

with the newer transactions.
l Point-in-time recovery is not supported with this model and the database can be restored only from the

last full or differential backup.
l This model is ideal when the data in the database is not consideredmission critical, is being backed up

periodically, or can be restored from another means, such as summarization.

The Full recovery model is recommended for customers who have an IT department that canmanage
scheduled backups. There are several things that should be considered when using the Full recovery model:

l The log file will grow until a transaction log backup is successfully completed against the SQL Server
database. Transaction logs can be applied to full database backups to ensure point-in-time recovery, up
to the time when the last transaction log backup was taken.

l Point-in-time recovery is supported with this model
l This model requires a regular backup schedule and sufficient disk space to house the log file as it grows

between backups.

Frequency and scope of configuration changes may be a suitable indicator in determining which recovery
model to use. If configuration changes are infrequent and point-in-time recovery is not critical, the Simple
recovery model may be sufficient. However, when using the Simple recovery model, we highly recommend
that SQL Server backups are performed after any significant configuration changes have beenmade to the
database.

Regardless of the recovery model used, it is strongly recommended that the data files collected by the
Contact Center Solutions applications are backed up on a regular basis, as these files are used in the
summarization process to re-generate historical data.

Backing up Enterprise Server configuration data
CAUTION: Restoring the YourSite database deletes all of the current database table entries and replaces
them with the entries defined at the time of your last database backup. Any changes made to the database in
the interim are lost.

Backing up and restoring Enterprise Server configuration data offers protection in case you program the
database incorrectly, or a careless user reconfigures it. prairieFyre recommends you perform this backup
weekly, in addition to regular databasemaintenance. If required, you can later recover the YourSite database
data exclusively, rather than restoring the entire SQL database.
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To back up or restore the YourSite database
 1. Start Contact Center Client.
 2. Click View=>Administration.
 3. Click Management.
 4. Click Configuration.
 5. Click Back up/Restore configuration data.
 6. Follow the steps in the Backup and RestoreWizard to back up or restore the database.

For any additional information contact prairieFyre Software technical support at 613-599-0045 (North
American customers) or your approvedMitel vendor (for customers residing in Latin America, Europe, the
Middle East, Africa, and Asia Pacific).

Backing up raw telephone system data files
To back up raw telephone system data files
 1. On the Enterprise Server, right-click Start=>Explore.
 2. Copy the <drive>:\program files\prairiefyre software inc\CCM\DataDirectory folder to the desktop,

a network share, or optionally store it on a CD.

Management Console
TheManagement Console application resides in Contact Center Client. UsingManagement Console, you can
administer the database, perform maintenance functions, create support packages, and update your Contact
Center Management software.

Management Console consists of the followingmenus:
l Configuration
l Maintenance
l Support
l System

Opening Management Console
Management Console is available to users whose security permissions permit them to useManagement
Console.

To openManagement Console
 1. OpenContact Center Client.
 2. If prompted, type your user name and password.
 3. Verify the Enterprise Server IP address.
 4. Click Log on.

The Contact Center Client window opens.
 5. Click Tools in the ribbon.
 6. Click theManagement Console icon.

TheManagement Console window opens.
See Figure 5 - 1.
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Figure 5 - 1 Management Console

 7. Access the Configuration, Maintenance, Support, and System options by clicking on the applicable icon
in the window.

NOTE:Whether Management Console displays and is available depends on individual user's security
settings.

Configuration
The Configurationmenu enables you to update the server IP address.

Updating server IP addresses
If you want to apply Enterprise Server or SQLDatabase Server IP address changes to all Contact Center
Solutions applications, you use the Update Server IP Address Wizard.

To apply the IP address change to all Contact Center Solutions applications
 1. In Management Console, click Configuration.
 2. Click Update server IP address.
 3. Follow the steps in the wizard to apply the IP address change universally.



Contact Center Solutions User Guide

- 53 -

Maintenance
Using theMaintenancemenu, you can

l Run themaintenance routine
l Summarize data

Running the maintenance routine immediately
Contact Center Management runs the prairieFyreMaintenance Service automatically at 2:00 A.M. However,
you canmanually invoke the prairieFyreMaintenance Service at any time with the Runmaintenance
command.

To run themaintenance routine
 1. In Management Console, click Maintenance.
 2. Click Run maintenance.

A message notifies you that processing is complete.

Summarizing data
The Summarize DataWizard uploads historical telephone system data to the SQL database for a specific
date range.

If you run a report and notice that data for a particular device is missing from the report output, verify the
device is programmed in the telephone system and in the YourSite database. If you determine the device is
missing from the database, add it to the database and use the Summarize command to update Collector
Service and the SQL database with the complete raw telephone system data (stored on the local hard drive).
You can then produce reports on the device.

NOTE:
l When a summarize is performed the devices not programmed in the telephone system or YourSite

database are identified and logged to an XML file located in the Logs directory. The files are named as in
the following example, summarizeInspection[29-01-2007][29-01-2007][29-01-2007].xml, where the first
date is the current date, the second is the start date of the summarize, and the third is the end date of
the summarize.

l If you attempt to summarize data and there is no data for that date an error opens. Please select
another date.

To summarize data
 1. In Management Console, click Maintenance.
 2. Click Summarize data.
 3. Follow the steps in the Summarize DataWizard to summarize the data.

Support
Using the Support menu, you can

l Create an Enterprise Server support package
l Create a client support package
l View contact information
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Creating an Enterprise Server support package
You can package your Enterprise Server telephone system records and YourSite configuration data to send to
prairieFyre for troubleshooting issues using the Support PackageWizard. The Support package formats your
data in a way that helps to resolve any problems.

To create an Enterprise Server support package
 1. In Management Console, click Support.
 2. Click Create support package.
 3. Follow the steps in the Support PackageWizard to package your telephone system records and

YourSite configuration data.
 4. Click Finish.

Creating a client support package
You can package your client configuration data to send to prairieFyre for troubleshooting issues using the
Client Support PackageWizard. The Client Support PackageWizard formats your data in a way that helps to
resolve any problems.

To create a client support package
 1. Browse to http://www.prairiefyre.com/wp-content/rscs/cspwizard.
 2. Click Install.
 3. Click Install.

The Client Support PackageWizard opens.
 4. Follow the steps in the Client Support PackageWizard to package your client configuration data.
 5. Click Finish.

Viewing contact information
Should you need to contact prairieFyre Software for support, contact information is provided inManagement
Console.

To view contact information
 1. In Management Console, click Support.
 2. Click View contact information.
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System
Using the Systemmenu, you can

l Control services
l Convert data files

Controlling services
Services Manager controls all Contact Center Management services andmandatory system services. These
include the prairieFyre Collector Service (v5), DataService, prairieFyre .NET Enterprise Server,
MTCEService, prairieFyre Report Writer (v5), prairieFyre Reporting Service, prairieFyre SQLWriter,
AuditorServer, ForecastingServer, WallboardServer, CCSServer, MitaiProxy, MCCExchangeObjects,
MCCExchangeSetup, and IIS Admin.

To control services
 1. In Management Console, click System.
 2. Click Services Manager.
 3. Select the service you want to control.
 4. Right-click the service.

The right-click menu opens. This enables you to control the service the following ways:
l Start
l Stop
l Pause
l Resume
l Restart
l Refresh
l Restart All Running Services

 5. Select the action you want to perform.

Converting data files
The Data file conversion tool enables you to convert Toolbox data files to prairieFyre data files. This enables
you to restore all historical data from competitor products when changing your contact center solution to
Contact Center Solutions.

To convert data files
 1. In Management Console, click System.
 2. Click Data file conversion tool.

The Data file conversion tool opens.
 3. Select amedia server from the list.
 4. Click Browse and specify the location of the data files to be converted.

NOTE: The pathmust be accessible from the server. We recommend you use a Universal Naming
Convention (UNC) share.

 5. Click Next.
The data file conversion will then process.

 6. Click Finish to complete the data file conversion.
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Converting Callview and Contact Center Suite data
If you were previously using an Inter-Tel telephone system with Contact Center Suite/Callview and Toolbox
software, you can convert historic data to Contact Center Solutions format and create a historical media
server so you can retain data for reporting purposes.

Historical media servers enable
l Historical reporting for queues, agents, and extensions
l Forecasting
l ACD and SMDR Inspector functionality
l Auditor functionality

Inter-Tel summary-based options, such as service level and spectrum values, can bemodified in YourSite
Explorer. Summarize is performed on an on-demand basis fromManagement Console in Contact Center
Client. Historical media servers have no real-time functionality. All devices associated with historical media
servers are historical by default and can not be edited or used to collect any new data.

NOTE:
l In order to convert Callview or Contact Center Suite data to Contact Center Solutions and Call

Accounting format, the Callview and Contact Center Suite databasemust be Version 3.x or 4.x.
l The conversion tool requires the following files: System.mdw, config.mdb, and one or any combination

of the following: Ha<MMYYYY>.mdb, Hc<MMYYYY>.mdb, Haday.mdb, Hcday.mdb, Hamonth.mdb,
Hcmonth.mdb. For version 4.11 or earlier, select cvgwcfg.mdb instead of config.mdb.

To convert Callview and Contact Center Suite data
 1. InWindows, open the Inter-Tel Import Tool.
 2. AfterAccess Databases, click Browse.
 3. Browse to the location of the files to convert.

The conversion tool requires the following files: System.mdw, config.mdb, and one or any combination
of the following: Ha<MMYYYY>.mdb, Hc<MMYYYY>.mdb, Haday.mdb, Hcday.mdb, Hamonth.mdb,
Hcmonth.mdb. For version 4.11 or earlier, select cvgwcfg.mdb instead of config.mdb.

 4. Click OK.
 5. AfterStart Date, select the start date of the data to import.
 6. AfterEnd Date, select the end date of the data to import.
 7. If you are upgrading from a 5000/Axxess telephone system to a 3300 ICP or SX-200 telephone system,

but want to retain historic Inter-Tel data for reporting purposes, click Create historic media server.
Otherwise, continue to step 9.
The Inter-Tel DatabaseMigration Tool will import the telephone system configuration information, such
as agents, extensions, and trunks, and associate it to the 5000/Axxess media server. It will also
convert all historic telephone system records to ACD and SMDR files.

 8. If you are upgrading to Contact Center Solutions or Call Accounting and continuing to use your
5000/Axxess telephone system, after Target to Import, select the Inter-Tel 5000/Axxess media to
associate the converted data with. Otherwise, continue to step 10.
NOTE: If you are upgrading to Contact Center Solutions or Call Accounting and continuing to use your
5000/Axxess telephone system, youmust run Synchronization before running the Inter-Tel Database
Migration Tool. See "Configuring the YourSite database using synchronization" on page 101.
The Inter-Tel DatabaseMigration Tool will not import configuration data because synchronization
provides amore accurate configuration. However, telephone system records will be converted
telephone system records to ACD/SMDR.
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 9. If you have remote 5000/Axxess telephone systems and use a CT Gateway, select Synchronized
system uses CT Gateway.
NOTE:Before you run the Inter-Tel DatabaseMigration Tool, youmust have created an Inter-Tel media
server for each of the telephone systems connected to the CT Gateway, selected This media server
belongs to a CT Gateway and provided the Gateway ID in YourSite Explorer. See "Adding
5000/Axxess media servers" on page 87.

 10. If you want to summarize the data immediately after the conversion, select Summarize upon
completion.

 11. Click Import.
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Chapter 6

Configuration

YourSite database application areas
YourSite Explorer
Enterprise setup
Addingmedia servers
NetworkMonitor alarms
YourSite database configuration
Configuring employee scheduling preferences
Configuring scheduling options
Business hour schedules
Monitoring and alarming subsystem
Security roles
Configuring work timer
Validating YourSite Explorer configuration
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Configuration
You configure Contact Center Management in the following order.
 1. In YourSite Explorer, under YourSite, set up your Enterprise structure by specifying Enterprise settings,

adding sites, and addingmedia servers to the sites.
See "Configuring enterprise settings" on page 71, "Adding sites" on page 72, and "Addingmedia
servers" on page 74.

 2. In Contact Center Client, in Network Monitor, specify the days and times that media server data alarms
will be activated.
See "Configuringmedia server alarms" on page 95.

 3. In YourSite Explorer, under YourSite, configure the YourSite database tomirror the information on your
telephone system. Add devices in the following order:
l Add employees
l Add one or more agent login IDs for each employee
l Add agent groups
l Associate the agent login IDs with agent groups
l Add queues
l Associate the agent groups with the queues for which they answer calls
If you intend to run reports on employee groups, queue groups, teams, extensions, extension groups,
trunks, trunk groups, DNIS numbers, Account Codes, ANI, Make Busy and DoNot Disturb Reason
Codes, phone numbers, or Intelligent Queue devices, youmust add these devices and device groups
as well.
See Figure 6 - 1.

 4. In YourSite Explorer, under YourSite=>Schedules, create schedules that specify the business hours of
your operation that will be used for media servers, queues, Network Monitor alarms, WallBoarder sign
plans, and Interactive Contact Center Queue control.
See "Creating schedules" on page 169.

 5. On the Contact Center Management website, under YourSite=>Security, restrict user access to
specific areas of the Contact Center Management website.
See "Security roles" on page 177.
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Figure 6 - 1 Contact Center Management YourSite database configuration flowchart



Contact Center Solutions User Guide

- 61 -

For themost part, configuration is done using YourSite Explorer, however, there are a few exceptions where
configuration is done in the Contact Center Management website. See Table 6 - 1 for a list of where
components are configured.

YourSite Explorer simplifies datamanagement by enabling you to configure and administer devices for
Contact Center Solutions and Call Accounting in one application.

YourSite Explorer streamlines configuration. For example, you can
l Select multiple devices and change their attributes in one step.
l View groupmembership information on the samewindow as the devices are listed.
l View multiple windows of devices simultaneously and tab between them.
l Edit in line in an extended grid.

If you have a 3300 ICP, 5000, or Axxess, you configuremedia servers, Network Monitor alarms, devices, and
business hour schedules and perform Synchronization in YourSite Explorer.

NOTE: If youmake configuration changes for the 3300 ICP, 5000, and Axxess using the Contact Center
Management website, your updates will not write back to the telephone system during Synchronization or
nightly maintenance.

If you have an SX-200, youmust configuremedia servers, Network Monitor alarms, devices, and business
hour schedules in the Contact Center Management website.

You addMultimedia Contact Center Email, Webchat, and Fax media servers to your site in YourSite Explorer.

Intelligent Queuemedia servers are added to your site in the Contact Center Management website.

The following table outlines what is configured in YourSite Explorer, the Contact Center Management
website, or both. (See Table 6 - 1.)
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Table 6 - 1 Configuration outline

Item Contact
Center

Management
website

YourSite
Explorer

Enterprise Settings x x

Sites x x

Security x

Adding 3300 ICP media servers x

Adding SX-200media servers x

Adding 5000 / Axxess media servers x

AddingMultimedia Contact Center Email, WebChat, and Fax
media servers

x

Adding Intelligent Queuemedia servers x

Call recording x

Network Monitor alarms x x

Business hour schedules x x

Agents, agent groups, and queues that you will synchronize
with/write back to the telephone system

x

Editing telephone system assignment forms (System Options,
SMDR Options, Class of Service, and Class of Restriction)

x

Quick Setup device configuration (employees, agents, extensions,
trunks, trunk groups, DNIS, account codes, make busy reason
codes, teams, and device groups)

NOTE:To achieve optimal results, use YourSite Explorer
exclusively for Quick Setup of devices.

x x

Quick Setup device configuration (extension divisions and account
code groups)

x

Quick Setup device configuration (queues) x

.csv file import device configuration x

Manual device configuration (ANI and Intelligent Queue devices) x
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Item Contact
Center

Management
website

YourSite
Explorer

Manual device configuration (account code groups, do not disturb
reason codes, extension divisions, phone numbers, and phone
number groups)

x

Manual device configuration (account codes, agents, agent
groups, DNIS, DNIS groups, employees, employee groups,
extensions, extension groups, make busy reason codes, queues,
queue groups, teams, trunks, trunk groups, and employee
divisions)

NOTE: To achieve optimal results, in accordance with the Contact
Center Solutions Version 6.0.1 Simplified Licensingmodel, use
YourSite Explorer exclusively to configure devices.

x x

Call Classification codes x

Contact CenterWork Timer x

Queue Spectrum settings x x

Interactive Contact Center queue control x

Multimedia Contact Center queue configuration x

Workforce Scheduling employees and schedule attributes x

Call Accounting extensions, trunks, and phone numbers x

Call Accounting location information x

Call Accounting Subscriber Services and Traffic Analysis
components

x
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YourSite database application areas
The YourSite database includes five application areas, Youmust set them up in the following order:

l Enterprise
Enterprise settings and sites are configured in YourSite Explorer. You also configure 3300 ICP media
servers, 5000 and Axxess media servers, andMultimedia Contact Center media servers in YourSite
Explorer. Youmust browse to the Contact Center Management website to add SX-200 and Intelligent
Queuemedia servers.
See "Enterprise setup" on page 69.

l Network Monitor
Depending on your telephone system, you browse to YourSite Explorer or the Contact Center
Management website and specify the days and times during whichmedia server alarms are active. For
SX-200 and Intelligent Queuemedia servers youmust configuremedia server alarms in
YourSite=>Network Monitor. For 3300 ICP, 5000 and Axxess media servers, andMultimedia Contact
Center media servers, you configuremedia server alarms in YourSite Explorer=>Node alarms.
See "Network Monitor alarms" on page 94.

l Configuration
Youmust browse to the Contact Center Management website and use YourSite=>Configuration to set
up the YourSite database tomirror the information on the SX-200 telephone system. You set up the
YourSite database tomirror the information on the 3300 ICP and the 5000 and Axxess telephone
systems in YourSite Explorer.
See "YourSite database configuration" on page 96.

l Schedule
For the SX-200 youmust browse to the Contact Center Management website under
YourSite=>Schedule to create schedules that reflect the business hours of your operation. You create
schedules for the 3300 ICP and the 5000 and Axxess in YourSite Explorer. You can apply the
schedules tomedia servers, queues, Network Monitors, wall signs, and Interactive Contact Center
queue control.
See "Business hour schedules" on page 169.

l Security
Youmust browse to the Contact Center Management website and use YourSite=>Security to restrict
user access to specific areas of the Contact Center Management website.
See "Security roles" on page 177.

YourSite Explorer
YourSite Explorer streamlines configuration.

NOTE:
l YourSite Explorer enables you to havemultiple device tabs open simultaneously. As a best practice,

we recommend you only have the device tabs open that you are currently using.
l We recommend you avoidmodifying large data sets from within YourSite Explorer as performance

levels will be negatively affected. As a best practice, all large dataset modifications should bemade on
the telephone switch directly and synchronized back to Contact Center Management. If you prefer to
perform modifications inside YourSite Explorer, we recommend you partition the changes into smaller
chunks of data.

For detailed information regarding which devices are configured in YourSite Explorer see "Configuration" on
page 52.
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Starting YourSite Explorer
To start YourSite Explorer
 1. Open YourSite Explorer.
 2. If prompted, type your username and password and verify the Enterprise Server IP address.
 3. Click Log on.

YourSite Explorer Start Page
The YourSite Explorer Start Page is a startup resource that provides links to both information resources for
getting started as well as system information for Contact Center Solutions. By default, if enabled, the Start
Page opens automatically with each new session of YourSite Explorer.

The Start Page has two tabs: Getting Started and System Information.
l Getting Started—provides configuration overviews for Contact Center Solutions and includes the

following tabs:
l Welcome—details the contents of both the Getting Started tab and the System Information tab
l Contact Center Management—overview of Contact Center Management YourSite Explorer

configuration
l Call Accounting—overview of Call Accounting YourSite Explorer configuration
l Workforce Scheduling—overview of Workforce Scheduling YourSite Explorer configuration for

employees and schedules
NOTE:Youmust be licensed forWorkforce Scheduling to view this tab.

l Visual Workflow Manager—overview of IVR Routing configuration
NOTE:Youmust be licensed for IVR Routing to view this tab.

l System Information—provides documentation as well as system and license information and
includes the following tabs:

l Documentation—provides links to Contact Center Solutions and Call Accounting
documentation

l About—provides system information, custom reports, and contact information for prairieFyre
l Alarms—provides information on currently active Contact Center Management alarms, with

links to corresponding prairieFyre Knowledge Base articles

Configuring the YourSite Explorer Start Page
You can configure whether or not the Start Page opens automatically when you start YourSite Explorer. You
can also configure whether or not the Start Page automatically loads in View tab of YourSite Explorer.

To prevent the Start Page from opening automatically
 1. Start YourSite Explorer.
 2. On the Start Page, clear theShow page on startup checkbox.

The Start Page will no longer automatically open on startup.

To configure whether the Start Page opens in the View tab
 1. In YourSite Explorer, in the ribbon, click theView tab in themenu of YourSite Explorer.
 2. If you want to prevent the Start Page from loading automatically on startup, clear theShow start page

checkbox.
If you want to enable the Start Page to load automatically on startup, select theShow start page
checkbox.
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Searching
When you perform searches in YourSite Explorer, you can filter on specific criteria to narrow the search.
YourSite Explorer searches on criteria you type into the Search box. The search result will consist of all
instances of the search item. For example, if you ran a search for ext, your search result could contain:
extension, text, and next time.

After you perform an initial search, you can type additional criteria in the box to narrow the search. If no words
or numbers match your search request, the resultant list will be blank.

YourSite Explorer searches on the following variables:
l Employees, employee groups—first and last name
l Extensions, extension groups—reporting number
l Trunks, trunk groups, DNIS, DNIS groups, Account Codes, divisions—name and reporting number
l Phone numbers, phone number groups—search on information found in all columns except Created by,

Created date, Last modified by, or Last modified.

To search for a specific word or number
l In theSearch box, type a word or number surrounded by quotationmarks.

For example, to search for an extension named Extension1, type "Extension1."
A list of devices that match the search criteria displays.

Paging
Paging enables you to specify the number of items to be included per page. You can reduce the page size to
increase the application speed. By default, the page size allows for 100 items. When changing the page size,
youmust close and re-open the device window.

To change the number of items viewed per page
 1. In YourSite Explorer, click YourSite.
 2. On the ribbon, click theView tab.
 3. AfterPage size, select the number of items to be viewed per page.
 4. Click Save.

Filtering
The filtering bar enables you to access records alphabetically.

YourSite Explorer filters records on the following variables:
l Employee—last name
l Phone number—country name
l Employee group, extension, extension group, trunk, trunk group, DNIS, DNIS group, Account Code,

division, and phone number group—name.

To filter records alphabetically
l On the filter bar, click the letter with which the record begins.

To filter numerically
l On the filter bar, click # to view records that start with numbers 0 through 9.

To reset filtering
l On the filter bar, click All to view all records.
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You can filter and then search within the filtered records. For example, click F to filter for all records that start
with the letter F. Then type th to search within that list for any record with th.

Customizing the user interface
You can customize the user interface by minimizing aspects of it, changing the order of the columns,
changing column options, and adjusting the page size. This customization is referred to as a profile. Your
profile is associated with the username you use to access YourSite Explorer. Each time you close YourSite
Explorer, your profile is automatically saved. When you reopen YourSite Explorer using the same username,
the user interface displays your profile.

Minimizing aspects of the user interface
To add space to the user interface so you can view additional rows of data, you canminimize the

l Filter bar
The filter bar is the bar on which the alphabet is displayed.

l Page bar
The page bar is located above the filter bar. The page number is displayed on the left side of the page
bar.

l Ribbon
The ribbon is located at the top of the user interface. The ribbon includes Home, View, and
Configuration tabs, and enables you to add devices and change the view (horizontal, vertical, or data
grid). Ribbon attributes change depending on the area you are viewing.

To hide the filter bar
 1. On the ribbon, click theView tab.
 2. Click Save.
 3. In YourSite Explorer, click YourSite.
 4. Clear theShow filter bar check box.

To hide the page bar
 1. On the ribbon, click theView tab.
 2. Click Log on.
 3. In YourSite Explorer, click YourSite.
 4. Clear theShow paging bar check box.

Tominimize the ribbon
 1. In YourSite Explorer, underEnterprise, click Media servers.
 2. Click Minimize the Ribbon.

The ribbon at the top of YourSite Explorer is hidden.

Selecting the first record of each list
You can save time by configuring YourSite Explorer to automatically select the first record on a page.

To select the first record of each list
 1. On the ribbon, click theView tab.
 2. In YourSite Explorer, click YourSite.
 3. Select theSelect the first record check box.
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Changing the order of the columns
You can reorder columns in either of two ways. You can drag a column heading to a different position on the
table, or you can change column order using Column options. See "Changing column options" on page 68.

To drag column headings
 1. With the device window open, select the column heading to bemoved.
 2. Drag it to a different position on the table.

Changing column options
You can adjust the width and order of columns, and hide or show columns in device windows.

To adjust columnwidth
 1. Drag the column to the left or right to adjust its width.
 2. Click OK.

To hide a column
 1. Right-click a column heading.

The Column options window opens.
 2. Select Column options.
 3. Select the column heading to be hidden.
 4. Click <<.
 5. Click OK.

To change the order of columns
 1. Right-click a column heading.

The Column options window opens.
 2. Select Column options.
 3. Select the column heading to bemoved.
 4. Use the arrows to change the order of the column headings.

The top column displays first in the device window.
 5. Click OK.

Grouping device criteria by column headers
You can group devices by column heading in the grid view. For example, if you click the Site column heading
on the Employees window, you can group employees by site. Grouping enables you to quickly select like
devices andmake changes to them simultaneously. For example, if you click theMedia server column
heading on the Extensions window (to group the extensions by media server), you can then readily select the
extensions associated with a particular media server and change their attributes, such as licensing or failover
media server. See "Makingmultiple changes" on page 69.

To group device criteria by column headers
 1. Open the device with the criteria to be grouped.
 2. Click Group by.
 3. Select themethod of grouping.
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Making multiple changes
In one action, you can edit common information across multiple devices of the same type. If, for example, you
recently set up your system to be resilient, youmust configure your employees as resilient. You assign
resiliency tomultiple employees by selectingmultiple employees and then selecting the This employee is
resilient check box.

You can change information that is common across multiple devices only. For example, you cannot change
Name and Reporting number across multiple employees because they are specific to each device item.

You canmakemultiple changes to
l Employees
l Trunk groups
l DNIS

Changing the YourSite Explorer view
You can select from three window orientations or views: horizontal, vertical, and data grid. The horizontal view
displays information in a horizontal layout. The vertical view displays information in a vertical layout.

The data grid view contains a table in which you can readily edit device attributes. Pressing the Tab key
enables you tomove from column to column. When viewing a device group in grid view, you can associate
members within the samewindow.

When you close YourSite Explorer and then restart it, YourSite displays the view and device windows that
were open the last time you used YourSite Explorer.

To select a particular view
 1. In YourSite Explorer, on the ribbon, click theView tab.
 2. Click YourSite.
 3. Select Horizontal, Vertical, orData grid.

Enterprise setup
For all telephone system types, you set up your site structure in YourSite Explorer.

To set up your enterprise structure
 1. Specify enterprise settings.
 2. Add a site.
 3. Addmedia servers to the site.

See "Addingmedia servers" on page 74.

Youmust understand the following terms to set up your enterprise structure.
l Enterprise

The enterprise is all of the sites that comprise your company.
See Figure 6 - 2.

l Site
A site is an office location with one or moremedia servers. It can be the office where the Enterprise
Server is installed or a branch office.
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l Media server
Themedia servers are themeans by which customers communicate with you. For example, if
customers contact you by telephone only, and you have an Axxess telephone system, then you would
configure an Axxess media server.

For example, you have a business called ABC Company. You have two offices. One office is in Salt Lake
City and your head office is in Los Angeles. The Salt Lake City site has Contact Center Management
software installed on the Enterprise Server. Both sites have the Axxess telephone system and the Exchange
Server installed. Your customers contact you at either site by telephone or email.

When setting up your enterprise site structure, you install Contact Center Management on the Enterprise
Server. You define the site with the Enterprise Server (Salt Lake City). You add the Los Angeles site to the
enterprise. Finally, you program twomedia servers at each site: Axxess (for calls) and Exchange (for emails).

Figure 6 - 2 Enterprise structure

Starting Contact Center Management
To start Contact Center Management on the Enterprise Server or on a client computer
 1. Start Internet Explorer in your browser and type your Enterprise Server IP address http://[your

Enterprise Server IP address]/CCMweb/.
 2. Click Favorites=>Add to Favorites to add the Enterprise Server IP address to your list of favorite

addresses.
 3. Click OK.
 4. Click Favorites, locate the Contact Center Management entry (at the bottom of the list) and drag it to the

top of the list.
 5. Optionally click Make Home Page to set the Enterprise Server IP address as your home page.
 6. If prompted, type your username and password and click Submit.
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Configuring enterprise settings
When programming the enterprise, you configure Enterprise server general settings, somemaintenance
services, email alarms, and screen pop. The Enterprise Server is the computer on which Contact Center
Management is installed.

Configuring the Enterprise Server settings
To configure the Enterprise Server settings
 1. In YourSite Explorer, click YourSite=>Enterprise.
 2. UnderGeneral settings, after IP address, verify the IP address of the Enterprise Server.
 3. If the IP address is incorrect, after IP address, type the IP address of the Enterprise Server.

NOTE: If you want to change the Enterprise IP address, use the Contact Center Client Update Server
IP Wizard. See "Updating server IP addresses" on page 52.

 4. AfterReal-time port, type the real-time port number.
The default real-time port is 5024.
The real-time port is used to communicate real-time events.

 5. AfterAuditor port, type the Auditor port number.
The default Auditor port is 5025.
The auditor port is used to run Auditor events.

 6. AfterMiTAI proxy server port, type theMiTAI proxy server port number.
The default MiTAI proxy server port is 5026.

 7. If you want Lifecycle reports, select theEnable LifeCycle reports check box.
 8. If you use Secure Socket Layer, select the This server uses Secure Socket Layer (SSL) check box.
 9. UnderSystem Messages, if you want to be notified when your warranty is about to expire, select the

Display warranty warning and expiration message check box.
 10. UnderUpdater settings, if you want client applications to be automatically updated, select theAuto

update client applications check box.
 11. Click Save.
 12. Specify enterprisemaintenance functions.

See "Configuring enterprisemaintenance functions" on page 71.

Configuring enterprise maintenance functions
To configure enterprisemaintenance functions
 1. In YourSite Explorer, click YourSite=>Enterprise.
 2. Click theMaintenance tab.
 3. After Zip files older than, select the number of days after which you want to zip data files.
 4. AfterPurge reports older than, select the age after which reports will be discarded.
 5. AfterDelete maintenance logs older than, select the age after whichmaintenance logs will be

discarded.
 6. AfterDelete configuration backup files older than, select the age after which configuration backup

files will be discarded.
 7. After Time Maintenance Service runs, select the time themaintenance service summarizes data.

Themaintenance service is set to run at 2:15 A.M. by default. Select a time for themaintenance
manager to run when your contact center is closed or is the least busy.

 8. AfterPurge Life cycle reports older than, select the age after which Life cycle reports will be
discarded.

 9. Click Save.
 10. Configure email alarms.

See "Configuring email alarms" on page 72.
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Configuring email alarms
You configure email alarms so you are notified by email about Enterprise server and real-time performance
issues.

To configure email alarms
 1. In YourSite Explorer, click YourSite=>Enterprise.
 2. Click theEmail alarms tab.
 3. AfterSMTP Mail Server address, select the IP address of the SMTP Mail Server.
 4. AfterEmail notification interval minutes, select the duration (in minutes) after which you will be

notified when an alarm occurs.
 5. If you want the system to send an email notification when an alarm occurs, select theEnable email

alarms check box.
 6. AfterSend Enterprise Server alarms to the following address(es), type the email address of the

employee(s) who will receive the email notification.
 7. Click Save.

Adding sites
Your site structure determines how you view statistics and reports. When you set up your site structure, you
specify site andmedia server information. When you add a site, you add the name of the site and the time
zone. By making each site distinct, you can restrict user access to sites. See "Security roles" on page 177.

To add a site
 1. In YourSite Explorer, click YourSite=>Enterprise.
 2. Click Add.
 3. AfterSite name, type the name of the site.

You can add a number to the name of the site to indicate the number of sites in this location.
 4. After Time zone, select the time zone for the site.
 5. AfterSite language setting, select your preferred language for your Contact Center Management

website.
NOTE: The language setting you specify here becomes the default language for all of the client
computers. However, you can customize this setting for individual employees in the Contact Center
Management website, under My Options=>My preferences.

 6. AfterChat settings, select theChat enabled check box to enable Contact Center Chat.
NOTE:Contact Center Chat is enabled by default.

 7. If you want to use Lync Client as your default instant messaging client and view enhanced presence on
real-timemonitors, select theEnable enterprise presence and chat integration check box.
NOTE:Employees who are associated to sites where the above option is not enabled will not be able to
communicate using Contact Center Client.

 8. Click Save.
 9. If required, configure smart algorithms.

See "Configuring smart algorithms for sites" on page 73.
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Configuring the SMTP Server
To configure an SMTP server
 1. In YourSite Explorer, click SMTP servers.
 2. Click Add.
 3. AfterSMTP Server, type the IP address or name of themail server (for example, PFEXCHANGE).
 4. AfterSMTP Port, type the port number of the SMTP mail server.

NOTE: The default value of this port is 25.
 5. If theMail server uses Secure Sockets Layer, select theUse SSL check box.
 6. Under Logon Information, select the Is SMTP Authentication Required check box if the email

server requires authentication and type theUsername, Password, andDomain .
 7. UnderUser Information, type the name and email address from which all Contact Center Management

reports will bemailed.
NOTE: The email address field is mandatory as some email servers will not relay mail messages
without a valid sender.

 8. To send a test email, click the Test Email button.
 9. Click Save.

Configuring smart algorithms for sites
NOTE: If your site uses smart algorithms, agents can handle only one contact at a time.

If your site handles email, SMS, fax, and chat requests in addition to voice requests, you can use smart
algorithms to prioritize the incoming requests. When you select smart algorithms, Contact Center
Management routes the different media requests to multi-media agents in the order you specify on the Smart
algorithms tab.

To configure smart algorithms
 1. In Contact Center Management, click YourSite=>Enterprise.
 2. Select a site for which you will configure smart algorithms.
 3. Click theSmart algorithms tab.
 4. Select the This site uses smart algorithms check box.
 5. Select media types in the order you want them offered to agents.
 6. Click Save.
 7. If you use a SMTP server, configure the SMTP server.

See "Configuring the SMTP Server" on page 73.
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Adding media servers
NOTE:MixingMitel 5000/Axxess (formerly Inter-Tel 5000/Axxess) and 3300/SX-200media servers in the
same enterprise is supported by Contact Center Solutions and Call Accounting applications.

You add 3300 ICP, 5000, and Axxess media servers to your site in YourSite Explorer.

You addMultimedia Contact Center Email, Webchat, and Fax media servers to your site in YourSite Explorer.

Youmust add SX-200 and Intelligent Queuemedia servers to your site in the Contact Center Management
website.

To distinguish between the various types of media for management and reporting purposes, youmust make
eachmedia server distinct when you set up your site.

NOTE:
l Although theMitel SX-200 17 (Release 4 or greater) platform works with Contact Center Management

and Call Accounting, the SX-200ML/EL has beenmanufacture discontinued and is no longer supported
by Mitel or prairieFyre Software. Any issues or limitations arising from the use of the SX-200 telephone
system will not be supported with software fixes or customization. Instead, upgrading to the SX-200
ICP or another supported platform will be required. Contact your Mitel Channel Partner for information
on the “SX-200ML/EL trade up” program.

l Introduced in Contact Center Solutions Version 6.0 and continued into Version 6.0.2 the SX-2000
telephone system is no longer supported.

You can click Help=>About Your Mitel Applications to verify the types of media servers and the number of
employees for which you are licensed.

Contact Center Management works with the followingmedia server types:

3300 IP Communications Platform (ICP)
The 3300 ICP ACD system streams SMDR and ACD real-time data over TCP/IP.
See "Adding 3300 ICP media servers" on page 75.

SX-200 ACD (for 17 Release 4.0 and greater with real-time option enabled)
The SX-200 post 17 Release 4.0 (SX-200 ACD) system has both SMDR and ACD real-time data streams
delivered over RS-232.
See "Adding SX-200 ACD media servers" on page 85.

Mitel 5000/Axxess
TheMitel 5000 and Axxess telephone systems stream ACD andOAI data over TCP/IP. In addition, theMiTAI
remote telephone system software is installed locally on the Enterprise Server and communicates over
TCP/IP with the telephone systems.
See "Adding 5000/Axxess media servers" on page 87.

SX-200 Call Accounting
The SX-200 system has SMDR records delivered over a single data connection, RS-232, or TCP/IP.
See theMitel Call Accounting User Guide.
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Multimedia Contact Center Email
TheMultimedia Contact Center Email routing engine leverages Microsoft® Exchange Server 2003/2007 to
dynamically allocate emails to agents on their Microsoft® Outlook 2003 desktops. The Exchange Server
2003/2007 dedicated toMultimedia Contact Center Server must talk to your corporatemail server.
See "Adding aMultimedia Contact Center Email media server" on page 89.

Multimedia Contact Center WebChat
TheMultimedia Contact CenterWebChat routing engine dynamically allocates live chat sessions from
customers over theWeb to agents on their Microsoft® Outlook 2003/2007 desktops. TheWebChat routing
engine uses Microsoft® Exchange Server 2003/2007, and a chat component that resides on yourWeb server.
See "AddingMultimedia Contact CenterWebChat media servers" on page 91.

Multimedia Contact Center Fax
The corporate fax server converts customer faxes to electronic format. Then theMultimedia Contact Center
Fax routing engine dynamically allocates faxes from customers to agents on their Microsoft® Outlook
desktops.
See "AddingMultimedia Contact Center Fax media servers" on page 92.

Intelligent Queue
Intelligent Queue is an “all-in-one” announcement package for contact centers. Intelligent Queue uses the
Enterprise Server for real-time statistics (required for the Intelligent Queue Talk option) and for historical
reporting of Intelligent Queue caller activity (Call Detail reporting option).
See "Adding Intelligent Queuemedia servers" on page 93.

Adding 3300 ICP media servers
You add 3300 ICP media servers in YourSite Explorer.

Youmust first add the 3300 ICP media server and then configure its location settings, telephone system
settings, data summary options, Network Monitor settings, data collection settings, MiTAI options and,
optionally, write-back functionality and call recording.

NOTE:
l As a best practice, we recommend you perform Full Synchronization after adding and configuring a

media server in YourSite Explorer and before configuring telephone system settings for themedia
server. For more information on synchronization, see "Configuring the YourSite database using
synchronization" on page 101. For information on performing synchronization, see "Performing
synchronization" on page 104.

l If you are addingmedia servers as part of a new installation, we recommend you perform
synchronization after all media servers have been added. For more information, see theContact Center
Management Installation Guide.

To add a 3300 ICP media server
 1. In YourSite Explorer, click YourSite=>Media servers.
 2. Click Add=>3300 ICP.
 3. AfterName, type the name of themedia server.

NOTE:
l To distinguish between the various types of media for management and reporting purposes,

youmust name eachmedia server distinctly when setting up your site.
l TheMedia server ID field will be populated with a unique number after themedia server has

been saved.
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 4. AfterSite, select the site where themedia server resides.
 5. AfterComputer name, select the computer where the server resides.
 6. AfterMedia server type, select the type of media server.

NOTE: The typical media server type is ‘Enterprise Node’. If you select ‘Queueing gateway’, no agent
data will be filed to SQL. If you select ‘Agent/extension gateway’, no queue data will be filed to SQL.
When amedia server is configured as an ‘Agent/extension gateway’, no queues are loaded and, as a
result, no call activity is displayed in the Interactive Visual Queue real-timemonitor.

 7. If you have hot desking agents, select theUses hot desking agents check box.
NOTE: If this is selected, all created agents will be hot desking agents. You cannot mix hot desking
and standard agents.

 8. To be informed of media server alarms, select theEnabled for alarms check box.
NOTE: Selecting this check box will inform you of media server alarms via RSS and email. For more
information, see "Monitoring and alarming subsystem" on page 171.

 9. Select Licensed for Call Accounting if you are applying for a Call Accounting license.
NOTE: This check box is selected by default when you add a 3300 ICP media server and have
remaining Call Accountingmedia server licenses. If you are licensed for Contact Center Management
and Call Accounting, youmust select "Licensed for Call Accounting" to have access to Call
Accounting. If you are not licensed for a product, you will not be able to select the check box for that
product.

 10. If you want to designate themedia server for historical reporting use only, click Make Historical.
Making amedia server historical terminates all active licenses for devices associated with that media
server. Historical data is retained on themedia server but no new data is collected.

 11. After IP/DNS address, specify the IP/DNS address of themedia server.
 12. AfterUsername, type the username used to connect to the telephone system.
 13. AfterPassword, type the password used to connect to the telephone system.
 14. AfterConfirm password, type the password used to connect to the telephone system.
 15. Click the Test Connection button to test the connection between themedia server and the Enterprise

Server.
This connection is required to ensure Synchronization functionality.

 16. If this media server is part of a Mitel cluster, underCluster setting, select the This media server is
part of a Mitel cluster check box.

 17. If this media server is part of a Mitel cluster, afterCluster ID, type the cluster ID.
The cluster ID can be found on the telephone system.

 18. If this media server is part of a Mitel cluster, afterCluster ID Digits, type the digits used to identify the
cluster.

 19. If this media server is part of a Mitel cluster, afterCluster name, select the cluster name.
NOTE:After synchronization, Cluster settings will automatically align with the telephone system
settings and these fields will auto-populate.

 20. Click Save.
 21. Configure the location settings.

See "Configuring location settings for 3300 ICP media servers" on page 76.

Configuring location settings for 3300 ICP media servers
To configure location settings for a 3300 ICP media server
 1. Click the Location tab.
 2. AfterCountry, click the ... button and select the country where themedia server is located.
 3. AfterArea, click the ... button and select the appropriate area code for themedia server's location.
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 4. AfterMinimum digits to dial locally, specify theminimum number of digits dialed for a local call in the
city in which themedia server is located.

 5. AfterMaximum digits to dial locally, specify themaximum number of digits dialed for a local call in
the city in which themedia server is located.

 6. AfterOutbound dialing prefix, specify the number dialed to access an outside line.
 7. Configure the data summary options for the 3300 ICP.

See "Configuring data summary options for 3300 ICP media servers" on page 77.

Configuring data summary options for 3300 ICP media servers
To configure data summary options for a 3300 ICP media server
 1. Click theData summary options tab.
 2. If you want to use Trace reporting, select the Inbound/Outbound/Make Busy Trace reporting check

box.
 3. If your business operates around the clock, select the This enterprise operates 24 hours a day check

box.
NOTE: If you do not select the "This enterprise operates 24 hours a day" check box, but have agents
logged in to Contact Center Solutions applications overnight, youmay experience difficulties with shift-
related statistics, such as agent shift monitor andMake Busy Reason codes. For example, if logged in
to Contact Center Client overnight with aMake Busy Reason code, when you change theMake Busy
Reason code the following day, Contact Center Client will display “UnknownMake Busy code.” This
can be remedied by logging out of the application and logging back in.

 4. To track outbound calls that were not answered, select theCredit unanswered outbound calls check
box.

 5. If you want to display when calls ring at agents’ extensions, select theMonitor Agent Ringing state
check box.

 6. AfterDigits dialed prefix, type the digits that must precede a telephone number tomake an outbound
call.

 7. AfterDigits dialed postfix, type the digits that must follow a telephone number tomake an outbound
call.

 8. AfterMaximum MiTAI monitors, specify themaximum number of MiTAI monitors.
 9. UnderAgent state timeout audit, afterClear line if agent Hold Time exceeds, specify the number

of minutes or hours you are in a hold state before the telephone system clears the line.
 10. AfterClear line if agent primary Talk Time exceeds, select the number of minutes or hours an agent

can be in a single state on the primary line (ACD line) before the system clears that line.
 11. AfterClear line if agent secondary Talk Time exceeds, specify the number of minutes or hours an

agent can be in a single state on the secondary line (non ACD) before the system clears that line.
 12. If you do not want to report on the secondary line (non-ACD and outbound calls), select the Ignore

agent secondary line activity check box.
 13. AfterChange the agent state from Ringing to Idle after, specify the number of minutes or hours

after which you want the agent state to change from Ringing to Idle.
 14. Select theReset MKB/DND time in realtime after call ends check box to enable theMKB/DND time

to reset in real time when the call concludes.
 15. UnderACD Options, to store ACD redundant events, select the File all ACD stream redundant

events check box.
 16. If you do not consider ACD real-time sequence errors as record errors, select the Ignore ACD real-

time sequence errors as record errors check box.
 17. Configure Network Monitor settings.

See "Configuring Network Monitor settings for 3300 ICP media servers" on page 78.
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Configuring Network Monitor settings for 3300 ICP media servers
You can configure Network Monitor settings for 3300 ICP media servers by modifying the default alarm and
the default media server schedule, or by creating new alarms and new media server schedules.

To configure Network Monitor settings for a 3300 ICP media server
 1. Click theNetwork Monitor tab.
 2. AfterAlarm name, click the ... button.

The Select amedia server alarm window opens.
 3. Select an alarm from the list and click OK.
 4. Tomodify an existing alarm, click Manage alarms andmake any changes to the alarm's configuration.

For more information on alarm configuration options, or to create a new alarm, see "Configuringmedia
server alarms" on page 95.

 5. Tomodify a schedule for themedia server, on the Network Monitor tab, click Manage schedule and
make any changes to the schedule.
For more information on schedule configuration options, or to create a new schedule, see "Creating
schedules" on page 169.

 6. On the ribbon, click Save.
 7. Configure data collection settings for themedia server.

See "Configuring data collection settings for 3300 ICP media servers" on page 78.

Configuring data collection settings for 3300 ICP media servers
CAUTION:Selecting the TCP, EnterpriseManager (OPS Manager), or Simulation tabs will change themedia
server’s data collectionmode. Ensure that you select the tab for the appropriate data collectionmode. Be
aware that Simulationmode halts data collection and is used for demonstration purposes only. We do not
recommend you runmedia servers in simulationmode. However, if you want to simulate media server real-
time data collection and reporting, see the following prairieFyre Knowledge Base article:
http://www.prairiefyre.com/kb/KnowledgebaseArticle51207.aspx

To configure data collection settings for a 3300 ICP media server
 1. Click theData collection tab.
 2. If you do not use EnterpriseManager (OPS Manager), click TCP. Otherwise, skip to step 8.
 3. AfterSMDR, type the SMDR port number of themedia server.
 4. If you will be entering ACD information, select theACD check box.
 5. AfterACD, type the ACD port number of themedia server.
 6. If you use Traffic Analysis, select the Traffic Analysis check box.
 7. After Traffic Analysis, type the Traffic Analysis port number of themedia server.
 8. If you use Enterprise Manager (OPS Manager), click Enterprise Manager (OPS Manager).
 9. After IP address/DNS name, type either the IP address or the DNIS name of the Enterprise Manager

(OPS Manager) computer.
 10. After FTP port, type the FTP port number.
 11. After FTP user name, type the FTP user name to gain access to EnterpriseManager (OPS Manager).
 12. After FTP password, type the FTP password to gain access to EnterpriseManager (OPS Manager).
 13. AfterRemote directory to data files, type the directory path where the data from the telephone system

is stored by EnterpriseManager (OPS Manager).
 14. Configure themedia server's MiTAI options.

See "ConfiguringMiTAI options for 3300 ICP media servers" on page 79.
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Configuring MiTAI options for 3300 ICP media servers
To configureMiTAI options for a 3300 ICP media server
 1. Click theMiTAI Options tab.
 2. AfterMaximum messages per second, select the number of messages per second from the drop-

down list.
The default number of messages is 10 per second. The higher the version of MiTAI, the greater the
number of messages per second.

 3. AfterMiTAI auto-synchronization will occur at, select the time from the list that you want Automatic
Synchronization to run.

 4. AfterSpecify the port used for the MiTAI data stream, type the port number used for theMiTAI data
stream.

 5. To enable write-back functionality, see "Enabling write-back functionality" on page 79.

Enabling write-back functionality
For changes that youmake to the configuration settings in YourSite Explorer to be written back to the
telephone switch, youmust enable the read/write option in YourSite Explorer.

NOTE: The user account must an Enterprise Administrator in Contact Center Management to have read/write
access.

To enable write-back functionality
 1. In YourSite Explorer, click YourSite=>Media servers.
 2. Select themedia server for which you want to enable read/write functionality.
 3. On the ribbon, click the Telephone System tab.
 4. In theSettings section, select Read/Write.
 5. Configure the telephone system settings for themedia server.

See "Configuring telephone system settings for 3300 ICP media servers" on page 79.

Configuring telephone system settings for 3300 ICP media servers
To configure telephone system settings for a 3300 ICP media server
 1. Click the Telephone system settings tab.
 2. Click System options.
 3. After Feature access code for silent monitoring, type the feature access code used for silent

monitoring, as programmed on the 3300 ICP telephone system.
NOTE: The feature access code for silent monitoringmust be unique and up to four digits in length. Do
not use * and # alone to define feature access codes.

 4. If applicable, afterReplacement Access Code, enter the replacement access code programmed on the
telephone system.

 5. If applicable, afterRegistration Access Code, enter the registration access code programmed on the
telephone system.

 6. AfterACD 2000 - Automatically log out last agent on no answer, select Yes by default.
 7. AfterACD Real-Time Events Feature Level, set the value to 1.
 8. AfterACD Make Busy Walk Away Codes, select Yes by default.
 9. Click SMDR options.
 10. If applicable, correct the SMDR Options settings.

For the SMDR Options settings list, see Table 6 - 2.
 11. Click Class of Service and select a Class of Service number.

The properties for the selected Class of Service are shown in the right-hand pane.
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 12. AfterDefault type, enter the Class of Service type.
 13. AfterComment, enter a description for the Class of Service.
 14. Select Yes for the following Class of Service options:

l HCI/CTI/TAPI call control allowed
Selecting Yes enables the softphone extensions and IVR Routing ports to be controlled by the
host computer.

l HCI/CTI/TAPI monitor allowed
Selecting Yes enables an HCI monitor to be initiated against softphone extensions and IVR
Routing ports.

l SMDR external
Selecting Yes enables trunking SMDR.

l SMDR internal
Selecting Yes enables SMDR internal records to be generated.

 15. AfterCall forward delay, enter the amount of time to wait before forwarding a call.
 16. AfterCall forward no answer timer, enter the amount of time to wait for a forwarded call to be

answered.
 17. Select Yes orNo for the following additional Class of Service options:

NOTE:Youwill receive a warning in YSE if you choose a Class of Service option that is not
recommended.

l Message waiting
This option permits a phone to enable and disable message waiting notification on another phone.

l Message waiting audible tone notification
This option enables message waiting notifications to take the form of a tone every time the phone
goes off-hook.

l Do not Disturb
This option enables users to change their Do not Disturb status and prevents the phone from
ringing on incoming calls.

l Do not Disturb permanent
This option sets the phone permanently in Do not Disturb.

l Public network access via DPNSS
This option enables devices to originate calls to directory numbers on the PSTN. Selecting “No”
disables network access.

l Suppress simulated CCM after ISDN progress
This option prevents the PBX from sending an answermessage to a party calling on an ISDN
trunk, preventing systems usingMiTAI or HCI to play ringback or call processing tones when the
call is answered.
NOTE:Enable this option on end nodes only. Do not enable this option on transit nodes.

l Recorded announcement device
This option enables RAD ports to play recordedmessages for one-way, outgoing audio.

l Accept hot desk login
This option enables a hot desk login on a device.

l Voice mail port
This option enables the voicemail system to uniquely identify the party that is receiving a
message.

l External hotdesk user – answer confirmation
This option forces an external hotdesk user to press a DTMF key to answer incoming calls.

 18. AfterAnswer Plus Message Length Timer, specify an amount of time to apply to MCD RAD
messages. The time specified should equal the time it takes for the RAD message to play.

 19. AfterAnswer Plus Expected Off-hook Timer, specify the amount of time the RAD can be off-hook
and not playingmessages before it requires servicing and is removed.

 20. AfterWork Timer, specify the amount of time agents can be in aWork Timer state. For information on
work timer, see "Configuring work timer" on page 184.
NOTE: This timer applies to ACD extensions only.
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 21. Click Class of Restriction.
 22. Select a Class of Restriction.

The properties for the selected Class of Restriction are shown in the right-hand pane.
 23. AfterDo you want this Class of Restriction to be the default setting?, select Yes orNo.
 24. AfterClasses of Restriction for the group, enter the Class of Restriction numbers to include in the

group.
Youmay specify a range of numbers. Separate numbers using dashes or commas. For example, 1
though 9may be entered as 1-9, or a combination of individual numbers and ranges may be entered as
1,2,3,7-10,13.
NOTE:Class of Restriction numbers must be entered in ascending order within each group.

 25. On the ribbon, click Save.
 26. If you want to enable call recording, see "Call recording" on page 83.
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Table 6 - 2 SMDR Option Settings

SMDR Option Value

Extended digit length Yes

MCD - Report transfers All

Network format Yes

Report Account Codes Yes

Report incoming calls Yes

Report internal calls Yes

Report meter pulses No

Report outgoing calls Yes

SMDR record transfer Yes

System identification Yes

Time change report Yes

24-hour time reporting Yes

ANI/DNIS/ISDN/CLASS number delivery reporting Yes

OLI node ID format for incoming trunk calls

Extended time to answer Yes

Standardized network OLI Yes

Standardized call ID format Yes

Suite services reporting No

Report internal unanswered calls No

SMDR extended reporting level 1 Yes

SMDR extended reporting level 2 Yes

Report attendant name Yes

Account Code number for internal calls Yes

Path reporting number for internal ACD2 calls Yes

SMDR Meter Unit Per Station No
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Call recording
Contact Center Solutions offers 24/7 call recording by integrating with OAISYS Tracer (Version 6.2 or greater)
or dvsAnalytics Encore (Version 2.3 or greater) call recording software. For enhanced call security, Contact
Center Solutions also integrates with theMitel Secure Recording Connector service to facilitate the recording
of Mitel encrypted voice streams by third party software. OAISYS Tracer can optionally be used in
conjunction with theMitel Secure Recording Connector service. dvsAnalytics Encoremust be used in
conjunction with theMitel Secure Recording Connector service.

Configuring call recording integration
Using the OAISYS Tracer, Contact Center Solutions can optionally record calls based on pre-defined
schedules. With OAISYS Tracer, call recording can be temporarily started or stopped in Contact Center Client
to ensure customer confidentiality or to create a record of volatile or sensitive calls. See "Recording calls" on
page 406.

When a call recording is complete, a hyperlink to the recording is appended to call-specific Lifecycle reports.
See theMitel Contact Center Solutions Reports Guide for more information about Lifecycle reporting.

NOTE:
l OAISYS Tracer or dvsAnalytics Encore call recording integration is supported for use with theMitel

3300 ICP only.
l Before you can configure call recording in YourSite Explorer, youmust configure your OAISYS Tracer

or dvsAnalytics Encore by following the recommended installation and configuration guidelines
included with these products.
Contact your OAISYS or dvsAnalytics approved vendor for all set up and troubleshooting issues.

l The Contact Center 3rd Party Call Recording Connector dvsAnalytics Encore does not support External
hot desking Agents.

l Contact OAISYS or dvsAnalytics for information on integrating call recording with theMitel Secure
Recording Connector.

l Ensure call recordings are working properly for all configured extensions before activating the call
recording integration in YourSite Explorer.

l If you use theMitel Secure Recording Connector and Contact Center Softphone, youmust enter the IP
addresses of theMitel Secure Recording Connector in YourSite Explorer.

To configure OAISYS call recording integration
 1. In YourSite Explorer, underEnterprise, click Media servers.
 2. Select amedia server from the list.
 3. Click theCall recording options tab.
 4. UnderCall recording provider options

l AfterRecorder type, select OAISYSfrom the drop-down list.
l AfterOAISYS server address, type the IP address of the call recorder.
l AfterOAISYS server port, specify the port of the call recorder.
l AfterUsername, type the username to log into the call recorder.
l AfterPassword, type the password to log into the call recorder.

 5. Click Save.
Call recordings are enabled and can be accessed from hyperlinks in call-specific Lifecycle reports.
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To configure dvsAnalytics Encore
 1. In YourSite Explorer, underEnterprise, click Media servers.
 2. Select amedia server from the list.
 3. Click theCall recording options tab.
 4. UnderCall recording provider options

l AfterRecorder type, select dvsAnalytics Encore from the drop-down list.
l AfterEncore Web API address, type http://<Encore Server IP address>/WebAPI/ECAPI.svc

 5. Click Save.
Call recordings are enabled and can be accessed from hyperlinks in call-specific Lifecycle reports.

Configuring the Mitel Secure Recording Connector service
Contact Center Solutions integrates with Mitel Border Gateway’s Secure Recording Connector service, which
facilitates the recording of Mitel encrypted voice streams by third-party call recording equipment. In order to
use Contact Center Softphone in conjunction with theMitel Secure Recording Connector service, youmust
complete the configuration process described below.

NOTE:
l Before you can configure call recording in YourSite Explorer, youmust configure the Secure Recording

Connector service in Mitel Border Gateway. For Mitel Border Gateway configuration information, see
theMitel Border Gateway Installation andMaintenanceGuide.

l If multiple Mitel Border Gateways are used in a clustered environment to take advantage of load
balancing and the soft phone is connected to the primary Secure Recording Connector when that
connector goes offline, the soft phone will re-connect as determined by the cluster. New soft phones
will attempt to connect to the first Mitel Border Gateway configured in YourSite Explorer, then try the
secondMitel Border Gateway configured in YourSite Explorer and as a final attempt, try registering with
themedia server itself. If it registers with themedia server, call recording will not be possible.

For soft phone balancing in a Secure Recording Connector service environment to function properly,
youmust alter a configuration file on theMitel Border Gateway server. If you do not, you will have to
restart Contact Center Client and the soft phone in the event of a failover. For instructions on how to
make alterations, contact prairieFyre Software Inc. Technical Support at 613-599-0045 or
support@prairiefyre.com (North American customers). For customers residing in Latin America,
Europe, theMiddle East, Africa, and Asia Pacific, contact your approvedMitel vendor.

To configure the Secure Recording Connector service
 1. In YourSite Explorer, underEnterprise, click Media servers.
 2. Select a 3300 ICP media server from the list.
 3. Click theCall recording options tab.
 4. UnderMitel Secure Call Recording, after IP address 1, type the primary IP address of the Secure

Recording Connector.
 5. If you usemultiple Secure Recording Connectors, type the IP address of the secondary Secure

Recording Connectors after IP address 2.
If the soft phone fails to connect to the primary Secure Recording Connector, it will attempt to connect
to the secondary. If that fails, then soft phone will use the IP address of themedia server programmed
in the data collection field. If it uses the IP address of themedia server, call recording will not be
possible.

 6. Click Save.
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Adding SX-200 ACD media servers
You add an SX-200 ACD media server in the Contact Center Management website.

Youmust first add the SX-200, and then configure its data collection settings, data summary options, and
Network Monitor settings.

To add an SX-200 ACD media server
 1. In Contact Center Management, click YourSite=>Enterprise.
 2. Click Add media server=>SX-200 ACD with Real-time.

NOTE: To distinguish between the various types of media for management and reporting purposes, you
must give eachmedia server a unique namewhen setting up your site.

 3. AfterName, type the name of themedia server.
 4. AfterSite, select the site where themedia server resides.
 5. After This media server is installed on the computer you named, select the computer on which the

media server is installed.
NOTE: The Change themedia server type for this media server list displays only after you have saved
themedia server. It allows you to edit themedia server type after themedia server has been added to
the site.

 6. AfterCountry, select the country where themedia server is located.
If you are setting up a node, select the country in which the node is located.

 7. AfterArea, select the area where themedia server is located.
If you are setting up a node, select the area in which the node is located.

 8. AfterMinimum digits dialed, type theminimum number of digits dialed for a local call in your city.
 9. AfterMaximum digits dialed, type themaximum number of digits dialed for a local call in your city.
 10. AfterApply license for, select the product to which you are applying a license.

For example, select Call Accounting if you are applying a Call Accounting license. If you are not
licensed for a product the check box for that product does not show. If you have no remaining licenses,
although the check box still shows, an error message indicates that all available licenses have been
used.

 11. Specify the data collection settings.
See "Configuring data collection settings for SX-200 ACD media servers" on page 85.

Configuring data collection settings for SX-200 ACD media servers
To configure data collection settings for an SX-200 ACD media server
 1. Click theData collection tab.
 2. If themedia server streams ACD and SMDR data over RS-232, underSpecify data collection

settings, click Com port. Otherwise, skip to step 4.
 3. Accept the default ACD and SMDR settings for Com port, baud rate, data bits, parity bit, and stop bits.

Skip to step 7.
 4. Click TCP.
 5. Click IP address, orDNS, and type the IP address, or name, of the collection point.
 6. AfterSpecify ports, type the ACD and SMDR port numbers of the telephone system.
 7. If you want to store ACD redundant events, select the File all ACD stream redundant events check

box.
This displays on the SX-200 with Real-time user interface only.

 8. If you do not consider ACD real-time sequence errors as record errors, select the Ignore ACD real-time
sequence errors as record errors check box.
This displays on the SX-200 with Real-time user interface only.

 9. If you have clustering, select the This media server is part of a Mitel cluster check box.
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 10. AfterCluster ID, type the cluster ID.
 11. AfterCluster name, type the cluster name.
 12. Specify the data summary options.

See "Configuring data summary options for SX-200 ACD media servers" on page 86.

Configuring data summary options for SX-200 ACD media servers
To configure data summary options for an SX-200 ACD media server
 1. Click theData summary options tab.
 2. If you want trace reporting, select the Inbound/Outbound/Make Busy Trace reporting check box.
 3. If your business operates around the clock, select the This enterprise operates 24 hours a day check

box.
NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have agents
logged in to Contact Center Solutions applications overnight, youmay experience problems with shift-
related statistics, such as agent shift monitor andMake Busy Reason codes. For example, if logged in
to Contact Center Client overnight with aMake Busy Reason code, when you change theMake Busy
Reason code the following day, Contact Center Client will display “UnknownMake Busy code.” This
can be remedied by logging out of the application and logging back in.

 4. If you want to track outbound calls that were not answered, select theCredit unanswered outbound
calls check box.

 5. If you want reports andmedia servers to have a 24-hour clock format (for example, if you want 1:00 P.M.
to show as 13:00), select the 24-hour clock format check box.

 6. UnderAgent state timeout audit, afterClear line if agent Hold Time exceeds, select the number of
minutes or hours you are in a hold state before the telephone system clears the line.

 7. AfterClear line if agent primary Talk Time exceeds, select the number of minutes or hours you are in
a single state on the primary line (ACD line) before the system clears that line.

 8. AfterClear line if agent secondary Talk Time exceeds, select the number of minutes or hours you
are in a single state on the secondary line (non ACD) before the system clears that line.

 9. If you do not want to report on the secondary line (non-ACD and outbound calls), select the Ignore
agent secondary line activity check box.

 10. If your telephone system outputs leading digits in SMDR, afterPrefix digits, type the digits.
 11. If your telephone system outputs trailing digits in SMDR, afterPostfix digits, type the digits.
 12. Specify Network Monitor settings.

See "Configuring Network Monitor settings for SX-200 ACD media servers" on page 86.

Configuring Network Monitor settings for SX-200 ACD media servers
To configure Network Monitor settings for an SX-200 ACD media server
 1. Click theNetwork Monitor tab.
 2. AfterAlarm name, select an alarm.
 3. If youmust create or modify an alarm that will warn you if data is not being collected for this media

server, click Manage alarms and configure an alarm.
See "Configuringmedia server alarms" on page 95.

 4. UnderNotify me during these business hours, afterSchedule name, select a schedule that reflects
the hours of operation for themedia server.

 5. If youmust create or modify a schedule for themedia server, click Manage schedule and configure a
schedule.
See "Creating schedules" on page 169.

 6. Click Save.
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Adding 5000/Axxess media servers
You add 5000/Axxess media servers in YourSite Explorer.

Youmust first add the 5000/Axxess media server and then configure its location settings, data summary
options, data collection settings, and Network Monitor settings.

NOTE: To ensure optimal functionality, we recommend you perform Full Synchronization as part of adding
and configuring amedia server in YourSite Explorer. For more information on synchronization, see
"Configuring the YourSite database using synchronization" on page 101. For information on performing
synchronization, see "Performing synchronization" on page 104.

To add a 5000/Axxess media server
 1. InYourSite Explorer, click Media servers.
 2. Click Add=>Mitel 5000/Axxess.

NOTE: To distinguish between the various types of media for management and reporting purposes, you
must give eachmedia server a unique namewhen setting up your site.

 3. AfterName, type the name of themedia server.
NOTE: The typical media server type is ‘Enterprise Node’. If you select ‘Queueing gateway’, no agent
data will be filed to SQL. If you select ‘Agent/extension gateway’, no queue data will be filed to SQL.
When amedia server is configured as an ‘Agent/extension gateway’, no queues are loaded and, as a
result, no call activity is displayed in the Interactive Visual Queue real-timemonitor.

 4. AfterSite, select the site where themedia server resides.
 5. AfterComputer name, select the computer where the server resides.
 6. AfterMedia server type, select the type of media server.
 7. Specify the licenses to use for themedia server.

For example, select Call Accounting if you are applying a Call Accounting license. If you are not
licensed for a product the check box for that product does not show. If you have no remaining licenses,
although the check box still shows, an error message indicates that all available licenses have been
used.

 8. After IP/DNS address, specify the IP address of themedia server.
If you use a CT Gateway, the IP address entered in this field must be the IP address of the CT
 Gateway and not that of themedia server.

 9. AfterPassword, type the password used to connect to the telephone system.
 10. AfterConfirm password, type the password used to connect to the telephone system.
 11. If the 5000/Axxess is connected to a CT Gateway, underGateway settings, select This media server

belongs to a gateway and specify the Gateway ID.
 12. Click Save.
 13. Configure the location settings.

See "Configuring location settings for 5000/Axxess media servers" on page 87 .

Configuring location settings for 5000/Axxess media servers
To configure location settings for a 5000/Axxess media server
 1. Click the Location tab.
 2. AfterCountry, select the country where themedia server is located.

If you are setting up a node, select the country in which the node is located.
 3. AfterArea, select the area code where themedia server is located.

If you are setting up a node, select the area in which the node is located.
 4. AfterMinimum digits to dial locally, type theminimum number of digits dialed for a local call in your

city.
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 5. AfterMaximum digits to dial locally, type themaximum number of digits dialed for a local call in your
city.

 6. AfterOutbound dialing prefix, type the number you dial to access an outside line.
This information is required if you use a general business model and want to view when phone
extensions are active or inactive.

 7. Configure the data summary options.
See "Configuring data summary options for 5000/Axxess media servers" on page 88

Configuring data summary options for 5000/Axxess media servers
To configure data summary options for a 5000/Axxess media server
 1. Click theData summary options tab.
 2. If you want to use Trace reporting, select the Inbound/Outbound/Make Busy Trace reporting.
 3. If your business operates around the clock, select the This enterprise operates 24 hours a day check

box.
NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have agents
logged in to Contact Center Solutions applications overnight, youmay experience problems with shift-
related statistics, such as agent shift monitor andMake Busy Reason codes. For example, if logged in
to Contact Center Client overnight with aMake Busy Reason code, when you change theMake Busy
Reason code the following day, Contact Center Client will display “UnknownMake Busy code.” This
can be remedied by logging out of the application and logging back in.

 4. If you want to track outbound calls that were not answered, select theCredit unanswered outbound
calls check box.

 5. AfterDigits dialed prefix, type the digits that must precede a telephone number tomake an outbound
call.

 6. AfterDigits dialed postfix, type the digits that must follow a telephone number tomake an outbound
call.

 7. AfterMaximum monitors, specify themaximum number of MiTAI monitors.
 8. UnderAgent state timeout audit, afterClear line if agent Hold Time exceeds, select the number of

minutes or hours you are in a hold state before the telephone system clears the line.
 9. AfterClear line if agent primary Talk Time exceeds, select the number of minutes or hours you are in

a single state on the primary line (ACD line) before the system clears that line.
 10. AfterClear line if agent secondary Talk Time exceeds, select the number of minutes or hours you

are in a single state on the secondary line (non ACD) before the system clears that line.
 11. If you do not want to report on the secondary line (non-ACD and outbound calls), select the Ignore

agent secondary line activity check box.
 12. EnableReset MKB/DND time in realtime after call ends check box, if you want theMKB/DND time

to reset in real time when the call concludes.
 13. UnderACD options, if you want to file all ACD stream redundant events, select the File all ACD

stream redundant events check box.
 14. If you want to ignore data stream sequence number errors, select the Ignore stream sequence

number errors.
 15. Configure the data collection settings.

See "Configuring data collection settings for 5000/Axxess media servers" on page 89.
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Configuring data collection settings for 5000/Axxess media servers
To configure data collection settings for a 5000/Axxess media server
 1. Click theData collection tab.
 2. AfterOAI Listening Port, specify the port number.

The default Listening Port is 4000.
 3. Specify the Network Monitor settings.

See "Configuring Network Monitor settings for 5000/Axxess media servers" on page 89.

Configuring Network Monitor settings for 5000/Axxess media servers
To configure Network Monitor settings for a 5000/Axxess media server
 1. Click theNetwork Monitor tab.
 2. AfterAlarm name, select an alarm.
 3. If youmust create or modify an alarm that will warn you if data is not being collected for this media

server, click Manage alarms and configure an alarm.
See "Configuringmedia server alarms" on page 95.

 4. UnderNotify me during these business hours, afterSchedule name, select a schedule that reflects
the hours of operation for themedia server.

 5. If youmust create or modify a schedule for themedia server, click Manage schedule and configure a
schedule.
See "Creating schedules" on page 169.

 6. Click Save.

Adding a Multimedia Contact Center Email media server
You addMultimedia Contact Center Email media servers in YourSite Explorer.

Youmust first add theMultimedia Contact Center Email media server and then configure its options and
Network Monitor settings.

Adding Multimedia Contact Center Email media servers
To add aMultimedia Contact Center Email media server
 1. InYourSite Explorer, click Media servers.
 2. Click Add=>MCC Email.
 3. AfterName, type the name of themedia server.

NOTE: To distinguish between the various types of media for management and reporting purposes, you
must give eachmedia server a unique namewhen setting up your site.

 4. AfterSite, select the site where themedia server resides.
 5. AfterComputer name, select the computer where the server resides.
 6. Specify the options.

See "Configuring options for Multimedia Contact Center Email media servers" on page 90.
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Configuring options for Multimedia Contact Center Email media servers
To specify options for aMultimedia Contact Center Email media server
 1. Click theOptions tab.
 2. UnderGeneral

l Select theDelete messages from the Agents sent items folder that are older than x days
check box.

If you do not select this check box, themessages will remain until an administrator removes
them.

l AfterDelete messages from the Agents sent items folder that are older than, select the
number of days after which past messages will be deleted.

 3. UnderData summary options
l If you want trace reporting, select the Inbound/Outbound/Make Busy Trace Reporting check

box.
l If your business operates around the clock, select the This enterprise operates 24 hours a day

check box.
NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have
agents logged in to Contact Center Solutions applications overnight, youmay experience
problems with shift-related statistics, such as agent shift monitor andMake Busy Reason codes.
For example, if logged in to Contact Center Client overnight with aMake Busy Reason code,
when you change theMake Busy Reason code the following day, Contact Center Client will
display “UnknownMake Busy code.” This can be remedied by logging out of the application and
logging back in.

l EnableReset MKB/DND time in realtime after call ends check box, if you want theMKB/DND
time to reset in real time when the call concludes.

 4. Specify Network Monitor settings.
See "Configuring Network Monitor settings for Multimedia Contact Center Email media servers" on
page 90.

Configuring Network Monitor settings for Multimedia Contact Center
Email media servers
To configure Network Monitor settings for aMultimedia Contact Center Email media server
 1. Click theNetwork Monitor tab.
 2. AfterAlarm name, click ....
 3. Select an alarm from the list and click OK.
 4. If youmust create or modify an alarm that will warn you if data is not being collected for this media

server, click Manage alarms and configure an alarm.
See "Configuringmedia server alarms" on page 95.

 5. If you want to modify a schedule for themedia server, click Manage schedule.
See "Creating schedules" on page 169.

 6. Click Save.

Adding Multimedia Contact Center WebChat media servers
You addMultimedia Contact CenterWebChat media servers in YourSite Explorer.

Youmust first add theMultimedia Contact CenterWebChat media server and then configure its options and
Network Monitor settings.
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Adding Multimedia Contact Center WebChat media servers
To add aMultimedia Contact CenterWebChat media server
 1. InYourSite Explorer, click Media servers.
 2. Click Add=>MCC WebChat.
 3. AfterName, type the name of themedia server.

NOTE: To distinguish between the various types of media for management and reporting purposes, you
must give eachmedia server a unique namewhen setting up your site.

 4. AfterSite, select the site where themedia server resides.
 5. AfterComputer name, select the name of the Exchange Server computer.
 6. Specify the options.

See "Configuring options for Multimedia Contact CenterWebChat media servers" on page 91.

Configuring options for Multimedia Contact Center WebChat media
servers
To configure options for aMultimedia Contact CenterWebchat media server
 1. Click theOptions tab.
 2. UnderGeneral

l Select theDelete messages from the Agents sent items folder that are older than x days
check box.

If you do not select this check box, themessages will remain until an administrator removes
them.

l AfterDelete messages from the Agents sent items folder that are older than, select the
number of days after which past messages will be deleted.

 3. UnderData summary options
l If you want trace reporting, select the Inbound/Outbound/Make Busy Trace Reporting check

box.
l If your business operates around the clock, select the This enterprise operates 24 hours a day

check box.
NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have
agents logged in to Contact Center Solutions applications overnight, youmay experience
problems with shift-related statistics, such as agent shift monitor andMake Busy Reason codes.
For example, if logged in to Contact Center Client overnight with aMake Busy Reason code,
when you change theMake Busy Reason code the following day, Contact Center Client will
display “UnknownMake Busy code.” This can be remedied by logging out of the application and
logging back in.

l EnableReset MKB/DND time in realtime after call ends check box, if you want theMKB/DND
time to reset in real time when the call concludes.

 4. Specify Network Monitor settings.
See "Configuring Network Monitor settings for Multimedia Contact CenterWebChat media servers" on
page 91.

Configuring Network Monitor settings for Multimedia Contact Center
WebChat media servers
To configure Network Monitor settings for aMultimedia Contact CenterWebChat media server
 1. Click theNetwork Monitor tab.
 2. AfterAlarm name, click ....
 3. Select an alarm from the list and click OK.
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 4. If youmust create or modify an alarm that will warn you if data is not being collected for this media
server, click Manage alarms and configure an alarm.
See "Configuringmedia server alarms" on page 95.

 5. If you want to modify a schedule for themedia server, click Manage schedule.
See "Creating schedules" on page 169.

 6. Click Save.

Adding Multimedia Contact Center Fax media servers
You addMultimedia Contact Center Fax media servers in YourSite Explorer.

Youmust first add theMultimedia Contact Center Fax media server and then configure its options and
Network Monitor settings.

Adding Multimedia Contact Center Fax media servers
To add aMultimedia Contact Center Fax media server
 1. InYourSite Explorer, click Media servers.
 2. Click Add=>MCC Fax.
 3. AfterName, type the name of themedia server.

NOTE: To distinguish between the various types of media for management and reporting purposes, you
must give eachmedia server a unique namewhen setting up your site.

 4. AfterSite, select the site where themedia server resides.
 5. AfterComputer name, select the computer where the server resides.
 6. Specify the options.

See "Configuring options for Multimedia Contact Center Fax media servers" on page 92.

Configuring options for Multimedia Contact Center Fax media servers
To configure options for aMultimedia Contact Center Fax media server
 1. Click theOptions tab.
 2. UnderGeneral

l Select theDelete messages from the Agents sent items folder that are older than x days
check box.

If you do not select this check box, themessages will remain until an administrator removes
them.

l AfterDelete messages from the Agents sent items folder that are older than, select the
number of days after which past messages will be deleted.

 3. UnderData summary options
l If you want trace reporting, select the Inbound/Outbound/Make Busy Trace Reporting check

box.
l If your business operates around the clock, select the This enterprise operates 24 hours a day

check box.
NOTE: If you do not select the This enterprise operates 24 hours a day check box, but have
agents logged in to Contact Center Solutions applications overnight, youmay experience
problems with shift-related statistics, such as agent shift monitor andMake Busy Reason codes.
For example, if logged in to Contact Center Client overnight with aMake Busy Reason code,
when you change theMake Busy Reason code the following day, Contact Center Client will
display “UnknownMake Busy code.” This can be remedied by logging out of the application and
logging back in.

l EnableReset MKB/DND time in realtime after call ends check box, if you want theMKB/DND
time to reset in real time when the call concludes.



Contact Center Solutions User Guide

- 93 -

 4. Specify Network Monitor settings.
See "Configuring Network Monitor settings for Multimedia Contact Center Fax media servers" on page
93.

Configuring Network Monitor settings for Multimedia Contact Center
Fax media servers
To configure Network Monitor settings for aMultimedia Contact Center Fax media server
 1. Click theNetwork Monitor tab.
 2. AfterAlarm name, click ....
 3. Select an alarm from the list and click OK.
 4. If youmust create or modify an alarm that will warn you if data is not being collected for this media

server, click Manage alarms and configure an alarm.
See "Configuringmedia server alarms" on page 95.

 5. If you want to modify a schedule for themedia server, click Manage schedule.
See "Creating schedules" on page 169.

 6. Click Save.

Adding Intelligent Queue media servers
To add an Intelligent Queuemedia server
 1. In Contact Center Management, click YourSite=>Enterprise.
 2. Click Add a media server=>Intelligent Queue.
 3. AfterName, type the name of themedia server.
 4. AfterSite, select the site where this media server resides.
 5. After This media server is installed on the computer you named, select the computer on which the

media server is installed.
 6. Click Save.

Configuring data collection settings for Intelligent Queue media servers
To configure data collection settings for an Intelligent Queuemedia server
 1. Select an Intelligent Queuemedia server from the tree view.
 2. Click the Intelligent Queue Reporting data collection tab.
 3. UnderSpecify data collection settings, click TCP.
 4. Click IP Address, orDNS, and type the IP address, or name, of the Intelligent Queue server.
 5. AfterSMDR, type the SMDR port number of themedia server.
 6. If you will be entering ACD information, select ACD.
 7. AfterACD, type the ACD port number of themedia server.
 8. Click Save.
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Deleting media servers
CAUTION: If you delete amedia server, you will delete all of the devices associated to themedia server.

To delete amedia server in YourSite Explorer
 1. InYourSite Explorer, click Media servers.
 2. Select themedia server you want to delete.
 3. Click Delete.

A window opens with themessage “All of the data associated with this media server will be
permanently deleted. Are you sure you want to delete this media server?”

 4. Click OK.

To delete amedia server in the Contact Center Management website
 1. In Contact Center Management, click YourSite=>Enterprise.
 2. Expand the Enterprise tree and select themedia server to be deleted.
 3. Click Delete.

A window opens with themessage “All of the data associated with this media server will be
permanently deleted. Are you sure you want to delete this media server?”

 4. Click OK.

Network Monitor alarms
You can configure one or more data alarm schedules for your media servers. You specify the days and times
during which data alarms will be activated. For those days and times, the system will notify you if the
Enterprise Server Collector Service is not receiving data from your media servers, or if the server disk space
is low. The Low Disk Threshold setting detects if the disk space is low on the disk housing the text files and
SQL database. If the disk space is less than the threshold you specify, the system sets off an alarm.

In Network Monitor, you can verify if alarms are enabled for your media servers and if themedia servers are
reporting any alarms. The Network Monitor icon in your system tray is marked with a red line and blinks when
the system is reporting alarms. See "Viewing alarms" on page 345.

The list of alarms is as follows:
l Invalid configuration
l Node offline
l No alarms configured
l PBX PC time drift
l SMDR Record error
l ACD Sequence number error
l Exchange link down
l WebChat Server link down
l Alarm outside of business hours
l SMDR Link down
l SMDR Data timeout
l ACD Link down
l ACD Data timeout
l MiTAI link down
l Intelligent Queue SQL Server is down
l Intelligent QueueMessaging Service is down
l Intelligent Queue Callback Service is down
l Intelligent Queue Recording Service is down
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l Intelligent QueueMusic Service is down
l Intelligent QueueWatchdog Service is down
l Intelligent QueueMitel IP Emulation Service is down
l Intelligent Queue is missing an audio file
l Intelligent Queue has detected an incompatible audio file
l Intelligent Queue has no audio functions
l Intelligent Queue has detected aMiTAI error
l Intelligent Queue is low on disk space
l The agent callback destination is invalid. Please enter a valid agent callback destination.
l Due to a lack of available ports, all Updated position in queuemessages could not be sent. Please add

additional ports to the Updated position in queue port group or reduce the number of Updated position in
queuemessages to be sent.

Youmust configure Network Monitor alarms for SX-200media servers in the Contact Center Management
website. You configure Network Monitor alarms for 3300 ICP, 5000, and Axxess media servers in YourSite
Explorer.

Configuring media server alarms
In YourSite Explorer or in the Contact Center Management website, you set the days and times during which
data alarms will be activated and a threshold for low disk space. The Collector Service adheres to the settings
you specify.

To configure amedia server alarm in YourSite Explorer
 1. InYourSite Explorer, click Media server alarms.
 2. Click Add.
 3. AfterName, type the name of themedia server alarm.
 4. AfterSchedule, click ... and select the schedule that reflects the company’s hours of operation.

The schedulemust accurately reflect the hours and days of the week the business is open and data is
being received somedia server alarms are not activated after hours.

 5. After Low disk threshold, select the value in MB for the threshold below which you want themedia
server alarm to be activated. (For example, select 50. An alarm will be activated when the disk space is
less than 50MB).

 6. If you want to automatically restart the data ports in the event Collector Service detects a problem with
the Com ports, enable theAuto restart data ports check box.

 7. After Data alarm timeout minutes, select the duration of the time lapse inminutes from when the data
stops streaming to when you want the alarm to display.
This setting relates to the SMDR Data timeout and ACD Data timeout Network Monitor alarms.
NOTE: In a resilient environment, SMDR and ACD Data timeout alarms may trigger unnecessarily. To
prevent this, set Data alarm timeout minutes to zero.

 8. Click Save.

To configure amedia server alarm in the Contact Center Management website
 1. In Contact Center Management, click YourSite=>Network Monitor=>Configure alarms.

The Configure alarms window displays.
 2. Click Add.
 3. AfterName, type the name of themedia server alarm.
 4. AfterSchedule, select the schedule that reflects the company’s hours of operation.

The schedulemust accurately reflect the hours and days of the week the business is open and data is
being received somedia server alarms are not activated after hours.
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 5. After Low disk threshold, select the value in MB for the threshold below which you want themedia
server alarm to be activated. (For example, select 50. An alarm will be activated when the disk space is
less than 50MB).

 6. If you want to automatically restart the data ports in the event Collector Service detects a problem with
the Com ports, select theAuto restart data ports check box.

 7. After Data alarm timeout minutes, select the duration of the time lapse inminutes from when the data
stops streaming to when you want the alarm to display.
This setting relates to the SMDR Data timeout and ACD Data timeout Network Monitor alarms.
NOTE: In a resilient environment, SMDR and ACD Data timeout alarms may trigger unnecessarily. To
prevent this, set Data alarm timeout minutes to zero.

 8. Click Save.

YourSite database configuration
NOTE:

l The 5000/Axxess telephone system concept of hunt group will be referred to as queue or agent group
when used in conjunction with Contact Center Solutions. Hunt groups will be referred to as queues
when discussing routing and call treatment options. Hunt groups will be referred to as agent groups
when discussingmembership roles. Since the 5000/Axxess hunt group acts as both queue and agent
group, the telephone systems will not queue onmultiple hunt groups at the same time. However,
agents can be logged in tomultiple hunt groups simultaneously.

l YourSite Explorer enables you to havemultiple device tabs open simultaneously. As a best practice,
we recommend you only have the device tabs open that you are currently using.

In an ACD contact center using Contact Center Management there are twomain databases: the telephone
system database and the prairieFyre YourSite database. Your dealer is responsible for assessing your
contact center requirements and configuring the telephone system database accordingly. You are responsible
for configuring the YourSite database tomirror the trunk, extension, agent, agent group, queue, Account Code
numbers, and routing and timing options in use on the telephone system. This can be achieved quickly using
synchronization for the 3300 ICP, 5000, and Axxess. See "Performing synchronization" on page 104.

YourSite database permissions are based on teams and groups. In the YourSite database, you create
associations between devices and device groups in order to view real-time data and run reports.

Youmust
 1. Add employees.
 2. Add one or more agent login IDs for each employee.
 3. Associate the agent login IDs with the employees.
 4. Add agent groups.
 5. Associate the agent login IDs with agent groups.
 6. Add queues.
 7. Associate the agent groups with the queues for which they answer calls.

If you intend to run reports on extensions, queue groups, employee groups, trunks, trunk groups, DNIS
numbers, or Account Codes, youmust add these devices and device groups to the YourSite database also.
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Determining your contact center configuration needs
NOTE: If you are running Contact Center Management concurrently with Call Accounting, see theCall
Accounting User Guide for information on how to configure your system for Call Accounting.

If you want each of your employees to have one agent login ID only, then youmust set up your contact center
as described in configuration scenario 1. If you want your employees to have an agent login ID for each agent
group to which they belong, then youmust set up your contact center as described in configuration scenario 2.

Configuration scenario 1
In configuration scenario 1, an employee has one agent login ID. The employee belongs to four agent groups
that handle calls for four queues. The employee is simultaneously available to handle calls to all four queues
without having to log out of one queue and into another queue. (See Figure 6 - 3.)

Figure 6 - 3 Configuration scenario 1

NOTE: If you have the optional Multimedia Contact Center application, you can use the same agent login ID
across voice, email, chat, and/or fax media types. For example, in YourSite=>Configuration, you could add
Agent 1000, and associate Agent 1000 with voice, email, chat and/or fax media types.

In configuration scenario 1, you can use the employeeQuick Setup tool to create agent login IDs from
employee IDs. You add a range of employee IDs, and then select the Create an agent login ID for each
employee ID check box. Employee 1000 becomes Agent login ID 1000. On the Edit agent groupmembers
tab, you add Agent login ID 1000 to Agent groups 1 to 4. Using Agent login ID 1000, the employee is now
simultaneously available to handle calls for Agent groups 1, 2, 3, and 4. (See Figure 6 - 4.)



YourSite database configuration

- 98 -

Figure 6 - 4 Make the agent login IDs the same as the employee IDs
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Configuration scenario 2
In configuration scenario 2, employees are cross-trained and answer calls for various products and services.
The employees monitor call volumes in all of the queues for which they have been cross-trained. If an
employee notices a queue is particularly busy, the employee logs off of the telephone system and logs on with
an agent login ID associated with the busy queue. (See Figure 6 - 5.)

Figure 6 - 5 Configuration scenario 2

In configuration scenario 2, you can use the employeeQuick Setup tool to create agent login IDs from
employee IDs. You add a range of employee IDs and increment them according to the number of agent login
IDs you require for each employee. Then you select the Create an agent login ID for each employee ID check
box. Employee 1000 becomes Agent login ID 1000. On the Agent login window, youmanually add additional
agent login IDs for employees who are cross trained (Employee 1000 also becomes Agent login ID 1001,
Agent 1002, and Agent 1003). (See Figure 6 - 6.)

On the Edit agent groupmembers tab, you add each agent login ID to the appropriate agent group. Employees
are available to handle calls for one agent group at a time. If an employee is handling calls for Agent group 2
and notices the call volume is particularly busy for Agent group 4, the employeemust log off of the telephone
system and log on with an agent login ID associated with Agent group 4.
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Figure 6 - 6 Creating employee IDs for agents with multiple agent IDs

Configuring YourSite database devices
You can configure the YourSite database in the following ways:

l Synchronization
If you have a 3300 ICP, you can synchronize the YourSite database with the queues, agents (including
their skill level within each agent group), agent groups, agent skill groups, trunks, and extensions
programmed on the telephone system using Synchronization. You can perform Synchronization on
individual 3300 ICPs or all 3300 ICPs in your enterprise.
If you have a 5000, or Axxess, you can synchronize the YourSite database with the queues, agents,
agent groups, agent skill groups, trunks, and extensions programmed on the telephone system using
Synchronization. You can perform Synchronization on individual telephone systems or all telephone
systems in your enterprise.
See "Configuring the YourSite database using synchronization" on page 101.

l Active Directory synchronization
If you specified theWindows Authenticationmodel during the Contact Center Management / Call
Accounting ConfigurationWizard, you can synchronize your system with Active Directory at any time
from within YourSite Explorer. When you run Active Directory synchronization, employees in YourSite
Explorer are synchronized with users in Active Directory groups. If you useWindows Authentication
and Active Directory synchronization, users will not be prompted to authenticate themselves with a
username and password when they start Contact Center Solutions and Call Accounting applications.

l Quick Setup
If you want to add a range of devices (employees, employee groups, employee divisions, agent logins,
agent groups, queues, queue groups, extensions, extension groups, extension divisions, trunks, trunk
groups, DNIS, DNIS groups, Account Codes, Account Code groups, Make Busy Reason Codes, Do
Not Disturb Reason Codes, and teams) you can useQuick Setup.
See "Configuring devices and device groups using Quick Setup" on page 112.

l Comma-separated value (.csv) import
If you have a 3300 ICP, 5000, or Axxess. you can also add a range of devices (employee, employee
groups, employee divisions, agents, agent groups, queues, queue groups, extensions, extension
groups, extension divisions, trunks, trunk groups, DNIS, DNIS groups, Account Codes, Account Code
groups, Make Busy Reason Codes, Do Not Disturb Reason Codes, and teams) using .csv files.
See "Configuring devices using .csv files" on page 119.
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l Manual configuration
If you want to configure devices manually, see "Configuring devices manually" on page 123.

Configuring devices and device groups
The following devices and device groups are configured in YourSite Explorer and/or the Contact Center
Management website (under YourSite=>Configuration)

l Employees, employee groups
l Employee divisions
l Agents, agent groups
l Queues, queue groups, virtual queue groups
l Extensions, extension groups
l Extension divisions (YourSite Explorer only)
l Trunks, trunk groups
l DNIS (Dialed Number Identification Service), DNIS groups
l Account Codes
l Account Code groups (YourSite Explorer only)
l Make Busy Reason Codes
l DoNot Disturb Reason Codes (YourSite Explorer only)
l Phone numbers, phone number groups (YourSite Explorer only)
l Teams
l ANI (Automatic Number Identification) (Contact Center Management website only)
l Intelligent Queue Smart Choice layer, Intelligent Queue Smart Choice layer group, Intelligent Queue

extension, Intelligent Queue extension group, Intelligent Queue voice callback queue, Intelligent Queue
voice callback queue group, Intelligent QueueWeb callback queue, Intelligent QueueWeb callback
queue group and Intelligent Queue voice exit codes (Contact Center Management website only)

Configuring the YourSite database using synchronization
Synchronization functionality differs depending on the telephone system in use.

Synchronization for the 3300 ICP
YourSite Explorer enables you to configure and write 3300 ICP queues, agent skill groups, and agents
(including skill level), and validate/edit contact center related Class of Service, Class of Restriction, System
Options, and SMDR Options settings using synchronization.

During synchronization, the queues, agent skill groups, and agents configured in YourSite Explorer are written
to the telephone system. This enhanced functionality enables you to configure Contact Center Solutions
applications from your desktop. Validation of device and assignment form settings ensures quality data
collection and accurate reporting. After running synchronization, Class of Service and Class of Restriction
settings programmed in the telephone system can be edited in YourSite Explorer.

During synchronization, administrators can preview device changes, identify devices that should be excluded
from synchronization, andmanage the business rules related to synchronization of device names and
associated device creation.

While synchronizing data, the telephone system continues to operate without experiencing downtime. After
synchronization is complete, the Contact Center Client applications open on agent desktops will be refreshed
with a device update. After synchronization is complete, all critical programming, such as SMDR Options,
System Option, Class of Service, and Class of Restriction settings will be validated. A report is then
generated to summarize the results of synchronization. We highly recommend that you correct invalid
programming, as detailed on the Telephone system settings tab of media servers in YourSite Explorer,
immediately.
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In Mitel 3300 releaseMCD 4.0 SP2, configuring your network using SDS Directory synchronizationmode is
optional. Customers can continue to operate in the Classic mode, with OPS Manager if operating in a
clustered environment. In Mitel 3300 releaseMCD 4.1, configuring your network using SDS Directory
synchronizationmode is mandatory for all sites operating with 20 nodes or less.

Classic mode synchronization
Using YourSite Explorer and the 3300 ICP in Classic mode, you can add, edit, and delete standard agents,
agent groups, and queues, as well as ACD related Class of Service (COS), Class of Restriction (COR),
SMDR Options, and System Options. When not in a clustered environment, you can also continue to add hot
desk agents and all synchronization device names. Adding hot desk agents in a clustered environment
requires the use of Mitel OPS Manager.

SDS Directory synchronization mode
Using YourSite Explorer and the 3300 ICP in SDS Directory synchronizationmode, you can now add, edit and
delete standard and hot desk agents, agent groups, queues, trunks, trunk groups, and extensions,
synchronize device names, as well as ACD related Class of Service (COS), Class of Restriction (COR)
SMDR options and System Options in both a single site and in a clustered environment. When operating in
SDS Directory synchronizationmode, you can configure Network ACD queue set up on the 3300 ICP without
any manual configuration previously required usingMitel OPS Manager.

NOTE:
l You can only use synchronization to synchronize the YourSite database with resilient, Network ACD,

and clustered telephone systems if you are using 3300 ICP ReleaseMCD 4.0 SP2 or greater, with the
SDS Directory synchronization option enabled on all of the telephone systems in your enterprise.

l If you edit the feature access code used for silent monitoring on themedia server, youmust also
manually edit the feature access code on the telephone system. The feature access code entered in
YourSite Explorer must be identical to that on the telephone system and be valid for use with silent
monitoring. See "Editing System options" on page 109.

l Intelligent Queue port settings are not programmed during synchronization.

Synchronization for the 5000 and Axxess
If you have a 5000 or Axxess, you can synchronize the YourSite database with the queues, agents, agent
groups, extensions, Do Not Disturb Reason codes, and trunks programmed on the telephone system using
synchronization.

NOTE: The device write-back functionality available in YourSite Explorer for the 3300 ICP is not currently
available for the 5000 and Axxess telephone systems.

During synchronization, queues, agents, extensions, Do Not Disturb Reason codes, and trunks programmed
on the 5000 or Axxess will be synchronized with the YourSite database. Reporting numbers for queues and
agent groups will be automatically generated during synchronization.

NOTE: If agents, queues, and extensions on the telephone system have the same reporting or dialable
number as the devices programmed in the YourSite database, but they do not have the same name,
synchronization will change the name of the device in the YourSite database tomatch the name of the device
on the telephone system.

For Network ACD environments, synchronization looks for agents configured in the cluster. If not found,
agents are added to themedia server being synchronized. Once agents are created, or matches are found,
agent group associations are synchronized for those agents. Agent name changes are only synchronized for
the agent's primary media server. Name changes found on other telephone systems are ignored.
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While synchronizing data, the telephone system continues to operate without experiencing downtime. After
synchronization is complete, the Contact Center Client applications open on agent desktops will be refreshed
with a device update. After synchronization is complete, all critical programming will be validated. A report is
then generated to summarize the results of synchronization. We highly recommend that you correct invalid
programming, as detailed in the report, immediately.

Preparing for synchronization
NOTE:

l Superset phones are not currently supported for synchronization. See theMitel Contact Center
Solutions and Call Accounting System Engineering Guide for a list of devices that are supported for
synchronization.

l Only Mitel telephones that are programmed on the IP Multiline set assignment form will synchronize
with the YourSite database. For details on the phones that are supported, please refer to your Mitel
3300 ICP documentation.

Before you perform synchronization for the 3300 ICP
l Ensure the 3300 ICP is V8.x or greater. You can only use synchronization to synchronize the YourSite

database with resilient, Network ACD, and clustered telephone systems if you are using 3300 ICP
ReleaseMCD 4.0 SP2 or greater, with the SDS Directory synchronization option enabled on all of the
telephone systems in your enterprise.

l Ensure that you have completed programming the 3300 ICP and created a username and password for
synchronization (on the 3300 ICP User Authorization Profile form). The 3300 ICP User Authorization
Profile must include Application Access and System Admin Access. Desktop Admin andGroup Admin
options can be disabled. These steps must be completed for all 3300 ICPs in your Enterprise.

l Ensure your MiXML service is started by navigating to the Control Panel inWindows and selecting
"MiXML". Verify that port 18000 is entered on the Settings tab and click Start.

l Ensure that yourWindows or Corporate firewall is not blocking the following ports
l SOAP: 18000 (HTTPS)
l UDP: 53
l TCP: 7011
l TCP: 22
l TCP: 443 (SSH)

l Configure the user name and password for each of the 3300 ICP media servers in YourSite Explorer.
See theContact Center Management Installation Guide.

l If you havemultiple NICs on your Enterprise Server, youmust specify the NIC to use for synchronizing
data to the telephone system. To do this, navigate to the Control Panel inWindows and select
"MiXML". After NIC IP Address specify the primary NIC to be used to send back data to the telephone
system.

l If you are running 3300 ICP Release 9.x or earlier, resilient Network ACD, and clustered telephone
systems must be programmed using OPS Manager, RDNs, and cluster element IDs. 3300 ICPs
programmedwith Remote Agent Subgroups and ARS are not supported. Contact Center Management
clusters and cluster element IDs must match what is programmed on the telephone system.

Before you perform synchronization for the 5000 and Axxess
l If you have a 5000, ensure it is Version 2.20 or greater. If you have an Axxess, ensure it is Version

10.00 or greater.
l Ensure that you have programmed anOAI IP address and port number on the 5000/Axxess.
l If there is a firewall between your Enterprise Server and the 5000/Axxess, ensure that yourWindows or

corporate firewall is not blocking port 4000 (TCP).
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Specifying synchronization settings
YourSite Explorer enables you to specify the synchronization settings, read options, and write options used
by synchronization. When you select amedia server in YourSite Explorer, the following synchronization
options are available from the ribbon, on the Telephone system tab:

l Settings
l Disabled
This option will fully disable synchronization.

l Read
This option will read devices programmed on your telephone systems and synchronize them with
the YourSite database.

l Read/Write
This option will read the devices programmed on your telephone systems and synchronize them
with the YourSite database and enable devices programmed in YourSite Explorer to be written to
the telephone systems.

l Read Options
l Create employees with new agent
For every new agent added to the YourSite database, a new employee will be created and
associated with the agent.

l Create employees with new extensions
For every new extension added to the YourSite database, a new employee will be created and
associated with the agent.

l Use telephone system device names
Override device names programmed in YourSite Explorer with the device names configured on
the telephone system.

l Default employee license
Select the default employee license that you want to be applied when synchronizing new agents.
Contact Center Enterprise Edition default employee licenses include None, Basic, Standard,
Advanced, and Premium employees. Contact Center Business Edition default employee
licenses include None, Reporting, and Desktop employees.

l Write Options
l Update telephone directory names
Override telephone directory names with agent, agent group, queue, and extension names
configured in YourSite Explorer.

Performing synchronization
There are two ways to perform synchronization:

l Full synchronization
Running full synchronization will synchronize the devices programmed on the telephone system and
enable you to review all devices, and optionally exclude any devices, before committing changes to
YourSite Explorer.

l Telephone system settings synchronization
Running telephone system settings synchronization will read the current telephone system settings
and enable you to view any errors or warnings related to the telephone system configuration.
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NOTE:
l You can only use synchronization to synchronize the YourSite database with resilient, Network ACD,

and clustered telephone systems if you are using 3300 ICP Release 10.0 (MCD 4.0 SP2) or greater,
with the SDS Directory synchronization option enabled on all of the telephone systems in your
enterprise.

l As a best practice, we recommend all new installations run Full synchronization to ensure the
telephone systems in your enterprise are synchronized with the YourSite database and that there are no
critical telephone system programming errors.

l Youmust program your 3300 ICPs and perform synchronization before you can configure telephone
system assignment form options in YourSite Explorer.

l We recommend you do not exchange the reporting number of one device with that of another device.
l Synchronization will not synchronize a device being added to the YourSite database with the telephone

system if the device has the same reporting number as an existing device with a different dialable
number.

l If you run synchronization for a 3300 ICP media server containing a queue that has not been configured
in YourSite Explorer a default 24/7 business hour schedule will be applied to that queue.

l If you are synchronizing a single telephone system, agents and queues must be programmed on the
same telephone system. Single node synchronization can disassociate agents and queues if agents
and queues reside on separate telephone systems.

l If you are running 3300 ICP Release 9.x or earlier and you synchronized your network ACD
assignments and/or resilient agents using OPS Manager, youmust synchronize all of the 3300 ICPs in
your enterprise. Otherwise, agent group and queue group associations will be lost.

To perform full synchronization
 1. In YourSite Explorer, underEnterprise, click Media servers.
 2. Select a 3300 ICP or a 5000/Axxess media server from the list.
 3. Click the Telephone system tab.
 4. In the ribbon, specify the settings to use with synchronization.

See "Specifying synchronization settings" on page 104.
 5. In the ribbon, click Run.

The Synchronization window opens.
 6. Select themedia servers to synchronize.
 7. Ensure Full synchronization is selected.
 8. If this is the first time you have run synchronization, click Synchronize and continue to step 11. If you

have already run full synchronization, click Next.
 9. Optionally, select the telephone systemmedia servers and devices to include with synchronization.

All media servers and devices are selected by default.
 10. Specify how you would like to proceed with synchronization:

l Synchronize—selecting this option will synchronize the devices programmed on the telephone
system and enable you to review all entries and optionally exclude any devices before committing
them to YourSite Explorer. If you select this option, continue to step 11.

l Save settings—selecting this option will save the device settings you specified to be used for the
next scheduled or on-demand synchronization. If you select this option, the synchronization window
will close.

l Cancel—selecting this option will cancel the synchronization. No changes will bemade to YourSite
database or the telephone systems. If you select this option, the synchronization window will close.

l Auto commit—selecting this option and clicking Synchronize will synchronize the devices
programmed on the telephone systems and automatically commit them to YourSite Explorer. There
will be no opportunity for you to review the entries and optionally exclude any devices before
committing them to YourSite Explorer.
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 11. When the synchronization report displays, you have the following three options:
l Commit—selecting this option will commit the specified changes and synchronize telephone

system devices with YourSite Explorer.
l Cancel—selecting this option will cancel the specified changes. No devices will be synchronized

and the synchronization window will close.
l Edit—selecting this option will rerun synchronization and enable you tomodify the devices to be

included in synchronization. If you select this option, return to step 9.
If this is the first time you have run synchronization, any telephone system errors and warnings will
display in the synchronization report. You can correct any errors or warnings found in this report by
clicking Edit, clicking the Telephone system settings tab and changing the telephone systems settings
to the recommended settings. If this is not the first time you have run synchronization, the
synchronization window will close once it is complete and you can review any telephone system
setting errors and warnings on by selecting amedia server in YourSite Explorer and clicking the
Telephone system settings tab.

To perform telephone system synchronization
 1. In YourSite Explorer, underEnterprise, click Media servers.
 2. Select a 3300 ICP or a 5000/Axxess media server from the list.
 3. Click the Telephone system tab.
 4. In the ribbon, specify the settings to use with synchronization.

See "Specifying synchronization settings" on page 104.
 5. In the ribbon, click Run.

The Synchronization window opens.
 6. Select themedia servers to synchronize.
 7. Ensure Telephone system settings is selected.
 8. Click Synchronize.

The Synchronization report window will open and display the progress and status of the
synchronization. Once synchronization is complete, any telephone system errors and warnings will
display in the synchronization report. You can correct any errors or warnings found in this report by
clicking Edit, clicking the Telephone system settings tab and changing the telephone systems settings
to the recommended settings.

Viewing Synchronization reports
NOTE: The Synchronization report is currently available in English only.

To view a Synchronization report
 1. In Contact Center Management, click Tools=>Administrative tools=>Administrative reports.
 2. AfterStatus, click View.

Understanding Synchronization reports
After you perform Synchronization, a report summarizing the results of the synchronization is generated. The
Synchronization report contains a synchronization summary, synchronization details, validation results, and
any warnings and errors. Table 6 - 3 describes the information provided in the Synchronization report.
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Table 6 - 3 Synchronization report overview

Contents Description

Synchronization
Summary

For eachmedia server in your enterprise, the number of devices added and updated are
listed.

A license summary is also included in the Synchronization Summary section of the
Synchronization report. The License Summary lists the number of employee licenses
added and the number of licenses that remain. If you have exceeded the number of
employee licenses you currently own, a warning will be displayed and you will be
instructed to resolve the problem.

Synchronization
Details

The Synchronization Details section of the Synchronization report lists specific details
that pertain to the devices added and updated, or associations made or deleted during
the synchronization.

Validation
Results

The Validation Results section of the Synchronization report lists any system and
device level warnings and any critical programming errors.

Warnings TheWarnings section of the Synchronization report lists any non-critical warnings that
may have affected the results of the synchronization process. We highly recommend
that you immediately correct any invalid programming that may have caused warnings
to display.

Errors The Errors section of the Synchronization report lists any critical errors that would have
prevented synchronization from occurring. If critical errors are detected, the
Synchronization report will display theWarnings and Errors sections of the report only.
We highly recommend you immediately correct any invalid programming that may have
caused the error, to ensure your contact center functions properly.

Subscribing to the Synchronization report RSS feed
You can subscribe to a Really Simple Syndication (RSS) feed using a RSS aggregator of your choice (for
example, Microsoft Outlook or Internet Explorer), so you are informed every time a Synchronization report is
generated. RSS enhances management productivity because you can automatically receive reports without
having to browse to the Administrative Reports inbox in Contact Center Management.

To subscribe to the Synchronization report RSS feed
 1. In Contact Center Management, click Tools=>Administrative tools=>Administrative reports.
 2. Click Access RSS feed.
 3. Click Subscribe to this feed.
 4. Follow the steps required by your RSS aggregator to subscribe to the Synchronization report feed.

NOTE:When you browse to a webpage that contains RSS information, the orange RSS button displays next
to the Home icon.
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To add a RSS feed throughMicrosoft Internet Explorer 7+
 1. Click the RSS feed button.

A list of all available RSS feeds on theWeb page is displayed.
 2. Click the RSS feed you want to subscribe to.

You can optionally click theRSS orXML buttons in theWeb page to subscribe to a RSS feed.

To add a RSS feed throughMicrosoft Office Outlook 2007
 1. On the Tools menu, click Account Settings.
 2. On theRSS Feeds tab, click New.
 3. In theNew RSS Feed dialog box, type or copy and paste the URL of the RSS feed, for example,

http://www.example.com/feed/main.xml.
 4. Click Add.
 5. Click OK.

Active Directory synchronization
You can synchronize your system with Active Directory at any time from within YourSite Explorer.

Active Directory is a directory service created by Microsoft that is used for managing a domain. Active
Directory Synchronization will align Active Directory security groups and users with Contact Center
Management / Call Accounting employees and employee groups within selected organizational units.

At any time, you can optionally re-synchronize or reset all client computers running Contact Center Solutions
and Call Accounting applications and refresh them with the latest configuration changes. Re-synchronizing
will send a delta of the latest configuration changes to client computers, while resetting will completely drop
client computer configurations and send the latest configurations from YourSite Explorer.

When you run Active Directory synchronization, employees and employee groups in YourSite Explorer are
synchronized with users in Active Directory groups.

To run Active Directory synchronization
 1. In YourSite Explorer, underYourSite, click Enterprise orEmployees.
 2. On the ribbon, click Active Directory.
 3. UnderSync frequency, select how often you want automatic synchronization to occur.

The default frequency is every hour.
 4. Click Sync paths.

The Select paths to sync window opens.
 5. Click > or < to add or remove Active Directory entities from the Active Directory tree on the left to the

selected items list on the right and click OK.
The list of selected items on the right includes the Active Directory entities that will be synched.

 6. UnderSecurity Role, click ...and select a default security role to apply to newly created employees.
 7. Click OK.
 8. UnderSites, click ... and select a default site to apply to newly created employees.
 9. Click OK.
 10. Click Run.

Active Directory synchronization is initiated and pertinent information is updated in YourSite Explorer.

To send recent configuration changes to client computers
 1. In YourSite Explorer, underYourSite, click Enterprise orEmployees.
 2. On the ribbon, click Tools.
 3. Click Re-synchronize clients.
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To completely reset client computers with the latest YourSite database configuration information
 1. In YourSite Explorer, underYourSite, click Enterprise orEmployees.
 2. On the ribbon, click Tools.
 3. Click Reset clients.

Editing telephone system assignment forms
After you run Synchronization for the 3300 ICP in YourSite Explorer, you can edit a subset of contact center
related 3300 ICP System Options, SMDR Options, Class of Service, and Class of Restriction assignment
forms. Any changes made to the telephone system assignment forms in YourSite Explorer are written to the
telephone system when a user clicks Save.

After running Active Directory Synchronization, if the 3300 ICP System options, SMDR options, Class of
Service options, or Class of Restriction assignment forms are incorrectly configured, alerts will display
describing what modifications need to bemade to achieve accurate telephone system settings.

NOTE:Youmust have read/write capabilities enabled in YourSite Explorer before running Active Directory
synchronization if you want to receive these alerts. See "Specifying synchronization settings" on page 104.

Editing System options
Using YourSite Explorer, you can configure access codes and select options for the ACD 2000, ACD Real-
time Events Feature Level, and ACD Make Busy Walk Away Codes. Recommended values for these system
options are displayed in YourSite Explorer

To edit System Options
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderEnterprise, click Media servers.
 3. UnderMedia servers, select a 3300 ICP media server.
 4. Click the Telephone system settings tab.
 5. In the left pane, click System options.
 6. After Feature access code for silent monitoring, type the feature access code used for silent

monitoring, as programmed on the telephone system.
NOTE: If you edit the feature access code on themedia server, youmust alsomanually edit the feature
access code on the telephone system. The feature access code entered in YourSite Explorer must be
identical to that on the telephone system and be valid for use with silent monitoring.

 7. Specify remaining system options as required.
 8. Click Save.

Editing SMDR options
Using YourSite Explorer, you can edit a subset of contact center related SMDR options. YourSite Explorer
displays the recommended value for these SMDR options.

To edit SMDR Options
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderEnterprise, click Media servers.
 3. UnderMedia servers, select a 3300 ICP media server.
 4. Click the Telephone system settings tab.
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 5. In the left pane, click SMDR options.
 6. Specify the SMDR options.
 7. Click Save.

Editing Class of Service options
Using YourSite Explorer, you can edit a subset of contact center related Class of Service options. YourSite
Explorer displays the recommended value for these Class of Service options.

NOTE: When first provisioning or changing work timer values, youmust synchronize with your telephone
system. See "Performing synchronization" on page 104.

To edit Class of Service options
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderEnterprise, click Media servers.
 3. UnderMedia servers, select a 3300 ICP media server.
 4. Click the Telephone system settings tab.
 5. In the left pane, click Class of Service.
 6. UnderName, select the Class of Service to edit.
 7. In the right pane, afterDefault type, select a default class of service. Alternatively, select None and,

afterComment, type a description for the Class of Service.
 8. Specify the remainder of system options for each Class of Service.

NOTE:Work timer durations are dependent upon your telephone system.
l MCD 5.0 and greater – 4 hours maximum
l MCD 4.x or earlier – 10minutes maximum

 9. Click Save.

Editing Class of Restriction options
Using YourSite Explorer, you can edit a subset of contact center related Class of Restriction options.

To edit Class of Restriction options
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderEnterprise, click Media servers.
 3. UnderMedia servers, select a 3300 ICP media server.
 4. Click the Telephone system settings tab.
 5. In the left pane, click Class of Restriction.
 6. UnderNumber, select the Class of Restriction to edit.
 7. AfterDo you want this Class of Restriction to be the default setting, click Yes orNo
 8. AfterClasses of restriction for the group, enter the Class of Restriction numbers to include in the

group.
A range of numbers may be specified. Separate numbers using commas or dashes. For example, 1
though 9may be entered as 1-9 or a combination of individual numbers and ranges may be entered as
1,2,3,7-10,13.
NOTE:Class of Restriction numbers must be entered in ascending order within each group.

 9. Click Save.
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Adding resilient and/or Network ACD hot desking agents
Resiliency and network ACD functionality is configured in your Mitel telephone system. For information on
configuring your telephone system for resilient and/or network ACD hot desking agents, consult your Mitel
telephone system documentation.

When your telephone systems are set up correctly for resiliency and network ACD hot desking, you can
configure your media servers in YourSite Explorer to use hot desking agents. See "Adding 3300 ICP media
servers" on page 75.

Invalid ACD cluster programming
Combining traditional ACD agents and ACD hot desking agents on the same telephone system is not
supported. All media servers within a cluster must be configured with the same type of agents. If the
telephone systems within a cluster are configured with both ACD hot desking agents and traditional ACD
agents, agent states will not display correctly in Contact Center Client real-timemonitors and you will receive
an "Invalid ACD cluster programming" error in YourSite Explorer.

The "Invalid ACD cluster programming" error is displayed when the following conditions aremet
l One ormoremedia servers in a cluster are programmedwith both traditional and ACD hot desking

agents and/or
l Themedia servers in a cluster are not programmedwith the same type of ACD agents

NOTE: As a best practice, we recommend you perform Synchronization before attempting to resolve any
invalid ACD cluster programming errors on the telephone system. This will ensure that your configuration is
accurate and any errors being reported are valid.

The following scenarios provide examples of different invalid ACD cluster programming, with the problem
areas identified in red text.

Scenario 1
In the scenario shown in Table 6 - 4, media servers with mixed agent types are programmed in YourSite
Explorer.

Table 6 - 4 Invalid ACD agent programming scenario 1

Cluster name: Primary

Media
Server

YourSite Explorer
agent type

3300 ICP
agent type

Invalid agent type
programming

Kanata 3300
5th floor

Hot desking Hot desking No

Kanata 3300
7th floor

Traditional Traditional No

Scenario 2
In the scenario shown in Table 6 - 5, media servers have the correct agent type settings programmed in
YourSite Explorer, but havemixed agent types programmed against a single 3300 ICP.
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Table 6 - 5 Invalid ACD agent programming scenario 2

Cluster name: Master

Media
Server

YourSite Explorer
agent type

3300 ICP
agent type

Invalid agent type
programming

Kanata 3300
5th floor

Traditional Hot desking /
Traditional

Yes

Kanata 3300
7th floor

Traditional Traditional No

Formore information on ACD agent programming, see theMitel 3300 System Administration Tool Help, which
can be found at http://edocs.mitel.com/default.htm.

Configuring devices and device groups using Quick Setup
If you have a 3300 ICP or 5000/Axxess telephone system, you add a range of contact center devices in
YourSite Explorer using Quick Setup.If you have an SX-200 ACD, youmust configure your systemmanually.
See "Configuring devices manually" on page 123.

NOTE:Quick Setup is not offered in the Data grid view.

In the Contact Center Management website under YourSite=>Configuration, if youmove your mouse over the
Configurationmenu on the left side of the Configuration window, themenu displays devices you can
configure. Moving your mouse over the arrows to the right of these devices exposes additional devices.
Alternatively, you can click the Configurationmenu to view the complete list of devices to configure.

You can add a range of employee and agent login IDs in one action with Quick Setup, or you can add
employee and agent login IDs manually on their respective windows. Using Quick Setup is faster and less
tedious than adding individual employee and agent login IDs. However, if you want to use existing numbers
for employee IDs (for example, the first three numbers of each employee’s social security number), then you
must add the employee and agent login IDs manually.

You can useQuick Setup to add ranges of the following devices:
l Employees and employee groups
l Employee divisions
l Agents and agent groups
l Queues (Contact Center Management website only)
l Queue groups and virtual queue groups
l Extensions and extension groups
l Extension divisions (YourSite Explorer only)
l DNIS and DNIS groups
l Account Codes
l Account Code groups (YourSite Explorer only)
l Make Busy Reason Codes
l Teams
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Employee Quick Setup
NOTE:

l When you create employee IDs and agent login IDs, group all of the employees together from each site,
and then group all of the employees together who have similar contact characteristics. For example, if
half of the employees at a site will be voice agents (similar characteristic) and half of the employees will
be email agents (similar characteristic), then group the voice agents together and group the email
agents together. Using Quick Setup, you create the employee IDs and agent login IDs for the voice
agents group, and then create the employee IDs and agent login IDs for the email agents group.

l If you are upgrading a Contact Center Management (voice) employee to aMultimedia Contact Center
(voice, email, and/or chat) employee, before you useQuick Setup, youmust assign a folder to the
employee prior to assigning the employee an agent login ID. To do so, click
Configuration=>Employee=>Employee=>Edit, and update theMultimedia Contact Center properties
for the employee.

If you have an SX-200, you add a series of employees in the Contact Center Management website under
YourSite=>Configuration, Employee=>Employee.

If you have a 3300 ICP, 5000, or Axxess, to add a series of employees
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employees.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

postfix type the prefix and/or postfix.
 6. On the Licensing tab, for Contact Center Enterprise Edition users,

l UnderEmployee license, depending on licensing, select from None, Basic, Standard,
Advanced, orPremium employee.
See "Configuring general information and licensing information (in YourSite Explorer)" on page
124 for a description of each employee type.

l UnderSupervisor license, depending on licensing, select from None, Advanced, orSystem
Administrator.
See "Configuring general information and licensing information (in YourSite Explorer)" on page
124 for a description of each supervisor type.

l UnderPhone type license, depending on licensing, select whether the employee will use a
Mitel desk phone orContact Center Softphone.
NOTE: If the employee requires the use of Contact Center Softphone in addition to or in
combination with aMitel desk phone, select the Softphone endpoint. Contact Center Softphone
licensing is available to Advanced or Premium employees.If the employee is a non-ACD
employee (designated as employee type 'None'), youmust select 'Licensed for integrated client'
to have access to Contact Center Softphone functionality.

l UnderWorkforce Scheduling license, select the Licensed for Workforce Scheduling check
box if you want the employee to be scheduled usingWorkforce Scheduling.
NOTE:Workforce Scheduling licensing is only available to Basic, Standard, Advanced, or
Premium employees.

l Under Integrated client license, select Licensed for integrated clients if this is a non-ACD
employee who needs access to Contact Center PhoneSet Manager, CTI Toolkit Client, or
Salesforce.com Client.
See theContact Center Solutions and Call Accounting System Engineering Guide for in-depth
licensing information.
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l UnderScreen Pop license, select Licensed for Screen Pop if this is a non-ACD employee
(designated as employee type 'None') who needs access to Contact Center Screen Pop.
Integrated Client is required for non-ACD users to use screen pop.

 7. On the Licensing tab, for Contact Center Business Edition users,
l UnderEmployee license, depending on licensing, select from None, Reporting, orDesktop

employee.
See "Configuring general information and licensing information (in YourSite Explorer)" on page
124 for a description of each employee type.

l UnderSupervisor license, depending on licensing, select from None orDesktop supervisor.
See "Configuring general information and licensing information (in YourSite Explorer)" on page
124 for a description of each supervisor type.

l UnderPhone type license, depending on licensing, select whether the employee will use a
Mitel desk phone orContact Center Softphone.
NOTE: If the employee requires the use of Contact Center Softphone in addition to or in
combination with aMitel desk phone, select the Softphone endpoint. If the employee is a non-
ACD employee (designated as employee type 'None'), youmust select 'Licensed for integrated
client' to have access to Contact Center PhoneSet Manager, CTI Toolkit Client, or
Salesforce.com Client functionality.

l Select whether the employee will be licensed forScreen Pop, Integrated Client, and
Multimedia Contact Center by selecting the applicable check boxes.
See theContact Center Solutions and Call Accounting System Engineering Guide for in-depth
licensing information.

 8. If you want to create an agent login ID for each employee, on theAgent Associations tab, select the
Create an agent login ID for each employee check box.
NOTE: It is recommended you create agent login IDs from employee IDs.

 9. Select themedia server and failover media server the agent will use.
NOTE: If the employees are resilient, they can be associated with only one voicemedia server per
cluster and you can select the failover media server for the employees.

 10. AfterStart the agent login IDs at, type the first agent login ID number to associate to the employee ID
range.

 11. After Increment the agent login IDs by, type the increment by which the agent login ID numbers will
increase.

 12. If you want to create an extension for each employee, on theExtension associations tab, select the
Create an extension number for each employee check box.

 13. Select themedia server and failover media server the extension will use.
 14. If the extension will be costed with Call Accounting, select theCost this extension check box.
 15. AfterStart the extension numbers at, type the first extension number to associate with the employee

ID range.
 16. After Increment the extension numbers by, type the increment by which the extension numbers will

increase.
 17. If you want to create Account Code associations, on theAccount Code associations tab, select the

Create anAccount Code for each employee check box.
 18. AfterStart the Account Code numbers at, type the first Account Code number to associate to the

employee ID range.
 19. After Increment the Account Code numbers by, type the increment by which the Account Code

numbers will increase.
 20. Click Run.
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Agent Quick Setup
NOTE:You cannot useQuick Setup to create agent login IDs for aMultimedia Contact Center Email media
server.

If you have an SX-200, you add a series of agents in the Contact Center Management website under
YourSite=>Configuration, Agent login=>Agent login.

If you have a 3300 ICP, 5000, or Axxess, to add a series of agents.
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Agents.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

postfix type the prefix and/or postfix.
 6. On theGeneral tab, afterAssociate the devices to this media server, click ... and select amedia

server.
 7. If you want to create an employee ID for each agent, on theAgent Associations tab, select theCreate

an employee ID for each agent check box.
NOTE: Select this check box only if you have not already added employee IDs to the database.

 8. AfterStart the employee IDs at, type the first employee ID number to associate with the agent
reporting number range.

 9. After Increment the employee IDs by, type the increment by which the employee ID numbers will
increase.

 10. If you want to append a prefix to the agent reporting number, on theReporting numbers tab, select the
Append a prefix and/or postfix to the reporting number check box and type a prefix and/or postfix.

 11. Click Run.

Queue Quick Setup
If you have an SX-200, 3300 ICP, or 5000/Axxess, to add a series of queues
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Queue=>Queue.
 3. Click Quick Setup.
 4. Select a site and themedia server the queues will use.
 5. In theActive number from andActive number to boxes, type a range of queue numbers.
 6. On theGeneral tab, if you want to add a prefix or postfix to this range of queue numbers, select the

Append a prefix and/or a postfix to the device name check box and type the prefix and/or postfix.
 7. If you want to add a prefix or postfix to the range of dialable numbers, select theAppend a prefix

and/or a postfix to the dialable number check box and type the prefix and/or postfix.
 8. On theMetrics tab, afterShort Abandon, type the Short Abandon threshold (in seconds) for the

queues.
 9. AfterShort Talk, type the Short Handle threshold (in seconds) for the queues.
 10. After The goal for this queue is to handle, type the Service Level Percent objective for the queues.
 11. After% of calls in less than, type the Service Level Time objective for the queues.
 12. If you selected a 3300 ICP media server, click theMiTAI tab and complete steps 14 to 16.
 13. AfterBusiness hours, select the business hours of themedia server.
 14. If the queues are unavailable outside of business hours, select theSet the queue to unavailable

outside of these business hours check box.
 15. Select theAuto-synchronize the YourSite database with the telephone system check box.
 16. Click Run.
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Extension Quick Setup
If you have an SX-200, you add a series of extensions in the Contact Center Management website under
YourSite=>Configuration, Extension=>Extension.

If you have a 3300 ICP, 5000, or Axxess, to add a series of extensions
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Extensions.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

Postfix type the prefix and/or postfix.
 6. On theGeneral tab, select amedia server and a failover media server for the extension.
 7. If the extension will be costed with Call Accounting, select the Cost this extension check box.
 8. Select theDisable real-time monitoring and data collection on this device check box if you do not

want to enable the extension to be set with aMiTAI monitor, viewed in Contact Center Client, and use
Contact Center Softphone or Salesforce.com Connector.
By default, this check box is not selected.

 9. UnderAdvanced options, select theExtension type.
 10. If you want to create an employee for each extension, on theEmployee associations tab, select the

Create an employee ID for each extension check box.
NOTE:Select this check box only if you have not already added employee IDs to the database.

 11. AfterStart the employee IDs at, type the first employee ID to associate to the extension number
range.

 12. After Increment the employee IDs by, type the increment by which the employee IDs will increase.
 13. Click Run.

Trunk Quick Setup
If you have an SX-200, you add a series of trunks in the Contact Center Management website under
YourSite=>Configuration, Trunk=>Trunk.

If you have a 3300 ICP, 5000, or Axxess, to add a series of trunks
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Trunks.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

postfix type the prefix and/or postfix.
 6. On theGeneral tab, click ... and select amedia server for the trunk.
 7. Click Run.
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Trunk group Quick Setup
If you have an SX-200, you add a series of trunk groups in the Contact Center Management website under
YourSite=>Configuration, Trunk=>Trunk group.

If you have a 3300 ICP, 5000, or Axxess, to add a series of trunk groups
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Trunk groups.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, enter a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

postfix type the prefix and/or postfix.
 6. On theGeneral tab, click ... and select the voicemedia server associated with the trunk (for example,

3300 ICP Voice).
 7. If this trunk group uses an intra switch, select the Intra switch check box.
 8. To cost calls using this trunk, clear theDo not cost calls check box.
 9. Click Run.

DNIS Quick Setup
If you have an SX-200, you add a series of DNIS in the Contact Center Management website under
YourSite=>Configuration, DNIS=>DNIS.

If you have a 3300 ICP, 5000, or Axxess, to add a series of DNIS
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click DNIS.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

postfix type the prefix and/or postfix.
 6. On theGeneral tab, afterAssociate the devices to this media server, click ... and select amedia

server.
 7. AfterShort Abandon, type the Short Abandon threshold for the DNIS.
 8. AfterService Level, type the Service Level time for the DNIS.
 9. Click Run.

Account Code Quick Setup
If you have an SX-200, you add a series of Account Codes in the Contact Center Management website under
YourSite=>Configuration, Account Codes=>Account Codes.

If you have a 3300 ICP, 5000, or Axxess, to add a series of Account Codes
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Account Codes.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

postfix type the prefix and/or postfix.
 6. To you want to create an employee for each Account Code, on theEmployee Associations tab, select

theCreate an employee ID for each Account Code check box.
NOTE:Select this check box only if you have not already added employee IDs to the database.
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 7. AfterStart the employee IDs at, type the first employee ID number to associate to the Account Code
range.

 8. After Increment the employee IDs by, type the increment by which the employee ID numbers will
increase.

 9. Click Run.

Make Busy Reason Codes Quick Setup
If you have an SX-200, you add a series of Make Busy Reason Codes in the Contact Center Management
website under YourSite=>Configuration=>Make Busy Reason Code.

If you have a 3300 ICP, 5000, or Axxess, to add a series of Make Busy Reason Codes
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Make Busy Reasons.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

postfix type the prefix and/or postfix.
 6. Click Run.

Team Quick Setup
If you have an SX-200, you add a series of Teams in the Contact Center Management website under
YourSite=>Configuration=>Team.

If you have a 3300 ICP, 5000, or Axxess, to add a series of Teams
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Teams .
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. If you want to add a prefix or postfix to this range of device numbers, afterName prefix and/orName

postfix type the prefix and/or postfix.
 6. Click Run.

Device group Quick Setup
If you have an SX-200, you add a series of employee groups, agent groups, queue groups, extension groups,
and DNIS groups in the Contact Center Management website under YourSite=>Configuration.

If you have a 3300 ICP, 5000, or Axxess, to add a series of Account Code groups, agent groups, DNIS
groups, employee groups and divisions, extension groups and divisions, and queue groups
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click the device group name.
 3. Click Quick Setup.
 4. In theActive number from andActive number to boxes, type a range of device numbers.
 5. To add a prefix or postfix to the range of device numbers, afterName prefix and/orName postfix type

the prefix and/or postfix.
 6. If you are adding an agent group, click ... and select amedia server and failover media server to

associate with the agent group.
 7. Click Run.
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Configuring devices using .csv files

If you have a 3300 ICP, 5000, or Axxess telephone system, you can import devices to YourSite Explorer
using comma-separated value (.csv) files. The following device types are currently supported for use with the
YourSite Explorer .csv import tool: employees, employee groups, employee divisions, agents, agent groups,
queues, queue groups, extensions, extension groups, extension divisions, trunks, trunk groups, DNIS, DNIS
groups,Account Codes, Make Busy Reason Codes, Do Not Disturb Reason Codes, and teams.

A .csv file is used for the digital storage of data structured in a table of lists form, where each associated item
(member) in a group is in association with others also separated by the commas or tabs of its set.

There are two ways to create .csv files: Notepad or Microsoft Excel. We recommendmaking .csv files in
Excel, as adding and editing a large number of entries at once using auto-fill functions is much simpler and
more convenient than using Notepad.

Alternatively, you can also import tabbed delimited text files created in Excel. Tabbed delimited text files are
almost identical to .csv files, but use tabs to differentiate data fields instead of commas.

NOTE:When creating .csv files, youmust save the file as either a .csv or .txt file. Simply renaming an Excel
file or changing a file type extension to .csv will not work and you will be unable to import device data into
 YourSite Explorer.

Figure 6 - 7 and Figure 6 - 8 provide two examples of how .csv files can be formatted. The following figures
display Microsoft Excel .csv formatting and Notepad .csv formatting. Both .csv examples contain the
following data: first name, last name, agentlogin ID, andmedia server.

NOTE: To import configuration options that display in the YourSite Explorer grid view as a check box, you
must enter True or False as the field data.

Figure 6 - 7 Microsoft Excel .csv formatting example



YourSite database configuration

- 120 -

Figure 6 - 8 Notepad .csv formatting example

Fields required for successful .csv imports
Table 6 - 6 details the fields that are required in order to successfully import devices into YourSite Explorer
using a .csv file.

NOTE:Datamust be entered in .csv files using the exact order detailed in Table 6 - 6 below. Failure to import
data in the order specified will result in import errors.
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Table 6 - 6 Mandatory device fields for .csv imports

Device Mandatory fields Optional fields

Employees First name, last name, employee
ID (reporting number)

Full time, middle name,
email address, suffix, real-
time license, nickname,
resiliency license activated,
scheduling license, site,
password, is a supervisor,
username, supervisor, is
active, security role, pre-
ferred printer, print locally,
use employee email for
report distribution, fax
number, hire date, birth
date, business phone
number, emergency contact
phone number, emergency
contact relationship, emer-
gency contact name, coun-
try, ZIP or postal code,
street address, city, state,
or province, pager number,
phone number

Employee groups Name, employee group ID (report-
ing number)

N/A

Employee divisions Name, reporting number Failover media server,
employee, is active

Agents First name, last name, agent login
ID, media server

Failover media server,
employee, is active

Agent groups Name, reporting number, media
server

Failover media server, is
active

Queue groups Name, reporting number N/A

Extensions Name, reporting number, media
server

Extension type, failover
media server, real-time
license, is active, cost this
extension, notes, is general
business hot desking

Extension groups Name, reporting number N/A
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Device Mandatory fields Optional fields

Extension divisions Name, reporting number N/A

Trunks Name, reporting number, media
server

N/A

Trunk groups Name, reporting number Media server, do not cost
calls, carrier plan, intra
switch

DNIS Name, reporting number, media
server

Short abandon, service
level, carrier plan, call type,
call rate

DNIS groups Name, reporting number N/A

Account Codes Name, reporting number Use as classification code

Make Busy Reason Codes Name, reporting number N/A

DoNot Disturb Reason Codes Name, reporting number N/A

Teams Name, reporting number N/A

Importing a range of devices using a .csv file
NOTE:Before you attempt to import a device using a .csv file, ensure

l The .csv file contains data for all of the fields required to save a device in YourSite Explorer as detailed
in the following table.

l If a device requires a dependency to be specified, for example specifying amedia server is required in
order to save an agent, the dependency must already exist in YourSite Explorer. The Import Wizard
cannot create new dependencies and will fail if the dependency does not already exist in the database.

To import a range of devices using a .csv file
 1. In YourSite Explorer, underDevices, click the name of the device you will add using a .csv file.
 2. Click Import.
 3. AfterSelect file type, specify whether the .csv file uses Comma separated values or Tab separated

values.
 4. AfterSelect file, click Browse and specify the location of the .csv file.
 5. UnderOptions, specify how the Import Wizard will handle duplicate items.

If duplicates are found:
l Overwrite entries if duplicates are found will use the .csv file as themaster and overwrite

duplicate entries in the YourSite database with data in the .csv file.
l Skip duplicate entries during import will retain data configured in YourSite Explorer as themaster

and import any new data entries from the .csv file into the YourSite database.
l Do not import if duplicates are found will scan the .csv and YourSite database for duplicates. If

duplicates are found in either the .csv or the YourSite database, the import is cancelled and no
data is imported to the YourSite database.

 6. Click Next.
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 7. On the Field Mappings window, map the fields in theAvailable columns list to theSelected
columns list using the arrow buttons, so they display in the same order as they do in your .csv file.

 8. Click Next.
 9. When the import has completed, click Finish.

NOTE: If the import fails, the Import Wizard will notify you of whether the YourSite database or .csv file
contained the duplicate(s) and which row(s) of the .csv file contained the error(s) that resulted in the
failure. Fixing these errors will allow devices to be successfully imported.

Configuring devices manually
CAUTION: For reporting purposes, the trunk, extension, agent, agent group, queue, DNIS, dialable numbers,
and Account Code numbers you configure in the YourSite databasemust be identical to those of the
telephone system.

CAUTION:Print a copy of your telephone system assignment forms to use as a guide for programming
YourSite Explorer. The numbers you enter in YourSite for extensions, trunks, and Account Codes must be
identical to those of the telephone system.

If you have an SX-200 telephone system, youmust add contact center devices in the Contact Center
Management website using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess telephone
system, you add contact center devices in YourSite Explorer.

Throughout themanual device configuration section of this chapter instructions for YourSite Explorer
configuration are given first, followed by instructions for configuring devices in the Contact Center
Management website.

NOTE:
l When you configure numbers for groups in YourSite, use numerical characters only, such as 1 (for

Extension group 1). Do not insert symbols, such as a star [*] or pound sign [#], in the number.
l If you attempt to add a device or device group to YourSite that is already in the database, the system

notifies you that the device or device group is already present. When you add a series of devices or
device groups to YourSite, such as Extensions 5001 to 5005, if the system detects you have already
added Extension 5002, then it will not add Extension 5002 or any subsequent extensions in the series
(that is, Extensions 5003 to 5005) to the database.

l If you are upgrading a Contact Center Management (voice) employee to aMultimedia Contact Center
(voice, email, chat and/or fax) employee, before you assign the employee to an agent login ID, you
must assign a public folder to the employee. To do so, click Configuration=>
Employee=>Employee=>Edit and update theMultimedia Contact Center properties for the employee.

l If you have the optional Intelligent Queue application, after you set up your contact center site (in
YourSite Enterprise) and add an Intelligent Queuemedia server to the site, the information in the
YourSite database automatically synchronizes to that of the telephone system.

Adding employees
Youmust add all contact center employees (agents, supervisors, andmanagers) to the YourSite database so
you can run reports on employee activities and view employee performance in real time, and so the
employees can use Contact Center Management.

Youmust add agent login IDs to the YourSite database for employees you want to track in real time and
reporting. When you add an employee, you can simultaneously create an agent login ID for the employee,
provided you want the agent login ID to be the same as the employee ID.
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NOTE:Youmust assign each employee a unique ID number.

If you have an SX-200 telephone system, youmust add employees in the Contact Center Management
website using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess telephone system, you add
employees in YourSite Explorer.

NOTE: In order to enable an employee with none, basic, standard, advanced, or premium licensing, youmust
configure the employee in YourSite Explorer. If you configure the employee in the Contact Center
Management website the default setting of "none" will be applied to the employee license.

Configuring general information and licensing information (in YourSite
Explorer)
To configure general and licensing information for an employee.
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employees.
 3. Click Add.
 4. UnderGeneral, specify employee identification information.

Youmust provide the date the employee became an active part of the enterprise if you want to generate
administrative employee reports, or if you haveWorkforce Scheduling and will schedule employees
based on seniority, or will manage time off entitlements and business rules based on time off allocation.
Youmust enter a unique employee ID number for each employee.
NOTE:If the employee will use Enterprise Presence and Chat integration and the employee’s email
address differs from the employee’s Lync (SIP) email address, youmust enter the Lync (SIP) email
address in the email field.

 5. Under Licensing, select the applicable licensing options for employees, supervisors, phone types,
Workforce Scheduling, Contact Center Screen Pop, Integrated Client, andMultimedia Contact Center.

For Contact Center Enterprise Edition users, depending on licensing, select from None, Basic.
Standard, Advanced, orPremium employee.

l None: this option enables you to run reports on the employee, if data exists for that employee,
however, you cannot monitor the employee in real time and no new data will be collected for the
employee. When you select this option historical data for the employee continues to be stored
and the employee's name is removed from all Contact Center Client device selection lists. If this
is a non-ACD user, when configured with an Integrated Client license, the user will have access
to Contact Center Management / Call Accounting website and Contact Center Client for Contact
 Center PhoneSet Manager. Associated extensions can be viewed in real time, either for general
business purposes or Call Accounting (if associated extensions are configured to be call
costed).
CAUTION: If data exists for an employee whowas previously licensed but is currently
unlicensed, that data can be accessed in reports. However, if a summarization is done after the
employee is no longer licensed, there is a risk that the collected data could be lost.

l Basic employee: is reported on historically, viewed in real time, and has access to real-time
monitors. Users also have access to the Contact Center Management / Call Accounting website
My Options page to configure user options, such as language preference.

l Standard employee:includes all Basic employee features and functionality and has access to
Interactive Contact Center and Enterprise Presence and Chat.

l Advanced employee: includes all Standard employee features and functionality as well as
Contact Center Management and Interactive Contact Center resiliency (requires a Network
license), choice of Contact Center PhoneSet Manager, CTI Toolkit Client, or Salesforce Client
(requires a Salesforce.com Connector), and Contact Center Screen Pop.



Contact Center Solutions User Guide

- 125 -

l Premium employee: includes all Advanced employee features and functionality plus
multimedia routing for all media types, including fax, email, web chat, and SMS.
NOTE:Only one employee type can be selected for each employee. You cannot license an
employee if no licenses remain.

For Contact Center Enterprise Edition users, depending on licensing, select from None, Advanced, or
System Administrator supervisor.

l None: use this option for employees who are agents or general business extensions.
l Advanced supervisor: has access to the following: the Contact Center Management website

(reporting , forecasting, andMy Options), Flexible Reporting (if a Standard Starter Pack or
greater is owned), Contact Center Client for real-timemonitoring, and YourSite Explorer (read
access only).

l System Administrator: a System Administrator has full access to all Contact Center, Call
Accounting, and Intelligent Queue software (if licensed) for the purposes of configuration and
network and system administration.
NOTE:Only one supervisor type can be selected for each employee.

For Contact Center Enterprise Edition users, depending on licensing, select a phone type license.
l Mitel desk phone: select this option if the employee will use aMitel desk phone. This is the

default option.
l Softphone and/or Mitel desk phone: select this option if the employee will use and is licensed

for Contact Center Softphone.
NOTE: If the employee requires the use of Contact Center Softphone in addition to or in
combination with aMitel desk phone, select the Softphone phone type. Contact Center
Softphone licensing is available to Advanced or Premium employees. If the employee is a non-
ACD employee (designated as employee type 'None'), youmust select 'Licensed for integrated
client' to have access to Contact Center Softphone functionality.

For Contact Center Enterprise Edition users, select additional licensing options as required.
l UnderWorkforce Scheduling license, select Licensed for Workforce Scheduling if you

want to be able to schedule the employee usingWorkforce Scheduling. Users must be
configured as Basic, Standard, Advanced, or Premium to be scheduled in Workforce
Scheduling.

l Under Integrated client license, select Licensed for integrated clients if this is a non-ACD
employee who needs access to Contact Center PhoneSet Manager, CTI Developer Toolkit
Client, or Salesforce.com Client.
Integrated client license is a prerequisite for Contact Center Softphone. Salesforce.com
Connector is required to activate Salesforce.com Client.
See theContact Center Solutions and Call Accounting System Engineering Guide for in-depth
licensing information.

l UnderScreen Pop license, select Licensed for Screen Pop if this is a non-ACD employee
(designated as employee type 'None') or a Contact Center Business Edition agent who needs
access to Contact Center Screen Pop.
Integrated Client is a prerequisite for Screen Pop.
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For Contact Center Business Edition users, depending on licensing, select from None, Reporting, or
Desktop employee.

l None: this option enables you to run reports on the employee, if data exists for that employee,
however, you cannot monitor the employee in real time and no new data will be collected for the
employee. When you select this option historical data for the employee continues to be stored
and the employee's name is removed from all Contact Center Client device selection lists.
CAUTION: If data exists for an employee whowas previously licensed but is currently
unlicensed, that data can be accessed in reports. However, if a summarization is done after the
employee is no longer licensed, there is a risk that the collected data could be lost.

l Reporting employee: is reported on historically, viewed in real time, and has access to
Enterprise Presence and Chat.

l Desktop employee: is reported on historically, viewed in real time, has access to Enterprise
Presence and Chat, and the ability to view real-timemonitors via Contact Center Client.
NOTE:Only one employee type can be selected for each employee. You cannot license an
employee if no licenses remain.

For Contact Center Business Edition users, depending on licensing, select from None orDesktop
supervisor.

l None: use this option for employees who are agents or general business extensions.
l Desktop supervisor: has access to the following: Contact Center Management website

(reporting, contacts, forecasting, and security), Contact Center Client for real-timemonitoring,
and YourSite Explorer for enterprise and device configuration.

For Contact Center Business Edition users, depending on licensing, select a phone type license.
l Mitel desk phone: select this option if the employee will use aMitel desk phone. This is the

default option.
l Softphone and/or Mitel desk phone: select this option if the employee will use and is licensed

for Contact Center Softphone.
NOTE: If the employee requires the use of Contact Center Softphone in addition to or in
combination with aMitel desk phone, select the Softphone phone type license. If the employee is
a non-ACD employee (designated as employee type 'None'), youmust select 'Licensed for
integrated client' to have access to Contact Center PhoneSet Manager, CTI Toolkit Client, or
Salesforce.com Client functionality.

For Contact Center Business Edition users, select additional licensing options as required.
l Under Integrated Client license, select Licensed for integrated clients if you want the

employee to have access to Contact Center PhoneSet Manager, CTI Toolkit Client, or
Salesforce.com Client.
Integrated client license is a prerequisite for Contact Center Softphone. Salesforce.com
Connector is required for Salesforce.com Client.
See theContact Center Solutions and Call Accounting System Engineering Guide for in-depth
licensing information.

l UnderScreen Pop license, select Licensed for Screen Pop if you want the employee to have
access to Contact Center Screen Pop.
Integrated Client is a prerequisite for Screen Pop.

l UnderMultimedia Contact Center license, select Licensed for Multimedia Contact Center
if you want the employee to be able to access voice and a choice of two additional media types,
including email, SMS, WebChat, and fax.
Email and fax are enabled by default.

 6. Configure employee user account information.
See "Configuring user account information (in YourSite Explorer)" on page 127.
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Configuring user account information (in YourSite Explorer)
To configure user account information for an employee
 1. On theUser account tab, underUser account, specify login credentials for the employee and select

the site to which the employee is associated.
 2. UnderSecurity, select a security role for the employee.

The default security role permits users full access to all applications and devices.
 3. UnderReport distribution, specify the path of the network printer and select print and email options.

Youmust configure the network printer as the default printer on the Enterprise Server. The printer path
name is case sensitive.

 4. Create an agent login ID, extension, and Account Code for the employee.
See "Creating agent login IDs, extensions, and Account Codes for employees (in YourSite Explorer)"
on page 127.

Creating agent login IDs, extensions, and Account Codes for employees
(in YourSite Explorer)
To create an agent login ID, extension, and Account Code for an employee
 1. Click theCreate Associated devices tab.
 2. Click Agent login ID and select the check boxes for themedia servers to which the employee will log

in.
This creates an agent login ID based on the employee ID for eachmedia server you select, which is
recommended.

 3. Click Extension and select theCreate an extension number for the employee check box, select a
media server and failover media server for the extension, and, if the extension will be costed with Call
Accounting, select theCost this extension check box.

 4. Click Account Code and select theCreate an Account Code for the employee check box.
 5. If applicable, configureMultimedia Contact Center user settings. Otherwise, skip to .

See "Configuringmultimedia user settings (in YourSite Explorer)" on page 127.

Configuring multimedia user settings (in YourSite Explorer)
If you are a Contact Center Enterprise Edition user, are licensed as a Premium employee, have aMultimedia
media server configured, and are associated with amultimedia agent ID, youmust configuremultimedia user
settings.

To configureMultimedia Contact Center user settings
 1. Click theMultimedia Contact Center tab.
 2. Type the Employee's Exchange public folder name.
 3. Configure employee personal information.

See "Configuring employee personal information (in YourSite Explorer)" on page 127.

Configuring employee personal information (in YourSite Explorer)
To configure employee personal information
 1. Click theDetails tab.
 2. Complete the employee's personal information.
 3. On the ribbon, click Save.
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Associating employees with agent login IDs, extensions, and Account
Codes (in YourSite Explorer)
To associate employees with agent login IDs, extensions, and Account Codes
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employees.
 3. Select the employee for which you want to update associations.
 4. Click Agent logins.
 5. UnderAvailable members, select the agent login ID(s) you want to associate to the employee.
 6. Click > to move the selected Agent login ID(s) to theSelected members list.
 7. Click Add.
 8. Click Extensions.
 9. UnderAvailable members, select the extension(s) you want to associate to the employee.
 10. Click > to move the selected extension to theSelected members list.
 11. Click Add.
 12. Click Account Codes.
 13. UnderAvailable members, select the Account Code(s) you want to associate to the employee.
 14. Click > to move the selected Account Code(s) to theSelected members list.
 15. Click Add.
 16. Click Save.

Configuring general information and licensing information (in the
Contact Center Management website)
To configure general information and licensing information for an employee
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Employee=>Employee.
 3. Click Add.
 4. On theAdd an employee tab, specify identification information for the employee.

NOTE: Youmust enter a unique employee ID number for the employee.
 5. AfterEmployee ID, type an identification number for the employee (for example, 100).
 6. If you will track and run reports on the employee, select the The employee will be tracked in real-time

and reporting check box.
 7. If the employee is a supervisor, select the The employee is a supervisor check box.
 8. If the employee is resilient, select the This employee is resilient and will be tracked in real time

and reporting check box.
NOTE: If the number of employees in the YourSite database exceeds the number for which you are
licensed, you will not be able to select this check box.

 9. AfterEmail address, type the employee’s email address.
Reporting Service uses this email address to send and receive reports.

 10. AfterActive from, select the date the employee ID was created.
 11. AfterNickname, type the employee’s nickname.
 12. Click Save.
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Configuring user account information (in the Contact Center
Management website)
To configure user account information for an employee
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Employee=>Employee.
 3. Select an employee from the list.
 4. On theUser account tab, select the This employee will use these credentials to log on to

applications check box, and specify security and report distribution information.
 5. Click Save.

NOTE: If you are upgrading a Contact Center Management (voice) employee to aMultimedia Contact Center
(voice, email, chat and/or fax) employee, youmust assign a public folder to the employee prior to assigning
him an agent login ID. To do so, click Configuration=> Employee=>Employee=>Edit and update the
Multimedia Contact Center properties for the employee.

Associating employees with agent IDs, extensions, and Account Codes
(in the Contact Center Management website)
To associate the employee with an agent login ID, extension, and Account Code
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Employee=>Employee.
 3. Select an employee from the list.
 4. On theCreate associated devices tab, underAgent login, select the check boxes of themedia

servers to which the employee will log in.
This creates an agent login ID based on the employee ID for eachmedia server you select, which is
recommended.

 5. On theExtension tab, select theCreate an extension reporting number for each employee ID
check box and select amedia server and failover media server for the extension.

 6. If the extension will be costed with Call Accounting, select theCost this extension check box.
 7. On theAccount Code tab, select theCreate Account Code for employee check box.
 8. On the ribbon, click Save.

Configuring multimedia user settings (in the Contact Center Management
website)
To configureMultimedia Contact Center user settings
 1. On the Configurationmenu, click Employee=>Employee.
 2. Select an employee from the list.
 3. On theMultimedia Contact Center user tab, select the The employee will be a Multimedia

Contact Center agent check box and specify the employee’s Exchange public folder name.
 4. Click Save.
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Adding employee groups
After adding employees, you add employee groups and associate employees to these groups.

If you have an SX-200 telephone system, youmust add employee groups in the Contact Center Management
website using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess telephone system, you add
employee groups in YourSite Explorer.

You add employee groups to the YourSite database so you can generate reports on employee group activities.

Adding employee groups (in YourSite Explorer)
To add an employee group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employee groups.
 3. Click Add.
 4. Configure employee group identification information.
 5. On the ribbon, click Save.

Associating employees with employee groups (in YourSite Explorer)
To associate an employee with an employee group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employee groups.
 3. Select an employee group from the list.
 4. On theMembership tab, underAvailable members, select an employee and click > to move the

employee to theSelected members list.
 5. On the ribbon, click Save.

Adding employee groups (in the Contact Center Management website)
To add an employee group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Employee=>Employee group.
 3. Click Add.
 4. Specify employee group identification information.
 5. If you want all employees to be added to this employee group, select theAutomatically add all

employees to this employee group check box.
 6. Click Save.

Associating employees with employee groups (in the Contact Center
Management website)
To associate an employee with an employee group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Employee=>Employee group.
 3. Across from the employee group to which you want to associate employees, click Members.
 4. UnderAvailable employees, select the check boxes of themembers to be added to the group and click

Add selected>>.
 5. Click Save.
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Adding employee divisions
A division is composed of several employee groups. The Division tab shows the employee groups that belong
to the division currently selected. When you create employee divisions in YourSite, you can run reports for
several employee groups simultaneously.

If you have a 3300 ICP, 5000, or Axxess, you add employee divisions and associate employee groups to
these divisions in YourSite Explorer.

To add an employee division
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employee Divisions.
 3. Click Add.
 4. Type aName andReporting number for the employee division.
 5. On the ribbon, click Save.

To associate an employee group with an employee division
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employee Divisions.
 3. Select an employee division from the list.
 4. On theMembership tab, underAvailable members, select an employee group and click > to move the

employee group to theSelected members list.
 5. On the ribbon, click Save.

Adding agents
Youmust add agent login IDs to the YourSite database for employees you want to track in real time and
reporting. An employee can havemore than one agent login ID but only one employee ID. You assignmultiple
agent login IDs to employees who are cross-trained to handle calls for different departments (different
queues). For example, Carol Jones handles calls for English, French, and Spanish queues. In the YourSite
database, you assign Carol three agent login IDs, one for each queue that she handles.

We recommend you browse to the employee window and create agent login IDs based on employee IDs. See
"Adding employees" on page 123.

NOTE: Agents are programmed in YourSite Explorer. If agents are in a clustered environment but not hot
desking and not resilient, the agent names will not display on the telephone switch. Youmust enter these
agent names outside of Contact Center Management.

In order to provide Contact CenterWork Timer functionality in Contact Center Client, every traditional agent’s
extension or every hot desking Agent ID must be enabled with aMiTAI monitor.

If your agents handle calls for multiple voice queues, you can add additional agent login IDs. For the SX-200,
you do so in YourSite=>Configuration=>Employee=>Employee=>View agent logins. For the 3300 ICP, 5000,
and Axxess, you do so in YourSite Explorer.

To add an agent
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Agents.
 3. Click Add.
 4. AfterEmployee, if you want to associate the agent to an employee, click ... and select an employee.
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 5. After First name and Last name, type the agent's name.
 6. AfterAgent login ID, type the agent login ID.
 7. AfterMedia Server, click ... and select themedia server the agent will use.
 8. Select theDisable real-time monitoring and data collection on this device check box if you do not

want to enable the agent to be set with aMiTAI monitor, viewed in Contact Center Client, and use
Contact Center Softphone or Salesforce.com Connector.
By default, this check box is not selected.

 9. If you want to enable this agent for external hot desking, select theExternal hot desk user enabled
check box.
Agents that are enabled as external hot desk agents can handle non-ACD or ACD calls while logged in
externally.

 10. AfterExternal dialing prefix, type the dialing prefix for the external device to which calls will be routed.
 11. AfterExternal dialing number, type the dialing number for the external device to which calls will be

routed.
 12. On the ribbon, click Save.

Specifying 3300 ICP options for agents
You can specify Class of Service, Class of Restriction, and failover media server options for agents in
YourSite Explorer.

To specify 3300 ICP options for an agent
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Agents.
 3. Select an agent from the list.
 4. Under 3300 ICP Options, afterCOS, select a Class of Service from the list.
 5. AfterCOR, select a Class of Restriction from the list.
 6. After Failover media server, click ... and select a failover media server from the list.
 7. On the ribbon, click Save.

Adding additional agent login IDs
To add additional agent login IDs

 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employees.
 3. Select an employee from the list.
 4. Click theAgent logins tab.
 5. Select an employee from theAvailable members list and click > to move the employee to the

Selected Members list.
 6. On the ribbon, click Save.
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Adding agent groups
Youmust add agent groups to the YourSite database and associate agent login IDs to the agent groups so
you can run reports on agent group activities and view agent group activities in real time.

You can associate an agent login ID tomore than one agent group. See "Determining your contact center
configuration needs" on page 97.

NOTE:
l If you attempt to add a group to YourSite that is already in the database the system notifies you that the

group is already present. When you add a series of groups to YourSite, such as Extension Groups 1 to
5, if the system detects you have already added Extension Group 3, then it will not add Extension
Group 3 or any subsequent extensions in the series (that is, Extension Group 4 or 5) to the database.

l An agent groupmust be composed of agents who handle contacts for the samemedia server type. A
group of agents of mixedmedia types would produce a report that compares voice agents to email
agents to chat agents. The comparison would not be valid. You want to compare apples to apples
(emails to emails) not apples to oranges (emails to chats).

If you have an SX-200 telephone system, youmust add agent groups in the Contact Center Management
website using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess telephone system, you add
agent groups in YourSite Explorer.

Adding agent groups (in YourSite Explorer)
To add an agent group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Agent groups.
 3. Click Add.
 4. Configure agent group identification information, and select themedia server for the agent group.
 5. Select theDisable real-time monitoring and data collection on this device check box if you do not

want to enable the agent group to be set with aMiTAI monitor, viewed in Contact Center Client, and
use Contact Center Softphone or Salesforce.com Connector.
By default, this check box is not selected.

 6. On the ribbon, click Save.

Specifying 3300 ICP options for agent groups (in YourSite Explorer)
To specify 3300 ICP options for an agent group
 1. UnderDevices, click Agent groups.
 2. Select an agent group from the list.
 3. On the 3300 ICP options tab, click ... and select a failover media server.
 4. Specify if the agent group uses skills and if calls are to be queued to the agent group when no agents are

logged in.
 5. On the ribbon, click Save.
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Associating agents with agent groups (in YourSite Explorer)
To associate an agent with an agent group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Agent groups.
 3. Select an agent group from the list.
 4. On theMembership tab, underAvailable members, select an agent and click > to move the agent to

theSelected members list.
 5. On the ribbon, click Save.

Adding agent groups (in the Contact Center Management website)
To add an agent group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Agent login=>Agent group.
 3. Click Add.
 4. Specify agent group identification information and select themedia server and failover media server for

the agent group.
 5. If you want all agents associated with themedia server for the agent group to belong to the agent group,

select theAutomatically add all agents associated with this media server to this agent group
check box.

 6. Click Save.

Associating agents with agent groups (in the Contact Center
Management website)
To associate an agent with an agent group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Agent login=>Agent group.
 3. Across from the agent group to which you want to associate agents, click Members.

The Edit agent groupmembers window opens.
 4. UnderAvailable agent login IDs, select the check boxes of themembers to be added to the group and

click Add selected>>.
 5. Click Save.

Adding teams
After adding agent groups, you can add teams and associate agent groups to these teams.

If you have an SX-200 telephone system, youmust add teams in the Contact Center Management website
using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess telephone system, you add teams in
YourSite Explorer.

Adding teams (in YourSite Explorer)
To add teams in YourSite Explorer
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Teams.
 3. Click Add.
 4. Type aName andReporting number for the team.
 5. On the ribbon, click Save.
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Associating agent groups to teams (in YourSite Explorer)
To associate agent groups to teams in YourSite Explorer
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Teams.
 3. Select a team from the list.
 4. On theMembership tab, underAvailable members, select an agent group and click > to move the

agent group to theSelected members list.
 5. On the ribbon, click Save.

Adding teams (in the Contact Center Management website)
To add teams in the Contact Center Management
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Team.
 3. Click Add.
 4. Type aName andReporting number for the team.
 5. If you want to add all agent groups to the team, select Automatically add all agent groups to this

team.
 6. Click Save.

Associating agent groups to teams (in the Contact Center Management
website)
To associate agent groups to teams
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Team.
 3. Across from the team to which you want to associate agent groups, click Members.
 4. The Edit teammembers window opens.
 5. UnderAvailable agent groups, select the check boxes of themembers you want to add to the team

and click Add selected >>.
 6. Click Save.

Adding queues
Youmust add queues to the YourSite database so you can run reports on queue activities and view queue
performance in real time. When you add a queue to the YourSite database, the configuration options available
depend upon themedia server you select. Media servers fall under five general categories: voice (a telephone
system with or without MiTAI enabled), Intelligent Queue, email, SMS, chat, and fax.

When you add a queue to the YourSite database, you associate the queue with the agent groups that handle
calls for the queue. You do this so you know which agent groups handle which queues. Youmust associate at
least one agent group with a queue in order to produce reports on the queue. When configuring queues, you
can optionally configure work timer options, such as extending the telephone system work timer beyond the
tenminutemaximum, or forcing agents to enter call classification codes before they handle other requests. If
you select the Force entry of a classification code check box, agents will receive a pop-up in their Contact
Center Client forcing them to enter a call classification code before they can answermore calls.

NOTE: When a queue is added in Contact Center Management and synchronized with the telephone system,
real-time events are turned on by default.
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If you have an SX-200 telephone system, youmust add queues in the Contact Center Management website
using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess telephone system, you add queues
in YourSite Explorer.

Configuring general information for queues (in Your Site Explorer)
To configure general information for a queue
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Queues.
 3. Click Add.
 4. Specify queue identification information.

The queue reporting number for a phone queuemust be the same as the path reporting number on the
telephone system assignment forms (for example, if the reporting number is 20, then you type P0020
for the SX-200 Real-time).
NOTE: To ensure accurate reporting, queue reporting numbers must be unique across both active and
inactive queues.

 5. Click ... and select themedia server for the queue.
 6. Select theDisable real-time monitoring and data collection on this device check box if you do not

want to enable the queue to be set with aMiTAI monitor, viewed in Contact Center Client, and use
Contact Center Softphone or Salesforce.com Connector.
By default, this check box is not selected.

 7. UnderQueue service objective, specify theService Level goal and theService Level time.
 8. If the queue is a voice or chat queue, afterShort Handle less than, type the duration that will define a

call as a short handle call.
For example, type 3 to define a short handle call as one that lasts less than 3 seconds. Short talk calls
are included in call statistics.

 9. AfterShort Abandon less than, type the duration that will define an abandoned call as "Call
Abandoned (Short)".
For example, type 5 to define a short abandon call as one that is abandoned in less than 5 seconds.

 10. If the queue is a voice queue, after Dialable number, type the path directory number listed on the
telephone system assignment forms.

 11. If you want to configure the queue’s work timer, underWork timer options, select theUse work timer
check box and specify the duration. The default duration is 00:00:00.
NOTE:

l Queue work timer maximum duration is dependent upon your telephone system.
l MCD 5.0 and greater – 4 hours maximum
l MCD 4.x or earlier – 10minutes maximum

l A queue’s work timer must not exceed the Class of Service associated with any agents in
agent groups who are associated with this queue. See "Editing Class of Service options" on
page 110.

 12. To force agents to enter call classification Account Codes, select the Force entry of a classification
code check box.
This feature is hidden unless you are licensed for Integrated Client and use either Contact Center
PhoneSet Manager or Contact Center Softphone.

 13. To automatically cancel contact center work timer, select theCancel work timer once code is
entered check box.

 14. If you want to add contact center work timer time to handling time, select the Include work timer as
part of handling time check box.
NOTE:When "Include work timer as part of handling time" is enabled, the ACD handling time durations
for reporting purposes span from ACD pick up to the end of the work timer time. When this option is
disabled, the ACD handling time duration spans from ACD pick up to hang up.

 15. On the ribbon, click Save.
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Associating agent groups with queues (in YourSite Explorer)
To associate an agent group with a queue
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Queues.
 3. Select a queue from the list.
 4. On theMembership tab, underAvailable members, select an agent group and click > to move the

agent group to theSelected members list.
 5. On the ribbon, click Save.

Configuring business hours for queues (in YourSite Explorer)
You configure business hours for queues to determine when queues are available.

To configure business hours for queues
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Queues.
 3. Click theBusiness Hours tab.
 4. AfterBusiness-hour schedule, click ... and select a schedule for the queue.
 5. Click OK.
 6. If you want to restrict the production of real-time statistics and reports to only during business hours,

select theGenerate real-time statistics and reports only within the business hours selected
check box.

 7. To apply the selected business-hour schedule to all queues associated with themedia server, click
Submit.

 8. Click Save.

Configuring queue spectrum settings for queues (in YourSite Explorer)
Queue spectrum reports provide valuable information on how calls are dispersed in your contact center. You
configure answer, abandon, interflow, handle, and ringing thresholds for queues in YourSite Explorer.

The answer, abandon, interflow, and talk statistics will be distributed across the queue spectrum reports in the
time intervals you specify.

NOTE: The data in the queue spectrum ringing reports is derived from the ACD data stream. Queue
performance report data is derived from the SMDR data stream so cannot be compared to queue spectrum
ringing report data.

To configure queue spectrum settings for a queue
 1. Select the spectrum value(s) you want to include in reports and specify thresholds for each.

All threshold values are in seconds.
 2. To apply spectrums to all queues associated with themedia server, click Submit.
 3. Click Save.
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Specifying 3300 ICP options for queues (in YourSite Explorer)
On the 3300 ICP options tab, you can specify queue priority and themethod a queue uses for handling
interflowed calls in Interactive Visual Queue.

To specify 3300 ICP options for a queue
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Queues.
 3. Select a queue from the list.
 4. On the 3300 ICP options tab, underGeneral, specify the priority level of the queue and the queue

unavailable answer point directory number.
The highest priority level is 1. The lowest priority level is 64.

 5. Under Interflow options, specify interflow options for the queue.
You select Interflow to this queue uses this queue’s priority if you want interflowed calls to use the
queue’s priority. Otherwise, interflowed calls will retain the priority levels of their originating queues.

 6. On the ribbon, click Save.

Configuring general information for queues (in the Contact Center
Management website)
To configure general information for a queue
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Click Add.
 4. On theQueue tab, specify queue identification information and select themedia server for the queue.

The queue reporting number for a phone queuemust be the same as the path reporting number on the
telephone system assignment forms (for example, if the reporting number is 20, then you type P0020
for the SX-200 Real-time).

 5. If the queue is a voice queue, after Dialable number, type the path directory number listed on the
telephone system assignment forms.

 6. AfterQueue service objective, type your queue service level goal.
 7. If the queue is a voice or chat queue, afterShort Abandon, type the duration for the call abandon

parameter.
If the abandon time is less than the call abandon parameter, then the call is a short abandon call and is
not included in the call statistics (for example, type 5 to define a short abandon call as a call that lasts
less than 5 seconds).

 8. AfterShort Handle, type the duration for the call talk parameter.
If the talk time is less than the call talk parameter, then the call is a short talk call (for example, type 3 to
define a short talk call as a call the agent makes that lasts less than 3 seconds).Short talk calls are
included in call statistics.

 9. On theQueue spectrum tab, configure queue spectrum settings.
 10. Click Save.
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Associating agent groups with queues (in the Contact Center
Management website)
To associate an agent group with a queue
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. For the queue to which you want to associate agent groups, click Members.

The Edit queuemembers window opens.
 4. UnderAvailable agent groups, select the check boxes of themembers you want to add to the queue

and click theAdd >> button.
 5. Click Save.

Configuring business hours for queues (in the Contact Center
Management website)
If you want to apply business hours to queues, you do so in the Contact Center Management website.

To configure business hours for a queue
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from the queue for which you want to configure business hours, click Edit.
 4. On theBusiness hours tab of the queue, select a business-hour schedule.
 5. If youmust create or modify a schedule for the queue, click Manage schedule and configure a

schedule.
See "Applying schedules" on page 170.
For voice queues, the schedule specifies when real-time data should not be filed to the SQL database.
For chat and email queues, the business-hours schedule specifies the time of day customers receive
the business-hours auto-acknowledgment message.

 6. If you want to apply this schedule to all of the queues with the samemedia server, select theApply this
business-hour schedule to all queues associated with this media server check box.

 7. If the queue is a voice queue and you want to exclude statistics generated for calls received or dialed
outside of business hours, select theGenerate real-time statistics and reports only within the
business hours selected check box.
Enabling this option prevents data from being filed to the SQL database outside of business hours.

 8. If you are configuring a voice queue using Interactive Visual Queue, click the Interactive Visual Queue
tab and specify the queue priority settings.

 9. If the queue is a voice queue using amedia server with MiTAI, click the Interactive Contact Center
queue control tab and specify the queue control plan.
See "Configuring Interactive Contact Center Queue control" on page 140.

 10. If the queue is a voice queue, click Save. Otherwise continue with step 11.
 11. If the queue is an email queue, specify Multimedia Contact Center Email options.

See "ConfiguringMultimedia Contact Center Email routing options" on page 144.
 12. If the queue is a chat queue, specify Multimedia Contact Center Chat routing options.

See "ConfiguringMultimedia Contact CenterWebChat routing options" on page 145.
 13. If the queue is a fax queue, specify Multimedia Contact Center Fax options.

See "ConfiguringMultimedia Contact Center Fax routing options" on page 146.
 14. Click Save.
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Configuring Interactive Contact Center Queue control
NOTE:

l Youmust install Interactive Contact Center before you can use Interactive Contact Center Queue
control. It is available to queues associated with 3300 ICP and 5000/Axxess media servers only.

l Before you can use Interactive Contact Center Queue control, youmust save the queue.

Using queue control plans, you can place queues in and remove queues from DoNot Disturb automatically
based on predefined criteria. Each queue control planmonitors one queue, and based on the activity of the
queue, either places a queue in, or removes a queue from DoNot Disturb.

NOTE: 5000/Axxess queues cannot be placed in DoNot Disturb and can only redirect calls to an alternate
answering point.

Queue control plans open and close queues based on plan parameters only during business hours. Each
queue is controlled by only one queue control plan at a time. You can apply the same queue control plan to
several queues.

Interactive Contact Center Queue control is configured in the Contact Center Management website.

To configure Interactive Contact Center Queue control
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from the queue for which you want to configure Interactive Contact Center Queue control, click

Edit.
 4. On the Interactive Contact Center queue control tab of the queue, select the This queue uses

Interactive Contact Center queue control check box.
 5. After Interactive Contact Center queue control schedule, select the business hours schedule for the

queue.
 6. If youmust create or modify a schedule for the queue, click Manage schedule and configure a

schedule.
See "Applying schedules" on page 170.

 7. After Interactive Contact Center queue control plan, select the queue control plan for the queue.
 8. If youmust create or modify a control plan for the queue, click Manage queue control plan and

configure a plan.
See "Managing a queue control plan (3300 ICP)" on page 140.

 9. Click Save.

Managing a queue control plan (3300 ICP)
Tomanage a queue control plan
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from the queue for which you want to manage a queue control plan, click Edit.
 4. On the Interactive Contact Center queue control tab of the queue, click Manage queue control

plan.
See Figure 6 - 9.
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Figure 6 - 9 Interactive Contact Center Queue control plan

 5. AfterName, type the name of the plan.
 6. AfterMonitor, select the current queue or an alternate queue.

An alternate queue is available only when you havemore than one queue programmed in YourSite
Explorer. The queues are displayed in the following format: site - media server - queue reporting number
- queue name.

 7. Select the queue or device that you want to place in, or remove from DoNot Disturb.
You can control the current queue, an alternate queue (on the samemedia server), or a directory
number. The current queue is always the queue to which the plan is applied. If you do not monitor the
current queue, then the current queuemust be affected. The directory number is the dialable number of
a queue or extension. The directory number can be between 1 and 7 digits, inclusive. If youmonitor the
current queue you can affect an alternate queue. For example, you can affect another voice queue in
your contact center.

 8. AfterPlace the device in DND when the following conditions are true for, type the duration, in
seconds, that you want a condition to be true before the queue or device enters Do Not Disturb.
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 9. AfterRemove the device from DND when the following conditions are false for, type the duration,
in seconds, that you want a condition to be false before the queue or device is removed from DoNot
Disturb.

 10. AfterEnabled, select the check boxes of the variables to be included in the plan.
 11. AfterVariable type, if you select Calls Waiting, select a symbol or combination of symbols (>=, <, =,

>, <=) and type the relevant number of calls after which you want the queue plan to take action.
For example, if you select = 5, then the queue control plan will take action only when there are 5 calls
waiting in queue.

 12. AfterVariable type, if you select Longest Waiting, select a symbol or combination of symbols (>=, <,
=, >, <=) and type the duration (hh:mm:ss) after which you want the queue plan to take action.
For example, if you select > 00:05:00, then the queue control plan will take action only after the longest
call waiting in queue has been waiting for more than fiveminutes.

 13. AfterVariable type, if you select Call Load, select a symbol or combination of symbols (>=, <, =, >,
<=) and type the duration (hh:mm:ss) after which you want the queue plan to take action.
For example, if you select >= 10, then the queue control plan will take action only when the call load is
at 10 calls, or more, per agent.

 14. Click Save.

Managing a queue control plan (5000/Axxess)
Tomanage a queue control plan
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from the queue for which you want to manage a queue control plan, click Edit.
 4. On the Interactive Contact Center queue control tab of the queue, click Manage queue control

plan.
 5. AfterName, type the name of the plan.
 6. AfterMonitor, select the current queue or an alternate queue.

An alternate queue is available only when you havemore than one queue programmed in YourSite
Explorer. The queues are displayed in the following format: site - media server - queue reporting number
- queue name.

 7. Select the queue or device that you want to redirect calls to.
You can control the current queue, an alternate queue (on the samemedia server), or a directory
number. The current queue is always the queue to which the plan is applied. If you do not monitor the
current queue, then the current queuemust be affected. The directory number is the dialable number of
a queue or extension. The directory number can be between 1 and 7 digits, inclusive. If youmonitor the
current queue you can affect an alternate queue. For example, you can affect another voice queue in
your contact center.

 8. AfterRedirect the device when the following conditions are true for, type the duration, in seconds,
that you want a condition to be true before the queue or device is redirected.

 9. AfterRemove the device from redirection when the following conditions are false for, type the
duration, in seconds, that you want a condition to be false before the queue or device is redirected.

 10. AfterEnabled, select the check boxes of the variables to be included in the plan.
 11. AfterVariable type, if you select Calls Waiting, select a symbol or combination of symbols (>=, <, =,

>, <=) and type the relevant number of calls after which you want the queue plan to take action.
For example, if you select = 5, then the queue control plan will take action only when there are 5 calls
waiting in queue.
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 12. AfterVariable type, if you select Longest Waiting, select a symbol or combination of symbols (>=, <,
=, >, <=) and type the duration (hh:mm:ss) after which you want the queue plan to take action.
For example, if you select > 00:05:00, then the queue control plan will take action only after the longest
call waiting in queue has been waiting for more than fiveminutes.

 13. AfterVariable type, if you select Call Load, select a symbol or combination of symbols (>=, <, =, >,
<=) and type the duration (hh:mm:ss) after which you want the queue plan to take action.
For example, if you select >= 10, then the queue control plan will take action only when the call load is
at 10 calls, or more, per agent.

 14. Click Save.

Configuring reporting intervals (SX-200)
Configuring reporting intervals is done in the Contact Center Management website.

To configure the reporting intervals for the abandon, answer, interflow, and handle statistics for the queue
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from the queue for which you want to configure reporting intervals, click Edit.
 4. On theQueue spectrum tab, edit the spectrum time intervals.

When you run spectrum reports the statistics will be spread across the time intervals selected.
 5. Optionally select theApply spectrums to all queues associated with this media server check box.
 6. On theBusiness hours tab, specify the business hours for the queue.
 7. Click Save.

Configuring Multimedia Contact Center Email options
You can optionally configure email queues to handle SMS media. ConfiguringMultimedia Contact Center
Email options is done in the Contact Center Management website.

To configure email options
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from an email queue, click Edit.
 4. Click theMultimedia Contact Center Email options tab.
 5. AfterPublic email address, type the email orWeb address customers use to contact your company.

NOTE:
l TheQueue public folder name is permanent.
l Exchange will attempt to assign an email address (<QueueName>@yourdomain.com) to the queue

public folder. However, if that email address already exists, it might assign an email address named
<QueueName>2@yourdomain.com. To correct this, youmust use Active Directory Users and
Computers and/or Exchange SystemManager to swap the email address of the conflictingmail-
enabled items. To do this, youmodify the properties on the email address tab for the appropriate
User, Distribution List, or Public Folder.

 6. AfterQueue public folder name, type the name associated with the public email address.
The queue public folder name is the name used to describe the alias email for the queue. For example, if
the alias is Support@yourcompany.com, then the public folder name could be Support.
TheQueue Public Folder Name displays in the Outlook public folder list as
CyberAED/Queues/<QueueName>.

 7. Click Save.
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Configuring Multimedia Contact Center Email routing options
You can configureMultimedia Contact Center queues to handle email or short messaging service (SMS)
messages. As a best practice, we recommend you configure eachmultimedia queue to handle one contact
type only.

In order to handle SMS contacts, youmust configure aMulti-Tech SMSFinder modem or aMulti-Tech
SMSFinder multi-port modem on theMultimedia Contact Center server. Each SMS queue requires amodem
port and you can install as many modems as you have queues.

ConfiguringMultimedia Contact Center Email routing options is done in the Contact Center Management
website.

To configure email routing options
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from an email queue, click Edit.
 4. Click theMultimedia Contact Center Email/SMS routing options tab.
 5. AfterPriority of this queue in relation to all other queues associated with this media server, type

a priority value between 1 and 10 inclusive.
The priority value is assigned to the queue. The value 1 has the highest priority.

 6. AfterAgent requeue time, type the time inminutes that an email will ring in the assigned agent’s inbox
before it is put back into the same queue and offered to the next available agent.

 7. AfterDuration an email is on hold before the agent requeue timer begins, type the time inminutes
that an email can be on hold in the assigned agent’s inbox before a warning flashes to indicate that the
requeue timer will start.
You specify the length of time the requeue timer runs in the Agent requeue time field.

 8. After Interflow Time, type the time inminutes an email can wait in the original queue before it is sent to
another queue (the interflow queue).

 9. If you want to direct queue-delayed emails to an alternate queue, click Internally interflow contacts to
this email queue and select the queue to which you will interflow the emails.
The email will be interflowed to this queue after it has waited in the original queue for a set period of time
(the interflow time).

 10. If you want to direct queue-delayed emails to a specific email address, click Externally interflow
contacts to this email address and type the address to which you will interflow the emails.

 11. If this queue handles SMS messages, underSMS Options
l AfterPhone Number, type the phone number of the SMS modem’s SIM card.
l AfterSMSFinder Server, type the IP address of the SMS modem.
l AfterUser name, type the SMS modem user name.
l AfterPassword, type the SMS modem password.
l AfterRemote Port, type the connection port number of themodem.
NOTE: Entering the connection port number of themodem is not required but is strongly
encouraged to avoid cycling through all occupied ports.

 12. If you are using aMulti-Tech SMSFinder multi-port modem, select Load last SMS Options settings to
use the SMS Options settings from step 11 for each port on themodem.
NOTE: The Phone Number field must be changed tomatch the SMS modem's SIM card number for
each port.

 13. Click Save.
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Configuring Multimedia Contact Center WebChat routing options
ConfiguringMultimedia Contact CenterWebchat routing options is done in the Contact Center Management
website.

To configure chat routing options
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from a chat queue, click Edit.
 4. Click theMultimedia Contact Center WebChat Routing options tab.
 5. AfterPriority of this queue in relation to all other queues associated with this media server, type

a priority value between 1 and 10 inclusive.
The priority value 1 has the highest priority.

 6. AfterNumber of chat sessions that can be simultaneously routed to each agent for this queue,
enter a number between 1 and 10 inclusive.

 7. AfterRequeue time, type the time (in seconds) that a chat message will ring in the assigned agent’s
inbox before it is put back into the same queue and offered to the next available agent.

 8. After Interflow time, type the time inminutes a chat message can wait in the original queue before it is
sent to another queue (the interflow queue).

 9. If you want to direct queue-delayed chat messages to an alternate queue, after Internally interflow
contacts to this chat queue select the queue.
The chat message will be interflowed to this queue after it has waited in the original queue for a set
period of time (the interflow time you specified above).

 10. AfterQueue public folder name, type the name associated with the public email address.
The queue public folder name is the name used to describe the alias email for the queue. For example, if
the alias is Support@yourcompany.com, then the public folder name could be Support.
TheQueue Public Folder Name displays in the Outlook public folder list as
CyberAED/Queues/<QueueName>.

 11. After Internal email address, type the email address theMultimedia Contact Center server uses to
send chat requests to the chat public folder corresponding with the queue.

 12. Click Save.

Configuring Multimedia Contact Center WebChat transcript options
ConfiguringMultimedia Contact CenterWebchat transcript options is done in the Contact Center
Management website.

To configure transcript options
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from a chat queue, click Edit.
 4. Click theMultimedia Contact Center WebChat Transcript options tab.
 5. If you want your customers to receive chat transcripts, select theEmail a chat transcript to the

customer after the chat session is complete check box.
 6. After Transcript email address, type your company’s public email address.
 7. Click theMultimedia Contact Center auto acknowledgement tab.
 8. If you want to activate auto acknowledgement messages for this queue, select theEnable auto-

acknowledgement messages for this queue check box.
 9. Select auto acknowledgement messages to be used during business hours and outside business hours.
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 10. If you want to create or modify an auto acknowledgement message, click Manage, type a title and body
text for the auto acknowledgement message, click Apply orAdd (depending on whether you are
creating a new message or modifying a previous message), and click Save.

 11. Click Save.

Configuring Multimedia Contact Center Fax options
ConfiguringMultimedia Contact Center Fax options is done in the Contact Center Management website.

To configure fax options
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from a fax queue, click Edit.
 4. Click theMultimedia Contact Center Fax options tab.
 5. AfterPublic email address, type the address of the public fax address.

NOTE:
l The queue public folder name is permanent.
l Exchange will attempt to assign an email address (<QueueName>@yourdomain.com) to the

queue public folder. However, if that email address already exists, it might assign an email
address named <QueueName>2@yourdomain.com. To correct this, youmust use Active
Directory Users and Computers and/or Exchange SystemManager to swap the email address of
the conflictingmail-enabled items. To do this, youmodify the properties on the email address tab
for the appropriate User, Distribution List, or Public Folder.

 6. AfterQueue public folder name, type the name associated with the public email address.
The queue public folder name is the name used to describe the alias email for the queue. For example, if
the alias is Support@yourcompany.com, then the public folder name could be Support.
TheQueue Public Folder Name displays in the Outlook public folder list as
CyberAED/Queues/<QueueName>.

 7. AfterEmail address for email replies, type the email address where you want email replies sent.
 8. AfterEmail address for fax replies, type the email address where you want fax replies sent.
 9. AfterGFI reply commands, optionally type fax code for additional fax directives.

For example, youmight want to add a cover sheet to each fax sent out.
 10. Click Save.

Configuring Multimedia Contact Center Fax routing options
ConfiguringMultimedia Contact Center Fax routing options is done in the Contact Center Management
website.

To configure fax routing options
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Queue=>Queue.
 3. Across from a fax queue, click Edit.
 4. Click theMultimedia Contact Center Fax Routing options tab.
 5. AfterPriority of this queue in relation to all other queues associated with this media server, type

a priority value between 1 and 10 inclusive.
The priority value 1 has the highest priority.

 6. UnderRequeue Options, afterAgent requeue time, type theminutes after which the fax contact re-
queues.

 7. AfterDuration a fax is on hold before the agent requeue timer starts, type theminutes after which
the fax contact enters the requeuing sequence.

 8. Under Interflow options, after Interflow Time, type theminutes after which the fax contact is
interflowed.
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 9. If you want the fax to interflow to a specific fax queue, select the Internally interflow to this fax queue
check box, and select the interflow queue.

 10. If you want the fax to interflow to a specific email address, select theExternally interflow contacts to
this email address check box, and type the interflow email address.

 11. Click Save.

Adding queue groups
Queue groups can optionally be configured as Virtual queue groups in YourSite Explorer. Virtual queue groups
are comprised of two or more queues across one or more telephone switches that all send ACD calls to the
same pool of agent groups, balancing loads across queues. Queues within a virtual queue groupmust have
themust have the same reporting numbers, the same agent groups, and different dialable numbers. For
example, in Figure 6 - 10 below, the virtual queue group is made from two queues on two different telephone
systems:

l PBX 1: Queue 7000: reporting number P700, dialable 7000 on PBX1, agent groups 700, 701, 702
assigned

l PBX 2: Queue 7001: reporting number P700, dialable 7001 on PBX2, agent groups 700, 701, 702
assigned

Figure 6 - 10 Virtual Queue Group

Virtual queue groups provide the ability to mergemultiple queues into a single visual representation in
Interactive Visual Queue and provide callers with an accurate position in queue through the Updated Position
in Queuemessaging service.

NOTE:Although virtual queue groups are added and configured under QueueGroups in YourSite Explorer, a
virtual queue group is treated as a singular entity.
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Youmust add queue groups to the YourSite database, and associate queues to the queue groups so you can
run reports on queue group activities and view queue group activities in real time.

NOTE: When a queue is added in Contact Center Management and synchronized with the telephone system,
real-time events are turned on by default.

If you have an SX-200 telephone system, youmust add queue groups in the Contact Center Management
website using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess telephone system, you add
queue groups in YourSite Explorer.

Adding queue groups (in YourSite Explorer)
To add a queue group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Queue Groups.
 3. Click Add.
 4. Type aName and aReporting number for the queue group.
 5. If you want to make the queue group a Virtual queue group, select theVirtual Queue check box.

NOTE:Virtual queue groups may include queues frommultiple telephone systems, but the queues must
have the same reporting numbers, different dialable numbers, and the same agent groups.

 6. On the ribbon, click Save.

Associating queues with queue groups (in YourSite Explorer)
To associate a queue with a queue group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Queue Groups.
 3. Select a queue group from the list.
 4. On theMembership tab, underAvailable members, select a queue and click > to move the queue to

theSelected members list.
 5. On the ribbon, click Save.

Adding queue groups (in the Contact Center Management website)
To add a queue group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Queue=>Queue group.
 3. Click Add.
 4. Specify queue group identification information.
 5. If you want to add all queues to this queue group, select theAutomatically add all queues to this

queue group check box.
 6. Click Save.

Associating queues with queue groups (in the Contact Center
Management website)
To associate a queue with a queue group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Queue=>Queue group.
 3. Across from the queue group to which you want to associate queues, click Members.

The Edit queue groupmembers window opens.
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 4. UnderAvailable queues, select the check boxes of themembers to be added to the group and click
Add selected >>.

 5. Click Save.

Adding extensions
When you perform Synchronization, YourSite Explorer is configured tomirror the phone set extension
numbers/base directory numbers (DNs) on the 3300 ICP. If you have traditional agents that can sit at multiple
locations within your organization, hot desking agents, or general business hot desking extensions, we
recommend you give these base extensions generic names based on the position of the physical DNs (for
example, Base DN: Floor 2, Desk 1). We recommend only general business hot desking extensions assigned
to specific hot desking users be given user-based names (for example, Hot desking extension: John, Smith).
If you have traditional ACD agents who sit at the same desk every day, or traditional extension phone sets
that belong to single users, we recommend that the base DNs be configured with the user's names.

NOTE: Agents are programmed in YourSite Explorer. If agents are in a clustered environment but not hot
desking and not resilient, the agent names will not display on the telephone switch. Youmust enter these
agent names outside of Contact Center Management.

In order to provide Contact CenterWork Timer functionality in Contact Center Client, every traditional agent’s
extension or every hot desking Agent ID must be enabled with aMiTAI monitor.

If your agents handle calls for multiple voice queues, you can add additional agent login IDs. For the SX-200,
you do so in YourSite=>Configuration=>Employee=>Employee=>View agent logins. For the 3300 ICP, 5000,
and Axxess, you do so in YourSite Explorer.

Adding extensions (in YourSite Explorer)
NOTE: For information on configuring extensions for IVR Routing, see "Configuring extensions" on page 440.

To add an extension in YourSite Explorer
 1. In YourSite Explorer, click YourSite=>Devices.
 2. Click Extensions.
 3. Click Add.
 4. UnderGeneral, specify extension identification information and click ... to select themedia server and

failover media server for the extension.
 5. Select theClass of Service for themedia server, from the drop-down list.
 6. UnderNotes, select theDisable real-time monitoring and data collection on this device check

box if you do not want to enable the extension to be set with aMiTAI monitor, viewed in Contact Center
Client, and use Contact Center Softphone or Salesforce.com Connector.
By default, this check box is not selected.

 7. If the extension is a general business hot desking extension, select the Is general business hot
desking check box.

 8. If the extension will be costed with Call Accounting, under Licensing, select theCost this extension
check box.

 9. If you want to enable this extension for external hot desking, select theExternal hot desk user
enabled check box.
Extensions that are enabled as external hot desk users can handle non-ACD calls while logged in
externally.
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 10. AfterExternal dialing prefix, type the dialing prefix for the external device to which calls will be routed.
 11. AfterExternal dialing number, type the dialing number for the external device to which calls will be

routed.
 12. On the ribbon, click Save.

Adding extensions (in the Contact Center Management website)
To add an extension
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Extension=>.
 3. Click Add.
 4. If you want to create an employee ID and associate it with the extension, select theCreate a new

employee for this extension check box.
NOTE:Select this check box only if you have not already added employee IDs to the database.
Some employees havemultiple extension reporting numbers. Associating an employee with each of
the employee’s extensions enables you to run an employee report and consolidate the data for all of the
employee’s extensions.

 5. Specify extension identification information and select amedia server and failover media server for the
extension.

 6. AfterSite, select the site with which to filter themedia server list.
 7. UnderAdvanced options(3300 ICP only),

l If the extension is resilient, click This extension is resilient.
l If the extension will be costed with Call Accounting and you are not licensed for Call Accounting

resiliency, click This extension is costed.
l If you are licensed for Call Accounting resiliency and the extension will be resilient and costed, click

This extension is resilient and costed.
l To apply the advanced option to all extensions associated with themedia server, select theApply

this setting to all extensions associated with this media server check box.
 8. Click Save.

Adding extension groups
After adding extensions, you add extension groups and associate extensions with these groups.

If you have an SX-200 telephone system, youmust add extension groups in the Contact Center Management
website using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess, you add extension groups
in YourSite Explorer.

Adding extension groups (in YourSite Explorer)
To add an extension group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Extension groups.
 3. Click Add.
 4. Type aName and aReporting number for the extension group.
 5. On the ribbon, click Save.

Associating extensions with extension groups (in YourSite Explorer)
To associate an extension with an extension group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Extension groups.
 3. Select an extension group from the list.
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 4. On theMembership tab, underAvailable members, select an extension and click > to move the
extension to theSelected members list.

 5. On the ribbon, click Save.

Adding extension groups (in the Contact Center Management website)
To add an extension group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Extension=>Extension group.
 3. Click Add.
 4. Type aName and aReporting number for the extension group.
 5. If you want to add all voice extensions to this extension group, select Automatically add all voice

extensions to this extension group.
 6. On the ribbon, click Save.

Associating extensions with extension groups (in the Contact Center
Management website)
To associate an extension with an extension group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Extension=>Extension group.
 3. Across from the extension group to which you want to associate extensions, click Members.

The Edit extension groupmembers window opens.
 4. UnderAvailable extensions, select the check boxes of themembers to be added to the group and click

Add selected >>.
 5. Click Save.

Adding trunks
If you have an SX-200 telephone system, youmust add trunks in the Contact Center Management website
using YourSite=>Configuration. If you have a 3300 ICP, 5000, or Axxess, you add trunks in YourSite
Explorer.

NOTE:
l If you want to report on SMDR information for SIP trunks youmust ensure your SMDR tag is

numbered. Please see theContact Center Management Installation Guide.
l We recommend you name trunks and trunk groups in a way that helps you identify them as either SIP

or TDM trunks, enabling the trunk type to be easily identified in reports.

Adding trunks (in YourSite Explorer)
To add a trunk
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Trunks.
 3. Click Add.
 4. Type aName and aReporting number for the trunk.
 5. Click ... and select aMedia server to associate with the trunk.
 6. On the ribbon, click Save.
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Adding trunks (in the Contact Center Management website)
To add a trunk
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Trunk=>.
 3. Click Add.
 4. Type aName and aReporting number for the trunk.
 5. Select aSite to associate with the trunk.
 6. Select aMedia server to associate with the trunk.
 7. Click Save.

Adding trunk groups
You add trunk groups and then associate trunks with the trunk groups.

If you have a 3300 ICP, 5000, or Axxess, you add trunk groups in YourSite Explorer. If you have an SX-200,
you add trunk groups in the Contact Center Management website.

NOTE:
l If you have Traffic Analysis and/or Call Accounting and use the same trunk group numbers across

multiple telephone systems, youmust associate each trunk group with amedia server.
l We recommend you name trunks and trunk groups in a way that helps you identify them as either SIP

or TDM trunks, enabling the trunk type to be easily identified in reports.

If you have Traffic Analysis and/or Call Accounting and use the same trunk group numbers across multiple
telephone systems, youmust associate each trunk group with amedia server.

Adding trunk groups (in YourSite Explorer)
To add a trunk group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Trunk groups.
 3. Click Add.
 4. Type aName and aReporting number for the trunk group.
 5. Click ... and select aMedia server to associate with the trunk group.
 6. On the ribbon, click Save.

Associating trunks with trunk groups (in YourSite Explorer)
To associate a trunk with a trunk group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Trunk groups.
 3. Select a trunk group from the list.
 4. On theMembership tab, underAvailable members, select a trunk and click > to move the trunk to the

Selected members list.
 5. On the ribbon, click Save.
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Adding trunk groups (in the Contact Center Management website)
To add a trunk group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Trunk=>Trunk Group.
 3. Click Add.
 4. Type aName and aReporting number for the trunk group.
 5. Select aMedia server to associate with the trunk group.
 6. If you want to add all trunks to this trunk group, select theAutomatically add all trunks to this trunk

group check box.
 7. Click Save.

Associating trunks with trunk groups (in the Contact Center Management
website)
To associate a trunk with a trunk group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the Configurationmenu, click Trunk=>Trunk group.
 3. Across from the trunk group to which you want to associate trunks, click Members.

The Edit trunk groupmembers window opens.
 4. UnderAvailable trunks, select the check boxes of themembers to be added to the trunk group and

click Add selected >>.
 5. Click Save.

Adding DNIS
Dialed Number Identification Service (DNIS) is a feature of toll-free lines that identifies the telephone number
the caller dials. This assists agents who handle calls for more than one business or product line. Each
business or product line has its own toll-free number. When a caller dials a toll-free number, the telephone
system forwards information to the agent allowing the agent to identify who the caller dialed. For example, a
caller dials a toll-free number for a cruise line. The telephone system sends a script to the agent along with the
call. The agent then knows to answer “Goodmorning. Thank you for calling Southern Cruises,” instead of the
name of another cruise line serviced by the center.

Adding DNIS (in YourSite Explorer)
To add a DNIS
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click DNIS.
 3. Click Add.
 4. Specify DNIS identification information and click ... to select themedia server for the DNIS.
 5. AfterShort Abandon, type the duration for the call abandon parameter. If the abandon time is less than

the call abandon parameter, then the call is a short abandon call and is not included in the call statistics
(for example, type 5 to define a short abandon call as a call that lasts less than 5 seconds).

 6. AfterService Level, type the Service Level time.
 7. If you have Call Accounting, select a carrier plan, call type, and call rate.
 8. On the ribbon, click Save.
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Adding DNIS (in the Contact Center Management website)
To add a DNIS
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click DNIS=>.
 3. Click Add.
 4. Specify DNIS identification information and select themedia server for the DNIS.
 5. AfterShort Abandon, type the duration for the call abandon parameter. If the abandon time is less than

the call abandon parameter, then the call is a short abandon call and is not included in the call statistics
(for example, type 5 to define a short abandon call as a call that lasts less than 5 seconds).

 6. AfterService Level, type the Service Level time.
 7. Click Save.

Adding DNIS groups
After adding DNIS, you can create DNIS groups and then associate DNIS numbers for specific businesses or
product lines to those groups.

Adding DNIS groups (in YourSite Explorer)
To add a DNIS group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click DNIS groups.
 3. Click Add.
 4. Type aName and aReporting number for the DNIS group.
 5. On the ribbon, click Save.

Associating DNIS to DNIS groups (in YourSite Explorer)
To associate a DNIS with a DNIS group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click DNIS groups.
 3. Select a DNIS group from the list.
 4. On theMembership tab, underAvailable members, select a DNIS and click > to move the DNIS to

theSelected members list.
 5. On the ribbon, click Save.

Adding DNIS groups (in the Contact Center Management website)
To add a DNIS group
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click DNIS=>DNIS Group.
 3. Click Add.
 4. Type aName and aReporting number for the DNIS group.
 5. If you want to add all DNIS to this DNIS group, select theAutomatically add all DNIS to this DNIS

group check box.
 6. Click Save.
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Associating DNIS to DNIS groups (in the Contact Center Management
website)
To associate a DNIS with a DNIS group
 1. On the configurationmenu, click DNIS=>DNIS Group.
 2. Across from the DNIS group to which you want to associate DNIS, click Members.

The Edit DNIS groupmembers window opens.
 3. UnderAvailable DNIS, select the check boxes of themembers to be added to the DNIS group and

click Add selected >>.
 4. Click Save.

Adding Account Codes
Account Codes can be verified, non-verified, or forced.

l Verified and Non-Verified Account Codes
Verified and Non-Verified Account Codes allow callers to complete a call without entering a code.
These codes are used to categorize calls or portions of calls. You define Account Codes in the YourSite
database to generate reports for specific departments, services, and companies. For example, an
agent who receives calls for three catalog companies enters Account Code 01 for calls to company X,
Account Code 02 for calls to company Y, and Account Code 03 for calls to company Z. When you
configure the Account Codes, Contact Center Management generates reports on the number, origin,
and handling of calls for each of the departments, services, or companies.

l Forced Account Codes
Both Verified and Non-Verified Account Codes can be forced. With Forced Verified Account Codes,
youmust enter the Account Code as soon as the phone is off-hook. With Forced Non-Verified Account
Codes, youmust enter the Account Code after you dial the phone number.

For example, youmight have 03 programmed on the telephone system as the trunk access code for
calling England. Before youmake a call to England, youmust preface the telephone number with the
Account Code 03, otherwise the call will not go through. To report on these verified Account Codes, you
define them in the YourSite database.

NOTE:
l If you will used forced account codes and have aMake Busy button programmed on your Mitel phone

set, youmust remove theMake Busy button, or forced account codes will not work with Interactive
Contact Center and Contact Center PhoneSet Manager.

l If a Forced Verified Account Code is not entered in before work timer expires, then a -1 Non Compliant
Code will be automatically assigned to the call.

You can add Account Codes for individual departments, projects, and services and generate reports on them.
Agents can tag incoming calls with Account Codes for various services. Agents who work for companies that
use Call Accounting can use Account Codes to gain access to outside lines.

If you are adding Account Codes to be used by voice agents, you print a copy of your telephone system
assignment forms to use as a guide for programming. If you are adding Account Codes to be used by email,
SMS, chat, or fax agents, you enter Account Code reporting numbers of your choice.

You can label Account Codes as call classification codes. This option associates the entire handling time to
calls of this Account Code type. This option is available for contact centers that have the 3300 ICP only.
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If you have an SX-200, you add Account Codes in Contact Center Management, YourSite=>Configuration.

If you have a 3300 ICP, 5000 or Axxess, you add Account Codes in YourSite Explorer.

Adding Account Codes (in YourSite Explorer)
To add an Account Code
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Account Codes.
 3. Click Add.
 4. Type aName andReporting number for the Account Code.
 5. If the Account Code will be used as a call classification code, select theUse as Classification Code

check box.
NOTE:

l When the "Use as Classification Code" check box is enabled, the Account Code duration spans
from the time the call arrives until the call ends. When you disable the "Use as Classification
Code" check box, the Account Code duration spans from the time the code was entered until the
next code is entered or the call ends.

l As a best practice, we recommend you name all call classification codes for easy identification
or group call classification codes in Account Code groups.

 6. On the ribbon, click Save.

Adding Account Codes (in the Contact Center Management website)
To add an Account Code
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Account Code.
 3. Click Add.
 4. Select the employee ID that is associated with this Account Code.
 5. Type aName andReporting number for the Account Code.
 6. Click Save.

Adding Account Code groups
You can create Account Code groups to group similar Account Codes or to differentiate traditional Account
Codes and call classification codes. Agents can readily identify and select appropriate Account Codes using
the soft phone or Interactive Contact Center and supervisors can report on Account Code groups.

To add an Account Code group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Account Code Groups.
 3. Click Add.
 4. Type aName andReporting number for the Account Code group.
 5. On the ribbon, click Save.
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Associating Account Codes with Account Code groups
To associate an Account Code with an Account Code group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Account Code groups.
 3. Select an Account Code group from the list.
 4. On theMembership tab, underAvailable members, select an Account Code and click > to move the

Account Code to theSelected members list.
 5. On the ribbon, click Save.

Adding Account Code categories
In businesses that use a large number of Account Codes, Account Code categories can be used to provide a
hierarchical and grouped listing of the Account Codes available to agents and employees from the soft phone
toolbar within Contact Center Client. You configure Account Code categories from within YourSite Explorer.
Once you have configured Account Codes, they can be nested under specific Account Code categories. An
Account Code can only be in one category. Call Classification Codes, which are treated the sameway as
Account Codes, can optionally be nested in Account Code categories. Account Code category availability to
agents and employees can optionally be controlled using Contact Center Management / Call Accounting
security. When Account Code categories are enabled, Contact Center Management / Call Accounting reports
will display the Account Code category path (for example, Sales=>Automotive=>Tires).

To enable Account Code categories
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Account Codes.
 3. In the ribbon, click theConfiguration tab.
 4. Enable theDisplay Account Codes in categoriescheckbox.

To add an Account Code category
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Account Codes.
 3. In the ribbon, click theConfiguration tab.
 4. Ensure theDisplay Account Codes in categories checkbox is enabled.
 5. Click Edit categories.

The Account Code category designer displays.
 6. Using the Account Code category designer, add and name Account Code categories in the left pane and

then add the Account Codes you have configured, which display in the left pane) to the custom
categories.
Account Code categories are sorted by category name and Account Code reporting number. Account
Code categories will display in soft phone toolbars exactly as you have designed them in the Account
Code category designer. If you have Account Code categories enabled, but do not assign Account
Codes to categories, leaving them in the right pane of the designer, these Account Codes will not be
available in the soft phone toolbar.



YourSite database configuration

- 158 -

Adding ANI
You define area codes and corresponding regions on the ANI tab. The ANI window provides area codes used
to produce reports on the number of telephone calls originating from various geographical regions.

To add an ANI number
 1. In Contact Center Management, click YourSite=>Configuration=>ANI.
 2. Click Add.
 3. Specify ANI identification information.
 4. AfterDigits to follow, type the digits that follow the ANI number.
 5. Click Save.

Adding Make Busy Reason Codes
Voice agents can place themselves in Make Busy using their phone sets, provided theMake Busy with
Reason option is enabled on the telephone system. Using Interactive Contact Center, agents can place
themselves in Make Busy with reason in Contact Center Client, and supervisors can place agents in Make
Busy with reason in Contact Center Client. Agents enter Make Busy Reason Codes to indicate why they are
placing themselves in Make Busy and not answering contacts.

If you have Interactive Contact Center or Multimedia Contact Center, you assignMake Busy Reason Codes
the reporting numbers of your choice. Otherwise, you typeMake Busy Reason Code reporting numbers listed
on the telephone system assignment forms.

TwoMake Busy Reason Codes are configured by default with Contact Center Management and cannot be
deleted from YourSite Explorer: Contact CenterWork Timer (Reporting Number -3) and SystemMake Busy
Code (Reporting Number -1). The -3Make Busy Reason Code is specifically allocated for configurations that
use Contact CenterWork Timer instead of the default Mitel telephone systemWork Timer.

The -1Make Busy Reason Code is allocated for when:
l Multimedia Contact Center messages are requeued
l Multimedia Contact Center agents force forwardmessages
l Smart Algorithms are enabled and an agent goes into an ACD ringing state
l Certain Exchange public folder errors. For example, if errors are encountered with Exchange public

folders for a specific agent for toomany consecutive times

These codes are programmedwith aminus ( - ) in front of them becauseMake Busy Reason Code 0 is
reserved for telephone systemMake Busy and customMake Busy Reason Codes and can be programmed
using any digit between 1-9 on the dial pad.

Adding Make Busy Reason Codes (in YourSite Explorer)
To add aMake Busy Reason Code
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Make Busy Reasons.
 3. Click Add.
 4. Type aName andReporting number for theMake Busy Reason Code.
 5. On the ribbon, click Save.
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Adding Make Busy Reason Codes (in the Contact Center Management
website)
To add aMake Busy Reason Code
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Make Busy Reason Code.
 3. Click Add.
 4. Type aName andReporting number for theMake Busy Reason Code.
 5. Click Save.

Adding Do Not Disturb Reason Codes
Interactive Contact Center, an optional application, enables supervisors who have a 3300 ICP, 5000, or
Axxess telephone system to control the availability of agents and ACD queues. Likewise, agents can control
their own availability, including placing themselves in or removing themselves from DoNot Disturb. There are
many reasons why agents place themselves in Do Not Disturb. You assign these reasons in YourSite
Explorer.

To add a DoNot Disturb Reason Code
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click DND Reason Codes.
 3. Click Add.
 4. Type aName andReporting number for the DoNot Disturb Reason Code.
 5. On the ribbon, click Save.

Adding phone numbers
The phone number device enables you to

l Add contacts.
l Edit location information that displays in reports.

When adding a phone number to the database, you select
l Area/City codewhen you are adding or updating the area code for a province/state/city

For the phone number 613-599-0045, 613 is the area code.
l City exchangewhen you are adding a new exchange

For the phone number 613-599-0045, 599 is the city exchange (Kanata).
l Contactwhen you are adding a phone number with contact information

For the phone number 613-599-0045, 5990045 is the contact.

To add a phone number area/city code
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Phone numbers.
 3. Click Add=>Add an area/city code.
 4. Select a country and type an area/city name and area code.

An area can be a city, region, province, or state.
 5. On the ribbon, click Save.
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To add city exchange information
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Phone numbers.
 3. Click Add=>Add a city exchange.
 4. AfterCountry, select a country.
 5. AfterArea/City name, select a city, region, province, or state (for example, Greater Toronto Area).
 6. AfterCity name, type the name of a city or suburb (for example, Thornhill).
 7. AfterCity/Exchange, type a city exchange number (for example, 231).

For the phone number 416-231-5555, 231 is the city exchange.
 8. On the ribbon, click Save.

To add phone number contact information
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Phone numbers.
 3. Click Add=>Add a contact.
 4. AfterCountry, select a country.
 5. AfterArea/City name, select a city, region, province, or state (for example, Washington).
 6. AfterCity name, select a city or suburb (for example, Des Moines).
 7. Type a contact name and number.

This information displays in the Phone Number Accounting Trace and Phone Number Group
Accounting Trace reports.

 8. If you want to hide the contact name and number in reports select theHide the name and number in
reports check box.

 9. On the ribbon, click Save.

Adding phone number groups
You can associate Phone numbers with Phone number groups. Phone number groups are added in YourSite
Explorer and then Phone numbers are associated with them.

To add a Phone number group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Phone number groups.
 3. Click Add.
 4. Type aName andReporting number for the Phone number group.
 5. On the ribbon, click Save.

To associate a Phone number with a Phone number group
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Phone number groups.
 3. Select a phone number group from the list.
 4. On theMembership tab, underAvailable members, select a Phone number and click > to move the

Phone number to theSelected members list.
 5. On the ribbon, click Save.
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Adding auto-acknowledgement messages and associating them with
queues
You define theMultimedia Contact Center acknowledgement the customer receives (after emailing or sending
a chat message to your company) on theMultimedia Contact Center auto-acknowledgement tab. For
example, the Payment Response acknowledgement sent to a customer upon payment for an order might be
“Thank you for shopping with us. Your order is scheduled for delivery onMay 05, 2009 between the hours of
9:00 A.M. and 5:00 P.M., pending credit approval.”

To add an auto-acknowledgement
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Multimedia Contact Center=>Multimedia Contact Center auto-

acknowledgement.
 3. Click Add.
 4. AfterName, type the name of the auto-acknowledgement.
 5. AfterBody, type themessage the caller will receive.
 6. Click Save.

To associate an auto-acknowledgement with a queue
 1. In Contact Center Management, click YourSite=>Configuration.
 2. On the configurationmenu, click Queue=>Queue.
 3. Across from a queue with an email, chat, or fax media server, click Edit.
 4. On theMultimedia Contact Center auto-acknowledgement tab, select theEnable auto-

acknowledgement messages for this queue check box.
 5. AfterDuring business hours, the auto-acknowledgement message is, select a business-hours

auto-acknowledgement message.
An auto-acknowledgement is a greeting the client receives in response to contacting your company by
email, SMS, chat, or fax. For example, the auto-acknowledgement could be “Thank you for your email.
Wewill respond to your request shortly.”

 6. If youmust create or modify an auto-acknowledgement message, click Manage and configure a
message.

 7. AfterOutside business hours, the auto-acknowledgement message is, select an after-hours auto-
acknowledgement message.

 8. Click Save.

Configuring Intelligent Queue devices
NOTE:Youmust have the Intelligent Queue application, and add an Intelligent Queuemedia server to your
site before you can view the Intelligent Queue option on the YourSite Configurationmenu. See "Adding
Intelligent Queuemedia servers" on page 93.

Viewing Smart Choice layers
You can configure your ports to act as options, or Smart Choicemessage trees. Each option will play a user-
definedmessage and transfer the caller to a user-defined destination, or allow the customer to create a voice
callback if this option has been purchased.
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To view Intelligent Queue Smart Choice layers in the YourSite database
l In Contact Center Management, click YourSite=>Configuration=>Intelligent Queue=>Intelligent

Queue Smart Choice=>Intelligent Queue Smart Choice layer.
The Intelligent Queue Smart Choice layer window opens.
Under Media server, the Intelligent Queuemedia servers are listed.
Under Reporting number, the Intelligent Queue Smart Choice layer reporting numbers are listed.
Under Name, the Intelligent Queue Smart Choice layer names are listed.

Adding Smart Choice layer groups
To add an Intelligent Queue Smart Choice layer group
 1. In Contact Center Management, click YourSite=>Configuration=>Intelligent Queue=>Intelligent

Queue Smart Choice=>Intelligent Queue Smart Choice layer group.
 2. Click Add.

The Add an Intelligent Queue Smart Choice layer group window opens.
 3. Specify identification information for the Smart Choice layer group.
 4. Click Save.

Adding Smart Choice layers to a Smart Choice layer group
To add Intelligent Queue Smart Choice layers to an Intelligent Queue Smart Choice layer group
 1. In Contact Center Management, click YourSite=>Configuration=>Intelligent Queue=>Intelligent

Queue Smart Choice=>Intelligent Queue Smart Choice layer group.
The Intelligent Queue Smart Choice layer group window opens.

 2. Across from the record of the Smart Choice layer group just created, click Members.
 3. UnderAvailable Intelligent Queue Smart Choice layers, select the check boxes of themembers you

want to add to the group and click Add >>.
 4. Click Save.

Viewing Intelligent Queue ports
To view Intelligent Queue ports in the YourSite database

l In Contact Center Management, click YourSite=>Configuration=>Intelligent Queue=>Intelligent
Queue Smart Choice=>Intelligent Queue Smart Choice port.
The Intelligent Queue Smart Choice port window opens.
Under Media server, themedia server associated with each Intelligent Queue port is listed.
Under Reporting number, the Intelligent Queue port reporting numbers are listed.
Under Name, the Intelligent Queue port names are listed.
Under Dialable number, the dialable numbers are listed.

Adding Intelligent Queue port groups
To add an Intelligent Queue port group
 1. In Contact Center Management, click YourSite=>Configuration=>Intelligent Queue=>Intelligent

Queue Smart Choice=>Intelligent Queue Smart Choice port group.
 2. Click Add.

The Add an Intelligent Queue Smart Choice port group window opens.
 3. Specify identification information for the Intelligent Queue port group.
 4. Click Save.
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Adding Intelligent Queue ports to an Intelligent Queue port group
To add an Intelligent Queue port to an Intelligent Queue port group
 1. In Contact Center Management, click YourSite=>Configuration=>Intelligent Queue=>Intelligent

Queue Smart Choice=>Intelligent Queue Smart Choice port group.
The Intelligent Queue Smart Choice port group window opens.

 2. Across from the record of the Intelligent Queue Smart Choice port group just created, click Members.
The Edit Intelligent Queue Smart Choice port groupmembers window opens.

 3. UnderAvailable Intelligent Queue Smart Choice ports, select the check box of themember you
want to add to the group and click Add >>.

 4. Click Save.

Viewing Intelligent Queue Smart Choice layer exit codes
Exit codes trigger each exit from a queue or from the auto attendant. They apply to Smart Choicemessage
queues, RAD queues, and routing queues.

To view Intelligent Queue Smart Choice layer exit codes in the YourSite database
l In Contact Center Management, click YourSite=>Configuration=>Intelligent Queue=>Intelligent

Queue Smart Choice layer exit code.
The Intelligent Queue Smart Choice layer exit code window opens.
Under Reporting number, the Intelligent Queue exit code reporting numbers are listed.
Under Name, the Intelligent Queue exit code names are listed.

Configuring employee scheduling preferences
Schedule Builder uses employee preferences/options as parameters when scheduling employees. Youmust
configure employee scheduling preferences accurately in YourSite Explorer to create ameaningful schedule.

To configure employee information for scheduling
 1. Select the employee or employees you want to configure.
 2. Specify the employee role.

See "Configuring employee roles" on page 164.
 3. Specify employee work hours.
 4. Specify employment status.

See "Configuring employment status" on page 164.
 5. Specify employee payroll information.

See "Configuring employee payroll information" on page 164.
 6. Specify employee availability.

See "Configuring employee availability" on page 165.
 7. Specify time off information

See "Configuring employee time off" on page 165.
 8. Specify employee skills

See "Configuring employee skills" on page 166.
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Configuring employee roles
To configure an employee role
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Employees.
 3. Select the employee to which you will add an employee role.
 4. On theWorkforce Scheduling tab, click General.
 5. If the employee is a supervisor who will schedule employees, select the Is a supervisor of scheduled

employees check box.
 6. AfterSchedule supervisor name, select the name of the scheduling supervisor from the list.
 7. On the ribbon, click Save.

Configuring employee work hours
To configure employee work hours
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Employees.
 3. Select an employee.
 4. On theWorkforce Scheduling tab, clickWork hours.
 5. Enter theminimum andmaximum number of hours the employee can work in a day, week, or year.
 6. If you want to schedule the employee for an unlimited number of hours, click Unlimited.
 7. AfterMinimum time required between shifts, enter theminimum number of hours required between

the employee's shifts.
NOTE:Ensure you set aminimum time between shifts or Schedule Builder will schedule back-to-back
shifts for employees.

 8. If the employee is permitted to work overtime, underAvailable, select an overtime type from the list and
click > to move the overtime type to theAssigned list.

 9. On the ribbon, click Save.

Configuring employment status
To configure employment status
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Employees.
 3. Select an employee.
 4. On theWorkforce Scheduling tab, click Payroll.
 5. If the selected employee is full-time, underEmployment status, select Full time.
 6. If the selected employee is part-time, underEmployment status, select Part time.
 7. On the ribbon, click Save.

Configuring employee payroll information
NOTE: If you want to schedule employees by seniority, the employeemust be assigned a hire date.

To configure employee payroll information
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Employees.
 3. Select an employee.
 4. On theWorkforce Scheduling tab, click Payroll.
 5. UnderSalary, afterPay period, select the pay period for the employee.
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 6. If the employee is paid an hourly salary, next toHourly salary, specify the employee's pay per hour.
 7. If the employee is paid a yearly salary, next toYearly salary, specify the employee's yearly salary and

the typical number of hours the employee works in a week.
 8. On the ribbon, click Save.

Configuring employee availability
NOTE: If you do not specify availability, Schedule Builder assumes the employees are available 24 hours a
day, seven days a week.

To configure employee availability
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Employees.
 3. Select an employee.
 4. On theWorkforce Scheduling tab, click Availability.
 5. Select theUses availability check box.
 6. UnderNew Availability, afterWork day, select the day of the week the employee availability applies to

from the list.
 7. If the employee is available only during certain hours of the day, select Part of the day and specify the

hours the employee is available.
 8. If the employee is available all day, select Full day.
 9. Click Add availability.
 10. On the ribbon, click Save.

Configuring employee time off
To configure employee time off
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Employees.
 3. Select an employee.
 4. On theWorkforce Scheduling tab, click Time off.
 5. If the employee's time off is carried over based on their start date, underCarryover date, select

Employee start date.
 6. If the employee's time off is carried over based on a fixed date, underCarryover date, select Fixed

date and specify the carryover date.
 7. If the employee is permitted time off, underAvailable, select the time off type from the list and click > to

move the time off type to theAssigned list.
 8. On the ribbon, click Save.

Overriding employee time off
To override an employee time off type
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Employees.
 3. Select an employee.
 4. On theWorkforce Scheduling tab, click Time off.
 5. UnderAssigned time off, select a time off type to override.
 6. If you want to override the total number of time off hours allowed, select theOverride total hours

allowed check box and specify the number of hours.
 7. If you want to override a percent of time off hours based on time worked, select theOverride % of

hours worked check box and specify the number of hours.
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 8. If you want to override the number of hours that can be carried over, select theOverride allowed carry
over and specify the number of hours.

 9. If you want to override the time off hours available to the employee, afterAvailable as of, specify the
date after which the time off hours are available and number of hours that will be available.

 10. On the ribbon, click Save.

Configuring employee skills
NOTE: If you have selectedmultiple employees to edit, skills that are not available to these employees are
grayed out and cannot be assigned.

To configure employee skills
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Employees.
 3. Select an employee.
 4. On theWorkforce Scheduling tab, click Skills.
 5. UnderAvailable, select the skill type from the list and click > to move the skill type to theAssignedlist.
 6. Repeat step 5 for all skills the employee will use.
 7. On the ribbon, click Save.

Configuring scheduling options
Before you canmake schedules inWorkforce Scheduling, youmust configure the following scheduling
options in YourSite Explorer

l Employees
See "Adding employees" on page 123.

l Holidays
See "Configuring holidays" on page 166.

l Overtime types
See "Configuring overtime types" on page 167.

l Time off types
See "Configuring time off types" on page 167.

l Skills
See "Configuring skills" on page 168.

Configuring holidays
You configure holiday options on the Holidays window. You can add holidays that affect your contact center,
specify which holidays give employees the day off, and specify which holidays are paid.

To configure a holiday
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Holidays.
 3. Click Add.
 4. AfterName, type the name of the holiday.
 5. If this holiday is a company holiday and you want to receive warnings when trying to schedule

employees for this day, select the This holiday is a company holiday check box.
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 6. Specify the pattern of the holiday.
l If the holiday always falls on the same day of themonth, select Every and specify themonth and

date the holiday falls on.
l If the holiday has a pattern of falling on a certain day, week, andmonth, select The and specify the

pattern, day of week, andmonth.
l If the holiday is a calculated holiday, such as Good Friday or Easter Monday, select Calculated

holiday and specify the holiday.
 7. On the ribbon, click Save.

Configuring overtime types
You can configure the following overtime parameters:

l Pay rate multiplier—The number of times by which the basic pay is increased to calculate the
overtime pay rate. For example, if the pay ratemultiplier is 1.5 and applied to $10 per hour, the overtime
pay rate is $15 per hour

l Color—The color in which the job displays in the time bar pane
l Hours worked in a given day are greater than—The number of hours in a day an employeemust

work before the employee is paid at the overtime pay rate
l Hours worked in a given week are greater than—The number of hours in a week an employeemust

work before the employee is paid at the overtime pay rate
l Days of the week worked—Any work done on these days will be considered overtime pay
l Day of the year worked—Any work done on this specific date will be considered overtime pay
l Holiday worked—Any work done on this specific holiday will be considered overtime pay

To configure an overtime type
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Overtime.
 3. Click Add.
 4. AfterName, type the name of the overtime type.
 5. UnderEffects, enter a pay ratemodifier and select a color for the overtime type.
 6. UnderConditions, select eitherHours worked, Days of the week worked, Days of the year

worked, orHoliday worked.
l If you select Hours worked, youmust select either Hours worked on a given day are greater than or

Hours worked on a given week are greater than and specify the number of hours.
l If you select Days of the week worked, select they days of the week to which this overtime type

applies.
l If you select Days of the year worked, select the days of the year to which this overtime type

applies.
l If you select Holiday worked, select the holiday to which this overtime type applies.

 7. On the ribbon, click Save.

Configuring time off types
Employees might take time off work for a variety of reasons. Depending on the nature of time taken off,
employees might be paid, employees might be required to take a full day as time off, and employees might
accrue time off (for example, vacation).

Create time off types that reflect the time off that employees take at your contact center.
l Consider if the type of time off should accrue, such as vacation, time off for amedical procedure, or

personal days.
l Consider when the time off is accrued. For example, an employeemight accrue 1 day of paid sick

leave per month.
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l Consider if the type of time off must be taken as a full day.
l Consider if employees must qualify for the type of time off.
l Consider if employees can carry the time off over to the next year.

Workforce Scheduling can warn you when employees do not qualify for the time off or when the scheduled
time off is not within the limits allowed.

To configure a time off type
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Time off.
 3. Click Add.
 4. AfterName, type the name of the time off type.
 5. If employees will be paid for this time off type, underEffects, select thePaid time off check box and

select a color for the time off type.
 6. If employees can request this type of time off from Employee Portal, underEffects, select theCan be

requested check box.
 7. UnderEmployment duration qualification, select either theEmployed for at least orEmployed no

more than check box and specify the number of months.
 8. UnderScheduling limitations, select either theYou must schedule this type in increments of at

least orYou must not schedule this type for more than check box and specify the number of hours
per day/week.

 9. If you want to limit the number of hours this time off type can be scheduled, select the Limit the
number of hours that can be scheduled check box.

l If you want to fix the annual amount of this time off type, select Fixed annual amount of and
specify the number of hours.

l If the annual hours of this time off type are accrued, select theAnnual hours are accrued
check box and select eitherWeekly, Biweekly, orMonthly.

l If you want to base this time off type on a percent of the number of hours worked, select Based
on hours worked at a rate of and specify a percent.

l If you want to carry over a fixed amount of accumulated time off hours, select Percent of
accumulated hours, at a rate of and specify a percent.

l If you want to carry over a percent of accumulated time off hours, select Percent of
accumulated hours, at a rate of and specify a percent.

 10. On the ribbon, click Save.

Configuring skills
Employees offer a variety of different skills. For example, some employees might be bilingual or have
certification in a specialty. UsingWorkforce Scheduling, you can incorporate these skills when you create
your schedules.

Configuring the different types of skills allows you to create andmanage schedules that incorporate the skills
and skill levels of your employees. When you create schedules, Workforce Scheduling allows you to
schedule employees with specific skill sets.

NOTE:Skill levels range from 1 to 10, level 10 being the highest skill level, or most skilled, and level 1 being
the lowest skill level. Remember this when you configure employees in YourSite Explorer or on the Contact
Center Management website.
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To configure a skill
 1. In YourSite Explorer, in the left pane, clickWorkforce Scheduling.
 2. Click Skills.
 3. Click Add.
 4. AfterName, type a name for the skill.
 5. On the ribbon, click Save.

Business hour schedules
You create schedules that accurately reflect the business hours of your operation. You can create yearly or
seasonal schedules. When you install Contact Center Management, the 24/7 default schedule is created.
This schedule is for businesses that operate 24 hours a day, seven days a week.

Your contact center software performs certain tasks during business hours and other tasks after business
hours. For example, Multimedia Contact Center sends business hour auto-acknowledgement messages to
customers who contact you by email or chat during your business hours, and sends outside business hour
auto-acknowledgement messages to customers who contact you by email or chat after your business closes
for the day. You create schedules so that Contact Center Management knows what the hours of operation are
for your business.

You create schedules for the SX-200media server in the Contact Center Management website, under
YourSite=>Schedule. You create schedules for 3300 ICP, 5000, and Axxess media servers in YourSite
Explorer=>Schedules.

Creating schedules
The schedules you create do not expire. The weekly schedule configuration applies week after week until you
change the schedule or apply a different schedule to the device. You can exclude specific dates from the
schedule for national holidays.

To create a schedule in YourSite Explorer
 1. InYourSite Explorer, click Schedules.
 2. Click Add.
 3. AfterName, type the name of the schedule (for example, type Fall 2008 schedule).
 4. AfterSchedule exclusion list, click ... and select a schedule exclusion list.
 5. If youmust create or modify an exclusion list for the schedule, click Manage schedule exclusion list

and configure a list of days to exclude from the schedule.
See "Managing schedule exclusion lists" on page 170.

 6. After Start time, select the business day start time for each day of the week.
 7. AfterEnd time, select the business day end time for each day of the week.
 8. AfterDisable for day, enable the check box for each day your business is closed.
 9. Click Save.

To create a schedule in the Contact Center Management website
 1. In Contact Center Management, click YourSite=>Schedule.
 2. Click Add.

The Add a schedule window opens
 3. AfterName, type the name of the schedule (for example, type Fall 2007 schedule).
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 4. AfterSchedule exclusion list, select a list.
 5. If youmust create or modify an exclusion list for the schedule, click Manage schedule exclusion list

and configure a list.
See "Managing schedule exclusion lists" on page 170.

 6. After Start time, select the business day start time for each day of the week.
 7. AfterEnd time, select the business day end time for each day of the week.
 8. AfterDisable for day, select the check box for each day your business is closed.
 9. Click Save.

Managing schedule exclusion lists
Tomanage schedule exclusion lists in YourSite Explorer
 1. InYourSite Explorer, click Schedules.
 2. Click Add.
 3. Click Manage schedule exclusion list.
 4. AfterName, type the name of the exclusion list.
 5. On the calendar, click the dates you want to exclude from the schedule.
 6. Click Save.
 7. Click Apply to apply the new schedule exclusion list to the schedule.

Tomanage schedule exclusion lists in Contact Center Management
 1. In Contact Center Management, click YourSite=>Schedule.

The Schedule window opens.
 2. Click Add orEdit.
 3. Click Manage schedule exclusion list.
 4. AfterName, type the name of the exclusion list.
 5. On the calendar, click the dates you want to exclude from a schedule.
 6. Click Save.
 7. Click Apply to apply the new schedule exclusion list to the schedule.

Applying schedules
You can apply the schedules you create to

l Media servers—See "Addingmedia servers" on page 74
l Queues—See "Adding queues" on page 135
l Network Monitor alarms—See "Network Monitor alarms" on page 94
l WallBoarder sign plan business hour and scheduledmessages—See "Creating sign plans for daisy-

chained signs" on page 263
l Interactive Contact Center Queue control— See "Configuring Interactive Contact Center Queue

control" on page 140
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Monitoring and alarming subsystem
Contact Center Solutions uses a centralized alarming system that is entirely configured in YourSite Explorer.
TheMaintenance Alarm Dispatcher service is located on the Enterprise Server and performs server
maintenance activities as well as controlling all alarming in the network. Alarm notifications are sent for each
device that is triggering an alarm and distributed in the following ways:

l Email:Summary emails are sent to valid email subscribers and list all current, active alarm statuses as
well as a list of alarms that triggered the alert.

l RSS:AnRSS feed is published on the server and can be subscribed to by any RSS reader that has
been given access to the server.

l SNMP:A count of alerting alarms for each category can be viewed in an SNMP manager.
l Start Page:A list of currently active Contact Center Management alarms with a Knowledge Base

article list of descriptions, severity, impact on contact centers, and troubleshooting can be viewed on
the Start Page of YourSite Explorer. (See "YourSite Explorer Start Page" on page 65.)

By default, alarms are configured to expire after 24 hours.

The Server Monitoring Agent is a standalone service that is deployed on each server in the enterprise. It
monitors performance counter values based on alarm configuration, collects external alarm data from
services, and notifies theMaintenance Alarm Dispatcher service when alarm states surpass configured
thresholds.

Alarms may also be viewed with the Enterprise Status icon and RSS feed link, located in the lower-right
corner of the YourSite Explorer window. The Enterprise Status icon is a circular, colored status indicator. The
color indicates the highest level of severity for all alarms currently alerting (Normal = Green, Minor = Yellow,
Major = Orange, Critical = Red, Unknown = Gray). If you subscribe to the RSS feed and your RSS reader is
open, you will be notified with changes to alarm states. If you don’t subscribe to the RSS feed, you can click
the RSS feed link and view active alarms in your default browser.

In addition to receiving notification of alarms, you can quickly view Enterprise status and active alarms using
the YourSite Explorer Start Page’s Alarms tab. The Alarms tab consists of two panes: the Feed Preview and
the prairieFyre Knowledge Base pane. The Feed Preview contains an RSS feed of the active alarms. The
prairieFyre Knowledge Base pane contains a table of contents linking to relevant Knowledge Base (KB)
articles for each alarm. Each KB article contains a description of the reason for the alarm, the severity of the
alarm, the impact on contact centers, and troubleshooting steps.

Alarms are categorized based on the type of data they analyze. There are three types of alarms:
l Performance counter and Registered services performance counters alarms: based on

performance counters
l Media server alarms: independently tracked for eachmedia server
l General alarms: all other alarms

Alarms are configured in YourSite Explorer=>Enterprise=>Alarms.
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To configure performance counter and Registered services performance counter type alarms
 1. In YourSite Explorer, click YourSite=>Alarms.

NOTE: Alarms is located in the Enterprise pane.
 2. Select the performance counter or Registered services performance counters alarm you want to

configure.
 3. Click theGeneral tab.
 4. Select a category type from the drop-down list afterCategory, if you want to specify in which SNMP

category you want this alarm to display.
 5. Set minor, major, and critical thresholds and threshold durations for the alarm.

The threshold duration you specify determines the length of time an alarm state is active before an
alarm is triggered and notification is sent.
You can disable any of the thresholds by selecting Disabled from the drop-down list next to the
threshold.

 6. Select theRealert on value change check box if you want to be notified every time the alarm value
changes.

 7. If you want to disable this alarm, click Disable.
 8. If you want to temporarily disable this alarm, click Snooze and choose a length of time for which the

alarm will be disabled. If you want to disable the alarm for a length of time outside of the available
choices, click Customize and choose a time by using the options in theSelect Wake Timewindow.

 9. Click theActions tab.
 10. Select theEnabled check box if you want subscribers to receive emails when alarms are triggered.
 11. Click… and select a business hour schedule to apply to this alarm.
 12. If you want to receive notifications for critical alarms outside of specified business hours, select the

Ignore business hours for critical alerts check box.
 13. Click Save.

To configuremedia server type alarms
 1. In YourSite Explorer, click YourSite=>Alarms.

NOTE: Alarms is located in the Enterprise pane.
 2. Select themedia server type alarm you want to configure.
 3. Click theGeneral tab.
 4. Select a category type from the drop-down list afterCategory, if you want to specify in which SNMP

category you want this alarm to display.
 5. AfterSeverity, select the level of severity you want to apply to this alarm (minor, major, or critical).
 6. AfterDuration, select the length of time the alarm state is active before an alarm is triggered and

notification is sent.
 7. Select theRealert on value change check box if you want to be notified every time the alarm value

changes.
 8. If you want to disable this alarm for specific media servers, afterDisable media servers, click…,

select themedia server from theSelect disabled media serverswindow, and click OK.
 9. If you want to disable this alarm, click Disable.
 10. If you want to temporarily disable this alarm, click Snooze and choose a length of time for which the

alarm will be disabled. If you want to disable the alarm for a length of time outside of the available
choices, click Customize and choose a time by using the options in theSelect Wake Timewindow.

 11. Click theActions tab.
 12. Select theEnabled check box if you want subscribers to receive emails when alarms are triggered.
 13. Click… and select a business hour schedule to apply to this alarm.
 14. If you want to receive notifications for critical alarms outside of specified business hours, select the

Ignore business hours for critical alerts check box.
 15. Click Save.
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To configure general type alarms
 1. In YourSite Explorer, click YourSite=>Alarms.

NOTE: Alarms is located in the Enterprise pane.
 2. Select the general type alarm you want to configure.
 3. Click theGeneral tab.
 4. Select a category type from the drop-down list afterCategory, if you want to specify in which SNMP

category you want this alarm to display.
 5. AfterSeverity, select the level of severity you want to apply to this alarm (minor, major, or critical).
 6. AfterDuration, select the length of time the alarm state is active before an alarm is triggered and

notification is sent.
 7. Select theRealert on value change check box if you want to be notified every time the alarm value

changes.
 8. If you want to disable this alarm, click Disable.
 9. If you want to temporarily disable this alarm, click Snooze and choose a length of time for which the

alarm will be disabled. If you want to disable the alarm for a length of time outside of the available
choices, click Customize and choose a time by using the options in theSelect Wake Timewindow.

 10. Click theActions tab.
 11. Select theEnabled check box if you want subscribers to receive emails when alarms are triggered.
 12. Click… and select a business hour schedule to apply to this alarm.
 13. If you want to receive notifications for critical alarms outside of specified business hours, select the

Ignore business hours for critical alerts check box.
 14. Click Save.

Validating alarms
Some alarms require the system to be validated before the alarms will clear. The Validate buttonmust be
clicked after the values have been corrected, otherwise the alarm will not be cleared until nightly
synchronization. The alarm may not clear with nightly synchronization if the value is still wrong.

Consult the alarm’s Knowledge Base article for validation information.

Enabling SNMP agent for alarms
Contact Center Solutions/Call Accounting includes an SNMP agent that enables you tomonitor Contact
Center Solutions/Call Accounting alarms through an SNMP manager. Contact Center Solutions/Call
Accounting SNMP agent integrates with theWindows SNMP service and requires that aWindows SNMP
Service be added and configured on the Enterprise Server.

The Contact Center Solutions/Call Accounting SNMP agent is primarily configured for traps only, but also
responds to Get-request messages for trapmessages.

SNMP Agent provides information on nine categories of alarms:
l General Category Alarm
l Data Collection Alarms
l Server Resource Alarm
l Communication Alarm
l License Violation Alarm
l IVR Alarm
l Reporting Alarm
l Performance Alarm
l Configuration Alarm
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The value reported for each alarm category is the highest severity of alarm currently triggered in that category.

Configuring Windows SNMP service for the SNMP agent
Contact Center Solutions and Call Accounting requires the use of theWindows SNMP service for the Contact
Center Solutions SNMP agent.

To configureWindows SNMP service for the SNMP agent
 1. If you do not have SNMP Service installed on your server, install it using theAdd/Remove Program,

Add Features, orAdd roles and features function of yourWindow server.
 2. After the installation has completed, navigate toServices.
 3. Right-click onSNMP and select Properties.
 4. Select the Traps tab.
 5. UnderCommunity name, type a community name, such as Public, and click Add to list.
 6. Under Trap destinations:, click Add.
 7. UnderHost name, IP or UPX address:, type the destination for Contact Center Solutions SNMP

Agent traps.
 8. Click Add.
 9. Select theSecurity tab.
 10. Click Add.
 11. In theCommunity rights drop-down list, select READ WRITE.
 12. UnderCommunity name:, typePublic.
 13. Select the Log On tab.
 14. Under Log on as:, select Local System Account.
 15. Click OK.

NOTE:After setting up your SNMP Agent, it is recommended you test it using an appropriate tool to
confirm that it has been configured correctly.

SNMP MIB summary
Table 6 - 7 and Table 6 - 8 summarize object information from theMIB. TheMIB is located in
<drive>]/CCM/Services/MaintenanceAlarmDispatcher/Snmp.

Table 6 - 7 prairieFyre sub-tree

Object Type Object Identifier

enterpriseAlarms prairieFyre 1

enterpriseAlarms prairieFyre 2

enterpriseAlarms prairieFyre 3
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Table 6 - 8 MIB enterpriseAlarms sub-tree summary

Object Type Syntax Integer Max
Access Description Object Identifier

manufacturer manufacturer read-
only

prairieFyre Soft-
ware's Contact
Center Suite

enterpriseAlarms 1

overridingSystemAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

This is the cumulative
total of all reporting
active alarms and
should be viewed as
the overriding alarm
state that the prair-
ieFyre suite is now
reporting.

enterpriseAlarms 2

generalCatagoryAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

When a software
entity raises an alarm
not covered in the fol-
lowing list then it is
categorized as a gen-
eral alarm.

enterpriseAlarms 3

dataCollectionAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

One of theMedia Con-
troller Data Link Con-
nections within the
prairieFyre Enterprise
is offline. This could
be a connection to a
PBX or an e-Mail
Server or SMS trans-
port server or some
other controller of a
media transaction
that is configured to
be connected to the
prairieFyre suite.

enterpriseAlarms 4

serverResourceAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

One or more software
services in the prair-
ieFyre suite is report-
ing an unusual
consumption of com-
puter resources. This
may a result of an
exceptionally high
CPU consumption or
running low on phys-

enterpriseAlarms 5
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Object Type Syntax Integer Max
Access Description Object Identifier

ical memory, for
example. This may
require a service
restart to resolve.

communicationsAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

One or more service
endpoints is reporting
an error in its control
channel with an asso-
ciated endpoint. This
may be a socket or
WCF channel or may
be anMSMQ error
that is preventing nor-
mal process flow in
the prairieFyre soft-
ware suite.

enterpriseAlarms  6

licenseViolationAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

The prairieFyre Enter-
prise LicensingMan-
ager is reporting that
the installation is vio-
lating or has
attempted to exceed
enforced license lim-
its for their instal-
lation. This may be
configuring the YSE
services for features
or capacity they have
not purchased.

enterpriseAlarms  7

ivrAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

The IVR services are
reporting an alarm,
whichmay be due to
media ports being out
of service or an inabil-
ity to load a call flow.

enterpriseAlarms  8
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Object Type Syntax Integer Max
Access Description Object Identifier

reportingAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

The reporting engine
is reporting an error
that implies it cannot
generate a requested
report due to a sys-
tem inoperability
error. This may be a
corrupt report tem-
plate or could be a
transaction error on
the retrieval of SQL
data to fill the report.

enterpriseAlarms  9

performanceAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

One or more of the
service endpoints in
the prairieFyre suite
is reporting an over-
load condition

enterpriseAlarms  10

configurationAlarm unknownAlarm(0)
noAlarm(1)
minorAlarm(2)
majorAlarm(3)
criticalAlarm(4)

read-
only

One or more of the
service endpoints in
the prairieFyre suite
is reporting an error
when loading con-
figuration data.

enterpriseAlarms  11

Security roles
You create security roles if you want to restrict employees from specific devices and Contact Center
Management application areas.

NOTE: In order for you to assign security roles, your account must be associated with a security role that
does not restrict you from administering security.

The Contact Center Solutions default security setting ofLocal Administrator allows employees full access to
all of the Contact Center Solutions applications (to which the contact center is licensed) and devices except
Write Back for synchronization. Contact Center Solutions security roles are inclusive. This means that a
security role assigned to an employee defines the application areas an employee can access.

When you install Contact Center Management, a default user is created. This assures you there is at least
one account with which you can access the Contact Center Management website.
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The default user name and password are
l Username: _admin
l Password: _password
l Security Role: Local Administrator

Security roles have two components:
Basic—Basic security controls user access to specific areas of Contact Center Management, Flexible
Reporting, and toWorkforce Scheduling and Schedule Adherence.
Advanced—Advanced security controls user access to customized lists of devices, real-time
monitors, profiles, reports, sites, and users.

Creating and applying security roles
You can create security roles that have a number of combinations of basic and advanced authorizations
applied to them. For example, you can create a security role with minimal security restrictions, granting users
access to as many Contact Center Management reports and applications as you designate. You do this by
leaving the security components listed under the Advanced tab set to "Not restricted". Alternatively, you can
create a security role that has full access to someContact Center Management application areas but is
restricted from accessing other reports and devices. (Figure 6 - 11.)

To create and apply a security role with basic and advanced components, youmust
 1. Ensure employees are configured in the YourSite database.

See "Adding employees" on page 123.
 2. Create security lists.
 3. Configure basic security.
 4. Configure advanced security.
 5. Assign the security role to one or more employees.

To create and apply a security role with basic security components only, youmust
 1. Ensure employees are configured in the YourSite database.
 2. Specify basic security.
 3. Assign the security role to one or more employees.

To create and apply a security role with advanced security components only, youmust
 1. Create security lists if you want to apply advanced security.
 2. Configure basic security.
 3. Configure advanced security.
 4. Ensure all employees are configured in the YourSite database.
 5. Assign the security role to one or more employees.
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Figure 6 - 11 Security flow chart
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Creating security lists
You can use advanced security to restrict user access to sites, reporting, and real-time functions.

Before you can specify advanced security, youmust create security lists (device lists, real-timemonitor lists,
report lists, site lists, and/or user lists). Each list must contain the devices, real-timemonitors, reports, sites,
and/or users to which employees are granted access. You can combine these lists when you assign a
security role. For example, you can specify advanced security that permits users to create EmployeeGroup
Performance by Employee reports (specific report list) on Kanata employees (specific device list) only.

Use the following security lists to define advanced security:
l Device list—Device lists specify devices for which employees may view real-time information. You

create device lists to restrict access to statistics on specific employees. For example, youmight want
amanager to view certain employees only (specific device - Kanata employees). The device list must
contain the device (employee group - in this case, Kanata employees) to which the user may gain
access.
Devices include agents, agent groups, divisions, DNIS groups, employees, employee groups,
Intelligent Queue Smart Choice Layer groups, Intelligent Queue Smart Choice Port groups, Intelligent
Queue voice call back queue groups, Intelligent QueueWeb call back queue groups, queue groups,
teams, trunk groups, and voice extension groups. Statistics are generated from these devices. You can
view these statistics or generate a report from them.
NOTE: If you add an agent to a device list, youmust also add the associated employee.

l Profile list—You create a profile list to restrict users frommanaging specific real-timemonitor profiles.
l Real-time monitor list—The real-timemonitor list specifies real-timemonitors to which you are

granted access. You create a real-timemonitor list to restrict access to particular real-timemonitors.
The real-timemonitor list must contain themonitors to which the user may gain access.

l Report list—You create report lists to restrict users from viewing specific report types. For example,
youmight want managers to view employee reports only (specific report category). The report list must
contain the reports the user may run. If you do not assign a report list to the employee, then the
employee will see every YourSite group and team when running reports andmonitoring real-time
activities (unless a basic security role is assigned to that employee that does not permit the employee
to gain access to any reports).

l Site list—The site list specifies sites youmay manage. You create a site list to restrict access to
devices by site. For example, youmight want a supervisor to view the employees at a particular site
only. The site list must contain the site (in this case, Kanata) to which the user may gain access.

l User list—You create a user list to restrict a user from chatting online with certain employees. The user
list must contain the employees with which the user may chat. For example, youmight want managers
to chat online with only the employees they supervise. If Janemanages Bill, Sue, andGeorge, then you
assign Jane an advanced security role that permits Jane to chat with Bill, Sue, andGeorge (the user list
would contain Bill, Sue, andGeorge).

l Card design list—You create a card design list to restrict users frommanaging card designs (card
designs specify the information displayed on agent, employee, and extension real-timemonitors).

To create a security list
 1. In Contact Center Management, click YourSite=>Security=>Security lists=>select the security list

you want to create.
 2. Click Add.

The Add list tab opens.
 3. AfterName, type the list name (for example, type Jane’s chat group).
 4. AfterDescription, type the list description (for example, type Jane’s group).
 5. Click the Members tab.
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 6. If you are creating a device or reports list, after Filter by, select a category to narrow the items that
display in the list (for example, Agent group).

 7. Select the check boxes of themembers you want to include in the list.
 8. Click Save.

The security list displays in the list tree.

Configuring security roles
NOTE:When users first access the Contact Center Management website, by default, they can access all of
the Contact Center Management Web applications.

You can create basic security to restrict user access to specific areas of the Contact Center Management
website. For example, if you want to restrict users from viewing Contact Center Client and Enterprise
Configuration, then youmust create a security role with those characteristics. (See Figure 6 - 12.)

Youmust create a security list before you can create an advanced security role. Using these lists, you define
a security role. See "Creating security lists" on page 180.

Figure 6 - 12 Basic security tab

To configure security roles
 1. In Contact Center Management, click YourSite=>Security=>Security roles.

The Security roles window opens. It lists all of the security roles that have been created.
 2. Click Add a role.
 3. AfterRole name, type the name of the security role, (for example, Contact Center Management only).
 4. AfterRole description, type the description of this security role, (for example, No access toWorkforce

Scheduling and Schedule Adherence).
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 5. On theBasic tab, clear the check boxes of the items the user is not permitted to use. For example, if
agents are not permitted to administer security, clearMay manage security.
See Table 6 - 9 for a description of the YourSite Explorer security setting options.

 6. If required, click theAdvanced tab and specify advanced security.
An advanced security role restricts access to reports, real-time and Interactive Contact Center
statistics, Chat, sites, and real-timemonitors
See Figure 6 - 13.

 7. Click Save.

Table 6 - 9 describes the security setting options for YourSite Explorer synchronization that display in the
Basic security tab.

Table 6 - 9 YourSite Explorer synchronization - security setting options

Option Description

No access If NoAccess is enabled you cannot configure Enterprise settings or devices in YourSite
Explorer.

Allow Read
Access

Allow Read Access enables you to read Enterprise/device configuration settings on the tel-
ephone system(s).

Allow
Read/Write
Access

Allow Read/Write Access enables you to read Enterprise/device configuration settings on
the telephone system(s) and write them to the YourSite database.

Allow Full
Control

Allow Full Control enables you to read Enterprise/device configuration settings on the tel-
ephone system(s), write them to the YourSite database, and write back devices pro-
grammed in YourSite Explorer to the telephone system.
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Figure 6 - 13 Advanced security tab

Verifying security role properties
To verify the properties of a security role
 1. In Contact Center Management, click YourSite=>Security=>Security roles.

The Security roles window opens. It lists all of the security roles that have been created.
 2. Click View adjacent to the security role for which you want to view properties.

You can assign the security roles to new users and to existing users.
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Assigning security roles to employees
NOTE: Users who are currently logged on will not be affected by changes made to their associated role until
the next time they log on. If you want the security role changes to take effect immediately, start and stop the
Contact Center Management website from the Internet Server Manager. All of the clients will be disconnected
and forced to log on again.

To assign a security role to an employee
 1. In Contact Center Management, click YourSite=>Configuration.
 2. Click Employee=>.
 3. Across from the record you want to edit, click Edit.
 4. Click theUser accounttab.
 5. AfterSecurity role, select a security role to assign to the employee.

All security roles are listed here.
 6. Click Save.

Configuring work timer
Work timer provides agents handling calls with a period of time after they finish a call to set classification
codes, handle paperwork, or deal with other administrative tasks before returning to handling calls. Work timer
is configured as a Class of Service for Media Servers, but may also be configured for individual queues if
individual queues require shorter work timer, if classification codes need to be enforced, or to add work timer
duration to the ACD handle time.

When configured, after call completion, work timer places the agent into theWork Timer real-time state and
ACD calls no longer route to them, giving the agent time to do after call work. As the agent enters into the
Work Timer agent state, their timer in PhoneSet Manager or Softphone begins counting down the configured
work timer duration (In real-timemonitors in Contact Center Client, work timer will count up). When the
countdown reaches 00:00:00 or if the employeemanually ends work timer, they are returned to the Idle real-
time state where they can handle calls again.

Work timer can be cancelledmanually by an agent by pressing the Cancel work timer button on their hard set
or soft phone applications. If the “Force entry of a classification code” is enabled, agents must enter a
classification code first. If they do not, work timer cannot be endedmanually and a non-compliance
classification code will be assigned to the call when work timer ends. Work timer can also be ended by an
agent entering a classification code (if the “Cancel work timer once code” is entered is enabled).

Work timer’s maximum duration is dependent upon a contact center’s telephone system:
l MCD 5.0 and greater – 4 hours
l MCD 4.x or earlier – 10minutes

Work timer is configured as a Class of Service for the telephone system, but may also be configured on a
queue by queue basis. While Queue work timers override the Class of Service work timer, Queue work timers
may not be greater than the work timer configured as a Class of Service for the telephone system.
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NOTE: When an agent receives a transferred call and enters into work timer, regardless of the queue the
agent is in, their work timer duration is taken from the Class of Service work timer as a transferred call does
not enter via the queue.

For information on configuring work timer as a Class of Service for Media Servers, see "Editing Class of
Service options" on page 110.

For information on configuring work timer for queues, see "Adding queues" on page 135.

Preparing media server agent timeout options for MCD 5.0+
By default, YourSite Explorer is configured to clear lines if an agent using that line remains in a single state for
more than two hours. This can impact work timer’s functionality if work timer has been configured to be
greater than two hours. Tomake proper use of the four hour work timer feature available to MCD 5.0+, you
must configure the agent state timeout audit options for your media servers to ensure that they do not interfere
with work timer.

To configure themedia server agent state timeout audit option
 1. In YourSite Explorer, click Media Servers.
 2. Select your media server from the list of media servers.
 3. Click theData summary options tab.
 4. AfterClear line if agent primary Talk Time exceeds, select 24 hours from the drop-down list.
 5. If you are usingmultiple media servers, repeat steps 2-4 for all your contact center media servers.
 6. Click Save.

Validating YourSite Explorer configuration
The Validate buttonmanually triggers a validation of your contact center system configuration by going
through Class of Service system options, SMDR options, agent groups, voice queues, andmedia servers,
firing or clearing alarms as appropriate. Validation automatically takes place with the synchronization that
occurs during nightly maintenance, but manual validation is required to clear some alarms.

To validate YourSite Explorer configuration
 1. In YourSite Explorer, click the Tools tab.
 2. Click theValidate button.
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Chapter 7

Real-time Monitors

Contact Center Client
Wallboarder
Troubleshooting real-time issues
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Real-time Monitors
The Enterprise Server continuously updates the real-time applications with telephone system data, and
simultaneously updates connected clients through Transmission Control Protocol-Internet Protocol (TCP/IP).
Contact Center Client real-timemonitors are automatically updated to reflect device and device group
changes made in YourSite Explorer. Supervisors and agents are provided with point-and-click access to real-
time performance statistics for their contact center, enabling them to identify issues in contact center
performance and see who is available to answer or assist with calls. For a demonstration of real-time
monitors, click http://www.youtube.com/watch?v=oL-pXMSdOFc.

The real-time applications include Contact Center Client andWallBoarder. Supervisors and agents can view
real-time voice statistics in Contact Center Client and the phone availability of contact center and general
business employees. In contact centers that have theMultimedia Contact Center optional application,
supervisors and agents can view real-time voice, email, chat, and fax statistics. WallBoarder displays text
messages and contact center statistics on one or more Spectrum Light Emitting Diode (LED) reader boards
(wall signs). See "WallBoarder" on page 249.

Contact Center Management integrates with OAISYS or dvsAnalytics Encore call recording software to
enable 24/7 call recording. Call recordings are appended to specific Lifecycle reports. See "Call recording" on
page 83.

In addition to real-timemonitors, Contact Center Client includes the following application areas:
l Network Monitor

Network Monitor provides information on the status of media server real-time data collection.
See "Network Monitor" on page 343.

l Auditor
Using Auditor, supervisors can view the historical real-time events that occurred on a particular date, in
the sequence they occurred, at your own pace.
See "Auditor" on page 337.

l Management Console
UsingManagement Console, network administrators can restart services, administer the database,
and perform maintenance functions.
See "Management Console" on page 51.

l Contact Center Chat
Contact Center Client provides instant messaging capabilities for both supervisors and agents and is
typically used by contact center employees. Contact Center Chat provides the online chat presence of
contact center employees, including Available, Offline, and Away. Agents can view the availability and
presence of other contact center employees before they transfer calls or send online chat messages.
With the Enterprise Presence / Chat Integration license, Contact Center Solutions integrates with Lync
Server 2010 to provide enhanced presence.
See "Using Contact Center Chat" on page 243.

http://www.youtube.com/watch?v=oL-pXMSdOFc
http://www.youtube.com/watch?v=oL-pXMSdOFc
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The following optional applications and features reside in Contact Center Client:
l Interactive Contact Center

Interactive Contact Center is an optional application that enables supervisors to control the availability
of agents and ACD queues. Agents can log themselves on or off, and place themselves in or remove
themselves fromMake Busy or Do Not Disturb.
See "Using Interactive Contact Center" on page 352.

l Interactive Visual Queue
Interactive Visual Queue is an optional application that enables agents to monitor calls within queues,
move calls from busy queues to less active queues, and call back abandoned callers.
See "Using Interactive Visual Queue" on page 366.

l Contact Center PhoneSet Manager and Contact Center Softphone
Contact Center PhoneSet Manager and Contact Center Softphone are optional applications that enable
agents to use their desktop computers as IP-based phones.
See "Contact Center PhoneSet Manager and Contact Center Softphone" on page 375.

l Contact Center Screen Pop
Contact Center Screen Pop is an optional application that launches applications orWeb pages. In
addition, it enables agents to automatically receive caller and account information via pop-ups on their
computer monitors every time they receive calls.
See "Using Contact Center Screen Pop" on page 410.

l Enterprise Presence / Chat Integration
With the addition of Lync Server 2010, agents and supervisors useMicrosoft Lync as their default
instant messaging client. The presence of all company employees is natively delivered in Contact
Center Client. Contact center employees can view the presence of both internal and external contacts
to determine if they are available to communicate. In addition to Available, Offline, and Away,
employees see In aMeeting, Busy, In a call, Do Not Disturb, Be Right Back, and other presence
indicators.

Lync Server 2010 extends the capabilities of Contact Center Chat enabling agents to communicate with
people who are

l In the same company, but are not using Contact Center Client
l In the same company, but are not on the same intranet
l External to the company, where the companies in which they work have a Lync Server environment

and use Lync
l External to the company, communicate over the public Internet, and use popular instant message

services (MSN, AIM, Yahoo!)

In aMicrosoft Lync environment, you can take advantage of other forms of communication: computer voice
calls, video conferencing, white boarding, and desktop sharing capabilities. Communication with MSN, AIM
and Yahoo! is typically limited to instant messaging only.

Contact Center Client
NOTE:

l By default, all supervisors and agents view all real-timemonitors and devices in Contact Center Client.
You can specify whichmonitors and devices users view in YourSite=>Security=>Security lists. In
addition, you can configure security in YourSite=>Security=>Security roles that dictate whether users
canmanage personal and/or global profiles.

l An employeemust be amember of an employee group in order for you to view the employee on the
employee groupmonitors in Contact Center Client. A queuemust be amember of a queue group in
order for you to view the queue on the queue groupmonitors in Contact Center Client.

l The number of employees logged on at any timemust be consistent with your software license.
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Contact Center Client uses ribbons for device andmonitor control. (See Figure 7 - 1.)

Figure 7 - 1 Contact Center Client ribbon

Some tabs that display in the ribbon are dependent upon whichmonitor is active. These are referred to as
context sensitive tabs. When you enable context sensitivity for monitors, the associated context sensitive tab
for the activemonitor automatically becomes the active tab. See Table 7 - 1 for a list of the associated context
sensitive tabs for eachmonitor. See Figure 7 - 2 for an example of context sensitivity enabled for the Agent
State by Positionmonitor. Note that the Agent andMonitor Control tabs display in the ribbon.

NOTE: The options that display in the Contact Center Client ribbon are dependent upon your individual
security settings. Options which you are not given access to will not display.
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Table 7 - 1 Context sensitivity options display per monitor

Monitor Associated context sensitive tabs

Agent State
by Position

Agent andMonitor Control tabs

Employee
State by
Position

Employee andMonitor Control tabs

Extension
State by
Position

Extension andMonitor Control tabs

NOTE:When an agent is logged into an extension, the context
sensitivity tab displays 'Agent Control'. When no agent is
logged into the extension, the context sensitivity tab displays
'Extension Control'.

Agent State
by Time

Agent andMonitor Control tabs

Agent State
by Time for
Queue

Agent andMonitor Control tabs

Employee
State by
Time

Employee andMonitor Control tabs

Agent Shift Agent andMonitor Control tabs

Queue by
Period

Monitor Options tab

Queue Now Monitor Options tab

Queue
Group Now

Monitor Options tab

Queue Per-
formance

Chart Options tab

Queue
Group Per-
formance

Chart Options tab

Queue Chart Options tab

Queue
Group

Chart Options tab
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Monitor Associated context sensitive tabs

Interactive
Visual
Queue

n/a

NOTE:Context sensitivity is not supported for the Interactive
Visual Queuemonitor

Figure 7 - 2 Context sensitivity example - Agent Control tab

Starting Contact Center Client
You start Contact Center Client to access real-time functionality. Supervisors and agents can view real-time
voice statistics. In contact centers that have the optional Multimedia Contact Center application, supervisors
and agents can view real-time voice, email, chat, and fax statistics. After starting Contact Center Client, you
can choose tominimize it to either the system tray or the taskbar, depending on your operating system.
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To start Contact Center Client
 1. OpenContact Center Client.
 2. If prompted, type your user name and password and verify the Enterprise Server IP address.
 3. If you use Secure Socket Layer, select SSL.

CAUTION:Do not select “Remembermy credentials” if you intend to work both at the office and from
home.

 4. Click Log on.

When youminimize Contact Center Client and you are usingWindows XP as your operating system, the
Contact Center Client icon displays in your desktop system tray.

If you are usingWindows Vista, you can optionally configure Contact Center Client to display in your desktop
taskbar.

To display Contact Center Client in the taskbar
 1. In Contact Center Client, click the Contact Center Client icon button in the upper-left of the ribbon.
 2. Click Options.
 3. Clear theHide when minimized check box and click OK.

Contact Center Client, whenminimized, will display in the taskbar.
 4. To save the profile, click the Contact Center Client icon button and click Save as.
 5. Type aName for the profile and click OK.

The profile is saved and will automatically be applied each time you open Contact Center Client.
When device associations to device groups are changed in YourSite Explorer (add, delete, rename),
these changes will be automatically made in Contact Center Client real-timemonitors saved with user
profiles

Configuring Contact Center Client options
You can customize the Contact Center Client user interface and real-timemonitor device control and display
options by accessing the Options menu.

NOTE: The Contact Center Client button is the circular button located in the upper left corner of the window.
The following options are available from the Contact Center Client button: New, Open, Open from file, Save,
Save as, Save as file, Options, Logout, and Exit.

To configure Contact Center Client options
 1. In the ribbon, click the Contact Center Client button.

TheOptions window displays.
See Figure 7 - 3.

 2. UnderUser interface display, select a Toolbar style, Real-time icon type, Background color, Page
size, and whether you want to hide Contact Center Client when the window is minimized.

 3. Select Context Sensitivity forMonitors if you want the context sensitive tab to automatically become
the active tab when you select amonitor.
NOTE:Monitor context sensitivity is enabled by default.

 4. Select Context Sensitivity forSoft phone if you want the soft phone tab to automatically become the
active tab when a call is received.
If the Soft phone toolbar is floating, context sensitivity does not apply. Soft phone context sensitivity is
disabled by default.
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 5. Select theDisplay monitor device control option check box if you want to be able to see the option
for monitor control when you right-click cells in a real-timemonitor.
NOTE:Monitor control enables you to simultaneously control all of the agents on amonitor and is only
available if you have appropriate permissions, are licensed for Interactive Contact Center, and have
extensions configured for your employees.

 6. Configure Time format options.
The options you select will display in the real-timemonitor cells.

 7. Under Fullname format, select how you want agent's and employee's first and last names to display in
real-timemonitors.

 8. Click OK.

Figure 7 - 3 Contact Center Client options
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Adjusting the Contact Center Client view
You can adjust the way you view Contact Center Client features on your desktop.

To adjust the view
 1. Click View in the Contact Center Client ribbon.

The View options ribbon opens.
See Figure 7 - 4.

Figure 7 - 4 View options ribbon

 2. To change the way monitors display inside Contact Center Client, select from the options in the
Window Docking column.

 3. To adjust the position of the Contact Center Client window on your desktop, select from the options in
theScreen Docking column.

 4. If you want Contact Center Client to always display on top of other applications on your desktop, click
Always on top.

 5. Enable theStatus Bar if you want the status bar to be visible at the bottom of the Contact Center Client
window.
See Figure 7 - 5.

Figure 7 - 5 Status bar

 6. To open Voice, Email, Chat, or Fax legends, select from the options in the Legends column.
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Agent states
NOTE: If Contact Center Client becomes disconnected from the server, upon re-connection agent states will
automatically be synchronized with the server.

Table 7 - 2 lists the agent states and their corresponding icons for voice, email, chat, and fax.
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Voice Email WebChat Fax Term Meaning

Ringing an ACD call ringing on an agent’s phone waiting
to be handled
a contact in an agents Multimedia Contact
Center inbox waiting to be handled

ACD an agent handling an ACD call/email/chat/fax

ACD Hold an agent who has placed an ACD
call/email/chat/fax on hold

Idle an agent logged on and waiting to receive a
call/email/chat/fax

- - -
Non ACD an agent involved in an incoming non-ACD call

or agent-originated call

- - -
Non-ACD
Hold

an agent who has placed a non-ACD call on hold

- - -
Outbound an agent on an outgoing call

- - -
Outbound
Hold

an agent who has placed an outgoing call on
hold

Table 7 - 2 Agent states
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Off Hook an agent has picked up the phone to dial a
number

Camp on a call is waiting to be answered

Forwarded
to

the agent has set all incoming calls to be
forwarded to an alternate answer point

- - -
Do Not
Disturb

an agent who has activated do not disturb and is
not available to receive any ACD or non-ACD
calls

Make
Busy

an agent who is not available to receive ACD
calls/emails/chats/faxes but can receive calls
dialed directly to the agent’s extension

this icon also displays when an external hot
desk agent is in the Reseize Timer state

System
Make
Busy

If an agent is amultimedia agent and is logged
on to two or moremedia servers simultaneously,
the system sends the agent only one incoming
communication at a time. For example, when
the agent picks up a call, then the system
places the agent ID(s) for the other media server
types in SystemMake Busy.

- - -
Work
Timer

an agent who is completing paperwork and is
unavailable to receive calls

Unknown an agent who has not generated any activity
since Contact Center Management was started

LoggedOff an agent not currently logged in to any queue
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Extension states
NOTE: If your Contact Center Client becomes disconnected from the server, upon re-connection the
extension states will automatically by synchronized with the server.

Table 7 - 3 lists the extension states and their corresponding icons.

Icon Term Meaning

Ringing Call is ringing on the extension and waiting to be handled

Idle Extension is waiting to receive a call

Non ACD Extension is involved in an incoming call or an internal
extension-originated call

Non-ACD Hold Extension has placed an incoming call or an internal
extension-originated call on hold

Outbound Call Extension is on an outgoing call

Outbound Hold Extension has placed an outgoing call on hold

Forwarded to Extension has set all incoming calls to be forwarded to an
alternate answer point

Table 7 - 3 Extension states
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Icon Term Meaning

Camp on Extension is on a call and an incoming call is camped on
(waiting to be answered)

Off Hook Extension's phone is off the hook, so cannot receive calls

Do Not Disturb Extension has activated DoNot Disturb and is not available to
receive calls

Logged off Extension is not currently logged on and is unavailable to take
calls

Understanding Contact Center Client features
Contact Center Client has agent, queue, queue chart, and call notemonitors. For information on adding and
viewing call notes, see "Adding call notes to a call" on page 394.

You can perform the following tasks on themonitors by either right-clicking within themonitor or selecting
options via the Contact Center Client ribbon:

l Call recording
l Openmonitors
l Dock monitors
l Add and remove device IDs
l Sort monitor devices
l Rearrange cells
l Set monitor dimensions
l Freeze and unfreeze columns
l Hide and show columns
l Filter device variables
l Set alarms
l Clear alarms
l Definemonitor styles
l Group data
l Print monitors
l Arrange windows
l Modify the view
l Build marqueemonitors to broadcast statistics andmessages
l Chat online with agents and supervisors
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Contact Center Client options
The following options apply to real-timemonitors.

Call recording
On the Agent State by Time, Agent State by Position, and Agent State by Queue by Timemonitors, the Call
recording option enables you to start, stop, and restart call recording at any time during a call. See "Recording
calls" on page 406.

Clear alarms
The Clear alarms command clears any current performance variable threshold alarms.

Set alarms
The Set alarms command specifies performance thresholds for queues and agents.

Add/Remove devices
The Add/Remove devices command adds or removes devices or device groups from themonitor. If you add
agents, they are added to the bottom of themonitor.

Set table dimensions
On the Agent State by Position, Employee State by Position, and Extension State by Positionmonitors, the
Set table dimensions command adds or deletes columns or rows. If you delete devices, they are deleted them
from the lower-right side of themonitor.

Size table to frame
On all monitors, the Size table to frame command adjusts the table to fit within the frame

Sort monitor
On the Agent State by Position, Employee State by Position, and Extension State by Positionmonitors, the
Sort monitor by Agent ID, name, state, or extension command sorts agents by Agent ID, name, state and
time in state, or extension.

Filter device variables
On the Agent Shift, Queue by Period, andQueue Now monitors, the Filter device variables command filters
the data based on conditions you specify and displays a subset of data on themonitor.

General
On all monitors, under Properties, the General option specifies themonitor name and enables the horizontal
and vertical scroll bars.
On the queuemonitors, you can also enable grouping.

On the agent, employee, and extensionmonitors you can also display tool tips, display a pattern upon failover,
and display instant messaging online presence indicators.
On the Agent and Employee State by Timemonitors, you can also sort logged off agents by the longest
logged off first.

Print monitor
The Print monitor command prints the current monitor.
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Enable grouping
Under Properties, the Enable grouping option displays a grouping panel to which users can drag columns. The
grouping order determines the order in which the rows display. The Enable grouping option affects all monitors
that contain columns.

Row settings
Under Properties=>Layout, the Row settings option specifies the background color and font color of rows, and
the font type and text alignment.

Row alternate settings
Under Properties=>Layout, the Row alternate settings option specifies the background color and font color of
alternate rows, and the font type and text alignment.

Column settings
Under Properties=>Layout, the Column settings option specifies the background color and font color of
columns, and the font type and text alignment.

Column dimensions
Under Properties=>Layout, the Column dimensions option specifies the column height and width.

Column order
Under Properties=>Layout, the Column order option hides or displays individual columns, and specifies the
order of columns across themonitor.

Monitor style
Under Properties=>Layout, theMonitor style option specifies styles and skins (sets of styles) for themonitor,
and the Card design option specifies how information is displayed in the cells of agent, employee, and
extensionmonitors.

Cascade
When you right-click amonitor tab, underWindows, the Cascade command distributes activemonitors down
and across the Contact Center Client window.

Tile vertically
When you right-click amonitor tab, underWindows, the Tile vertically command distributes activemonitors
across the Contact Center Client window.

Tile horizontally
When you right-click amonitor tab, underWindows, the Tile horizontally command distributes activemonitors
down the Contact Center Client window.

Dock Contact Center Client
When you right-click amonitor tab, underWindows, the Dock Contact Center Client command docks Contact
Center Client at the top, bottom, left, or right of your desktop.

Always on top
When you right-click amonitor tab, underWindows, and select the Always on top command, Contact Center
Client always displays on your desktop on top of all other open applications.
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View
The View command hides or displays themainmenu, status bar, real-timemonitors, and email, fax, chat, and
voice legends.

Diagnostics monitor
The log and error monitors are accessed via Contact Center Client.

To access log and error monitors
 1. Click Tools in the Contact Center Client ribbon.
 2. Click either Log Monitor orError Monitor, depending on what kind of log information you want to

review.
See Figure 7 - 6.

Figure 7 - 6 Diagnostics monitors

Viewing agent availability
Contact Center Client provides instant messaging capabilities for both supervisors and agents and is typically
used by contact center employees. Contact Center Chat provides the online chat presence of contact center
employees, including Online, Offline, Away. On the agent, employee, and extensionmonitors, agents can
view the availability and presence of other contact center employees before they transfer calls or send online
chat messages. (See Figure 7 - 7.) If an agent cell in amonitor is grayed out, the phone is not connected to the
network and considered out of service. The out of service state applies to phones that are not connected to
the network, remote agents and employees that have lost their Internet connection, phones that are physically
disconnected or malfunctioning, or employees that are not logged into their soft phone.

Figure 7 - 7 Agent State by Position - viewing agent availability and online presence
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With the addition of Lync Server 2010, agents and supervisors use Lync Client as their default instant
messaging client. The presence of all company employees is natively delivered in Contact Center Client.
Contact center employees can view the presence of both internal and external contacts to determine if they
are available to communicate. In addition to Available, Offline, and Away, employees see In aMeeting, Busy,
In a call, Do Not Disturb, Be Right Back, and other presence indicators. (See Figure 7 - 8.)

Figure 7 - 8 Agent State by Position - viewing agent availability and enhanced presence

The followingmonitors display agent activities:
l Agent State by Position
l Employee State by Position
l Extension State by Position
l Agent State by Time
l Employee State by Time
l Agent Shift

Agent, Employee, and Extension State by Position
The Agent, Employee, and Extension State by Positionmonitors provide real-time information in cells that you
can arrange tomirror your floor plan: you can view agents, employees, or phone extensions by their physical
position in your contact center. In addition, thesemonitors enable you to view the current status of general
business extensions. Card designs enable you to customize the information displayed in the cells. See
"Customizing the information displayed on position and timemonitors" on page 239.

When you first open an agent, employee, or extensionmonitor, you can select a card design:
l The Classic card displays the agent state, time in the state, presence, agent/employee name, agent

login ID/employee ID, and extension number (or queue name for voice agents on ACD or on ACD
Hold).

l The Caller ID card displays the caller name and number (ANI), the number the caller/employee dials for
incoming/outgoing calls, the state, time in the state, presence, agent/employee name, agent login
ID/employee ID, and extension number (or queue name for voice agents on ACD or on ACD Hold.

l Custom cards you create and share

Caller ID information is displayed when
l Agents, employees, and extensions are in the following real-time states: ACD, ACD Hold, Ringing,

Non ACD, Non ACD Hold, Out, andOut Hold Time
l Extensions are in the following real-time states: Inbound andOutbound

You can set alarms for all real-time statistics and for caller ID information, such as the caller name and
number.
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NOTE: If you are upgrading to Contact Center Management Version 6.0 or greater, before you can select the
Caller ID card on the Add devices window ofagent, employee, and extensionmonitors, youmust make the
card available. To do so, right-click an openmonitor, select the Caller ID card under Properties, Layout=>Card
design and click Apply.

In a fault tolerant setup, if a network outage occurs the cells in the agent, employee, and extensionmonitors
display a crisscrossed pattern to identify agents who have homed to their secondary controllers.

If an agent cell in amonitor is grayed out, the phone is not connected to the network and considered out of
service. The out of service state applies to phones that are not connected to the network, remote agents and
employees that have lost their Internet connection, phones that are physically disconnected or
malfunctioning, or employees that are not logged into their soft phone.

Viewing the activities of agents who can log on to multiple voice queues
In Figure 7 - 9, the Agent State by Positionmonitor shows three cells for Andre Bourque, each with a different
agent ID. The first two cells show Andre logged off of the telephone system. The third cell shows Andre’s
current state. Andre is logged on to Queue 151 using Agent ID 2013. He has been on an ACD call for 12
minutes and 50 seconds.

Figure 7 - 9 Agent State by Position - viewing multiple agent IDs

Agents can log on to the telephone system using only one agent ID at a time. If your agents havemultiple
voice IDs (and thereforemultiple cells) the Agent State by Positionmonitor becomes cluttered.

If you have agents who are cross trained to answer calls for different departments (and log in and out of
various voice queues) the telephone system requires you assign the agents multiple IDs. You can use the
Agent State by Positionmonitor to view the activities of each department. You create an Agent State by
Positionmonitor for each department. When you arrange the cells for the agents in the same order for each
department, you can easily compare the activities of one department with another.

Viewing the current logged on states of agents who log on to multiple
queues
If you have voice agents who are cross trained to answer calls for different departments (and log in and out of
several queues) the telephone system requires you assign the agents multiple IDs. If a voice agent has
multiple agent IDs and you want to view the agent’s current logged on state only, you use the Employee State
by Positionmonitor. For example, agent Andre Bourque answers calls for English, French, and Spanish
queues. In the YourSite database you assign him three agent IDs (one for each queue for which he answers
calls) and an employee ID.

To view themonitor, you open the Employee State by Positionmonitor and select employees to add to the
monitor. Themonitor shows one cell for Andre, listing his current state and agent ID. (See Figure 7 - 10.)
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Figure 7 - 10 Employee State by Position - viewing the ID to which the agent is logged on

Andre is currently logged on to Extension 1104 using Agent ID 2001. Sometime later you notice Andre is
logged on to Extension 1119 using Agent ID 2009. (See Figure 7 - 11.)

Figure 7 - 11 Employee State by Position

Viewing extensions
NOTE:Users who will use the Extension by Positionmonitor must have the Class of Service HCI settings
enabled.

l Traditional or hot desking ACD agents who sit at different desks each day and who log on using their
agent ID

l General business, traditional extensions (non-contact center employees) who sit at the same desks
each day, are assigned their own desk phone extensions, and do not log on to their phones (their
phones are programmedwith their personal settings and are always active)

l General business, hot desking extensions (non-contact center employees) who log on to any phone in
the enterprise with a virtual extension configured with their personal settings. When the employee logs
on the extension becomes active. When the employee logs off of the extension it goes out of service.

You can set up your real-timemonitor profile to include two or more Extension by Positionmonitors: one with
cells that are arranged to show the whereabouts of agents in your contact center, and another that shows the
status of general business extensions: active/inactive, inbound/outbound.

Extension Inbound
Extension Inbound refers to a general business extension on an inbound call.

Extension Outbound
Extension Outbound refers to a general business extension on an outbound call
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General business active extension
General business active extension refers to aMitel desk phone/Contact Center PhoneSet Manager/Contact
Center Softphone that is live with no ACD agents logged on (active extension), or an extension to which a
general business hot desking user is logged on. The user is an active extension not logged on to any ACD
queue.

General business inactive extension
General business inactive extension refers to aMitel desk phone that has been unplugged or is damaged, or a
soft phone that is not running because the computer is turned off or Contact Center Client is not running, or a
hot desking extension to which nobody is logged on.

Traditional or hot desking ACD agents who sit at different desks each day
If you have traditional or hot desking ACD agents who sit at different desks each day, you use the Extension
State by Positionmonitor to view where they are sitting in the contact center. After you add Registration
Directory Numbers (RDNs)/desk phone extensions to themonitor, you can arrange the cells to match the
layout of your contact center.

When nobody is logged on to a particular extension, themonitor cell displays the General business active icon
and the phone set RDN ID. When an agent logs on to the desk phone, themonitor cell displays the ACD
agent status, (which can include information such as the time in state, queue reporting number, andMake
Busy status), the agent ID, the agent name, and the RDN (at the bottom of the cell). Depending on the agent’s
current state youmay see additional information, such as the time in state, queue reporting number, or Make
Busy status. If the Caller ID card design is selected, you will also see the caller name and phone number.
(See Figure 7 - 12.)

If you would prefer that Extension State by Positionmonitor cells be blank when there are no agents logged on
to the telephone system, you can right-click themonitor, select Properties, and clear the Enable the general
business view check box.

If an agent cell in amonitor is grayed out, the phone is not connected to the network and considered out of
service. The out of service state applies to phones that are not connected to the network, remote agents or
employees that have lost their Internet connection, phones that are physically disconnected or
malfunctioning, or employees that are not logged into their soft phone.

Figure 7 - 12 Extension State by Position
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General business, traditional extensions who sit at the same desks each day
If you have general business, traditional extensions who sit at the same desks each day, you use the
Extension State by Positionmonitor to view where they are sitting in the contact center. After you add their
extensions to themonitor, you can arrange the cells to match the layout of your business, or arrange them
alphabetically or by department.

When a general business employees is in Idle, the cell for the employee’s phone extension in the Extension
State by Positionmonitor displays the employee’s name and extension number, and the General business
active icon. When the employee is on an incoming/outgoing call, the cell displays the Extension
Inbound/Extension Outbound icon, the employee’s name and extension number, and the time in state. If the
Caller ID card design is selected, you will also see the caller name and phone number. Either card enables
you to readily determine the online and phone availability of general business subject matter experts.

General business hot desking employees who sit at different desks each day
General business, hot desking extensions can log on to any phone in the enterprise and access their personal
settings. When adding extensions to the Extension State by Positionmonitor, you can arrange them
alphabetically or by department.

When an employee is logged on, themonitor cell displays the General business active icon, the employee’s
name and extension. When the employee is on an incoming/outgoing call, the cell displays the Extension
Inbound/Extension Outbound icon and the time in state. If the Caller ID card design is selected, you will also
see the caller name and phone number. When the employee logs off, themonitor cell is grayed out (inactive).
(See Figure 7 - 13.)

Figure 7 - 13 Extension State by Position

Agent State and Employee State by Time
The Agent State by Time and Employee State by Timemonitors provide real-time agent information under
ACD, Idle, Non ACD, Unavailable, and LoggedOff column headings. They display the same real-time
information as that of the Agent State by Position, Employee State by Position, and Extension State by
Positionmonitors. See "Agent, Employee, and Extension State by Position" on page 203.

If an agent is in an email, chat, or fax agent state, themonitors display the queue number to which the agent is
logged on. Each column lists agents in order of time in state. You can specify which columns of agent
statistics are displayed, and the order in which they are displayed. You can sort logged off agents by the
longest logged off first. (See Figure 7 - 14.)
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If you have agents who are cross trained to answer calls for different departments (and log in and out of
various voice queues) the telephone system requires you assign the agents multiple IDs. You use the
Employee State by Timemonitor to view the activities of voice agents with multiple agent IDs. See "Viewing
the current logged on states of agents who log on tomultiple queues" on page 204.

Figure 7 - 14 Agent State by Time

Table 7 - 4 lists the Agent State by Time and Employee State by Time column headings and their associated
agent states.

Category Associated agent states

ACD includes agents in ACD and agents in ACD Hold

Idle includes agents in the Idle state

Non ACD includes agents in Non ACD, in Non-ACD Hold, Outbound agents, andOutbound Hold
agents

Unavailable includes agents in Do Not Disturb, Make Busy, Work Timer, Reseize Timer, and
Unknown

LoggedOff includes agents in the LoggedOff state

Table 7 - 4 Agent State by Time and Employee State by Time column headings

Agent State by Time for Queue
The Agent State by Time for Queuemonitor is a Contact Center Client real-timemonitor designed specifically
for contact centers using Agent Group Presence functionality. However, the Agent State by Time for Queue
monitor is available for all media server types. The Agent State by Time for Queuemonitor is accessed from
the Timemenu in Contact Center Client and displays all agents configured in a specific Queue and agents
who are on ACD calls, idle, on non-ACD calls, unavailable, logged on to the system (but not present in the
queue beingmonitored), and logged off. (See Figure 7 - 15).

NOTE:Virtual queue groups are shown under the Virtual queue groups section of the Agent State by Time for
Queuemonitor. Any Agent State by Time for Queuemonitors that aremonitoring virtual queues aremarked in
the title as (virtual).
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Figure 7 - 15 Agent State by Time for Queue

Table 7 - 5 lists the Agent State by Time and Employee State by Time column headings and their associated
agent states.

Category Associated agent states

ACD includes agents in ACD and agents in ACD Hold

Idle includes agents in the Idle state

Non ACD includes agents in Non ACD, in Non-ACD Hold, Outbound agents, andOutbound
Hold agents

Unavailable includes agents in Do Not Disturb, Make Busy, Work Timer, Reseize Timer, and
Unknown

Logged on to
system

includes agents who are logged on to the telephone system but not in the queue
beingmonitored

LoggedOff includes agents in the LoggedOff state

Table 7 - 5 Agent State by Time for Queue column headings

To view the Agent State by Time for Queuemonitor
 1. Open and log on to Contact Center Client.
 2. Click View=>Real time to view the Contact Center Client monitor icons.
 3. Click the Time icon and click Agent State by Time for Queue.

The Add/Remove devices window opens. You can optionally sort members in either ascending or
descending order.

 4. UnderQueues, select the queues tomonitor.
 5. Click OK.

Agent Shift
The Agent Shift monitor provides running totals of statistics on individual agents for the day. You can specify
which columns of statistics are displayed, rearrange columns, and sort individual columns in ascending or
descending order. (See Figure 7 - 16.)
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Figure 7 - 16 Agent Shift

Agent Shift column heading definitions
Table 7 - 6 describes the Agent Shift column headings.
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Term Meaning

LoggedOn the time the agent logged on

Last Event Received the last time an agent performed an event (for example, answered a call)

Shift Time the total shift time for the agent

ACD Time the total time the agent spent on ACD calls

ACD Hold Time the total time for ACD calls put on hold

Non-ACD Time the total time the agent spent on non-ACD calls

Non-ACD Hold Time the total time for non-ACD calls put on hold

Outbound Time the total time the agent spent on outbound calls

Outbound Hold Time the total time for outbound calls agents put on hold

DoNot Disturb Time the total time the agent spent in the DoNot Disturb state

Make Busy Time the total time the agent spent in theMake Busy state

Wrap Up Time the total time the agent spent in theWork Timer state

DoNot Disturb Count the number of times the agent entered the DoNot Disturb state

Make Busy Count the number of times the agent entered theMake Busy state

ACD Count the total number of ACD calls answered by the agent

Short ACD Count the total number of ACD calls answered that lasted less than 20 seconds

Hold ACD Count the number of times the agent put ACD calls on hold

Non-ACD Count the total number of non-ACD calls answered by the agent

Non-ACD Hold Count the number of times the agent put non-ACD calls on hold

Outbound Count the total number of outgoing calls the agent made

Outbound Hold Count the number of times the agent put outgoing calls on hold

Calls Per Hour the average number of incoming ACD calls answered by the agent per hour since
the beginning of the shift

Agent Unavailable% the percent of time the agent was set in Do Not Disturb or Make Busy and
unavailable

Table 7 - 6 Agent Shift column headings
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Term Meaning

Average Handle the average amount of time the agent spent handling ACD calls (ACD Time
divided by ACD Count)

Occupancy the total time the agent spent in an occupied state (occupied state excludes idle
time)

Viewing queue statistics
NOTE:

l You can see queue statistics during business hours as long as the business schedule you configure in
YourSite=>Schedule or YourSite Explorer=>Schedules is consistent with your company’s hours of
operation. You assign business-hours schedules to queues in
YourSite=>Configuration=>Queue=>Queue or in YourSite Explorer=>Queues=>Business Hours.

l When an agent receives an ACD call and fails to pick up the call after X seconds or X rings, the
telephone system places the agent in Make Busy. The telephone system re-queues the call (places the
call back in the same queue) and offers it to the next available agent.

The followingmonitors display queue statistics:
l Queue by Period
l Queue Now
l QueueGroup Now

Queue by Period
TheQueue by Periodmonitor collates queue statistics by 15-minute intervals over a 24-hour period. The
monitor refreshes each time there is a change in a statistic and each 15-minute interval. TheQueue by Period
monitor always displays the current 15minute interval at the top of themonitor. You can specify which
columns of statistics are displayed, rearrange columns, and sort individual columns in ascending or
descending order. (See Figure 7 - 17.)

Figure 7 - 17 Queue by Period
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Queue by Period column heading definitions
Table 7 - 7 describes the Queue by Period column headings.

Term Meaning

Offered the total number of calls offered to the queue during the 15-minute interval

Handled the total number of calls answered by agents during the 15-minute interval

Short Abandoned during the 15-minute interval, the total number of calls abandoned before the short
abandon time configured in YourSite

Abandoned the total number of calls abandoned during the 15-minute interval before being
answered by agents

Interflowed the total number of calls interflowed during the 15-minute interval

Requeued the total number of calls re-queued during the 15-minute interval

% Handled by 1-4 a count of all of the calls answered by the first, second, third, and fourth answer
points during the 15-minute interval

#Handled by 1-4 the number of calls answered by the first, second, third, and fourth answer points
during the 15-minute interval

Total Talk Time the total time agents spent talking to callers during the 15-minute interval

Average Talk Time the average time agents spent talking to callers during the 15-minute interval

Average Time to
Handle

the average number of minutes callers waited before agents answered their calls
during the 15-minute interval

Average Time to
Abandon

the average number of minutes callers waited during the 15-minute interval before
they abandoned their calls

Average Time to
Interflow

the average number of minutes callers waited during the 15-minute interval before
being interflowed

Service Level %
Today

during the 15-minute interval, the percentage of calls answered within the Service
Level Time specified for the queue

% Handled during the 15-minute interval, the percentage of calls answered compared to the total
number of calls offered to the ACD queue for the day

Wrap Up the total time the agent spent in theWork Timer state during the 15-minute interval

Make Busy the total time the agent spent in theMake Busy state during the 15-minute interval

Occupancy the total time the agent spent in an occupied state during the 15-minute interval
(occupied state excludes idle time)

Table 7 - 7 Queue by Period column headings
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Queue Now and Queue Group Now
NOTE:

l Virtual queue groups are shown under the Queue groups column in the Queue Now monitor so that their
individual queues can be selected in a single operation.

l Hierarchical individual queues that comprise each queue group (virtual or otherwise) can now be
displayed in the QueueGroup Now monitor.

l Contact Center Client updates Longest Waiting statistics every fifteen seconds, or more frequently as
records are received from the telephone system.

l Contact Center Client obtains the Calls Waiting, Longest Waiting, and Agents Available statistics from
the ACD data stream. If the telephone system has not updated Contact Center Management with ACD
real-time statistics within the last 90 seconds, questionmarks display in place of these statistics.

l Agents logged in and idle whose extensions are ringing are included in the Agent Available statistic.
Agents whose extensions are ringing are not included in the Unavailable statistic.

l The Average Handling Time is the Average Talk Time plus the Average Hold Time. If an agent calls a
supervisor in search of more information (while the caller is on hold) and/or transfers or conferences the
call, these times are added to the Average Handling Time value.

l When an agent receives an ACD call and fails to pick up the call after X seconds or X rings, the
telephone system places the agent in Make Busy. The telephone system re-queues the call (places the
call back in the same queue) and offers it to the next available agent.

l The abandoned calls column in the Interactive Visual Queuemonitor displays all abandoned calls,
whereas, the abandoned column in the Queue Now monitor does not peg short abandons as abandoned
calls. Because of this difference, youmay notice discrepancies between the abandoned call
information in these twomonitors.

TheQueue Now andQueueGroup Now monitors display the following queue and queue group statistics:
Calls Waiting, Longest Waiting, Agents Available, ACD, Idle, Non ACD, Outbound, Unavailable, Offered,
Handled, Abandoned, Interflowed, Requeued, % Handled by 1, % Handled by 2, % Handled by 3, % Handled
by 4, Average Time to Handle, Average Time to Abandon, Total Talk Time, Average Talk Time, Service Level
%, % Handled, Total Queue Unavailable, Current Queue Unavailable, Offered Last Hour, Time to Handle Last
Hour, % Handled Last Hour, Service Level % Last Hour, Handled Last Hour, Abandoned Last Hour,
Interflowed Last Hour, Unavailable Last Hour, Average Handling Time Last Hour, Offered Last 15Minutes,
Time to Handle Last 15Minutes, % Handled Last 15Minutes, Service Level % Last 15Minutes, Handled Last
15Minutes, Abandoned Last 15Minutes, Interflowed Last 15Minutes, Unavailable Last 15Minutes, Average
Handling Time Last 15Minutes, % Abandoned, % Abandoned Last Hour, % Abandoned Last 15Minutes,
Remote Calls Waiting, Remote Longest Waiting, LoggedOut, Logged In Not Present, Agent Unavailable%,
Wrap Up, Make Busy, Occupancy, #Handled by 1, #Handled by 2, #Handled by 3, and #Handled by 4.

TheQueue Now andQueueGroup Now monitors display the following agent and agent group statistics:
DND Cnt, MKB Cnt, ACD Cnt, Shrt ACD Cnt, Hold ACD Cnt, Non ACD Cnt, Hold Non ACD Cnt, Out Cnt,
Out Hold Cnt, Avg Hndl, Shift Time, DND Time, MKB Time, Wrap Up Time, ACD Time, Hold ACD Time,
Non ACD Time, Hold Non ACD Time, Out Time, Out Hold Time, Occupancy Time, Agent Name, Present,
Media Server, Agent login ID, Extn#, Log In, LogOff, Calls per Hour, On failover, Agt Unavail%, Occupancy,
Logged in Not Present Time, External Handle Duration, External Inbound Count, and External Outbound
Count.

On theQueue Now monitor, you can specify which columns of statistics are displayed, rearrange columns,
and sort individual columns in ascending or descending order. You can expand a queue and view statistics on
the agent groups associated with the queue. You can expand an agent group and view performance statistics
on the agents in the group. (See Figure 7 - 18.)
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When you expand theQueue Now monitor to display the Agent name column, themonitor also displays agent
presence in the queue. Presence is indicated by a colored star in the Present column. A green star indicates
the agent is present in the queue. A gray star and gray row indicates the agent is not present in the queue.

Figure 7 - 18 Queue Now

Queue Now and Queue Group Now column heading definitions
Table 7 - 8 describes the real-time and over-the-business-day Queue Now andQueueGroup Now queue and
queue group statistics.

Term Meaning

Calls Waiting The current number of callers queued up waiting for an agent to become available,
including those listening to silence, music, or recorded announcements

Longest Waiting The current duration, in minutes and seconds, of the call waiting the longest in queue

Agents Available The current number of agents logged on and not in Do Not Disturb, Make Busy, Work
Timer, Reseize Timer, or Unknown

ACD The current number of agents handling ACD calls

Idle The current number of agents logged on and ready to receive calls

Non-ACD The current number of agents handling non-ACD calls

Outbound The current number of agents on outgoing calls

Table 7 - 8 Queue Now and Queue Group Now queue statistic column headings
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Term Meaning

Unavailable The current number of agents in Do Not Disturb, Make Busy, Work Timer, or Unknown

Offered The total number of calls offered to the queue

Handled The total number of calls answered by agents for the day

Abandoned The total number of calls abandoned before being answered by an agent for the day

Interflowed The total number of calls interflowed for the day. Interflow is amechanism that directs a
call waiting in queue to another answer point.

Requeued The total number of calls re-queued for the day

Average Time to
Handle

The average time it takes for the call to be answered by an agent

Average Time to
Abandon

The current average duration callers wait before abandoning calls

Average Talk Time The current average time agents spend talking to callers

Service Level % The percentage of calls answered within your Service Level Time value over the day

% Handled The percentage of calls answered compared to the total number of calls offered to the
ACD queue for the day

% Handled by 1-4 The percentage of all of the calls answered by the first, second, third, and fourth answer
points

#Handled by 1-4 The number of calls answered by the first, second, third, and fourth answer points

Total Talk Time The current total time agents spend talking to callers

Current Queue
Unavailable

The total number of callers that were rerouted after you set the queue to Unavailable.
When youmake the queue available again, this value resets to zero.

Total Queue
Unavailable

The total number of times during the day callers dialed the queue and were rerouted
because no agents were logged on to the queue or you set the queue to Unavailable

See Current Queue Unavailable.

Offered Last Hour The total number of calls offered to the queue in the last hour of business

Time to Handle
Last Hour

The predicted duration callers, who call in the last hour of business, wait before being
answered by an agent

% Handled Last
Hour

The percentage of calls answered in the last hour of business, compared to the total
number of calls offered to the ACD queue for the day
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Term Meaning

Service Level %
Last Hour

The percentage of calls answered within your Service Level Time value in the last hour

Interflowed Last
Hour

The total number of calls interflowed during the last hour of business. Interflow is a
mechanism that directs a queue delayed call to voicemail or to another answering point

Handled Last Hour The total number of calls answered by agents during the last hour of business

Abandoned Last
Hour

The total number of calls abandoned during the last hour of business

Unavailable Last
Hour

The total number of times, in the last hour of business, callers dialed the queue and
were rerouted because no agents were logged on to the queue or you set the queue to
Unavailable

See Current Queue Unavailable.

Average Handling
Time Last Hour

The average duration of calls from agent pick up to client hang up (including hold
time) during the last hour of business

Offered Last 15
Minutes

The total number of calls offered to the queue in the last 15minutes of business

Time to Handle
Last 15Minutes

The predicted duration callers, who call in the last 15minutes of business, wait before
being answered by an agent

Average Handling
Time Last 15
Minutes

The average duration of calls from agent pick up to client hang up (including hold
time) during the last 15minutes of business

% Handled Last 15
Minutes

The percentage of calls answered in the last 15minutes of business, compared to the
total number of calls offered to the ACD queue for the day

Service Level %
Last 15Minutes

The percentage of calls answered within your Service Level Time value in the last 15
minutes of business

Handled Last 15
Minutes

The total number of calls answered by agents during the last 15minutes of business

Abandoned Last 15
Minutes

The total number of calls abandoned during the last 15minutes of business

Interflowed Last 15
Minutes

The total number of calls interflowed during the last 15minutes of business. Interflow is
amechanism that directs a queue delayed call to voicemail or to another answering
point
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Term Meaning

Unavailable Last
15Minutes

The total number of times, in the last 15minutes of business, callers dialed the queue
and were rerouted because no agents were logged on to the queue or you set the queue
to Unavailable

See Current Queue Unavailable.

% Abandoned The percentage of calls that were abandoned. The% Abandoned = (Calls Abandoned ÷
Calls Offered).

% Abandoned Last
Hour

The percentage of calls that were abandoned in the last hour of business.

% Abandoned Last
15Minutes

The percentage of calls that were abandoned in the last 15minutes of business.

Remote Calls
Waiting

When you havemore than one telephone system networked together, this is the current
number of calls waiting in a remote queue to be answered by agents at your site

Remote Longest
Waiting

When you havemore than one telephone system networked together, this is the wait
time for the caller waiting the longest in a remote queue to be answered by an available
agent at your site

LoggedOut The number of agents that are associated with the queue but not logged in to the
system

Logged In Not
Present

The number of agents that are logged into the telephone system, but not present in the
queue beingmonitored

Agent Unavailable
%

The percent of time the agent was set in Do Not Disturb or Make Busy and unavailable

Wrap Up The total time the agent spent in theWork Timer state

Make Busy The total time the agent spent in theMake Busy state

Occupancy The total time the agent spent in an occupied state (occupied state excludes idle time)

Table 7 - 9 describes the real-time and over-the-business-day Queue Now andQueueGroup Now agent and
agent group statistics.

Term Meaning

Agent name The name of the agent beingmonitored

Agent group The name of the agent group beingmonitored

Table 7 - 9 Queue Now and Queue Group Now agent statistic column headings
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Term Meaning

Present Indicates whether the agent is present in the queue

Presence is indicated by a colored star. A green star indicates the agent is present in
the queue. A gray star and gray row indicates the agent is not present in the queue

Media Server Themedia server to which the agent is associated

Agent login ID The login ID of the agent beingmonitored

Extn# The extension where the agent logged in

Log In Themost recent time the agent logged into Contact Center Management

LogOff Themost recent time the agent logged out of Contact Center Management

Shift Time The total elapsed time logged for the agent or agent group , calculated based on the dif-
ference between log in and log off

DND Time The duration of time where DoNot Disturb was the overriding state for the agent or
agent group, controlled by the agent or the supervisor

MKB Time The duration of time whereMake Busy was the overriding state for the agent or agent
group, controlled by the agent or the supervisor

Wrap Up Time The duration of time whereWrap Up Timewas the overriding state for the agent or
agent group. Wrap up time does not include any time spent making or taking calls dur-
ing the wrap up timer.

ACD Time The duration of ACD calls handled, from agent pickup to client hangup (does not include
hold time)

Hold ACD Time The duration of time ACD calls spent on hold

Non ACD Time The duration of non-ACD calls handled, from agent pickup to client hangup

Hold Non ACD
Time

The duration of time non-ACD calls spent on hold

Out Time The duration of time agents spent talking in outbound calls

Out Hold Time The duration of time outbound calls spent on hold, for agents

DND Cnt The number of times the agent entered the DoNot Disturb state

MKB Cnt The number of times the agent entered theMake Busy state

ACD Cnt The number of ACD calls answered by the agent

Shrt ACD Cnt The number of ACD calls answered by the agent, where the talk time was less than the
Short Handle parameter
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Term Meaning

Hold ACD Cnt The number of times ACD calls were placed on hold

Non ACD Cnt The number of non-ACD calls answered by the agent

Hold Non ACD Cnt The number of times non-ACD calls were placed on hold

Out Cnt The number of outbound calls answered by the agent

Out Hold Cnt The number of times outbound calls were placed on hold

Avg Handl The average duration of calls, from agent pickup to client hangup

Occupancy The duration of time the agent spent processing calls (total shift minus idle time)

Calls per Hour The total ACD call count minus the ACD short handle call count, divided by the shift
time for the agent

On failover Indicates whether the primary media server is offline and has failed over to the sec-
ondary (redundant) media server

Agt Unavail% The percentage of time for the shift that the agent was unavailable (Do Not Disturb,
Make Busy, andWrap Up Timer)

Logged in Not
Present Time

The duration of time the agent was logged into Contact Center Management but not
present in a queue

External Handle
Duration

The duration of time the agent spent handling external calls

External Inbound
Count

The number of incoming external calls

External Outbound
Count

The number of outgoing external calls

Viewing queue chart statistics
NOTE:

l You can see queue charts during business hours as long as the business schedule you configure in
YourSite=>Schedule or YourSite Explorer=>Schedules is consistent with your company’s hours of
operation. You assign business-hours schedules to queues in
YourSite=>Configuration=>Queue=>Queue or in YourSite Explorer=>Queues=>Business Hours.

The following charts display queue statistics:
l Queue Now
l QueueGroup Now
l Queue Performance by Period
l QueueGroup Performance by Period
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Queue Now and Queue Group Now
TheQueue Now andQueueGroup Now (Integer) charts show, by default, the total calls Handled, Abandoned,
and Interflowed across queues and queue groups for the day. Along with the defaults, the charts can be
configured to display call statistics for Calls Waiting, Agents Available, ACD, Idle, Non ACD, Outbound,
Unavailable, Offered, Requeue, Total Queue Unavailable, Current Queue Unavailable, Offered Last Hour,
Handled Last Hour, Abandoned Last Hour, Interflowed Last Hour, Unavailable Last Hour, Offered Last 15
Minutes, Handled Last 15Minutes, Abandoned Last 15Minutes, Interflowed Last 15Minutes, Unavailable
Last 15Minutes, Remote Calls Waiting, Logged out, Logged in not present, # Handled by 1, # Handled by 2, #
Handled by 3, and # Handled by 4. (See Figure 7 - 19.)

Queue Now andQueueGroup Now (Percentage) charts show, by default, Service Level %, Handled%, %
Handled by 1, % Handled by 2, % Handled by 3, % Handled by 4, % Handled Last Hour, Service Level % last
Hour, % Handled Last 15Minutes, Service Level % Last 15Minutes, %Abandoned, %Abandoned Last Hour,
and%Abandoned Last 15Minutes.

Queue Now andQueueGroup Now (Time) charts show, by default, Longest Waiting, Average Time to
Handle, Average Time to AbandonMinutes, Average Talk Time, Ttl Talk Time, Time to Handle Last Hour,
Average Time to Handle Last Hour, Hdnl Last 15Min, Average Handling Time Last 15Minutes, Rmt Long
Wtg, Total work timer minutes, Total make busy minute, and Total occupancy minutes.

Figure 7 - 19 Queue Now (Integer) chart

Queue Performance by Period and Queue Group Performance by Period
TheQueue Performance by Period andQueueGroup Performance by Period (Integer) charts show, by
default, the calls Handled and Interflowed across 15-minute intervals for queues and queue groups. Along with
the defaults, the charts can be configured to display call statistics for Offered, Short Abandoned, Abandoned,
Requeue, # Handled by 1, # Handled by 2, # Handled by 3, and # Handled by 4. (See Figure 7 - 20.)
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TheQueue Performance by Period andQueueGroup Performance by Period (Percentage) charts show, by
default, % Handled by 1, % Handled by 2, % Handled by 3, % Handled by 4, Service Level % Today, and%
Handled.

TheQueue Performance by Period andQueueGroup Performance by Period (Time) charts show, by default,
Average Time to Handle, Average Time to Abandon, Average Time to Interflow, Ttl Talk Time, Average Talk
Time, Total work timer minutes, Total make busy minutes, and Total occupancy minutes.

Figure 7 - 20 Queue Performance by Period chart

Navigating charts
You can zoom in and out of charts to change how the data is displayed in the chart, expanding or compressing
the displayed data. If the range of data displayed exceeds the boundary of the chart window in Contact Center
Client, you can use the horizontal scroll bar to move back and forth across the displayed data.

To zoom in on a chart
 1. Hold your mouse over the edge of the horizontal scroll bar until the cursor turns into a double-arrow (<->)

icon.
 2. Click and drag the edge of the horizontal scroll bar towards the opposite side of the scroll bar.

The chart zooms in and the horizontal scroll bar shrinks in size.
NOTE: To undo the zoom function, click Zoom Out.

To zoom out of a chart
 1. Hold your mouse over the edge of the horizontal scroll bar until the cursor turns into a double-arrow (<->)

icon.
 2. Click and drag the edge of the horizontal scroll bar and drag to zoom out.

To show the entire chart in the window
l If you are zoomed in, in the chart window click Show All.
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To scroll across the chart
l Click and drag the horizontal scroll bar in the direction you wish to scroll the chart.

Viewing callback lists
NOTE:

l You canmonitor the currently available callbacks in real time.
l You can requeue and reject callbacks.

TheGlobal callback monitor displays callback information.

Global callback monitor
TheGlobal callback monitor enables system administrators to monitor callback states in real time and
displays the callbacks currently available. Using the Global callback monitor, you can requeue and delete
callbacks. (See Figure 7 - 21.)

To access the global callback monitor
 1. Click theReal Time tab in the Contact Center Client ribbon.
 2. Click theCallbacks icon.

TheMonitor Callback List displays.

Figure 7 - 21 Global callback monitor

Table 7 - 10 describes the Global callback monitor column headings.
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Table 7 - 10 Global callback column headings

Column heading Definition

Caller number the phone number provided by the caller

Caller name the name of the caller

Status the state of the callback — new request, in progress, requeued,
completed, unknown

Priority the importance level of the callback.

Callback priority levels are:
l Voice—High
l Web—Normal
l Caller abandoned— Low

Reason lists why the callback is in a particular status

Type the type of callback — voice, web, or caller abandoned

# of Attempted Calls from
Agent

the number of times the agent attempted the callback

Last Time Agent
Attempted

the last time the agent attempted the callback

Request Time the specific time the callback will be executed

TimeReceived the specific time the caller submitted the callback request

Web IP Address the IP address of the caller who submitted the callback request

Last Attempted Call to
Client

the specific time the last callback attempt to the caller was made

Attempted Calls to Client the number of times the callback was attempted

Client Available From the earliest time the caller is available to receive the callback

Client Available To the latest time the caller is available to receive the callback

ANI the phone number of the caller

DNIS Number the phone number the caller dialed

Dialable the dialable number of the device that will handle the callback

Device Name the name of the device that will handle the callback

Device Type the type of device that will handle the callback — agent, queue, or exten-
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Column heading Definition

sion

RecordedMessage contains a hyperlink to the voice callback .wav file left by the caller

Country the country the call originated from

Area the province/state or other area the call originated from

Port the number of the port attempting to perform the callback

Viewing ports
NOTE:

l You canmonitor port states in real time and view currently executing call flows.
l You can select the ports you want to monitor individually or by hunt group.
l You can remove ports from DoNot Disturb.

The Port Status monitor displays port information.

Port status monitor
The Port Status monitor enables system administrators to monitor port states in real time and displays the call
flows that are currently executing on ports. Using the Port Status monitor, you can take ports out of Do Not
Disturb and playback historical port events in Auditor mode. (See Figure 7 - 22.)

To access the port status monitor
 1. Click theReal Time tab in the Contact Center Client ribbon.
 2. Click thePorts icon.

The Port status monitor displays.

Figure 7 - 22 Port status monitor
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Table 7 - 11 describes the Port Status monitor column headings.

Table 7 - 11 Port Status column headings

Column head-
ing Definition

Name the name of the port

Dialable the port's dialable number

Extension
Type

the type the extension—RAD, messaging, callback, or UPiQ

Media Server themedia server to which the port is associated

Hunt Group
Name

the name of the hunt group the port is associated with. A port can be associated with
more than one hunt group

Hunt Group
Dialable

the dialable number of the hunt group

Phone state the state of the phone— idle, dialing, talking, ringing, or unknown

Call flow name the name of the executing call flow

Phone Display displays theMiAUDIO state (that is displayed on the phone)

ANI the phone number of the caller

DNIS the phone number dialed by the caller

Redirect the number of the device the call was directed from

Viewing Web pages
While using Contact Center Client, you can view Web pages using theWeb browser monitor.

To view aWeb page within Contact Center Client
 1. Click theReal Time tab in the Contact Center Client ribbon.
 2. Click theWeb icon.

TheWeb Browser Properties window opens.
 3. AfterMonitor title, type a name for themonitor.
 4. AfterStart URL, type theWeb address of the website to view.

NOTE: The website address must begin with http:// or you will not be able to view themonitor.
 5. Optionally, select a value for theWeb BrowserRefresh Rate.
 6. Click OK.
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Viewing and customizing real-time monitors
NOTE:

l Contact Center Client has a tabbed interface for managing and arranging windows. You can dock the
monitors, displaying them on overlapping tabbed panels to maximize real estate. This enables you to
readily navigate betweenmonitors.

l You can save threshold settings and display characteristics you define for monitors. When you click
File=>Save, Contact Center Client saves all openmonitors under one profile name. You can click
File=>Open to open another profile, or File=>New to create a new profile.

Opening monitors
To open amonitor in Contact Center Client
 1. In the Contact Center Client ribbon, click Real time to view the Contact Center Client monitor icons.
 2. In theState by Position column on the ribbon, click Agent .

This selects the Agent State by Positionmonitor and the Add/Remove device IDs window opens.
See Figure 7 - 23.

 3. UnderAgent groups, select agent groups tomonitor and/or underAgents, select agents to monitor.
 4. UnderCard designs, select a card design.

Card designs specify the information displayed on agent, employee, and extensionmonitors.
 5. Click OK.

Figure 7 - 23 Add/Remove devices
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Docking monitors
You can dock monitors and readily navigate between them. You can dock amonitor to the top, bottom, left, or
right of another monitor. Alternatively, you can dock amonitor on the top, bottom, left, or right side of the
Contact Center Client window. You can dock monitors on top of one another, displaying them on overlapping
tabbed panels to maximize real estate.

To dock amonitor on top of another monitor
 1. Right-click the title bar of an openmonitor and select Dock.
 2. Repeat step 1 for all openmonitors.
 3. Click the title bar of amonitor and drag themonitor on top of a secondmonitor placing your cursor in the

center of the four-headed arrow that displays.
See Figure 7 - 24.

Figure 7 - 24 Docking monitors

 4. Release themouse button.
Your monitors are displayed on overlapping tabbed panels.
See Figure 7 - 25.
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Figure 7 - 25 Docked monitor

Adding and removing devices
You can add and remove devices from all of the Contact Center Client monitors except for the chart monitors.

To add devices to the bottom of amonitor
 1. Right-click an openmonitor and click Add/Remove devices.
 2. UnderAgent/Employee/Queue groups, select additional agent, employee, or queue groups to add to

themonitor, or underAgents/Employees/Queues, select additional agents, employees, or queues to
add to themonitor.

 3. Click OK.
On the Agent State by Position, Employee State by Position, and Extension State by Position
monitors a blank row of cells separates the original agents from those you just added. To remove the
blank row youmust sort themonitor.
See "Sortingmonitor devices" on page 230.

To remove devices from amonitor
 1. Right-click an openmonitor and click Add/Remove devices.
 2. UnderAgents/Employees/Queues, clear the check boxes of the agents, employees, or queues to be

removed.
 3. Click OK.

NOTE:You can alternatively add and remove devices via theMonitor Options tab in the Contact Center Client
ribbon for the Queue by Period, Queue Now, andQueueGroup Now monitors.
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Sorting monitor devices
When you select devices to display on amonitor, you can specify the devices be sorted by media server (on
agent monitors only), ID, or name (alphabetically) in ascending or descending order. When themonitor opens,
the devices display in the order you selected.

To sort the devices displayed on amonitor
l In the left pane of theAdd/Remove deviceswindow, click Media server to sort themembers by

media server, click Name to sort themembers alphabetically, or click Reporting to sort themembers
by ID, in either ascending or descending order.

You can sort information by state, name, agent ID, or extension on the Agent State by Position, Employee
State by Position, and Extension by Positionmonitors.

To sort agents or employees by state
l Right-click amonitor and click Sort monitor=>By state.

If you sort agents by state, Contact Center Client displays the agents by state and time in state across the
monitor in the following order:

l Ringing
l ACD
l ACD Hold
l Idle
l Non ACD
l Non-ACD Hold
l Outbound
l Outbound Hold
l DoNot Disturb
l Make Busy
l SystemMake Busy
l Work Timer
l Unknown
l LoggedOff

To sort agents or employees by name
l Right-click amonitor and click Sort monitor=>By name.

To sort agents or employees by agent ID
l Right-click amonitor and click Sort monitor=>By agent ID.

To sort agents or employees by extension
l Right-click amonitor and click Sort monitor=>By extension.
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Rearranging cells
You can rearrange cells on the Agent State by Position, Employee State by Position, and Extension State by
Positionmonitors.

To rearrange cells
l On an openmonitor, drag a cell to a different position on themonitor.

You can rearrange columns on the Agent Shift, Queue by Period, Queue Now, andQueueGroup Now
monitors.

To rearrange columns
 1. Right-click an openmonitor and click Properties.
 2. Click the Layout folder.
 3. Click Column order.
 4. Click a column header and click the up or down arrow key to change the position of the column relative

to other columns on themonitor.

NOTE:You can alternatively rearrange cells via theMonitor Options tab in the Contact Center Client ribbon
for the Queue by Period, Queue Now, andQueueGroup Now monitors.

Setting monitor dimensions
You can specify the numbers of rows and columns of cells to display on the Agent State by Position,
Employee State by Position, and Extension by Positionmonitors. You can then adjust the table to fit within
themonitor frame.

To set table dimensions
 1. Right-click amonitor and click Set table dimensions.
 2. AfterColumns, type a number.
 3. AfterRows, type a number.
 4. Click OK.

Columns or rows are added or deleted from themonitor. You can redistribute the cells using a drag-and-
drop operation.

To size the table to fit the frame
l Right-click in any real-timemonitor and select Size table to frame.

Hiding monitor columns
On the Agent Shift, Queue by Period, Queue Now, andQueueGroup Now monitors, you can hide specific
columns of statistics.

To hide columns
 1. Right-click an openmonitor and click Properties.
 2. Click the Layout folder.
 3. Click Column order.
 4. In theVisible column, clear the check boxes of the columns you want to hide from view.

NOTE:You can alternatively hidemonitor columns via theMonitor Options tab in the Contact Center Client
ribbon for the Queue by Period, Queue Now, andQueueGroup Now monitors.
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Configuring chart characteristics
Individual charts have a range of configurable characteristics and options that enable users to customize their
chart display.

You can right-click charts to access the following options or select them via the Chart Options tab:

l Change the chart types
l Configure the legend
l Configure the color scheme
l Enable points labels
l Modify Properties

Changing chart type
Contact Center Client enables you to configure the type of chart, either column or line, used for your Queue
andQueueGroup Performance by Period charts.
Queue andQueueGroup Now charts display as bar charts.
 1. Right-click on an open By Period chart and click Chart Type.
 2. Select the type of chart you want your chart to display.

NOTE:Alternatively, you can change the chart type by selecting an open By Period chart, and choosing
Column or Line from the drop-down list beside Type in the Chart Options tab.

Configuring the legend
You can choose if your chart has a legend, as well as configure where the legend displays.

To configure the legend
 1. Right-click on an open queue chart and click Legend box.
 2. Select or deselect Enabled to either display or remove the legend.
 3. Right-click on an open queue chart and click Legend box.
 4. Click Left, Top, Right, orBottom to determine where you want the legend box to display.

NOTE: Alternatively, you can configure the legend by selecting an open queuemonitor and accessing options
from the Legend section of theChart Options ribbon.

Configuring the color scheme
You can select the color scheme for the chart.

To configure the color scheme for a chart
 1. Right-click on an open queue chart and click Color.
 2. Select the color scheme you want to apply to the chart from the list.

NOTE:Alternatively, you can configure the color scheme by selecting an open queue chart and selecting
color options from the drop-down list besideColor in theChart Options ribbon.
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Defining queue chart properties
Under Chart properties, you can select general chart characteristics, such as colors and stacked effects. You
can define series characteristics, such as the type of chart, the fill properties, and the shape of the bars. In
addition, you can define y axis characteristics.

To define queue chart properties
 1. Right-click an open queuemonitor and click Chart properties.
 2. On theGeneral tab, specify general chart characteristics (colors, effects, and 3D).
 3. Click theSeries tab.
 4. Specify series characteristics (chart style, fill style, bar type, and border style).
 5. Click theY Axis tab.
 6. Specify axis scale characteristics, label characteristics, and the width and color of the axis line.
 7. Click OK.

NOTE:Alternatively, you can configure queue chart properties by selecting an open queuemonitor and
clickingProperties located in theChart Options ribbon.

Enabling point labels
You can enable labels for each point in your chart.

To enable point labels
l Right-click on an open queue chart and click Points labels.

NOTE:Alternatively, you can enable point labels by selecting an open queue chart and clickingEnabled in
thePoints Label section of theChart Options ribbon.

Modifying Properties
Properties controls the way chart data displays. Under Properties, you can

l Specify the queue chart title
l Highlight statistics
l Configure 2D and 3D statistics
l Animate charts
l Select call statistics to display
l Create andmodify constant lines

NOTE:You can either right-click an open queue chart to modify properties or select an open queue chart and
choose options via the Properties section of the Chart Options tab.

Specifying the queue chart title
Under Properties, you can specify the title of the queue chart.

To specify the queue chart title
 1. Right-click on an open queue chart and click Properties.
 2. AfterMonitor title, select and delete the old chart title and type a new name for the queue chart.
 3. Click OK.
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Highlighting statistics
Under Properties, you can enable the highlight feature. When the highlight feature is enabled, and when you
move your cursor over a bar representing a specific call statistic, that bar is highlighted and the other bars,
representing other call statistics, are dimmed.

To highlight statistics
 1. Right-click on an open queue chart and click Properties.
 2. Expand theChart properties tree and click General.
 3. Select theHighlight check box.
 4. Click OK.

Configuring 2D or 3D chart displays
Under Properties, you can configure whether your chart displays bars in 2D or 3D. By default, your charts
display in 3D.
 1. Right-click on an open queue chart and click Properties.
 2. Expand theChart properties tree and click General.
 3. Select the 3D check box to enable or disable 3D charts.
 4. Click OK.

Animating charts
Under Properties, you can enable the animated feature. When the animated feature is enabled, changes to
chart values actively display. The animated feature is disabled by default.

CAUTION:Enabling the animated feature will result in additional CPU load on the affected workstation.

To animate charts
 1. Right-click on an open queue chart and click Properties.
 2. Expand theChart properties tree and click General.
 3. Select theAnimated check box.
 4. Click OK.

Selecting call statistics to display
Under Properties, you can select call statistics to display. For example, you can add Calls Waiting, Agents
Available, Idle, and Requeued statistics to the QueueGroup Now (Integer) chart.

To select call statistics to display
 1. Right-click on an open queue chart and click Properties.
 2. Expand theChart properties tree and click Series data.
 3. Select theSeries data type radio button to define the types of data visible in the chart.

l Integer
l Percentage
l Time

 4. If you are selecting call statistics for a Queue or QueueGroup Performance by Period chart, click Time
Interval. Select the radio button for the interval you want to use and set the time.

 5. UnderVisible, select the check box of the data you want to add to the chart.
 6. Alternatively, underVisible, clear the check box of the data you want to remove from the chart.
 7. Click OK.
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Creating and modifying Constant lines
Under Properties, you can configure Constant lines. Constant lines are horizontal lines you configure to
display across your chart at set values on the Y-axis, enabling you to clearly see how the data being displayed
in the chart meets with desired values.

To create Constant lines
 1. Right-click on an open queue chart and click Properties.
 2. Click Chart properties.
 3. Click Constant lines.
 4. Click Add.
 5. Click in theColor box to choose a color.

NOTE: The default constant line color is red.
 6. After Text, type the name you want to display beside the constant line in the chart.
 7. AfterValue, type the value you want the constant line tomark.
 8. AfterWidth, select the thickness of the line.
 9. Click OK.

The Constant line will be added to the list of active Constant lines.

Tomodify a Constant line
 1. Select the Constant line you want to modify and click Edit.
 2. After Text, type the name you want to display beside the Constant line in the chart.
 3. AfterValue, type the value you want the Constant line tomark.
 4. AfterWidth, select the thickness of the line.
 5. Click OK.

To delete a Constant line
l Select the Constant line you want to delete and click Delete.

Filtering device variables
On theQueue Now, Agent Shift, Queue by Period, andQueueGroup Now monitors, you can filter specific
device variables. For example, on the Queue by Periodmonitor, you could filter the Calls Offered variable and
display statistics for the intervals during which the queue was offered five or more calls.

To filter variables
 1. Right-click amonitor and click Filter device variables.
 2. Click Filter data to show, select a variable, select an operand, and type a number.
 3. Click OK.

A subset of the data is displayed based on the conditions defined in the filter.
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Setting alarms
You can define alarms to alert you to significant changes in contact center activity. Using the alarms, you
specify performance thresholds for contact center elements, such as queues and agents, and customize the
visual, auditory, or email delivery of alarms. If any availability or performance issues arise, your alarms deliver
a notification enabling you to instantly change agent and queue availability to adjust to unplanned call
volumes. For a demonstration of alarm configuration and functions, click
http://www.youtube.com/watch?v=cDdUa1l-Q1o.

Client alarms are specific to each computer. To notify you that performance thresholds are not beingmet, you
can configure alarms so that

l Monitor cells and statistics change color.
l A pop-up notification opens on your desktop.
l A sound prompt, such as a beep or .wav file, plays.
l You are notified by email.
l Contact Center Client opens on top of all open applications.

To configure alarms for real-timemonitors
 1. Add performance thresholds.
 2. Specify threshold colors.
 3. Specify threshold notification.

Adding performance thresholds
To add performance thresholds so you canmonitor alarms
 1. Right-click amonitor and click Set alarms.

Alternatively, select an openmonitor and click Set alarms in the Alarms column, found in theMonitor or
Chart Options tab in the Contact Center Client ribbon.
The Set alarms window open.
NOTE:You can select theApply the alarm thresholds to all devices displayed on the monitor
check box to apply the threshold settings for performance variables across all queues or agents.
Alternatively, you can select Apply the alarm thresholds to a specific list of devices to apply the
threshold settings for a performance variable to a list of queues or agents.

 2. UnderDevices, select one or more queues or agents or select theSelect all check box to select all
queues or agents.

 3. In thePerformance variables list, select a variable.
 4. UnderAlarm Thresholds, click Add threshold and type a value for the upper boundary of the

threshold.
The lower boundary cannot bemodified. The lower boundary of the next threshold is always slightly
greater than the upper boundary of the previous threshold.

 5. Click OK.

http://www.youtube.com/watch?v=cDdUa1l-Q1o
http://www.youtube.com/watch?v=cDdUa1l-Q1o
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Specifying performance threshold colors
To configure performance threshold colors
 1. For the alarm threshold for which you want to specify colors, underBackground, click the arrow.

A color palate opens.
 2. Select a color.
 3. Under Font color, click the arrow.

A color palate opens.
 4. Select the font color for the alarm threshold.
 5. Click OK.

Specifying threshold notification
To configure performance threshold sound notification
 1. For the alarm threshold for which you want to be notified by a sound, underSound, select the check

box.
The Sound window opens.

 2. Specify the alarm triggering properties.
 3. Specify the sound you want played when the alarm is triggered.
 4. Click Save.

To configure performance threshold pop-up window notification
 1. For the alarm threshold for which you want to be notified by a pop-up window, underPop-up, select the

check box.
The Pop-up window opens.

 2. AfterDuration, type the number of seconds you want the pop-up alarm to be displayed when threshold
conditions are satisfied.

 3. If you want to display the pop-up alarm on top of all of the other applications, select theKeep this
message visible on mouse over check box.

 4. Optionally, click the Format font button to specify font attributes for the pop-up alarm message.
 5. In the text box, type themessage for the performance threshold and click theAdd variable button to

insert performance variables. (for example, type CW P001 = <calls waiting variable>).
 6. Click Save.

To specify that Contact Center Client opens on top of all other applications when a performance threshold is
satisfied

l For the alarm threshold for which you want to be notified, underBring to front, select the check box.

To configure performance threshold email notification
 1. For the alarm threshold for which you want to be notified, or notify others by email, underEmail, select

the check box.
The Email window opens.

 2. AfterDistribution, specify which contacts are to be notified by email when threshold conditions are
satisfied.
See "Emailing reports" on page 282.

 3. AfterSubject, type the subject of the email to be sent (for example, type Calls Wtg in Sales Queue 1
>10!).

 4. In themessage box, type the body of the email.
 5. Click Save.
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Consider the threshold programming in Figure 7 - 26. When the number of agents available in the technical
support queue is between 0 and 2, the cell housing the Agents Available statistic is red. When the number of
agents available is between 3 and 4, the cell turns orange. When the number of agents available is 5 or
greater, the cell turns white. In addition, audible alarms and pop-up alarms display.

To clear any current client alarms in Contact Center Client
l Right-click themonitor and click Clear alarms.

Figure 7 - 26 Set alarms window



Contact Center Solutions User Guide

- 239 -

Customizing the information displayed on position and time
monitors
On the agent, employee, and extension by position and by timemonitors, real-time information is displayed in
cells (cards). You can select from available card designs, or customize cards to display specific information.

When you first open an agent, employee, or extensionmonitor, you can select a card design on the
Add/Remove device IDs window:

l The Classic card displays the agent state, time in the state, presence, agent/employee name, agent
login ID/employee ID, and extension number (or queue name for voice agents on ACD or on ACD
Hold).

l The Caller ID card displays the caller name and number (ANI), the number the caller/employee dials for
incoming/outgoing calls, the state, time in the state, presence, agent/employee name, agent login
ID/employee ID, and extension number (or queue name for voice agents on ACD or on ACD Hold.

l Custom cards you create and share

The Caller ID card is the default card design. You can use this card design, or select the Classic card or a
customized card. You can create new card designs or copy existing card designs andmodify them. For
example, you can add or remove text and variables from cards and rearrange the information displayed. You
can share card designs with other employees. When you select a card design for an agent, employee, or
extensionmonitor, it is applied to all monitors of that type.

Selecting and customizing card designs
To select a card design
 1. Right-click an open position or timemonitor and click Properties.
 2. Click Layout=>Card design.
 3. Under Design name, select a card design.
 4. Click OK.

To customize cards for position and timemonitors
 1. UnderCard design,

l If you want to create a card design, click New.
l If you want to edit an existing card design, select a card design and click Edit.
l If you want to create a card design based on the Caller ID card or the Classic card, select either

card and click Copy.
 2. On theNew card designwindow, type the name of the new card design.
 3. If you want to share the design with other agents, select Share design.
 4. Click OK.
 5. Select the card and click Edit.

See Figure 7 - 27.
 6. AfterState, select a state for the card design.

You can use the same card design for all states or you can customize cards for specific states, such as
ACD, Idle, Make Busy, and Unknown.

 7. Under Fields, select a field type and drag and drop it to the card design.
 8. If you want to resize the field, click the field and use your pointer to move or resize the field.
 9. If you want to change the properties for a field, click the field and change the properties in the right pane

of Card Designer.
 10. If you want to change the size of the card design preview, after Zoom, select a different magnification

value from the list.
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 11. Add additional fields to the card.
 12. Select Copy to if you want to copy the current design to the card of a different state.
 13. Click OK.

The new card design displays on the Card design list.
 14. Click OK.

Figure 7 - 27 Card Designer window

Defining monitor styles
You can customize the appearance of individual monitor elements. For example, you can configure the font
size and color of column headings or apply a skin of predefined colors and font attributes to the entire monitor.

To customize the appearance of monitor elements
 1. Right-click an openmonitor and click Properties.
 2. Click General=>General settings.
 3. If you want to change the title of themonitor, after Title, type a name.
 4. If you want to scroll horizontally on themonitor, select theEnable horizontal scroll bars check box.
 5. If you want to scroll vertically on themonitor, select theEnable vertical scroll bars check box.
 6. If you want to groupmonitor headings, select theEnable grouping check box.
 7. If you want to apply a skin to themonitor, click Layout=>Monitor style.
 8. Click Load style and select a skin.
 9. Otherwise, underProperties, manually configure the column settings, column font, row settings, and

row-alternate settings.
 10. Click OK.
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Adding text to card designs
You can use a text box to add custom text to a card.

To edit text that you have added to a card
 1. Select the text box.

Properties displays on the right.
 2. UnderProperties, in the box to the right of Text, type the text to be added to the card.
 3. Click OK.
 4. Click OK.

Grouping data
You can group rows of data in the Queue Now monitor, and other monitors that contain columns. For example,
you can group the data by the ACD count statistic and readily see which agents handled themost calls, and
which agents handled the least calls, as illustrated in Figure 7 - 28.

Figure 7 - 28 Enable grouping

The Enable grouping option displays a grouping panel to which users drag columns. The grouping order
determines the order in which the rows display.

To enable grouping
 1. Right-click an openmonitor and click Properties.
 2. Select theEnable grouping check box.
 3. Click OK.

Themonitor displays a grouping panel.
 4. Drag a column heading to the panel to group by the column heading.
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Building marquee monitors
You can build marqueemonitors to broadcast real-time statistics andmessages and alarm on real-time
contact center performance statistics. With marqueemonitors and wall-mountedmarquee displays, such as
LCD monitors or LED reader boards, you can offer your supervisors and agents access to important contact
center performancemetrics. For a demonstration of marqueemonitors, click
http://www.youtube.com/watch?v=wFsiFz6JgMc.

You can build amarqueemonitor to broadcast statistics andmessages. To do so, youmust
l Specify styles for themarqueemonitor.
l Configuremarquee text and variables.

Configuring marquee monitor styles
To specify attributes for themarquee background
 1. Click theMarquee icon.

The Configuremarquee window opens.
 2. Click Add a message.

The Add amessage window opens.
 3. Type a name for themessage.
 4. UnderPosition, select Top, Right, Left, Center, orBottom to specify how themessage is to be

displayed on themarquee.
 5. Click Format marquee.

The Format marquee window opens.
 6. AfterBackground color, select a color for the background.
 7. AfterCell color, select a color for themarquee cells.
 8. AfterCell size, specify a value for the size of themarquee cells.
 9. AfterCell spacing, select a value for the space betweenmarquee cells.
 10. To specify themarquee text font type and color, click Format font.

The Font window opens.
 11. Select font attributes.
 12. Click OK.
 13. If you want themessage and the background of themessage to be displayed using pixels, select the

Matrix style check box.
 14. Click OK.
 15. Click OK.

Themarquee displays.
Youmust configuremarquee text and variables.
See "Configuringmarquee text and variables" on page 242.

Configuring marquee text and variables
To configure text and variables for themarquee

 1. Right-click themarquee and click Configure marquee.
The Configuremarquee window opens.

 2. In theMessage editor text box, type amessage to display on themarquee (for example, type Calls
Wtg =).

 3. UnderMessage editor, click theAdd variable button.
The Add/Edit variable window displays.

 4. Click Add.
The Configure variable window opens.

http://www.youtube.com/watch?v=wFsiFz6JgMc
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 5. UnderVariable types, click themonitor type to which the variable applies.
 6. UnderVariables, click a variable.
 7. UnderDevices, select the check box of a device.
 8. Under Thresholds, click Add threshold and specify a value for the upper boundary of the first

threshold.
 9. Click OK.
 10. For the threshold, underVariable, select a color to be displayed in themarqueemessage string.
 11. For the threshold, underMessage, select a color for the text that will precede the variable in the

marquee text string.
 12. After Type a name for the variable, type a name.
 13. Click OK.
 14. On theConfigure marqueewindow, in theMessage editor text box, position your pointer where you

want to add the variable.
You can add variables at the beginning, middle, or end of message strings.

 15. On theAdd/Edit variablewindow, double-click the variable to add it to themessage string.
 16. Click theAdd variable button.

The Add/Edit variable window opens.
 17. Click theConfigure transition effects button and select the check boxes for the transition effects to

be included.
 18. Click OK.

Themarquee displays, showing the text you typed and a real-time value for the performance variable.
You can define additional thresholds for the performance variable, and add additional variables to the
marquee.

Using Contact Center Chat
Contact Center Client provides instant messaging capabilities for both supervisors and agents and is typically
used by contact center employees only. Contact Center Chat provides the online chat presence of contact
center employees, including Online, Offline, and Away. Agents can view the availability and presence of other
contact center employees before they transfer calls or send online chat messages.

Using Contact Center Chat, you can communicate essential information to one or more agents, agent groups,
or supervisors quickly and securely. You can coach agents and send timely messages, such as asking an
agent to delay going on break when it is busy.

NOTE:
l Youmust have a security role that does not restrict you from gaining access to Contact Center Chat.
l Youmust log on to Contact Center Client in order to send and receive onlinemessages.
l When you receive amessage it is displayed immediately on top of all open windows.
l Contact Center Chat requires server to client hostname resolution to properly function.

Contact Center Chat is enabled by default. If you want to disable Contact Center Chat you do so in the
Contact Center Management website in YourSite=>Enterprise=>local site. If you want to disable Contact
Center Chat in YourSite Explorer, you do so in YourSite=>Site=>Chat Settings.

NOTE:
l In order to use Enterprise / Presence Chat integration, youmust enable Contact Center Chat.
l If Contact Center Chat is disabled for a particular site all employees associated to that site will be

unable to communicate with each other using Contact Center Client.
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Sending an initial Contact Center Chat message
On an agent, employee, or extensionmonitor, you can right-click an agent’s cell and click Send instant
message to send an onlinemessage to the agent.The example below demonstrates integration with Microsoft
Lync Server 2010, enablingMicrosoft Lync as the default instant messaging client.

To send a chat message
 1. Click Chat in the Contact Center Client ribbon.
 2. Double-click the ID that displays besideContact Center Chat in the toolbar.

The Send an Instant Message window opens.
See Figure 7 - 29.

 3. Type the recipient's name in the contact text box or double-click a contact from the contact list.
The Conversation window displays.

 4. Type amessage.
 5. Click Enter.

Figure 7 - 29 Instant message window

To send a chat message while viewing agents on an agent, employee, or extensionmonitor
 1. Right-click a cell in any open agent monitor and click Send instant message.

The Conversation window opens.
 2. Type amessage.
 3. Click Send.
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Adding someone to a conversation
To add someone to a conversation
 1. On the Conversation window, click the Invite someone to join this conversation icon.
 2. Double-click a contact to add the contact to the conversation.
 3. Click Send.

Responding to a Contact Center Chat message
Agents and supervisors can receive Contact Center Chat messages only if they are logged on to Contact
Center Client.

To respond to a chat message
 1. Type amessage.
 2. Click Send.

Contact Center Chat sends your response to all chat session participants.

Using Contact Center Client with Lync
NOTE: In order to use Enterprise Presence / Chat integration, an employee’s email address, as configured in
YourSite Explorer under Employee, must be the same as the SIP address configured in Lync Server 2010.

With the addition of Lync Server 2010, agents and supervisors use Lync Client as their default instant
messaging client. The presence of all company employees is natively delivered in Contact Center Client.
Contact center employees can view the presence of both internal and external contacts to determine if they
are available to communicate. In addition to Available, Offline, and Away, employees see In aMeeting, Busy,
In a call, Do Not Disturb, Be Right Back, and other presence indicators.

If an agent views an employee on a real-timemonitor and notes the employee is online, the agent can right-
click the employee and send an instant message.

Table 7 - 12 provides details on the presence indicators that are available when Contact Center Client is used
in conjunction with Lync Client andMitel Enterprise Presence / Chat Integration.
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Table 7 - 12 Lync presence indicator icons

Presence
Icon
(Large)

Presence
Icon
(Small)

Status
Text

Description

Available The contact is online and can participate in con-
versations. Users canmanually set this status,
but the next automatic state change will over-
ride this setting.

Busy The contact is available, but is engaged by
another activity. Busy contacts will not be
routed ACD calls, but may receive non-ACD
calls. Possible activities include the following:

In a Call—the contact is in a phone,
voice, or video conversation.
In a Meeting—theOutlook calendar
shows that the contact has a scheduled
meeting.

Users canmanually set this status.

Do Not Dis-
turb

The contact is engaged by another activity and
is unavailable. Contacts in Do Not Disturb will
neither receive ACD or non-ACD calls. Users
canmanually set this status.

Away /
Inactive

Be Right
Back

Off Work

The contact is likely unavailable. Possible
reasons include the following:

The contact’s computer has been idle for
more than the away time period setting (5
minutes by default).
NOTE:By default, the transition from
Available to Inactive occurs after 5
minutes. Then, after fivemoreminutes,
the status changes to Away if there is still
no activity on the computer.

The contact’s Outlook calendar or Out of
Office Assistant indicates that they are
out of the office.

The contact is temporarily unavailable
NOTE:As soon as activity is detected on
the contact’s computer, Ignite
automatically resets the presence status
to the appropriate state.
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The contact has locked their computer.

The contact has manually set their
presence to Away or Be Right Back.

Users canmanually set this status.
NOTE:When a user manually sets themselves
as Away, they are still available to receive calls,
such as from a transfer.

Offline The contact is not available. Possible reasons
for this include the following:

The contact has manually set their
presence status to Appear Offline.

The contact has not signed into Lync.

The contact has blocked you from seeing
their presence status.

Lync is not running on the contact’s
computer.

Presence
unknown

Lync cannot determine the status of the con-
tact. This status is typically displayed because
the contact’s presence status is unavailable to
Lync, such as for a contact who is part of an
organization that is not a federated partner.

Sending an instant message
On an agent or employeemonitor, you can right-click an agent or employee’s cell and click Send instant
message to send an onlinemessage to the agent or employee. You can also send instant messages using
Microsoft Lync. Using Lync, you can send instant messages to individuals or multiple contacts. After initiating
a conversation, you can invite additional contacts to the conversation.

NOTE:Supervisors send instant messages to contacts or groups of contacts using Contact Center Client.

To send an instant message while viewing agents on an agent, employee, or extensionmonitor
 1. Right-click a cell in an openmonitor and click Send instant message.

The Conversation window displays.
 2. Type amessage.
 3. Click Send.
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To send an instant message to an individual in Lync
 1. Double-click a contact in theContact list in Lync.

The Conversation window displays.
 2. Type amessage in theConversation window.
 3. Press Enter.

To send an instant message tomultiple contacts in Lync
 1. To send an instant message to a contact group, right-click the group's name in theContact list and click

Send an Instant Message.
 2. If you want to select specific contacts from a group, expand the group in theContact list, press Ctrl,

and select the contacts to which you want to send an instant message. Right-click the last contact
selected and click Send an Instant Message.

 3. Type amessage in theConversation window.
 4. Press Enter.

To invite additional contacts to a conversation in Lync
 1. In theConversation window, click thePeople Options icon and select Invite by Name or Phone

Number.
 2. Select the contacts you want to invite to the conversation and click OK.

Alternatively, drag one or more contacts from the Contact list to the Conversation window.

NOTE:
l When you invite people to a conversation, conferencing features become active.
l A group instant messaging conference cannot exceed 100 participants.

Hot desking
When an agent is configured as aMitel hot desking agent, the agent can sit at any extension on the network
and log on to the extension. After the agent is logged on, the agent takes control of the extension. The agent's
Contact Center Client and soft phone real-time profile settings are available. Any previous associations with
the extension are taken out of service. When an agent logs off, the agent disconnects from the extension and
the default settings for the extension are restored automatically.

External hot desk agents
External hot desk agents can work remotely using, for example, a standard PSTN analog telephone or a
cellular telephone. External hot desk agents are similar to regular hot desk agents with additional configuration
available to specify external number information. To access external hot desk agent functionality youmust
configure the following options in the User and Device Configuration form for the 3300 ICP:

l External Hot Desking Enabled:Select “Yes” to enable external hot desk agent functionality.
l External Hot Desking Dialing Prefix: Type the prefix digit(s) required to dial out to the external hot

desk device.
l External Hot Desking Number: Type the telephone number of the external hot desk device. This

number will be used by the telephone system to route ACD calls to the external hot desk agent.

NOTE: The combined length of the external dialing prefix and external number cannot exceed 26 digits.

An agent ID can be associated to only one external dialing number. If an external hot desk agent will usemore
than one external device for handling calls they must be associated to one agent ID for each external dialing
number.
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An external hot desk agent can either log in externally or internally. When they log in internally (locally) the
telephone system recognizes them as a standard hot desk agent. When they log in externally the telephone
system recognizes them as an external hot desk agent.

WARNING: If an external hot desk agent is using a personal phone to handle calls, incoming calls that are not
answered could reach their personal voicemail.

NOTE:
l 3300 ICP releaseMCD 5.0+ is required to access external hot desk agent capabilities.
l External hot desk agent functionality is only supported for use with hot desk agents, not traditional ACD

agents.

The following options are available for external hot desk agent login:
l Log in locally from aMiNET phone: agent displays as a regular hot desk agent
l Log in locally from an analog, cellular, or MiNET phone and connect through a loopback trunk: agent

displays as an external hot desk agent
l Log in externally from an analog or cellular phone: the agent ID is registered as an external pivot device

number and the external number dialing that has been configured in the telephone system is overlaid on
this external pivot device number. The external number is then used by the telephone system to deliver
ACD calls to the external hot desk agent. The agent displays as an external hot desk agent.

NOTE:An external hot desk agent can also log in externally by directly contacting a specific trunk
configured for this purpose. In this case, the agent would not need to log in via Contact Center Client.
For more information, log into Mitel Edocs, open theMitel Communications Director System
Administration Help Tool, and browse to "External Hot Desking - Operation".

WallBoarder
TheWallBoarder application displays real-time performance statistics and text messages on one or more
Spectrum Light Emitting Diode (LED) reader boards (wall signs).

WallBoarder parameters
WallBoarder consists of site(s), sign groups, signs, sign variables, signmessages, and sign plans.

Site
At the Site level, you

l Add sign groups to your site by clicking Add=>Sign group.
l Specify the name of the computer on which theWallBoarder Service is installed on the Edit

WallBoarder Service for tab.
l Enable priority messages on the Priority message tab.
l View communications between the Enterprise Server Service and theWallBoarder Service on the

Database load log tab.
l Verify the serial addresses of your wall signs on theQuery signs tab.
l Add sign variables to your site by clicking Add=>Sign variable.
l Add signmessages to your site by clicking Add=>Signmessage.
l Add sign plans to your site by clicking Add=>Sign plan.
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Edit WallBoarder Service for tab
The Edit WallBoarder Service for tab provides the following function:

l TheWallBoarder Service is installed on the following computer specifies the computer on which the
WallBoarder Service is installed.

Priority message tab
NOTE:

l You create priority messages on the Add signmessage tab.
l Priority messages override all of the other messages.

The Priority message tab provides the following function:
l Enable this priority message for this sign group immediately sends amessage to all of the wall signs in

the sign group immediately, overriding any business hour, or scheduledmessages.

Database load log tab
Under Diagnostics, the Database load log tab records communications between the Enterprise Server
Collector Service and theWallBoarder Service, and indicates if theWallBoarder Service has loaded the sign
plan configured by the Contact Center Management user.

Query signs tab
Under Diagnostics, the Query signs tab lists the wall signs theWallBoarder Service can locate, and
information relating to these signs. It displays the serial addresses of the wall signs. This can come in handy.

For example, you have connected a wall sign to Com port 3, have configured the sign and specified the com
port value inWallBoarder, and have reset the wall sign, but it does not display themessages in the sign plan.
Most likely, the serial address of the sign is not the same as that configured inWallBoarder. TheQuery signs
tab displays the true serial address of the wall sign. You can easily verify the address and amend the address
on the Edit sign tab for the sign.

Sign groups
NOTE:Youmust create at least one sign group in order to register wall sign addresses. You can include all of
the wall signs under one sign group, or create additional sign groups. Sign groups dictate whichmessages are
displayed by particular wall signs.

At the Sign group level, you can
l Edit sign groups on the Edit sign group tab.
l Define the wall sign refresh interval and reset wall signs on the Advanced tab.
l Add signs to your sign groups by clicking Add=>Sign.

Sign addresses distinguish wall signs for messaging purposes. Each wall sign has a unique sign address.
You add one or more signs to a sign group. For example, you could addWall sign 1 to Sign group 1, andWall
signs 2 to 4 to Sign group 2. You associate each sign group with a sign plan. Using sign groups and sign plans
you can display the samemessage on one or more wall signs, or display uniquemessages on all wall signs.
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Edit sign group tab
The Edit sign group tab provides the following functions:

l Name lists the name of the sign group.
l Site is the contact center site whereWallBoarder is installed.

Advanced tab
The Advanced tab provides the following functions:

Reinitialize all of the wall signs every x seconds
The Reinitialize all of the wall signs every x seconds field restarts all of the wall signs in the sign group
(clearing all of the signmemory) at the time interval you specify.

Refresh all of the sign messages every x seconds
The Refresh all of the signmessages every x seconds field resends all of themessages to all of the wall signs
in the sign group at the time interval you specify. If you see questionmarks [???] instead of statistics on a wall
sign, this means the Enterprise Service does not have a value for the variable. There are two reasons why the
Enterprise Service does not have a value for the variable: it is in the process of loading the variable or the
telephone system has not sent any real-time information yet.

Refresh all of the ACD sign variables every x seconds
The Refresh all of the ACD sign variables every x seconds field updates all of the variables on all of the wall
signs in the sign group at the time interval you specify.

Update wall signs in serial for sign messages
The Update wall signs in serial for signmessages check box updates the wall signs in a sign group
individually for signmessages, at the refresh time interval you specify.

Update wall signs in serial for sign variables
The Update wall signs in serial for sign variables check box updates the wall signs in the sign group
individually for sign variables, at the refresh time interval you specify.

Minimum pause time between wall sign updates is x seconds
AfterWallBoarder sends amessage or variable update to a wall sign, theMinimum pause time between wall
sign updates is x seconds field suspends the transmission of subsequent information to the wall sign for x
seconds. Typically you select a value greater than zero only if you have a small Spectrum reader board, such
as the 251C reader board.

Minimum display time for a message is x seconds
AfterWallBoarder sends amessage to a wall sign, theMinimum display time for amessage is x seconds field
displays themessage for aminimum of x seconds. This ensures you can view themessage for a sufficient
amount of time before a subsequent message displays.

Minimum pause time after beep is sent is x seconds
If you select the Beep check box on the Add sign plan tab, the wall sign produces an audible beep prior to
displaying eachmessage. It takes a few seconds for the beep to occur. Therefore, the wall sign is delayed in
receivingmessages by a few seconds.
TheMinimum pause time after beep is sent is x seconds field suspends the transmission of messages to the
wall sign for x seconds, to accommodate the beep.
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Reinitialize all of the wall signs in this sign group
The Reinitialize all of the wall signs in this sign group command restarts all of the wall signs in the sign group
instantly, clearing all of the signmemory.

Apply to all of the sign groups at this site
The Apply to all of the sign groups at this site command applies the configuration values on the Advanced tab
to all of the sign groups at the site.

Signs
At the Sign level, you

l Configure sign information on the Add sign tab.
l Configure sign connectivity information on the Connectivity tab.
l Reset the wall sign and send a test message to the wall sign on the Tools tab.
l Add signs to your sign groups by clicking Add=>Sign.

Diagnostics
Under Diagnostics, the following tabs list information pertaining to wall sign function and are used for trouble
shooting purposes:

l General
l Properties
l Tool tab
l Error reporting
l Current message tabs

Tools tab
Under Diagnostics, the Tools tab displays wall sign settings and provides the following functions:

l Reset sign restarts the wall sign and empties the signmemory.
l Get status displays the latest sign diagnostics.
l Send test message sends amessage to the wall sign to test the connectivity.

Sign messages
At the Signmessage level, you

l Compose, test, and savemessage strings displayed on wall signs on the Add signmessage tab
Message strings indicate to the wall sign how messages are displayed. They are constructed of
l Text
l Queue and queue group performance variables (Variables)
l Display characteristics (Position, Color, Effects, Special, andMiscellaneous)

l Add signmessages to your site by clicking Add.

Add sign tab
The Add sign tab provides the following functions:

Name
The Name field specifies the name of the sign.



Contact Center Solutions User Guide

- 253 -

Sign address
The Sign address field specifies the address of the wall sign. Each wall sign has a unique address. You use a
keypad provided with themaster sign to set the internal addresses of your signs. The addresses distinguish
wall signs for messaging purposes. If you have one wall sign only, its address is 00. If you havemore than
one wall sign, then the address of themaster sign is 01.

NOTE:When you assign serial addresses to your Spectrum wall signs using remote or software spectrum
tools, youmust specify sign addresses greater than 9 as hexadecimal variants. For example, the following
decimals are converted to hexadecimal: 10 = a, 11 = b, 12 = c, 13 = d, 14 = e, 15 = f.

Sign group
The Sign group field specifies the sign group to which the sign belongs.

Connectivity tab
NOTE: The default data bits, parity bit, and stop bits Com port settings for newer Spectrum IP/Serial wall
signs are 8, None, 1. In the past, the default Com port settings were: 7, Even, 2. If you select one set of Com
port values and the wall sign does not display information, try selecting the other set of Com port values, or
refer to the Spectrum documentation to verify the correct default Com port settings.

The Connectivity tab provides the following functions:
l Com port or TCP/IP specifies the sign connectivity. The default value for Com port is 1.
l The default value for Baud rate is 9600.
l The default value for Data bits is 8.
l The default value for Parity bit is None.
l The default value for Stop bits is 1.
l TCP specifies the TCP/IP address of the wall sign.
l DNS specifies the name you assigned the wall sign on the network.
l Port specifies the port number used by the wall sign.
l Signmemory specifies thememory capacity of the sign (typically 32k).
l Reset this wall sign when it does not respond and at midnight resets the wall sign. When the

WallBoarder Service restarts, it queries the wall sign for the information listed on the sign Diagnostics
tabs. If it does not get an answer, it resets the wall sign.

Add sign message tab
The Addmessage tab provides the following functions:

l Name specifies the name of themessage.
l Site is the contact center site whereWallBoarder is installed.
l Test message sends themessage to the wall sign so you can verify it works.

Variables
You associate a queue, queue group, or agent group, and a performance variable with the sign variable on the
Variable tab. You specify display characteristics and color-coded alarm thresholds. When you incorporate a
sign variable, such as Sign Variable 6, in amessage string, the real-time value of the associated performance
variable is displayed.

Position
The Position tab specifies the vertical position of themessage string on the wall sign. If you do not specify the
text position, the wall sign defaults to the fill mode. Themessage enters the wall sign from the upper left
corner and scrolls to fill up to three rows of text. If you specify the text position, do so before you set other
display features.
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Color
The Color tab specifies the color of the text you type in themessage string, and the color of any pre-defined
text and graphics you select on the Special tab. You can specify different colors for each word in the text
string. If you specify text coloring, do so after specifying text positioning, but prior to specifying other display
features. Some Spectrum signs offer more color choices than other Spectrum signs. Please refer to the
Spectrum product brochure for more information.

Effect
The Effects tab specifies how messages move across wall signs. If you do not specify effects, the wall sign
defaults to the Automode option. Automode produces randommessage display formats, such as message
strings that flash or roll to the left.

Special
The Special tab provides display features and illustrations you can add tomessage strings.

Misc
TheMisc (Miscellaneous) tab specifies the speed at whichWallBoarder displays message strings, the size of
message string text, the display time and date, and other features.

Sign variables
At the Sign variable level, you

l Associate a queue or queue group, and a performance variable with the sign variable on the Add sign
variable tab.

l Define and save display characteristics for sign variables on the Advanced tab.
l Add sign variables to your site by clicking Add.

Add sign variable tab
The Add sign variable tab provides the following functions:

l Name specifies the name of the sign variable.
l Site is the contact center site whereWallBoarder is installed.
l Select a device type group specifies the device type (queue or queue group) you will associate with the

sign variable.
l Select a device specifies the device you will associate with the sign variable (for example, Queue

Group 1).
l Select a variable type specifies the performance variable you will associate with the sign variable (for

example, Agents on ACD).

Advanced tab
The Advanced tab provides the following functions:

l Select display options for this variable specifies the number of characters reserved for a performance
variable in themessage string. It centers, left-justifies, or right-justifies the performance variable within
the variable string position.

l Enable variable color based on these thresholds defines color-coded alarms for performance thresholds
for the variable.
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Sign plans
TheWallBoarder Service displays messages in the following order:
 1. Priority messages
 2. Business-hour messages
 3. Scheduledmessages
 4. Sign planmessages
 5. Default sign planmessage

At the Sign plan level, you
l Create a sign plan.
l Associate the sign plan with a sign group.
l Specify up to five statements (conditions) for the sign plan on the Add sign plan tab.
l Specify the hours of operation for your business on the Business hours tab.
l Schedulemessages to be displayed on the Scheduledmessages tab.

When you configure a sign plan, you can configure up to fivemessages for a sign group. The conditions, or
values, of variables dictate whichmessage strings WallBoarder displays, and the priority in which
WallBoarder displays them. If none of the conditions are satisfied, WallBoarder displays the default message
on all of the wall signs. The default message can be amessage congratulating agents, or informing them of an
upcomingmeeting or other need-to-know information.

Add sign plan tab
The Add sign plan tab provides the following functions:

l Name specifies the name of the sign plan.
l Sign group specifies the sign group to which the sign plan applies.
l If check boxes activate conditional messages. You can specify up to five statements (conditions).

Conditions dictate whichmessage strings WallBoarder displays, and the priority in whichWallBoarder
displays them.

l Sign variable specifies the sign variable to display for the current (active) condition.
l Evaluates to specifies the value, above or below which, WallBoarder displays themessage string

associated with the sign variable for the current condition.
l Play message specifies the signmessage to display for the current (active) condition.
l Beep programs the wall sign to produce an audible beep prior to displaying amessage for a satisfied

condition.
l Default message to play if no variables have triggered amessage to play specifies a default message

to display on the wall sign. WallBoarder displays themessage during periods when the defined
conditions (“If” statements) are not satisfied for the sign group. That is, when call center performance
objectives are beingmet.

Business hours tab
The Business hours tab provides the following functions:

l Outside business hours display this message specifies whichmessage is displayed on the wall signs
after business hours.

l Business-hours schedule for this sign plan specifies the hours of the day for the sign plan
l Manage schedule creates and edits business hour schedules.
l Apply this business-hours schedule to all of the sign plans at this site applies the schedule to all of the

sign plans at your contact center site.
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The Scheduledmessages tab provides the following function:
l Play this message during these hours specifies themessage to be displayed and the schedule for

displaying themessage.

NOTE: You create schedules under YourSite=>Schedule.

Connecting Spectrum wall signs
NOTE: For detailed information on how to install Spectrum wall signs, view the Spectrum wall sign
installationmanuals on the Enterprise Server at <drive>:\Program Files\prairieFyre Software
Inc\CCM\Websites\CCMWeb\webforms\help\online_en.

If you havemultiple wall signs, you can daisy chain the wall signs together.Figure 7 - 30 illustrates the
connectivity between the Enterprise Server and themaster sign (Wall sign 1). The Enterprise Server connects
to themaster sign over an RS-232 25-pin cable, an RS-485 converter, and RS-485 RJ-11 cabling. Themaster
sign connects to slave signs over RS-485 cabling. In this setup, one Enterprise Server com port is dedicated
to your wall signs.
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Figure 7 - 30 Setting up Spectrum wall signs

If you do not want to dedicate an Enterprise Server com port to your wall signs (or you simply need another
computer to connect to a wall sign), you can hook up your wall sign(s) to a client computer. You click
Help=>Software downloads/Installations=>Remote Server installation and install a remotemedia server
(data collection point) on a client computer. The computer connects to themaster wall sign over an RS-232
25-pin cable, an RS-485 converter, and RS-485 RJ-11 cabling, as in the proceeding setup. In this setup, one
client computer com port is dedicated to your wall sign(s).

The new Spectrum IP wall signs plug into a network jack on the wall, just like your network printer.

Each wall sign has a unique sign address. You add one or more signs to a sign group. For example, you could
addWall sign 1 to Sign group 1, andWall signs 2 to 4 to Sign group 2. Keep inmind that all of the signs in the
same sign group, display the samemessages. You associate each sign group with a sign plan. Using sign
groups and sign plans, you can display the samemessage on one or more wall signs, or display unique
messages on all of the wall signs.
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Configuring wall signs and wall sign messages
To configure wall signs and wall signs messages
 1. For each site, select the computer on which theWallBoarder Service is installed.
 2. Add sign group(s). (In the tree under Site, click Add=>Sign group.)
 3. Add sign(s) to sign group(s) and send a test message to test the sign connectivity. (In the tree under

Sign group, click Add=>Sign.)
 4. Configure sign variables to use in sign plans. (In the tree under Site, click Add=>Sign variable.)
 5. Configure signmessages to use in sign plans and test themessages. (In the tree under Site, click

Add=>Signmessage.)
 6. Add and configure a sign plan for each sign group. (In the tree under Site, click Add=>Sign plan.)

Selecting the computer on which the WallBoarder Service is installed
To select the computer on which theWallBoarder Service is installed
 1. Click Real time=>WallBoarder.
 2. Expand the Enterprise tree and click the name of your site.
 3. The Edit WallBoarder Service for tab opens.

See Figure 7 - 31.
 4. After The WallBoarder Service is installed on this computer, select the computer on which the

WallBoarder Service is installed.
 5. Click Save.

Figure 7 - 31 Edit WallBoarder Service for prairieFyre Demo tab

Creating sign groups
NOTE: Youmust create at least one sign group in order to register wall sign addresses. You can include all of
the wall signs under one sign group, or create additional sign groups. Keep inmind that all of the signs in the
same sign group, display the samemessages.

Sign addresses distinguish wall signs for messaging purposes. Each wall sign has a unique address. You set
the internal sign addresses using the keypad provided with themaster sign, and register the sign addresses in
WallBoarder on the Sign tab.

Each sign group has one or more signs. For example, you can specify that Sign group 1 provide real-time
displays forWall sign 1, Sign group 2 provide real-time displays forWall signs 2 to 4, and so on. You
associate each sign group with a sign plan. Using sign groups and sign plans, you can display the same
message on one or more wall signs, or display uniquemessages on all of the wall signs.

Sign groups dictate whichmessages are displayed by particular wall signs.
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To add a sign group and specify sign group information
 1. Click Real time=>WallBoarder.
 2. Click the name of your site.

The Edit WallBoarder Service for tab opens.
 3. Click Add=>Sign group.

The Add sign group tab opens.
See Figure 7 - 32.

 4. AfterName, type the sign group name.
 5. AfterSite, select the contact center site whereWallBoarder resides.
 6. Click theAdvanced tab.
 7. AfterReinitialize all wall signs every, select a time interval for restarting all of the wall signs in the

sign group.
 8. AfterRefresh all sign messages every, select a time interval for resending all of themessages to all of

the wall signs in the sign group.
If you see questionmarks [???] instead of statistics on a wall sign, this means the Enterprise Service
does not have a value for the variable. The Enterprise Server does not have a value for the variable
because it is in the process of loading the variable, or the telephone system has not sent any real-time
information yet.

 9. AfterRefresh all ACD sign variables every, select a time interval for updating all of the variables on
all of the wall signs in the sign group.

 10. AfterMinimum pause time between wall sign updates is, select a time interval for pausing between
wall sign updates.

 11. AfterMinimum display time for a message is, select a time interval for displaying a wall sign
message.

 12. AfterMinimum pause time after beep is sent in, select a time interval for pausing after a beep is
sent.

 13. If you want to reinitialize all of the wall signs, click Reinitialize all wall signs in this sign group.
 14. To apply the preceding options to all of the sign groups, click Apply to all sign groups at this site.
 15. Click Save.

Figure 7 - 32 Add sign group tab

Adding signs to sign groups
NOTE: You can add one or more signs to a sign group. Keep inmind that all of the signs in the same sign
group, display the samemessages.

To add signs and specify sign information
 1. Click Real-time=>WallBoarder.
 2. Click a sign group.
 3. Click Add=>Sign.

The Add sign tab opens.
 4. AfterName, type the sign name.
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 5. AfterSign address, select the address for the sign (for example, type 1).
You set the internal sign addresses using the keypad provided with themaster sign, and register the
sign addresses inWallBoarder in the Sign address field.

 6. AfterSign group, select the sign group to which the sign belongs.
 7. Click theConnectivity tab.

NOTE: The default data bits, parity bit and stop bits Com port settings for newer Spectrum IP/Serial
wall signs are 8, None, 1. In the past, the default Com port settings were: 7, Even, 2. If you select one
set of Com port values and the wall sign does display information, try selecting the other set of Com
port values, or refer to the Spectrum documentation to verify the correct default Com port settings.

 8. If you click Com port, accept the default settings for Com port, baud rate, data bits, parity bit, and stop
bits.

 9. If you click TCP/IP, click TCP and specify the TCP/IP address of the wall sign, or click DNS and
specify the name you assigned the wall sign on the network.

 10. AfterPort, specify the port number used by the wall sign.
 11. AfterSignmemory, select thememory for the sign based onmanufacturing specifications.
 12. Optionally select theReset this wall sign when it does not respond and at midnight check box.
 13. Click theDiagnostics tab.
 14. Click the Tools tab.

See Figure 7 - 33.
 15. To restart the wall sign and empty the signmemory, click Reset sign.
 16. To display the latest sign diagnostics, click Get status.
 17. To verify the wall sign setup, type amessage and click Send test message.
 18. Click Add=>Sign and repeat steps 4 to 12 to add additional signs to the sign group.
 19. Click Save.

Figure 7 - 33 Diagnostics tab
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Configuring sign variables
You define and save display characteristics for sign variables (performance variables associated with a
particular queue or queue group) on the Add sign variable tab.

To configure sign variables
 1. Click Real-time=>WallBoarder.
 2. Click +, located beside local site.
 3. Click Sign variables.

The Add sign variable tab opens.
See Figure 7 - 34.

 4. AfterName, type ameaningful name for the sign variable (for example, type Calls waiting - P800).
The namewill display in a list of sign variables on theMessage tab.

 5. AfterSite, select the contact center site whereWallBoarder resides.
 6. AfterSelect a device type, click a device type (for example, click Queue).
 7. AfterSelect a device, select a device (for example, select P800).
 8. AfterSelect a variable type, select a performance variable (for example, select Abandoned).
 9. Click theAdvanced tab.

NOTE: Some performance variables require a display width of eight characters. For example,
WallBoarder displays the Average Speed of Answer Today in hh:mm:ss. If you select a value less than
8 for the width, the at symbol [@] will display on the wall sign in place of the Average Speed of Answer
Today statistic.

 10. AfterSelect display options for this variable, click Left, Center, orRight to left-justify, center, or
right-justify the performance variable within the variable string position, and accept the default value for
the width of displayed characters.

 11. Select theBase variable color on these thresholds check box, and specify performance thresholds
for the variable.
In this example, we selected the calls waiting in queue performance variable and P800 to associate
with the Calls waiting - P800 sign variable.

 12. Click Add and repeat steps 3 to 10 to specify other sign variables for your queues and queue groups.
 13. Click Save.

Figure 7 - 34 Add sign variable tab
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Configuring sign messages
You compose, test, and savemessage strings displayed on wall signs on the Add signmessage tab.
Message strings indicate to the wall sign how messages are displayed. They are constructed of performance
variables, text, display features, and optionally graphics.

Consider themessage strings defined in Figure 7 - 35. WallBoarder displays the first message string on the
top line [PS02-Top Line] of the wall sign. It displays the Long Call Wtg = component of themessage string in
red [C001-Red]. Themessage string flashes [MO03-Flash] across the sign at display speed 2 [MI06-Display
Speed 2]. It is comprised of text you type (Long Call Wtg =) and Sign variable 1 [VA01-Calls], that displays
the real-time value for the longest waiting caller performance variable. The color of the sign variable statistic
changes with the wait time of the longest waiting caller, as per the threshold settings defined on the Variable
tab.

To create signmessages
 1. Click Real-time=>WallBoarder.
 2. Click Sign messages.

See Figure 7 - 35.
 3. AfterName, type themessage name (for example, type Calls Wtg - P800).

The namewill display in a list of signmessages on the Plan tab.
 4. AfterSite, select the contact center site whereWallBoarder resides.

NOTE: If you do not select display attributes, WallBoarder will post themessage using default display
attributes.

 5. Click thePosition, Color, Effect, Special, and/orMisc tabs and double-click display attributes to
select them.

 6. Type amessage (for example, type Calls Wtg 800 = ).
 7. Click theVariables tab and double-click a variable to select it (for example, double-click Calls waiting -

P001).
 8. Click Send test message.

In this example, Calls Wtg P800 = displays on the wall sign followed by the real-time value for the calls
waiting in queue performance variable.

 9. Click Add and repeat steps 3 to 8 to create and test other signmessages.
 10. Click Save.

Figure 7 - 35 Add Sign Message tab
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Creating sign plans
You associate each sign group with a sign plan. Using sign groups and sign plans, you can display the same
message on one or more wall signs, or display uniquemessages on all of the wall signs. All of the signs in a
sign group display the samemessages.

If you have two wall signs (that are not daisy chained together) and you want to display the samemessages
on both signs, you create one sign group, add both signs to it, and associate the sign group with a sign plan.
The serial addresses do not need to be unique in this case, as you are communicating with each sign on a
dedicated connection (for example, one signmay be connected to a comport, and the other sign to the
network using IP).

You dictate themessages displayed by particular wall signs on the Add sign plan tab. You can specify up to
five statements (conditions) using sign groups. Conditions dictate whichmessage strings WallBoarder
displays and the priority in whichWallBoarder displays them. If none of the conditions are satisfied,
WallBoarder displays the default message on all of the wall signs in the sign group. The default message can
be amessage congratulating agents, or amessage informing them of an upcomingmeeting or other need-to-
know information.

Consider the conditions defined in Figure 7 - 36:
l The first condition specifies “If Sign variable 1 (the calls waiting in P800) exceeds 10, play Sign

message 01.”
l The second condition specifies “If Sign variable 2 (the agents logged on to P008) exceeds 45 seconds,

play Signmessage 02.”
l The third condition specifies “If Sign variable 3 (the longest waiting caller in P008) drops below 6, play

Signmessage 03.”

Figure 7 - 36 Add sign plan tab

Creating sign plans for daisy-chained signs
If your wall signs are daisy chained together and you want to display the samemessages on all of the wall
signs, you create one sign group, add your signs to it, and associate the sign group with a sign plan. The wall
signs share the same com port, but have unique serial addresses.

If your wall signs are daisy chained together and you want to display uniquemessages on all of the wall signs,
youmust create one sign group for each sign in the chain, and associate each sign group with a unique sign
plan. The wall signs share the same com port, but have unique serial addresses.
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To create a sign plan
 1. Click Real-time=>WallBoarder.
 2. Click Sign plan.

The Add sign plan tab opens.
See Figure 7 - 37.

 3. AfterName, type the plan name (for example, type Sign plan - P800).
 4. AfterSign group, select the sign group to which you will apply the sign plan.
 5. Select the If check box to define the first conditional message for the sign plan.
 6. UnderSign variable, select a sign variable.
 7. UnderEvaluates to, specify the threshold, above or below which, a signmessage is displayed.
 8. UnderPlay message, select a signmessage.
 9. If you want an audible alarm to accompany themessage, select theBeep check box.
 10. Click theBusiness hours tab.
 11. AfterOutside business hours display the following message, select amessage to be displayed on

the wall signs after business hours.
NOTE:Business-hour messages override scheduledmessages.

 12. AfterBusiness hours schedule for the sign plan, select a schedule that defines the hours of
operation for your business.

 13. If you want to apply the schedule to all of the sign plans at your contact center site, select theApply the
business hours schedule to all of the sign plans at this site check box.

 14. Click Save.

Figure 7 - 37 Add sign plan tab
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Activating priority messages
NOTE:

l You create priority messages on the Add signmessage tab.
l Priority messages override all of the other messages.

To activate a priority message
 1. Click Real-time=>WallBoarder.
 2. Expand the Enterprise tree and click the name of your site.

The Edit WallBoarder Service for tab opens.
 3. Click thePriority message tab.

See Figure 7 - 38.
NOTE:When you enable a priority message, WallBoarder displays themessage on all of the wall signs
until youmanually clear theEnable this priority message check box.

 4. To send a priority message, select the Enable this priority message check box and select a priority
message to display on all of the wall signs at the site.

 5. If you want an audible alarm to accompany the priority message, select theBeep when this priority
message is played check box.

 6. Click Save.

Figure 7 - 38 Priority message tab

Scheduling messages
NOTE:

l You can create schedules under YourSite=>Schedule.
l Business-hour messages override scheduledmessages.

You can schedule specific messages to play according to schedules.

To schedule amessage
 1. Click Real-time=>WallBoarder.
 2. Expand the Enterprise tree and click Sign plan.

The Add sign plan tab opens.
 3. Click theScheduled messages tab.

See Figure 7 - 39.
 4. Select a check box to activate a schedule.
 5. Select thePlay this message check box to activate themessage.
 6. AfterPlay this message, select amessage.

NOTE: When you enable a scheduledmessage, WallBoarder displays themessage on all of the wall
signs in the sign group (associated with the sign plan) until youmanually clear the Play this message
check box.



Troubleshooting real-time issues

- 266 -

 7. After according to this schedule, select a schedule.
 8. Click Save.

Figure 7 - 39 Scheduled messages tab

Troubleshooting real-time issues
The following information pertains to Contact Center Client, Interactive Contact Center, and Enterprise
Presence / Chat Integration.

Interactive Contact Center and resiliency
When the collector is started while the telephone system is in resilient fail-over mode, Interactive Contact
Center device control will not function. If this happens, the DoNot Disturb status of the queue in the Queue
Now monitor will not update.

Enabling Enterprise Presence / Chat Integration
If you want to use Lync as your default instant messaging client and view enhanced presence on real-time
monitors, youmust enable Enterprise Presence / Chat Integration.

To enable Enterprise Presence / Chat Integration
 1. In Contact Center Management, click YourSite=>Enterprise.
 2. In the Enterprise tree, click local site.
 3. AfterChat settings, select theChat enabled check box.
 4. Select theEnable Enterprise Presence and Chat Integration check box.

Ensuring Contact Center Client recognizes Lync users
In some instances, Contact Center Client agent, employee, and extensionmonitors will display an
employee’s instant message presence as Unknown even though the employee is online. The following
solutions address themost common problems in displaying instant message presence on real-timemonitors.

Employee and agent monitors display instant message presence as
Unknown
If your agent or employeemonitors are displaying a user’s instant message presence as Unknown even
though the user is online, this means

l Lync Server does not recognize the user because the user’s email address in YourSite Configuration is
not the same as the SIP address of the user specified on the SIP server, or

l The user is not configured as a contact in Lync.
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To determine the email addresses as entered on the SIP server
 1. On the Lync Server, clickStart=>All Programs=>Administrative Tools=>Lync Server 2010.
 2. In the left pane, expand the tree.
 3. Under Forest=>Domain=>Lync servers and pools, select your server pool.
 4. Right-click Users and select Export list.
 5. Save the list of SIP email addresses to a file.

Tomake the user known to Lync Server
l InYourSite Explorer=>YourSite=>Employee, verify the user’s email address is the same as the

email address of the user specified on the SIP server.i

Extension monitor displays instant message presence as Unknown
If your extensionmonitor is displaying a user’s presence as Unknown even though the user’s extension is
configured in YourSite Configuration, this means

l Lync does not have a user associated with the extension, or
l The user is not configured as a contact in Lync.

Tomake the extension known to Lync Server
 1. On the Lync Server, browse toActive Directory Users and Computers.
 2. In the right pane, right-click the user and select Properties.
 3. On theGeneral tab, after Telephone Number, type the user’s phone extension.
 4. On the Lync tab, afterSIP URI, verify the SIP email address for the user.

To add the user as a contact in Lync
l In Lync, click Contacts=>Add a Contact and add the user’s email address as specified on the SIP

server.



Contact Center Solutions User Guide

- 268 -

Chapter 8

Reports

Understanding reports
Reporter
Scheduled Reports
Report Inbox
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Reports
NOTES:

l Microsoft Excel Viewer is required as aminimum on all client computers to view reports. Microsoft
Excel 2003 or greater is required on the Enterprise Server to generate and view reports. TheMicrosoft
Excel Viewer can be downloaded for free at
http://www.microsoft.com/downloads/en/details.aspx?familyid=1cd6acf9-ce06-4e1c-8dcf-
f33f669dbc3a&displaylang=en.

l As a best practice, we recommend you limit the reports you run to under 65,000 rows of data. If you
need to run reports with more than 65,000 rows of data youmust take the following requirements into
consideration. Reports with more than 65,000 rows can only be viewed inMicrosoft Excel 2007 or
greater. In addition to this, youmust ensure that your Enterprise Server hardwaremeets theminimum
memory requirements. If you are running reports with more than 65,000 rows of data, we recommend
you use Server Configuration 4 as the hardware and software guidelines for the Enterprise Server. For
more information, see theContact Center Solutions and Call Accounting System Engineering Guide.

The Reporter and Scheduled Reports applications provide detailed performance statistics. You use Reporter
to produce on-demand reports, and Scheduled Reports to automate report generation. You can generate
reports for day of week, day of month, week, or 15, 30, or 60-minute intervals, and for over-midnight shifts.
You can create presentation-quality tables and charts in Microsoft Excel or Adobe Acrobat .pdf format.

The prairieFyre Service analyzes the raw telephone system data with respect to the YourSite Explorer
configuration details. The service then writes the statistical data to Structured Query Language (SQL). It is
this statistical data that sources the reports.

Time stamps for data produced in a 5000/Axxess configuration that uses a CT Gateway are based on the
Enterprise Server’s PC clock. If the 5000/Axxess configuration includes Remote Servers, then time stamps
are based on the Remote Server’s PC clock. Time stamps for the 3300 ICP are based on the telephone
system clock.

You can view reports in .pdf and youmust install Excel on the Enterprise Server to view reports. Whether you
want to view reports in .pdf or Excel, youmust set up contacts and contact groups to which you will email
reports.

For a demonstration of reporting and how it enables contact center supervisors andmanagers to readily
pinpoint problem areas andmeasure andmanage contact center performance, click
http://www.youtube.com/watch?v=kmq8jboyR8k.

Understanding reports
To createmeaningful reports youmust understand reporting concepts.

Service Level is the standardmeasurement of customer service because it provides themost accurate
representation of the customers’ experience. An appropriate Service Level objective is one that

l Satisfies callers’ expectations for service
l Keeps abandonment in check (at less than five percent)
l Minimizes expenses andmaximizes revenue

Understanding the following terms will help you define your corporate Service Level objective.

http://www.youtube.com/watch?v=kmq8jboyR8k
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Offered
All of the contacts (calls, emails, SMS messages, chats, faxes) received by the ACD queue, regardless of
how they are handled or routed, are referred to as offered contacts. Offered contacts include ACD handled
contacts, abandoned (long) contacts, and interflowed (long) contacts. ACD requeued contacts, queue
unavailable (path available) contacts, and abandoned (short) contacts are not considered to be offered
contacts. The Erlang C equation uses offered contacts and Average Talk Time data in calculating the agents
required.

Handled
Handled contacts are calls, emails, SMS messages, chats, and faxes answered by live agents. If an agent
answers a call and then forwards it to another agent or supervisor before the Short Handle time threshold, the
call is classified as an ACD Short Handle Call. You define a Short Handle time threshold for queues.

Abandoned
Abandoned calls are calls that do not reach agents because callers hang up. Abandoned chats are chats that
do not reach agents because customers end the chat sessions before agents become available to chat.
Neither emails nor faxes can be abandoned. A call is considered aCall Abandoned (Long) call when the caller
hangs up after the Short Abandon time threshold. If you define a Short Abandon time of 6 seconds, and a
caller hangs up after 7 seconds, the call is considered a Call Abandoned (Long) call. A call is considered aCall
Abandoned (Short) call when the caller hangs up at or before the Short Abandon time threshold.
You define a Short Abandon time threshold for queues.

Interflowed
Interflow is a mechanism that directs a contact (call, email, SMS message, chat, fax) waiting in queue to
another answer point. When a contact has been waiting in queue for longer than the interflow time defined in
the system, the contact is interflowed and the interflow timer starts. If the interflow timer expires, the contact
is re-directed to yet another answer point. The interflow timer runs independently of the overflow timer.

The interflowed statistic represents the number of contacts removed from a queue and sent to another answer
point. Calls Interflowed (Short) calls are calls that interflow before the Short Abandon time threshold. Calls
Interflowed (Long) calls are calls that interflow after theShort Abandon time threshold.

The telephone system Dial Out of Queue feature is a user-initiated interflow feature which removes a call from
queue and sends it to an alternate answer point. A Dial Out of Queue call is considered a Calls Interflowed call
in the reports.

Service Level time
TheService Level time is the time used in calculating the queue service objective, such as 80 percent
(Service Level percent) of contacts answered within 120 seconds (Service Level time). You specify a service
objective for queues.

Service Level Count
Service Level Count = The number of contacts answered within the specified Service Level Time.

Service Level percent
Service Level Percent = Service Level Count ÷ ACD offered
For calls and chats, the Service Level percent is the number of calls/chats which are handled, abandoned, and
interflowed before the Service Level time, compared to the total number of calls/chats handled, abandoned,
and interflowed. The Service Level percent = (Handled + Abandoned (Long) + Interflowed (Long)) within the
Service Level time ÷ Total (Handled + Abandoned (Long) + Interflowed (Long)).
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For emails, SMS messages, and faxes, the Service Level percent is the number of emails/SMS
messages/faxes which are handled and interflowed before the Service Level time, compared to the total
number of emails/faxes handled and interflowed. The Service Level percent = (Handled + Interflowed (Long))
within the Service Level time ÷ Total (Handled + Interflowed (Long)).

In Figure 8 - 1, the Service Level objective is to handle 80 percent of calls in less than 30 seconds. Calls that
wait in queue for 60 seconds are routed to voicemail.

Figure 8 - 1 Service Level percent

Setting the Service Level objective
An appropriate Service Level objective is one that

l Satisfies customers’ expectations for service
l Keeps abandonment in check (at less than five percent)
l Minimizes expenses andmaximizes revenue
l Meets with the approval and support of agents, supervisors, and senior management

Voice queue Service Level objective
You set the queue Service Level objective in YourSite Explorer=>YourSite=>Queues (3300 ICP, 5000, or
Axxess) or YourSite=>Configuration=>Queue=>Queue (SX-200).
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The voice statistics defaults are
l Service Level percent = 80%
l Service Level time = 20 seconds
l Short abandon threshold = 6 seconds
l Short handle threshold = 20 seconds
l Overflow is set at the telephone system switch and there is no default
l Interflow is set at the telephone system switch and there is no default
l Wrap-up time is set at the telephone system switch and we recommend you set it for 1 second

Email queue service level objective
You set the email queue Service Level objective in YourSite=>Configuration, Queue=>Queue.

The email statistics defaults are
l Service Level percent = 80%
l Service Level time = 120minutes
l Short handle threshold = 20minutes

You set the interflow value in YourSite=>Configuration, Queue=>Queue, Multimedia Contact Center Email
routing options tab.

There is no interflow default for email.

The following do not apply to email:
l Overflow
l Wrap-up time
l Abandon

Chat queue service level objective
You set the chat queue Service Level objective in YourSite=>Configuration, Queue=>Queue.

The statistics defaults are
l Service Level percent = 80%
l Service Level time = 120 seconds
l Short abandon threshold = 6 seconds
l Short handle threshold = 20minutes

You set the interflow value in YourSite=>Configuration, Queue=>Queue, Multimedia Contact Center
WebChat routing options tab.

The queue statistic default is
l Interflow = 120 seconds

The following do not apply to chat:
l Overflow
l Wrap-up time
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Fax queue service level objective
You set the fax queue Service Level objective in YourSite=>Configuration, Queue=>Queue.

The statistics defaults are
l Service Level percent = 80%
l Service Level time = 120minutes
l Short handle threshold = 20minutes

You set the interflow value in YourSite=>Configuration, Queue=>Queue, Multimedia Contact Center Fax
routing options tab.

There is no interflow default for email.

The following concepts do not apply to email:
l Overflow
l Wrap-up time
l Abandon

Report types
For a complete description of report types and fields, see theContact Center Solutions Reports Guide.

The Contact Center Management report types include voice, email (includes SMS), chat, fax, multimedia,
Workforce Scheduling, and Intelligent Queue reports.

Administrative reports
Administrative reports consists of the Employee Profile. It provides configuration data and contact information
on each employee.

Voice reports
Voice reports provide detailed information about call performance. Voice reports can be generated on the
following devices: Employee, Agent and Agent Group, Queue andQueue group, Team, Extension, Trunk,
DNIS, and Forecast.

Lifecycle reports
Lifecycle reports provide detailed information on all of the events related to the life of a specific call, from the
moment the call enters the telephone system to call termination. You can generate Lifecycle reports on the
following devices: agent, agent group, queue, queue group, DNIS, DNIS group, extension, extension group,
trunk, trunk group, media server, and site. Lifecycle reports can be filtered by call direction, DNIS, trunk,
queue, duration in queue, agent, Account Code, hold duration, call duration, phone number, and extension. If
you have clustered your enterprise into a single site, you can run a Lifecycle report on site to report on your
entire enterprise. Lifecycle reports also include call notes and links to call recordings. For detailed information
on configuring Lifecycle reports, see theContact Center Management Installation Guide.

NOTE:
l Lifecycle reports containing data for internal transferred ACD calls will not link data properly unless the

Call ID feature on the telephone system is enabled.
l If you have a Network ACD environment with telephone systems in the same time zone, youmust

synchronize telephone system clocks to ensure Lifecycle report accuracy.
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Email reports
Email reports provide detailed information about email or SMS performance, depending on themedia the email
queue is configured to handle. Email reports can be generated on the following devices: Agent, Agent Group,
Queue, andQueueGroup. You can generate these reports if you are licensed for Multimedia Contact Center
Email.

To avoid confusion, when configuring an email queue to handle SMS, we recommend you name the queue
with a unique identifier (for example, Sales SMS Queue). This will also assist with running reports on SMS
statistics, as in this release SMS is handled as email and SMS statistics display in email reports generated on
SMS queues.

NOTE:
l Any email statistics in reports generated on SMS queues pertain to SMS contacts
l Any email statistics in Agent reports pertain to SMS contacts if the agent(s) are handling SMS media.

Chat reports
Chat reports provide detailed information about Chat performance. Chat reports can be generated on the
following devices: Agent, Agent Group, Queue, andQueueGroup. You can generate these reports if you are
licensed for Multimedia Contact Center Chat.

Fax reports
Fax reports provide detailed information about fax performance. Fax reports can be generated on the following
devices: Agent and Agent Group. You can generate these reports if you are licensed for Multimedia Contact
Center Fax.

Multimedia reports
Multimedia reports provide detailed information across media types: Voice, Email/SMS, Chat, and Fax.
Multimedia reports can be generate on the following devices: EmployeeGroup andQueue. You can generate
these reports if you are licensed for Multimedia Contact Center.

Intelligent Queue reports
Intelligent Queue reports provide detailed information about Intelligent Queue performance. Intelligent Queue
reports can be generated on Smart Choice Layers and Smart Choice Ports. You can generate these reports if
you are licensed for Intelligent Queue.

Workforce Scheduling reports
Workforce Scheduling reports provide detailed information about schedules. Schedule reports can be
generated on Agents and Agent Groups. You can generate these reports if you are licensed forWorkforce
Scheduling.

Real-Time Schedule Adherence reports
Real-Time Schedule Adherence reports provide detailed information about schedule adherence. Schedule
adherence can be generated on EmployeeGroups. You can generate these reports if you are licensed for
Intelligent Queue.

Call Accounting reports
Contact Center Management with Call Accounting reports provide detailed information about Agent and
Queue call costing. The remaining Call Accounting and Subscriber Services reports can be found in theCall
Accounting Reports Guide.
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Custom Reports
Custom Reports are a collection of reports developed based on specific customer requests. You can generate
these reports if your Contact Center Management license includes this type of report.

Traffic Analysis Reports
Traffic Analysis Reports provide detailed information about trunk traffic.

Recommended top-five reports
prairieFyre recommends every contact center use the following top-five reports:

Queue Performance by Period
TheQueue Performance by Period report shows traffic level highs and lows and the Service Level you provide
at these times. Generate this report each day and watch for trends in the traffic level, abandon rate, and
Service Level.

Queue Group Performance by Queue
TheQueueGroup Performance by Queue report compares queues and provides information on the
performance of your entire contact center.

Queue Group (Answer, Handle, Abandon) Spectrum by Queue
The spectrum reports provide valuable information on how calls are dispersed in your contact center. You can
configure answer, handle, and abandon thresholds, and describe the percent breakdown by time for

l Calls Answered -Which call waited in queue for the greatest duration before an agent answered? How
quickly aremost calls answered?

l Calls Handled -What was the greatest duration an agent spoke to a caller? How quickly domost
agents complete a call?

l Calls Abandoned -What was the greatest duration a caller waited before hanging up?What was the
average time a caller waited in queue before hanging up?

Agent Group Performance by Period
The Agent Group Performance by Period report enables you to identify trends in agent group performance.

Agent Group Event by Period (hh:mm:ss)
The Agent Group Event by Period (hh:mm:ss) report enables you to compare the performance of agents who
perform similar jobs. This report provides the shift time by agent, and a variety of call counts and peg counts
for phone use.
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Using reports to identify problems
The recommended top-five reports help you identify problems that affect your Service Level objectives. Table
8 - 1 and Table 8 - 2 address frequently asked questions.

What do I
watch for in the
queue reports?

How do I find the source of the problem and resolve it?

A drop in Service Level When does the Service Level drop during the day?
 1. Check the Agent Group Performance by Period report to see the distribution.

How many agents were logged on throughout the day.
 2. Examine agent talk times. Do you have a chatterbox agent?
 3. Use Auditor to re-run events during a time interval to see exactly what each

agent was doing.
 4. Generate a forecast report with your Service Level goals to determine the

number of agents required by period for the day. Compare the forecast
statistics to the AverageManned Agent statistic in the Agent Group
Performance by Period report. Have you scheduled enough agents to meet
your Service Level objective?

Why are some queues not meeting their Service Level goals while others are?
l Check the Agent Group Performance by Queue report. Are some agent

groups overworked?

High abandon callers Why did the callers hang up?
 1. Check the Average Delay to Abandon statistic. Did the callers hang up

because they were impatient? Did callers wait a long time in queue?Were
agent talk times excessive during this time? If so, why?

 2. In DataMining=>Auditor, re-run the interval to see exactly what each agent
was doing.

 3. Generate the Queue ANI Abandon report and then call back the customers to
determine why they abandoned their calls.

A high requeue count
(because it decreases
the Average Speed of
Answer time and the
Service Level)

Are agents forgetting to set themselves as Unavailable on their telephone sets
before they leave their desks?

l Check the Agent Group Performance by Period report to see which agents
are experiencing requeues. Remind agents to use the Unavailable option.

Table 8 - 1 Solving problems with queue reports
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What do I
watch for in
the agent
reports?

How do I find the source of the problem and resolve it?

Extremely high or low
performance statistics

Do some agents perform 20-30% worse than other agents?
 1. Silent monitor agents periodically to ensure they are properly trained to handle

callers' needs, and are not chatting unnecessarily.
 2. Check Outbound or Non-ACD statistics for peg counts and times. Generate an

Agent Inbound or Outbound Trace report to see a list of all calls. Are agents
spending toomuch time on personal calls?

Do some agents perform 20-30% better than other agents?
 1. High ACD/Non-ACD/Outbound call counts is not a problem if agents are

maintaining high Service Levels. Silently monitor agents periodically to
ensure they are providing a high quality of service, but not rushing callers.

 2. Check the ACD Call Count <20 seconds statistic in the Agent Event by Period
report. Not many voice transactions can occur in less than 20 seconds. This
could indicate that agents are “padding” their ACD handle statistics by
prematurely terminating calls.

High Unavailable
statistics

Are agents accumulating Unavailable time andMake Busy peg counts?
 1. Check the Agent Event by Period (hh:mm:ss) report to evaluate individual

statistics. Determine how muchMake Busy and DoNot Disturb (DND) time
agents are logging. Be sure agents are adhering to your contact center
policies regarding when to useMake Busy and DoNot Disturb. Check if your
agents are using Unavailable instead of logging out.

 2. For agents who have highMake Busy peg counts, run the Auditor application
with an Agent by Timemonitor for the agent group. Be sure agents are not
usingMake Busy to avoid being the longest idle agent or to avoid being sent
the next ACD call.

 3. Implement Make Busy with Reason functionality. Assign reasons with which
agents go intoMake Busy. Track Make Busy use by generating the Agent
Performance by Make Busy Reason Code report.

Table 8 - 2 Solving problems with agent reports

Reporter
Using the Reporter application, you can generate on-demand voice reports, email/SMS reports, chat reports,
fax reports, multimedia reports, Workforce Scheduling scheduling reports, and Intelligent Queue reports. You
can restrict access to any or all of the reports with advanced security roles using report lists. See "Security
roles" on page 177.

SMS reports are handled as email reports. To differentiate SMS contacts from email contacts in reports, we
recommend you configure a queue to handle only SMS contacts and run email reports on that queue only.
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NOTE:
l Any email statistics in reports run on SMS only queues pertain to SMS contacts
l Any email statistics in Agent reports pertain to SMS contacts if the agent(s) are handling SMS

contacts.

Reporter options
The complete list of Reporter options follows.

l Report type—specifies the report name.
l Start date and End date—specify the range of dates used in the report. You can pick any calendar

date as the start date and any date later in the calendar year as the end date.
l Start hour and End hour—specify the hours of the day included in the report.
l Days to include—specifies the days of the week to include in the report.
l Report mode—specifies the report period: 15, 30, or 60minutes.
l Email the report to — emails the report spreadsheet and associated graph to the email address

selected in the email to list. You add contacts and contact groups to the email to list under theMy
options menu.

l Print the report check box— prints the report spreadsheet.
l Include the charts when printing—prints the report spreadsheet and the associated graph.

Setting up contacts and contact groups
Before you generate a report, if you want to email that report, youmust set up

l My email contacts, which includes personal email addresses
l My email contact groups, which includes mailing lists comprised of global contacts andMy email

contacts

Setting up email contacts for emailing reports
To set up groups for emailing reports
 1. Click My options=>My contacts=>My email contacts.

TheMy email contacts window opens.
 2. Click Add.

The Add contact window opens.
 3. Type the first name, last name, and email address of the person to whom you will email reports.
 4. Click Save.

Setting up email contact groups for emailing reports
If you intend to email the report to more than one recipient youmust add the recipients to amailing list and
then associate the recipients with a group.

To set up groups for emailing reports
 1. Click My options=>My contacts=>My email contact groups.

TheMy email contacts window opens.
 2. Click Add.

The Add contact window opens.
 3. Type the name and description of the email group to which you will email reports.
 4. Click Save.

The new email contact group opens on theMy email contact groups window.
 5. Across from the record of the contact group, click Members.
 6. UnderAvailable contacts, select the check boxes of the contacts you want to add to the group.
 7. Click Add>>.
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Generating on-demand reports
NOTES:

l You can generate on-demand reports on licensed employees' extensions only. The number of
employees' extensions you license in YourSite Configuration Explorer must be consistent with your
software license.

l Workforce Scheduling reports are generated differently from Contact Center Management reports. See
"GeneratingWorkforce Scheduling reports" on page 279.

Generating Workforce Scheduling reports
The following steps detail how to generate a Schedule by Employee by TimeOff by Day of Week report. All
otherWorkforce Scheduling reports are generated by following a similar procedure.

NOTE:Some report features may be available or unavailable depending on the report type you want to
generate. For example, the Interval feature is unavailable (and will appear greyed out) for the Schedule by
Employee by TimeOff by Day of Week report.

To generate aWorkforce Scheduling report
 1. Click Reporter=>Workforce Scheduling=>Schedules.

The Basic tab opens.
See Figure 8 - 2.

Figure 8 - 2 Workforce Scheduling Basic tab

 2. AfterReport type, select theSchedule by Employee by Time Off by Day of Week report.
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 3. AfterDevice type, select one of the following:
l Employee— only the employees selected will appear in the report
l Supervisor— only the employees associated with the selected supervisor will appear in the

report
l Employee group— only the employees who aremembers of the selected employee group will

appear in the report
l Schedule— only the employees associated with the selected schedule will appear in the report

 4. Select one or more devices from the table.
Hold down the <Shift> key or <Ctrl> key to select more than one device.
NOTE: If you want one report that spans two days (for example, from December 3 at 9 P.M. to
December 4 at 5 A.M.), thenmake the Start date and the End date the date the shift begins (December
3). If youmake the Start date the date the shift begins (December 3) and the End date the date the shift
ends (December 4), you will generate a report that spans three days (December 3 from 9 P.M. to
December 5, 5 A.M.). The time span for each shift cannot exceed 24 hours.

 5. AfterStart date andEnd date, specify the start and end dates for the report.
 6. Click the Filter tab (if available for the report type selected). Otherwise skip to step 8.
 7. Specify the filtering options to include in the report.
 8. Click theAdvanced tab.
 9. AfterReport output language, select the language used in the report output.
 10. AfterRender type, specify how you will view reports, either in Excel or PDF format.
 11. If you want to email the report, select theEmail the report to check box and specify to whom you will

email the report:
l A contact group— select the this contact group check box, and select a group
l One contact only — select the this contact check box, and select a contact
l A contact that is not listed— select the this email address check box, and type the email

address
You add contacts and contact groups to the Email to list under My options=>My contacts.

 12. If you want to print the report spreadsheet, select thePrint the report check box.
 13. Click Submit.

The Report submitted screen opens.
 14. Click View Report Inbox.

The Report Inbox window opens, listing all created reports.
 15. Click View to open a report.

The report opens in the format you specified in step 10.

Generating reports
NOTE: The following steps detail how to generate a Voice Agent Group Performance by Period report.

To generate a report
 1. Click Reporter=>Voice=>Agent reports.

The Basic tab opens. If you want to run an Administrative report, then you select
Reporter=>Administrative=>Employee reports.
See Figure 8 - 3.

 2. AfterReport type, select theAgent Group Performance by Period report.
 3. AfterAgent group, click one or more agent group.

Hold down the <Shift> key or <Ctrl> key to select more than one agent group.
NOTE: If you want one report that spans two days (for example, from December 3 at 9 P.M. to
December 4 at 5 A.M.), thenmake the Start date and the End date the date the shift begins (December
3). If youmake the Start date the date the shift begins (December 3) and the End date the date the shift
ends (December 4), you will generate a report that spans three days (December 3 from 9 P.M. to
December 5, 5 A.M.). The time span for each shift cannot exceed 24 hours.
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 4. AfterStart date andEnd date, specify the start and end dates for the report.
 5. AfterStart hour andEnd hour, specify the start and end hours for the report.
 6. After Interval, specify the time interval in which the statistics will display in the report.
 7. If your contact center does not operate 24 hour a day, afterReport mode, click Default.
 8. If you want to run a report over midnight, click Over midnight.

TheOver midnight report mode is most appropriate for 24-hour contact centers.
 9. AfterDays to include, select the days of the week to include in the report.
 10. Click the Filter tab.

NOTE: The Filter tab is available for Forecast, Call Accounting, Lifecycle, Workforce Scheduling, and
Make Busy / DND Code reports only. For all other report types, skip to step 12.

 11. Specify the filtering options to include in the report.
 12. Click the Advanced tab.
 13. If you want to create a separate report for each day in the date range you selected, select theCreate

one report for each day in the selected date range check box.
 14. AfterReport output language, select the language used in the report output.:
 15. AfterRender type, specify how you will view reports, either in Excel or .pdf format.

This option is available for Call Accounting, Lifecycle, Workforce Scheduling, and Flexible Reporting
reports only.

 16. If you want to email the report, select theEmail to check box and specify to whom you will email the
report:

l A contact group, select the this contact group check box, and select a group
l One contact only, select the this contact check box, and select a contact
l A contact that is not listed, select the this email address check box, and type the email

address
You add contacts and contact groups to the Email to list under My options=>My contacts.

 17. If you want to print the report spreadsheet, select thePrint the report check box.
 18. If you want to print the report chart, select the Include charts when printing check box.
 19. Click Submit.

The Report submitted screen opens.
 20. Click View Report Inbox.

The Report Inbox window opens, listing all created reports.
 21. Click View to open a report.

The report opens in the format you specified.

Figure 8 - 3 Reporter: Basic tab
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Emailing reports
To email a report
 1. After selecting a report to email, click the Advanced tab.
 2. AfterReport output language, select the language of the report from the list.
 3. If you want to email the report spreadsheet, underExcel distribution, select either the this contact

group or this contact check box.
 4. Or, if you want to email to a specific address, select the this email address check box and type the

email address.
 5. Click Submit.

The Report submitted screen opens.
 6. Click View report inbox.
 7. AfterComplete, click View.

Printing reports
To print a report
 1. After selecting a report to print, click the Advanced tab.
 2. AfterReport output language, select the language of the report from the list.
 3. If you want to print the report spreadsheet, underExcel distribution, select thePrint the report check

box.
 4. Click Submit.

The Report submitted screen opens.
 5. Click View report inbox.
 6. AfterComplete, click View.

Scheduled Reports
You use Scheduled Reports to automate the generation of voice, email/SMS, chat, fax, multimedia,
Workforce Scheduling, and Intelligent Queue reports. You can restrict user access to any or all of the reports
with advanced security roles. See "Creating and applying security roles" on page 178.

SMS reports are handled as email reports. To differentiate SMS contacts from email contacts in reports, we
recommend you configure a queue to handle only SMS contacts and run email reports on that queue only.

NOTE:
l Any email statistics in reports run on SMS only queues pertain to SMS contacts
l Any email statistics in Agent reports pertain to SMS contacts if the agent(s) are handling SMS

contacts.

Scheduled reports options
To create a scheduled report youmust complete the following options on the properties and distribution tabs.

l Schedule name is a user defined name to describe the contents of the schedule.
l Schedule will run specifies how often the schedule will be generated.
l At defines when the scheduled report will be generated.
l Reports time span defines the dates of report activity to appear in the report.
l Output language specifies the language used in the report tables and charts.
l Email the report to defines the email contact group to which the report is sent.
l Print the report indicates the scheduled report will be printed every time it is generated.
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Generating scheduled reports
NOTE:

l Ensure Contact Center Client is running before you generate a report or execute a report schedule,
otherwise the report or the schedule will fail.

l You can generate reports on licensed employees only. The number of employees you license in
YourSite Configurationmust be consistent with your software license.

To generate a scheduled report, youmust follow these steps:
 1. Create a report schedule.
 2. Add reports to the schedule.

Creating report schedules
NOTE: If you select printing andmailing options, Reporting Service prints and emails all of the reports
included in the schedule on the date the system generates the reports.

You can create schedules for Contact Center Management Reports, Contact Center Management Individual
Reports, andWorkforce Scheduling Schedules.

Using Contact Center Management Reports schedules, you can
l Generate reports on all contact center devices.
l Distribute reports to yourself and to a contact, a contact group, or a specific email address.

Using Contact Center Management User reports schedules, you can
l Generate reports on agents and employees.
l Distribute reports automatically to yourself and to the individuals within the agent groups, employee

groups, and/or teams you select.

UsingWorkforce Scheduling Schedules, you can
l Generate reports on employee schedules.
l Distribute agent/employee report schedules to yourself and to individual employees associated with the

schedules you select.

Creating Contact Center Management Report schedules
To create a schedule for Contact Center Management reports
 1. Click Reporter=>Scheduled Reports.

The Contact Center Management Report schedules tab opens.
 2. Click Next>>.

See Figure 8 - 4.
 3. AfterSchedule name, type a schedule name.
 4. AfterSchedule will run, select the schedule frequency, for example, every day, every Wednesday, or

the start of month.
When you select the day, all of the reports associated with the schedule will be generated that day,
every week.
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 5. After at, click the time of day the schedule will be activated.
For example, if you select Wednesday at 7:00 A.M., all of the reports associated with the schedule will
be generated every Wednesday at 7:00 A.M.
NOTE:Reports are based on the data in the SQL database. We recommend you schedule your reports
for after the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure the reports are based on
the entire day’s raw telephone system data.

 6. AfterReports time span, select a time span.
If you select Year to date, the report output includes all of the days from January 1 to the present date. If
you select From given start date to current date you will produce reports for your fiscal year.

 7. Click theDistribution tab.
 8. If you want to email the report to a contact group, underExcel distribution, select theEmail the report

to check box, select the this contact group check box, and then select a group.
NOTE:You add contacts and contact groups to the email to list under My options=>My contacts.

 9. If you want to email the report to one contact only, select theEmail the report to check box, select the
this contact check box, and then select a contact.

 10. If you want to email the report to a contact that is not listed, select theEmail the report to check box,
select the this email address check box, and then type an email address.
NOTE:You add contacts and contact groups to the email list underMy options=>My contacts.

 11. If you want to print the report spreadsheet, underExcel distribution, select thePrint the report check
box.

 12. If you also want to print the report graphs, select the Include charts when printing check box.
 13. Click Save.
 14. Add the reports you want to generate using the schedule you just created.

See "Adding Contact Center Management reports to schedules" on page 286.

Figure 8 - 4 Scheduled Reports: Properties tab

Creating Contact Center Management User report schedules
To create a schedule to automatically email agents/employees their reports
 1. Click Reporter=>Scheduled Reports.
 2. Click theContact Center Management User report schedules tab.
 3. Click Next>>.

The Properties tab opens.
 4. AfterSchedule name, type a schedule name.
 5. AfterSchedule will run, select the schedule frequency, for example, every day, every Wednesday, or

the start of month.
When you select the day, all of the reports associated with the schedule will be generated that day,
every week.
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 6. After at, click the time of day the schedule will be activated.
For example, if you select Wednesday at 7:00 A.M., all of the reports associated with the schedule will
be generated every Wednesday at 7:00 A.M.
NOTE:Reports are based on the data in the SQL database. We recommend you schedule your reports
for after the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure the reports are based on
the entire day’s raw telephone system data.

 7. AfterReports time span, select a time span.
If you select Year to date, the report output includes all of the days from January 1 to the present date. If
you select From given start date to current date you will produce reports for your fiscal year.

 8. Click theDistribution tab.
You can email reports to members of agent groups, employee groups, and teams.

 9. Click the type of group(s) to which you want to email agent and employee reports.
 10. Within each type of group, select the check boxes of the groups to which you will email reports.
 11. Click Save.
 12. Add reports you want to automatically distribute to the agent group(s), employee group(s) and teams

you selected.
See "Adding agent and employee reports to Contact Center Management User report schedules" on
page 286.

Creating Workforce Scheduling report schedules
To create a schedule to automatically email agents/employees their report schedules
 1. Click Reporter=>Scheduled Reports.
 2. Click theWorkforce Scheduling report schedules tab.
 3. Click Next>>.

The Properties tab opens.
 4. AfterSchedule name, type a schedule name.
 5. AfterSchedule will run, select the schedule frequency, for example, every day, every Wednesday, or

the start of month.
When you select the day, all of the reports associated with this schedule will be generated that day,
every week.

 6. After at, click the time of day the schedule will be activated.
For example, if you select Wednesday at 7:00 A.M., all of the reports associated with this schedule will
be generated every Wednesday at 7:00 A.M.
NOTE:Reports are based on the data in the SQL database. We recommend you schedule your reports
for after the nightly maintenance routine runs, that is, after 2:00 A.M., to ensure the reports are based on
the entire day’s raw telephone system data.

 7. AfterReports time span, select a time span.
If you select Year to date, the report output includes all of the days from January 1 to the present date. If
you select From given start date to current date you will produce reports for your fiscal year.

 8. Click theDistribution tab.
 9. Select the check boxes of the schedules you want to email to employees.
 10. Click Save.
 11. Add reports.

See "Adding work schedules toWorkforce Scheduling Schedules" on page 286.
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Adding Contact Center Management reports to schedules
NOTE: Before you can add reports to schedules, youmust create and save the schedules.

To add a report to a Contact Center Management report schedule
 1. On theManage schedulewindow, click Add report.
 2. Select a report category, for exampleQueue reports.
 3. AfterReport type, select a report to add to the schedule.
 4. AfterQueue, select the queue(s) for which you will generate reports.
 5. AfterDays to include, select the days of the week to include in the report (for example, if you select a

date range of September 1 to September 30, and select Wed and Friday as the days to include, you will
produce a report for theWednesdays and Fridays that fall between September 1 and September 30).

 6. AfterStart hour andEnd hour, select a start hour and end hour for the report.
 7. If you are generating an event by period report, after Interval, select the time interval for reporting.

NOTE: If you want to generate a report that spans two days (for example, from December 3 at 9 P.M. to
December 4 at 5 A.M.), then select December 3 for the Start date and the End date. The time span for
each shift cannot exceed 24 hours.

 8. AfterReport mode, select DefaultorOver midnight.
 9. Click theAdvanced tab.
 10. AfterReport Output language, select a language.
 11. Click Submit.

Adding agent and employee reports to Contact Center Management User
report schedules
To add agent and employee reports to a Contact Center Management User reports schedule
 1. On theManage schedule window, click Add report.
 2. Select a report category, for example agent reports.
 3. UnderReport type, select the report you want to add to the schedule.
 4. AfterStart hour andEnd hour, select a start hour and end hour for the report.
 5. If you are generating an event by period report, after Interval, select the time interval for reporting.
 6. AfterReport mode, select eitherDefault orOver midnight. .
 7. AfterDays to include, select the days of the week to include in the report (for example, if you select a

date range of September 1 to 30, and select Wednesday and Friday as the days to include, you will
produce a report for theWednesdays and Fridays that fall between September 1 and September 30).

 8. Click theAdvanced tab.
 9. AfterReport Output language, select a language.
 10. Click Submit.

Adding work schedules to Workforce Scheduling Schedules
To add work schedules to aWorkforce Scheduling Schedule
 1. On theManage schedule window, click Add report.
 2. ClickWorkforce Scheduling=>Workforce Scheduling Schedule reports.
 3. UnderReport type, select the work schedule you want to add to the schedule.
 4. Click theAdvanced tab.
 5. AfterReport Output language, select a language.
 6. Click Submit.
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Generating scheduled reports immediately
If you want to generate your scheduled reports at a specific time (other than immediately), you specify the
date and time they will be generated when you create the schedule. See "Creating report schedules" on page
283.

To generate scheduled reports immediately
 1. Click Reporter=>Scheduled Reports.
 2. AfterSelect a schedule, select the schedule you want to generate.
 3. Click Execute schedule now.

The Execute schedule now window opens.
 4. In theStart date and End date calendars, select start and end dates for the report.
 5. Click Submit.

The reports associated with the schedule are generated immediately and placed in your Report Inbox.

Report Inbox
The Report Inbox application displays the on-demand, scheduled, and forecast reports generated under your
user name over the past 30 days. Inbox manager deletes reports from your inbox by date range.

NOTE:
l In Report Inbox, if the report status is Pending for an extended period of time, start Client Component

Pack Manager and confirm the Enterprise Server IP address and your user name and password are
correct.

l In Report Inbox, if Data Limit Exceeded opens, re-generate the report using a shorter time span.

Report Inbox includes
l Today's reports displays all of the reports generated today under your user name.
l Yesterday's reports displays all of the reports generated yesterday under your user name.
l All of your reports displays all of the reports generated under your user name over the last 30 days.
l Inbox Manager deletes reports from your inbox by date range.

Reporter Inbox options
Report Inbox has the following options.

l Report type lists the report name.
l Media server defines themedia server used in reporting.
l Reporting specifies the reporting number of the device or device group as configured on the telephone

system.
l Name is the name of the device or device group.
l Request date is the date and time the report was generated.
l Status field confirms if your report is ready. WhenComplete appears in the status field the report is

waiting in your Report inbox. WhenPending appears, the report is not ready. No datameans no records
are available for the parameters you specified. Failedmeans the report did not generate. If a report fails,
the Reporting Service logs errors in the NT Event log.

l View displays reports generated inMicrosoft Excel.
l Delete deletes reports from your report inbox.
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Viewing reports
To view report details
 1. Click View Report Inbox (upon submitting a report) or click Report Inbox=>Today’s reports.
 2. Select theAutomatically refresh this page every 10 seconds check box to automatically update the

Status column.
The Status column indicates if your reports are ready:

l Complete: The the report is waiting in your report inbox.
l Pending: The report is not ready.
l No data: No no records were available for the parameters you specified.
l Data limit exceeded: The time span selected was too great. Select a shorter time span and re-

generate the report.
l Failed: The the report did not generate. If a report fails, Inbox Manager logs errors in the event

log. Clicking Re-submit regenerates the report.
 3. Click View to view the report spreadsheet and chart.

Viewing call recordings
If you useOAISYS or dvsAnalytics Encore call recording integration, you can access call recordings from
Lifecycle reports. Hyperlinks to call recordings are located after the Full Name column of call segments in
Lifecycle reports. (See Figure 8 - 5.)

NOTE:
l TheOAISYS Tracer or dvsAnalytics Encore supports the use of non-administrative user accounts to

access call recordings. We recommend you create one non-administrative user account on the Tracer
system and provide the log in credentials to all employees who require access to call recordings.

l When you first access the OAISYS system from the link provided in Lifecycle reports, you are
presented with a log in screen. Youmust enter a valid set of credentials and ensure that the "Auto
Login" check box is selected. This will ensure you provide your credentials the first time you access a
call recording only. Close Internet Explorer and click the link in the Lifecycle report again to access the
call recording.

To view a call recording
 1. Run a Lifecycle report that contains call recordings.

See "Generating reports" on page 280.
 2. Click View Report Inbox (upon submitting a report) or click Report Inbox=>Today’s reports.
 3. After the report is complete, click View to view the Lifecycle report.
 4. Click a call recording hyperlink.

See Figure 8 - 5.
If you are using OAISYS Tracer, youmust provide the OAISYS Tracer system credentials, select Auto
Login, close Internet Explorer, and click the hyperlink to the call recording again before you can view the
call recording.

 5. Click Play.
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Figure 8 - 5 Lifecycle report call recording hyperlink

Editing reports in Excel
You can graph specific data by highlighting one or more columns of data in the Excel spreadsheet and using
the Excel Chart Wizard. For more information, seeMicrosoft Excel Help.

Deleting reports
Maintenance Service deletes any reports that are 30 days or older from your report inbox. Youmust save any
reports you want to retain beyond 30 days to your hard drive or network directory.

Report Writer uses the following criteria to determine a report’s age. For on-demand reports, the request date
governs the report’s age. For scheduled reports, the date the system generates the report governs the report’s
age. Inbox manager does not delete reports you schedule to generate in the future.

To delete all of the reports submitted on a given date
 1. Click Report Inbox=>Inbox manager.
 2. Select fixed dates or a date range for deleting reports.
 3. Select the status type(s).
 4. Click Delete.

The Inbox manager deletes all of the reports submitted on the dates you specified.

Configuring user printer settings
You can configure reports to print on either a network or a local printer, for each employee.

To configure user printer settings
 1. In YourSite Explorer, click Employees.
 2. Select the employee for which you want to configure user printer settings.
 3. UnderReport Distribution, specify the path of the network printer and select print and email options.

Youmust configure the network printer as the default printer on the Enterprise Server. The printer name
is case sensitive.

Troubleshooting reporting issues
Common reporting troubleshooting issues are described below.
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Troubleshooting missing data
NOTE:You can run reports on licensed employees only.

If you run a report and notice that the data for a device is missing from the report output, verify the device is
programmed in the telephone system and in the YourSite database. If you determine the device is missing
from the database, add it to the database and use the Summarize Data command (in theManagement
Console application) to update the prairieFyre Service and the SQL database with the complete telephone
system data stored on the local hard drive. You can then produce reports on the device.

To summarize data
 1. OpenContact Center Client.
 2. If prompted, type your user name and password.
 3. Click Log on.

The Contact Center Client window opens.
 4. On themain toolbar, click Management.
 5. Click Maintenance.
 6. Click Summarize data.
 7. Follow the steps in the Summarize DataWizard to summarize the data.

Configuring reports to exclude Junk Mail from completed email
statistics
Using the Registry Editor on the Enterprise Server, you can configuremultimedia reports to exclude Junk Mail
from the completed email statistics. If you exclude Junk Mail from completed email statistics, the following
statistics will be affected:

l Completed count
l Completed total duration
l Hold count
l Hold total duration
l Short handled count

To exclude Junk Mail from completed email statistics
 1. InWindows, open theRun command, type regedit, and click OK.

The Registry Editor opens.
 2. Expand the tree toHKEY_LOCAL_MACHINE\Software\prairieFyre Software Inc\CCM.
 3. Right-click Common and select New=>String Value.
 4. TypeSubtractJunkEmailStatsFromCompletedStats and click Enter.
 5. Right-click theSubtractJunkEmailStatsFromCompiledStats string and selectModify.

The Edit String window opens.
 6. UnderValue data, type 1.
 7. Click OK.

Troubleshooting Reporting Service
Why is Reporting Service not emailing or printingmy reports?

l Ensure the SMTP Mail settings are correctly configured.
l Ensure the printer settings are correctly configured.
l View the log file for Reporting Service to find out why reports are not being printed/emailed the way you

expect in the installation/Log file.
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Chapter 9

Forecasting

Forecasting terms
Forecasting tool
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Forecasting
Forecasting involves taking historical data generated by your telephone system and using it to predict future
traffic volumes and patterns. Forecasting is the basis for estimating required resources, such as agents,
trunks, and workstations. You take a year or more of ACD queue traffic data, examine trends in Call Load
patterns and determine the ACD Handling Times of the calls. After you run a forecast, you examine the data
andmake adjustments based on current contact center conditions. You can tweak the forecast by adding or
reducing calls, based on your intuition, and information gathered by yourself and others. See "Step #3
Forecast the Call Load" on page 23 for more information on forecast concepts.

For a demonstration of how forecasting can help contact centers make informed scheduling decisions, click
http://www.youtube.com/watch?v=IKwl6CEwQxQ.

Forecasting terms
Conducting a forecast involves accurately estimating Time to Handle, Wrap Up Time, and ACD Calls Offered
values. The following terms are used in forecasting resource requirements:

l Service Level percent
See "Understanding reports" on page 269.

l Service Level time
See "Understanding reports" on page 269.

l Wrap Up time
WrapUp Time is the time an agent spends completing transactions associated with a call after the
agent hangs up. TheWrap Up Time is a standardized period. If an agent requires additional time to
complete paperwork or online transactions, the agent can leave the ACD queue temporarily for this
purpose.

l Agent Efficiency percent
Agent Efficiency percent is the percentage of time agents spend on ACD calls relative to the time
agents are scheduled to work. Agent efficiency is calculated using a straight linear relationship. For
example, 50% agent efficiency means that twomore agents are required to handle the forecasted
workload. An Agent efficiency percentage of 100 is unrealistic. Agents routinely take breaks, perform
other non-ACD duties, make outgoing calls, and place themselves in Make Busy.

l Average Talk time
Average Talk Time is the average time agents spend talking to callers.

l Calls Offered
You can predict the agent requirement for your Service Level percent and Service Level time targets by
applying the Erlang C equation to the estimated Call Load and average ACD Handling Time.

l Manned Agents
Manned Agents is the average number of agents who were logged on for the interval of time being
forecasted.

l Time to Handle
Time to Handle is the average time calls wait in queue before agents handle them.

http://www.youtube.com/watch?v=IKwl6CEwQxQ
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l ACD Handling time
ACD Handling time is the talk time plus the hold time. If an agent calls a supervisor in search of more
information (while the caller is on hold) and/or transfers or conferences the call, the system adds these
times to the ACD Handling Time value.
For example, an agent speaks to a caller for twominutes and then puts the caller on hold for three
minutes and tries to solve the problem. This might include a call to the supervisor. The agent then
initiates a conference call with the caller and a third party and they speak for threeminutes and resolve
the issue. Therefore, the ACD Handling Time for the agent is 2 + 3 + 3 = 8minutes.

l Call Load
The term Call Load is to the combined effect of the number of calls received by the ACD queue and
their duration, or the calls offered x (average ACD Handling Time + averageWrap Up Time).

Forecasting tool
You use the Forecasting tool to create forecasts based on historical contact center traffic volumes. You can
then perform "what-if" scenarios, and optimize the balance between the agents scheduled and your Service
Level objectives.

The Forecasting tool is accessed via Contact Center Client. In order to access the Forecasting tool, your
security role must have the "May manage Forecasting" option enabled.

To access the Forecasting tool
 1. Click Tools in the Contact Center Client ribbon.
 2. In theData Mining column, click Forecasting to open the Forecasting tool.

The Forecasting window opens.
See Figure 9 - 1.

Figure 9 - 1 Forecasting window
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To forecast resource requirements you
 1. Load historical data.
 2. Modify historical data if required.
 3. Perform a forecast.
 4. Print the forecast.

Loading historical data
When you load historical data, you include data over a historical period that best represents the call center
activity for the time period. You can select sequential or non-sequential dates (for example, Monday,
Wednesday, and Friday) to use in the forecast.

To load historical data
 1. In Contact Center Client, click Tools=>Forecasting.

NOTE: You can load historical data for a queue or queue group. If you are using the forecast to build a
schedule, select historical data from the same queue group with which the schedule is associated. This
data will best represent the agents required for your schedule.

 2. Click Load historical data.
The Forecasting window opens.

 3. UnderQueues orQueue groups, click on the queue or queue groups you want to use as the source of
historical data.
NOTE: You can select one or more specific dates and/or date ranges of historical data.

 4. If you want to add a specific date, underHistorical date(s) for the forecast, click Specific day.
l Select a date.
l Click Add dates.
l Repeat step 4 to addmore dates.

 5. If you want to add data from a date range, click Date range.
l After Every, select the date frequency.
l Select the check boxes for one or more days of the week.
l After From and To, select the start and end dates of the historical data period used for the

forecast.
l Click Add dates.
l Repeat step 5 to addmore date ranges.

 6. AfterStart hour and End hour, select the time frame for historical data.
The Interval value, in minutes, is the time increment by which the forecast will be displayed. For
example, if you schedule your employee shifts in 30minute increments, select 30minutes as the
Interval value.

 7. After Interval, select the schedule interval: 15, 30, or 60minutes.
 8. Click Submit.

The forecast table is populated with historical data.

Modifying historical data
Youmust load historical data before you canmodify it. After you perform a forecast and run "what-if"
scenarios, the changes youmake to the historical data (for example, Calls Offered and Average Talk time)
affect the agents required.
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Modifying Average Talk time
You canmodify the Average Talk time value for one day or several days simultaneously.

Tomodify the Average Talk time parameter on the forecast grid
 1. Click Modify...=>Average Talk time.

See Figure 9 - 2.
 2. UnderSpecify how you want to change the Average Talk Time value(s), specify how you want to

modify Average Talk time:
l Add seconds to or subtract seconds from the value
l Increase or decrease by a percent of the value
l Select a fixed value

 3. UnderApply the changes to the following data source, specify if you want to modify the original
value or the current grid value.

 4. UnderApply to days, select the days for which you want to modify Average Talk time.
 5. Click Apply.

Figure 9 - 2 Average Talk Time window
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Modifying Calls Offered
You canmodify the Calls Offered value for one or several time intervals simultaneously.

Tomodify the Calls Offered parameter on the forecast grid
 1. Click Modify...=>Calls Offered.

See Figure 9 - 3.
 2. UnderSpecify how you want to change the Calls Offered value(s), specify how you want to modify

Calls Offered:
l Add calls to or subtract calls from the values
l Increase or decrease by a percent of the values
l Select a fixed value

 3. UnderApply the changes to the following data source, specify if you want to modify the original
value or the current grid value.

 4. UnderApply to times, select the days and time interval for which you want to modify Calls Offered.
 5. Click Apply.

Figure 9 - 3 Calls Offered window

Modifying the weekly total for Calls Offered
You canmodify the Calls Offered values for an entire week simultaneously. Modifying these values changes
the number of Calls Offered while maintaining the same proportion of calls across all time intervals. For
example, if you increase the weekly total by 10 percent, an interval with 10 calls will change to 11. However,
an interval with zero calls will remain zero.
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Tomodify the Calls Offered parameter on the forecast grid
 1. In Contact Center Client, click Tools=>Forecasting.
 2. Click Modify...=>Weekly total.

See Figure 9 - 4.
 3. UnderSpecify how you want to change the weekly total, specify how you want to modify Calls

Offered over the week:
l Increase or decrease by a percent of the values
l Select a fixed value

 4. UnderApply to totals, specify if you want to modify the original values or the current grid values.
 5. Click Apply.

Figure 9 - 4 Calls Offered window

Performing forecasts
NOTE:Youmust load historical data before you can perform a forecast. See "Loading historical data" on page
294.

To run a forecast
 1. Specify the Service Level %, Service Level Time, Wrap Up Time, and Agent Efficiency % you expect

for the queue or queue group.
 2. Click Perform forecast.

You can perform what-if scenarios on the historical data using different Service Level objectives until
you are satisfied with the forecast.

Printing forecasts
After you generate forecast data you can print it.

To print a forecast
 1. Click Export Forecast.

The Forecast data export window opens.
 2. Click Printer.
 3. Click Export.

The print preview window opens.
 4. Click the print direct icon, or click the print icon, specify your printer options, and click OK.
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Saving forecasts as Excel files
After you generate forecast data you can export it to aMicrosoft Excel spreadsheet.

To export a forecast as an Excel file
 1. Click Export Forecast.

The Forecast data export window opens.
 2. Click Microsoft Excel.
 3. Click Export.

The forecast opens in aMicrosoft Excel spreadsheet you canmodify and save.
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Chapter 10

Data-mining

ACD Inspector
SMDR Inspector
Auditor
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Data Mining
The data-mining tools comprise

l ACD Inspector
ACD Inspector searches for agent and ACD queue event records.

l SMDR Inspector
SMDR Inspector searches through SMDR data to find specific contact center events.

l Auditor
Using Auditor you can view the historical real-time events that occurred on a particular date, in the
sequence they occurred, at your own pace.

NOTE: For ACD Inspector and SMDR Inspector to function effectively when using Internet Explorer 9 as your
browser, youmust add Contact Center Management to the Internet Explorer Trusted Sites category and set
the Internet security to medium. See theContact Center Management Installation Guide.

You access ACD and SMDR Inspectors via the Contact Center Client ribbon. In order to access the ACD and
SMDR Inspectors, your security role must have the "May manage ACD Inspector" and "May manage the
SMDR Inspector" options enabled.

To access ACD and SMDR Inspectors
 1. Click Tools in the Contact Center Client ribbon.
 2. In theData Mining column, click Inspectors to open the Data Inspectors tool.

The Data Inspectors window opens.
See Figure 10 - 1.
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Figure 10 - 1 Data Inspectors window

ACD Inspector
ACD Inspector searches through telephone data obtained from the telephone system, for agent and ACD
queue event records. For example, using ACD Inspector, you can find the exact time an agent logs off at
lunch. You can run a search and examine the activities of individual agents or all of the agents in a particular
agent group or customer service queue during that time interval. You can also search on specific agent states
and other parameters, such as the number of calls waiting and the number of active agents. The search
follows a wild card format. Your specifications do not have to be exact. You canmake the search as inclusive
or exclusive as you wish. The results are placed in an easy-to-interpret grid that can be printed or saved to file.
You can verify that your reports are valid by conducting searches against raw telephone system data.

There are four types of search result tabs:
l Agent events
l Queue events
l Date events
l Exception events
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Running searches in ACD Inspector
NOTE:When you run searches on queues in ACD Inspector, be sure to include a P preceding the queue
number.

When you run a search, ACD Inspector searches through the raw telephone system data on the local hard
drive. Each search requires the following information:

Select dates/Delete dates
The Select dates button specifies the date range within which you want to search. The Delete dates button
deletes days within the range you selected. The date is displayedmonth first, then day, then year.

Select media servers
The Select media servers check boxes specify the origin of the data used in the search. Currently you can
search on telephone activity only. In the future, you will be able to search on email, chat, and fax activity.

In addition to the date andmedia server parameters, the ACD Inspector has the following search criteria tabs:
l Agent events
l Queue events
l Option events

You can use the Reset criteria button to reset all of the search parameters to their default settings.

Agent events criteria for searches
NOTE: When conducting a search, if you accept the default settings—all check boxes—the search output will
contain all of the event records. You can clear check boxes to narrow down your search. For example, if you
clear all of the agent states except for the Agent login and Agent logout check boxes, the agent event search
output will include log on and log off event records only.

When you click Tools=>Inspectors=>ACD Inspector, the Agent events tab opens. It displays the agent event
criteria used in the search. (See Figure 10 - 2.)
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Figure 10 - 2 ACD Inspector main window - Agent events tab

The Agent events tab has the following search criteria:

Agent information
The Agent information boxes specify the agent’s ID and extension number, and line numbers for one or more
telephone lines to which the agent connects. You can search for agent information records for a particular
agent, or for all of the agents. The agent information specifies the Agent ID for themedia server you have
already selected. For example, if you selected themedia server Phone, ensure you select the Agent Login ID
for themedia server Phone. It is specified in YourSite Explorer=>YourSite=>Agents.

Agent events
The Agent events criteria are listed and automatically selected.
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Idle event modifiers
The idle event modifier check boxes provide additional agent event searches. You can select one or more
check boxes to include records for agents who are in the following states: unknown, idle, DND, Make Busy,
and both DND andMake Busy.

NOTE: When conducting a search, if you accept the default settings the search output will contain all of the
event records. You can clear check boxes to narrow down your search.

ACD queue
The ACD queue specifies the queue to which your agent belongs. For example, if the agent belongs to Tech
Support, then you specify the Tech support queue. The agent’s queue is specified in YourSite
Explorer=>YourSite=>Queues. When you enter an ACD queue number and an agent number (in the Agent ID
box), the search results contain records for all of the calls the agent receives from the queue.

Table 10 - 1 describes the ACD information provided by the Agent events tab.
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Table 10 - 1 ACD information provided by Agent event tab

Agent events Description

Agent Login This record is produced whenever an agent successfully logs on.

Agent Logout This record is produced whenever an agent successfully logs off. If agent A is
currently logged on extension X and agent B logs on to extension X, a log off record
is automatically produced for A. This is followed by the log on record for B. Make
Busy is automatically enabled on the extension when the agent logs out. No remove
Make Busy record is produced. The extension number is the prime line of the ACD
set which an agent is logged on.

Agent Set Do Not
Disturb

A record is not produced when a hunt group is placed in DND. The records do not
differentiate between setting DND locally and remotely. The extension number
reported is always the prime line of the ACD extension. A set DND record will be
produced for the following conditions:

l Setting DND locally by using the DND access code
l Setting DND remotely by using the remote DND access code
l Setting DND remotely by using the attendant console features key
l Setting DND locally on a SUPERSET 4 telephone by pressing the select

features hardkey and dialing the digit 2 or setting it on a SUPERSET 4DN or
SUPERSET 430 telephone by pressing the DoNot Disturb Feature Key

Agent Remove Do
Not Disturb

The extension number is always the prime line of the ACD extension. A clear DND
record will be produced for the following conditions:

l Clearing DND locally by using an access code
l Clearing DND remotely by using the Cancel Remote DND access code
l Clearing DND remotely by using the attendant console feature key
l Clearing DND by using the Cancel All Features access code
l Clearing DND by using the Cancel All DND feature on the attendant console
l Agent logging in on an extension in DND

Agent Set Make Busy This record is produced whenever an extension is placed in theMake Busy state. A
record is not produced when an agent logs out because Set Make Busy is implied
when an agent log out record is received. The extension number is always the prime
line of the ACD extension.

Agent RemoveMake
Busy

This is similar to Set Make Busy. No record is produced when the agent logs on.
The removeMake Busy is implied by the log in record. The extension number is
always the prime line of the ACD extension.

Agent Answer ACD This record is produced whenever an agent answers a call that was directed to the
ACD hunt group. The event record contains the Agent ID and extension number
(hunt group pilot number to which the call was placed). The ACD extension that
answered the call can be determined by using the last agent log in event for that
extension. If the ACD set does not have a logged in agent, the Agent ID area is
blank and the extension number is that extension’s prime line.

Agent Answer
Personal

A record of all of the non-ACD hunt group calls are included in this category. The
extension number is always the prime line of the ACD extension that answered.
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Agent events Description

Agent Make
Outbound

This record is produced whenever an agent originates a call and enters a
conversation. A record is not produced under the following conditions: entering a
feature access code, dialing an invalid number, or hanging up before the called party
answers. An agent extension number is always the prime line of the ACD set that
originated the call.

Agent Idle If work timer is in effect, the Agent Idle record is produced when the work timer
expires or when it is cancelled. If the agent enters Make Busy while work timer is in
effect, an Agent Idle record is produced followed immediately by a set Make Busy
record. A record is not produced to show the end of the call or the start of the work
timer. This entire period is treated as part of the time to process the call.
If work timer is not in effect, the Agent Idle record is produced at the end of a call,
not when the agent hangs up. For example, if the agent presses the HANG-UP
softkey and remains off hook for 5 seconds, the record is produced when the
HANG-UP is pressed, not when the agent actually goes on hook. The extension
number is always the prime line of the ACD set that is now idle.

Agent Work timer Stat This record is produced when an agent terminates an ACD call and the work timer is
started for that agent. If the work timer cannot be started, an idle event record is
produced instead.

Agent RemoveWork
timer

This record is produced when the work timer expires for that agent.

Agent Hold Active When an agent places a call on hold, a record is produced. If the agent places
another call or answers a call on a second line, the second call will be recorded
independently of the first.

Agent Hold Retrieve When the held call is retrieved, a record is produced, indicating that the agent is now
busy on that line.

Agent Hold Abandon When the held call is abandoned, a record is produced for that line.

Agent Answer
Remote ACD

When an agent answers a remote ACD call, a record is produced. When you have
networked ACD (more than one telephone system networked together), local calls
are calls routed through the same telephone system that the agent’s extension is
located, remote calls are calls routed through the other telephone system.

Agent Ringing ACD This record is produced when the telephone rings with an ACD call.

Interactive Contact
Center Queue Set
DND Request

This record is produced when the agent set the queue in DND.
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Agent events Description

Interactive Contact
Center Queue Set
DND

A record is produced when the supervisor puts a queue in DND and when the
Contact Center Management system puts a queue in DND. In
YourSite=>Configuration=>Queue, on the Business Hours tab, you set the hours of
operation for the business. The Contact Center Management system reads these
hours of operation and will put this queue in DND during off hours.

Interactive Contact
Center Queue
Remove DND
Request

This record is produced when the agent removed the queue from DND.

Interactive Contact
Center Queue
Remove DND

A record is produced when the supervisor removes the queue from DND andwhen
the Contact Center Management system removes the queue from DND. In
YourSite=>Configuration=>Queue, on the Business Hours tab, you set the hours of
operation for the business. The Contact Center Management system reads these
hours of operation and will remove this queue from DND during business hours.

Interactive Contact
Center Agent Login
Request

This record is produced when the agent logged on.

Interactive Contact
Center Agent Login

This record is produced when the supervisor logged on the agent.

Interactive Contact
Center Agent Logout
Request

This record is produced when the agent logged off.

Interactive Contact
Center Agent Logout

This record is produced when the supervisor logged off the agent.

Interactive Contact
Center Set MKB with
Reason Code
Request

This record is produced when the agent sets himself as Make Busy.

Interactive Contact
Center Set MKB with
Reason Code

This record is produced when the supervisor sets the agent in Make Busy.

Interactive Contact
Center RemoveMKB
Request

This record is produced when the agent sets himself in Make Busy.

Interactive Contact
Center RemoveMKB

This record is produced when the supervisor removed the agent fromMake Busy.
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Agent events Description

Interactive Contact
Center Set DND
Request

This record is produced when the agent sets himself as DND.

Interactive Contact
Center Remove DND

This record is produced when the supervisor removed the agent from DND.

Interactive Contact
Center Sync Queue

This record is produced when Interactive Contact Center queues are synchronized
tomatch the telephone system queues. In YourSite=>Configuration=>Queue, under
Interactive Contact Center options, you can select this queue to be synchronized
with the telephone system data each night. That means that the information in
Contact Center Management will be changed to reflect what is programed on the
telephone system.

Interactive Contact
Center Sync Agent
Group

This record is produced when Interactive Contact Center agent groups are
synchronized tomatch the telephone system queues.

Interactive Contact
Center Sync Agent

This record is produced when Interactive Contact Center agents are synchronized
tomatch the telephone system queues.

Interactive Contact
Center Sync Started

This record is produced when the synchronization between the Contact Center
Management database and the telephone system is started.

Interactive Contact
Center Sync Finished

This record is produced when the synchronization between the Contact Center
Management database and the telephone system is finished.

Queue events criteria for searches
When performing a queue events search, you can search on the following criteria:

l Agent group statistics
l Queue statistics
l Date

TheQueue events tab has the following search criteria:

Queue information
TheQueue information box specifies the ACD queue or agent group used in the search. When you type an
ACD queue or agent group number, the search results contain records specific to that ACD queue or agent
group.

Queue event
When you select all three queue event check boxes (Agent Group statistics, Queue statistics, Date), the
search results contain records for all of the agent groups and queues, and all of the telephone system refresh
cycles. The telephone system performs a re-synchronization and generates a refresh record every time it
notices the date or hour has changed (once an hour).
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Agent information
The Agent information boxes specify the range of values for the Agents Available statistic used in the search.
For example, if you select a range of 5 to 10, the search results contain records for all of the calls during
periods when 5 to 10 agents were logged on to the ACD, but not in Make Busy or Do Not Disturb.

Calls waiting/Longest waiting settings
The Calls waiting settings and Longest waiting settings boxes specify ranges of values for the Calls waiting
and Longest waiting statistics. For example, selecting a range from 10 to 999 in the Calls waiting box
produces all of the records for calls received during periods whenmore than 10 callers waited in queue.

TheQueue events tab displays the queue event criteria used in the search. (See Figure 10 - 3.)

Figure 10 - 3 ACD search criteria - Queue events tab
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Option events criteria for searches
TheOption events tab displays the telephone system refresh records, error, and information criteria used in
the search. (See Figure 10 - 4.)

TheOption events tab has the following search criteria:

Time ranges
The Time ranges boxes specify the time interval used for the search. The time interval applies to searches on
agent and queue events.

Exception records
Collector Service tags telephone system records that contain errors with an E (telephone system 1) or e
(telephone system 2). Under Exception records, you select the Error records check box to include these
records in the search output.

Collector Service writes a log record to the data stream upon start up. It tags the log record with an I to
indicate it is an information record. You select the Information records check box to include log records in the
search output. ACD Inspector displays the error and information search result records on the Exception
records tab.

In contact centers that have two telephone systems, Collector Service tags records from the second
telephone system with an S. You specify the Com ports used by your telephone systems on the Data
collection tab of YourSite Configuration.

Output record count
TheOutput record count specifies themaximum number of rows of records to display.
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Figure 10 - 4 ACD search criteria - Option events tab

Running agent events searches
NOTE: When you run a search on Agent Answer ACD, type the Agent ID but do not type the agent’s
extension. Once answered, an ACD call is not pegged as an extension but is pegged as ACD. You will get no
data if you type the agent’s extension.

You can run an Agent events search to find all of the records of when agent 2005 was on ACD and used Set
Make Busy.

To run an Agent events search
 1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.

The Agent events tab of theACD Inspector criteria tab opens.
 2. Click Select dates and select March 3, 2003 toMarch 5, 2003.
 3. UnderSelect media servers, Phone is preselected.

NOTE:
When you run a search on Agent answer ACD, type the Agent ID but do not type the agent’s
extension. Once answered, an ACD call is not pegged as an extension but is pegged as ACD. You
will get no data if you type the agent’s extension.
You can find the Agent ID by selecting YourSite=>Configuration=>Agent login=>Agent login. The
Agent ID is located under the Agent login ID heading. Ensure you select the Agent ID associated
with the Phonemedia server.

 4. UnderAgent information, type the Agent ID, 2005.
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 5. UnderAgent events, if you are not selecting all events, clearSelect all.
 6. Select theAgent event(s) you want to search on, in this case, Agent answer ACD, Set Make Busy,

andRemove Make Busy.
 7. You can leave theACD queue blank.
 8. Click Start search.

The ACD Inspector results - Agent events tab opens.

Agent events search results
This section describes the records produced when you run searches in ACD Inspector. Table 10 - 2 describes
the ACD information provided by the Agent events tab. The Agent events tab displays the ACD activity and
theMake Busy activity for agent 2005. (See Figure 10 - 5.)

Figure 10 - 5 ACD search results - Agent events tab
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Table 10 - 2 Agent events result information

Column heading Description

Media server TheMedia server box identifies the telephone system (with or without MiTAI) that
produced the event record.

Function/Event The Function/Event box displays the criteria for which you searched - in this case
Agent answer ACD, Agent set Make Busy, Agent removeMake Busy.

Date The Date box displays the date of the event record (month/day/year).

Time The Time box displays the time the event occurred.

Extension Queue ID The Extension Queue ID displays the Extension or ACD queue used for the call.
The Extension Agent ID column contains the extensions when a search involves
the extension (such as Make Busy). It contains Queue IDs when no extension
information is requested (such as Agent Answer ACD).

Agent ID The Agent ID box displays the agent number for the agent involved in the call.

Line The Line number box displays the telephone line the agent used to pick up or
originate the call.

Idle Event Modifier The Idle Event Modifier box indicates when the agent is idle.

Narrowing an Agent events search
You can use theOptions tab in conjunction with the Agent events search or the Queue events search. Using
the Options tab, you narrow down the time frame for either search.

You can run an Agent events search to find all of the records for a specific agent who was on ACD and when
that agent used Set Make Busy. Then you narrow the search with the Options tab to search between 9:00
A.M. and 11:00 A.M. only. The ACD Inspector results on the Agent events tab display the ACD activity and
theMake Busy activity for agent 2005 between 9:00 A.M. and 11:00 A.M. (See Figure 10 - 6.)

To run an Agent events/Options events search
 1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.

TheAgent events tab of theACD Inspector criteria tab opens.
 2. Click Select dates and select March 3, 2007 toMarch 5, 2007.
 3. UnderSelect media servers, Phone is preselected.

NOTE:
When you run a search on Agent answer ACD, type the Agent ID but do not type the agent’s extension.
Once answered, an ACD call is not pegged as an extension but is pegged as ACD. You will get no data
if you type the agent’s extension.
You can find the Agent ID by selecting YourSite=>Configuration=>Agent login=>Agent login. The
Agent ID is located under the Agent login ID heading. Ensure you select the Agent ID associated with
the Phonemedia server.
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 4. UnderAgent information, type the Agent ID, 2005.
 5. UnderAgent events, if you will are not selecting all events, clearSelect all.
 6. Select theAgent event(s) you want to search on, in this case, Agent answer ACD, Set Make Busy,

andRemove Make Busy.
You can leave the ACD queue blank.

 7. Click theOption tab.
 8. Under Time ranges, select theStart at andEnd at times with which to narrow the Agent events

search.
In this example, the start time is 9:00 A.M. and the end time is 11:00 A.M.

 9. Click Start search.
The ACD Inspector results - Agent events tab opens.

Figure 10 - 6 ACD search results - Agent events tab

Running queue events searches
You can run aQueue events search to determine when you had too few agents available to answer calls for a
particular queue. You search for amaximum of two agents and local calls that waited between one and three
minutes.

To run aQueue events search
 1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.

TheAgent events tab of theACD Inspector criteria tab opens.
 2. Click theQueue events tab.
 3. Click Select dates and select March 1, 2003 andMarch 4, 2003.
 4. UnderSelect media servers, Phone is preselected.
 5. UnderQueue information, type the ACD Queue, p280.
 6. UnderQueue event, select Queue stats.
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 7. UnderAgent information, type 0-2 agents.
In this example, you want to know when you have only two agents scheduled to answer the queue.

 8. UnderCalls waiting setting, select 0-999 Local calls waiting.
In this example, you want to know the number of calls waiting on the telephone system to which your
agent is connected. If you have only one telephone system, you do not have any remote calls waiting.

 9. Under Longest waiting settings, select 1-3minutes.
In this example, you want to know the number of local calls that waited between 1-3minutes. You think
waiting up to aminute is acceptable, so you did not search for calls less than aminute. If you have only
one telephone system, you do not search for the remote longest waiting.

 10. Click Start search.
The ACD Inspector results - Agent events tab opens.

 11. Click theQueue events tab.

Queue events search results
TheQueue events tab displays the number of calls that waited between one and threeminutes (one call),
when there were amaximum of two agents available, for the dates selected, for queue 280. (See Figure 10 -
7.)

Figure 10 - 7 ACD search results - Queue events tab
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Table 10 - 3 describes the ACD information provided by the Queue events tab.

Table 10 - 3 Queue events result information

Column heading Description

Media server TheMedia server box identifies the telephone system (with or without MiTAI)
application that produced the event record.

Function/Event The Function/Event box indicates whether the event record is for a queue or an
agent group.

Date The Date box displays the date of the event record (month/day/year).

Time The Time box displays the time the event occurred (in seconds).

Queue/Agent group TheQueue/Agent group box displays the queue or agent group number.

Agents available The Agents available box displays the current number of agents logged on to the
ACD system, who are not in Make Busy or Do Not Disturb.

CW (Number of local
calls waiting)

The CW box displays the number of local callers waiting for an available agent.

LW (Longest local call
waiting)

The LW box displays the wait time for the caller waiting the longest in queue for
an available agent.

Rem CW (Number of
remote calls waiting)

When you have networked ACD (more than one telephone system networked
together), the Rem CW box displays the number of remote callers waiting for an
available agent.

Rem LW (Longest
remote call waiting)

When you have networked ACD (more than one telephone system networked
together), the Rem LW box displays the wait time for the caller waiting the
longest in a remote queue for an available agent.

Narrowing a Queue events search
You use theOptions tab in conjunction with the Agent events search or the Queue events search. Using the
Options tab, you can narrow down the time frame for either search.

You can run aQueue events search to find when you have too few agents available to answer calls for a
particular queue. You search for amaximum of two agents and local calls that waited between one and three
minutes.Then you narrow the search with the Options tab to search between 9:00 A.M. and 11:00 A.M. only.

To run aQueue events/Options events search
 1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.

TheAgent events tab of theACD Inspector criteria tab opens.
 2. Click theQueue events tab.
 3. Click Select dates and select March 1, 2003 toMarch 4, 2003.
 4. UnderSelect media servers, Phone is preselected.
 5. UnderQueue information, type the ACD Queue, p280.
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 6. UnderQueue event, select Queue stats.
 7. UnderAgent information, type 0-2 agents.

In this example, you want to know when you have only two agents scheduled to answer the queue.
 8. UnderCalls waiting setting, select 0-999 Local calls waiting.

In this example, you want to know the number of calls waiting on the telephone system to which your
agent is connected. If you have only one telephone system, you do not have any remote calls
waiting.

 9. Under Longest waiting settings, select 1-3minutes.
In this example, you want to know the number of local calls that waited between 1-3minutes. You
think waiting up to aminute is acceptable, so you did not search for calls less than aminute. If you
have only one telephone system, you do not search for the remote longest waiting.

 10. Click theOption tab.
 11. Under Time ranges, select the Start at andEnd at times with which to narrow the Agent events

search.
In this example, the start time is 9:00 A.M. and the end time is 11:00 A.M.

 12. Click Start search.
The ACD Inspector results - Agent events tab opens.

 13. Click theQueue events tab.

TheQueue events tab displays the number of calls that waited between one and threeminutes, when there
were amaximum of two agents available, for the dates selected, between 9:00 A.M. and 11:00 A.M. for queue
280. There was only one call that waited between one and threeminutes in the selected time frame and
queue. (See Figure 10 - 8.)

Figure 10 - 8 ACD search results - Queue events tab
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Running wild card queue events searches
When performing searches on theQueue Events tab, you can enter aP800 under Queue information and the
search will produce records involving Queue 800 only. Alternatively, you can run wild card searches. When
you perform wild card searches, you use * to represent the wild card. For example, if you enter “*00” under
Queue information on theQueue events tab, the search will produce records for all of the Queues or Agent
groups that end in “00” (for example, 200, 300).

To run a wild card Queue events search, where all of the queues end in “00”.
 1. In Contact Center Client, click Tools=>Inspectors=>ACD Inspector.

TheAgent events tab of theACD Inspector criteria tab opens.
 2. Click theQueue events tab.
 3. Click Select dates and select February 9, 2003 and February 10, 2003.
 4. UnderSelect media servers, Phone is preselected.
 5. UnderQueue information, type *00.

In this example, you are searching for all of the queues that end in “00”.
 6. UnderQueue event, select Queue stats.
 7. UnderAgent information, type 0-2 agents.

In this example, you want to know when you have only two agents scheduled to answer the queue.
 8. UnderCalls waiting setting, select 0-999 Local calls waiting.

In this example, you want to know the number of calls waiting on the telephone system to which your
agent is connected. If you have only one telephone system, you do not have any remote calls
waiting.

 9. Under Longest waiting settings, select 1-3minutes.
In this example, you want to know the number of local calls that waited between 1-3minutes. You
think waiting up to aminute is acceptable, so you did not search for calls less than aminute. If you
have only one telephone system, you do not search for the remote longest waiting.

 10. Click Start search.
The ACD Inspector results - Agent events tab opens.

 11. Click theQueue events tab.
See Figure 10 - 9.
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Figure 10 - 9 ACD Wild card search results - Queue events tab

Wild card queue events search results
TheQueue events tab displays the Queue statistics when there were amaximum of two agents available, for
the dates selected, for all of the queues that end in “00”. TheQueue statistic in this case are the records of the
telephone system performing re-synchronization. A refresh record is produced every time the system notices
the date or hour has changed (once an hour).

Running searches for error and information records
Using the Options tab, you can run a search for error and information records. The error messages are records
of sequence errors. The information records are records of when the Collector restarts.

To run an exception events search
 1. Click theACD Inspector criteria tab.
 2. Click theOptions tab.
 3. Click Select dates and select a date.
 4. UnderSelect media servers, Phone is preselected.
 5. Under Time ranges, type the Start at and End at times.
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 6. UnderException records ensure theError records and/or Information records check boxes are
selected.

 7. UnderOutput record count, select themaximum number of records you want to display.
 8. Click Start search.

The ACD Inspector results - Agent events tab opens.
 9. Click theException events tab.

Exception events search results
Table 10 - 4 describes the ACD information provided by the Exception events tab.

Column Heading Description

Media server TheMedia server box identifies the telephone system (with or without MiTAI)
application that produced the event record.

Record The Function/Event box displays refresh records. The refresh event signifies the
start of a new cycle of group and queue statistics.

Table 10 - 4 Exception event result information

SMDR Inspector
SMDR Inspector searches through SMDR data to find specific contact center events. For example, suppose
you receive a complaint from a caller who waited 16minutes in queue for a customer service agent, sometime
between 1:00 P.M. and 1:30 P.M. sometime last week. In a single session, you can search through data from
multiple days to find a specific event. The search follows a wild card format. Your specifications do not have
to be exact. You canmake the search as inclusive or exclusive as you wish. The results are placed in an
easy-to-interpret grid that can be printed or saved to file. You can verify that your reports are valid by
conducting searches against raw telephone system data.

Common SMDR Inspector searches include searches for all of the records on
l Queue P001
l Calls the telephone system sent to agent group 23
l The queue for which agent 8000 answered calls
l Outbound calls made by agent 2311 (internal and external)
l Where Account Codes were entered
l DNIS that start with 89
l Calls transferred to trunks

The search result tabs consist of the following:
l SMDR search results
l Exception results

Starting SMDR Inspector
To start SMDR Inspector on the client computer
 1. Click Tools in the Contact Center Client ribbon.
 2. In theData Mining column, click Inspectors to open the Data Inspectors tool.
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Running searches in SMDR Inspector
When you run a search, SMDR Inspector searches through the raw telephone system data on the local hard
drive. Each search requires the following information:

Select dates/Delete dates
The Select dates button specifies the date range within which you want to search. The Delete dates button
deletes days within the range you selected. The date is displayedmonth first, then day, then year.

Select media servers
The Select media servers check boxes specify the origin of the data used in the search. Currently you can
search on telephone activity only. In the future, you will be able to search on email, chat, and fax activity.

In addition to the date andmedia server parameters, SMDR Inspector has the following search criteria tabs:
l Call parties
l Call types
l Options

Call parties criteria for searches
The Call parties criteria helps you to find call events such as, what calls an agent received (Called party),
what calls an agent made (Calling party), or what extension the call was transferred to (Third party). (See
Figure 10 - 10.)

The Call parties tab search options are as follows.

Digits dialed
The Digits dialed box specifies the queue number of the queue that picks up the call (for inbound calls).

The ANI digits box specifies the area code and telephone number for an inbound call. The search results
contain records that match the data the user typed in the ANI field.

The DNIS digits box specifies the phone number the caller dialed. The DNIS could be product specific, or it
could specify demographic variables or marketing targets.

The Account Code box specifies the Account Code number used in the search. Agents enter Account Code
numbers to tag inbound and outbound calls.

Outbound calls
TheOutbound calls box specifies telephone number the agent dials (for outbound calls).

Call parties
The Calling party box specifies the extension or agent number (for an outbound call), or the trunk number (for
an inbound call) used in the search.

The Called party box specifies the answering extension or the trunk number (for an outbound call) used in the
search.

The Third party box searches for call records on the extension number used in a transfer.
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Call identification
The Call identification box specifies theMitel call IDs assigned to a call segment.

The Sequence ID box specifies the sequence number assigned to the call record by the telephone system.

The Associated ID box specifies the number attached to associated data records of the call assigned by the
telephone system.

Figure 10 - 10 SMDR search criteria - Call parties tab
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Call types criteria for searches
The Call types tab displays the types of calls the agent receives, for example, ACD or non-ACD, abandoned,
interflowed, requeued, unavailable, or outbound calls. (See Figure 10 - 11.)

The Call types tab search options are as follows.

Call types
TheCall types check boxes specify one or more categories of calls used in the search. The telephone system
generates an Unavailable (Queue unavailable calls) event record when a caller dials a queue and the queue is
not available (in DND) or there are no agents logged on to handle the call.

Answer supervision
TheAnswer supervision check box searches for instances where calls were answered by the called party. If
you have answer supervision and youmake an outbound call but the called party does not answer (you hang
up) then an SMDR record is generated with no duration. If you do not have answer supervision then no SMDR
record is generated at all.

Busy call
TheBusy call check box searches for call records on queues or extensions the caller dials but finds busy.

Error by caller
TheError by caller check box searches for call records on numbers the caller dials that are not recognized by
the telephone system.

TAFAS answered
The TAFAS Answered check box searches for call records that involve calls manually picked up by agents at
alternate extensions. In a TAFAS answered call, an employee hears another employee's phone ring and dials
a number to pick up the call.

Internal call
The Internal call check box searches for call records on calls between employees that do not involve trunks.

Blank
TheBlank check box searches for call records that have no data in the Call completion box. That is, when the
check box is selected, the search output contains records where there is nothing recorded in the Call
completion box.

Attendant involved
TheAttendant involved options specify whether or not call records for calls involving an automated attendant
are used in the search.

Transfer/Conference
The Transfer/Conference check box searches for records on transferred or conferenced calls.

Speed call/Forward
TheSpeed call/Forward check boxes search for call records involving a speed dial and/or conference
function. When the Blank check box is selected, the search output contains records where there is nothing
recorded in the Speed or Fwd check boxes.
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System ID
TheSystem ID check box searches for call records that pertain to a specific telephone system. In amulti-site
enterprise, you program each telephone system with a 3-digit system ID number. You can distinguish records
by their system ID number. The telephone system appends it to all of the SMDR records.

Figure 10 - 11 SMDR search criteria - Call types tab

Options criteria for searches
When you click Tools=>Inspectors=>SMDR Inspector, the Options tab opens. TheOption criteria work in
conjunction with the Call parties criteria and the Call types criteria to narrow down the search. (See Figure 10 -
12.)

TheOptions tab search options are as follows.

Time ranges
The Time ranges boxes specify the time interval used for the search.

Call duration
The Call duration boxes specify a range of values for the Call duration statistic used in the search.
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Time to answer
The Time to answer boxes specify a range of values for the Time to answer statistic used in the search. For
example, if you select a time to answer of 240 to 999 seconds, the search records include calls that were
answered by an agent after waiting at least 240 seconds to be answered.

Exception records
The Collector Service tags telephone system records that contain errors with anE (telephone system 1) or e
(telephone system 2). You select the Error records check box to include these records in the search output.
The Collector Service writes a log record to the data stream upon start up. It tags the log record with an I to
indicate it is an information record. You select the Information records check box to include log records in the
search output. ACD Inspector displays the error and information search result records on the Exception
Records tab.

In contact centers that have two telephone systems, the Collector Service tags records from the second
telephone system with anS. You specify the Com ports used by your telephone systems on the Data
collection tab in YourSite Configuration.

Output record count
TheOutput record count specifies themaximum number of rows of records to display.

Figure 10 - 12 SMDR search criteria - Options tab
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SMDR search results information
The SMDR Search results tab shows the search results for Call parties, Call types, andOptions searches.
Table 10 - 5 describes the SMDR information provided by the SMDR Search results tab.

Column
heading

Description

Media server TheMedia server box identifies the telephone system (with or without MiTAI) that
produced the event record.

Start time The Start time of a call is reported in hours andminutes in either a 12- or 24-hour format. If a
12-hour clock is used, the letterP indicates P.M. (hh:mmp)

Date The Date box displays the date of the event record (month/day/year).

Total duration The duration of a call is reported in hours, minutes and seconds (hh:mm:ss). Leading zeros
are output (Maximum time = 99 hours, 59minutes, 59 seconds). If the call duration
exceeds 100 hours, a call duration of 99 hours, 99minutes, 99 seconds will be recorded.

Calling party The Calling party is the identity of the party that/who originated the call. It may be a station,
an attendant, or an incoming trunk, as described below:

(a) Station number as Calling party (cccc). A station number (extension number or agent
ID) may be one to four digits (0-9, *, #) which are left-justified (that is, no leading zeros).

(b) Attendant as Calling party (ATTm). Calls originated by an attendant that do not involve
a third party are reported as a calling party by ATT, followed by the console number. When
the console number is in the range of 10 through 99, the format is modified to be ATmm. If
an attendant calls an outside party on behalf of a station or trunk, that station or trunk is
reported as the caller but the attendant flag symbol [*] is shown in the Attendant was
Involved box.

(c) Trunk number as Calling party (Tnnn or Xnnn). When the originating party is an
incoming CO trunk, Tnnn is shown on the record, where nnn is the number of the trunk. If
the trunk number is less than three digits long, it is left-padded with zeros. If the extended
digit length option is enabled, the trunk number nnnnmay be up to four digits long, left-
justified and without leading zeros. When the originating party is an incoming non-CO
trunk, Xnnn is shown in the trunks record. The T orX ensures that CO trunks and CO
Attendant trunks can be distinguished from tie trunks. The trunk number is the trunk ID
specified during customer data entry in the Trunk Assignment form.

Attendant flag This 1-digit box contains an asterisk [*] when a call is assisted by, or initially answered by,
an attendant. This flag will not be shown if a call is transferred to an attendant.

Time to answer
(Time to Ans)

This is the number of seconds from the time an incoming external call rings the destination
until the call is answered. If a call is never answered, this box displays three asterisk [***].
Leading zeros are output and the box remains at 999 when an overflow is reached. If the

Table 10 - 5 SMDR search results information
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Column
heading

Description

Call Distribution (MCD) feature package is installed, and theMCD report transfers option
is enabled, this box contains the total time to answer regardless of the number of times the
call is rerouted. This box does not apply to Internal SMDR.
NOTE: Time to answer does not include the duration the request waits in queue outside of
regular business hours.

Digits dialed External SMDR
External SMDR records the digits dialed on the outgoing trunk. A maximum of 26 digits is
recorded. This number is reduced to 20 when the Report Meter Pulses option is selected in
CDE. This box does not include the trunk group access code on outgoing calls. The digits
recorded are the actual digits outpulsed on the trunk after digit modification has been
performed. On incoming calls, the digits dialed in on the trunk are recorded. The digits
dialed field contains the digits the telephone system used to route the call. For an incoming
call this could be the extension or the path to which the call is being routed. For outgoing
calls this is the number the caller dialed. Whenmore than 26/20 digits are dialed, the
remaining digits are ignored.
If theMCD option is enabled, each device is listed whenever the call is rerouted, rather
than the last device as in non-MCD loads. To reflect theMCD option, the Digits dialed on
the Trunk box displays dd1 ddd2 ddd3.
Internal SMDR
Internal SMDR records the digits dialed on an internal line. Up to 26 digits are recorded.
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Column
heading

Description

Call completion flag External SMDR (Outgoing calls)
This reports the completion status of an outgoing call in so far as the telephone system is
able to determine it. When an outgoing call fails toll-deny checking and is dropped, this box
contains a T. When the trunk group is programmed to receiveAnswer Supervision and a
supervision is received, anA is reported. When the trunk group is programmed for Toll
Reversal and a supervision is received, a T is reported.
External SMDR (Incoming calls)
The telephone system canmonitor the outcome of a call and can provide a comprehensive
report on call completion. When the station or hunt group to which a call is directed is busy,
aB is recorded. When an incoming trunk accesses an invalid number and receives reorder
tone, anE is reported. AnE is also reported for incomplete calls. A T is reported if the
incoming trunk is answered with Trunk Answer From Any Station (TAFAS) and if an
outgoing trunk call is toll denied, or if the call is Pickup answered.
When an incoming call is forwarded by an attendant to a busy station, aB is shown in the
call completion status box, the number called is shown as the third party, and the
Attendant is shown as the called party.
Internal SMDR
An I indicates that an internal call was completed.
Speed Call or Call forward flags (S or F)
This box contains anS when the number is speed dialed, and an Fwhen an external call is
forwarded through the external call forward feature.
If Internal SMDR is enabled, an F is also recorded when an internal call is forwarded
through the call forward feature. However, for internal calls the Third Party box does not
contain the number of the station that initiated the call forward feature. The Third Party box
is left blank because the Digit dialed box identifies the station that has call forward
enabled.

Speed call forward The Speed call/Forward check boxes search for call records involving a speed dial and/or
conference function. When the Blank check box is selected, the search output contains
records where there is nothing recorded in the Speed or Fwd check boxes.

Called party A Called party can be a station number, an attendant, or for outgoing calls, the outgoing
trunk number. The Called party output format is identical to that used for the Calling party.
SeeCalling party. For incoming calls to an attendant, the called party is recorded as the
attendant unless the attendant transfers a call to a station. For direct-in-lines, it would be
the station number. On outgoing calls handled by an attendant, the called party would be
the outgoing trunk’s ID.

Transfer/Conference
call
(Trans Conf)

This box identifies calls involving three or more parties. It contains a T for supervised
transfers, X for unsupervised transfers (that is, transfer in to busy reports a T, transfer in to
ringing reports anX), and aC for 3-way conversations or conferences.

Third party The Third party box contains the number of the station to which a trunk call has been
transferred. When several transfers take place during a trunk call, the first party is the only
one reported, as long as MCD Report transfers = No, and Record transfers = No.
If an external call is made to a station whose call forwarding is set to an external number,
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Column
heading

Description

the Third party box contains the number of the station that initiated the call forward feature.
For internal calls, the Third Party box is left blank because the Digit dialed box identifies
the station that has external call forward enabled.

Account Code Enabling the report Account Codes option in the SMDR Options Assignment form allows
an Account Code of two to 12 digits to be recorded here, if one is used tomake a call.
Leading zeros are reported if they are entered.

Route optimization
flag

At the starting and end nodes of a network call a flag will be shown in this box if route
optimization has taken place. A route optimized call involves two trunks to the same party:
the pre-optimization trunk and the post-optimization trunk. An SMDR record will be
produced for both trunks, which will be distinguished by a lower case r for the pre-
optimization trunk, and an upper caseR for the post-optimization trunk. Route optimization
is available with theMSDN/DPNSS Voice IV feature package only.

ANI/DNIS ANI/DNIS digits are recorded in this box. ANI and DINS numbers can be up to 10 digits in
length, and are recorded for incoming calls on ANI/DNIS trunks. COS option ANI/DNIS
reportingmust be enabled.

System identifier This optional 3-digit box may contain values from 000 to 999. 000 indicates that no
identifier has been entered. In the absence of a System identifier, a Node identifier is
printed (when programmed). Whenmore than one node identifier exists, the first one on the
programmed list is printed. When both a System ID and a Node ID are programmed, the
System ID takes precedence. Programming of System Identifiers and Node Identifiers is
described in the Customer data entry volume.

Call ID The Call ID box specifies the call number to which the record relates.

Call ID seq The Sequence ID box specifies the sequence number assigned to the call record.

Assoc call ID The Associated ID box specifies the number attached to associated data records of the
call.

System ID This optional 3-digit box may contain values from 000 to 999. 000 indicates that no
identifier has been entered. In the absence of a System identifier, a Node identifier is
printed (when programmed). Whenmore than one node identifier exists, the first one on the
programmed list is printed. When both a System ID and a Node ID are programmed, the
System ID takes precedence. Programming of System Identifiers and Node Identifiers is
described in the Customer data entry volume.

Record See "SMDR record boxes" on page 330.
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SMDR record boxes
This section describes the SMDR search output records available.

The telephone system records SMDR data in table format. Table 10 - 6 provides information used to interpret
the SMDR Inspector search output. It summarizes the SMDR record boxes and provides themeaning of the
symbols used.

Name Format Definition Notes

Date mm/dd mm = Month
dd = Day

mm = 01 - 12
dd = 01 - 31

Start time hh:mmp hh = Hours
mm = Minutes
p = pm

hh = 00 - 12 or 00 - 23
mm = 00 - 59
p = P.M. (12-hour clock)

Duration of
call

hh:mm:ss

hhhh:mm:ss

hh:mm:ss = duration in
hours:minutes:seconds

hhhh:mm:ss = duration in
hours:minutes: seconds

hh = 00 - 99
mm = 00 - 99
ss = 00 - 99
hhhh = 0000 - 9999
mm = 00 - 99
ss = 00 - 99

Calling party pppp

ppppppp

cccc = Extension #
Tnnn = Trunk # (CO)
Xnnn = Trunk # (non-CO)
ATTm = Attendant

ccccccc = Extension #
Tnnnn = Trunk # (CO)
Xnnnn = Trunk # (non-CO)
ATTmm = Attendant

c = 0 - 9, *, #
nnn = 000 - 999

m = Console # (ATmm for
Attendant 00 - 99)
c = 0 - 9, *, #
nnnn = 0000 - 9999

mm = Console #

Attendant f * = Attendant
-- = Attendant not involved

Attendant answered or
initiated the call, then
transferred it to an extension

Time to
answer

ttt ttt = time in seconds (000 - 999) ***
= Call unanswered

Leading zeros output.
Incoming calls only.

Digits dialed
on the trunk

xx...x

x...x y...y
or
Tx...x y...y
(Network Format)

Up to 26 (20 if metering) digits
dialed on the trunk
Network Format: up to 26 digits (20
if metering) in total

x = 0 - 9, *, #
y = 0 - 9, *, #
x...x = Node ID & Extension #
(up to 14 digits)
y...y = actual digits dialed
Tx...x = Node ID & Trunk #

Table 10 - 6 Summary of boxes in SMDR records
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Name Format Definition Notes

Call
completion
status

h A = Answer supervision
B = Called party busy
E = Caller error
I = Internal call
T = Toll-denied, TAFAS answered,
or Pickup answered

Outgoing
Incoming Direct/Dial-in
Incoming/Dial-in incoming
Incoming/Outgoing

Speed call or
Call fwd flags

S or F S = Number was Speed called
F = External call forwarded through
External call fwd feature or internal
call forwarded through Call forward
feature

Outgoing

Called party qqqq

qqqqqqq

cccc = Extension #
Tnnn = Trunk # (CO)
Xnnn = Trunk # (non-CO)

ATTm = Attendant

ccccccc = Extension #
Tnnnn = Trunk # (CO)
Xnnnn = Trunk # (non-CO)
ATTmm = Attendant

c = 0 - 9, *, #
nnn = Range specified in
telephone system form
programming
m = Console # (ATmm for
Attendant 00 - 99)
c = 0 - 9, *, #
nnnn = 0000 - 9999

mm = Console #

Transfer/
Conference
call

K T = Supervised transfer
X = Unsupervised transfer
C = 3-Way or Conference
R = re-queue call
U = Path unavailable
I = Interflow

U and I only apply to
ACD TELEMARKETER®
2000.

Third party rrrr
rrrrrrr

cccc = Extension #
cccccccc = Extension #

c = 0 - 9, *, #
c = 0 - 9, *, #

Account
Code (opt.)

aa....a Length of 2 to 12 digits a = 0 - 9, space-filled

Route
optimization
flag (opt.)

s r = pre-optimization trunk
R = post-optimization trunk
- = Space (no route optimization)

System
identifier
(optional)

iii Entered by System ID i = 0 - 9
iii = 000 - 999
000 = No code entered
In the absence of a System
ID, a Node ID is printed (if
programmed). When both
System ID and Node ID are
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Name Format Definition Notes

programmed, System ID takes
precedence.

ANI/DNIS xx...xxxxxxx Format
-aaaaaaaaaa-dddddddddd
- = blank
a = ANIS digit
d = DNIS digit
Extended digit length format
-aaaaaaaaaa-ddddddd

For Extended digit length
format only the 7 right most
DNIS digits are recorded.

Running call parties searches
You can run a Call party search to find out who called agent 2005 onMarch 10, 2004.

To run a Call parties search
 1. Click the SMDR Inspector criteria tab.

TheOptions tab opens.
 2. Click theCall parties tab.
 3. Click Select dates and select March 10, 2003.
 4. UnderSelect media servers, Phone is preselected.
 5. UnderCall parties, type the Called party, agent ID 2005.
 6. Click Start search.

The SMDR Inspector results - SMDR Search results window opens.

Call parties search results
The SMDR Search results tab displays the results of who called agent 2005. The agent’s extension is 1106.
He answers calls that come to queue 280 and dial zeros (which is extension 1290). On line one of the results,
an outside call dialed the agent’s extension. On line two, the agent answered a call from his queue (P280). On
line three, we see that extension 1107 called the agent. On line four, we see that extension 1112 called his
extension. (See Figure 10 - 13.)
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Figure 10 - 13 SMDR search results tab - Call parties search

Running call types searches
You run a Call types search when you want to narrow down the Call parties search. Previously, you have
completed a Call parties search for agent 2005 (Call parties tab). Now you want to narrow the search to
include only Answer non-ACD call types.

To run a Call types search
 1. Click the SMDR Inspector criteria tab.

TheOptions tab opens.
 2. Click theCall parties tab.
 3. Click Select dates and select March 10, 2003.
 4. UnderSelect media servers, Phone is preselected.
 5. UnderCall parties, type the Called party, agent ID 2005.
 6. Click theCall types tab.
 7. UnderCall types, clear the check boxes for all of the criteria but Answer non ACD .
 8. Click Start search.

The SMDR Inspector results - SMDR Search results window opens.

Call types search results
The SMDR search results tab displays the call parties/call type results. All of the non-ACD calls received by
agent 2005 onMarch 10, 2004 are displayed. They included external and internal calls where the caller dialed
the agent’s extension (1106), and all of the dial zero calls. (ACD calls are calls that are sent through the
queue.) (See Figure 10 - 14.)
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Figure 10 - 14 SMDR search results - Call types search

Running option searches
You runOption searches to narrow down further, Call types and Call parties searches. Previously, you ran a
Call parties search for agent 2005, and then a Call types search to include only Answer non-ACD calls. Now
you want to search for Answer non-ACD calls for agent 2005 that occurred between 9:00 A.M. and 1:00 P.M.

To run anOptions search
 1. Click the SMDR Inspector criteria tab.

TheOptions tab opens.
 2. Click theCall parties tab.
 3. Click Select dates and select March 10, 2003.
 4. UnderSelect media servers, Phone is preselected.
 5. UnderCall parties, type the Called party, agent ID 2005.
 6. Click theCall types tab.
 7. UnderCall types, clear the check boxes for all of the criteria but Answer non ACD.
 8. Click theOptions tab.
 9. Under Time ranges, after the Start At time, type 9:00:00.
 10. Under Time ranges, after the End At time, type 12:59:59.
 11. Click Start search.

The SMDR Inspector results - SMDR Search results window opens.
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Options search results
The SMDR search results tab displays the call parties/call type/options results. All of the non-ACD calls
received by agent 2005 onMarch 10, 2004 between 9:00 A.M. and 1:00 P.M. are displayed. They included
external and internal calls where the caller dialed the agent’s extension (1106), and all of the dial zero calls.
(ACD calls are calls that are sent through the queue.) (See Figure 10 - 15.)

Figure 10 - 15 SMDR Search result - Options search

Running searches for error and information records
Using the Option tab you can run a search for error and information records. The error messages are records of
sequence errors. The information records are records of when the Collector restarts.

Previously, you ran a Call parties search for agent 2005, and then a Call types to include Answer non ACD
that occurred between 9:00 A.M. and 1:00 P.M.

To run an Exception event search
 1. Click the SMDR Inspector criteria tab.

TheOptions tab opens.
 2. Click theCall parties tab.
 3. Click Select dates and select March 10, 2003.
 4. UnderSelect media servers, Phone is preselected.
 5. UnderCall parties, type the Called party, agent ID 2005.
 6. Click theCall types tab.
 7. UnderCall types, clear the check boxes for all of the criteria but Answer non ACD.
 8. Click theOptions tab.
 9. Under Time ranges, after the Start At time, type 9:00:00.
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 10. Under Time ranges, after the End At time, type 12:59:59.
 11. UnderExceptions, select theError records and Information records check boxes.
 12. Click Start search.

The SMDR Inspector results - SMDR Search results window opens.

Exception search results
There was an information record produced every fiveminutes. Either the alarm is set incorrectly (the system
thinks it should be receiving data because the business hours indicate the business is open), or the
connection has died. The Exception results tab displays error and information records. (See Figure 10 - 16.)

The Exception search has the following results information:

Media server
TheMedia server box identifies the telephone system (with or without MiTAI) that produced the event record.

Record
The Data record box displays detailed information on the exception record.

Figure 10 - 16 SMDR search results - Exception results tab
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Wild card searches
NOTE:

l To search for a string of numbers within a digits dialed string, enclose the string of numbers in
parenthesis, such as “8905”. The search will produce records that include 8905 only in the digits dialed
string.

l To search for records where the calling, called or third party involved a trunk (BOTH T and X in one
search), put a C in the calling, called or third party box.

When performing searches on theQueue Events tab, you can enter aP800 under Queue information and the
search will produce records involving Queue 800 only. Alternatively, you can run wild card searches. When
you perform wild card searches, you use * to represent the wild card. For example, if you enter “*00” under
Queue information on theQueue events tab, the search will produce records for all of the Queues or Agent
groups that end in “00” (for example, 200, 300).

Exporting search results
You can save the ACD Inspector and SMDR Inspector search results in the following formats:

l HTML
l Microsoft Excel
l Microsoft Access
l XML
l Text

To export the search results
 1. Click Save search.

The Inspector Search Results Export window opens.
 2. Select the format in which you want the search results saved: HTML,Microsoft Excel,Microsoft

Access, XML, or Text.
 3. Click Next.
 4. Click the ellipses to select the location where you want to save the file.
 5. After File name, type the file name.
 6. Click Save.
 7. Click Next.
 8. Click Next to confirm the format in which you want to save the file and the location of the file.

A window opens with themessage “Inspector Search Results export to [export type] complete.”
 9. Click OK.
 10. Click Finish.

A window opens with themessage “Would you like to view/open this file now?”
 11. If you want to view the file immediately, click Yes.

The file opens.

Auditor
Using Contact Center Auditor you can view historical, multimedia real-time events, at your own pace. Auditor
makes it easy for you to analyze when and why past service problems occurred. You can see a series of
events that led to a problem and analyze when and why it occurred. In the future, you will be able to recognize
when another problem is about to occur.
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For example, you notice that on July 15 you have 12 contacts abandon between 10:00 AM and 10:15 AM. You
can review the contacts and the agents’ actions on that date for that time period with Auditor. Did all of the
contacts arrive at the same time? Did all of the agents go on break at the same time? If all of the contacts
arrived at once, you need to schedulemore people. If all of the agents went on break at the same time, you
need to adjust their break schedule.

Using Auditor you can also track when employees log on and log off the system. It is easy to determine if any
of the employees consistently start late or finish early.

With Auditor, you can use existing profiles, including alarm thresholds, when viewing past days run in real-
time.

In order to access Auditor, your security role must have the "May manage Auditor" option enabled.

The first tool bar consists of real-timemonitors that provide information on agent availability, queue statistics,
and graphic displays on queues. (See Figure 10 - 17.)

Figure 10 - 17 Auditor
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Auditor icons
Using Auditor’s second toolbar you select the date of the historical real-time events that you want to view and
the speed at which to play the events. The icons are described in Table 10 - 7.

Icon Term Meaning

Calendar You can select the date of the historical real-time events that you want to
view by clicking the calendar.

Speed of audit The Speed of audit is expressed as a ratio of real-time to play speed. You
can select the speed from a list of ratios that opens when you click the
clock: 1:1, 1:2, 1:5, 1:10, 1:30, 1:60, and 1:120. If you select the ratio1:1, it
will take you one second to view one second of the past day. If you select
1:60, it will take you one second to view oneminute of the past day.

Rewind If you click Rewind when the play is stopped, you jump back to the
beginning of the day.

Stop You can stop the real-time historical events from playing, and jump back to
the beginning of the day, by clicking Stop.

Pause You can pause the real-time historical events by clicking Pause.

Play You can play the real-time historical events by clicking Play.

Step forward You can select the increment (in seconds) you will advance from a list that
opens when you click the down arrow to the right of Step forward: 1 sec, 2
sec, 5 sec, 10 sec, 15 sec, 30 sec, and 45 sec. If you select 30 seconds,
then when the play is stopped, you can step forward in 30 second
increments each time you click Step forward. When you reach the end of
data for that day, you will automatically jump to the end of the day.

Jump forward You can select the increment (in minutes) you will advance from a list that
opens when you click the down arrow to the right of Jump forward: 1min, 2
min, 5min, 10min, 15min, 30min, and 60min. If you select 10minutes,
then when the play is stopped, you can jump forward in 10minute
increments each time you click Jump forward. When you reach the end of
data for that day, you will automatically jump to the end of the day.

Slider As you view the events of the day, the slider indicates the time at which
the events occurred. The length of the slider represents the length of the
day for which you are viewing historical real-time events.

Table 10 - 7 Auditor Icons
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Viewing historical real-time events
You start Contact Center Client to gain access to Auditor functionality. For more information on Contact
Center Client real-timemonitoring, see "Contact Center Client" on page 188.

To view historical real-time events, youmust
 1. Start Contact Center Client.
 2. Open the grids in which you want to view historical events.
 3. Start Auditor.

Starting Contact Center Client
Youmust start Contact Center Client before you can view Auditor.
To start Contact Center Client
 1. OpenContact Center Client.
 2. Type your user name and password.
 3. Click OK.

Opening monitors
NOTE: You cannot view the Contact Center Client marquee, Network Monitor, Interactive Visual Queue,
Contact Center PhoneSet Manager, or Contact Center Softphone applications (which function in real time
only) in Auditor.

Youmust open themonitors in which you want to view historical events with Auditor. In the following example
wewill open the Agent State by Positionmonitor.

To open amonitor in which to view historical events with Auditor
 1. In the Contact Center Client ribbon, click Real Time.
 2. Click Agent in theState by Position column in the ribbon.

The Add/Remove device IDs window opens.
 3. Select the agents or agent groups you want to monitor.
 4. Click OK.

Starting and using Auditor
NOTE: If you are using the Contact Center Client marquee, Network Monitor, Interactive Visual Queue,
Contact Center PhoneSet Manager, or Contact Center Softphone applications (which function in real time
only), open Auditor in another instance of Contact Center Client.

To start and use Auditor
 1. In the Contact Center Client ribbon, click Auditor Controls.
 2. Click Auditor Mode in the toolbar ribbon.

The Auditor toolbar displays.
See Figure 10 - 18.

 3. Click the calendar icon and select a date.
The date displays on the left of the slider.

 4. Click the speed icon and select the speed of the audit.
The speed of the audit, expressed as a ratio of real time to play speed, displays on the right of the speed
icon.

 5. Move the slider to select the time of day at which you want to start monitoring.
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 6. Click the play button to play the real-time events of the selected date.
The historical real-time events play at the speed you selected.

Figure 10 - 18 Auditor toolbar



Contact Center Solutions User Guide

- 342 -

Chapter 11

Data Collection

NetworkMonitor
Troubleshooting data collection issues
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Data Collection
The telephone system generates real-time and historical data used tomanage your contact center. You use
real-time data tomonitor the current Call Load and agent availability, andmakeminute-to-minute adjustments.
You use historical information for forecasting, staffing, and scheduling.

NOTE:
l Real time synchronization between the remote nodes and 5000/Axxess media servers is not

supported. All synchronization with remote 5000/Axxess telephone systems must be performed using
Synchronization in YourSite Explorer or manually.

l A single collection point can collect ACD/SMDR data from up to 65 voicemedia servers. If you are
attempting to collect data frommore than 65 PBXs with a single collection point, youmust contact
prairieFyre Technical Support at 613-599-0045 (North American customers) or your approvedMitel
vendor (for customers residing in Latin America, Europe, theMiddle East, Africa, and Asia pacific) for
guidance.

The Enterprise Server Collector Service writes SMDR and ACD data to text files. The text files are located on
the Enterprise Server in C:\Program Files\prairieFyre Software Inc\CCM\DataDirectory\Node_x

Network Monitor
The Network Monitor application resides in Contact Center Client. Network Monitor provides information on
the status of media server real-time data collection. You can verify if alarms are enabled for your media
servers and if themedia servers are reporting any alarms.

Viewing Network Monitor
NOTE:When you open Contact Center Client, it automatically points Network Monitor to the Enterprise
Server default IP address. If you havemore than one server at your site, ensure that Contact Center Client is
pointing to the correct server.

Network Monitor is available to users whose security permissions permit them to use Network Monitor.
To view Network Monitor
 1. Open Contact Center Client.
 2. If prompted, type your user name and password.
 3. Verify the Enterprise Server IP address.
 4. Click Log on.

The Contact Center Client window opens.
 5. Click Network Monitor in the Contact Center Client ribbon.
 6. Click the Network Monitor icon that opens in the toolbar.

When active, a green arrow displays.
The Network Monitor displays.
See Figure 11 - 1.
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Figure 11 - 1 Network Monitor

After you open Network Monitor, you canminimize it or close it. When you close Network Monitor, it resides
in the Network Monitor toolbar.

Opening the Network Monitor
After you view Network Monitor, you canminimize or close it. When you close Network Monitor, it resides in
the Network Monitor toolbar.

To open Network Monitor from the toolbar
l Double-click the Network Monitor toolbar.

Network Monitor opens.
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Viewing alarms
In Network Monitor, the Enterprise andMedia server windows display critical alarms and warning alarms.
Critical alarms are activated when Collector Service is not receiving data, the Enterprise Server disk space is
low, and in other instances where the Enterprise Server is prevented from functioning optimally. When there is
a critical alarm, Network Monitor displays the alarm and you are emailed a notification. Warning alarms are
activated when license violations occur, duplicate records are created, and for other non-critical issues. When
there is a warning alarm, the Network Monitor icon in the System Tray blinks.

The overall alarming state is displayed in Network Monitor with a circular, colored status indicator. The color
indicates the highest level of severity for all alarms currently alerting (Normal = Green, Minor = Yellow, Major
= Orange, Critical = Red, Unknown = Gray). If needed, you can click on the RSS Feeds link for more specific
alarm details.

NOTE:Youmust configure settings for your SMTP mail server in YourSite Explorer in order to receive alarm
notifications by email.

In YourSite Explorer, you can configure alarms to notify you if Collector Service is not receiving data or if the
server disk space is low. See "Configuringmedia server alarms" on page 95.)

The current alarm status displays in the Network Monitor ribbon, as illustrated in Figure 11 - 2.

Figure 11 - 2 Network Monitor - Current alarm status

To open Network Monitor from the toolbar
l Double-click the Network Monitor toolbar.

To view a summary of alarms and the status of the Enterprise Server
l In the Enterprise window, under Description, view if there are any critical alarms and if the Enterprise

Server is online.

To view the status of the alarms
l In theMedia servers window, view any Critical alarms andWarning alarms.

TheMedia Servers window displays all critical and non-critical alarms for themedia servers installed on
the Enterprise Server and Remote Servers.

To view data and system alarms with Administrative tools
l On the Enterprise Server, inWindows, navigate to theEvent Viewer to seemore information on the

error.
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Verifying media servers are receiving telephone system data
The Data link window displays the following information:

l SMDR/ACD displays SMDR/ACD records as they arrive from the telephone system.
l Records today displays the total number of SMDR/ACD records received by Collector Service for the

day that were valid SMDR or ACD records.
l Last received displays the date and time Collector Service received the SMDR/ACD record last sent.
l Clear records clears the records displayed on the Data links window.
l Reset SMDR link/Reset ACD link button resets the SMDR/ACD data link from the telephone system

to Collector Service when SMDR data stream/ACD data stream shows no data is streaming. If you
attempt to reset the link and data does not start streaming, check your cabling connections from the
telephone system to the TCP/IP sockets of the server.

To verify amedia server is receiving telephone system data
l In theMedia Servers window, under themedia server, click Data link.

The Data link window opens.
See Figure 11 - 3.

To reset the data links
 1. In theMedia Servers window, under themedia server, click Data link.

The Data link window opens.
 2. If no data is streaming in the SMDR or ACD panes, click Reset SMDR/ACD link.

Figure 11 - 3 Data link for the Intelligent Queue Server
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Configuring enterprise and media server alarm notifications
You can define alarms notifications that alert you when the Enterprise Server andmedia servers are not
functioning optimally. You can specify the severity of, and performance thresholds for each server
malfunction.

Client notifications are specific to each computer. You can be notified of enterprise andmedia server alarms in
several ways:

l A pop-up notification opens on your desktop.
l A sound prompt, such as a beep or .wav file, plays.
l You are notified by email.
l Contact Center Client opens on top of all open applications.

To configure notifications
 1. Add alarm thresholds.
 2. Specify threshold colors.
 3. Specify threshold notification.

Adding alarm thresholds
When configuring thresholds for alarms, youmust specify the following alarms as warnings rather than critical
alarms (because these alarms will always be warnings when they are active):

l No alarms configured
l PBX PC time drift
l ACD sequence number error
l Alarm outside of business hours
l Maintenance
l Intelligent QueueWatchdog Service is down
l Intelligent Queue low disk space
l Intelligent Queue has detected aMiTAI error

You configure all other alarms as critical because they will have a severity of critical when they are triggered.

In addition to configuring an alarm threshold with a severity of warning or critical (for a specific alarm), you can
configuring an alarm threshold with a severity of normal. Network Monitor then notifies you when the alarm is
cleared.

To add performance thresholds for enterprise andmedia server alarms
 1. In Network Monitor, right-click the Enterprise window (to configure enterprise alarm notifications) or the

Media server window (to configuremedia server alarm notifications) and select Set enterprise
notifications orSet media server notifications.
The Set alarms window opens.

 2. UnderDevices, select the enterprise server or one or more servers/media servers or select theSelect
all check box to select all servers/media servers.

 3. In thePerformance variables list, select an alarm type.
 4. UnderAlarm Thresholds, click Add value.
 5. Under Severity select Normal,Warning, orCritical.
 6. Click OK.
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Specifying threshold colors
To configure performance threshold colors
 1. For the alarm threshold for which you want to specify colors, underBackground, click the arrow.

A color palate opens.
 2. Select a color.
 3. Under Font color, click the arrow.

A color palate opens.
 4. Select the font color for the alarm threshold.
 5. Click OK.

Specifying threshold notification
To configure performance threshold sound notification
 1. For the alarm threshold for which you want to be notified by a sound, underSound, select the check

box.
The Sound window opens.

 2. Specify the alarm triggering properties.
 3. Specify the sound you want played when the alarm is triggered.
 4. Click Save.

To configure performance threshold pop-up window notification
 1. For the alarm threshold for which you want to be notified by a pop-up window, underPop-up, select the

check box.
The Pop-up window opens.

 2. AfterDuration, type the number of seconds you want the pop-up alarm to be displayed when threshold
conditions are satisfied.

 3. If you want to display the pop-up alarm on top of all of the other applications, select theKeep this
message visible on mouse over check box.

 4. Optionally, click the Format font button to specify font attributes for the pop-up alarm message.
 5. In the text box, type themessage for the performance threshold and click theAdd variable button to

insert performance variables. (for example, type CW P001 = <calls waiting variable>).
 6. Click Save.

To specify that Contact Center Client opens on top of all other applications when a performance threshold is
satisfied

l For the alarm threshold for which you want to be notified, underBring to front, select the check box.

To configure performance threshold email notification
 1. For the alarm threshold for which you want to be notified, or notify others by email, underEmail, select

the check box.
The Email window opens.

 2. AfterDistribution, specify which contacts are to be notified by email when threshold conditions are
satisfied.
See "Emailing reports" on page 282.

 3. AfterSubject, type the subject of the email to be sent (for example, type Calls Wtg in Sales Queue 1
>10!).

 4. In themessage box, type the body of the email.
 5. Click Save.
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Consider the threshold programming in Figure 11 - 4. When the number of agents available in the technical
support queue is between 0 and 2, the cell housing the Agents Available statistic is red. When the number of
agents available is between 3 and 4, the cell turns orange. When the number of agents available is 5 or
greater, the cell turns white. In addition, audible alarms and pop-up alarms display.

To clear any current client alarms in Contact Center Client
l Right-click themonitor and click Clear alarms.

Figure 11 - 4 Set alarms window

Troubleshooting data collection issues
If data is not being collected for a particular voicemedia server (has “timed out”), Network Monitor will display
the SMDR/ACD data collection timeout alarm.

There are several possible reasons why data does not stream. The following solutions address themost
common streaming problems:

SMDR data is not streaming
SMDR data records are generated at the end of calls. If SMDR data is not flowing through the TCP/IP
sockets, then the telephone system is not producing data records, your Class of Service and/or SMDR
Options Assignment forms are not configured correctly, or something is wrong with the TCP/IP sockets.
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If SMDR data is not streaming
 1. On a client computer or on the Enterprise Server, in Network Monitor, on the Data link window of the

telephone systemmedia server, click Reset SMDR Link to restore the connection.
 2. Wait 60 seconds.
 3. If you have an ethernet connection, verify it is up and running.
 4. If SMDR data is still not flowing, on the Enterprise Server, verify the SMDR Options and Class of

Service Options Assignment forms are configured correctly on the telephone system.
See theContact Center Management Installation Guide.

 5. If SMDR data is still not flowing, on the Enterprise Server, use a hyperterminal session to verify data is
flowing through the TCP/IP sockets.

 6. Restart Collector Service.
 7. If SMDR data is still not flowing, call prairieFyre software at 613-599-0045, option 3 (North American

customers) or your approvedMitel vendor (for customers residing in Latin America, Europe, theMiddle
East, Africa, and Asia Pacific).

ACD data is not streaming
ACD data records are generated with each agent event and with periodic refresh events produced by the
telephone system. If ACD data is not flowing through the TCP/IP sockets, then the telephone system is not
producing data records or something is wrong with the TCP/IP sockets.

If ACD data is not streaming
 1. On a client computer or on the Enterprise Server, in Network Monitor, on the Data link window of the

telephone systemmedia server, click Reset ACD Link to restore the connection.
 2. Wait 60 seconds.
 3. If you have an ethernet connection, verify it is up and running.
 4. If ACD data is still not flowing, on the Enterprise Server, use a hyperterminal session to verify data is

flowing through the TCP/IP sockets.
 5. Restart Collector Service.
 6. If ACD data is still not flowing, please call prairieFyre software at 613-599-0045, option 3 (North

American customers) or your approvedMitel vendor (for customers residing in Latin America, Europe,
theMiddle East, Africa, and Asia Pacific).

Viewing the data collection TCP/IP ports with Hyperterminal
You can use Hyperterminal to verify if data is flowing from the TCP/IP sockets.

To view the TCP/IP sockets with Hyperterminal
 1. On the Enterprise Server, stop Collector Service.
 2. Click Start=>Programs=>Accessories=>Communications=>HyperTerminal.
 3. Create a session (using the TCP/IP address displayed on the Data link window in Network Monitor) and

verify data is flowing through the TCP/IP sockets.

Restarting Collector Service
Youmust restart Collector Service after you view the TCP/IP sockets with Hyperterminal.

To stop Collector Service
 1. On the Enterprise Server, inWindows, navigate toServices.
 2. Right-click prairieFyre Collector Service (v5) and click Restart.
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Chapter 12

Interactive Contact Center

Using Interactive Contact Center
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Interactive Contact Center
Interactive Contact Center is an optional application that enables supervisors who have a 3300 ICP, 5000, or
Axxess telephone system to control the availability of agents and ACD queues. Agents can control their own
availability: they can log themselves on or off, and place themselves in or remove themselves fromMake
Busy or Do Not Disturb.

Using Interactive Contact Center
Interactive Contact Center is designed for agents and supervisors.

Supervisors and Interactive Contact Center
Using Interactive Contact Center, supervisors can

l Control the availability of agents and ACD queues
l Log agents on and off of the telephone system
l Remove agents from agent groups and place them into other agent groups. Agent groups are assigned

to queues so, in this way, agents can bemoved from one queue to another as needed
l Place agents in Make Busy
l Place agents in Do Not Disturb
l Place queues in DoNot Disturb

If an agent has multiple voice agent IDs, the agent can answer calls for multiple queues. In order to move the
agent from one queue to another queue, the supervisor logs off the agent and then logs on the agent using a
different agent ID.

You create associations between agents and queues in YourSite Explorer.

You can restrict individual supervisors frommanaging particular monitors and devices in Contact Center
Management, YourSite=>Security.

Agents and Interactive Contact Center
Using Interactive Contact Center, agents can

l Log themselves on and off of the telephone system
l Remove themselves from agent groups and place themselves into other agent groups. Agent groups

are assigned to queues so, in this way, agents canmove themselves from one queue to another as
needed

l Place themselves in Make Busy
l Place themselves in Do Not Disturb

You can restrict individual agents frommanaging particular monitors and devices in Contact Center
Management using YourSite Security.

Every time agents leave their desks they must set Make Busy or Do Not Disturb. There aremany reasons
why agents leave their desks. You assign each of these reasons aMake Busy or Do Not Disturb Reason
Code and then agents can apply the codes. When you run an Agent Performance by Make Busy / DND Code
report, the report clearly indicates when an agent went in Make Busy or Do Not Disturb, and why (which code
the agent selected each time).
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Starting Contact Center Client
You start Contact Center Client to access real-time functionality. Supervisors and agents can view real-time
voice statistics. In contact centers that have the optional Multimedia Contact Center application, supervisors
and agents can view real-time voice, email, chat, and fax statistics. After starting Contact Center Client, you
can choose tominimize it to either the system tray or the taskbar, depending on your operating system.

To start Contact Center Client
 1. OpenContact Center Client.

CAUTION:Do not select “Remembermy credentials” if you intend to work both at the office and from
home.

 2. If you use Secure Socket Layer, select SSL and click OK.

Agent control
Using Interactive Contact Center and Contact Center Client, you can control agents on the following
monitors:

l Agent State by Position and Employee State by Position
l Agent State by Time and Employee State by Time
l Agent Shift

Agent control gives you control over individual agents. Monitor control gives you control over all of the agents
on amonitor. All of the agents on themonitor are affected simultaneously by the action you take.

If you have Context Sensitivity enabled for monitors, the Agent Control andMonitor Control tabs display in the
Contact Center Client ribbon when you have any of the abovemonitors open. You can perform actions using
either a right-click and select method within themonitor or by selecting an agent or an empty cell (monitor
control) and accessing the actionmenu in the Agent or Monitor Control tab views. (See Figure 12 - 1.)

NOTE: Monitor control is available only if you configure extensions for your employees.
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Figure 12 - 1 Agent Shift - Agent Control tab options

Hiding the Monitor control option
When you right-click a device on a real-timemonitor amenu is displayed. If you have Interactive Contact
Center and you are permitted to use agent and queue control, you will see aMonitor control option on this
menu. If you do not useMonitor control, you can hide this option so it is not displayed on themenu.

To hide theMonitor control option
 1. In Contact Center Client, click theContact Center Client button=>Options.
 2. UnderDevice control, clear theDisplay monitor device control option check box.
 3. Click OK.
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Logging on an agent
NOTE:

l An ACD hot desking agent must enter an extension number each time the agents logs on to the
telephone system using Interactive Contact Center. The agent cannot rely on the extension number
last used when logging on. This is because the ACD data stream unifies the agent ID and the
extension. After a hot desking agent logs on or off of the telephone system using Interactive Contact
Center, sometimes the Interactive Contact Center agent controls are not available to the agent for two
to fiveminutes.

l Mitel 5000/Axxess agents that are logged on to all available queues are set to work timer. If they are
logged on to a single queue, they are set to idle.

l Youwill be unable to log in an agent to the ACD if there are no available 3300 ICP user licenses.
l If your contact center participates in the use of PINs, supervisors with the correct Class of Service do

not require an agent’s PIN to interactively log in a hot desking agent.
l Supervisors marked as Advanced supervisor or System Administrator will not be prompted to enter a

PIN when logging into Interactive Contact Center, Softphone, or PhoneSet Manager provided third
party call control is configured under security in the Contact Center Management website and on the
telephone switch.

In the following example wewill use the Agent State by Positionmonitor to illustrate Agent control.

To log on an agent
 1. In Contact Center Client, click View=>Real time to view the supervisor monitor icons.
 2. Click thePosition icon and click Agent State by Position.
 3. Select agents to monitor.
 4. Click OK.

Contact Center Client displays the devices across themonitor in the order you specified.
NOTE: The first time you log on an agent, youmust click By extension and specify the agent’s
extension number so Interactive Contact Center knows to which phone the agent is logged on.

 5. Right-click the cell of an agent who is logged off and click Agent control=>Log on=>By extension.
NOTE: If the agent being logged on is an external hot desking agent, click either the agent ID, the
agent's external number, or by extension.

 6. AfterAgent ID, select one of the agent’s agent login IDs.
 7. AfterAgent's extension, type the agent’s extension number.
 8. Click OK.

Logging off an agent
To log off an agent

l Right-click the cell of an agent who is logged on and click Agent control=>Log off. Alternatively,
select the agent cell in an openmonitor and click Log off from the Agent Control tab on the Contact
Center Client ribbon.

Logging off all of the agents on a monitor
To log off all of the agents

l Right-click themonitor and click Monitor control=>Log off. Alternatively, select an empty cell in the
monitor and click Log off from theMonitor Control tab of the Contact Center Client ribbon.
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Logging an agent out of one queue and into another queue
Employees can log out of one answer point and into another answer point if they havemultiple agent login IDs
that are associated with different answer points.

For example, Daniel Hobbs. has three Agent login IDs: 999, 1000, and 1001. They are associated with
Queues P007, P003, and P001 respectively. Queue P007 is associated with Spanish calls. Queue P003 is
associated with French calls. Queue P001 is associated with English calls. When the English call volume
increases, Daniel can log out of the Spanish Queue and into the English Queue. Figure 12 - 2 shows Daniel
logged in using Agent ID 1001.

To log Danielout of P007 and into P001
 1. Right-click themonitor.
 2. Click Agent control=>Log on. Alternatively, select the agent cell in an openmonitor and click Log in

from the Contact Center Client ribbon.
A list of available agent login IDs opens.

 3. Select 1001: Daniel Hobbs from the list.
Daniel is now handling English calls.

Figure 12 - 2 Logging an agent into another queue
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Agent Group Presence
If you have aMitel 3300 ICP (MCD 4.0 SP2 and 4.1 or greater) or 5000/Axxess telephone system, you can
add agents to and remove agents from one or more agent groups using Interactive Contact Center.

TheMitel 3300 ICP (MCD 4.0 SP2 and 4.1 or greater) enables agents to be placed in or removed frommultiple
agent groups (up to 16 on theMitel 3300MXe II Controller and up to 30 on theMitel 3300MXe server). Agents
can be added and removed from agent groups using Feature Access Codes (FAC), a Feature Access Key
(FAK) programmed on their set, or using Interactive Contact Center.

The agent group presence option is controlled by Class of Service. Once the appropriate Class of Service has
been set, the agent group presence status can be changed in the following ways.

l Feature access keys can be programmed on aMitel multiline phone set. One button would be used to
join or leave each agent group to which the agent is amember.

l Supervisors and agents can dial a feature access code followed by the group number to change their
status for that group or to change their status for all groups to which they are amember.

l The desktop tool in the embedded systemmanagement can be used tomake status changes.
l MiTAI controls are also available to make status changes.

Agent Group Presence has several licensing and configuration prerequisites:
l Youmust have purchased a Contact Center Standard Starter Pack license or greater to use Interactive

Contact Center. For more information on Contact Center Starter Packs, see theContact Center
Solutions and Call Accounting System Engineering Guide.

l For agents to use Agent Group Presence, Group Presence Control must be enabled for all agents on
the Class of Service Options Assignment form on theMitel 3300 ICP.

l For supervisors or system administrators to use Agent Group Presence, they must log into Contact
Center Client as a non-administrative user. They also require a valid employee license and an
associated device with Group Presence Control andGroup Presence Third Party Control enabled on
the Class of Service Options Assignment form on theMitel 3300 ICP.

l Real-timemonitoringmust be enabled in YourSite Explorer for all agents. For supervisors to control
agent group presence in Interactive Contact Center, the agent and at least one of the agent's dialable
numbers must be enabled for Real-timemonitoring. See "Adding agents" on page 131.

Agent Group Presence also requires that specific security roles be enabled:
l To control agent presence status in Interactive Contact Center, youmust enable “May change the real-

time presence states of agents in Interactive Contact Center”.
l To control supervisor presence status in Interactive Contact Center, youmust enable “May control my

real-time presence status in Interactive Contact Center”.

For more information, see "Configuring security roles" on page 181.

If the ACD Logout Agent No Answer Timer Class of Service option is enabled on your Mitel 3300 telephone
system, when an agent in an agent group fails to answer a call offered to them after the logout time expires,
the agent is logged out of their agent group. In an environment usingMCD 5.0 SP2 or greater, however,
agents who fail to answer an offered call before the logout time expires are removed by the telephone system
from their agent group.
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Agent group presence best practices
It is important to note that agents may join or leave agent groups but not queues. Agents become absent from
a queue indirectly if they leave all agent groups associated with that queue. An agent who is present in an
agent group which is associated to all queues would be disassociated from all queues simultaneously if they
became absent in their agent group. Since the goal of agent group presence is to provide a dynamic response
to varying queue activity, allowing agents to become absent from all queues simultaneously is
counterproductive.

As a best practice, we recommend you associate agent groups to queues based on business groups within
your organization. A unique agent group to business group queue(s) association allows agents who leave an
agent group associated to a particular business group to remain present in an agent group(s) associated to
other business group(s).

Adding agents to and removing agents from agent groups
After logging into Contact Center Client, agents use Interactive Contact Center to control their presence
status in agent groups. Optionally, supervisors can use Interactive Contact Center to control the presence
status of agents in specific agent groups.

NOTE:
l Agents must be Standard or higher to control their own Agent Group Presence. Basic Agents cannot

control their own Agent Group Presence.
l An agent's ACD hot desk line remains in service while they are logged in as an ACD hot desk user

even if they are not present in any ACD groups and not receiving ACD calls.
l For information on the configuration, licensing, and security role prerequisites that must bemet in order

to use Agent Group Presence, see "Agent Group Presence" on page 357.

To add an agent to or remove an agent from an agent group
 1. Right-click the cell of an agent who is logged on and click Agent control=>Join/Leave agent group.

Alternatively, select the cell of an agent and click Join/Leave agent group from the Agent Control tab
in the Contact Center Client ribbon.

 2. Select the agent group(s) to which you want to add the agent or from which you want to remove the
agent.

 3. Click OK.

Placing agents in Make Busy
To place an agent on amonitor in Make Busy

l Right-click the cell of an agent who is logged on and click Agent control=>Set Make Busy=>reason
code.Alternatively, select the agent cell in an openmonitor and click Set Make Busy from the Agent
Control tab in the Contact Center Client ribbon.

To place all of the agents on amonitor in Make Busy
l Right-click themonitor and click Monitor control=>Set Make Busy=>reason code.
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Removing agents from Make Busy
To remove an agent fromMake Busy

l Right-click the cell of an agent who is in Make Busy and click Agent control=>Remove Make Busy.
Alternatively, select the agent cell in an openmonitor and click Remove Make Busy from the Agent
Control tab in the Contact Center Client ribbon.

To remove all of the agents on amonitor fromMake Busy
l Right-click themonitor and click Monitor control=>Remove Make Busy. Alternatively, select an

empty cell in an openmonitor and click Remove Make Busy from theMonitor Control tab in the
Contact Center Client ribbon.

Placing agents in Do Not Disturb
NOTE:

l For the 5000/Axxess, Synchronizationmust be performed before DoNot Disturb with Reason codes
can be used by agents and supervisors.

l For the 5000/Axxess, if you set an agent to Do Not Disturb and do not enter any notes, clicking Cancel
on the DoNot Disturb Notes dialog box will place the agent in Do Not Disturb with no notes, without
canceling the DoNot Disturb state.

l If an agent in Make Busy sets and later removes DoNot Disturb on their extension, work timer will not
work until the agent either logs off the telephone system or until calls removeMake Busy on the
extension (even though the agent state is set to idle).

To place an agent in Do Not Disturb
l Right-click the cell of an agent who is logged on and click Agent control=>Set Do Not

Disturb=>reason code. Alternatively, select the agent cell in an openmonitor and click Set Do Not
Disturb from the Agent Control tab in the Contact Center Client ribbon.

To place all of the agents on amonitor in Do Not Disturb
l Right-click themonitor and click Monitor control=>Set Do Not Disturb=>reason code.

Alternatively,select an empty cell in an openmonitor and click Set Do Not Disturb from theMonitor
Control tab in the Contact Center Client ribbon.

Removing agents from Do Not Disturb
To remove an agent from DoNot Disturb

l Right-click the cell of an agent who is in Do Not Disturb and click Agent control=>Remove Do Not
Disturb. Alternatively, select the agent cell in an openmonitor and click Remove Do Not Disturb
from the Agent Control tab in the Contact Center Client ribbon.

To remove all of the agents on amonitor from DoNot Disturb
l Right-click themonitor and click Monitor control=>Remove Do Not Disturb. Alternatively, select an

empty cell in an openmonitor and click Remove Do Not Disturb from theMonitor Control tab in the
Contact Center Client ribbon.



Contact Center Solutions User Guide

- 360 -

Cancelling agents in Work Timer
To cancel an agent inWork Timer

l Right-click the cell of an agent who is inWork Timer and click Agent control=>Cancel Work Timer.
Alternatively, select the agent cell in an openmonitor and click Cancel Work Timer from the Agent
Control tab in the Contact Center Client ribbon.

To cancel all of the agents on amonitor inWork Timer
l Right-click themonitor and click Monitor control=>Cancel Work Timer. Alternatively, select an

empty cell in an openmonitor and click Cancel Work Timer from theMonitor Control tab in the
Contact Center Client ribbon.

Canceling the Reseize Timer for external hot desk agents
If an external hot desk user is unavailable (they are in a non-ACD call or off hook) and the ACD path attempts
to deliver a call to them the telephone system will initiate the Reseize Timer, preventing further ACD call
delivery attempts until the timer expires or is canceled by the agent or supervisor. Value settings for reseize
timers are aminimum of four seconds, a default of 180 seconds, and amaximum of 60minutes. These values
are configured on the telephone system. When an agent is in the Reseize Timer state, the applicable real-time
monitors in Contact Center Client display theMake Busy icon as well as text denoting the agent’s current
state as “Reseize Timer”.

To cancel an agent in the Reseize Timer state
l Right-click an agent that is in the Reseize Timer state and click Agent control=>Cancel Reseize

Timer. Alternatively, select the agent cell in an openmonitor and click Cancel Reseize Timer from the
Agent Control tab in the Contact Center Client ribbon.

To cancel all of the agents on amonitor in the Reseize Timer state
l Right-click themonitor and click Monitor control=>Cancel Reseize Timer. Alternatively, select an

empty cell in an openmonitor and click Cancel Reseize Timer from theMonitor Control tab in the
Contact Center Client ribbon.

Queue Control
Using Interactive Contact Center and Contact Center Client, you can control queues on theQueue Now
monitor.

You can control queues
l Manually
l Using a schedule
l Using aQueue control plan

Manually controlling queues
NOTE:

l You can see queue statistics during business hours as long as the business schedule you configure in
YourSite=>Schedule or YourSite Explorer=>Schedules is consistent with your company’s hours of
operation. You assign business-hours schedules to queues in
YourSite=>Configuration=>Queue=>Queue or in YourSite Explorer=>Queues=>Business Hours.

l Manual queue control overrides queue schedules and queue control plans.
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Interactive Contact Center Queue control enables you to control individual queues. Monitor control enables
you to control all of the queues on amonitor.

TheMonitor Options tab displays in the ribbon for the Queue Now monitor. You can perform actions using
either a right-click and select method in the openmonitor or by accessing the actionmenu in theMonitor
Options ribbon. (See Figure 12 - 3.)

Figure 12 - 3 Queue Now monitor - Monitor Options tab

Hiding the Monitor control option
When you right-click a device on a real-timemonitor amenu is displayed. If you have Interactive Contact
Center and you are permitted to use agent and queue control, you will see aMonitor control option on this
menu. If you do not useMonitor control, you can hide this option so it is not displayed on themenu.

To hide theMonitor control option
 1. In Contact Center Client, click theContact Center Client button=>Options.
 2. UnderDevice control, clear theDisplay monitor device control option check box.
 3. Click OK.
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Placing queues in Do Not Disturb
Usingmanual queue control, you can place queues in and remove queues from DoNot Disturb on the Queue
Now monitor. A call will not enter a queue that is in Do Not Disturb. The call is sent to an unavailable answer
point programmed in the telephone system.

To place a queue in DoNot Disturb
l Right-click the cell of an active queue and click Queue control=>Set Do Not Disturb. Alternatively,

select the queue in an openQueue Now monitor and click Set Do Not Disturb from theMonitor Option
tab in the Contact Center Client ribbon.
See Figure 12 - 4.

Figure 12 - 4 Placing a queue in Do Not Disturb

To place all of the queues on amonitor in Do Not Disturb
l Right-click themonitor and click Monitor control=>Set Do Not Disturb. Alternatively, select an open

Queue Now monitor and click Set Do Not Disturb from theMonitor Option tab in the Contact Center
Client ribbon.
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Removing queues from Do Not Disturb
To remove a queue from DoNot Disturb

l Right-click the cell of a queue that is in Do Not Disturb and click Queue control=>Remove Do Not
Disturb. Alternatively,select the queue in an openQueue Now monitor and click Remove Do Not
Disturb from theMonitor Option tab in the Contact Center Client ribbon.

To remove all of the queues on amonitor from DoNot Disturb
l Right-click themonitor and click Monitor control=>Remove Do Not Disturb. Alternatively, select an

openQueue Now monitor and click Remove Do Not Disturb from theMonitor Option tab in the
Contact Center Client ribbon.

Controlling queues using a schedule
A Queue control schedule opens queues during business hours and closes queues after business hours.

Scheduling queues to enter or leave Do Not Disturb
Using a schedule, you can place queues in and remove queues from DoNot Disturb on the Queue Now
monitor.

To schedule a queue to enter or leave DoNot Disturb
 1. Click YourSite=>Configuration.
 2. On theConfiguration menu, click Queue=>Queue.
 3. Across from a 3300 ICP/5000/Axxess queue, click Edit.
 4. On the Interactive Contact Center Queue control tab, after Interactive Contact Center Queue

control schedule, select a schedule.
 5. Click Manage schedule.
 6. Click Edit schedule orCreate a new schedule.

You can edit the default 24/7 schedule or you can click Create new schedule to create a new schedule.
 7. If you are creating a new schedule, afterName, type the name of the schedule.
 8. Specify the time you want the queue to enter and leave DoNot Disturb.

For example, your business opens onMonday at 9:00 A.M. and closes on Friday at 5:00 P.M. You
select a start time of 9:00 A.M for the days Monday to Friday. You select an end time of 5:00 P.M for
the days Monday to Friday. For Saturday and Sunday you select Disable for day. Your queues will be in
Do Not Disturb at all times except for Monday to Friday, from 9:00 A.M. to 5:00 P.M.

 9. Click Apply schedule.

Controlling queues using Queue control plans
NOTE:Youmust install Interactive Contact Center before you can use Interactive Contact Center Queue
control.

If you have a 3300 ICP/5000/Axxess, using Queue control plans, you can place queues in and remove queues
from DoNot Disturb automatically based on predefined criteria. Each queue control planmonitors one queue,
and based on the activity of the queue, either places a queue in or removes a queue from DoNot Disturb.
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Creating Queue control plans
Queue control plans open and close queues based on plan parameters only during business hours. Each
queue is controlled by only one queue control plan at a time. You can apply the same queue control plan to
several queues. For information on how to create queue control plans, see "Managing a queue control plan
(3300 ICP)" on page 140.
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Chapter 13

Interactive Visual Queue

Using Interactive Visual Queue



Contact Center Solutions User Guide

- 366 -

Interactive Visual Queue
Interactive Visual Queue is a Contact Center Client real-timemonitor that works in conjunction with Contact
Center Management and Interactive Contact Center. Interactive Visual Queue comprises aQueued calls grid
and an Abandoned calls grid. In the Queued calls grid, supervisors and agents can view calls within queues
and then use a drag-and-drop operation tomove calls from busy queues to less active queues. In the
Abandoned calls grid, supervisors can view abandoned call information, including the caller name, phone
number, and time of the abandoned call. Agents can use the Abandoned calls grid to call back abandoned
callers.

Using Interactive Visual Queue
Interactive Visual Queue works in conjunction with Contact Center Management. Before you use Interactive
Visual Queue youmust configure options in Contact Center Management so they mirror those of the 3300
ICP, 5000, or Axxess telephone system.

NOTE: In order to use Interactive Visual Queue, youmust enable all HCI options on Class of Service
Assignment form 1 (COS 1).

Configuring options in Contact Center Management
In YourSite Configuration, for each queue you want to monitor, youmust configure the priority level and the
method for handling interflowed calls. The values you configuremust match the values specified on the Path
Assignment form of your telephone system.

NOTE: The YourSite Configuration settings for Interactive Visual Queuemonitors do not affect call flow
activity on the actual queues. These settings only affect the way Interactive Visual Queue displays the queue
monitors in Contact Center Client. If you want to modify call flow on the actual queues, youmust change the
telephone system settings.

If the telephone system settings and Interactive Visual Queue settings do not match, Interactive Visual
Queue will not display the correct call activity. For example, if Queue 1 is set to a priority of 10 on the
telephone system and a priority of 20 in YourSite Configuration, Interactive Visual Queue will display calls in
Queue 1 as priority 20. However, the actual queue will handle the calls as priority 10.

Starting Contact Center Client
Interactive Visual Queue resides in Contact Center Client.

To start Contact Center Client
 1. OpenContact Center Client.
 2. Type your user name and password and verify the Enterprise Server IP address.
 3. If you use Secure Socket Layer, select SSL.

CAUTION:Do not select “Remembermy credentials” if you intend to work both at the office and from
home.

 4. Click Log on.
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Opening Interactive Visual Queue
You access Interactive Visual Queue by logging on to Contact Center Client and then opening the Real-time
toolbar.

To open an Interactive Visual Queuemonitor
 1. Log on to Contact Center Client.
 2. In the Contact Center Client ribbon, click Real time.
 3. Click Interactive Visual Queue.

The Add/Remove device IDs window opens.
 4. Select a queue from theQueues list and click OK.

See Figure 13 - 1.
NOTE:

l Virtual queue groups are shown in the Queue groups list.
l To use Interactive Visual Queue effectively, you should open two or more queuemonitors.

Figure 13 - 1 Interactive Visual Queue monitor
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Interactive Visual Queue monitor grids
The Interactive Visual Queuemonitor comprises the Queued calls grid and the Abandoned calls grid. The
Queued calls grid lists the calls that are currently in the selected queue. The Abandoned calls grid lists
abandoned calls.The calls are listed in order of priority, and the columns cannot be sorted. You can configure
the column headings and specify which columns are displayed.

NOTE: The abandoned calls column in the Interactive Visual Queuemonitor displays all abandoned calls,
whereas, the abandoned column in the Queue Now monitor does not peg short abandons as abandoned calls.
Because of this difference, youmay notice discrepancies between the abandoned call information in these
twomonitors.

The following list provides descriptions of the column headings available in the Queued calls grid:
l Position (#) displays the answer position relative to other calls in the queue
l Caller Number is the originating phone number of the call
l Caller Name is the name associated with the phone number (if available)
l Priority is the priority of the call in the queue (the lower the number, the higher the priority)
l TimeOffered to Queue is the time the call entered the current queue
l Time in Queue is the call's total time in the current queue
l TimeOffered to System is the time the call first entered the system
l Time in System is the call's total time in the system
l Queue Hops is the number of times a call has changed queues
l Call ID is a unique identification number that is assigned to the call by the telephone system
l DNIS Number displays the DNIS identification number associated with the digits dialed by the

customer, as configured in Contact Center Management
l DNIS Name displays the name you have configured in Contact Center Management for the associated

DNIS number
l Collected Digits displays the customer-entered digits provided by Intelligent Queue. Collected digits

requires Intelligent Queue and Collect Caller-entered Digits or Verified Collected Digits and, optionally,
Remote Database Verification or CTI Developer Toolkit

l Collected Information displays the single or series of collected results provided by Intelligent Queue.
Collected information requires Intelligent Queue and Verified Collected Digits and, optionally, Remote
Database Verification or CTI Developer Toolkit

The following list provides descriptions of the column headings available in the Abandoned calls grid:
l Caller Number is the originating phone number of the call
l Caller Name is the name associated with the phone number (if available)
l Time Abandoned is the time at which the caller abandoned the queue
l Time Since Abandoned is the elapsed time since the caller abandoned the queue
l Last Callback Employee is the employee name and employee ID associated with themost recent

callback attempt
l Last Callback Time is the time at which themost recent callback was attempted
l Time Since Last Callback is the elapsed time since themost recent callback attempt
l TimeOffered to Queue is the time the call entered the queue
l Time in Queue is the call's total time in the queue
l TimeOffered to System is the time the call first entered the system
l Time in System is the call's total time in the system
l Queue Hops is the number of times a call has changed queues
l Call ID is a unique identification number that is assigned to the call by the telephone system
l DNIS Number displays the DNIS identification number associated with the digits dialed by the

customer, as configured in Contact Center Management
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l DNIS Name displays the name you have configured in Contact Center Management for the associated
DNIS number

l Collected Digits displays the customer-entered digits provided by Intelligent Queue. Collected digits
requires Intelligent Queue and Collect Caller-entered Digits or Verified Collected Digits and, optionally,
Remote Database Verification or CTI Developer Toolkit

l Collected Information displays the single or series of collected results provided by Intelligent Queue.
Collected information requires Intelligent Queue and Verified Collected Digits and, optionally, Remote
Database Verification or CTI Developer Toolkit

Redirecting calls
A call canmove between queues automatically (interflow) or manually (redirection).

Interflow
You can configure queue settings on the telephone system to automatically move a call from one queue to
another after a specific duration. For example, you can configure your system tomove a call from Queue 1 to
Queue 2 if the call has not been answered within 30 seconds. Interflow occurs without any user interaction.

Redirection
Using Interactive Visual Queue, you canmanually redirect a call from a queue to another queue or a dialable
number.

There are two ways a call can be removed from the system. If a call is movedmore than 10 times, either by
redirection or by interflow, the call is dropped from the system. You can see the current number of times a call
has moved between queues in the Queue Hops column. A call will also be automatically removed from the
system if its total time in the system exceeds 24 hours. The Total Time column lists the call’s duration in the
system.

You canmanually redirect a call in the Queued calls grid using the followingmethods:
l Drag and drop a call between queues.
l Use the right-click menu tomove a call between queues.
l Use the right-click menu to send a call to a specific dialable number (for example, an extension,

callback port, or voicemail port).

Youmay notice that the first twomethods perform the same action. However, the secondmethod is
convenient when queuemonitor is maximized and you want to move a call without having to resize one or
moremonitors.

NOTE: If you right-click a call and redirect it to a specific extension, the call will no longer be considered an
ACD call for reporting purposes. If you redirect a call using either of the other twomethods, the call remains an
ACD call.

When youmanually redirect (drag and drop) a call in Interactive Visual Queue, Contact Center Management
changes the way the call is pegged on theQueue Performance reports. If you redirect a call before the short
abandon time set for the queue, the call is pegged as Unavailable. If you redirect a call after the short abandon
time set for the queue, the call is pegged as Interflowed. An internal ACD call is pegged as Abandoned if the
call is redirected at any time.
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Redirecting calls between queues
To redirect a call from one queue to another queue using a drag-and-drop operation
 1. In the Queued calls grid, click anywhere in the row of the call you want to move.
 2. Use a drag-and-drop operation tomove the call from its original queuemonitor to a new queuemonitor.

To redirect a call from one queue to another queue using themenu
 1. In the Queued calls grid, right-click the row of the call you want to redirect and click Send to.

A list of available queues appears.
NOTE:You can select multiple rows tomovemultiple calls to a new queue.

 2. Click the name of the queue to which you want to move the call.

Redirecting calls to specific numbers
Using the Send tomenu option, you can redirect calls in Interactive Visual Queue to any extension. In
addition, if you have Contact Center Softphone installed, you can send a call directly to your own extension by
selecting Send to=>Me.

To redirect a call to a dialable number
 1. In the Queued calls grid, right-click the row of the call you want to redirect and click Send

to=>[Extension].
When you click [Extension], it changes to a text box.

 2. Type a number in the text box and press Enter.
See Figure 13 - 2.
NOTE:You cannot use the Extension option if you havemultiple calls selected. Only one call can be
sent to a dialable number at a time.
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Figure 13 - 2 Redirecting a call to an extension

To redirect a call to your extension
 1. In the Queued calls grid, right-click the row of the call you want to redirect.
 2. Click Send to=>Me

NOTE: This option is not available unless you have Contact Center Softphone installed and configured
on your computer.

Removing calls
To remove a call from Interactive Visual Queue
 1. Right-click the row of the call you want to remove.
 2. Click Delete.

The call is removed from Interactive Visual Queue.

NOTE:Deleting a call from an Interactive Visual Queuemonitor will not remove it from the actual queue. This
will just cause Interactive Visual Queue to stop tracking the call.
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Calling back abandoned callers
The Abandoned calls grid displays abandoned call information and enables agents to call back abandoned
callers.

NOTE:
l If you want Interactive Visual Queue to automatically insert 1 when calling back long distance phone

numbers, youmust program your telephone system ARS accordingly. For more information, see the
Mitel 3300 ICP System Administration Tool Help.

l Abandoned call information is automatically deleted from the Abandoned calls grid after 24 hours.
l Abandoned calls can not be transferred to agents.

To call back an abandoned caller
 1. Right-click the row of the abandoned call you want to call back, and select Call to automatically dial the

abandoned caller.
NOTE:Each time an agent attempts to call back an abandoned caller, their name and ID are attached
to the call record and display in the Last callback employee column of the Abandoned calls grid.

 2. After you have contacted the abandoned caller, right-click the row associated with that call, and select
Delete to remove the abandoned call record from the Abandoned calls grid.

Configuring alarms
You set alarms on Interactive Visual Queuemonitors similar to the way you set alarms on Contact Center
Client monitors. Themain difference is that some of the variables you canmonitor, Caller Number, Caller
Name, DNIS Number, DNIS Name, Collected Digits, and Collected Information, use a string for their value
as opposed to a threshold boundary. For example, you can set an alarm that is triggered when a specific name
appears in the Caller Name column.

The value you type for Caller Number or Caller Name alarms is a wildcard, whichmeans the alarm will trigger
if that value appears in any form. For example, if you configure a Caller Name alarm for the value John, the
alarm will trigger for the values John Smith, Johnathan, longjohn, and so on.

To configure alarms:
 1. Right-click an Interactive Visual Queuemonitor and click Set alarms.

The Set Alarms window appears.
 2. UnderPerformance variables, select the variable you want to monitor.
 3. UnderAlarm thresholds, click Add value and select a boundary (or value) for the variable you

selected as well as the alarm type(s) that will indicate when the variable exceeds those boundaries.
For more information on configuringmonitor alarms, see "Setting alarms" on page 236.

 4. If you want to add further alarms for the variable, repeat step 3.
 5. Click OK to save the alarms.

Understanding call priority
Each queue has a default priority level. When a call enters the system for the first time, the call adopts the
default priority of whichever queue it enters. If all calls in a queue have the same priority, the position of the
calls are based on each call’s total time in the current queue. If a queue contains calls that havemultiple
priority levels, higher priority calls will have a higher position in the queue than lower priority calls.

As long as a call remains in a queue, it maintains its priority. However, if a call moves from one queue to
another queue, the call’s priority may change, based on themethod used tomove the call.
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When you redirect a call manually, the call always adopts the default priority level of the destination queue.
For example, supposeQueue 1 has a priority of 1 andQueue 2 has a priority of 15. When a call first enters
Queue 1, it has a priority of 1. However, if youmanually move that call to Queue 2, using either a drag-and-
drop operation or the right-click menu, the call priority lowers to 15. The rules work the same in reverse. If you
manually move a priority 15 call from Queue 2 to Queue 1, the call priority increases to 1 when it enters Queue
1.

Calls interflowed automatically retain the original call priority, or adopt the priority of the new queue based on
telephone system settings. The interflow options you specify for a queue in YourSite Explorer must be
identical to those of the telephone system. For more information on configuring interflowed calls, see "Adding
queues" on page 135.
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Chapter 14

Contact Center PhoneSet Manager

and Contact Center Softphone

Using Contact Center PhoneSet Manager
and Contact Center Softphone
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Contact Center PhoneSet Manager and Contact
Center Softphone
The Contact Center PhoneSet Manager and Contact Center Softphone applications are designed for the 3300
ICP telephone system. They provide ACD agent functions and enable agents to use their desktop computers
as IP-based phones.

NOTE:
l Soft phone is not supported on the Enterprise Server.
l Interactive Contact Center is required to control the availability of agents and ACD queues. See

"Interactive Contact Center" on page 352.
l External hot desking agents are supported for use with Contact Center PhoneSet Manager only.

Using Contact Center PhoneSet Manager and Contact
Center Softphone
Contact Center PhoneSet Manager and Contact Center Softphone enable agents to use their desktop
computers as IP-based phones. Contact Center PhoneSet Manager automates Mitel IP phone sets from the
computer desktop. An agent who uses Contact Center PhoneSet Manager has a headset connected to a desk
phone. Contact Center Softphone provides complete phone set functionality from the computer desktop. A
computer and wired or wireless USB headset deliver calls to the agent.

Starting Contact Center Client
Contact Center Softphone and Contact Center PhoneSet Manager reside in Contact Center Client.

Tested headsets
Wehave tested the following headsets to confirm they work with Contact Center PhoneSet Manager:

l GN Netcom GN 6120 Bluetooth office headset—wireless (part number GN 6120)
l Plantronics SupraPlus Noise-Canceling—monaural (part number H251N)
l Plantronics SupraPlus Noise-Canceling—binaural (part number H261N)
l GN NetcomMonaural over-the-head, SoundTube clarity (part number GN 2110 ST)
l GN Netcom Binaural over-the-head, SoundTube (part number GN 2115 ST)

NOTE: In order for the Plantronics andGN Netcom headsets to work with Contact Center PhoneSet Manager
youmust have the correct amplifier adaptor for theMitel phones.

We have tested the following headsets to confirm they work with Contact Center Softphone:
l Plantronics DSP PC 500—binaural (part number DSP 500)
l Plantronics CS50Wireless Office Headset System (part number CS50)
l Plantronics SupraPlus Noise-Canceling—monaural (part number H251N)
l Plantronics SupraPlus Noise-Canceling—binaural (part number H261N)
l GN NetcomMonaural over-the-head, SoundTube clarity (part number GN 2110 ST)
l GN Netcom Binaural over-the-head, SoundTube (part number GN 2115 ST)

NOTE: In order for the Plantronics andGN Netcom headsets to work with Contact Center Softphone you
must have the correct USB adaptor.
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USB-to-headset adaptors
For Contact Center Softphone, the Plantronics H251N and H261N and theGN Netcom GN 2110 ST andGN
2115 ST headsets must be connected to your computer by a USB-to-headset adaptor. We have tested the
following USB-to-headset adaptors to confirm they work with Contact Center Softphone:

l Plantronics DA60 USB-to-Headset Adaptor (part number DA60)
l GN Netcom USB-to-headset adaptor (part number GN 8110)
l GN Netcom USB-to-headset adaptor (part number GN8120)

You can integrate the GN 8120 with Contact Center Softphone and use the three different function buttons on
theGN 8120 to perform specific functions in Contact Center Soft phone. Table 14 - 1 shows theGN 8120
button functions.

Button State Action

Blue volume
control

Any state Increases or decreases the
headset speaker volume, which
controls the volume at which you
can hear a caller

White button Any state Turns themute function on or off

Green button Incoming call is ringing on one of your line
appearances

You are currently talking to someone and you do not
have anyone on consultation hold

You are currently talking to someone and you have
someone on consultation hold

Answers a call

Hangs up a call

Performs a swap with the party
on hold

Red button You are currently talking to someone, and you do not
have anyone on consultation hold

You currently have someone on hold

You are currently talking to someone and you have
someone on consultation hold

Places the current call on hold

Retrieves the call on hold

Cancels the current call and
returns you to the party on hold

Table 14 - 1 GN 8120 button functions

Table 14 - 2 shows situations where the LEDs will be lit or flashing based on the state of Contact Center
Softphone.
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What you are doing GN 8120 LED displays

All lines are idle, and themute function is off All LEDs are off

Themute function is on Blue LED above the white button is on

A call is ringing Green LED above green button is flashing

You are currently dialing, waiting for an answer, or
talking to someone, and you do not have anyone on
hold

Green LED above green button is on

You are currently talking to someone, and he has put
you on hold

Green LED above green button is flashing

You put someone on hold Red LED above red button is on

You are currently talking to someone, and you have
someone on consultation hold

Green LED above green button is on
Red LED above red button is flashing

Table 14 - 2 GN 8120 LED displays

Integrating the GN 8120 with Contact Center Softphone
To integrate the GN 8120 with Contact Center Softphone
 1. Log on to Contact Center Client.
 2. On themainmenu, click View=>Soft phone.
 3. Click Soft phone.
 4. After Input audio device, choose the GN 8120.
 5. AfterOutput audio device, choose the GN 8120.
 6. Click OK.

For more information about the GN 8120, visit the product page onGN Netcom’s website at
http://www.gnnetcom.com/US/EN/MainMenu/Products/Computer-VoIP/GN8120USB.htm.

Setting up the soft phone
The functionality of Contact Center PhoneSet Manager and Contact Center Softphone is similar. For
simplicity, we will use soft phonewhen referring to features and functionality common to both applications.

NOTE:
l Before you set up the soft phone on your client computer, ensure your network administrator has

configured your soft phone as a 5020 IP phone on the telephone system.
l Users who are upgrading to Contact Center Management Version 6.0 or greater must uninstall

MiAUDIODesktop Edition before they use Contact Center Softphone. MiAUDIO is now bundled in the
Contact Center Management software and no longer runs as the IP Phone Emulation Service.

l Although Inter-Tel users can log in tomultiple extensions simultaneously, this functionality is not
currently supported by Contact Center Solutions applications.



Using Contact Center PhoneSet Manager and Contact Center Softphone

- 378 -

To set up a client computer to use the soft phone
 1. Consult your network administrator to confirm your soft phone extension number.
 2. Ensure your headphone is connected.
 3. Configure sound and audio device properties.

See "Configuring sound and audio device properties" on page 378.
 4. Run Client Component Pack.

See "Installing the latest version of Client Component Pack" on page 37.

Configuring sound and audio device properties
To configure sound and audio device properties forWindows XP and Vista operating systems, youmust set
the PC speakers as the default audio device and adjust the volume of the PC speakers, headset speakers,
and headset microphone.

Configuring sound and audio device properties for Windows Vista
The following procedures describe how to configure sound and audio device properties forWindows Vista.

To set the PC speakers as the default audio device
 1. In Control Panel, double-click Sound to open the Sound dialog box.
 2. Select thePlayback tab.
 3. Click theSpeakers icon.
 4. Click theSet Default button.
 5. Click OK to save the Speakers as your default device.

This enables your PC speakers to be used as the default audio device, so when you receive calls on
the soft phone, the ring tone plays through your headset and your PC speakers.

To adjust the PC speaker volume
 1. In Control Panel, double-click Sound to open the Sound dialog box.
 2. Select thePlayback tab and double-click theDigital Output Device icon.
 3. Select the Levels tab and adjust the PC speaker volume by moving theDigital Output Device volume

slider from left to right.
 4. Click OK to save your volume setting.
 5. Click OK to close the Sound dialog box.

To adjust the headset speaker volume
 1. In Control Panel, double-click Sound to open the Sound dialog box.
 2. Select thePlayback tab and double-click theSpeakers icon.
 3. Select the Levels tab and adjust the headset speaker volume by moving theAudio output volume

slider from left to right.
 4. Click OK to save your volume setting.
 5. Click OK to close the Sound dialog box.

To adjust the headset microphone volume
 1. In Control Panel, double-click Sound to open the Sound dialog box.
 2. Select theRecording tab and double-click theMicrophone icon.
 3. Select the Levels tab and adjust the headset microphone volume by moving theMicrophone volume

slider from left to right.
 4. Click OK to save your volume setting.
 5. Click OK to close the Sound dialog box.
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Configuring sound and audio device properties for Windows XP
The following procedures describe how to configure sound and audio device properties forWindows XP.

To set the PC speakers as the default audio device
 1. In Control Panel, double-click Sounds and Audio Devices.
 2. Select theAudio tab and select your sound card device from theDefault device drop-down under

Sound playback.
This enables your PC speakers to be used as the default audio device, so when you receive calls on
the soft phone, the ring tone plays through your headset and your PC speakers.

 3. Click OK to save your settings.

To adjust the PC speaker volume
 1. In Control Panel, double-click Sounds and Audio Devices.
 2. Select theVolume tab and adjust the PC speaker volume by moving theDevice volume slider from left

to right.
 3. Click OK to save your settings.

To adjust the headset speaker volume
 1. In Control Panel, double-click Sounds and Audio Devices.
 2. Select theVoice tab and select your headset device from theDefault device drop-down list under

Voice playback.
 3. Click theVolume button, located underVoice Playback.
 4. Adjust the headset speaker volume by moving theVolume slider, located underSpeaker, up or down.
 5. Click OK to save your settings.

To adjust the headset microphone volume
 1. In Control Panel, double-click Sounds and Audio Devices.
 2. Select theAudio tab and select your headset device from theDefault device drop-down list under

Sound recording.
 3. Click theVolume button, located underSound recording.
 4. Adjust the headset microphone volume by moving theVolume slider up or down.
 5. Click OK to save your settings.

Opening the soft phone
To open the soft phone
 1. In the Contact Center Client ribbon, click Soft Phone
 2. Click theSoft Phone icon in the toolbar ribbon.

The Soft phone configuration window opens.
See Figure 14 - 1.
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Figure 14 - 1 Soft phone configuration window

 3. Click Add Extensions to search and select from all internal standard extensions, hot desk extensions,
and external hot desk user extensions.

 4. Click Add External Agents to search and select from all external hot desk agent extensions.
 5. Select your phone extension from the list of extensions.

NOTE:Although Inter-Tel users can log in tomultiple extensions simultaneously, this functionality is
not currently supported by Contact Center Solutions applications.

 6. If you have Contact Center PhoneSet Manager, click Desk phone. If you have Contact Center
Softphone, click Soft phone.

 7. If you want to log on automatically to the soft phone with your phone extension the next time you open
the current profile, select theRemember my extension check box.
Youmust save the current profile before you quit the soft phone for this option to work.
If you are a hot desk user who participates in the use of PINs, the PIN login dialog box opens. If you are
a hot desk user who does not participate in the use of PINs, go to step 10.
NOTE:When logging in as an external hot desking agent or a hot desking user who is not set up to use
a PIN login, if the PIN entry window displays, do not enter a PIN; just click Login.

 8. Type your Login PIN.
If you want Contact Center Client to remember your Login PIN, select the Remember your credentials
check box. This option is not available if your Contact Center Client profile is shared.
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 9. Click Login.
NOTES:

l If the Login PIN you entered is invalid the login will fail and you will be asked to enter a valid
Login PIN.

l Advanced supervisor or System Administrator will not be prompted to enter a PIN provided third
party call control is configured under security in the Contact Center Management website and on
the telephone switch.

 10. If you want Contact Center Client to be the top-most window on ringing, select theBring to front on
ringing check box.

 11. If you want Contact Center Client to not display the screen pop window when calls are ringing on the
desktop, enable theDisable toaster on ringing check box.

 12. If you selected Soft phone in step 6, underSoft phone settings, configure soft phone options.
 13. AfterAddress book source for contacts, select YourSite contacts orOutlook contacts.

Contact Center PhoneSet Manager and Contact Center Softphone users can access YourSite
database phone extensions or Outlook Personal Contact or Global Address List phone numbers when
they handle calls.

 14. To automatically log off the agent from the telephone system when closing the soft phone, select the
Automatically log off this ACD agent when closing the soft phone check box.

 15. If you want to synchronize online presence indicators with ACD agent states in real-timemonitors,
select theSynchronize my Lync presence with my ACDstate check box.

 16. If you want to display call notes on the soft phone display and on the Call Notes monitor, ensure the
Display call notes check box is selected.

 17. Click OK.
The Contact Center Client window displays the soft phone, Phone and Functions toolbars.
See Figure 14 - 2.

Figure 14 - 2 Soft phone toolbars

 18. If you want to be able to position the soft phone toolbar elsewhere on your desktop, enable the Float
check box.

 19. Tomove the soft phone toolbar, hover themouse over the perforated line on the left-side of the toolbar
until the four-headed arrow displays. Then click, drag, and drop it to the desired position on your
desktop. To reanchor the toolbar to the ribbon, drag and drop it into position under the ribbon.

 20. If you want to modify the soft phone configuration, click theConfiguration icon in the toolbar to reopen
the Soft phone configuration window.

Thumbnail soft phone toolbar
The thumbnail soft phone toolbar enables agents to quickly perform soft phone actions when other
applications are open on the desktop. The thumbnail toolbar gives agents access to Answer, Hang up,
Cancel, and Dial functions and is particularly helpful when the Contact Center Client application is minimized
and you want to perform a quick soft phone action. To see the toolbar options, hover over it with your mouse.
(Figure 14 - 3.)
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Figure 14 - 3 Thumbnail soft phone toolbar

NOTE:
l The thumbnail soft phone toolbar is supported withWindows 7 orWindows 2008 operating systems

only.
l Because of Windows limitations, this toolbar may not always display when Contact Center Client has

focus on the desktop.

Logging on to the ACD
Agents can log on to the ACD a number of ways, such as selecting the Superkey button in Contact Center
Softphone, or using the agent control function in Interactive Contact Center. See "Contact Center PhoneSet
Manager and Contact Center Softphone" on page 375.

We recommend that soft phone users who are hot desking agents log on to the ACD using the soft phone
Actions menu. This enables the soft phone to identify agents.

NOTE: If you are an external hot desking agent or a hot desking user who logged in internally, logged out, and
then chose to log back in externally, you will not be able to log on with the soft phone Actions menu. In order to
access this functionality, youmust first close and reopen the soft phone toolbar (View=>Deselect and
reselect the soft phone option).

To log a standard agent onto ACD
l On the soft phone Functions toolbar, click Actions=>Log on and select an agent ID.

To log an external hot desking user onto ACD
l On the soft phone Functions toolbar, click Actions=>Log on=>Hot Desking Users.

To log an external hot desking agent on to ACD
l On the soft phone Functions toolbar, click Actions=>Log on=>Agent ID.

NOTE:When a hot desk agent logs in to the ACD a 3300 ICP user license is taken from the available
licensing pool and when the agent logs out the license is released back to the licensing pool. Agents are
notified upon login attempt if the number of concurrent logins exceeds the number of available user licenses. If
there are no available user licenses the login attempt will fail.
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Phone and Functions toolbars
The Phone toolbar displays your

l Extensions (grey oval buttons)
l Hold button (red oval button)
l Superkey button (blue oval button, for Contact Center Softphone only)
l Current phone state (Idle, Dialing, Talking) box with a down arrow that displays a call details window
l Dial box (field for dialing extensions or phone numbers)
l Dial button (Contact Center PhoneSet Manager only)
l Redial button (Contact Center Softphone only)
l Cancel button (Contact Center Softphone only)
l Message button (for retrieving voicemail messages, Contact Center Softphone only)

The Functions toolbar displays
l Your current ACD state (LoggedOn/Off, in Make Busy, in Do Not Disturb)
l The ACD actions currently available
l Telephony buttons

See "Displaying, hiding, and retiring toolbar buttons" on page 386.

Phone functions
You can readily answer calls or forward them to extensions or phone numbers using the soft phone. You can
select people from contact and speed dial lists, and perform the following actions: Redial (Contact Center Soft
phone only), Transfer, Conference, Mute, Forward, Request help, Hold, Retrieve, Split, Swap, Camp on,
Leave amessage, Retrieve amessage, Call me back, Hang up, and Cancel.

NOTE:External hot desk agents access the "Answer" and "Hang up" functions using their external device
and not the soft phone toolbar.

Table 14 - 3 lists the soft phone telephony options and their correspondingmeanings.
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Icon Meaning

Account Code tags a call with an Account Code

Answer answers a ringing call

Auto answer if enabled, answers a ringing call without you having to click Answer

Call me back notifies you as soon as the extension number you are trying to call is
available

Camp on notifies an employee you are attempting to call with a series of audible
beeps

Cancel terminates your connection to a caller

Conference connects three or more people together for a conversation

Dial pad enables you to dial a number using a keypad

Forward forwards a call to a phone number or extension

Hang up terminates a call

Table 14 - 3 Agent actions
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Hold places the current call on hold

Leave amessage leaves amessage waiting notification on an employee’s extension

Mute if you have Contact Center Softphone, disables your microphone so you
can consult privately with another employee while on a call

Request help calls an employee who can click Answer and listen to an in-progress call
without the caller knowing

Retrieve picks up a call that is held or camped on to your extension

Speed dial enables you tomake a call to a specified number with onemouse click

Split disconnects one person from a conference call

Swap swaps between the current and the held party

Transfer forwards an in-progress call to another answer point

Transfer/Conference places a caller on hold andmakes a consultation call

Volume if you have Contact Center Softphone, adjusts the volume of your
speakers and/or microphone
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Call Notes enables you to view the notes associated with the current call and add
notes

Customizing the soft phone
You can enhance productivity by configuring the following time-saving options in the soft phone:

l Toolbar customization
l Sounds and notifications
l Call forward destinations
l Speed dial contacts
l Shortcut keys
l Pre-announcement messages

Configuring soft phone settings
To specify soft phone settings
 1. Right-click the Phone toolbar and click Configure.
 2. After Input audio device, select an audio device for your microphone.
 3. AfterOutput audio device, select an audio device for your speakers or headset.
 4. Click OK.

Specifying the address book source for contacts
To specify the address book the soft phone uses for contacts (Microsoft Outlook or the Contact Center
Management YourSite database)
 1. Right-click the Phone toolbar and click Configure.
 2. AfterAddress book source for contacts, select YourSite contacts orOutlook contacts.
 3. Click OK.

Resizing toolbar buttons
To resize toolbar buttons
 1. Right-click the Phone toolbar and click Configure.
 2. Click the Toolbars tab.
 3. After Functions toolbar, select a size for displaying the Functions toolbar buttons.
 4. AfterPhone toolbar, select a size for displaying the Phone toolbar buttons.
 5. Click OK.

Displaying, hiding, and retiring toolbar buttons
You can display telephony buttons, hide them so they appear on the Functions toolbar only when required, and
retire them for actions you rarely perform, such as Camp on and Request help.

To display telephony buttons
 1. Right-click the Phone toolbar and click Configure.
 2. Click the Toolbars tab.
 3. UnderSelected buttons, select the check boxes of the telephony buttons you want to display.
 4. Click OK.
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To hide telephony buttons
 1. Right-click the Phone toolbar and click Configure.
 2. Click the Toolbars tab.
 3. UnderSelected buttons, clear the check boxes of the telephony buttons you want to hide from view.
 4. Click OK.

To retire telephony buttons
 1. Right-click the Phone toolbar and click Configure.
 2. Click the Toolbars tab.
 3. UnderSelected buttons, select the telephony buttons you want to retire and click the left arrow to add

these buttons to the Available buttons list.
 4. Click OK.

To restore telephony buttons
 1. Right-click the Phone toolbar and click Configure.
 2. Click the Toolbars tab.
 3. UnderAvailable buttons, select the telephony buttons you want to restore and click the right arrow to

add these buttons to the Selected buttons list.
 4. Click OK.

Repositioning toolbar buttons
To specify the order in which telephony buttons appear
 1. Right-click the Phone toolbar and click Configure.
 2. Click the Toolbars tab.
 3. UnderSelected buttons, select a telephony button.
 4. Click the up or down arrow to change the position of the button relative to other buttons on the Functions

toolbar.
 5. Click OK.

Configuring sounds and notifications
You can configure sounds for individual phone events for incoming calls, secondary incoming calls, and/or the
digits dialed on your primary extension, or on all extensions. A primary incoming call is a call you receive while
you are in the idle state and are available to take the call. A secondary incoming call is a call you receive while
you are on a call on another extension and are not available to take the call.

Every time you receive a call a pop-up window notifies you the call has arrived. You can disable the pop-up
notification.

To configure a sound for a phone event
 1. Right-click the Phone toolbar and click Configure.
 2. Click theSounds tab.
 3. Select the Incoming calls, Secondary incoming calls, and/orPlay sounds when dialing digits

check boxes.
 4. AfterPhone events, select a phone event.
 5. AfterSound file name, click Browse and select a sound file.
 6. If you want to play the sound file when the phone event occurs on any of your extensions, click Apply to

all lines.
 7. Click OK.
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To disable the call arrival pop-up notification
 1. Right-click the Phone toolbar and click Configure.
 2. Click theSounds tab.
 3. UnderPhone events, click a phone line.
 4. Clear theDisplay pop-up notification for incoming calls check box.
 5. Click OK.

Making calls ring through your computer speakers
You canmake calls ring through your computer speakers instead of your headset.

Tomake calls ring through your computer speakers
 1. Right-click the Phone toolbar and click Configure.
 2. Click theSounds tab.
 3. AfterPlay the rings sounds on select the sound output device for your computer speakers.

Adjusting the volume of your speakers and microphone
If you have Contact Center Softphone, you can adjust the volume of your speakers andmicrophone.

To adjust the volume of your speakers
 1. Right-click the Phone toolbar and click Configure.
 2. Click theSounds tab.
 3. Adjust the volume by moving the speaker slider.

To adjust the volume of your microphone
 1. Right-click the Phone toolbar and click Configure.
 2. Click theSounds tab.
 3. Adjust the volume by moving themicrophone slider.

Configuring call forward destinations
You can forward calls manually to pre-configured call forward destinations. In addition, you can configure and
enable call forwarding so the telephone systems forwards calls to other answer points when you are
temporarily unavailable or away from the office. For example, you could specify all External call busy calls
you receive be forwarded to a co-worker’s extension. Rather than directing these call to voicemail, the
telephone system would forward these calls to your co-worker.

To configure call forward destinations for calls you will forwardmanually
 1. Right-click the Phone toolbar and click Configure.
 2. Click theCall forward tab.
 3. UnderName, type the name of the person to whom you will forward calls.
 4. UnderNumber, type an extension or phone number (preceded by a number you dial to access an

outside line).
 5. Click OK.
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To configure and enable call forward destinations for calls the telephone system will forward
 1. Right-click the Phone toolbar and click Configure.
 2. Click theCall forward tab.
 3. Specify the source for call forwarding.
 4. Specify destinations for the following call types:

l All calls (all calls you receive)
l External call busy (external calls to your extension when you are unavailable)
l External call no answer (external calls to your extension that you do not answer)
l Internal call busy (internal calls to your extension when you are unavailable)
l Internal call no answer (internal calls to your extension that you do not answer)

 5. If you want to activate the call forwarding rules immediately, select theEnabled check boxes of the call
forwarding types to be activated.

 6. Click OK.

Configuring speed dial numbers
When you pre-configure speed dial numbers in Contact Center Softphone, these contacts are available in
drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on the Functions toolbar.

You can display a button for each speed dial number or display one button with a down arrow that lists all of
the speed dial numbers you have configured. You can speed dial calls manually to pre-configured extensions
and phone numbers.

To configure a speed dial number
 1. Right-click the Phone toolbar and click Configure.
 2. Click theSpeed dial tab.
 3. UnderName, type the name of the person to whom you will speed dial calls.
 4. UnderNumber, type an extension or phone number (preceded by a number you dial to access an

outside line).
 5. Click OK.

Configuring shortcut keys
You can assign a shortcut key to a telephony function to perform it with a simple keystroke. This enables you
to perform telephony functions while the soft phone is minimized or another application is currently selected.

To configure a shortcut key for a telephony function
 1. Right-click the Phone toolbar and click Configure.
 2. Click theShortcut keys tab.
 3. UnderShortcut key, select a telephony function.
 4. Click the down arrow, select Ctrl, Alt, Shift, orWin, and select a keyboard number, letter, or function

from the list.
 5. Click OK.
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Configuring pre-announcement messages
NOTE: For hardware and software specifications related to pre-announcement messages, see theContact
 Center Solutions and Call Accounting System Engineering Guide.

Agents who have Contact Center PhoneSet Manager or Contact Center Softphone can record introductions
that are played to callers (for example, “Hi. This is Paul Jones in Customer Support. Could you please tell me
your customer site key?”) The introduction that is played is based on the queue the call arrives on and the time
of day it is received. The recorded introduction provides customers with a consistent greeting and gives the
agent extra time to retrieve customer information. You can stop pre-announcement messages at any time.

You can configuremore than one pre-announcement rule. For each rule, you specify the conditions in which
the soft phone will play a particular pre-announcement message. If one or more conditions is satisfied for a
particular rule, the soft phone will play the associated pre-announcement message. You can order the rules on
the Pre-announcement rules table to establish their priority. Pre-announcement rules are evaluated in the order
shown in the table. If one pre-announcement rule is satisfied, the associated sound file is played and no other
rules are evaluated.

NOTE: To use pre-announcement messages with Contact Center PhoneSet Manager, youmust have aMitel
ACD desk phone (for example, 5212) and a PCTI adaptor. The PCTI adaptor enables the audio being played
from the agent PC and the audio from the agent desk phone to bemixed.

To connect a PCTI adapter to your computer for use with Contact Center PhoneSet Manager
 1. Set the PCTI switch toBoth.
 2. Set the PCTI switch toHeadSet.
 3. Plug theMic/Audio cable of the headset into the appropriate Mic/Audio inputs on the PCTI adapter.
 4. Unplug the handset from the deskphone and plug it into the handset plug on the PCTI adapter.
 5. Plug the telephone input cable of the PCTI adapter into the telephone base.
 6. Plug the computer input of the PCTI adapter into the appropriate Mic/Speaker inputs on the PC.

NOTE: Ensure the headset is turned on, on the deskphone base.

To configure a pre-announcement rule for Contact Center PhoneSet Manager
 1. Right-click the Phone toolbar and click Configure.
 2. Under This extension is a, select Desk phone.
 3. To use audio devices for pre-announcements, select Use audio devices for pre-announcements and

specify the input and output audio device.
 4. Click thePre-announcement tab.
 5. Click Add rule.

The Add / Edit pre-announcement rule window opens.
 6. Select the conditions that determine when the pre-announcement message will play.
 7. Specify parameters for each condition.
 8. Select or record a wave file to play when the above conditions aremet.
 9. Type a name for the pre-announcement rule.
 10. If you want to hear ringing on your desk phone, select Enable ringing sound in desk phone.
 11. Click OK.
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To configure a pre-announcement rule for Contact Center Softphone
 1. Right-click the Phone toolbar and click Configure.
 2. Under This extension is a, select Soft phone.
 3. Click thePre-announcement tab.
 4. Click Add rule.

The Add / Edit pre-announcement rule window opens.
 5. Select the conditions that determine when the pre-announcement message will play.
 6. Specify parameters for each condition.
 7. Select or record a wave file to play when the above conditions aremet.
 8. Type a name for the pre-announcement rule.
 9. Click OK.

To re-order pre-announcement rules
 1. Select a rule.
 2. Click the up or down arrow to change the priority of the rule.
 3. Click OK.

Making and terminating calls using Contact Center Phoneset
Manager
When youmake calls, on the Functions toolbar you can readily select contacts you pre-configure in Microsoft
Outlook, or speed dial numbers you configure in Contact Center PhoneSet Manager. See "Configuring speed
dial numbers" on page 389 and "Displaying, hiding, and retiring toolbar buttons" on page 386.

You can dial any extension number or phone number. Contact Center PhoneSet Manager typically uses your
primary extension tomake calls. You can optionally select a different extension on the Phone toolbar to make
calls.

Making calls
To dial by phone number or extension number using Contact Center PhoneSet Manager
 1. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the dial box and type a number or extension on the
dial pad.

 2. Click Dial.
 3. If you want to view the call details window, click the down arrow adjacent to the box that displays your

current phone state.
See Figure 14 - 4.

To dial internally from a real-timemonitor using Contact Center PhoneSet Manager
l From any real-timemonitor, right-click an agent, employee, or extension cell and click Call.
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Figure 14 - 4 Making a call

Making calls to your contacts
Tomake a call to an extension in your contact list
 1. Click the arrow adjacent to the dial box and click theContacts tab.
 2. Select a contact in the list.
 3. Click Dial.

Making calls using speed dial
To dial using speed dial

l Click Speed dial and select a name in the list.

Terminating calls
To terminate a call

l Click Hang up.

Forwarding and answering calls using Contact Center Phoneset
Manager
You can forward calls manually to pre-configured call forward destinations without having to speak to the
caller first. In addition, you can configure and enable call forwarding so the telephone system forwards calls to
other answer points when you are temporarily unavailable or away from the office. See "Configuring call
forward destinations" on page 388.

If a call is ringing on your extension and you click the Forward button, the call will be forwarded to the default
call forward destination configured in the telephone system. If you click the down arrow adjacent to the
Forward button, you can select an extension or phone number for call forwarding.
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Forwarding calls
When a call is ringing on your extension, to forward the call using Contact Center PhoneSet Manager
 1. Click Forward.
 2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Forward button and select a contact.
 3. Click Dial.

Answering calls
When an agent receives a call with Contact Center PhoneSet Manager detailed caller information is displayed
on the desktop. (See Figure 14 - 5.) Agents can choose to answer the call or forward it to another
agent.Additionally, the display can provide access to call notes, which are notes an agent adds to the call
before transferring it. See "Adding call notes to a call" on page 394.

If configured and available the following information is provided in the soft phone display
l Caller name—name of the caller
l ANI—telephone number of the caller
l DNIS—telephone number the caller dials
l DNIS name—the name associated to the DNIS number in YourSite database
l Agent ID—agent who transferred the call
l Extension—extension from which the call was transferred
l Queue—queue from which the call originated
l Collect Caller Entered Digits—digits the caller enters for identification purposes, such as a customer

site key (Intelligent Queue required)
l Customer Collected Information—information collected from a third party OBDC database.

Customer Collected Information requires Intelligent Queue and Verified Collected Digits, and
optionally, Remote Database Verification or CTI Developer Toolkit

l Call notes—notes added by an agent

You can answer calls by right-clicking the Contact Center PhoneSet Manager system tray icon and selecting
Answer, or by clicking the Answer toolbar button.

Figure 14 - 5 Contact Center PhoneSet Manager display

To answer a call using Contact Center PhoneSet Manager
l Click Answer.
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Handling calls using Contact Center PhoneSet Manager
You can handle calls by right-clicking the Contact Center PhoneSet Manager system tray icon and selecting
telephony functions, or by selecting telephony buttons on the Functions toolbar. The telephony buttons
available depend on the action you last performed. You can configure the toolbar buttons so they are always
visible, or visible only when required. See "Displaying, hiding, and retiring toolbar buttons" on page 386.

When you pre-configure speed dial numbers in Contact Center PhoneSet Manager, these contacts are
available in drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on the
Functions toolbar. See "Configuring speed dial numbers" on page 389.

Placing calls on hold
To place a call on hold

l Click Hold (red oval button).

Retrieving calls
You can retrieve a held call, or retrieve a call when a call is camped on to your extension.

To retrieve a call
l Click Retrieve.

Adding call notes to a call
When agents are speaking with customers, they can add notes to calls to share with other contact center
employees involved in the call. This ensures agents and supervisors have context on calls and know what
information has been provided to customers upon call transfer.

When a call is being transferred to an agent or supervisor, the soft phone display shows themost recent note
associated with the call. When the agent answers the call, Contact Center Client appears on top of all other
open applications and displays the Call Notes monitor. Themonitor includes all of the call notes associated
with the current call.

Agents can add notes each time a call is transferred, and agents on conference calls can add notes
simultaneously. Each set of notes includes the agent’s name and a date/time stamp. When an agent
completes a call and answers a new call or closes the Call Notes monitor, all call note information is saved
and appended to the Lifecycle reports.

NOTE:
l On the Soft phone configuration window, you can clear the Enable call notes check box to hide the Call

Notes monitor and prevent call notes from being displayed.Optionally, you can enable the Bring to front
check box to ensure call notes display on top of all other windows when calls are received.

l Youmust have Contact Center PhoneSet Manager or Contact Center Softphone open in order to view
or add call notes.

l For 5000/Axxess configurations that use CT Gateway, time stamps are based on the Enterprise
Server’s PC clock. If the 5000/Axxess configuration includes Remote Servers, then time stamps are
based on the Remote Server’s PC clock. For the 3300 ICP, time stamps are based on the telephone
system clock.
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To add a call note
 1. As a call is ringing on your extension, on the soft phone display click Answer to answer the call.

Contact Center Client appears on top of all open applications and displays the Call Notes monitor.
 2. AfterEnter a new call note, type a note.

Call notes can include amaximum of 100 characters.
 3. Click Add.

The call note is added to the Call notes text box and is included in the soft phone display upon call
transfer.

Transferring calls
You can perform a blind transfer or a supervised transfer.

To perform a blind transfer using Contact Center PhoneSet Manager
 1. While on a call, click Trans/Conf.
 2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line if required). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a
contact.

 3. Click Dial.
 4. Click Hang up.

To perform a supervised transfer
 1. While on a call, click Trans/Conf.
 2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
 3. Click Dial.

The system places the caller on Hold.
 4. Wait for the called party to answer. If you receive a busy signal or a voicemail greeting, click Cancel to

return to the initial party. Otherwise, speak to the agent and identify the caller.
 5. Click Transfer to transfer the call.

Conferencing calls
You can include up to eight people in a conference call. The following example illustrates a three-way
conference call.

To set up a conference call
 1. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line).
 2. Click Dial.
 3. After you speak with the person who answers, click Trans/Conf to add a person to an in-progress call.

The system places the person on Hold.
 4. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
 5. Click Dial.
 6. Speak to the person who answers.
 7. Click Conference to initiate a three-way conference call.
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To split a conference call
l Click Split.

The last person you added to the conference call is placed on hold, and you can speak privately with the
first person.

Consulting with people while on calls
To consult with a person while on a call using Contact Center PhoneSet Manager
 1. Click Trans/Conf to conference in the person.

The system places the initial party on Hold.
 2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
 3. Click Dial.
 4. After you consult with the person, either click Conference to conference in the person, click Cancel to

hang up on the person, click Transfer to transfer the call to the person, or click Swap to talk to the initial
party.

Requesting help while on calls
To request help while on a call using Contact Center PhoneSet Manager
 1. Click Request help.
 2. On the dial pad, type the extension number of the employee you want to call. Otherwise, click the down

arrow adjacent to the Request help button and select a contact.
 3. Click Dial.

The system calls the employee. The employee can click Answer and listen in on the call without the
caller knowing and can click Conference to join the conversation at any time.

Using Camp on
The Camp on feature is available when youmake a call to an extension and receive a busy signal because the
employee is already on a call. Camp on notifies the employee you are attempting to call with a series of
audible beeps.

NOTE:
l Callers cannot camp on to your extension if you have call forwarding or voicemail configured on the

extension.
l You cannot camp on to an extension that is in Make Busy or Do Not Disturb.

To camp on to an extension
 1. In the dial box, type an extension number.
 2. Click Dial.
 3. If you receive a busy signal, click Camp on.

The employee you called will hear a series of beeps and can click Retrieve to place the caller on hold
and speak with you. After speaking with you, the employee can click Swap to return to the caller.
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Leaving and retrieving messages
The Leave amessage feature is available when youmake a call to an extension that is idle or on a call. You
must use the dial pad to type a number when you are retrieving amessage.

To leave amessage
 1. In the dial box, type an extension number.
 2. Click Dial.
 3. If the employee does not answer, click Leave a message.

The telephone system leaves amessage waiting notification on the employee’s extension and the
Contact Center Client icon flashes red and white in the employee’s system tray.

To retrieve amessage
 1. Click Dial pad and type the number configured in the telephone system for message retrieval.
 2. Press Enter.

The automated attendant will ask you for your password.
 3. Type your password on the dial pad.
 4. Follow the instructions provided by the automated attendant to retrieve themessage.

NOTE: If agents leave Call me back messages youmust use your physical phone set to retrieve the
messages.

Using Call me back
The Call me back feature is available when youmake a call to an extension that is idle or on a call. When you
select the Call me back button, the telephone systemmonitors the called employee’s other extension. When
the employee’s other extension returns to idle, your phone rings. If you pick up the call, the employee’s phone
will ring. If you do not pick up the call, the callback will expire.

To leave a callback message
 1. In the dial box, type an extension number.
 2. Click Dial.
 3. If the employee does not answer, click Call me back.

The telephone systemmonitors the called employee’s extension. Your phone will rings when the called
employee’s other extension returns to the idle state.

 4. When your phone rings, click Answer to pick up the call and speak with the employee.
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Tagging calls with Account Codes
You can tag calls with Account Codes you pre-configure in Contact Center Client.

To tag an in-progress call with an Account Code or a Classification Account Code
l Click the down arrow adjacent to the Account Code button and select a traditional Account Code or a

Classification Account Code.

After hanging up, while in work timer mode, you can tag calls with Classification Account Codes.

To tag a call, after hanging up, with a Classification Account Code
 1. Click the down arrow adjacent to theAccount Code button.
 2. Select After Call Classification and select the appropriate Classification Account Code from the drop-

down list.

Making and terminating calls using Contact Center Softphone
When youmake calls, on the Functions toolbar you can readily select from contacts you pre-configure in
Microsoft Outlook, or speed dial numbers you configure in Contact Center Softphone. See "Configuring speed
dial numbers" on page 389 and "Displaying, hiding, and retiring toolbar buttons" on page 386.

You can dial any extension number or phone number. Contact Center Softphone typically uses your primary
extension tomake calls. You can optionally select a different extension on the Phone toolbar to make calls.

For information on how to use the superkey and phone book functionality of Contact Center Softphone, refer
to the 5220 IP Phone User Guide at http://edocs.mitel.com/UG/Index.html.

Making calls
To dial by phone number or extension number using Contact Center Softphone
 1. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the dial box and type a number or extension on the
dial pad.

 2. If you want to view the call details window, click the down arrow adjacent to the box that displays your
current phone state.
See Figure 14 - 6.

To dial internally from a real-timemonitor using Contact Center Softphone
l From any real-timemonitor, right-click an agent, employee, or extension cell and click Call.
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Figure 14 - 6 Making a call

Making calls to your contacts
Tomake a call to an extension in your contact list
 1. Click the arrow adjacent to the dial box and click theContacts tab.
 2. Double-click a contact in the list.

Making calls to contacts who have called you recently
Tomake a call to a contact who has called you recently
 1. Click the arrow adjacent to the dial box and click theRecent tab.
 2. Double-click a contact in the list.

Making calls using speed dial
To dial using speed dial

l Click Speed dial and select a name in the list.

Redialing numbers
To dial the contact who last called you

l Click Speed dial and select a name in the list.

Terminating calls
To terminate a call

l Click Hang up.
Alternatively, on the Phone toolbar, click Cancel.

Forwarding and answering calls using Contact Center Softphone
You can forward calls manually to pre-configured call forward destinations without having to speak to the
caller first. In addition, you can configure and enable call forwarding so the telephone system forwards calls to
other answer points when you are temporarily unavailable or away from the office. See "Configuring call
forward destinations" on page 388.



Using Contact Center PhoneSet Manager and Contact Center Softphone

- 400 -

If a call is ringing on your extension and you click the Forward button, the call will be forwarded to the default
call forward destination configured in the telephone system. If you click the down arrow adjacent to the
Forward button, you can select an extension or phone number for call forwarding.

Forwarding calls
When a call is ringing on your extension, to forward the call using Contact Center Softphone
 1. Click Forward.
 2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Forward button and select a contact.

Answering calls
When an agent receives a call with Contact Center Softphone detailed caller information is displayed on the
desktop. (See Figure 14 - 7.) Agents can choose to answer the call or forward it to another agent.Additionally,
the display can provide access to call notes, which are notes an employee adds to the call before transferring
it. See "Adding call notes to a call" on page 394.

If configured and available the following information is provided in the soft phone display
l Caller name—name of the caller
l ANI—telephone number of the caller
l DNIS—telephone number the caller dials
l DNIS name—the name associated to the DNIS number in YourSite database
l Agent ID—agent who transferred the call
l Extension—extension from which the call was transferred
l Queue—queue from which the call originated
l Collect Caller Entered Digits—digits the caller enters for identification purposes, such as a customer

site key (Intelligent Queue required)
l Customer Collected Information—information collected from a third party OBDC database.

Customer Collected Information requires Intelligent Queue and Verified Collected Digits, and
optionally, Remote Database Verification or CTI Developer Toolkit

l Call notes—notes added by an agent

You can answer calls by right-clicking the Contact Center Softphone system tray icon and selecting Answer,
or by clicking the Answer toolbar button.

Figure 14 - 7 Contact Center Softphone display

To answer a call using Contact Center Softphone
l Click Answer.
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Handling calls using Contact Center Softphone
You can handle calls by right-clicking the Contact Center Softphone system tray icon and selecting telephony
functions, or by selecting telephony buttons on the Functions toolbar. The telephony buttons available depend
on the action you last performed. You can configure the toolbar buttons so they are always visible, or visible
only when required. See "Displaying, hiding, and retiring toolbar buttons" on page 386.

When you pre-configure speed dial numbers in Contact Center Softphone, these contacts are available in
drop-down lists adjacent to the Speed dial, Trans/Conf, and Request help buttons on the Functions toolbar.
See "Configuring speed dial numbers" on page 389.

Placing calls on hold
To place a call on hold

l Click Hold (red oval button).

Retrieving calls
You can retrieve a held call, or retrieve a call when a call is camped on to your extension.

To retrieve a call
l Click Retrieve.

Using Mute
To useMute
 1. Click Mute.

The system disables your microphone so you can consult privately with another employee.
 2. To restore your microphone, click Resume.

Transferring calls
You can perform a blind transfer or a supervised transfer.

To perform a blind transfer using Contact Center Softphone
 1. While on a call, click Trans/Conf.
 2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
 3. Click Hang up.

To perform a supervised transfer
 1. While on a call, click Trans/Conf.
 2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
The system places the caller on Hold.

 3. Wait for the called party to answer. If you receive a busy signal or a voicemail greeting, click Cancel to
return to the initial party. Otherwise, speak to the agent and identify the caller.

 4. Click Transfer to transfer the call.
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Conferencing calls
You can include up to eight people in a conference call. The following example illustrates a three-way
conference call.

To set up a conference call
 1. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line).
 2. After you speak with the person who answers, click Trans/Conf to add a person to an in-progress call.

The system places the person on Hold.
 3. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
 4. Speak to the person who answers.
 5. Click Conference to initiate a three-way conference call.

To split a conference call
l Click Split.

The last person you added to the conference call is placed on hold, and you can speak privately with the
first person.

Consulting with people while on calls
To consult with a person while on a call using Contact Center Softphone
 1. Click Trans/Conf to conference in the person.

The system places the initial party on Hold.
 2. In the dial box, type an extension or phone number (preceded by a number you dial to access an outside

line). Otherwise, click the down arrow adjacent to the Trans/Conf button and select a contact.
 3. After you consult with the person, either click Conference to conference in the person, click Cancel to

hang up on the person, click Transfer to transfer the call to the person, or click Swap to talk to the initial
party.

Requesting help while on calls
To request help while on a call using Contact Center Softphone
 1. Click Request help.
 2. On the dial pad, type the extension number of the employee you want to call. Otherwise, click the down

arrow adjacent to the Request Help button and select an employee.
The system calls the employee. The employee can click Answer and listen in on the call without the
caller knowing and can click Conference to join the conversation at any time.

Using Camp on
The Camp on feature is available when youmake a call to an extension and receive a busy signal because the
employee is already on a call. Camp on notifies the employee you are attempting to call with a series of
audible beeps.

NOTE:
l Callers cannot camp on to your extension if you have call forwarding or voicemail configured on the

extension.
l You cannot camp on to an extension that is in Make Busy or Do Not Disturb.
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To camp on to an extension
 1. In the dial box, type an extension number.
 2. If you receive a busy signal, click Camp on.

The employee you called will hear a series of beeps and can click Retrieve to place the caller on hold
and speak with you. After speaking with you, the employee can click Swap to return to the caller.

Leaving and retrieving messages
The Leave amessage feature is available when youmake a call to an extension that is idle or on a call.

To leave amessage
 1. In the dial box, type an extension number.
 2. If the employee does not answer, click Leave a message.

The telephone system leaves amessage waiting notification on the employee’s extension and the
Contact Center Client icon flashes red and white in the employee’s system tray

To retrieve amessage
 1. In the dial box, type your voicemail access number.

The automated attendant will ask you for your password.
 2. In the daily box, type your password.
 3. Follow the instructions provided by the automated attendant to retrieve themessage.

NOTE: If agents leave Call me back messages for you to check your messages, your Contact Center Client
tray icon will not clear themessages once you have checked your messages.

To clear amessage
 1. On the Phone toolbar, click Message.
 2. AfterCALL ME BACK?, click Yes.
 3. Click Erase.

The telephone image displays NO MORE MESSAGES.

Using Call me back
The Call me back feature is available when youmake a call to an extension that is idle or on a call. When you
select the Call me back button, the telephone systemmonitors the called employee’s other extension. When
the employee’s other extension returns to idle, your phone rings. If you pick up the call, the employee’s phone
will ring. If you do not pick up the call, the callback will expire.

To leave a callback message
 1. In the dial box, type an extension number.
 2. If the employee does not answer, click Call me back.

The telephone systemmonitors the called employee’s extension. Your phone will rings when the called
employee’s other extension returns to the idle state.

 3. When your phone rings, click Answer to pick up the call and speak with the employee.
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Tagging calls with Account Codes
You can tag calls with Account Codes you pre-configure in Contact Center Client.

To tag an in-progress call with an Account Code or a Classification Account Code
l Click the down arrow adjacent to the Account Code button and select a traditional Account Code or a

Classification Account Code.

After hanging up, while in work timer mode, you can tag calls with Classification Account Codes.

To tag a call, after hanging up, with a Classification Account Code
 1. Click the down arrow adjacent to theAccount Code button.
 2. Select After Call Classification and select the appropriate Classification Account Code from the drop-

down list.

Controlling your availability
You can log yourself on or off, cancel Work Timer, cancel Reseize Timer, and place yourself in or remove
yourself fromMake Busy with reason or Do Not Disturb with reason using the soft phone.

To log on to the ACD
l Click Actions=>Log on and select an agent ID.

To log off of the ACD
l Click Actions=>Log off.

To set Make Busy with reason
l Click Actions=>Set Make Busy and select aMake Busy Reason Code.

To removeMake Busy with reason
l Click Actions=>Remove Make Busy.

To set Do Not Disturb with reason
l Click Actions=>Set Do Not Disturb and select a DoNot Disturb Reason Code.

To remove DoNot Disturb
l Click Actions=>Remove Do Not Disturb.

To cancel Work Timer
l Click Actions=>Cancel Work Timer.

To cancel Reseize Timer
l Click Actions=>Cancel Reseize Timer.

Making and handling calls using Contact Center Client
You can open an agent, employee or extensionmonitor, or the Queue Now monitor and either right-click an
agent and select telephony functions or access telephony functions by selecting an agent and accessing the
options in the Contact Center Client ribbon. For example, when you are on a call you can consult with an idle
employee by right-clicking the employee’s cell and clicking Transfer/Conference, or by sending the employee
an instant message. (See Figure 14 - 8.)
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Figure 14 - 8 Consulting with a person while on call

Making calls
To call an agent using Contact Center Client

l Right-click the cell of an idle agent and click Call.

Alternatively:
 1. Select anidle agentin an openmonitor.
 2. Click theSoftphone button under theAgent Control tab in the Contact Center Client Real Time

ribbon.
 3. Choose theCallmenu item.

Forwarding calls
If a call is ringing on your extension, to forward the call using Contact Center Client

l Right-click the cell of an idle agent and click Forward.

Answering calls
If a call is ringing on another agent’s extension, to pick up the call using Contact Center Client

l Right-click the cell of the agent and click Pick up.

Adding call notes
When agents are speaking with customers, they can add notes to calls to share with other contact center
employees involved in the call. This ensures agents and supervisors have context on calls and know what
information has been provided to customers upon call transfer. If the call is transferred or parked, call notes
are preserved. See "Adding call notes to a call" on page 394.

NOTE:Before adding call notes, ensure the "Display call notes" option is enabled in the Softphone
configuration window. This option is disabled by default.
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To add a call note
 1. As a call is ringing on your extension, on the soft phone display click Answer to answer the call.

Contact Center Client appears on top of all open applications and displays the Call Notes monitor.
 2. AfterEnter a new call note, type a note.

Call notes can include amaximum of 100 characters.
 3. Click Add.

The call note is added to the Call notes text box and is included in the soft phone display upon call
transfer.

Recording calls
There are occasions when an agent wants to temporarily stop recording a call for confidentiality reasons, or, if
the call is not currently being recorded, the agent may want to start recording if the conversation becomes
hostile or sensitive in nature and a call recordmay be required. On the Agent State by Time, Agent State by
Position, and Agent State by Queue by Timemonitors, the Call recording option enables you to start, stop,
and restart call recording at any time during a call, using OAISYS call recording functionality. Requirements
for this on-demand call recording feature are Contact Center Management, Contact Center PhoneSet
Manager or Contact Center Softphone, Interactive Contact Center, and the OAISYS call recording connector.

To record a call
 1. Right-click the associated cell of an agent and select Call Recording=>Start Recording.
 2. To stop recording, right-click the cell and select Call Recording=>Stop Recording.

Alternatively:
 1. Select the cell of an agent in amonitor whose call you want to record.
 2. In the Contact Center Client Real Time ribbon, under theAgent Control tab, select Start Recording

from the drop-down list in theCall Recording column.
 3. To stop recording, select Stop Recording from the drop-down list in theCall Recording column.

See Figure 14 - 9.

Figure 14 - 9 Call recording
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Silent monitoring calls
Silent monitoring is the process of listening to the voice conversations of internal or external calls between
agents and callers. Silent monitoring enables you to track call handling techniques and determine where
improvements can bemade in individual performance. Silent monitoring is supported for the 3300 ICP
telephone system and requires Contact Center Management, Contact Center PhoneSet Manager or Contact
Center Softphone, and Interactive Contact Center.

NOTE:
l Themonitoring extension and the extension beingmonitoredmust coexist on the same telephone

system.
l Themonitoring extensionmust be permitted by security role to interactively control other agents.
l Themonitoring extension’s soft phone tool bar must be open.

To silent monitor a call using Contact Center Client
l Right-click the associated cell of an agent and select Silent Monitor.

Alternatively:
 1. Select the cell of an agent in amonitor whose call you want to silent monitor.
 2. In the Contact Center Client Real Time ribbon, under theAgent Control tab, click theSoftphone

button and click Silent Monitor.

NOTE: If the telephone system settings are incorrect or themonitoring extension and the extension being
monitored are on separate telephone systems, you will be unable to Silent monitor and will instead see "Not
Allowed" when you right-click the cell. See theContact Center Management Installation Guide for more
information. If the extension you want to monitor is not currently on a call, you will see "Waiting" when you
right-click the cell.

Transferring calls
To perform a blind transfer using Contact Center Client

l While on a call, right-click the cell of an idle agent and click Transfer call.

Alternatively:
 1. Select the cell of anidle agentin amonitor.
 2. In the Contact Center Client Real Timeribbon, under theAgent Control tab, click theSoftphone

button and click Transfer call.

Consulting with employees while on calls
To consult with an employee while on a call using Contact Center Client
 1. Right-click the cell of an idle agent and click Transfer/Conference.

The system places the initial party on hold.
 2. In the dial box, type an extension or phone number. Otherwise, click the down arrow adjacent to the

Transfer/Conference button and select a contact.
 3. Click Dial.
 4. After you consult with the employee, either click Conference to conference in that person, click

Transfer to transfer the call to the employee, click Swap to talk to the other party, or click Cancel to
end the consultation call.
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Requesting help while on calls
To request help while on a call using Contact Center Client

l Right-click the cell of an idle agent and click Request help.
The system calls the employee. The employee can click Answer in the soft phone and listen in on the
call without the caller knowing. The employee can click Conference in the soft phone to join the
conversation at any time.
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Chapter 15

Contact Center Screen Pop

Using Contact Center Screen Pop
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Contact Center Screen Pop
Contact Center Screen Pop is an optional application that requires Contact Center Management, and Contact
Center Softphone or Contact Center PhoneSet Manager. Optionally, if you want to screen pop based on caller
entered digits, you require Intelligent Queue with the Collect Caller Entered Digits options.

Contact Center Screen Pop launches applications orWeb pages. In addition, it enables agents to
automatically receive caller and account information via pop-ups on their computer monitors every time they
receive calls. Contact Center Screen Pop provides agents with the caller name, caller phone number (ANI),
called number (DNIS), and the queue used in the call. Optionally, if you have the Intelligent Queue Collect
Caller Entered Digits option, Contact Center Screen Pop displays the digits the customer entered.

Using Contact Center Screen Pop
When an agent receives a call, Contact Center Screen Pop can launch an application orWeb page. For
example, when integrated with a Customer Relationship Management (CRM) database, Contact Center
Screen Pop can launch a customer account page from the CRM database based on call information.
For contact centers that have Contact Center Screen Pop, the pop-up provides

l Caller name—name of the caller
l ANI—telephone number of the caller
l DNIS—telephone number the caller dials
l DNIS name—the name associated to the DNIS number in YourSite database
l Agent ID—agentwho transferred the call
l Extension—extension from which the call was transferred
l Queue—queue from which the call originated
l Collect Caller Entered Digits—digits the caller enters for identification purposes, such as a customer

site key (Intelligent Queue required)
l Customer Collected Information—information collected from a third party OBDC database.

Customer Collected Information requires Intelligent Queue and Verified Collected Digits, and,
optionally, Remote Database Verification or CTI Developer Toolkit.

l Call notes—notes added by an agent

Configuring options in YourSite Explorer
You configure Contact Center Screen Pop options in YourSite Explorer. You can specify which information
fields the pop-up displays and whether an application orWeb page is launched when an agent receives a call.
See "Configuring Contact Center Screen Pop options" on page 411.

Enabling Contact Center Screen Pop
To enable Contact Center Screen Pop
 1. Start Contact Center Client.

See "Starting Contact Center Client" on page 191.
 2. Right-click the Phone toolbar and click Configure.
 3. Click theScreen pop tab.
 4. Select theDisplay Contact Center Screen Pop check box.
 5. Click OK.
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Configuring Contact Center Screen Pop options
If you are licensed for ANI, DNIS, and/or Collect Caller Entered Digits and want to display these in the pop-up
youmust configure the options for Contact Center Screen Pop in YourSite Explorer.

To configure Contact Center Screen Pop options
 1. In YourSite Explorer, click YourSite=>Enterprise.
 2. Click theScreen pop tab.
 3. Ensure theDisplay Intelligent Queue licensed options (ANI, DNIS, and Collect Caller Entered

Digits) on the soft phone pop-up check box is selected.
 4. To launch an application orWeb page when agents answer a call, select the Launch an application or

Web page when agents answer ACD calls check box.
l If you want to launchOutlook contact information for callers and create a journal entry for each

caller, select Display caller-specific Microsoft Outlook Contact Information and create
Journal entries. This is the default option. Microsoft Outlook will display the contact information
of that caller, using the name and/or number of the caller to find their file in the Personal Address
Book. A journal entry will also be created for the call. If you select this option, ensure that you
complete "Configuring Contact Center Screen PopOutlook options for journal entries" on page
417 and "Configuring Contact Center Screen Pop to display Outlook contacts" on page 417. A
default path or URL is automatically entered in the Contact Center Screen Pop tab. Contact
Center Screen Pop will launch this application orWeb page box when it is used.

l If you want to display call statistics for incoming ACD calls, select Display the caller-specific
Inbound trace report Web page. The Inbound Trace report tells you the number of times the
caller has called in the last seven days and contains the following fields: Call Start Time, Call
Duration, DNIS name, Agent name, Extension, and Account Code. (See Figure 15 - 1.)

l A default path or URL is automatically entered in the Contact Center Screen Pop tab. Contact
Center Screen Pop will launch this application orWeb page box when it is used.

l If you have created aWeb page or an application to launch when agents answer calls, select
Display a specific application or Web page and type the path for the executable file or the
URL of theWeb page. Click How do I enter this value? for instructions. See "Configuring
Contact Center Screen Pop display variables" on page 412.
If you have typed text into theContact Center Screen Pop will launch this application or
Web page box, Display a specific application or Web page is automatically selected.

l If prairieFyre Professional Services has provided you with an integrated custom screen pop
select Display this Professional Services custom executable file or Web page. Click
Manage to review the Professional Services custom screen pop options.

 5. If you want to enable screen pop on non-ACD calls select theScreen pop on non-ACD calls check
box.

 6. Click Save.
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Figure 15 - 1 Inbound Customer Trace Report

Configuring Contact Center Screen Pop display variables
The variables described in Table 15 - 1 are used by Contact Center Screen Pop to determine the application
area orWeb page that launches when an agent answers an ACD call. Ensure the required Intelligent Queue
options are enabled to use these variables.

NOTE: The variable names are case-sensitive.
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Table 15 - 1 Contact Center Screen Pop display variables

Variable Intelligent Queue
feature required

Description

%PFCALLERNAME% ANI/DNIS routing option, enabled Caller name as provided by the
telephone carrier. For example,
"John Smith"

%PFANI% ANI/DNIS routing option, enabled Caller number (ANI), the telephone
number of the calling party. For
example, "6135990045"

%PFDNIS% ANI/DNIS routing option, enabled Dialed Number Identification
Service (DNIS), numbers passed
from the public telephone network
to identify what phone number the
caller dialed. This is typically used
to identify different 1-800 or 1-900
numbers. For example, "9875"

%PFVERIFIEDCOLLECTEDDIGITS% Collect Caller Entered Digits
option, enabled and configured

The digits entered by the user
during the call. For example,
account number "78831"

%Queue% ANI/DNIS routing option, enabled Name of the queue from which the
call is answered. For example,
"Sales"

%ReceivingAgent% N/A Contains the Agent ID for the agent
receiving the current call

%ReceivingExtension% N/A Contains the Extension ID for the
extension receiving the current call

%SendingAgent% N/A Contains the Agent ID for the agent
sending or transferring the call to
the current recipient

%SendingExtension% N/A Contains the Extension ID for the
extension sending or transferring
the call to the current recipient

To launch an application
l Type the URL of the executable file followed by the required variables.

For example, C:\MyProgram\CustomerManagement.exe "%PFCALLERNAME%"
"%PFANI%""%PFDNIS%""%PFVERIFIEDCOLLECTEDDIGITS%""%Queue%"
NOTE:Variables must be in quotes and be separated by a space.
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If John Smith calls 1-800-266-9875 from 613-599-0045, is prompted to enter his account number (78831), and
is then routed to the Sales queue, the executable file will use the actual values of the call, for example,
C:\MyProgram\CustomerManagement.exe "John Smith""6135990045""9875""78831""Sales".

To launch a Web page
l Type the URL of theWeb page followed by the required variables, as per standard HTTP protocol.

For example,
http://myintranetsite.business.com?CALLERNAME=%PFCALLERNAME%&ANI=%PFANI%&DNIS=%PFDNIS%
&CO-
LLECT-
EDDIGITS=%PFVERIFIEDCOLLECTEDDIGITS%=%PFVERIFIEDCOLLECTEDDIGITS%&QUEUE
=%Queue%

If John Smith calls 1-800-266-9875 from 613-599-0045, is prompted to enter his account number (78831), and
is then routed to the Sales queue, theWeb page will use the actual values of the call, for example,
http://myintranetsite.business.com?CALLERNAME=John%20Smith&ANI=6135990045&DNIS=9875&COLLECTEDDIGITS=
78831&QUEUE=Sales.

Enabling MiTAI event logging
The prairieFyre Enterprise service receives MiTAI events from the Collector Service and stores these events
in a log file located in the DataDirectory\ CallControlEventLog sub-folder under themain installation directory.
The Enterprise service logs all events across all nodes in one file and time stamps events based on arrival
time, providing insight when troubleshootingMiTAI linking issues. Additionally, ANI, DNIS, Verified Collected
Digits, and other custom field call details arriving from Intelligent Queue are logged.

Incorrectly configured devices andmonitors will result in missingMiTAI events and Intelligent Queue port
events, causing lost data and screen pop failures.

To enableMiTAI event logging
 1. Browse to <drive>:\program files\prairiefyre software inc\CCM\Services\EnterpriseServer.
 2. Open prairieFyre.Services.EnterpriseServer.exe.config in Notepad.
 3. Click Edit=>Find.
 4. In the Find what field, enter LogCallTrackingMiTAIEvents and click Find Next.

NOTE: If the LogCallTrackingMiTAIEvents key does not exist, youmust create one. Enter <add key="
LogCallTrackingMiTAIEvents " value="true" />

 5. Save the file.
 6. Browse to theDataDirectory\CallControlEventLog folder.
 7. Verify thatMiTAIEvents*.txt is present in the folder.
 8. OpenMiTAIEvents*.txt and verify that the file contains MiTAI events. (See Figure 15 - 2.)

Figure 15 - 2 MiTAI events example



Using Contact Center Screen Pop

- 415 -

Additionally, youmust ensure that
l All relevant devices including queues and extensions (or hot desking agents in a hot desking resilient

environment) have been synchronized or manually programmed successfully.
l The Advanced Real time option is turned on.
l The prairieFyre Collector Service logmonitors were correctly set and there are noMiTAI errors (MiTAI

errors will be shown as SXERR_*).
l Intelligent Queue ports are configured andmonitored correctly.

Intelligent Queuemonitoring problems are demonstrated by call flow failure.
l Intelligent Queue ports are not programmed as regular voice extensions.

The Intelligent Queuemessaging service automatically writes Intelligent Queue ports into the Contact
 Center Management database. If the Intelligent Queue ports have beenmanually programmed using
YourSite Explorer or the Contact Center Management website and enabled for real-time and advanced
real-timemonitoring, screen pop will not display correct results.

Ignoring MiTAI events on UPiQ and callback capture ports
MiTAI events arriving on UPiQ ports and callback capture ports should be ignored to reduceMiTAI linking
overhead.

To ignoreMiTAI events on UPiQ and callback capture ports
 1. Browse to <drive>:\program files\prairiefyre software inc\CCM\Services\EnterpriseServer.
 2. Open prairieFyre.Services.EnterpriseServer.exe.config in Notepad.
 3. Click Edit=>Find.
 4. In the Find what field, enterMitaiLinkerPortIgnoreList and click Find Next.

NOTE: If theMitaiLinkerPortIgnoreList key does not exist, youmust create one. Enter <add
key="MitaiLinkerPortIgnoreList" value="2230 , 2250-2260, 2270" />

 5. Save the file.

Configuring DNIS linkage
We recommend you configure the DNIS in the Contact Center Management database. In many situations, for
example, in a Network ACD environment, MiTAI events that arrive on the path and on the end devicemay not
contain the originally dialed digits. Capturing dialed digits at the Intelligent Queue port allows the system to
preserve them for use in the screen pop DNIS field.

Configuring time spent in IVR
We recommend you configure theMiTAI linker to dispose of old (stale) calls immediately. In a high load
environment where the system processes thousands of calls per hour, MiTAI call IDs can recycle in minutes.
To dispose of stale calls, we recommend you configure the time a call spends in Intelligent Queue (or any
IVR) before it gets transferred to a path or end device. For example, if callers typically spend twominutes or
less in the IVR call flow before they are transferred, theMiTAI linker should be configured to dispose of stale
calls within threeminutes.
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To dispose of stale calls
 1. Browse to <drive>:\program files\prairiefyre software inc\CCM\Services\EnterpriseServer.
 2. Open prairieFyre.Services.EnterpriseServer.exe.config in Notepad.
 3. Click Edit=>Find.
 4. In the Find what field, enterMitaiLinkerMaxTimeInSecsInIVRBeforeRouting and click Find Next.

NOTE: If theMitaiLinkerMaxTimeInSecsInIVRBeforeRouting key does not exist, youmust create
one. Enter <add key=" MitaiLinkerMaxTimeInSecsInIVRBeforeRouting " value="180" /> and replace
180 with the time threshold (in seconds) to dispose of stale calls.

 5. Save the file.

Deleting completed calls from memory
Configuring theMiTAI linker to delete completed calls frommemory allows the system to recycle calls faster.
If no special components tap into the call after it finishes, there is no need for the system to track calls for
longer than 15 seconds after they have completed.

To delete completed calls frommemory
 1. Browse to <drive>:\program files\prairiefyre software inc\CCM\Services\EnterpriseServer.
 2. Open prairieFyre.Services.EnterpriseServer.exe.config in Notepad.
 3. Click Edit=>Find.
 4. In the Find what field, enter MitaiLinkerMaxTimeInSecsToRecycleAfterCallCleared and click Find

Next.
NOTE: If theMitaiLinkerMaxTimeInSecsToRecycleAfterCallCleared key does not exist, youmust
create one. Enter <add key=" MitaiLinkerMaxTimeInSecsToRecycleAfterCallCleared" value="15" />.

 5. Save the file.

Preventing blank or duplicate pop-ups
In a scenario where screen pop is configured to display onmore than one field, for example, in a clustered
network environment, the client may invoke screen pop with incomplete or blank pop-ups. In this case, the
client receives the data in more than one batch due to

l The speed that the telephone switch delivers events.
Agent controllers are typically faster than queuing gateways.

l The order that the events arrive.
TheMiTAI linker may not have received and linked all required events at the time when a call rings at an
end device.

Youmust configure a list of required fields in the ContactCenterClient.exe.config file to prevent blank or
duplicate pop-ups.

To prevent blank or duplicate pop-ups
 1. On the client computer, browse to Client Installation directory Applications\ContactCenterClient.
 2. OpenContactCenterClient.exe.config in Notepad.
 3. Click Edit=>Find.
 4. In the Find what field, enterWebPopRequires and click Find Next.

NOTE: If theWebPopRequires key does not exist, youmust create one. Enter <add
key="WebPopRequires" value="PFDNIS, PFVERIFIEDCOLLECTEDDIGITS"/>

 5. Save the file.
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Configuring Contact Center Screen Pop Outlook options for journal
entries
NOTE:Contact Center Screen Pop can search the contacts available in Outlook Personal Contacts only.

You can configure Contact Center Screen Pop to automatically record information in journal entries. Youmust
complete the following instructions if you selected Display caller-specific Microsoft Outlook Contact
Information and create Journal entries in "Configuring Contact Center Screen Pop options" on page 411. This
stepmust be performed on every agent computer that uses Contact Center Screen Pop.

For information on viewing and searching for journal entries, seeMicrosoft Office Outlook Help.

To configure Contact Center Screen PopOutlook options for journal entries
 1. Start Contact Center Client.
 2. Right-click the Phone toolbar and click Configure.
 3. Click theScreen pop tab.
 4. Click Configure Outlook screen pop options.
 5. Select Create a journal entry for each incoming call and include the following properties.
 6. Select the properties that you want to include in your journal entries.

l Name—caller name as provided by the telephone carrier (for example, John Smith)
l Phone number—telephone number of the caller (for example, 6135990045)
l DNIS—number passed from the public telephone network that identify the phone number the

caller dialed. DNIS is typically used to identify different 1-800 or 1-900 numbers (for example,
9875).

l Queue—queue from which the call originated. Only the first word of the queue name is recorded.
l Collect Caller Entered Digits—the Collect Caller Entered Digits option, enabled and

configured. These are the digits entered by the user during the call (for example, account number
78831)

 7. Click OK.

Configuring Contact Center Screen Pop to display Outlook contacts
Contact Center Screen Pop searches the Outlook contact list for a caller’s information and displays it in an
Outlook window. Youmust complete this section if you selected Display caller-specific Microsoft Outlook
Contact Information and create Journal entries in "Configuring Contact Center Screen Pop options" on page
411.

To configure Contact Center Screen Pop to display Outlook contacts
 1. Start Contact Center Client.
 2. Right-click the Phone toolbar and click Configure.
 3. Click theScreen pop tab.
 4. Click Configure Outlook screen pop options.
 5. Select theSearch for an Outlook contact check box.

l If you want to search for a contact using their name, select By name.
l If you want to search for a contact using their telephone number, select By number.
You can select both By name and By number to enable Contact Center Screen Pop to search for
contacts using either method.

 6. Click OK.
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Configuring Contact Center Screen Pop to display Goldmine contacts
The FrontRangeGoldmine connector for Contact Center Screen Pop searches Goldmine contact lists for
caller phone numbers and displays the caller’s contact page. The following procedures detail how to configure
Contact Center Screen Pop to display FrontRangeGoldmine contact information.

To configure Contact Center Screen Pop to display FrontRangeGoldmine contacts
 1. In YourSite Explorer, click YourSite=>Enterprise.
 2. Click theScreen pop tab.
 3. Select the Launch an application or Web page when agents answer ACD calls check box.
 4. Select Display a specific application or Web page.
 5. UnderContact Center Screen Pop will launch this application or Web page, type the path of the

executable file followed by the required variables: <drive>:\Program Files\prairieFyre Software
Inc\CCM\Applications\ContactCenterClient\GoldmineScreenPopConnector.exe"%PFANI%"
If you want to suppress Goldmine frommaximizing and being popped to the front of all active windows,
follow the above string with -s.
See "Configuring Contact Center Screen Pop options" on page 411 and "Configuring Contact Center
Screen Pop display variables" on page 412.

 6. Click Save.

If you do not want Contact Center Screen Pop to display Goldmine contacts, you can disable this option for
individual desktops using Contact Center Client.

To disable the FrontRangeGoldmine screen pop on individual desktops
 1. Start Contact Center Client.
 2. Click View=>Soft phone.
 3. Right-click the Phone toolbar and click Configure.
 4. Click theScreen pop tab.
 5. Ensure theDisplay Contact Center Screen Pop option is deselected.
 6. Click OK.
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Testing Contact Center Screen Pop search functions
This test will confirm that Contact Center Screen Pop will function with the software you selected. For
example, if you selected theDisplay caller-specific Microsoft Outlook Contact Information and create
Journal entries option, the test will attempt to pop up a sample caller-specific Outlook Contact window, and
create a sample Journal entry. See "Configuring Contact Center Screen Pop options" on page 411.

To test the search function in Contact Center Screen Pop
 1. Start Contact Center Client.
 2. Right-click the Phone toolbar and click Configure.
 3. Click theScreen pop tab.
 4. Click Test.
 5. Type the variables using the described format.

PFCALLERNAME—first name followed by last name, separated by a space (for example, John
Smith)
PFANI—phone number (including area code if relevant) with no spaces, dashes, or brackets (for
example, 6135558769)
PFDNIS—phone number (including area code if relevant) with no spaces, dashes, or brackets (for
example, 8005556598)
PFVERIFIEDCOLLECTEDDIGITS—all digits the caller has entered since entering the telephone
system, with no spaces, dashes or brackets (for example, 1113)
Queue—queue that the caller first entered (for example, P500)

 6. Click OK.
A screen pop that contains the test parameters you specified will display. The outcome of the Contact
Center Screen Pop test will change depending on the type of screen pop you have configured and the
test parameters you entered.

Disabling Contact Center Screen Pop
If you prefer some client computers do not use Contact Center Screen Pop, you can disable it on one or more
computers. This procedure affects one agent profile only.

To disable Contact Center Screen Pop on a client computer
 1. Start Contact Center Client.
 2. Right-click the Phone toolbar and click Configure.
 3. Click theScreen pop tab.
 4. Clear theDisplay Contact Center Screen Pop check box.
 5. Click OK.
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Chapter 16

Flexible Reporting

Using Flexible Reporting
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Flexible Reporting
Flexible Reporting is an application that works with Contact Center Management Enterprise Edition. In
addition to the over 425 reports provided by Contact Center Solutions and Call Accounting, Flexible Reporting
enables you to design your own reports.

To install Flexible Reporting on a client computer, select the Flexible Reporting option in the Client Role
Selector.

To access Flexible Reporting, employees must be associated with a security role that allows them tomanage
reporting (theMay manage reporting check box must be selected).

With Flexible Reporting you can:
l Use a wizard interface to create customized reports with existing statistics (column headings)
l Create custom calculations using expressions
l Select column headings to build custom reports
l Select only the columns you want to view
l Select like data for two or more device types and combine them in one report
l Arrange the columns in the order in which you want to view them
l Customize the names of statistics (column headings) so they aremeaningful to your department,

business, and industry
l Save the reports in Excel and .pdf formats

Using Flexible Reporting
In Flexible Reporting you can

l Create new reports
l Modify standard Contact Center Management report templates
l Modify existing Flexible Reporting report templates
l Design reports
l Manage your Flexible Reporting reports
l Run reports

Starting Flexible Reporting
To start Flexible Reporting
 1. Open Flexible Reporting.
 2. Log on with your user name and password.

TheWelcome to Flexible Reporting dialog box opens.
 3. You can select from: Run a report, Create a new report, Redesign a standard report, Modify an existing

report, or Do not show this dialog box again. If you want to initiate a procedure, click OK and see the
associated section in this chapter. Otherwise, close the dialog box.
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Viewing the Flexible Reporting user interface
The Flexible Reporting user interface comprises the following. (See Figure 16 - 1.):

l Report Designer wizard
l Layout designer window
l Flexible Reporting button
l Ribbon
l Toolbox window

Figure 16 - 1 Flexible Reporting user interface

You can customize the position of the windows in the following ways:
l Dock to the left, right, top, or bottom of the user interface
l Float
l Hide
l Auto-hide

Report Designer wizard
Whether you are building a new report or modifying an existing Contact Center Management report, the Report
Designer wizard leads you through the following steps to select data for the report:

l Create a new report based on an existing one, or design a new report
l Select a report type (Performance reports, Answering points, Make Busy, and Account Code reports, or

Summarized/Detailed Agent Event reports)
l Select the device types
l Select the statistics (column headings), and the order in which you want them displayed
l Specify the time frame options
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Layout designer window
The layout designer window comprises two tabs: design and preview. The window displays the report header
and data grid. You can perform the following functions in the layout designer window.

On the design tab you can
l Add images to report headers
l Edit the report header titles
l Adjust the placement of the report header titles and values
l Remove report header titles and values
l Add existing or custom columns
l Move columns
l Delete columns
l Edit column heading names
l Specify columnwidth and row height
l Specify row colors
l Freeze and unfreeze columns
l Save report templates

On the preview tab you can
l Run and preview reports
l Save reports
l Export reports
l Print reports

Flexible Reporting button
The Flexible Reporting button is the circular button located in the upper left corner of the window. The
following options are available from the Flexible Reporting button: New, Open, Save, Save as, Close, About,
Log out, Exit, and Log out and exit.

Ribbon
The ribbon provides the same functionality as traditional toolbars. Use the tools on the ribbon to help you
design your reports. The ribbon comprises the Home, Insert, and View tabs.

On the Home tab of the ribbon, you will find the tools to help you
l Change the font type, size, and style
l Select text justification
l Specify columnwidth, auto-fit columnwidth, and row height
l Change row colors

On the Insert tab of the ribbon, you will find the tools to help you
l Insert and remove images from the report header
l Select the report header titles to open in the report header
l Add existing or custom columns
l Remove columns
l Freeze and unfreeze columns
l View ormodify expressions
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On the View tab of the ribbon, you will find the tools to help you
l Show and hide the Toolbox window
l Manage reports

Toolbox window
The Toolbox window contains the following:

l Report header
Report header is a list of report header titles that are currently not included in the report header. If the
Report Header list is empty, all of the report header titles will be applied to the report. When report
header titles are removed from a report they are shown in the Report headers list.

l Column heading
Column heading displays a list of all of the column headings (for only those devices selected for the
report) that are not currently included in the report grid. When you add a column heading to the report, it
is removed from the list. Similarly, if you remove a column heading from the report, it displays in the
Column headings list.

Creating new reports
Using the Report Designer wizard you can build new reports with existing column headings. Use the Report
Designer wizard to select the data for the report.

The Report Designer wizard guides you through the following steps:
l Select how you want to display the report data

l Performance reports display data for agents, queues, trunks, DNIS, or extensions by interval.
Each row in the report represents a specific period. The supported periods are: 15minutes, 30
minutes, 60minutes, day of week, day of month, andmonth.

l Answering points, Make Busy, and Account Code reports display data for a single device per
row (including employee, agent, queue, ANI, DNIS, Account Code, Make Busy code, Trunk
busy minutes, agent ID, and devices associated with device groups). Each row in the report
represents a device. Examples of by device reports are EmployeeGroup by Employee, Queue
Group by Queue, Queue by Agent, or Queue ANI by Area Code.

l Summarized/Detailed Agent Event reports display ACD-based agent activity data. The data can
be grouped by login/logout pair or can be viewed as a trace of all login/logout pairs. For example,
Detailed Agent Event Data reports show the agent state activity for each login/logout pair
performed by the agent. Summarized Agent Event Data reports group the data and show one line
representing the agent’s total activity.

l Select the device(s) on which you want to report
l Select the statistics (column headers) that will be shown in the report
l Select the time frames over which you want to run the report

To create a new report
 1. Click the Flexible Reporting button and select New to launch the Report Designer wizard.
 2. Click Next.
 3. Click Create a new report and follow the steps in the wizard.

At the end of the Report Designer wizard, the new report opens automatically on the Design tab.
 4. Design the report.

See "Designing reports" on page 427.
 5. Click the Flexible Reporting button and select Save to save the report.
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Modifying standard Contact Center Management report
templates
Using the Report Designer wizard you canmodify standard Contact Center Management voice report
templates. In the wizard, you can remove data (column headings) and add new data (additional devices and
column headings).

The Report Designer wizard guides you through the following steps:
l Select the report you want to modify from a list of standard Contact Center Management reports
l Select the time frames over which you want to be able to run the report

Choosing options on this page enables you to select time frames when submitting or previewing
reports. The start and end times enable you to run the report for a specific time frame for each day in the
report. For example, you can run the report for your hours of operation only, 8 A.M. to 6 P.M.
The days of the week time frame enables you to run the report for specific days. For example, every
Friday over the last twomonths.

Table 16 - 1 lists the standard Contact Center Management report templates.
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Table 16 - 1 Standard Contact Center Management report templates

Agent report templates

l Agent by Make Busy Code

l Agent Group by Make Busy Code

l Agent Group Performance by Period

l Agent Performance by Account Code

l Agent Performance by Period

l Agent Shift by Period

DNIS report templates

l DNIS Group Performance by Period

l DNIS Performance by Period

l Employee report templates

l EmployeeGroup Performance by Employee

l Employee Performance by Agent ID

Extension report templates

l Extension Group Performance by Period

l Extension Performance by Period

Queue report templates

l Queue ANI by Area Code

l QueueGroup Performance by Queue

l Queue Performance by Account Code

l Queue Performance by Agent

l Queue Performance by Period

Trunk report templates

l Trunk Group Performance by Period

l Trunk Performance by Period



Contact Center Solutions User Guide

- 427 -

Tomodify a standard Contact Center Management report template
 1. Click the Flexible Reporting button and select New to launch the Report Designer wizard.
 2. Click Next.
 3. Select theRedesign a standard report option and follow the steps in the wizard.

At the end of the Report Designer wizard, the new report template opens automatically on the Design
tab.
NOTE:On the Select an existing report template page of the wizard, under Filter by device type, select
All devices if you want to see all available reports for all devices.

 4. Design the report.
See "Designing reports" on page 427.

 5. Click the Flexible Reporting button and select Save to save the report.

Modifying existing Flexible Reporting report templates
Tomodify an existing Flexible Reporting report template
 1. Click the Flexible Reporting button and select Open.

The Reports List window opens, giving you access to all personal and shared Flexible Reporting
reports.

 2. Select the report you want to modify.
 3. Click Open.
 4. Modify the report.

See "Designing reports" on page 427.
 5. Click the Flexible Reporting button and select Save to save the changes to the report template, or

select Save As to save the report as a new template.
 6. If you want to run the report, click thePreview tab.

Designing reports
Using the options available on the ribbon, design the report by modifying the report header, columns, and
rows.

NOTE:You can open and edit report templates you previously created in Flexible Reporting.

Adding images to report headers
To add an image to a report header
 1. On the Insert tab of the ribbon, click the Insert button.
 2. Select an image file and click Open.

The image displays on the report header.
 3. Drag the image to where you want it to be shown on the report header.

Deleting images on report headers
To delete an image
 1. Select an image on the report header.
 2. On the Insert tab of the ribbon, click theRemove button.
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Editing report header titles
Report headers comprise titles and values. Edit the report header titles to customize the look of your reports.

You can edit the font type, size, and style of report header titles.

You can edit the titles of the following report headers:
l Report
l Site
l Device
l Date range
l Date created
l Created by

NOTE:You cannot edit the report header values as these are driven by the options selected when the report is
submitted.

To edit a report header title
 1. Click a report header title.
 2. Edit the text in the box.

Moving report header titles and values
You can drag and drop report header titles and values independently.

Tomove a report header title or value
l Drag and drop the report header title or value to where you want it to be shown on the report header.

Removing report header titles and values
All report header titles and values are shown on a report when it is first created. If you remove a report header
title, the corresponding value will also be removed from the header. For example, if you remove the Date range
title, the date range will not be shown on the report.

To remove a report header title and value
l On the Insert tab of the ribbon, click theHeader button and deselect the check box of the report header

title you want to remove. You can optionally drag and drop the report header title from the report to the
Report header list.
Report header titles removed from the report are shown in the Report header list in the Toolbox window.

Adding report header titles and values
To add a report header title and value to a report

l On the Insert tab of the ribbon, click theHeader button and select the check box of the report header
title you want to add. You can optionally drag and drop the report header title from the Report header list
to the report.
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Adding existing columns
To add an existing column
 1. On the Insert tab of the ribbon, click Add=>Existing.

Optionally, right-click the report and select Insert column=>Existing from the drop-down list.
The Add columns window opens.
NOTE:You can also drag and drop items from the Column heading list in the Toolbox window to add
existing columns to your report.

 2. Select the columns you want to add to the report.
 3. Click OK.

Adding custom columns
You can add custom columns to create custom calculations using expressions or blank columns. The ability
to create custom calculations using expressions enables you to further customize report data to suit your
specific business needs. Blank columns can be used as spacers tomake reports easier to read, or as
placeholders for importing third-party data after a Flexible Reporting report has been generated.

NOTE:
l Adding columns containing custom calculations requires a thorough understanding of Microsoft Excel

and regular expressions.
l We recommend you preview reports containing custom calculations in Flexible Reporting before saving

the changes and generating the report in the Contact Center Management website.

To add a column containing custom calculations
 1. On the Insert tab of the ribbon, click Add=>Custom.

Optionally, right-click the report and select Insert column=>Custom from the drop-down list.
A blank column displays in the report.

 2. Right-click a cell in the blank column and select Expression.
The Edit expression window opens.
NOTE:You cannot create calculations using expressions in a header cell.

 3. Select an option in theOptions list to view the associated Item list.
 4. Select an item in the Item list to view the associated item Description and expression Example.
 5. Double-click the item in the Item list to insert its expression into theExpression box.
 6. Repeat steps 3 to 5 until the complete calculation is entered in theExpression box and click OK.

The expression displays in row two of the blank column in the report.
 7. If you want to edit the expression you created, right-click the cell and select Expression to return to the

Edit expression window.

After adding a column containing custom calculations you can choose to view ormodify the expression.

To view ormodify an expression
 1. Select the cell in the report, for which you want to view ormodify the expression.
 2. On the Insert tab of the ribbon, click Expression.

Optionally, right-click the column and select Expression from the drop-down list.
The Edit expression window opens.

 3. Select an option in theOptions list to view the associated Item list.
 4. Select an item in the Item list to view the associated item Description andExpression example.
 5. Double-click the item in the Item list to insert its expression into theExpression box.
 6. Repeat steps 3 to 5 until the complete calculation is entered in theExpression box and click OK.

The expression displays in row two of the blank column in the report.
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You can restrict the number of decimal places that will display for results. As an example, setting the number
of decimal places that will display for the AverageManned Agent statistic is described below.

To set the number of decimal places that display for results
 1. In theDesign view, right-click theAverage Manned Agent column in the report and select Expression

from the drop-down list.
 2. Change the current value of =Fields!AgentGroupEventAvgMannedAgents.Value to

=FormatNumber(Fields!AgentGroupEventAvgMannedAgents.Value,1).
 3. Click OK.
 4. Click Save.

The column is formatted to display one decimal place. To alter the number of decimal places displayed,
enter the appropriate number in place of 1.

To add a blank column
 1. On the Insert tab of the ribbon, click Add=>Custom.

Optionally, right-click the report and select Insert column=>Custom from the drop-down list.
A blank column displays in the report.

 2. Optionally, click the header cell of the blank column and type a name for the column.

Moving columns
Tomove a column

l On the report grid, drag and drop the column to where you want it on the grid.

Deleting columns
To delete a column
 1. Click a column on the report grid.
 2. On the Insert tab of the ribbon, click theRemove button.

Optionally, right-click the column and select Delete column from the drop-down list.

NOTE:Some statistics require specific columns to ensure a report is meaningful. These statistics are
associated with the required columns and cannot be deleted on their own. For example, in by period reports,
you cannot delete the interval; in by device reports, the reporting number cannot be deleted.

Editing column heading names
You can edit the names of column headings so they aremeaningful to your department, business, and
industry. You can change the font type, size, and style as well as edit the text.

To edit a column heading name
 1. Click a column heading on the report grid.
 2. On theHome tab of the ribbon, use the font options to change

l the font type, size, and style
l the justification

 3. Optionally, edit the name of the column heading.
If, after renaming a column heading, you want to see the original column heading name, hover over the
column heading. The original column heading name displays after Name.
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Specifying column width
To specify the columnwidth
 1. Click a column.
 2. On theHome tab of the ribbon, afterColumn width, type the width (in pixels).

Optionally, right-click the column and select Columnwidth from the drop-down list.

To auto-fit the columnwidth
 1. Click a column.
 2. On theHome tab of the ribbon, afterScale to fit, click Auto.

Optionally, right-click the column and select Auto-fit Columnwidth from the drop-down list.

Specifying row height
You can specify a different row height for the header row than the body rows.

To specify the header row height
 1. Click the header row.
 2. On theHome tab of the ribbon, afterRow height, type the height (in pixels).

Optionally, right-click the header row and select Row height from the drop-down list.

To specify the body row height
 1. Click a body row.
 2. On theHome tab of the ribbon, afterRow height, type the height (in pixels).

Optionally, right-click the body row and select Row height from the drop-down list.
All of the body rows will be the same height.

Specifying row colors
You can alternate row colors to make report data easier to read.
 1. On theHome tab of the ribbon, select the primary and alternate colors.
 2. AfterAlt row count, type the number of rows for each color.

Freezing columns
Frozen columns remain stationary when you scroll to view columns to the right.

To freeze a column heading
 1. On the report grid, click the column to the right of the ones you want to freeze.
 2. On the Insert tab of the ribbon, click the Freeze column button.

Optionally, right-click the column and select Freeze column from the drop-down list.

Unfreezing columns
To unfreeze a column heading
 1. On the report grid, click the column to the left of the frozen column.
 2. On the Insert tab of the ribbon, click theUnfreeze column button.

Optionally, right-click the column and select Unfreeze column from the drop-down list.
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Managing your Flexible Reporting reports
Youmanage your Flexible Reporting reports on theMy Reports window. My Reports gives you access to all
of the reports you have created.

NOTE:You can access all the reports you have created and all shared reports created by others, by clicking
the Flexible Reporting button=>Open.

In theMy Reports window you can
l Change access properties: Shared or not Shared
l Rename reports
l Delete reports

Changing access properties
To change the access properties of a report
 1. On theView tab of the ribbon, click My reports.
 2. Select the report(s).
 3. If you want to share the report(s), underShared, select the check box. Otherwise, clear the check box

and the report(s) will be available to you only.
 4. Click OK.

Renaming reports
To rename a report
 1. On theView tab of the ribbon, click My reports.
 2. Select a report and click Rename.
 3. Edit the name.
 4. Click OK.

Deleting reports
You can only delete the reports you create.

To delete a report
 1. On theView tab of the ribbon, click My reports.

NOTE: You cannot delete a report that is open in Flexible Reporting.
 2. Select the report(s) you want to delete and click Delete.
 3. Click Yes to delete the selected report(s).
 4. Click OK.
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Running reports
You can run Flexible Reporting reports on the Contact Center Management website or in Flexible Reporting.
However, you can schedule reports on the Contact Center Management website only.

From the Contact Center Management website, you can run Flexible Reporting reports on demand, or
schedule them, the sameway you run standard reports. See "Reporter" on page 277 and "Scheduled Reports"
on page 282.

In Flexible Reporting you can run, save, and print reports on the Preview tab. After you run a report, printing
options enable you to view the print layout, and configure page setup and printer properties.

NOTE:
l Flexible Reporting will run reports only when there is data to generate the report.
l If you run a report on the Preview tab and the report data is all zeros, ensure you selected a device on

which to run the report. If you selected a device, ensure the selected time period is one that would have
incurred activity.

l Custom reports created in Flexible Reporting can only be generated in the language that was used
when they were created and saved.

Running reports in the Contact Center Management website
To run an on-demand report in the Contact Center Management website

l Click Reporter=>Flexible Reporting and select and run the report.
You will have access to all Flexible Reporting reports created by you and shared Flexible Reporting
reports created by others.

NOTE: When a report supports more than one device type, click on each tab to select the devices on which
you want to report.

To schedule a report on the Contact Center Management website
 1. On the Contact Center Management website, click Reporter=>Scheduled reports.
 2. If you want to create a new schedule, click Next. Otherwise, select an existing schedule and click

Manage schedule properties.
 3. Configure the schedule properties and distribution attributes.

For more information, see "Creating Contact Center Management Report schedules" on page 283.
 4. Click Add a report.
 5. Click Flexible Reporting and select a report to add to the schedule.

Running reports in Flexible Reporting
To run reports in Flexible Reporting
 1. On thePreview tab, underDevices, select the device(s).
 2. Specify the date and time parameters.
 3. Click Run report.

Flexible Reporting generates the report and displays it in the preview pane.
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Saving templates and reports
In Flexible Reporting you can save

l Templates
The report templates you create in Flexible Reporting are saved on the Enterprise Server so you can run
them from Flexible Reporting and the Contact Center Management website.
NOTE:Report templates are not saved automatically. Youmust save your report template before you
exit Flexible Reporting if you want to use it to run reports or modify the template later.

l Reports
After you run a report in Flexible Reporting, you can save the output (report) on your computer or
elsewhere on your network. Reports can be saved or, optionally, exported in Excel or .pdf formats.

To save a report template as a new document
 1. Click the Flexible Reporting button and select Save as.
 2. After File name, type the name of the new template.

NOTE:Only you can run and view reports you have created and designated as not shared. Shared
reports can be run and viewed by others.

 3. If you want to allow others to run the report, select theShared check box.
 4. Click Save.

To savemodifications to a report template
l Click the Flexible Reporting button and select Save.

To export a report in Excel or .pdf format
l In the Preview window, above the generated report, click theSave button, select Excel, and specify

the location to save the report as an Excel file, or select Acrobat (PDF) file and specify the location to
save the report in .pdf format.
Optionally, click the Export report button, on the View tab of the ribbon, and specify the file type and
location, as above.

Printing reports
To print a report you ran on the Preview tab

l On the Preview window toolbar, click thePrint button.
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Chapter 17

IVR Routing

IVR Routing features
Configuring IVR Routing
IVR Routing call flow samples
IVRRouting complex call flow configuration
Pre-configuredmessages and prompts
Configuring remote IVR Routing nodes with the
Enterprise Server in a workgroup
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IVR Routing
An IVR Routing license includes IVR Routing ports and Visual Workflow Manager. Mitel IVR Routing is an all-
in-one, scalable, integrated voice processing solution that works in conjunction with Contact Center
Management.

IVR Routing's Visual Workflow Manager application enables you to rapidly and intuitively
l Build call flows in a drag-and-drop graphical interface
l Create and relay static,dynamic, and custom recorded prompts to callers in queue
l Provide callers with estimated wait time or position in queuemessaging
l Guide callers to the information, extension, or ACD queue that best meets their needs
l Allow customers to request a queued callback by leaving a voicemessage or using theWeb
l Provides call flow branching based off ANI, DNIS, schedules, and queues
l Report on IVR activity

IVR Routing is activated during the Contact Center Management installation process, if you are licensed for
IVR Routing. For information on installing Contact Center Management, see theContact Center Management
Installation Guide. For information regarding installing IVR Routing on a Remote Server, see theContact
Center Management Installation Guide.

NOTE:
l To support IVR Routing resiliency and redundancy, youmust have at least one non-resilient extension

programmed on the queuing gateway and configured in the Contact Center Management database
(either manually or via synchronization). In addition, theremust be aMiTAI monitor set on this
extension. This is done in YourSite Explorer by ensuring the "Disable real-timemonitoring and data
collection on this device" check box is not selected. (Note: This check box is deselected by default.)
Having theMiTAI monitor set on the extension enables our software to recognize when the connection
to the queuing gateway is restored following a network outage.

l As a limitation of the telephone system, dual-tonemulti-frequency signaling (DTMF) digits are only
detected if the SIP trunks are configured to send via DTMF 2833. If your SIP trunks are configured to
send DTMF digits in-band, IVR Routing will not detect any DTMF digits.

l Call record data generated on remote IVR Routing nodes when themain IVR Routing server is offline
will not be reported on.
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IVR Routing features
IVR Routing includes the following features.

l Visual diagramming—Build call flows on a Call flow Canvas. Visual Workflow Manager enables you
to drag all activities, including transfers, database read/write, interactivemenus, verified collected
digits, and routing conditions to the Canvas to build call flows.

l New hunt group configuration—Hunt groups have been added and are configured in YourSite
Explorer.

l New prompt and playlist editor—Prompts (playlist editor) are now configured in YourSite Explorer.
You are able to view the list of system, queue, voice readback, and custom prompts and assemble
them to create playlists. Additionally, you can import, preview, and record prompts.

l Network Monitor enhancements—Network Monitor enables you to set alarms on critical IVR and
call flow functionality, such as audio failure.

l Sample call flows—The IVR Routing call flow samples are based on common business scenarios.
They not only demonstrate how IVR Routing can be used to efficiently direct calls to appropriate
queues but, because they can be imported directly into your IVR Routing application, they save you the
time of creating your own introductory call flows. See "IVR Routing call flow samples" on page 525.

Configuring IVR Routing
You configure all aspects of IVR Routing in YourSite Explorer.

Youmust provision your IVR Routing environment in the following order:
 1. Media servers - select themedia server type and set themedia server settings and options.

See "Configuringmedia servers for IVR Routing" on page 439.
 2. Ports and extensions - select the extension type and set extension settings and options.

See "Configuring extensions" on page 440.
 3. Hunt groups - select the phone lines associated to each hunt group and configure the destination point

for each hunt group.
See "Configuring hunt groups" on page 443.

 4. Call flows - add various activities and configure their properties and order of execution for incoming
calls.
See "Building call flows" on page 448.

Starting YourSite Explorer
To start YourSite Explorer
 1. OpenYourSite Explorer.
 2. Type your username and password and verify the Enterprise Server IP address.
 3. Click Log on.

YourSite Explorer opens.
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Viewing Visual Workflow Manager
You can view Visual Workflow Manager in two formats: Horizontal and Vertical.

To select a view type
 1. In the left pane, click Visual Workflow Manager.
 2. In the ribbon, click View.
 3. In the Page layout pane, select Horizontal, Vertical, orData Grid.

NOTE: The Data Grid view is not available for all Visual Workflow Manager devices.

Using the Import Wizard
The Import Wizard enables you to import a .csv file containing all of your IVR information. The .csv file must
have individual pieces of information separated by commas or by tabs. You can prepare a .csv file using
Microsoft Notepad.

For information on importing .csv files using the Import tool, see "Importing a range of devices using a .csv
file" on page 122.

Building conditions in IVR Routing features and activities
Many features in IVR Routing require users to configure conditions. These include:

l Routing rules
l Queue callback conditions
l Schedule conditions
l Queue conditions
l Variable compare conditions

While the individual types of expressions that can be added to conditions and their configurationmay vary
between the conditions being built, IVR Routing’s interface for adding, deleting, and grouping expressions
remains consistent throughout IVR Routing.

Adding and removing expressions
To add an expression

l Click theAdd button.
An expression is added to the condition.
NOTE:When an expression is added, it will be highlighted in red if it requires additional configuration.
The expression will remain highlighted in red until configured.

To remove an expression
l Select the expression you want to delete and click the Delete button.

The expression is removed from the condition.
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Grouping expressions
IVR Routing enables users to group expressions, facilitating the easily construction of detailed and specific
conditions. While grouping is associated with a number of different activities, configurations, and dialogs, the
grouping clauses are consistent throughout IVR Routing. Expressions within a groupmay also be grouped
together to create nested levels of sub-groups within a single group.

NOTE:We recommend you do not exceed eight levels of grouping within a group of expressions even though
IVR Routing is capable of handling greater than eight levels of grouping.

Expressions may be grouped by one of two clauses:
l AND:Expressions grouped by the AND clause require that all the expressions in a group bemet to

successfully meet the condition.
l OR:Expressions grouped by the OR clause require that only one of the expressions in a group bemet

to successfully meet the condition.

To group expressions
 1. Holding down theShift key, select the topmost expression in the range of expressions you want to

group and then select the last expression in the range of expressions you want to group.
All expressions in between these two expressions will be selected.
NOTE:

l Grouped expressions must be adjacent to each other. Holding downCTRL and selecting
individual expressions will select all expressions between the first and last expression you
selected.

l You cannot add an expression to an existing group. If you want to add an expression to an
existing group, ungroup the expression and then regroup it with the expression you want to
add.

 2. Click either the group AND or group OR buttons.
The expressions are grouped with the selected clause.

To ungroup grouped expressions
 1. Click the group’s drop-downmenu button.
 2. Select Ungroup.

To add a new expression to a group
 1. Click the group’s drop-downmenu button.
 2. Select Add.

An expression is added to the group.

To remove a single expression from a group
 1. Click the expression’s drop-downmenu button.
 2. Select Ungroup.

The expression is removed from the group.

Configuring media servers for IVR Routing
IVR Routing supports 3300 ICP media servers. You add and configure 3300 ICP servers in YourSite Explorer.
For more information, see "Adding 3300 ICP media servers" on page 75.
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Configuring extensions
An extension is a telephone system answer point that handles calls. Each extension has a specific extension
number. A caller to your contact center is presented with options to dial various answering points. The caller
can dial an individual agent at an extension through a queue number.

Following is a list of the five extension types specific to IVR Routing and their functions:
l RAD port 5020 IP: is used to play RAD (Recorded Announcement Device) messages for queue

announcements.
l Messaging port 5020 IP: is used to process voice call flows
l Outbound port 5020 IP: is used to process outbound call flows
l Callback port 5020 IP: is used to process Outbound Callback requests
l UPiQ port 5020 IP: is used to process UPiQ (Updated Position in Queue) messages

NOTE:
l Any extensions configured on the telephone switch are retrieved during synchronization and are shown

in the extensions list.
l IVR Routing uses 5020 IP port as its port type. APPSERVER ports that were used with Intelligent

Queue cannot be transitioned over to IVR Routing. When you install IVR Routing, you need to create
new ports. You cannot reuse ports that were previously used for Intelligent Queue, but you can delete
these ports and reuse the dialable numbers. You can also reuse existing hunt groups.

l TheOutbound extension option is only available to clients with IVR Routing Premium licensing.
l RAD 5020 IP ports must be assigned to the samemedia server as the queues receiving the RAD

messages.

Adding extensions
To add an extension
 1. In the left pane, click Visual Workflow Manager.
 2. Click Extensions.
 3. Click Add.

A new extension is added to the extensions list.
 4. Complete the following fields:

l Name—type a name for the extension.
l Reporting/Dialable number—enter a dialable number for the extension.
l Extension type—select the extension use type from the drop-down list.
NOTE:Ensure you select the correct extension type for the port. For example, if you want the
extension to be amessaging port, select Messaging port 5020 IP. If you want the extension to be
a RAD port, select RAD port 5020 IP, etc.

l Media Server—select amedia server from themedia server list.
NOTE: Callback ports must be assigned to the samemedia server(s) as the queues to which
callbacks are directed.

l Failover media server–select a failover media server to handle the call load in the event the
primary media server goes offline.

l Class of service–automatically populated based on the Class of Service set earlier in theMedia
servers section.

 5. If you want to disable real-timemonitoring and data collection on this device, select Disable real-time
monitoring, data collection and call handling on this device.
NOTE: This option is only used to unlicense the port and discontinue its use. Unlicensed extensions
can be assigned to a call flow but will not go into service or be visible in Contact Center Client.
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 6. Configure thePort Options as follows:
l AfterCall flow, click ... and select the call flow to which you want to associate the extension.
NOTE:UPiQ and Callback ports do not allow you to select a call flow; the call flow is
automatically associated to the port.

l AfterPort State, select eitherNormal orEmergency from the drop-down list.
Select "Emergency" as the port state only if this port is associated to a call flow that is configured
to have an emergency path. You can configure a port state as "Emergency" when applicable
either within YourSite Explorer directly or by using aManagement Plan remotely.

l Select the Trusted Service Level check box to set the service level for the 5020 IP port to
"trusted". This step is necessary if you are usingMCD 5.0+, otherwise, do not select this check
box.
NOTE: In order to set the trusted service level in YourSite Explorer, youmust have already
enabled write-back functionality on themedia server. (See "Enabling write-back functionality" on
page 79). If you do not have write-back enabled, youmust set the trusted service level on the
telephone system, instead of in YourSite Explorer, by logging in to the 3300 ICP, navigating to
User and Device Configuration, clicking the extension for which you want to set the service
level, and, on the Profile tab, selecting Trusted from the drop-down list beside Service Level.

l Select the This is a remote port check box if applicable.
l AfterRemote Server, if this is a remote port, click ... and select the remotemedia server on

which IVR Routing is configured.
l AfterMiTAI / MiAudio Local Binding IP Address, select the appropriate IP address.
NOTE: This option is used if you havemore than one NIC and want to specify which one is used
for MiTAI/MiAudio, for example, if you have a voice and data network split.

l ThePort License area details how many IVR Routing port licenses remain and how many
primary and redundant ports are in use.

 7. On the ribbon, click Save.
NOTE: If, after you configure and save the extension, it does not come in to service, check to see if the
prairieFyre IVR Inbound Service is installed and running. If you discover this service is not installed, it
may be that you were not licensed for IVR Routing at the time of installation. If that is the case, you
must re-run theMitel Contact Center ConfigurationWizard to reinstall the IVR Routing services.

Viewing specific extension types
To view specific types of extensions
 1. In the left pane, click Visual Workflow Manager.
 2. Click Extensions.
 3. Click Filter.
 4. From the drop down list, click the extension type you want to view.

NOTE:Only extensions of the type you selected are shown. If you select None, all extension types are
shown.

Deleting extensions
To delete an extension
 1. Select an extension from the extension list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.

The extension is deleted and removed from the extension list.
NOTE:You cannot delete an extension if it is associated to a hunt group.
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Using Extension Quick Setup
The Extension Quick Setup enables you to import extensions into YourSite Explorer from the telephone
switch.

To use quick setup to import extensions
 1. In the left pane, click Visual Workflow Manager.
 2. Click Extensions.
 3. Click Quick Setup.

The Extension Quick Setup pane opens.
 4. AfterActive number from, specify the first dialable number of the extension you want to add.
 5. AfterActive number to, specify the last dialable number of the extension you want to add.
 6. AfterName prefix, enter the text you want prefixed to the name of the port.
 7. AfterName postfix, enter the text you want postfixed to the name of the port.
 8. On theGeneral tab, configure theMedia server options as follows:

l Extension type:Select the extension type from the drop-down list.
NOTE:Ensure you select the correct extension type for the port. For example, if you want the
extension to be amessaging port, select Messaging port 5020 IP. If you want the extension to be
a RAD port, select RAD port 5020 IP, etc.

l Associate the devices to this media server:If you want to configure your ports to be resilient,
click ..., select a failover media server from the list, and click OK.

l Associate the devices to this failover media server:Click ..., select a failover media server
from the list, and click OK.
NOTE: The failover media server will be used to handle the call load in the event the primary
media server goes offline (only for voice extensions).

l Class of service: This field is automatically populated based on the Class of Service set during
media server configuration if there is a default Class of Service selected for the type of port you
are creating.

l Disable real-time monitoring, data collection and call handling on this device: If you
want to disable real-timemonitoring, data collection, and call handling for this extension, select
this check box.
NOTE:

l Selecting this option unlicenses the port and discontinues its use. Unlicensed
extensions can be assigned to a call flow but will not go into service or be visible in
Contact Center Client.

l Any ports created after you become overlicensed will have this option enabled
 9. Configure thePort Options as follows:

l AfterCall flow, click ... and select the call flow you want to which you want to associate the
extension.
NOTE:UPiQ and Callback ports do not allow you to select a call flow; the call flow is
automatically associated to the port.

l AfterPort State, select eitherNormal orEmergency from the drop-down list.
Select "Emergency" as the port state only if this port is associated to a call flow that is configured
to have an emergency path. You can configure a port state as "Emergency" when applicable
either within YourSite Explorer directly or by using aManagement Plan remotely.

l Select the Trusted Service Level check box to set the service level for the 5020 IP port to
"trusted". This step is necessary if you are usingMCD 5.0+, otherwise, do not select this check
box.
NOTE: In order to set the trusted service level in YourSite Explorer, youmust have already
enabled write-back functionality on themedia server. (See "Enabling write-back functionality" on
page 79). If you do not have write-back enabled, youmust set the trusted service level on the
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telephone system, instead of in YourSite Explorer, by logging in to the 3300 ICP, navigating to
User and Device Configuration, clicking the extension for which you want to set the service
level, and, on the Profile tab, selecting Trusted from the drop-down list beside Service Level.

l Select the This is a remote port check box if applicable.
l AfterRemote Server, if this is a remote port, click ... and select the remotemedia server on

which IVR Routing is configured.
l AfterMiTAI / MiAudio Local Binding IP Address, select the appropriate IP address.
NOTE: This option is used if you havemore than one NIC and want to specify which one is used
for MiTAI/MiAudio, for example, if you have a voice and data network split.

l ThePort License area details how many IVR Routing port licenses remain and how many
primary and redundant ports are in use.

 10. If you want to create an employee for each extension, on theEmployee associations tab, select the
Create an employee ID for each extension check box.

 11. AfterStart the employee IDs at, type the first employee ID to associate to this extension.
 12. After Increment the employee IDs by, type the increment by which the employee IDs will increase.
 13. Click Run.

Configuring hunt groups
A hunt group is a collection of extensions. When a call enters the system and is routed to a hunt group, the
hunt group searches its members for an available extension and directs the call to that number. Calls are
rotated through the hunt group until an available extension is found and the caller can be connected. Hunt
groups can be configured to be resilient, using a failover media server if the primary server fails.

NOTE:
l Any hunt groups configured on the telephone switch are retrieved during synchronization and are shown

in the hunt group list.
l For information on enabling ports shared by hunt groups to play different messages to different queues,

see "Dynamic RAD messages" on page 455.

Adding hunt groups
To add a hunt group
 1. In the left pane, click Visual Workflow Manager.
 2. Click Hunt Groups.
 3. Click Add.

A new hunt is added to the hunt group list.
 4. Complete the following fields:

l Name–Type a name for the hunt group.
l Dialable–Type a dialable number for the hunt group.
l Media Server–Click ..., select amedia server from the list, and click OK.
l Failover media server—Click …, select a failover media server from the list, and click OK.
l Class of Service–This field is automatically populated based on the class of service set earlier

in themedia servers section.
l Hunt Group Type–Select the type of extensions for this hunt group:

l Voice – handles messaging type extensions
l RAD – handles RAD type extensions
l Phantom – performs modified DND rerouting
l VoiceMail – handles voicemail type ports
l HCI Reroute – enables external applications to tell the system how to route calls
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l Recorder – handles groups of devices using the Record-A-Call feature
l Emergency – identifies the group as an Emergency Call notification hunt group
l Name Tag – identifies the group as using destination-based name tags for display on the

ringing sets
l Hunt Group Mode–Select Terminal if you want the first line in the hunt group list to always be

used or select Circular if you want the next line in the hunt group to be used.
NOTE:RAD hunt groups must be terminal.

l Priority–Specify the hunt group priority level. The priority level ranges from 1 (highest) to 64
(lowest).

l Phase timer ring– This option is only configured if you are using a RAD hunt group type and
determines the delay required between successive recorded announcements If no delay is
required, select "0".

 5. On the ribbon, click Save.

Adding extensions to hunt groups
Hunt groupmembers are extensions. To be amember of a hunt group, the extension and the hunt groupmust
be of the same type. For example, you can only add RAD extensions to RAD hunt groups.

To add an extension to a hunt group
 1. In YourSite Explorer, click Visual Workflow Manager.
 2. Click Hunt Groups.
 3. Select a hunt group from the hunt groups list.
 4. On theMembership tab, underAvailable members, select the extension you want to add to the hunt

group.
NOTE:The Available members pane only displays extensions belonging to the samemedia server as
the hunt group. Available members are also filtered by hunt group type.

 5. Click the > button.
The extension displays in the Selectedmembers window and is now part of the hunt group.
NOTE:

l If you have assigned the hunt group a Circular Mode, extensions are searched in the order in
which they appear in the Selectedmembers pane. If you have assigned the hunt group a
Terminal Mode, extensions are searched in chronological order and the first available
extension is selected first. See "Adding hunt groups" on page 443.

l If your call flow uses Dynamic RAD messages, configure each hunt group to begin its search
starting on different extensions. You do this by changing the order in which extensions appear
in the Selectedmembers pane for each hunt group. For more information on Dynamic RAD
messages, see "Dynamic RAD messages" on page 455.

 6. Repeat steps 4 and 5 for all additional extensions you want to add to the hunt group.
 7. If your contact center uses a remote configuration, click the Interleave button to distribute the hunt

groupmembers equally throughout your servers.
 8. On the ribbon, click Save.

Viewing specific hunt group types
To view specific types of hunt groups
 1. In the left pane, click Visual Workflow Manager.
 2. Click Hunt Groups.
 3. Click Filter.
 4. From the drop down list, click the hunt group type you want to view.

NOTE:Only hunt groups of the type you selected are shown. If you select None, all hunt group types
are shown.
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Deleting hunt groups
To delete a hunt group
 1. In the left pane, click Visual Workflow Manager.
 2. Click Hunt Groups.
 3. Select a hunt group from the list.
 4. Click Delete.

The Delete these elements dialog box opens.
 5. Click OK.

The hunt group is deleted and removed from the hunt group list.

Configuring queues
A queue consists of a group of agents responsible for answering calls pertaining to a specific product, service,
department, or functional area within your organization. Agents can bemembers of multiple queues, handling
calls for multiple departments, services etc., depending on the agent's knowledge and availability.

NOTE:Any queues configured on the telephone switch are retrieved during synchronization and are shown in
the queues list.

Adding queues
To add a queue
 1. In YourSite Explorer, in the left pane, click Visual Workflow Manager.
 2. Click Queues.
 3. Click Add.
 4. Specify theName andReporting Number for the queue.

NOTE: The queue reporting number for a phone queuemust be the same as the path reporting number
on the telephone system assignment forms. In addition, to ensure accurate reporting, queue reporting
numbers must be unique across both active and inactive queues.

 5. AfterMedia server, click ..., select themedia server for the queue, and click OK.
 6. UnderQueue service objective, specify theService Level goal and theService Level time.
 7. If the queue is a voice or chat queue, underHandling, afterShort Handle less than, type the duration

for the call talk parameter.
If the talk time is less than the call talk parameter, then the call is a short talk call (for example, type 3 to
define a short talk call as a call the agent makes that lasts less than 3 seconds). Short talk calls are
included in call statistics.

 8. AfterShort Abandon less than, type the duration for the call abandon parameter.
If the abandon time is less than the call abandon parameter, then the call is a short abandon call and is
not included in the call statistics (for example, type 5 to define a short abandon call as a call that lasts
less than 5 seconds).

 9. If you want to configure the queue’s work timer, underWork timer options, select theUse work timer
check box and specify the duration. The default duration is 00:00:00.
NOTE:

l Queue work timer maximum duration is dependent upon your telephone system.
l MCD 5.0 and greater – 4 hours maximum
l MCD 4.x or earlier – 10minutes maximum

l A queue’s work timer must not exceed the Class of Service associated with any agents in
agent groups who are associated with this queue. See "Editing Class of Service options" on
page 110.
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 10. To force agents to enter call classification Account Codes, select the Force entry of a classification
code check box.
NOTE: This feature is hidden unless you are licensed for Contact Center PhoneSet Manager.

 11. To automatically cancel contact center work timer, select theCancel work timer once code is
entered check box.
NOTE:Do not select this option if your contact centers use Salesforce.com Connector. Deselecting
this option enables agents to stay in work timer presence until they finish entering call log information in
their Contact Center Salesforce.com Connector.

 12. If you want to add contact center work timer time to handling time, select the Include work timer as
part of handling time check box.

 13. If the queue is a voice queue, afterDialable number, type the path directory number listed on the
telephone system assignment forms.

 14. To configure a new queue for web callbacks, see "Enabling callbacks" on page 462.
 15. To configure a new queue for UPiQ, see "Configuring UPiQ options" on page 448.
 16. On the ribbon, click Save.

Associating agent groups to queues
To associate an agent group with a queue
 1. In YourSite Explorer, in the left pane, click Visual Workflow Manager.
 2. UnderDevices, click Queues.
 3. Select a queue from the list.
 4. On theMembership tab, underAvailable members, select an agent group and click > to move the

agent group to theSelected members list.
 5. On the ribbon, click Save.

Configuring business hours for queues
To configure business hours for a queue
 1. In YourSite Explorer, in the left pane, click Visual Workflow Manager.
 2. UnderDevices, click Queues.
 3. Select a queue from the list.
 4. Click theBusiness Hours tab.
 5. After Business-hour schedule, click ..., select a schedule to associate with the queue, and click OK.
 6. If you want real-time statistics and reports to only be generated during business hours, select Generate

real-time statistics and reports only within the business hours selected.
 7. If you want to apply the selected business hour schedule to all queues associated with this media

server, click Submit.
 8. On the ribbon, click Save.

Configuring queue spectrum values for queues
To configure queue spectrum value for a queue
 1. In YourSite Explorer, in the left pane, click Visual Workflow Manager.
 2. UnderDevices, click Queues.
 3. Select a queue from the list.
 4. Click theQueue Spectrum tab.
 5. Adjust theAbandon, Answer, and Interflow values and click Submit.
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Configuring 3300 ICP options for queues
On the 3300 ICP options tab, you specify queue priority, the directory number for the queue unavailable
answer point, queue interflow options, and RAD message options.

RAD messages are associated to queues and can broadcast to up to 50 callers in the queue. After a call is
received and has traveled through a call flow to a queue, RAD messages can be configured to play at
programmed intervals for all callers in that queue. Up to four RAD messages can be associated to each
queue. A typical RAD messagemay greet the caller and thank them for holding.

RADs have been optimized in Contact Center Solutions tominimize the number of RAD devices that IVR
Routing requires. Previously, RADs weremapped to a specific queue and its position. RAD optimization
enables you to reduce the number of ports your system uses by configuring one port to play amessage
simultaneously to multiple queues.

NOTE: A minimum of MCD 5.0 is required for RAD optimization to function.

To specify 3300 ICP options for a queue
 1. In YourSite Explorer, in the left pane, click YourSite.
 2. UnderDevices, click Queues.
 3. Select a queue from the list.
 4. On the 3300 ICP options tab, underGeneral, specify the priority level of the queue and the queue

unavailable answer point directory number.
The highest priority level is 1. The lowest priority level is 64.

 5. Under Interflow options, specify interflow options for the queue.
You select Interflow to this queue uses this queue’s priority if you want interflowed calls to use the
queue’s priority. Otherwise, interflowed calls will retain the priority levels of their originating queues.

 6. UnderRecording options, specify the following RAD messaging options:
l Dialable—enter the dialable number of the port or hunt group you want to use to play the RAD

message
l Start delay—specify the time that must pass after a caller enters the queue or from when the last

message finished playing before playing the RAD message
l Interflow dialing list—select the interflow dialing list you have configured on the telephone

system
l Release digit receiver after recording—select the digit to stop recording
l Embeddedmusic source—select the in-queuemusic list you have configured on the telephone

system
l Alternative dialable—enter a secondary port or hunt group you want to use to play the RAD

message.
 7. If you want to repeatedly play the RAD message, select Repeat recording enabled and specify the

repetition interval.
 8. AfterDTMF Receiver Unavailable Action, specify the action when a dial out from aRAD is

programmed but no DTMF receiver can be seized to enable that functionality.
l Play RAD—plays a RAD message. The caller may be prompted with the option to dial out
l Skip—does not play a RAD message but leaves the caller in the queue
l Divert—transfers the caller to the number programmed in the DTMF Receiver Unavailable

Answer Point Directory Number field
 9. AfterDTMF Receiver Unavailable Answer Point Dialable, enter the desired directory number. For

numbers longer than seven digits, program this field as a speed call.
NOTE: The DTMF Receiver Unavailable Action field must be set to Divert.

 10. On the ribbon, click Save.
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Configuring UPiQ options
Updated Position in Queue (UPiQ)messages inform customers of their initial queue position and dynamically
continue to inform them of their position in queue and estimated wait time. The UPiQ configuration options
enable you to set theminimum andmaximum positions at which callers hear UPiQmessages, the duration of
time before callers hear an initial position in queuemessage, the intervals at which callers are informed of their
position in queue, and the language of the UPiQ prompts.

To configure UPiQ options
 1. In YourSite Explorer, click Visual Workflow Manager=>Queues, and select a queue from the queue

list.
 2. Under theVWM Options tab, select UPiQ.
 3. To set up the queue for UPiQ, select theEnable checkbox.
 4. Click the Change Priority button.

The UPiQ Priority Dialog box opens.
 5. To adjust the priority of a queue, select the queue and click the up or down arrow.

NOTE:The Priority number corresponds to the frequency in seconds within which a queue will attempt
to find a port if it does not find one on the first try. The quicker a queue finds a port, the sooner IVR
Routing can report on a caller’s position.

Building call flows
Call flows are the pathways callers use to reach all areas and individuals in your organization. Call flows
dictate the prompts callers hear, the inputs requested by the system, and the available routing options. Call
flow functionality can identify customers and determine their service needs by phone number, toll-free
numbers dialed, and the digits callers enter to reach specific areas of your organization. Proper call flow
configuration is necessary to direct callers to the agents, departments, and employees best qualified to handle
their requests.

The functions performed when a caller contacts your organization depend on the activities included in the call
flow. For more information on all available call flow activities and their descriptions, see "Activities" on page
479.

NOTE:
l If your contact center routinely handles a high volume of calls, for optimal traffic handling, we

recommend using subroutines in your call flows or increasing the number of available ports for your
call flows. For more information on subroutines, see "Building subroutines" on page 458.

l After you have built a call flow, youmust associate it to extensions or hunt groups in order to make
the call flow go "live" in your system. For more information, see "Associating call flows to
extensions or hunt groups" on page 454.
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Call flow types
Call flows are categorized into three types.

l RAD—plays RAD messages to all callers in their associated queues
l Voice—directs incoming calls to the agents, departments, and employees best qualified to handle their

requests
l Management—enables managers tomake changes to the incoming caller options in the event of an

emergency or unforeseen circumstance, as well as record new prompts using a phone.
l Outbound—makes outgoing calls to external and internal numbers. Once connected, an Outbound call

flow can play the connected party a greeting or ask them to enter information into IVR Routing.
Outbound call flows can also transfer a connected party to a queue, agent, or extension automatically
or based on responses to an optionmenu.
NOTE:Outbound call flows and extension options in YourSite Explorer are only available with IVR
Routing Premium licensing.

Each type of call flow offers you a contextual selection of Visual Workflow Manager activities from which to
build your specific call flow. For more information on activities, see "Activities" on page 479.

Call flow examples
The following call flow examples are provided to aid in understanding various call routing scenarios.

Example 1 — ANI routing
The ANI routing example shows a call flow that routes calls based on the phone number of the customer
contacting your company. Incoming calls are answered and, based on configured telephone routing rules,
routed to the sales department in the incoming call's country of origin. (See Figure 17 - 1.) In order to access
the ANI activity when building call flows, youmust have either Advanced or Premium IVR Routing licensing.

Figure 17 - 1 ANI routing call flow example
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Example 2 — DNIS routing
The DNIS routing example shows a call flow that routes calls to separate product lines based on the toll-free
line dialed by the customer. Incoming calls are answered and, based on the toll-free number dialed, routed to
the queue responsible for handling call requests for that product line. (See Figure 17 - 2.) In order to access the
DNIS activity when building call flows, youmust have either Advanced or Premium IVR Routing licensing.

Figure 17 - 2 DNIS routing call flow example

Example 3 — Schedules and Menus
The schedules andmenus routing example shows a call flow that first routes calls through a schedule to
determine the action to perform based on the date and time of the call. (See Figure 17 - 3.) If within business
hours, the call flow provides a user menu to the caller.

Figure 17 - 3 Schedules and menus call flow example
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Example 4 — Collected Digits
The premium collected digits call flow example shows a call flow that routes calls based on the extension
number inputted by the caller. The call is answered and the caller is prompted to enter the extension number of
the party they want to reach. A call routing decision is thenmade based on the collected digits. (See Figure 17
- 4.) In order to access the Collect Digits activity when building call flows, youmust have Premium IVR
 Routing licensing.

Figure 17 - 4 Collected digits call flow example
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Creating RAD, Voice, Management, and Outbound call flows
NOTE:

l Call flows must begin with an Answer activity if you intend to play amessage or collect digits. A call
flow must end with a Hangup activity if you do not end with a Transfer activity.

l A call flow may be assigned to a hunt group or a port. It is recommended to add one or the other, but you
may configure a call flow to be amember of both.

l The Validate call flow check box in the call flow Properties pane, which is selected by default, enables
Visual Workflow Manager to validate your call flow and its activities to ensure that there are no
programming errors. While this is enabled, youmust address any errors before the call flow can be
saved and assigned to a port or hunt group. Disabling this option enables you to save and experiment
with a prototype call flow beforemaking it live on your system.

l For information on using Dynamic RAD messages in call flows, see "Dynamic RAD messages" on
page 455.

To create a call flow
 1. In the left pane, click Visual Workflow Manager.
 2. Click Call flows.
 3. Click Add.

The call flow drop down opens.
 4. Select eitherVoice, RAD,Management, orOutbound call flow type.

The selected call flow type is added to the call flow list.
NOTE: The call flow type selected determines the activities available to be added to the call flow.

 5. In theProperties pane on the right, underName, enter a name for the new call flow.
NOTE: The namemust contain only alphanumeric characters and spaces.

 6. AfterSystem Name, enter a system name.
The default System Name is TelephonyCallflow.
NOTE: System Names must be unique. They must only contain characters from A-Z or from 0-9 and
cannot contain spaces.

 7. Click the Toolbox tab at the bottom of the Properties pane.
The Toolbox pane opens.

 8. Click and drag the Activities you want to add to theDrop Activities Here section of the interface under
theDesigner tab of the call flow.

 9. If you want to assign your call flow to a hunt group, click theHunt Group Membership tab.
 10. Click on a hunt group in theAvailable members pane and click the > button to assign hunt groups to

the call flow.
The hunt group is added to the Selectedmembers pane.

 11. If you want to assign your call flow to a port, click thePort Membership tab.
 12. Click on a port in theAvailable members pane and click the > button to assign ports to the call flow.

The port is added to the Selectedmembers pane.
 13. On the ribbon, click Save.

Filtering call flows
You can filter which call flow types are shown in the call flow list.

To filter call flows
 1. Click Filter.
 2. From the drop downmenu, select the call flow type you want to view.

NOTE:Only the call flow type you selected is shown in the call flow list.
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Copying call flows
You can quickly and easily reuse existing call flows as templates for new call flows by copying and pasting
them. A copied call flow retains all of the actions, menus, and conditions of the original call flow, but is not
bound to any port or hunt group.

To copy a call flow
 1. In the left pane, click Visual Workflow Manager.
 2. Click Call flows.
 3. Right-click on the call flow you want to copy and select Copy.
 4. Right-click anywhere in the call flow list and select Paste.

The call flow is copied.
 5. Select the copied call flow.
 6. If you want to assign your call flow to a hunt group, click theHunt Group Membership tab.
 7. Click on a hunt group in theAvailable members pane and click the > button to assign hunt groups to

the call flow.
The hunt group is added to the Selectedmembers pane.

 8. If you want to assign your call flow to a port, click thePort Membership tab.
 9. Click on a port in theAvailable members pane and click the > button to assign ports to the call flow.

The port is added to the Selectedmembers pane.
 10. On the ribbon, click Save.

Deleting call flows
To delete a call flow
 1. Select the call flow you want to delete from the call flow list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.

Importing and exporting call flows
Visual Workflow Manager enables you to import and export call flows. You can export and save call flows to
the local hard drive. Saved call flows can then be copied to another computer and imported for use. Imported
call flows are automatically converted to the latest version of IVR Routing.

NOTE:
l After importing a call flow, youmust configure your own prompts and connect the call flow to devices

that are specific to your system. If the prompts you configure or the connections youmake to devices
are invalid, a red exclamationmark icon displays on the Call flows Canvas indicating a validation error.
Selecting the relevant activity and clicking the exclamationmark icon indicates the specific errors you
must correct.

l Youmust associate a completed call flow to extensions or hunt groups in order to make it go "live" in
your system. For more information, see "Associating call flows to extensions or hunt groups" on page
454.
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To import a call flow
 1. In YourSite Explorer, click Visual Workflow Manager=>Call flows.

The Call flows pane opens.
 2. Click the Import button

The Select a .xoml file window opens.
 3. Browse to the .xoml file you want to import and click Open.

The call flow is added to the Call flows list
 4. On the ribbon, click Save.

To export a call flow
 1. In YourSite Explorer, click Visual Workflow Manager=>Call flows.
 2. Click Export.

The Save Call flow window opens.
 3. Browse to the location that you want to save the file.
 4. Name the file and click Save.

The file is saved to the location you specified.

Associating call flows to extensions or hunt groups
After building a call flow or importing a call flow into IVR Routing, youmust associate the call flow to an
extension or hunt group in order to make the call flow go "live" into your system.

NOTE: You can only associate call flows to extensions or hunt groups that are of the same type as the call
flow. For example, you cannot associate a RAD call flow to a Callback extension type.

To associate a call flow to an extension
 1. In YourSite Explorer, click Visual Workflow Manager=>Extensions.
 2. From theExtensions pane, select an extension to associate to the call flow.

NOTE: For IVR Routing sample call flows, youmust select an extension with aMessaging port 5020
IP extension type.

 3. UnderPort Options, afterCall flow, click the… button.
The Select a call flow window opens.

 4. Select the call flow you want to associate to the extension and click OK.
NOTE: The Select a call flow window only displays call flows that do not contain validation errors and
are the same type as the extension.

 5. AfterPort State, select eitherNormal orEmergency from the drop-down list.
Select Emergency only if this port is associated to a call flow that is configured to have an emergency
path.

 6. On the ribbon, click Save.

To associate a call flow to a hunt group
 1. In YourSite Explorer, click Visual Workflow Manager=>Extensions.
 2. From theHunt Groups pane, select a hunt group to associate to the call flow.
 3. Select theOptions tab.
 4. UnderVWM Settings, afterCall flow, click the ... button.

The Select a call flow window opens.
 5. Select a call flow and click OK.
 6. AfterPort State, select eitherNormal orEmergency from the drop-down list.

Select Emergency only if this port is associated to a call flow that is configured to have an emergency
path.

 7. On the ribbon, click Save.
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Dynamic RAD messages
Dynamic RAD messages enable a group of IVR Routing ports, shared by multiple hunt groups, to play
different RAD messages to callers waiting in queue. For example, if hunt groups for a Sales queue and a
Customer Service queue share a port, a call flow using Dynamic RAD messages enables the shared port to
play a Sales greeting to the Sales queue and a Customer Service greeting to the Customer Service queue.
Because Dynamic RAD messaging reduces the number of ports required to play messages, it is a cost-
effectivemeans of tailoring greetings to queues. For more information on configuring RAD messages for
playback, see "Configuring 3300 ICP options for queues" on page 447.

NOTE:
l To ensure the expected Dynamic RAD functionality, we recommend that you configure each hunt

group to begin its search starting on different extensions. See "Adding extensions to hunt groups" on
page 444.

l Dynamic RAD messages can only be used within RAD call flows.

To use Dynamic RAD messages in call flows, youmust ensure that
l Media server configuration is complete. Dynamic RADs require that all hunt groups, extensions, and

Class of Service options are populated with data from the 3300 ICP. For more information on
configuringmedia servers, see "Adding 3300 ICP media servers" on page 75.

l Full Synchronization is completed. For information, see "Performing synchronization" on page 104.
l Extension configuration is complete. Dynamic RAD messages require that each IVR Routing port

playing themessages is set to RAD port 5020 IP. Youmust also enable Trusted Service Level for the
relevant extensions. See "Configuring extensions" on page 440.

l Hunt group configuration is complete. Dynamic RADs require hunt groups to be configured as RAD
 hunt group types and that the appropriate RAD extensions have been added to the hunt groups you will
use in your call flow. See "Configuring hunt groups" on page 443.

l If you using are an IVR Routing instance on a Remote Server, ensure that remote configuration is
complete. Dynamic RAD messages require that the relevant ports are specified as remote ports and
assigned to the Remote Server. See "Configuring extensions" on page 440.

l You have configured the necessary prompts for your RAD messages. See "Configuring prompts" on
page 459.

l You have associated the call flow to the ports (extensions) that will play the RAD messages and to the
appropriate hunt groups. See "Associating call flows to extensions or hunt groups" on page 454.

l If you are usingmultiple, un-teamedNICs, you have selected the appropriate MiTAI Binding IP
address. See "Configuring extensions" on page 440.

For a demonstration on how to build a call flow that uses Dynamic RAD messages, please see the following
prairieFyre Knowledge Base article: http://www.prairiefyre.com/kb/KnowledgebaseArticle51476.aspx.

Building resilient call flows
Many of IVR Routing’s call flow activities and configurations are dynamic, relying upon statistics and
information from the Enterprise Server. In situations where the Enterprise Server or telephone system is
unavailable, such as during a reboot, the functionality of dynamic call flows is impacted. IVR Routing enables
contact centers to build resilient call flows that respond to disruptions in service to the Enterprise Server,
routing calls to alternate branches that are not reliant upon statistics from the Enterprise Server. Resilient call
flows rely on the queue condition statistic Last Queue Update Received and the system variable
CCMOnlineStatus.
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The Last Queue Update Received queue condition statistic is available in the Queue Condition builder for the
Queue activity, Abandon Callbacks, and Rules. In the Queue Condition builder, Last Queue Update Received
is assigned a duration of time (with aminimum duration limit of 30 seconds) that defines the time that may
pass between updates from the Enterprise Server before the statistics are considered to be stale. This real-
time statistic is particularly useful for contact centers that consider a limited amount of stale statistic data to
be acceptable, such as during the length of time it takes the Enterprise Server to reboot, but may want calls to
be routed using the Queue activity to different call flow paths if the real-time data from the Enterprise Server
remains unavailable beyond that timeframe. For information on configuring rules, abandon callbacks and
Queue activity, see "Configuring rules" on page 469, "Enabling callbacks" on page 462, and "Configuring the
Queue activity" on page 513.

The CCMOnlineStatus is a system variable that detects whether or not any real-time data is coming from the
Enterprise Server to IVR Routing services. If data is available from the Enterprise Server, it is set to True. If
the Enterprise Server’s real-time data is unavailable, it is set to False. In conjunction with the Variable
Compare activity, calls can be routed down the appropriate True and False branches immediately if the
availability of data from the Enterprise Server changes. For information on the Compare Variable activity, see
"Configuring the Compare Variables activity" on page 492.

Adding callback plans
To add a callback plan
 1. In YourSite Explorer, click Visual Workflow Manager.
 2. Click Callback Plan.
 3. Click Add and select Voice, Web, or Abandon from the drop down list.

A new callback plan is added to the callback plan list.
 4. AfterName, enter a name for the callback plan.
 5. On the ribbon, click Save.

Configuring caller options
NOTE:

l Caller options are only available for voice callback plans.
l To ensure callers leave the proper phone number for callbacks, we recommend you:

l Record local, in country, and international instructions in the prompts callers hear when leaving a
callback. The default prompt is a generic prompt intended for use by local and in country calls
only. International calling rules vary by country and region and customized prompts should be
recorded for specific business needs.

l Callers leaving a call back request must enter the date in the preferred date format (DDMM or
MMDD). As a best practice, we suggest you include the preferred date format in the prompt
played to callers to avoid invalid entries.

To configure caller options
 1. Click theCallers Option tab.

NOTE:Available only for voice callbacks.
 2. UnderGeneral, complete the following:

l Terminating Digit—select a digit to signify the end of the caller's input
l Min number of digits for external callbacks—select theminimum number of digits necessary for

an external callback to occur
l Min number of digits for internal callbacks—select theminimum number of digits necessary for

an internal callback to occur
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 3. Select Capture Preferred Time if you want to prompt the caller for their desired callback time:
l Preferred Time—select a prompt to request the caller's desired callback date and time
l Expiry Duration—select a time range around the caller's preferred callback time in the event their

preferred callback time is not available
l Date Format—select the date entry format for the caller's callback date
l Time Format—select the time entry format for the caller's callback time

 4. Select Capture Recording if you want to prompt the caller to record a voicemessage.
l RecordMessage—select a prompt to request the caller to record amessage
l Confirm Recording—select a prompt to confirm receipt of the caller's recordedmessage
l Recording timeout (sec)—select the amount of time allotted for the caller to record amessage

 5. UnderCapture Phone Number, complete the following fields:
l Request Phone Number—select a prompt to request the caller's callback phone number
l Invalid Phone Number—select a prompt to inform the caller of an invalid phone number entry
l Submit Phone Number—select a prompt to confirm the callback phone number
l Exclusion Phone List—enter a phone number to exclude from receiving callbacks

 6. Under Capture Confirmation, complete the following fields:
l Submitted Confirmation—select a prompt to confirm the caller's callback request.
l Cancel Confirmation—select a prompt to confirm the cancellation of the caller's callback quest.

 7. On the ribbon, click Save.

Configuring routing rules
To configure routing rules
 1. Click theRouting Rules tab.
 2. UnderGeneral, complete the following.

l On requeue, retain original callback date stamp—select to keep the original date stamp. Clear to
update the date stampwhen the callback is requeued.

l Number of attempts to contact client—enter the number of times Visual Workflow Manager will
attempt to return the client's call. The default is 3 times.

l Retry interval between attempts (min)—enter the number of minutes between callback attempts.
The default is 30minutes.

l No answer client timeout (sec)—enter the time limit a callback port will wait for an agent to
answer. The default is 120 seconds.

 3. Select Allow Schedule if you only want to process callbacks during a specified time period.
 4. If you selectedAllow Schedule, afterSchedule Plan, select the schedule plan you want to use to

process callbacks

Configuring agent options
To configure agent options
 1. Click Agent Options.
 2. UnderGeneral, afterNo answer timeout (sec), enter the amount of time before hanging up if an agent

does not pickup the callback request.
 3. Under Digit Menu, compete the following fields.

l Instruction—select a prompt to provide the agent with the callback instructionmenu
l Listen to caller's message—select amenu option number and a prompt to enable the agent to

playback the caller's message
l Connect to phone number—select amenu option number to enable the agent to perform the

callback
l Pre connect—select a prompt to be played to the agent before a connection attempt is made
l Connecting to customer—select a prompt to inform the agent they are being connected
l Greetingmessage to customer—select a prompt greeting to play for the customer when they

receive a callback
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l Failuremessage heard by agent—select a prompt to play to the agent if the customer does not
answer the callback, informing them the call cannot be completed

l Requeue callback—select amenu option and prompt to enable the agent to requeue the callback
l Reject callback—select amenu option and prompt to enable the agent to reject the callback
l Replay instruction—select amenu option to enable the agent to reply themenu choices

 4. On the ribbon, click Save.

Building subroutines
Subroutines are portions of call flows that can be reused inmultiple call flows. Subroutines create common
call flow activity groups that can be easily reused, encapsulating common activity groups in one single
activity. Subroutines can be reused across call flows or within a single call flow, which helps keep call flows
manageable and enables rapid call flow creation. They also facilitate call flow updates by requiring only one
change to affect all call flows that use the subroutine.

With a few exceptions, subroutines and call flows function almost identically. Subroutines are configured as
RAD, Voice, Management, or Outbound, like call flows, and each type offers different activities to use. This
enables you to use subroutines to get access to activities not normally available to your call flow type. While
all callflows are associated to ports or hunt groups, however, subroutines are contained within call flows and
are not associated to ports or hunt groups.

Adding subroutines
NOTE:Before you add a subroutine activity to a call flow, youmust first create and configure the subroutine.
While subroutine activities are added to call flows in the sameway as any other activity, subroutine activities
must be assigned to a pre-configured subroutine. See "Building subroutines" on page 458.

To add a subroutine to a call flow
 1. Select the call flow to which you want to add a subroutine.

The Call flows Canvas opens.
 2. In the Toolbox pane, click and drag theSubroutine activity into theDrop Activities Here section of

the Canvas.
NOTE: If the Toolbox pane is not visible, click the Toolbox flyout. To keep the toolbox pane visible,
click the pin icon.

 3. Right click the subroutine and select Assign Subroutine.
The Select a subroutine or variable window opens.

 4. Select a subroutine from the list and click OK.
 5. On the ribbon, click Save.

NOTE:A red exclamationmark icon shown in the top right corner of an activity signals an error or
missing information. Youmust correct the error or enter the information before you are able to save the
call flow. Clicking the icon will display the error or the information required. If you wish to disable
validation, deselect the Validate call flow check box in the call flow Properties pane
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Deleting subroutines
NOTE:You cannot delete a subroutine currently associated with a call flow. Remove the subroutine from all
call flows it is being used by and then delete it.

To delete a subroutine
 1. Select the subroutine you want to delete from the subroutine list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.
 4. On the ribbon, click Save.

Filtering subroutines
You can filter which subroutine types are shown in the subroutine list.

To filter subroutines
 1. Click Filter.
 2. From the drop downmenu, select the subroutine type you want to view.

NOTE:Only the subroutine type you selected is shown in the subroutine list.

Configuring prompts
Prompts are audio clips that provide callers with information during a call. Associated with activities, prompts
play messages when callers reach the associated activity in a call flow. Prompts can be individual wave files
or multiple wave files joined together to form custommessages. For a list of pre-configured prompts see "Pre-
configuredmessages and prompts" on page 556.

The default language for prompts will be taken from the site language and call flows will be executed in that
language unless a Language activity has been included in the call flow. Individual prompts can be configured
to handlemultiple languages, working with the Language activity to support multiple languages in a single call
flow. This reduces the number of prompts that must be created and allows for the same set of ports to be used
for multiple languages. For more information on the Language activity, see "Activities" on page 479.

If you want to use your own custom prompts with a new callback plan, youmust add your wave files by
importing the files or recording wave files using amicrophone on your computer or your telephone using a
management call flow. Youmust then associate your custom wave files to the callback plan. Otherwise,
when you create a new callback plan, all message plans are created automatically and are automatically
assigned to the callback. See "Configuring callbacks and callback plans" on page 462 for more information.

NOTE:Agent prompts cannot be configured to play in a language that is different than the language selected
as a preference in Contact Center Management. Agent language preference settings override agent prompt
language choices as IVR Routing aligns with agent language settings.
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Adding prompts
To add a prompt
 1. In the left pane, click Visual Workflow Manager.
 2. Click Prompts.
 3. Click Add.

A new prompt is added to the prompts list.
 4. AfterName, type a name for the prompt.
 5. AfterDescription, type a description for the prompt.
 6. AfterCategory, select one of the following categories from the drop-down list:

l Callback
l Custom
l Management
l UPiQ

If you wish to create your own category, afterCategory, type a name for the new category.
Prompt categories are an organizational tool to help keep your prompts sorted and easily accessible.

 7. After Language, select the primary language from the drop-down list.
NOTE: By default, the language is set to your default site language.Click one of the following tabs:

 8. Click one of the following tabs:
l System Wave Files—lists the system wave files callers hear while in the IVR or while waiting

on hold. This pane will only show the wave files that are available in the language you have
selected.

l Custom Wave Files—lists imported and newly created wave files. To import or record a custom
wave file, click Add and select Existing wave file to import the file, orRecord wave file to use
themicrophone on your computer to record the file.
NOTE: Wave files must be 8khz, Mono, ULAW format.

l Queue Stats—lists up-to-date queue statistics for use in prompts
l Variables—lists all variables available for use in prompts
NOTE:Read back on variables is based on the type of variable. Number variables read back the
whole number, while digit variables read back individual numbers. For example, number variables
would read 123 as "one hundred and twenty-three", while digit variables would read 123 as "one,
two, three".

l Prompts used in call flows and subroutines—lists all prompts used in call flows and
subroutines

 9. In theAll system wave files, All custom wave files, All queue stats, All Variables, orPrompts
used in call flows and subroutines pane, select the file(s) you want to add to the prompt.

 10. Click > to add the file to the prompt.
The file is added to the prompt and is shown in the Selectedmembers pane.
NOTE: The wave files play in the order they are added to the prompt. If you want to change the order in
which the wave files will be played, select the wave file and click the up or down arrow buttons on the
right-hand side of the dialog box.

 11. On the ribbon, click Save.
NOTE: If you are adding prompts in a new language, youmust add audio files that correspond to the
existing audio files in IVR Routing's default language. Otherwise, the caller will not hear anything when
the prompts are supposed to be playing.
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Adding files and variables to prompts
NOTE:Variable readback is only available for numerical variables.

To add files and variables to a prompt
 1. Select the prompt you want to add variables or files to from the prompt list.
 2. Click theSystem wave files tab.

All system wave files are shown.
 3. Select the system wave file you want to add to the prompt and click >.

The system wave file is added to the prompt and shown in theSelected members list.
 4. Add custom wave files, queues stats, and variables by repeating steps 1 to 3 and selecting the

corresponding wave file, queue stat, or variable tab.

Deleting prompts
To delete a prompt
 1. Select the prompt you want to delete from the prompt list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.
 4. On the ribbon, click Save.

Playing prompts
To play a prompt
 1. Select the prompt you want to play from the prompt list.

NOTE: To select multiple prompts, click and hold the shift key while selecting each prompt.
 2. Click Play.

The selected prompt is played.

To play an individual or selection of wave file in a prompt
 1. Select the prompt you want to play from the prompt list.
 2. Select the wave file(s) you want to play.

NOTE: To select multiple prompts, click and hold the shift key while selecting each prompt.
 3. Click Play.

The selected prompt is played.

Using Prompts Quick Setup
Quick setup enables you to import previously created wave files.

To use quick setup to import prompts
 1. In the left pane, click Visual Workflow Manager.
 2. Click Prompts.
 3. UnderPrompts, click Quick Setup.

The Prompts Quick Setup pane opens.
 4. After Folder Path, click Browse.

The Browse For Folder window opens.
 5. Browse to the folder containing the wave files and click Ok.

The prompts are imported and are shown in the prompt list in the right-most pane.
 6. On the ribbon, click Run.
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Configuring callbacks and callback plans
A callback plan is a tool that identifies a caller from the information provided in the caller's message and
makes a return telephone call. The callback plan settings you configure in YourSite Explorer determine the
rules and options IVR Routing uses when attempting to contact themessage sender.

For callbacks to function correctly, youmust have configured location settings for your media server. If
location settings are not configured, your callbacks will not be able to contact your customers. See
"Configuring location settings for 3300 ICP media servers" on page 76.

Three kinds of callbacks are available with IVR Routing.
l Abandon—Abandon callbacks are automatically generated when a caller hangs up before speaking to

an agent before the long abandon time is met. Although not recommended, abandon callbacks may also
be configured to generate inside the short abandon time.

l Voice—Voice callbacks enable callers to leave a callback request in queue, which is then sent to an
agent. Voice callback requests can be configured to be part of a call flow to which customers can
navigate.

l Web—Web callbacks enable customers to request an agent callback via theWeb. The customer
completes a request on an HTML/ASP page that is designed and hosted by the IVR Routing customer.
A customer who wants to receive a callback from an ACD agent fills out the following required
information on the web form:

l The telephone number at which they can be contacted
l The customer’s name, presented as a text-to-speech rendition to the ACD agent
l The target ACD path
l The time at which they would like to be contacted
l Optionally, a message presented as a text-to-speech rendition to the ACD agent.

Deleting callback plans
To delete a callback plan
 1. Select the callback plan you want to delete from the callback plan list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.
 4. On the ribbon, click Save.

Enabling callbacks
Voice, Abandon, andWeb callbacks are enabled in different ways. Voice callbacks are entered directly into a
call flow. Abandon callbacks are automated andmust be enabled. Abandon callbacks can be configured with
individual queues. TheQueue Condition builder for abandon callbacks enables you to build conditions into the
queue that must bemet before the queue takes abandon callbacks. You could, for example, configure it so
that the queue only takes callbacks if the agents available are less than the number of calls waiting. If no
queue conditions are configured, by default abandon callbacks will be offered if more than 1 agent is available.
Web callbacks require a webpage to be set up to submit callbacks andmust have queues enabled to receive
web callbacks.
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To enable voice callbacks
 1. In YourSite Explorer, click Visual Workflow Manager=>Call flows.
 2. Select the call flow you want to add a voice callback to from the list of call flows.
 3. Drag and drop a Callback Request activity into your call flow.
 4. Right-click on the Callback Request and select Properties.
 5. In the Properties pane, after Callback Plan, click the… button.
 6. Select a callback plan and click OK.
 7. AfterDestination, click the ... button.
 8. Select a queue and click OK.

To enable abandon callbacks
 1. In the ribbon, aboveAbandon Callbacks, click theDisabled button.

Abandon Callbacks are now enabled.
NOTE: Default Abandon Callback options refer to the Callback Settings, located under
Enterprise=>Callback Options.

 2. If you want to change plans, click the… button afterDefault Plan and select a plan.
 3. Click OK.
 4. If you want to select a different queue, click the… button afterDefault Queue and select a queue.
 5. Click OK.
 6. If you want to enable short abandon callbacks, select theAllow Short Abandon Callbacks check box.

NOTE: It is recommended that you do not enable this feature as it may generate extremely high
volumes of callback requests.

To enable abandon callbacks in individual queues
 1. In YourSite Explorer, click Visual Workflow Manager=>Queues.
 2. Select the queue to which you want to apply a specific callback plan.
 3. Click theVWM Options tab.
 4. Click theCallback tab.
 5. AfterCallback Plan, click the… button.
 6. Select the callback plan you want to apply to this queue and click OK.
 7. If you want to send abandon callbacks for this queue to another queue, afterQueue Destination, click

the… button.
 8. Select a queue and click OK.
 9. If you want to add queue conditions, go to step 10. Otherwise, in the ribbon, click Save.

NOTE: While queue conditions are optional, it is recommended you add a queue condition to the
callback queue to avoid callback requests being requeued when no agents are available.

 10. To add queue conditions that must bemet before abandon callbacks are offered, underQueue
Condition Builder, click Add.
A new queue condition is added to the queue condition builder list.
NOTE: If no queue conditions are set, abandon callbacks will be offered if the queue has more than 1
agent available.

 11. In the first column, select one of the following real-time statistics from the drop-down list:
l Agents Available
l Agents Unavailable
l Agent Idle
l Call Load
l Longest Wait Time
l Number of Calls Waiting
l Path DND
l ExpectedWait Time
l Last Queue Update Received
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l AvgTimeToAbandon
l AvgTimeToAnswer
l Service Level

 12. In the second column, select one of the following operators from the drop-down list:= Equal to
l != Not Equal
l > Greater than
l >= Equal to or greater than
l < Less than
l <= Equal to or less than
l >= Equal to or greater than

NOTE:Operators appearing in the drop-down list vary according to the variable selected.
 13. In the third column, from the drop-down list select either theValue, Queue Stats, or theCall variable

tab.
 14. UnderValue, type in a numeric value or enable the check box for the value.
 15. UnderQueue Stats, select a queue stat from the drop-down list.
 16. UnderCall variable, select a call variable from the drop-down list.
 17. Click OK.
 18. If you want to add another condition, at the top of the dialog box, click Add.
 19. Repeat steps 10-17 for each additional condition to add to the Queue.
 20. To import queue conditions, click the Import button and navigate to a *.csv file.
 21. To export queue conditions, click theExport button and navigate to a *.csv file.

NOTE:
l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.

 22. To test the conditions, under Test Parameters, enter a value in the relevant fields and click Test.
If the test is successful, “Pass” displays beneath the Test button.
If the test is not successful, “Fail” displays beneath the Test button.

 23. To enable reporting for the branch, select theEnable reporting for this Branch check box.
 24. To delete a queue condition, from the drop-down list to the left of the condition select Delete.
 25. Click OK.

To enable web callbacks
 1. Set up a webpage for submitting callback requests.

Sample webpage templates for submitting callback requests are available from C:\Program Files
(x86)\prairieFyre SoftwareInc\CCM\Websites\CallbackWebService

 2. Click YourSite Explorer=>Visual Workflow Manager=>Callback Plan.
 3. In the ribbon, underMax Per Hour Per IP Address, select the number of callbacks that are accepted

from a single IP address per hour.
 4. Click Queues.
 5. Select a queue for which you want to enable web callbacks.
 6. Click theVWM Options tab if it is not already open.
 7. Click theCallback tab if it is not already open.
 8. Select theEnable queue for web callbacks check box.

This queue can now receive requests for web callbacks.
 9. In the ribbon, click Save.
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Enabling .NET Framework 4.5 Advanced Services on Windows 8 for IVR
Routing web callbacks
If you are running IVR Routing andWindows 8, youmust have the certain .NET Framework 4.5 Advanced
Services enabled for web callbacks to function.

To enable .NET Framework 4.5 Advanced Services for IVR Routing web callbacks onWindows 8
 1. Navigate to theControl Panel.
 2. Click Programs=>Turn Windows features on or off.
 3. Select the following check boxes:

l .NET Framework 4.5 Advance Services
l WCF Services

l HTTP Activation
 4. Click OK.

Web callback templates
Using web callback, callers can submit callback requests using forms accessed through a contact center’s
website. Callers submit a telephone number, name, and time framewithin which their call should be returned,
as well as other optional information, which is then routed to the contact center.

prairieFyre offers two web callback templates included with IVR Routing that you can edit for use by your
contact center. Contact Center Solutions does not configure web callback webpages as part of installation.
Youmust set up the web callback templates as an application through IIS or another web server application.
(See Figure 17 - 5 and Figure 17 - 6.)
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Figure 17 - 5 Template - WebCallbackExample
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Figure 17 - 6 Template - WebCallbackExample2

Viewing the web callback templates
The web callback templates are stored in a zip file in <installation drive>:\Program Files (x86)\prairieFyre
Software Inc\CCM\Websites\CallbackWebService\WebCallbackTemplate.zip.

Customizing the web callback templates
You can edit elements of the web callback templates tomeet your contact center’s needs, changing headers,
customizing Cascading Style Sheets (CSS), or even customizing the web callback template content.

Customizing the header

In the templates, WebCallbackExample.aspx has a header consisting of the text “Image goes here”, where
youmay insert a company logo or change the text. WebCallbackExample2.aspx has a header consisting of
the text “Get in touch with us at prairieFyre”. You can customize these headers for your contact center,
however.

To customize the header

 1. Open the .aspx page in an HTML editor.
 2. Replace the text with your own text or an image.

NOTE:
l If you are using Notepad withWebCallbackExample, press CTRL+F and type “Image goes

here” after Find what and click Find Next to locate the header in the HTML.
l If you are using Notepad withWebCallbackExample2, press CTRL+F and type <h1> to

locate the header in the HTML.
 3. Save and close the HTML editor.
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Customizing the Cascading Style Sheet

The Cascading Style Sheet (CCS) defines how HTML elements are displayed. CCS enables you to control
the style and layout of multipleWeb pages all at once.

To customize the CCS

 1. OpenStyles.css in Notepad.
 2. Edit the heading and body font sizes and styles, or spacing.
 3. Click Save.

Customizing the content of the web callback template

You can change the content of the web callback template to reflect your business, however, we do not
recommend changing fields as improper changes will result in a non-functioning webpage. If you have the
experience, expertise, and resources to edit HTML, you can use the templates to build the webpage you
desire, however.

Configuring web callback options
If you are using custom web callback plans or intend to have a different machine run the web callback service
than the one IVR Routing is installed on, you will have to configure the templates to support their use.

Configuring templates for a custom web callback plan
If you are using custom web callback plans, you will have to reconfigure the example templates by replacing
the default web callback plan’s callbackPlan value in the template.

To configure a template for a custom web callback plan

 1. Open SQL Server Management Studio or another SQLManagement program.
 2. Query the following select statement:

select Pkey,Name from tblCOnfig_VWM_CallbackPlan
 3. Find your value for the custom callback plan.
 4. Open the .aspx page in an HTML editor.
 5. Locate the following line:

<input type="hidden" runat=server id="callbackPlan" name="callbackPlan" value="B0AA4E0E-A97D-
461E-A7F9-E32026C1FA40" />
NOTE: The valuemay vary.

 6. Replace the value=”“ with the value for your custom callback plan.
 7. Save and close the HTML editor.
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Configuring a different machine for web callback service
By default, the web callback service is configured to run on themachine on which IVR Routing is installed.
Youmay, however, configure the web callback service to run on a different machine.

To configure a different machine for web callback service

 1. Open web.config in an HTML editor.
 2. Locate the following line of HTML:

<add key="ServerUri" value="localhost/CallbackWebService"/>
 3. Delete localhost and type the IP address of themachine you want to run the web callback service in its

place.
 4. Save and close the HTML editor.

Configuring rules
Rules provide call conditions that are evaluated at the runtime of the call flow. They enable you to compare
against a broad range of conditions in a single call flow activity, reducing call flow clutter and enablingmore
precise routing.

In a call flow, rules are assigned to a rules activity. When an incoming call enters a call flow and encounters a
rules activity, the call is evaluated against the activity’s associated rules and is then branched based on
whether or not the call meets the rule’s routing rules’ conditions. Routing rules can be based on a number of
different conditions:

l ANI (Voice)
l DNIS (Voice, Outbound)
l Emergency (Voice, RAD, Outbound)
l Hunt Group (Voice, RAD, Outbound)
l Queue (Voice, Outbound)
l Redirect (Voice, Outbound)
l Schedule (Voice, RAD, Outbound)

If the call meets the routing rules’ conditions, then it is routed through the success branch and has variables
set to specific values based on the pre-configured variable options in the rule. If it does not meet the rule’s
routing conditions, then the call is routed through the failure branch. If the call is comparing against many
routing rules in a single Rules activity, the variables will only be set once (by the first routing rule that was
matched).

Rules are best used when you want to route calls based onmultiple conditions. A site that has aMonday to
Friday, 9 am to 5 pm French language queue and a 24-hour English queue could, using ANI and Schedule
routing rules in a single rule, route calls from French area codes that are calling within business hours to the
French queues and all other calls to the 24-hour English queue.

For more information on the rules activity for call flows, see "Configuring the Rules activity" on page 518.
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Adding rules
To add a rule
 1. In the left pane, click Visual Workflow Manager.
 2. Click Rules.
 3. Click Add.
 4. Select eitherVoice, RAD, orOutbound from the rules drop down list.

The rule is added to the list of rules.
 5. AfterName, enter name for the rule.

NOTE: The Expression field is automatically populated when routing rules have been configured. See
"Adding routing conditions to rules" on page 470.

Adding routing conditions to rules
NOTE:

l You cannot save your routing rules until after you add variables to your rules. See "Adding variables to
rules" on page 472.

l For instruction on grouping conditions and expressions, see "Grouping expressions" on page 439.

To add a DNIS, ANI, Redirect, or hunt group routing condition to a rule
 1. Select the rule you want to add routing conditions to from the Rules list.
 2. UnderRouting Rules, click Add.

A routing rule is added. The default routing rule is Emergency.
 3. In the first column, click the field to open the drop-downmenu and select one of the routing rule types:

l DNIS
l ANI
l Redirect
l Hunt Group

 4. In the second column, click the - button.
The routing rule dialog box opens.

 5. To add a value, click Add and enter a value for the routing rule.
 6. Click theAdd button.

The value is added to the Routing Rules.
 7. If you want to enable reporting for this Branch, select theEnable reporting for this Branchcheckbox.
 8. If you want to mask the result from this Branch with *** with reporting, select theMask the result from

this Branch with *** checkbox.
 9. Click OK.

To add a Schedule routing condition to a rule
 1. Select the rule you want to add routing conditions to from the Rules list.
 2. UnderRouting Rules, click Add.

A routing rule is added. The default routing rule is Emergency.
 3. In first column, click the field to open the drop-downmenu and select Schedule.
 4. In the second column, click the - button.

The Schedule dialog box opens.
 5. Click Add.

A condition is added. The default condition is Date.
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 6. If you want to select a different condition, click the drop-downmenu button and select one of the
following conditions:

l Date
l DOW (Day of Week)
l Holiday
l Time

 7. In the value field next to the name of the condition, click on the value.
The value window opens.

 8. Select a value for the condition and click OK.
 9. If you want to addmore schedule conditions, repeat steps 5-8.
 10. To test the conditions, underUtilities, enter time and date information and click Test.

If the test is successful, Pass will appear beside the Test button.
If the test is not successful, Fail will appear beside the Test button.

 11. To enable reporting, select theEnable reporting for this Branch checkbox.
 12. Click OK.

To add aQueue routing condition to a rule
 1. Select the rule you want to add routing conditions to from the Rules list.
 2. UnderRouting Rules, click Add.

A routing rule is added. The default routing rule is Emergency.
 3. In the first column, click the field to open the drop-downmenu and select Queue.
 4. In the second column, click the - button.

TheQueue Conditions dialog box opens.
 5. After theSelect a queue or queue group field, click the ... button.
 6. Select either theQueue or theQueue Group tab.
 7. Select a queue or queue group to add to the condition and click OK.
 8. To add a new queue, see "Configuring queues" on page 445.

NOTE:
l To configure a new queue for web callbacks, see "Enabling callbacks" on page 462.
l To configure a new queue for UPiQ, see"Configuring UPiQ options" on page 448.

 9. To add a new queue group, select theQueue Group pane and click Add.
TheQueue groups pane opens.

 10. AfterName, type a name for the queue group.
 11. AfterReporting number, type a reporting number for the queue group.
 12. Tomake the queue group virtual, enable theVirtual Queue check box.

NOTE:Use virtual queues for assigning the same pool of agents to answer the ACD calls for multiple
queues across multiple telephone switches.

 13. In theAvailable members pane, select a queue group and click the > button.
 14. Click Save.
 15. To add conditions, at the top of the Queue Conditions dialog box, click Add.
 16. In the first column, select one of the following real-time statistics from the drop-down list:

l Agents Idle
l Agents Available
l Agent Unavailable
l AvgTimeToAbandon
l AvgTimeToAnswer
l Call Load
l ExpectedWait Time
l Last Queue Update Received
l Longest Wait Time
l Number of Calls Waiting
l Path DND
l Service Level
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 17. In the second column, select one of the following operators from the drop-down list:
l ! = Not Equal to
l < Less than
l <= Equal to or less than
l = Equal to
l > Greater than
l >= Equal to or greater than

NOTE:Operators appearing in the drop-down list vary according to the variable selected.
 18. In the third column, from the drop-down list select either theValue, Queue Stats, or theCall variable

tab.
 19. UnderValue, type in a numeric value or enable the check box for the value.
 20. UnderQueue Stats, select a queue stat from the drop-down list.
 21. UnderCall variable, select a call variable from the drop-down list.
 22. Click OK.
 23. If you want to add another condition, at the top of the dialog box, click Add.
 24. Repeat steps 15-22 for each additional condition to add to the Queue Condition builder.
 25. To import queue conditions, click the Import button and navigate to a *.csv file.
 26. To export queue conditions, click theExport button and navigate to a *.csv file.

NOTE:
l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.

 27. To test the conditions, under Test Parameters, enter a value in the relevant fields and click Test.
If the test is successful, “Pass” displays beneath the Test button.
If the test is not successful, “Fail” displays beneath the Test button.

 28. To enable reporting for the branch, select theEnable reporting for this Branch check box.
 29. To delete a queue condition, from the drop-down list to the left of the condition select Delete.
 30. Click OK.

To add an Emergency routing condition to a rule
 1. Select the rule you want to add routing conditions to from the Rules list.
 2. UnderRouting Rules, click Add.

A routing rule is added. The default routing rule is Emergency.
 3. In second column, select Yes orNo.

The value is added to the Routing Rules.

Adding variables to rules
To add a variable to a rule
 1. Select the rule you want to add a variable to from the Rules list.
 2. UnderVariables, click Add.
 3. UnderName, click….

The Select a variable window opens.
 4. Select a variable to add to the rule from the variables list.

l If you want to view variables by name or number, click the appropriate letter or # button above
theOK button.

l If you want to search for a variable, enter the search term in the Search text box. The list of
variables will refresh with relevant variables.

 5. Click OK.
 6. The variable is added to the rule’s variables list.
 7. Click the field in the second column.

The Value pop-up opens.
 8. If you want to enter a specific value, in theValue tab, type the variable’s value.
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 9. If you want to use a call variable for the value, click theCall Variable tab and select a variable from the
list of variables.

 10. Click OK.
 11. On the ribbon, click Save.

The routing rule is now saved.

Deleting rules
To delete a rule
 1. Select the rule you want to delete from the rules list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.

Configuring holidays
Holidays can be configured for dates that affect your contact center functionality.

Adding holidays
To add a holiday

 1. In the left pane, click Visual Workflow Manager.
 2. Click Holidays.
 3. Click Add.

A new holiday is added to the Holidays list.
 4. UnderProperties, in theName field, type a name for the holiday.
 5. UnderPattern, specify the pattern of the holiday.

l If the holiday always falls on the same day of the samemonth, select Every and specify the
month and date the holiday falls on

l If the holiday has a pattern of falling on a certain day, week, andmonth, select The and specify
the pattern, day of week, andmonth

l If the holiday is a calculated holiday, such as Good Friday or Easter Monday, select Calculated
holiday and specify the holiday

 6. On the ribbon, click Save.

Deleting holidays
To delete a holiday
 1. Select the holiday you want to delete from the holidays list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.

Configuring data providers
You can create a connection to a data provider located on a local or an external server to access information
about incoming callers. For example, the data providers query can be configured to retrieve customer
information based on ANI, DNIS, collected digits, or variables. Visual Workflow Manager can addMicrosoft
Excel worksheets, Microsoft SQL servers, and Lightweight Directory Access Protocol (LDAP) as data
providers to query for data. Visual Workflow Manager can also import ODBC connections configured using
theWindows ODBC Data Source Administrator.
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Adding a Microsoft Excel worksheet as a data provider
To add aMicrosoft Excel worksheet as a data provider
 1. In the left pane, click Visual Workflow Manager.
 2. Click Data providers.
 3. Click Add and select Excel from the drop-down list.

A new data provider is added to the data provider list.
 4. AfterName, type a name for the data provider.
 5. Click Select File and browse to the Excel worksheet you want to use as a data provider.

NOTE: The Excel worksheet must be shared as a workbook and located on a UNC (Universal Naming
Convention) path, also known as a shared network path. The syntax for a UNC path is
\\ComputerName\SharedFolder\Resource. The IVR folder in <systemdrive>\program files\prairiefyre
software inc\ccm is set up to be shared during the installation process and is called ivrdirectory. An
example of the syntax format is \\IVRMACHINE\IVRDIRECTORY\WORKSHEET.xls. Locating the
worksheet on a UNC enables Visual Workflow Manager to access the data provider remotely.

 6. Click Open.
 7. Click Test Connection.
 8. On the ribbon, click Save.

Adding a Microsoft SQL server as a data provider
To add aMicrosoft SQL server as a data provider
 1. In the left pane, click Visual Workflow Manager.
 2. Click Data providers.
 3. Click Add and selectMicrosoft SQL Server from the drop down list.

A new data provider is added to the data provider list.
 4. AfterName, type a name for the data provider.
 5. AfterServer Name, enter the server name.
 6. Under Log on credentials, selectWindows Authentication orSQL Server Authentication.
 7. If you select SQL Server Authentication, enter aUsername andPassword.
 8. AfterDatabase Name, select a database name from the drop down list.
 9. Click Test Connection.
 10. On the ribbon, click Save.

Adding a LDAP as a data provider
To add a LDAP as a data provider

 1. In the left pane, click Visual Workflow Manager.
 2. Click Data providers.
 3. Click Add and select LDAP from the drop down list.

A new data provider is added to the data provider list.
 4. AfterName, type a name for the data provider.
 5. AfterDomain, type the domain of the LDAP.
 6. AfterUsername, enter the username for the LDAP.
 7. AfterPassword, enter the password for the LDAP.
 8. Click Test Connection.
 9. On the ribbon, click Save.
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Adding an ODBC as a data provider
ODBC connections can be added as a data provider through theWindows ODBC Data Source Administrator.
After adding anODBC using ODBC Data Source Administrator, the ODBC will automatically appear in data
source providers and will bemade available for the Query activity.

You cannot edit an ODBC data provider in Visual Workflow Manager.

Deleting data providers
NOTE:Visual Workflow Manager is unable to delete ODBC data providers from the data providers list.

To delete a data providers
 1. Select the data providersyou want to delete from the data providers list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.

Configuring variables
Variables are used inmultiple activities and to perform various tasks, including

l Storing information for later use
l Collecting user data
l Performing database queries
l Building simple or complex conditions

Variables can be used for different activities such as:
l Transferring a call to a different queue based on customer class
l Playing different prompts based on account balance
l Holding collected digits for use later in a database query

IVR Routing variables can be configured to be sent to agent screen pop windows, enabling agents to receive
customized information gathered as the call passed through the call flow. This feature is only available for
contact centers with an Advanced Contact Center Solutions license.

Custom variables can be populated through queries. See "Configuring the Query activity" on page 509.

See Table 17 - 1 for a list of built-in variables.
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Table 17 - 1 Built-in Variables

Variable Name Description Variable Type

LastCollectedDateTime Populated with last collected date and time
requested for a callback

DateTime

UpiqPosition The current position in queue when used with
UPiQ (Updated Position in Queue)

Digits

ANI Contains the ANI value of the current call which
is the number of the calling party

DN

DNIS Contains the DNIS value of the current call
which indicates which number was called. Typ-
ically used for 800 & 900 numbers

DN

HuntGroup Contains the hunt group dialable from which the
current call originated

DN

ManagmentCollectedDigits Used in default management plan to collect the
dialable number for a device

DN

Redirect Contains the redirect dialable if the current call
was redirected.

DN

UpiqPrompt The current prompt when used with UPiQ
(Updated Position in Queue)

PromptEntity

LastRecordingFilename Used in conjunction with a record activity and
always contains the last recorded filename

PromptRecording

CallerName Contains the name of the calling party if pro-
vided

Unspecified

CCMOnlineStatus True if the IVR service is connected to the
Enterprise Server, False otherwise.

Boolean

Language Populated when used in conjunction with a lan-
guage activity. The language activity is used for
changing the language of a call flow dynam-
ically at runtime based on user options.

Unspecified

LastCollectedDigits Populated when used in conjunction with a col-
lected digits activity in a call flow. Always con-
tains the last collected digit(s) from that activity

Unspecified

LastMenuCollectedDigits Populated when used in conjunction with a
menu activity in a call flow. It will always con-
tain the last collected digit from amenu activity.

Unspecified
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Variable Name Description Variable Type

LastQueryResult Contains the last query results when used in
conjunction with a query activity

Unspecified

Adding variables
To add a variable
 1. In the left pane, click Visual Workflow Manager.
 2. Click Variables.
 3. Click Add.

A new variable is added to the variables list.
NOTE:Default variables are grayed out and cannot be edited or deleted.

 4. AfterName, enter a name for the new variable.
NOTE:Name cannot contain any spaces or non-alphanumeric characters.

 5. AfterDescription, provide a brief explanation of the variable function.
 6. AfterVariable Type, select the type of variable from the drop-down list.

NOTE:A variable's type cannot be changed after you save.
 7. If you wish to enable this variable to display in an agent’s screen pop window, select theSend to

Agent’s toaster checkbox.
 8. AfterDisplay Name, type the name this variable will have when it appears in an agent’s screen pop

window.
 9. If you selected Dollars, Euros, or Pounds as the variable type, afterCurrency Format, select the format

from the drop-down list.
 10. If you selected Date Time as the variable type, afterDate Format, select the date format from the drop-

down list. After Time Format, select the time format from the drop-down list.
 11. On the ribbon, click Save.

Deleting variables
To delete a variable
 1. Select the variable you want to delete from the variables list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.

The variable is deleted and removed from the variables list.

Filtering variables
You can filter which variable types are shown in the variable list.

To filter variables
 1. Click Filter.
 2. From the drop downmenu, select the variable type you want to view.

NOTE:Only the variable type you selected is shown in the variable list.
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Configuring music on hold
IVR Routing provides music on hold for your telephone system using a PC sound card with a connection to
your telephone system.IVR Routing plays music through the sound card using a rotating (loop) playlist. Music
sources for the playlist include any or all of the following: audio CD, stored .wma, stored .wav file, and stored
.mp3 file. The playlist can includemusic or prerecorded informationmessages.

Administrators and supervisors can start or stop themusic engine from the user interface. Once started, the
music engine loops through the play list, playing continuously until it is stopped.

Adding music on hold
To add amusic on hold playlist
 1. In YourSite Explorer, in the left pane, click Visual Workflow Manager.
 2. Click Music on hold.
 3. Click Add.

A new music on hold playlist is added.
 4. AfterName, enter a name for the playlist.
 5. Click theSongs tab.
 6. If you want to add a song to the list of available songs, underAvailable songs, click Add.

The Select song(s) dialog box opens.
 7. Browse to the song you want to add and click Open.

The song is added to the available songs list.
 8. If you want to add a song to a playlist, select the song you want to add and click >.

The song is added to the playlist and is shown in the Selectedmembers list.
 9. Click Associate Servers.
 10. UnderAvailable members, select the computer that the playlist will be played from and click >.

The computer is shown in the Selectedmembers list.
 11. On the ribbon, click Save.

Deleting music on hold
To delete amusic on hold playlist
 1. Selected the playlist you want to delete from themusic on hold list.
 2. Click Delete.

The Delete these elements dialog box opens.
 3. Click OK.

Themusic on hold playlist is removed from the list.

Configuring Screen Pop
IVR Routing integrates with Screen Pop to display ANI, DNIS, and caller entered collected digits.

NOTE: This feature is hidden unless you are licensed for Screen Pop.

To enable Screen Pop with IVR Routing
 1. In YourSite Explorer, underEnterprise, click Enterprise.
 2. Click theScreen Pop tab.
 3. Select Display Intelligent Queue licensed options (ANI/DNIS and Collect Caller Entered Digits)

on the soft phone pop-up.
 4. Select Launch an application or Web page when agents answer ACD calls.
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 5. Select one of the following options:
l Display caller specific Microsoft Outlook contact information and create Journal entries—
l Display the caller specific Inbound Trace report web page—
l Display a specific application on web page—

 6. To have Screen pop open for non-ACD calls, select Screen pop on non-ACD calls.
 7. On the ribbon, click Save.

Configuring security
You can configure IVR Routing security settings in Contact Center Management to allow or prevent users
frommaking changes to call flows, devices, and prompts, and to the runtime operations of your business. See
"Configuring security roles" on page 181.

Activities
IVR Routing’s activities enable you to build Voice, RAD, Management, or Outbound call flows and configure
the routing conditions that send customers to queues. You can use activities to answer, transfer, or redirect
calls, collect caller-entered digits, play customized prompts, and direct calls to themost appropriate agent.
The following sections will explain the activities available in IVR Routing and explain how you can configure
activities in order to build call flows and routing conditions.

This section on Activities begins with Table 17 - 2, which lists IVR Routing's activities, displays the activities'
icons, and lists activity availability by call flow type and licensing level. The section then explains how
different activities are categorized based on the functions they perform in call flows and how they instruct IVR
 Routing tomanage call routing. This Activities section concludes by explaining how to configure activities in
order to build call flows and routing conditions. It provides procedures for configurations that are common to
many activities and concludes with procedures for configuring individual activities.

NOTE:
l The following sections explain activities and how to configure activities, but they do not explain how to

use those activities to create an entire call flow. For information on the types of call flows you can
create using IVR Routing activities, see "Call flow examples" on page 449.

l Call flows with improperly configured activities are considered to have validation errors and cannot be
saved. If an activity contains validation errors, a red exclamationmark will display. Clicking the red
exclamationmark icon will show the errors to correct in order to configure the activity properly and save
the call flow.

Activities available in IVR Routing
Table 17 - 2 contains the activities that are used to create call flows. The table lists the activity, shows the
activity's icon, and lists the activities' availability according to call flow type and licensing level. The table also
contains links to the configuration procedures for each activity.

NOTE:

l Formore information on IVR Routing licensing see theContact Center Solutions and Call Accounting
System Engineering Guide.

l Description of activity properties are available in the User Interface of IVR Routing's Visual Workflow
Manager.
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Table 17 - 2 Activities available in IVR Routing

Activity
Name

Icon Details

ANI Available in Voice andManagement call flows with IVR
Routing Advanced or Premium licensing

For configuration procedures, see "Configuring the ANI
activity" on page 487.

Answer Available in Voice, RAD, andManagement call flows at all
IVR Routing licensing levels

For configuration procedures, see "Configuring the Answer
activity" on page 488.

Callback
Request

Available in Voice call flows with IVR Routing Advanced or
Premium licensing

For configuration procedures, see "Configuring the Callback
Request activity" on page 488.

Collect Digits Available in Voice, Outbound, andManagement call flows
with IVR Routing Premium licensing

For configuration procedures, see "Configuring the Collect
Digits activity" on page 490.

Compare
Variables

Available in Voice, Outbound, andManagement call flows
with IVR Routing Advanced or Premium licensing

For configuration procedures, see "Configuring the Compare
Variables activity" on page 492.

Delay Available in Voice, RAD, Outbound, andManagement call
flows at all licensing levels

For configuration procedures, see "Configuring the Delay
activity" on page 501.

DNIS Available in Voice, Outbound, andManagement call flows
with IVR Routing Advanced or Premium licensing

For configuration procedures, see "Configuring the DNIS
activity" on page 493.
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Activity
Name

Icon Details

Email Available in Voice, Outbound, andManagement call flows at
all IVR Routing licensing levels

For configuration procedures, see "Configuring the Email
activity" on page 494

Execute Available in Voice, RAD, Outbound, andManagement call
flows at all licensing levels

For configuration procedures, see "Configuring the Execute
activity" on page 495.

Goto Available in Voice, Outbound, andManagement call flows at
all IVR Routing licensing levels

For configuration procedures, see "Configuring the Goto
activity" on page 499.

Hangup Available in Voice, RAD, Outbound, andManagement call
flows at all IVR Routing licensing levels

For configuration procedures, see "Configuring the Hangup
activity" on page 499.

Hunt Group Available in Voice, RAD, andOutbound call flows at all IVR
Routing licensing levels

For configuration procedures, see "Configuring the Hunt
Group activity" on page 500.

Language Available in Voice, Outbound, andManagement call flows at
all IVR Routing licensing levels

For configuration procedures, see "Configuring the Language
Activity" on page 501.

Make Call Available in Outbound call flows with IVR Routing Premium
licensing

For configuration procedures, see "Configuring theMake Call
activity" on page 502.

Management Available in Voice andManagement call flows at all IVR
Routing licensing levels

For configuration procedures, see "Configuring the
Management activity" on page 503.
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Activity
Name

Icon Details

Menu Available in Voice, Outbound, andManagement call flows at
all IVR Routing licensing levels

For configuration procedures, see "Configuring theMenu
activity" on page 505.

Mode of
Operation

Available in Voice andManagement call flows at all IVR
Routing licensing levels

For configuration procedures, see "Configuring theMode of
Operation activity" on page 506.

Play Available in Voice, RAD, Outbound, andManagement call
flows at all IVR Routing licensing levels

For configuration procedures, see "Configuring the Play
activity" on page 507.

Query Available in Voice, RAD, Outbound, andManagement call
flows with IVR Routing Premium licensing

For configuration procedures, see "Configuring the Query
activity" on page 509.

Queue Available in Voice, RAD, andOutbound call flows at all IVR
Routing licensing levels

For configuration procedures, see "Configuring the Queue
activity" on page 513.

Record Available in Voice andManagement call flows at all IVR
Routing licensing levels

For configuration procedures, see "Configuring the Record
activity" on page 516.

Redirect Available in Voice andManagement call flows at all IVR
Routing licensing levels

For configuration procedures, see "Configuring the Redirect
activity" on page 517.

Rules Available in Voice, RAD, Outbound, andManagement call
flows at all IVR Routing licensing levels

For configuration procedures, see "Configuring the Rules
activity" on page 518.
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Activity
Name

Icon Details

Schedule Available in Voice, RAD, andOutbound call flows at IVR
Routing licensing levels

For configuration procedures, see "Configuring the Schedule
activity" on page 519.

Set Device
Mode of
Operation

Available in Management call flows at all IVR Routing
licensing levels

For configuration procedures, see "Configuring the Set Device
Mode of Operation activity" on page 521.

Set System
Mode of
Operation

Available in Management call flows at all IVR Routing
licensing levels

For configuration procedures, see "Configuring the Set
SystemMode of Operation activity" on page 521.

Set Variables Available in Voice, RAD, Outbound, andManagement call
flows at all licensing levels

For configuration procedures, see "Configuring the Set
Variables activity" on page 522.

Subroutine Available in Voice, Outbound, andManagement call flows at
all IVR Routing licensing levels

For configuration procedures, see "Configuring the Subroutine
activity" on page 522.

Swap Prompt Available in Management call flows at all IVR Routing
licensing levels

For configuration procedures, see "Configuring the Swap
Prompt activity" on page 523.

Transfer Available in Voice andOutbound call flows at all IVR Routing
licensing levels

For configuration procedures, see "Configuring the Transfer
activity" on page 524.
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Understanding activity categories
Activities fall into three categories: conditional, action, and conditional action. Conditional activities check a
condition and branch calls based on that condition. For example, an ANI activity will check the number from
which a customer is calling and branch the call accordingly. Action activities perform actions within a call
flow, but do not branch calls. For example, the Play activity plays callers a prompt. Conditional action
activities perform actions and branch the call based on the result. For example, a Query activity can retrieve a
caller’s account balance and then branch the call to a Play activity that will recount that information.

Conditions include the following Activities:
l ANI
l Compare Variables
l DNIS
l Hunt Groups
l Menu
l Queue
l Redirect
l Rules
l Schedule

Actions include the following Activities:
l Answer
l Callback Request
l Delay
l Email
l GoTo
l Hang up
l Language
l Management
l Play
l Record
l Set Variables
l Subroutine
l Swap Prompt

Conditional actions include the following Activities:
l Collect Digits
l Execute
l MakeCall
l Mode of Operation
l Query
l Set DeviceMode of Operation
l Set SystemMode of Operation
l Transfer
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Configuring common activity options
Several of IVR Routing's activities share configuration procedures. This section explains procedures for
configurations that are common tomany activities, branches, and branching conditions.

NOTE:Branches route callers to different portions of the call flow. Branching conditions represent the
circumstances a call must match in order to be sent to a particular branch.

Adding activities to call flows
NOTE: The availability of activities varies depending on

l The call flow type you select. Table 17 - 2 lists the call flows in which different activities are available.
For example, you cannot use aMenu Activity in a RAD call flow. You can use subroutines to provide
access to activities from other call flow types. See "Building subroutines" on page 458 for more
information.

l Your licensing level. Table 17 - 2 lists the licensing levels at which different activities are available.
For example, as part of the Outbound call flow type, theMake Call activity is only available with IVR
Routing Premium Licensing.
See theContact Center Solutions and Call Accounting System Engineering Guide for more information
regarding licensing.

To add an activity to a call flow
 1. Select the call flow to which you want to add an activity.

The Call flows Canvas opens.
 2. In the Toolbox pane, click and drag the Activity you want to add to theDrop Activities Here section of

the Canvas.
NOTE: If the Toolbox pane is not visible, click the Toolbox flyout. To keep the toolbox pane visible,
click the pin icon.

 3. On the ribbon, click Save.
NOTE:A red exclamationmark icon displayed in the top right corner of an activity signals a validation
error or missing information. Youmust correct the error or enter the information before you can save the
call flow. Selecting the relevant activity and clicking the exclamationmark icon displays the error you
must correct. If you wish to disable validation, deselect theValidate call flow check box in the call
flow Properties pane.

Deleting activities or branches from call flows
To delete an activity or branch from a call flow
 1. Right-click the activity or branch and select Delete.
 2. On the ribbon, click Save.

Naming activities, activity configurations, and branches
Activities, configuration settings within an activity, and branches will often require a name or system name. A
“system name” is used by IVR Routing to identify an activity, activity condition, or branch. A “name” is used to
label an activity, activity condition, or branch for the user to see.
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To name an activity, activity configuration, or branches
 1. In the Call flows Canvas, select the activity, activity configuration, or branch.
 2. In the Properties pane, afterName, type a name for the activity, activity configuration, or branch.
 3. After System Name, type a system name for the activity, activity configuration, or branching condition.

NOTE:System names must be unique. They must only contain characters from A-Z or from 0-9 and
cannot contain spaces.

 4. On the ribbon, click Save.

Configuring activities and branches for reporting
Configuring activities or branches for reporting will enable you to run reports on them using Contact Center
Management. Running reports on activities or branches enables you to analyze call flow traffic and see how
callers aremoving through your call flows.

To configure an activity and branch for reporting
 1. In the Call flows Canvas, select the activity or branch to configure for reporting.
 2. In the Properties pane, select theReportable check box.
 3. On the ribbon, click Save.

Editing branches
To edit a branch
 1. In the Call flows Canvas, expand the activity.
 2. Right-click the condition to edit and select Edit (name of activity) Condition.
 3. Select the value to edit and type the new value.
 4. At the top of the pane, click Add.
 5. To add another value to the condition, at the top of the pane, click Add and type the value or range of

values.
 6. To delete a value, select the value and click Delete.
 7. Click OK.
 8. On the ribbon, click Save.

Changing the order of branches
You prioritize branching conditions by placing branches in sequence. The highest-priority branch, or branching
condition, is placed in the left-most position. IVR Routing will prioritize branching in the order of left to right.

NOTE: Calls that do not match an activity’s branching conditions will route to a “NoMatch” branch.

To change the order of a branch
 1. In the Call flows Canvas, expand the relevant activity.
 2. Right-click the branch you want to move and select eitherMove left orMove right.
 3. On the ribbon, click Save.
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Configuring the ANI activity
The ANI activity branches call flows based on all or part of a customer’s ANI. For example, you can configure
an ANI activity to identify the area codes for callers from French-speaking locations and route all applicable
calls to queues with French-speaking agents. The ANI activity enables customers to be efficiently routed to
the agents best suited to serve them. You can add branching conditions to ANI activities to determine how
IVR Routing directs callers through the call flow. The ANI activity is available in Voice andManagement call
flows.

NOTE: For general information on working with activities, including adding, deleting, and editing activities,
see "Configuring common activity options" on page 485.

Adding branching conditions to ANI activities
Branching conditions represent the criteria by which IVR Routing directs calls.

To add a branching condition to an ANI activity
 1. In the Call flows Canvas, right-click the ANI activity and select Add an ANI condition.

The ANI dialog box opens.
 2. To add an ANI value, at the top of the dialog box, click Add and type a value or range of values for the

ANI condition.
 3. Click theAdd icon.

NOTE:
l To branch all calls from a specified area code, city exchange, or other number identification,

include an “x” at the end of the numeric value. “x” indicates multiple wildcard characters.
l To indicate individual digits or to set branching conditions tomatch any ANI, include question

marks instead of numeric values.
 4. To import ANI conditions in *.csv format, click Import and navigate to the file name you want to import.
 5. To export ANI conditions in *.csv format, click Export and navigate to the file name you want to export.

NOTE:
l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.
l You cannot addmultiple branches by right-clicking the ANI condition and selecting the Edit

option.
 6. To addmore ANI conditions, at the top of the ANI dialog box, click Add.
 7. To enable reporting for the branch, select theReportable check box.
 8. To test the ANI conditions, underUtilities, enter a value.

If the test is successful, “Pass” displays.
If the test is unsuccessful, “Fail” displays.
NOTE:You cannot test a range of values.

 9. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the
dialog box open to create new branches.

 10. On the ribbon, click Save.
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Configuring the Answer activity
The Answer activity prompts a port to answer a ringing line and begin the call flow. You can configure timeouts
for Answer activities. Timeouts determine how long the Answer activity has to execute and indicate if it has
successfully answered the line before IVR Routing terminates the activity. The Answer activity is available in
Voice, RAD, andManagement call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring timeouts for Answer activities
To configure a timeout for an Answer activity
 1. In the Call flows Canvas, select the Answer activity.
 2. In the Properties pane, after Timeout (sec), type a number from 1 to 60.
 3. On the ribbon, click Save.

Configuring the Callback Request activity
The Callback Request activity offers a callback plan to customers. For example, you can use the Callback
Request activity to enable callers experiencing longer than average wait times to request a callback from an
agent. Callback Request helps youmeet your service level goals by reducing abandoned calls. You can
assign call back plans and destinations to Callback Request activities, add devices to Callback Request
destinations, and edit Callback Request activities to determine how IVR Routing directs callers through the
call flow. The Callback Request activity is available in Voice call flows.

NOTE:
l For callbacks to function correctly, youmust have configured location settings for your media server. If

location settings are not configured, your callbacks will not be able to contact your customers. See
"Configuring location settings for 3300 ICP media servers" on page 76.

l For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Assigning callback plans to Callback Request activities
A callback plan is a tool that identifies a caller from the caller’s message andmakes a return telephone call. It
also enables agents to re-queue or reject the callback request.

NOTE: IVR Routing provides a default voice callback plan. For information on configuring callback plans in
YourSite Explorer, see "Configuring callbacks and callback plans" on page 462.

To assign a callback plan to a Callback Request activity
 1. In the Call flows Canvas, right-click the Callback Request activity and select Assign Callback Plan.

The Select a callback plan dialog box opens.
 2. UnderName, select the callback plan to assign to the Callback Request activity.
 3. Click OK.

NOTE: The Callback Request activity receives the name of the callback plan assigned to it.
 4. On the ribbon, click Save.
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Assigning destinations to Callback Request activities
The callback destination represents the agent groups responsible for answering callbacks.

To assign a destination to a Callback Request activity
 1. Right-click the Callback Request activity and select Assign Destination.

The Select a device dialog box opens.
 2. Select a destination from one of the following devices:

l Queue
l Queue group
l Call variable
l Extensions
l Agent

 3. Click OK.
 4. On the ribbon, click Save.

Adding new devices to Callback Request destinations
To add a new device to a Callback Request destination
 1. Right-click the Callback Request activity and select Assign Destination.

The Select a device dialog box opens.
 2. Select one of the following tabs:

l Queue
l QueueGroup
l Call variable
l Extensions
l Agent

 3. In theQueue, Queue Group, Call variable, Extension, orAgent tabs, at the top of the dialog box,
click Add.

 4. To add a new queue, in the Queue pane, follow the steps under "Configuring queues" on page 445.
NOTE:

l To configure a new queue for web callbacks, see "Enabling callbacks" on page 462.
l To configure a new queue for UPiQ, see "Configuring UPiQ options" on page 448.

 5. To add a new queue group, follow the corresponding steps in "Adding and editing branching conditions
for Queue activities" on page 514.

 6. To add a call variable, follow the corresponding steps in "Adding new devices toMake Call destinations"
on page 503.

 7. To add a new extension, see "Adding extensions" on page 440.
 8. To add a new agent, follow the corresponding steps in "Adding agents" on page 131.
 9. To edit the destination assigned to the Callback plan, right-click the Callback Request activity and

select Assign Destination.
The Select a device dialog box opens.

 10. Select the new destination to assign to the Callback Request activity.
 11. Click OK.
 12. On the ribbon, click Save.
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Editing Callback Request activities
To edit a Callback Request activity
 1. To edit the destination, right-click the activity and select Assign Destination.

The Select a device dialog box opens.
 2. Select the new destination and click OK.
 3. To edit the callback plan assigned to a Callback Request activity, right-click the activity and select

Assign Callback Plan.
The Select a callback plan dialog box opens.

 4. Select the new callback plan and click OK.
 5. On the ribbon, click Save.

Configuring the Collect Digits activity

The Collect Digits activity prompts callers to enter, through their dial pad, information that can then be stored
in a variable. For example, Collect Digits could enable a caller to enter their membership number when they
enter the call flow. If stored in a custom variable, this information can be sent to an agent to provide them
additional information about the customer. You can configure options and collection settings for Collect Digits
activities to determine how IVR Routing directs callers through the call flow. The Collect Digits activity is
available in Voice, Management, andOutbound call flows.

NOTE:
l Information acquired by a Collect Digits activity is stored within the <<LastCollectedDigits>> system

variable. Subsequent Collect Digits actions overwrite this system variable. You can also select a
variable to in which to store customer-entered digits.

l For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring options for Collect Digits activities
To configure options for a Collect Digits activity
 1. Select the Collect Digits activity.
 2. In the Properties pane, afterConfirm Digit, select a confirmation digit from the drop-down list.

NOTE:Confirm digit sets the digit a caller presses to confirm that their input is correct.
 3. AfterConfirm Input, click theV button and follow the steps under "Adding prompts to Play activities"

on page 507.
NOTE:Confirm Input sets the prompts a caller hears asking them to confirm the digits they have
entered.

 4. To enable reporting, select theReportable check box.
 5. To set the number of times a caller can try to enter information, afterAttempts, type a number.
 6. To set the number of seconds a caller has to enter another digit, afterDTMF Multi Digit Delay, type a

number from one to five.
NOTE:Callers who take longer to enter a digit will be prompted again to enter their digits. After that, the
caller is routed to the Failure branch.

 7. To set the number of seconds that the system waits for a DTMF response before timing out, afterNo
digit timeout (sec), type a number from 1 to 10.
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 8. To hide customer-entered information in service logs, select theSuccess branch and, in the Properties
pane, select theMask branch result check box.
NOTE:

l To enableMask branch result, in the Properties pane, ensure that theReportable check box
is selected.

l Mask branch result covers customer-entered DTMF digits with ‘********’ in service logs.
 9. On the ribbon, click Save.

Configuring collection settings for Collect Digit activities
Collection settings assign themaximum andminimum number of digits a caller can enter.

To configure a collection setting for a Collect Digits activity
 1. Select the Collect Digits activity.
 2. In the Properties pane, afterCollection Settings, click the… button.

The Collect Digits dialog box opens.
 3. To store customer-entered digits in a variable other than <<Last Collected Digits>>, afterVariable, click

the… button.
The Variables dialog box opens.

 4. Select a variable and click OK.
 5. To add a new variable, click Add.

NOTE: The following variables are available to Collect Digits: Dollars, Euros, Pounds, Digits, Number,
and Date and Time.

 6. AfterName, type the name of the variable.
 7. AfterDescription, type a description for the variable.
 8. AfterVariable Type, select a type from the drop-down list.
 9. To enable agents to receive variable information on their toasters, select theSend to Agent’s toaster

check box.
 10. AfterDisplay Name, type the screen pop name that appears on the agent’s toaster.
 11. Click Save.
 12. UnderGreeting, click the… button and select a greeting for the collection settings.
 13. Click OK.
 14. To add a new greeting, click Add and follow the corresponding steps in "Configuring prompts" on page

459.
 15. Under Terminating Digit, type the digit that callers enter when they are finished inputting digits.
 16. UnderMin. digits to collect, type theminimum number of digits.
 17. UnderMax digits to collect, type themaximum number of digits.

NOTE:When a caller reaches themaximum number of digits, IVR Routing will not wait for the
terminating digit. If a caller reaches themaximum number of digits and then presses the terminating
digit, that digit will be incorporated into the subsequent activity.

 18. To configure another collection setting, click Add.
 19. To delete a collection setting, select the setting and click Delete.
 20. Click OK.
 21. On the ribbon, click Save.
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Configuring the Compare Variables activity
The Compare Variables activity branches calls by comparing customer information, stored in either custom or
system variables, against specified conditions. For example, you can use Compare Variables to create a
priority branch for customers with Goldmembership. The Compare Variables activity compares a variable for
Goldmembership against a customer’s actual membership level. If the customer’s membership information
compares positively against the criteria for the Gold branch then the caller is routed to the priority branch.
Customers whosemembership information does not match the criteria for the Gold branch are routed to the
NoMatch branch. You can add andmodify branching conditions for Compare Variables activities, and you
can group variable conditions to determine how IVR Routing directs callers through the call flow. The
Compare Variables activity is available in Voice, Outbound, andManagement call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Adding and modifying variable conditions for Compare Variables
activities
To add andmodify (edit/delete) a variable condition for a Compare Variables activity
 1. In the Call flows Canvas, right-click on the Compare Variables activity and select Add Compare

Variables condition.
The Variable Compare Condition Designer dialog box opens.

 2. AfterName, type a name for the variable compare condition.
 3. To add a new compare variable row, at the top of the dialog box, click Add.
 4. In the first column, select a variable from the drop-down list and click OK.
 5. In the second column, select one of the following operators from the drop-down list:

l != Not Equal
l < Less than
l <= Equal to or less than
l = Equal
l > Greater than
l >= Equal to or greater than
l Contains

NOTE:Operators appearing in the second column vary according to the variable selected in the first
column.

 6. In the third column, from one of the tabs in the drop-down list, type a value or select a value.
NOTE: Tabs appearing in the third column vary according to the variable selected in the first column.

 7. Click OK.
 8. To add a new variable row, at the top of the dialog box click Add.
 9. To delete a row, from the drop-down list to the left of the variable row select Delete.
 10. To enable reporting, select theEnable reporting for this branch check box.
 11. To edit variable conditions, right-click the Compare Variables activity and select Add Compare

Variables condition.
 12. Change the variable compare conditions.
 13. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the

dialog box open to create new branches.
 14. On the ribbon, click Save.
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Grouping variable compare conditions in Compare Variables activities
You can group variables to be compared in the Compare Variables activity using the “Group AND” or “Group
OR” buttons in the Variable Compare Condition Designer. Grouping variables by Group AND means that
every variable condition specifiedmust bemet to route the call to the Success branch. Grouping variables by
GroupOR means that only one of the variable conditions specifiedmust bemet to route the call to the
Success branch.

NOTE:
l The “Group AND” and “GroupOR” buttons will be disabled unless you have at least two conditions to

group.
l Group AND is the default grouping for the Compare Variables activity.

To group variable compare conditions in a Compare Variables activity
 1. Right-click the Compare Variables activity and select Add Compare Variable Condition.
 2. Select the variables to group and click theGroup AND orGroup OR buttons.

NOTE: To groupmultiple rows, press Ctrl and click to the right of the < Value> column for each
variable.

 3. To add a variable to an existing group, from the drop-down list to the left of And orOr, select Add.
 4. To ungroup a group of variables, from the drop-down list to the left of And orOr, select Ungroup.
 5. To remove one variable from a group, from the drop-down list to the left of the variable row, select

Ungroup.
 6. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the

dialog box open to create new branches.
 7. On the ribbon, click Save.

Configuring the DNIS activity
The DNIS activity branches call flows based on the number a customer has dialed. For example, you can
configure DNIS activities to branch calls to a “Service” section of the call flow as opposed to a “Sales” section
of the call flow. DNIS activities enable the use of a single call flow and port set for calls to multiple business
lines. You can add branching conditions to DNIS activities to determine how IVR Routing directs callers
through the call flow. The DNIS activity is available in Voice, Management, andOutbound call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Adding branching conditions to DNIS activities
To add a branching condition to a DNIS activity
 1. In the Call flows Canvas, right-click the DNIS activity and select Add a DNIS condition.

The DNIS dialog box opens.
 2. To add a DNIS value, at the top of the dialog box, click Add and type a value or range of values for the

DNIS condition.
 3. Click theAdd icon.
 4. To import DNIS conditions in .csv format click Import => Import from file and navigate to the file

name.
 5. To import DNIS conditions from aDNIS table, click Import => Import from DNIS table.

The Import from DNIS table pane opens.
 6. Select the DNIS conditions to import and click OK.
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 7. To export DNIS conditions, click Export and navigate to the file name.
NOTE:

l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.

 8. To addmore DNIS conditions, at the top of the dialog box, click Add.
 9. To enable reporting for the branch, select theReportable check box.
 10. To test the DNIS conditions, underUtilities, enter a value or range of values.

If the test is successful, “Pass” displays.
If the test is unsuccessful, “Fail” displays.
NOTE:You cannot test a range of values.

 11. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the
dialog box open to create new branches.

 12. On the ribbon, click Save.

Configuring the Email activity
The Email activity enables IVR Routing to send emails, with or without attachments, to recipients via the
SMTP provider configured in Contact Center Management. You can populate Email fields with variables, and
you can populate email attachments with variables or files. For example, you can use the Email activity to
enable automated emailing of purchase orders and reports within a call flow. The Email activity allows
electronic information to be sent from within a call flow efficiently and accurately to the different departments
in an organization. You can configure Email activity templates and add and edit SMTP servers using the Email
activity. The Email activity is available in Voice, RAD, Outbound, andManagement call flows.

NOTE:
l When using a variable as an attachment, you require an activity that can retrieve data to appear prior to

the Email activity in the call flow. This activity, such as Query or Execute, will retrieve the data to
populate the variable attachment.

l To configure the SMTP provider in Contact Center Management, see "Configuring the SMTP server" on
page 42. To configure email recipients, see "Configuring email contacts" on page 47.

l For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring Email activity templates
Configure Email activity templates by populating the template fields with variables or text.

NOTE:
l You can populate fields in an Email activity template with a variable by typing the name of the variable

between double-angle brackets. The text between the angle brackets will be replaced with the value of
the variable currently executing in the call flow.
For example, <<ANI>>. In this variable, ANI will be replaced with the caller ID information.
You can also right-click any field in the email template and select a variable from the drop-down list.

l Variables must be populated with a value that points to a file path or populated by an activity within the
call flow.
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To configure an Email activity template
 1. In the Call flows Canvas, right-click the Email activity and select Edit Email Template.

The Configure email template dialog box opens.
 2. Configure all email fields as applicable.

NOTE: In the To:, Cc:, and Bcc: fields, separatemultiple addresses with a semi-colon.
 3. In the body of the email, type the text the template will contain.
 4. To add call variables to fields in the email template, right-click the field and select the variable from the

drop-down list.
You can also type the name of the variable between double angle brackets.

 5. Click OK.
 6. On the ribbon, click Save.

Adding and editing SMTP servers in Email activities
To add and edit SMTP servers in an Email activity
 1. Right-click the Email activity and select Edit SMTP Server.

The Select a SMTP server dialog box opens.
 2. Select an SMTP server.
 3. Click OK.
 4. To configure the activity with another recipient, click theAdd button and follow the steps in "Configuring

the SMTP server" on page 42.
 5. To edit a recipient, select the recipient and click theEdit button.
 6. Follow the steps in "Configuring the SMTP server" on page 42.
 7. Click OK.
 8. On the ribbon, click Save.

Configuring the Execute activity
The Execute activity enables IVR Routing to interact with external systems by running the following four
processes:

l Executable/Script – Runs an *.EXE file or *.BAT script on the server and delivers return values or
parameters if the script executes successfully.
NOTE: The Execute activity requires *.EXE files and *BAT scripts to be on a UNC path.

l PowerShell – Runs a PowerShell script on the server and delivers return values or parameters if the
script executes successfully.
NOTE: The Execute activity requires PowerShell scripts to be on a UNC path.

l Web Service – Enables the Execute activity to retrieve an XML response from an external web service
using SOAP or REST and delivers return values if the script executes successfully.

l CRM Service – Sends user defined queries to aMicrosoft CRM 2007, 2011, or CRMOnline system
and delivers return values if the script executes successfully.

For example, you can use the Execute activity to retrieve customer information from aWeb Service database
and store this information in a custom variable for use within the call flow or to pass on to agents in a screen
pop for enhanced customer service. You could also use the Execute activity to run a PowerShell script
enabling an authorized caller to run remotemaintenance on the IVR Routing server. You can configure the
options and the process types for Execute activities. The Execute activity is available in Voice, RAD,
Outbound, andManagement call flows.
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NOTE:
l A success return value indicates the process executed without errors. A failure return value indicates

the process exited with errors and did not complete as expected.
l For general information on working with activities including adding, deleting, and editing activities, see

"Configuring common activity options" on page 485.

Configuring options for Execute activities
To configure the options for an Execute activity
 1. In the Call flows Canvas, select the Execute activity.
 2. To set waiting prompts to always play to completion before allowing the call flow to proceed, regardless

of whether the process has completed executing, deselect theBarge Prompt check box.
NOTE: The waiting prompt is what callers hear while they wait for the Execute activity process to
complete. Barge Prompt signifies that the prompt will stop playing once the process has completed
executing.

 3. To set the Execute activity to route to the Success branch without waiting for a process to complete,
deselect theWait for completion check box.
NOTE:

l We recommend you deselect “Wait for completion” only if you do not require the Execute
activity to retrieve information and return a result. For example, deselect Wait for completion
if you are using the Execute activity to runmaintenance.

l If the process fails to start, the activity will route to the Failure branch regardless of whether
“Wait for completion” is deselected.

 4. AfterWaiting Prompt, click theV button and follow the steps under "Adding prompts to Play activities"
on page 507.
NOTE:

l Waiting prompts help keep callers engaged on the line during processes that take longer than
usual to complete.

l If theWait for completion check box is deselected, it is not necessary to configure a waiting
prompt.

 5. To enable reporting, select theReportable check box.
 6. After Timeout, type a number from 1 to 60 to set the number of seconds for an associated process to

complete successfully before executing to the Failure branch.
 7. On the ribbon, click Save.

Configuring process types for Execute activities
The process type is the external process that executes when a caller progresses through the call flow. The
process type determines what parameters will be available and displayed. Process types include
Executable/Script or PowerShell processes, Web Service processes, and CRM Service processes.

To configure an Executable/Script or PowerShell process
 1. In the Properties pane to the right, afterProcess, click theV button and select Executable/Script.
 2. AfterPath, click theBrowse… button.
 3. For Executable/Script processes, navigate to the *.EXE or *.BAT script.

NOTE: This script must be on a UNC path.
 4. AfterSeparator, select a separator from the drop-down list required by your .exe file.

NOTE: The separator is the character that separates the parameters in the command line statement for
the process.

 5. For PowerShell processes, navigate to the PowerShell script.
 6. To add a set of input parameters, in the Input Parameters pane click Add.
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 7. UnderParameter, select the parameter that the process uses to execute.
NOTE: If your batch files or Executable/Script processes require delimiters, youmust enter them
manually into theParameter column.

 8. UnderValue, select a variable from the drop-down list or type a static value.
NOTE:

l This variable will be replaced when a caller progresses through the call flow.
l To configure the process to use a value not linked to a parameter, select a variable from the

Value field and leave theParameter field blank.
 9. Repeat steps 5-8 for each set of input parameters the process uses.
 10. To test the process, under Test Value enter the values to test the process and click Execute.
 11. The Results dialog box opens and gives the output values.

If the test is successful, “Execution Successful” displays in the Results dialog box.
If the test is not successful, “Execution Failed” displays in the Results dialog box.
NOTE:

l For Executable/Script processes, the Results dialog box lists return values and output
pipeline values.

l For PowerShell processes, the Results dialog box lists return values and PSObject[X]
values.

 12. Click OK.
TheOutput Mapping pane will be auto-populated.

 13. To delete a set of input parameters, click the arrow to the left of theParameter field and click Remove.
 14. To store the retrieved data as a call variable, in the Output Mappings pane underOutput, select an

output value.
 15. UnderMapping, select a call variable from the drop-down list.

When a caller progresses through the call flow, each call variable in the Output Mapping field is
assigned the value indicated in the Output field.

 16. Click OK.
 17. On the ribbon, click Save.

To configure aWeb Service process
 1. In the Properties pane to the right, afterProcess, click theV button and selectWeb Service.
 2. AfterURI, type the URI of theWeb Service with which the IVR will communicate.
 3. From theWeb Service Type drop-down list, select eitherSOAP orREST.
 4. If you are using a SOAPWeb Service, click theScan… button to verify theWeb Service.
 5. If you are using a RESTWeb Service, afterUsername andPassword type your login credentials for the

Web Service.
NOTE: Login credentials might not be necessary depending on theWeb Service you are using.

 6. AfterWeb Method, select theWebMethod from the drop-down list.
l TheWebMethod field will only appear if you are using a SOAPWeb Service.
l SOAPWeb Services populate theWebMethods field with a drop-down list of functions the

Web Service allows you to use.
l TheWebMethod populates the Parameters field for SOAPWeb Services.

 7. UnderValue, select a value from the drop-down list or type static values.
 8. To test the process, under Test Value, enter the values to test the process and click Execute.
 9. If you are using a SOAPWeb Service:

The Results dialog box opens.
If the test is successful, “Execution Successful” displays in the Results dialog box.
If the test is unsuccessful, “Execution Failed” displays in the Results dialog box.

 10. Click OK.
 11. If you are using a RESTWeb Service:

The Results dialog box opens.
 12. In the XMLOutput pane, select the node containing the information the Execute activity retrieves and

click OK.
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 13. AfterSelected Node, click theShow Results button.
 14. Click OK.

TheOutput Mappings pane will be auto-populated.
 15. To store retrieved data as a call variable, in the Output Mappings pane underOutput select an output

value.
 16. UnderMapping, select a call variable from the drop-down list.

When a caller progresses through the call flow, each call variable in theMapping field is assigned the
value indicated in the Output field.

 17. Click OK.
 18. On the ribbon, click Save.

To configure a CRM Service process
 1. In the Properties pane, afterProcess, click theV button and select CRM Service.
 2. AfterCRM URI, type the URI of the CRM system with which the IVR communicates.
 3. From theCRM Version drop-down list, select the version of the CRM system.
 4. If you select CRM2007, afterOrganization Name, type the name of the organization running the CRM

system.
 5. Complete the following fields:

l Domain – Type the domain name of the CRM site.
l Username – Type the username for your CRM site login.
l Password – Type the password for your CRM site login.
l Entity Name – From the drop-down list, select the name of the CRM entity that the Execute

activity queries.
 6. To add a set of input parameters, in the Input Parameters pane, click Add.
 7. UnderParameter, type the name of the parameter that the process uses to execute.
 8. UnderValue, select a variable from the drop-down list.

NOTE: This variable is replaced when a caller progresses through the call flow.
 9. To test the process, under Test Value, enter the values to test the process and click Execute.

The Results dialog box opens.
If the test is successful, “Execution Successful” displays in the Results dialog box.
If the test is unsuccessful, “Execution Failed” displays in the Results dialog box.

 10. To store retrieved data as a call variable, in the Output Mappings pane underOutput select an output
value.

 11. UnderMapping, select a call variable from the drop-down list.
When a caller progresses through the call flow, each call variable in theMapping field is assigned the
value indicated in the Output field.

 12. Click OK.
 13. On the ribbon, click Save.
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Configuring the Goto activity
TheGoto activity enables callers to be sent to an alternate point in the call flow. For example, if a customer
enters an invalid account number, the Goto activity sends them back through the call flow so they can enter
their digits again. TheGoto activity helps minimize the number of customers routed to the failure branch and
helps callers route to the queues best able to help them. You can configure destinations for Goto activities.
These destinations determine the parent activity to which the Goto returns callers. TheGoto activity is
available in Voice, Outbound, andManagement call flows.

NOTE:
l You can only use the Goto activity within nested activities, unless you are using aGoto activity within a

Query activity. Goto activities within Query activities may send caller to points in the call flow outside
the Query activities nested call flow.

l TheGoto activity enables callers to move up an activity tree and cannot be used to send callers
laterally in the call flow or to a subsequent workflow step.

l For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring destinations for Goto activities
To configure a destination for a Goto activity

 1. In the Call flows Canvas, right-click the Goto Activity and select Activity Name.
 2. Select the activity to which the Goto returns callers.
 3. If your call flow uses embeddedmenus, select theReset Repeat Count check box to give callers an

unlimited number of attempts to enter information.
 4. On the ribbon, click Save.

Configuring the Hangup activity
The Hangup activity instructs IVR Routing to end the call flow, preventing callers from waiting on a dead line
and freeing up ports to take new calls. Hangup activities are inserted at the end of a call flow or branch. For
example, you can insert a Hangup activity at the end of a “Closed” branch in a Schedule activity to terminate
the call after a customer hears that the contact center is closed. You can configure the timeout for Hangup
activities. Timeouts determine how much time the activity has to execute before IVR Routing terminates it.
The Hangup activity is available in Voice, RAD, andManagement call flows.

NOTE:
l We recommend you insert a Hangup activity any place where the call could potentially end. This

ensures the call is terminated correctly and the port is freed to accept a new call.
l For general information on working with activities including adding, deleting, and editing activities, see

"Configuring common activity options" on page 485.

Configuring timeouts for Hangup activities
To configure a timeout for a Hangup activity

 1. In the Call flows Canvas, select the Hangup activity.
 2. In the Properties pane, after Timeout (sec), type a number from 1 to 60.
 3. On the ribbon, click Save.
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Configuring the Hunt Group activity
The Hunt Group activity branches call flows based on the hunt group to which a call has been directed. For
example, you can configure a Hunt Group activity to route a call towards “Technical Assistance” telephone
lines and the queues that use these lines to provide technical support. The call flow will search the Technical
Assistance hunt groups for the first available line and switch the call onto the line when one is found. The Hunt
Group activity enables customers to be efficiently routed to the services they need. You can add branching
conditions to Hunt Group activities to determine how IVR Routing directs callers through the call flow. The
Hunt Group activity is available in Voice, RAD, andOutbound call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Adding branching conditions to Hunt Group activities
Branching conditions represent the criteria by which IVR Routing directs calls.

To add a branching condition to a Hunt Group activity
 1. In the Call flows Canvas, right-click the Hunt Group activity and select Add a Hunt Group condition.

The Hunt Group dialog box opens.
 2. To add a hunt group value, at the top of the dialog box, click Add and type a value or range of values for

the hunt group condition.
 3. Click theAdd icon.

l To branch all calls from a specified area code, city exchange, or other number identification,
include an “x” at the end of the numeric value. “x” indicates multiple wildcard characters.

l To indicate individual digits or to set branching conditions tomatch any ANI, include question
marks instead of numeric values.

 4. To import hunt group conditions in .csv format, click Import and navigate to the file name.
 5. To export hunt group conditions, click Export and navigate to the file name.

NOTE:
l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.

 6. To addmore hunt group conditions, at the top of the Hunt Group dialog box, click Add.
 7. To enable reporting for the branch, select theEnable reporting for this Branch check box.
 8. To test the hunt group conditions, underUtilities, enter a value or range of values.

If the test is successful, “Pass” displays.
If the test is unsuccessful, “Fail” displays.
NOTE:You cannot test a range of values.

 9. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the
dialog box open to create new branches.

 10. On the ribbon, click Save.
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Configuring the Delay activity
The Delay activity enables IVR Routing to suspend a call flow for a predetermined time. For example, a
customer calling the IVR will hear a welcomemenu that lasts a certain number of seconds. To test your call
flow and simulate the customer’s experience, you can insert a Delay activity suspending the call flow for a
duration that matches the length of the prompt. The Delay activity also enables third-party applications to
process a command before continuing to a step that requires the processing be complete. You can set the
duration of a Delay activity to determine for how long the IVR Routing will suspend the call flow. The Delay
activity is available in Voice, RAD, Outbound, andManagement call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Setting the duration of Delay activities
To set the duration of a Delay activity
 1. In the Call flows Canvas, select the Delay activity.
 2. In the Properties pane, afterDelay, type the number of seconds the call flow will pause.
 3. On the ribbon, click Save.

Configuring the Language Activity
The Language activity changes IVR Routing’s system language, enabling the IVR to provide an identical call
flow in different languages. When the Language activity is reached in the call flow, all subsequent prompts
play in the set language. For example, you can insert a Language activity into amenu to allow customers to
choose the language in which they receive service. By supportingmultiple languages in a single call flow, the
Language activity reduces the number of prompts youmust create and the number of duplicate activities in
your call flow. The Language activity also reduces the number of ports that IVR Routing uses by allowing the
same set of ports to be used for multiple languages. You can set and edit the languages for Language
activities. The Language activity is available in Voice, RAD, Outbound, andManagement call flows.

NOTE:
l The language value is stored within the <<Language>> system variable. Each subsequent Language

action overwrites the value in the system variable.
l For general information on working with activities including adding, deleting, and editing activities, see

"Configuring common activity options" on page 485.
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Setting and editing languages for Languages activities
To set and edit the language for Language activities
 1. In the Call flows Canvas, right-click the Language activity and select Select Language.
 2. Select one of the following languages for the call flow:

l Chinese Simplified
l Dutch
l English United Kingdom
l English United States
l French Canada
l French France
l German
l Italian
l Portuguese Brazil
l Russian
l Spanish Latin America
l Spanish Spain

 3. To edit the language, right-click the Language activity and select Select Language.
 4. Select a different language for the call flow.
 5. On the ribbon, click Save.

Configuring the Make Call activity
TheMake Call activity prompts an associated port to process an outbound call to a specified destination. This
destination can be retrieved from a data source including a SQL database, an Excel file, aWeb Service call, or
custom variable. For example, you can use theMake Call activity as part of an outbound call flow designed to
contact customers during an advertising campaign. You can assign theMake Call activity a destination, set
the amount of time the port has tomake the call before IVR Routing terminates the action, and add new
devices toMake Call activity destinations. TheMake Call activity is available in Outbound call flows.

NOTE:
l As part of Outbound call flows, theMake Call activity is only available with IVR Routing Premium

Licensing.
l For general information on working with activities including adding, deleting and editing activities, see

"Configuring common activity options" on page 485.

Configuring options for Make Call activities
To configure options for aMake Call activity
 1. In the Call flows Canvas, select theMake Call activity.
 2. To assign a destination for the call, in the Properties pane afterDestination, click the… button.

The Select a device dialog box opens.
 3. Select one of the following from the drop-down list:

l Extension
l Queue
l Queue group
l Call variable

 4. Click OK.
 5. To define the call as an external call to the phone system, select theExternal Call check box.

Selecting this check box adds the external dialing digit as defined for themedia server.
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 6. After Timeout (sec), type the number of seconds the system has tomake the call before the activity
closes.

 7. To enable reporting , select theReportable check box.
 8. On the ribbon, click Save.

Adding new devices to Make Call destinations
To add a new device to aMake Call Destination
 1. In the Properties pane, after Destination, click the ... button.

You can also type in a destination.
The Select a device dialog box opens.

 2. Select one of the following tabs:
l Extension
l Queue
l Queue group
l Call variable

 3. At the top of the dialog box, click Add.
 4. To add a new extension, see "Adding extensions" on page 440.
 5. To add a new queue, see "Configuring queues" on page 445.

NOTE:
l To configure a new queue for web callbacks, see "Enabling callbacks" on page 462.
l To configure a new queue for UPiQ, see "Configuring UPiQ options" on page 448.

 6. To add a new queue group, follow the applicable steps in "Adding and editing branching conditions for
Queue activities" on page 514.

 7. To add a new call variable, in the Variables pane afterName, type a name for the variable.
 8. AfterDescription, type a description for the variable.
 9. From theVariable Type drop-down list, select one of the following variables types:

l Queue
l Digits
l DN
l Hunt Group
l Number
l Unspecified

 10. To enable agents to receive call variable information on their toaster, select theSend to Agent’s
toaster check box.

 11. AfterDisplay Name, type the name that appears on the agent’s toaster.
 12. Click Save.
 13. In the Select a device pane, click OK.
 14. On the ribbon, click Save.

Configuring the Management activity
TheManagement activity represents amanagement plan that is available to authorized callers, enabling them
tomanage the state of IVR Routing and its prompts over the phone. For example, if the contact center is
unexpectedly closed due to severe weather, a manager working from home can use theManagement activity
to set the IVR to Emergency mode and record a prompt informing callers of the center’s closure. You assign
subroutines toManagement activities and configure remote access options for authorized callers. The
Management activity is available in Voice andManagement call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.
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Assigning subroutines to Management activities
IVR Routing provides a default Management subroutine. For information on building subroutines to assign to
Management activities, see "Building subroutines" on page 458.

To assign a subroutine to aManagement activity
 1. In the Call flows Canvas, select theManagement activity.
 2. In the Properties pane, afterManagement Subroutine, click the… button.

The Select a subroutine or variable window opens.
 3. Click either theSubroutines orVariables tab and select a subroutine or a call variable to assign to the

activity.
 4. Click OK.
 5. To create a new call variable, under theCall variables tab, click Add and follow the corresponding

steps in "Adding new devices toMake Call destinations" on page 503.
 6. In the Properties pane, afterActivity, select the activity from the drop-down list to which the Goto

returns callers.
NOTE:You can only select a Goto activity if the Subroutine is nested within another activity. For more
information, see "Configuring the Goto activity" on page 499.

 7. If your call flow uses embeddedmenus, select theReset Repeat Count, check box to give callers an
unlimited number of attempts to enter information.

 8. On the ribbon, click Save.

Configuring properties for remote access
To configure properties for remote access
 1. Right-click on theManagement activity and select Open Management.
 2. Select the subroutine.
 3. In the Properties pane, after Instructions, click theV button and follow the steps under "Adding prompts

to Play activities" on page 507.
NOTE: Instructions play prompts andmenu options to an authorized caller.

 4. To enable reporting, select theReportable check box.
 5. To set the number of times an authorized caller can try to enter information, afterAttempts, type a

number.
 6. To set the digits an authorized caller will use to repeat menu instructions, afterDigits Repeat, click the

… button, select a number, and click OK.
 7. To enable callers to skip instructions using a digit entry, select theDTMF Barge In check box.
 8. To set the time taken to reset each digit after it is pressed, afterDTMF Multi Digit Delay, type a

number from one to five.
 9. To set the number of seconds that IVR Routing will wait if the user does not enter any digits, afterNo

Input Timeout, type a number from 1 to 60.
NOTE: If this time elapses, IVR Routing will send the caller back through the call flow.

 10. On the ribbon, click Save.
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Configuring the Menu activity
TheMenu activity prompts callers with messages andmanages routing based on caller input. For example,
you can configure theMenu activity to ask customers to press “1” on their dial pad to reach Technical Support
and “2” if they want to reach Sales. IVR Routing then directs callers to the appropriate queue based on the
number they pressed. TheMenu activity enables efficient routing to the appropriate queue. You can configure
the prompts callers hear, input options, and digit options for Menu activities. TheMenu activity is available in
Voice, Management, andOutbound call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring options for Menu activities
To configure options for aMenu activity
 1. Select theMenu activity.
 2. In the Properties pane, after Instructions, click theV button and follow the steps under "Adding prompts

to Play activities" on page 507.
NOTE: Instructions play prompts andmenu options to callers.

 3. To enable reporting for this branch, select theReportable check box.
 4. To set the number of times callers can try to enter information, afterAttempts type a number.

NOTE: If this number is exceeded, IVR Routing sends the call to the Failure branch.
 5. To set the digits callers will use to repeat menu instructions, afterDigits Repeat click the… button,

select a number and click OK.
 6. To enable callers to skip instructions using a digit entry, select theDTMF Barge In check box.
 7. To set the time taken to reset each digit after it is pressed, afterDTMF Multi Digit Delay, type a

number from one to five.
 8. To set the number of seconds to wait if the user does not enter any digits, afterNo Input Timeout, type

a number from 1 to 60.
NOTE: If this time elapses, IVR Routing will send the call to the Timeout branch.

 9. On the ribbon, click Save.

Configuring digit options
Digit options are the numbers callers select to navigate the IVR Routingmenu.

To configure digit options
 1. Right-click theMenu activity and select Add digit option.

TheMenu dialog box opens.
 2. To add a digit option, at the top of the dialog box, click Add and type a value or range of values.

NOTE:
l Adding questionmarks to a digit option enables callers to enter customer-specific

information, of a set length, into IVR Routing. For example, youmay have amenu asking
callers who aremembers to enter their 10-digit membership number. Adding a digit option of
“??????????” will route all callers entering a 10-digit number to the appropriate queue.

l Adding the letter “x” to a digit option enables callers to enter customer-specific information of
an unspecified length. For example, youmay have amenu asking callers to enter their
telephone number, including extensions. Adding a digit option of “613x” will route all callers
phoning from a 613 area code to the appropriate queue.

 3. Click theAdd icon.
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 4. To import digit options conditions in .csv format, click Import and navigate to the file name you want to
import.

 5. To export digit options in *.csv format, click Export and navigate to the file name you want to export.
NOTE:

l Digit options on a single line and separated by a commawill be added to a single branch.
l Digit options onmultiple lines and separated by a commawill be added tomultiple branches.

 6. To addmore digit options, at the top of theMenu dialog box, click Add.
 7. To enable reporting, select theEnable reporting for this Branch check box.
 8. To test the digit options, underUtilities, enter a value or range of values.

If the test is successful, “Pass” displays.
If the test is unsuccessful, “Fail” displays.

 9. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the
dialog box open to create new branches.

 10. To delete a digit option, select the value and click Delete.
 11. To hide customer-entered information in service logs, select theMask the result from this Branch

with *** check box.
NOTE:

l To enableMask branch result, ensure that theEnable reporting for this Branch check box
is selected.

l Mask branch result covers customer-entered DTMF digits with ‘********’ in service logs.
 12. On the ribbon, click Save.

Configuring the Mode of Operation activity
TheMode of Operation activity branches call flows to a secondary type of operation when the contact center
is temporarily out of service. It can also change IVR Routing back to the Normal mode. For example, you can
use theMode of Operation activity to route calls to an Emergency branch if the contact center is closed due to
severe weather. You can add activities to theMode of Operation activity’s branches to determine how IVR
Routing directs callers through the call flow in the event of an Emergency or in the case of Normal operations.
TheMode of Operation activity is available in Voice andManagement call flows.

NOTE:
l Formore information on setting IVR Routing to Emergency mode, see "Configuring the Set Device

Mode of Operation activity" on page 521 and "Configuring the Set SystemMode of Operation activity"
on page 521.

l For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring Mode of Operation activities for Emergency and Normal
modes
Configure theMode of Operation activity by specifying the actions a call flow will take in Emergency and
Normal modes.

To configure aMode of Operation activity for Emergency and Normal modes
 1. In the Call flows Canvas, expand theMode of Operation activity.
 2. From the Toolbox pane, drag activities to theEmergency orNormal branch.

NOTE: To configure the call flow to play an emergency message to callers routed to the Emergency
branch, see "Configuring prompts" on page 459.

 3. To enable reporting on the activity or a branch, select the activity or branch and select theReportable
check box.

 4. On the ribbon, click Save.
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Configuring the Play activity
The Play activity enables IVR Routing to play messages or read back the contents of variables to callers. The
Play activity can play a prompt or a single wave file to customers. For example, you can use a Play activity to
greet callers and inform them of their position in queue. You can add an existing system prompt to a Play
activity, add a new prompt, add a prompt that you have recorded, add a variable to a prompt, and preview
prompts in Play activities. For more information on configuring prompts in call flows, see "Configuring
prompts" on page 459. The Play activity is available in Voice, RAD, Management, andOutbound call flows.

NOTE:
l The duration of a prompt is stored within the <<LastWavePlayedDuration>> system variable. This

value will be overwritten any time a wave file is played in the call flow.
l For general information on working with activities including adding, deleting, and editing activities, see

"Configuring common activity options" on page 485.

Adding prompts to Play activities
Prompts are themessages callers hear at specified points in the call flow.

To add a prompt to a Play activity
 1. In the Call flows Canvas select the Play activity.
 2. In the Properties pane, to enable callers to skip prompts using a digit entry, select theBarge Enable

check box.
 3. To add an existing prompt, afterGreeting Prompts, click theV button and select Existing prompt.

The Select a prompt dialog box opens.
 4. Select a prompt and click OK.
 5. To add a new prompt, afterGreeting Prompts, click theV button and select Add Prompt.

The Prompt dialog box opens.
 6. AfterName, type a name for the prompt.

NOTE:Do not use apostrophes in the name.
 7. AfterDescription, type a description for the prompt.
 8. AfterCategory, select one of the following categories from the drop-down list:

l Callback
l Custom
l Management
l UPiQ

 9. To create your own category, afterCategory, type a name for the new category.
NOTE:Prompt categories are an organizational tool to help keep prompts sorted and easily accessible.

 10. After Language, select the primary language from the drop-down list.
NOTE:

l The language you select will determine the system wave files available to you.
l By default, the language is set to the default site language.

 11. Select one of the following tabs:
l System Wave Files – lists the system wave files callers hear while in the IVR or while waiting

on hold. This pane will only show the wave files that are available in the language you have
selected.

l Custom Wave Files – lists imported and newly created wave files. To import or record a custom
wave file, click Add and select Existing wave file to import the file orRecord wave file to use
themicrophone on your computer to record the file.
NOTE:Wave files must be 8khz, Mono, or ULAW format.

l Queue Stats – lists up-to-date queue statistics for use in prompts.
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l Variables – lists all variables available for use in prompts.
NOTE:Read back on variables is based on the type of variable. Number variables read back the
whole number, while digit variables read back individual numbers. For example, number variables
would read 123 as “one hundred and twenty-three”, while digit variables would read 123 as “one,
two, three”.

l Prompts used in call flows and subroutines – lists all prompts used in call flows and
subroutines

 12. In theAll system wave files, All custom wave files, All queue stats, All variables, orPrompts
used in call flows and subroutines pane, select the files to add to the prompt.

 13. Click > to add the file to the prompt.
The files is added to the prompt and is shown in theSelected members pane.
NOTE: The wave files play in the order they are added to the prompt. To change the order in which the
wave files will be played, select the wave file and click the up or down arrow buttons on the right-hand
side of the dialog box.

 14. Click Save.
NOTE: If you are adding prompts in a new language, youmust add audio files that correspond to the
existing audio files in IVR Routing’s default language. Otherwise, the caller will not hear anything when
the prompts are supposed to be playing.

 15. To quick add a custom prompt, afterGreeting Prompts, click theV button and select Quick Add
Prompt.

 16. Navigate to the wave file.
 17. To add a variable to a prompt, afterGreeting Prompts, click theV button and select Add Variable to

Prompt.
The Add Variable to Prompt dialog box opens.

 18. Select the variable name and click OK.
 19. To add a new variable to a prompt, in the Add Variable to Prompt pane, click theAdd button.

The Variables pane opens.
 20. AfterName, type the name of the variable.
 21. AfterDescription, type a description for the variable.
 22. AfterVariable Type, select a type from the drop-down list.
 23. To clear a prompt, afterConfirm Input, click theV button and select Clear Prompt.
 24. To enable agents to receive variable information on their toasters, select theSend to Agent’s toaster

check box.
 25. AfterDisplay Name, type the screen pop name that appears on the agent’s toaster.
 26. Click Save.
 27. On the ribbon, click Save.

Previewing prompts in Play activities
To preview a prompt in a Play activity
 1. Right-click the Play activity and select Play Prompt.

The Play recordings dialog box opens.
 2. Click thePlay button to listen to the prompt.
 3. If you are satisfied with the prompt, close the Play recordings window.
 4. If you are not satisfied with the prompt, close the Play recordings window, right-click the prompt and

select Clear prompt.
 5. To add a different prompt, follow the steps under "Adding prompts to Play activities" on page 507.
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Configuring the Query activity
TheQuery activity enables IVR Routing to read and write information through aMS SQL connection, Excel
sheet, LDAP provider, or through anODBC connection. You can use theQuery activity to retrieve information
and store this information in custom variables for use within the call flow. For example, Query activities enable
IVR Routing to retrieve a customer’s call history from a database and provide this information to agents.
Advanced query activities enable a single query to returnmultiple records of information, which can be stored
inmultiple variables. For example, you can use theQuery activity to retrieve customer account balances for
the past year. Callers can then have their account history read back to them from within the call flow. You can
configure the data providers for Query activities, configure simple or advanced queries, and define simple or
advanced write statements for Query activities. TheQuery activity is available in Voice, RAD, Outbound, and
Management call flows.

NOTE:
l The query result is stored within the <<LastQueryResult>> system variable. Each subsequent Query

action overwrites this variable.
l Advanced queries require users to have knowledge of SQL. Advanced queries support LDAP syntax

and advanced queries for MS SQLServer andODBC data providers support stored procedures.
l Formore information on configuring data providers, see "Configuring data providers" on page 473.
l For general information on working with activities including adding, deleting, and editing activities, see

"Configuring common activity options" on page 485.

Assigning data providers to Query activities
To assign a data provider to a Query activity

 1. In the Call flows Canvas, select the Query activity.
 2. In the Properties pane, afterData Provider, click the… button.

The Select Connection window opens.
NOTE: To configure data providers, see "Configuring data providers" on page 473.

 3. Select the data provider for the query and click OK.
NOTE: To create a data provider for the Query, including an Excel worksheet, SQL server, or LDAP
provider, see "Configuring data providers" on page 473.

Configuring Query activities with simple queries
To configure aQuery activity with a simple query
 1. In the Properties pane, afterSelect query, click the… button.

The Database Lookup dialog box appears.
 2. UnderQuery Type, select Simple Query.
 3. AfterDatabase Table Name, from the drop-down list, select the table you want to query.

“Database table names” refer to the tables in the data source from which the Query activity will retrieve
information.

 4. AfterColumn Return Name, from the drop-down list, select the column of data you want to query.
“Column return names” refer to the columns in the selected table, from which the Query activity will
retrieve information.

 5. AfterVariable Return Name, from the drop-down list, select the variable to populate with the return
value.
“Variable return names” refer to the call variables that will be populated as a result of the query.
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 6. AfterColumn Where Name, from the drop-down list, select the name of the column of data to compare
against.
“Columnwhere names” refer to the columns in the data source against which the Query activity will
compare information.

 7. AfterVariable Where Name, from the drop-down list, select the variable to use for comparison.
“Variable where names” refer to the call variables that the Query activity will compare against.

 8. To enable the activity to convert digits into text values, select theDialpad Compare checkbox.
For example, if a caller is trying to reach an employee’s telephone extension, dialpad compare enables
the caller to enter the letters of the employee’s name into their dialpad instead of entering an extension
number.

 9. To test your query, after Test with a value equal to, enter a value from the data provider that you know
exists and click Test Query.
The Raw SQLwindow will display the SQL statement based on your selections from the drop-down
lists. If a record is found, the result displays. If no record is found, “Result not found” displays.

 10. To clear all fields and return to the Canvas, click Clear.
 11. If you are satisfied with the query, click OK.
 12. To enable reporting, in the Properties pane, select theReportable check box.

Configuring Query activities with advanced queries
Advanced queries allow users with knowledge of SQL to write SQL statements retrieving information from a
database provider. Advanced queries also support LDAP syntax for LDAP data providers.You can use an
advanced query to retrieve single or multiple records from a database provider.

To configure aQuery activity with an advanced query
 1. In the Properties pane, afterSelect query, click the… button.

The Database Lookup dialog box opens.
 2. UnderQuery Type, select Advanced Query.
 3. UnderQuery, type the SQL statements to be run directly against the data provider and click Execute.

The Execute window opens displaying a list of detected input and output parameters.
 4. UnderValue, type the numbers corresponding to the values contained in the data provider.
 5. To enable the activity to convert digits into text values, select theUse Dialpad Compare check box.
 6. Click Run.
 7. To assign variables to store information returned by the SQL statements, click theVariable

Assignment tab.
Return Columnwill be populated with the column names in the data provider.

 8. UnderVariable Name, select the variables to store information returned by the SQL statements.
 9. To assign values to the parameters filled by the SQL statements, click theParameter Assignment tab.

Parameter Namewill be populated with the SQL parameters used to query the data provider.
 10. AfterVariable Name, select a variable from the drop-down list to store the information retrieved by the

SQL parameter.
 11. To translate parameters from a dial-pad digit, select theDialpad checkbox.
 12. To view the values returned from the query, click the Test Results tab.
 13. To clear the variables and their parameters, click Clear.
 14. Click OK.
 15. To enable reporting, in the Properties pane, select theReportable check box.
 16. On the ribbon, click Save.
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Defining write statements
Write statements define a delete, insert, or update statement against a specified data provider. Write
statements enable you to delete, insert, or update column values in a data provider from within the call flow.
You can configure Query activities with simple or advanced write statements. Advanced write statements
enable users with knowledge of SQL to write insert, update, or delete SQL statements.

NOTE:You cannot use a “delete” write statement against an Excel data provider.

To define a simple write statement
 1. Select the Query activity.
 2. In the Properties pane, afterWrite statement, click the… button.

The DatabaseWrite dialog box opens.
 3. To define a simple write statement, select Simple Write.
 4. AfterWrite Type, select one of the following write types from the drop-down list:

l Delete
l Insert
l Update

NOTE:Delete is not an option for Excel data providers.
 5. After Table Name, from the drop-down list, select the table in the data provider against which the write

statement will be defined.
 6. UnderColumn Name, select a column in the data provider against which the write statement will be

defined.
 7. UnderValue, from the drop-down list, select the data you want to be inserted into your Excel or SQL

data provider.
For example, if you have a ColumnName of “phone number”, you can select “Digits” from the drop-
down list. This will insert phone number digits into your data provider.

 8. UnderWhere from the drop-down list, select a column name.
NOTE:

l “Where” statements appear only if you have selected Delete or Update.
l The column names that appear in the drop-down list derive from the Table Name you

selected.
 9. Select an one of the following operators from the drop-down list:

l = Equal to
l <> Not equal to
l > Greater than
l < Less than
l > = Greater than or equal to
l < = Less than or equal to

 10. From the third drop-down list, select or type the variables used to evaluate the information selected from
the first column.

 11. To test the write statement, underUtilities, click the Test Syntax button.
If the test is successful, “Syntax is valid” displays.
If the test is unsuccessful, “Syntax is invalid” displays.

 12. To empty column values, click Clear.
 13. Click OK.
 14. On the ribbon, click Save.
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To define an advanced write statement
 1. In the Properties pane, afterWrite statement, click the… button.

The DatabaseWrite dialog box opens.
 2. UnderWrite Type, click theAdvanced Write button.
 3. UnderQuery, type the insert, update, or delete SQL statements to be run against the data provider.
 4. Click Execute.

TheParameter Name columnwill be populated with the column names in the data provider.
 5. UnderVariable Name, from the drop-down list, select the variables used to evaluate the information

you selected from the first column.
 6. To test the write statement, underUtilities, click the Test Syntax button.

If the test is successful, “Syntax is valid” displays.
If the test is unsuccessful, “Syntax is invalid” displays.

 7. To empty column values, click Clear.
 8. Click OK.
 9. On the ribbon, click Save.

Dynamic prompting with the Query activity
Dynamic prompting leverages the Query activity to createmore flexible and specific prompting for your
contact center. A dynamic prompt is created by building a query that retrieves a file path to an audio file based
on information from either the call or collected earlier in the call flow. The file path is stored in a variable and a
Play activity after the Query activity is configured to play the file path-carrying variable.

To configure dynamic prompts in a call flow, youmust have:
l A data provider that contains .wav network file paths

NOTE: It is recommended that the .wav file path be a network file path (UNC) in case the engine does
not have direct access to the file directory.

l A Query activity configured to hold a .wav network file path in a variable
l A Play activity in a call flow configured to play the file path-holding variable

Dynamic prompting in a call flow can be configured using additional activities, such as Collect Digits, that
may provide variables to Query against to help determine which .wav file to play, so long as the Query activity
fills a variable with a .wav network file path as a result of the query.

For specific examples of how to create and configure dynamic prompting, see the prairieFyre Knowledge
Base.

Returning multiple results with queries
TheQuery activity supports returningmultiple results from a query. When aQuery activity returns multiple
results from a query, the call is looped through the Success branch for each result unless it is interrupted by a
caller-activated activity, such as Goto or Transfer. When there are nomore results for the Success branch to
loop, the call exits the Success branch of the Query activity and continues along the call flow.

Multiple result returning Query activities enable contact centers to build more complex call flow functions,
such as providing callers access to an employee directory. In Figure 17 - 7, we see an example where the
enclosed numbers indicate the consecutive steps of amultiple result-returning call flow for an employee
directory.
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Figure 17 - 7 Multiple result-returning query example call flow

In Figure 17 - 7, the employee directory call flow works as follows for returningmultiple results:
 1. The Collect digits activity collects the first three letters of an employee’s name as entered by a caller.

This is filled into a variable.
 2. In the Query activity, a database with employee names, extensions, and a .wav file that plays the

employee’s name is queried with the variable. The query fills twomore variables: one with the UNC file
path to the .wav file playing the employee’s name and the other with that employee’s extension.

 3. The UNC file path variable is used as a dynamic prompt with the Play activity in the Success branch of
the Query, playing to the caller the name of the first returned result.

 4. Themenu’s instruction prompt then asks the caller to dial 1 if that is the employee they are looking to call
or dial 2 if they would like to hear the next result.

 5. If the caller dials 1, they are taken to the Transfer activity, which uses the extension variable filled by the
Query to transfer the caller to the desired extension.

 6. If the caller dials 2, they proceed to the end of the Success branch, which then loops oncemore with the
next result of the query.

Configuring the Queue activity
TheQueue activity branches call flows to queue groups based on real-time queue conditions. For example,
you can configure aQueue activity to check queue conditions and offer a callback plan to callers experiencing
long wait times. TheQueue activity can help to lessen abandoned calls andmanage Service Level objectives
by routing calls based on emerging queue conditions. You can add and edit branching conditions for queue
activities and group queue conditions to determine how IVR Routing directs callers through the call flow. The
Queue activity is available in Voice, RAD, andOutbound call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.
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Adding and editing branching conditions for Queue activities
Adding branching conditions to the Queue activity determines the real-time conditions that send a call to an
associated action in the call flow.

NOTE:
l The actions that IVR Routing takes when queue conditions aremet are determined by activities you

insert into theDrop Activities Here section of the Call flows Canvas for that Queue condition.
l The call flow evaluates Queue conditions from left to right. For information on how to change the order

of Queue conditions, see "Changing the order of branches" on page 486.

To add and edit a branching condition for a Queue activity
 1. In the Call flows Canvas, right-click the Queue activity and select Add a queue condition.

TheQueue Conditions dialog box opens.
 2. AfterQueue Condition Name, type a name for the queue condition.
 3. AfterSelect a queue or queue group, click the… button.

The Select a queue or queue group dialog box appears.
 4. Select either theQueue or theQueue Group tab.
 5. Select a queue or queue group to add to the condition and click OK.
 6. To add a new queue, see "Configuring queues" on page 445.

NOTE:
l To configure a new queue for web callbacks, see "Enabling callbacks" on page 462.
l To configure a new queue for UPiQ, see "Configuring UPiQ options" on page 448.

 7. To add a new queue group, select theQueue Group pane and click Add.
TheQueue groups pane opens.

 8. AfterName, type a name for the queue group.
 9. AfterReporting number, type a reporting number for the queue group.
 10. Tomake the queue group virtual, enable theVirtual Queue check box.

NOTE:Use virtual queues for assigning the same pool of agents to answer the ACD calls for multiple
queues across multiple telephone switches.

 11. In the Available members pane, select a queue group and click the > button.
 12. Click Save.
 13. To add conditions that must bemet before the Queue activity proceeds to an associated action in the

call flow, at the top of the Queue Conditions dialog box, click Add.
 14. In the first column, select one of the following real-time statistics from the drop-down list:

l Agents Idle
l Agents Available
l Agent Unavailable
l AvgTimeToAbandon
l AvgTimeToAnswer
l Call Load
l ExpectedWait Time
l Last Queue Update Received
l Longest Wait Time
l Number of Calls Waiting
l Path DND
l Service Level
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 15. In the second column, select one of the following operators from the drop-down list:
l ! = Not Equal to
l < Less than
l <= Equal to or less than
l = Equal to
l > Greater than
l >= Equal to or greater than

NOTE:Operators appearing in the drop-down list vary according to the variable selected.
 16. In the third column, from the drop-down list select either theValue, Queue Stats, or theCall variable

tab.
 17. UnderValue, type in a numeric value or enable the check box for the value.
 18. UnderQueue Stats, select a queue stat from the drop-down list.
 19. UnderCall variable, select a call variable from the drop-down list.
 20. Click OK.
 21. If you want to add another condition, at the top of the dialog box, click Add.
 22. Repeat steps 13-20 for each additional condition to add to the Queue.
 23. To import queue conditions, click the Import button and navigate to a *.csv file.
 24. To export queue conditions, click theExport button and navigate to a *.csv file.

NOTE:
l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.

 25. To test the conditions, under Test Parameters, enter a value in the relevant fields and click Test.
If the test is successful, “Pass” displays beneath the Test button.
If the test is not successful, “Fail” displays beneath the Test button.

 26. To enable reporting for the branch, select theEnable reporting for this Branch check box.
 27. To delete a queue condition, from the drop-down list to the left of the condition select Delete.
 28. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the

dialog box open to create a new branch.
 29. To edit queue conditions, on the Call flows Canvas right-click the branch and select Edit queue

condition.
 30. On the ribbon, click Save.

Grouping queue conditions in Queue activities
You can group conditions in Queue activities using the “Group AND” or “GroupOR” buttons in the Queue
Conditions dialog box. Grouping conditions by “Group AND”means that every queue condition specifiedmust
bemet to route the call to the Success branch. Grouping conditions by “GroupOR”means that one of the
queue conditions specified needs to bemet to route the call to the Success branch.

NOTE:
l The "Group AND" and "GroupOR" buttons will be disabled unless you have at least two conditions to

group.
l “Group AND” is the default grouping setting for the Queue activity.

To group queue conditions in a Queue activity
 1. Right-click the Queue activity and select Add a queue condition.
 2. Select the conditions to group and click theGroup AND orGroup OR buttons.

NOTE: To groupmultiple rows, press Ctrl and click to the right of the third column for each row you
want to group.

 3. To add a condition to an existing group, from the drop-down list to the left of And orOr, select Add.
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 4. To ungroup a group of conditions, from the drop-down list to the left of And orOr, select Ungroup.
 5. To remove one condition from a group, from the drop-down list to the left of the condition row, select

Ungroup.
 6. Click OK to create the branch, or click Add to add the current branch and create a new branch.
 7. On the ribbon, click Save.

Configuring the Record activity
The Record activity enables authorized callers, such as managers or supervisors, to record a wave file over
the phone as opposed to using amicrophone in a computer. For example, amanager can call into IVR Routing
from home and use the Record activity to record a wave file to populate a custom prompt for Play activities.
The Record activity increases the flexibility with which you can create custom prompts for your call flow and
respond to after-hours conditions affecting the call center’s operations. You can configure Record activities
with prompts to determine themessage an authorized caller hears when they dial the IVR Routing system,
and set the number of seconds they have to record amessage. You can also preview the prompt that will play
to authorized individuals. The Record activity is available in Voice andManagement call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring Record activities with prompts
To configure a Record activity with a prompt
 1. In the Call flows Canvas, select the Record activity.
 2. In the Properties pane, after Timeout (sec), type a number from 1 to 60 to set the number of seconds

before the activity closes.
 3. To configure a prompt with recording instructions, after Instructions, click theV button and follow the

steps under "Adding prompts to Play activities" on page 507.
NOTE: “Instructions” plays recording instructions to authorized callers.

 4. To remove a date and time stamp from the wave file name, deselect theAppend date time stamp
check box.

 5. After Output name, type the file name for the wave file.
NOTE:The output namemust be a valid file name but may contain call variables enclosed between
double angle brackets. For example: <<ANI>>. The text between the angle brackets will be replaced
with the value of the variable currently executing in the call flow.

 6. AfterRecording Timeout, type the number of seconds that an authorized caller has to record a
message.

 7. On the ribbon, click Save.

Previewing prompts in Record activities
See "Previewing prompts in Play activities" on page 508.
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Configuring the Redirect activity
The Redirect activity branches call flows based off a redirect value received in a call record and the number of
the device from which the call was redirected. The Redirect activity provides an additional means of branching
call flows so that calls can reach the appropriate queue. You can add branching conditions to Redirect
activities to determine how IVR Routing directs callers through the call flow. The Redirect activity is available
in Voice andManagement call flows.

NOTE:
l Redirects are achieved using the telephone system’s HCIRedirect or Name Tag hunt groups.
l For general information on working with activities including adding, deleting, and editing activities, see

"Configuring common activity options" on page 485.

Adding branching conditions to Redirect activities
To add a branching condition to a Redirect activity
 1. In the Call flows Canvas, right-click the Redirect activity and select Add a redirection condition.

The Redirect dialog box opens.
 2. To add a Redirect value, at the top of the dialog box, click Add and type the value or range of values for

the Redirect condition.
 3. Click theAdd icon.
 4. To import Redirect conditions in .csv format, click Import and navigate to the file name.
 5. To export Redirect conditions, click Export and navigate to the file name.

NOTE:
l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.

 6. To addmore Redirect conditions, at the top of the dialog box, click Add.
 7. To enable reporting for the branch, select theEnable reporting for this Branch check box.
 8. To test the Redirect conditions, underUtilities, enter a value or range of values.

If the test is successful, “Pass” displays.
If the test is unsuccessful, “Fail” displays.

 9. Click OK to create the branch, or click Add to add the current branch to the call flow while leaving the
dialog box open to create new branches.

 10. On the ribbon, click Save.
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Configuring the Rules activity
The Rules activity enables call flows to be branched according tomultiple conditions, or routing rules, nested
within a single activity. When an incoming call enters a call flow and encounters a Rules activity, the call is
evaluated against the activity’s preconfigured routing rules. Calls will be directed through the call flow based
on whether the call meets the activity’s routing rules. If a call meets the activity’s routing rules, it is routed to
the Success branch and the activity will populate variables for the call based on pre-configured options in the
rule. These variable values will determine the queue to which the call is directed. For example, you can assign
a rule to a Rules activity that specifies the hours of operation and the ANI condition for a French-language
queue. If a call enters IVR Routing andmatches the ANI of a French-speaking region during the French
queue’s hours of operation, that call will have an ANI variable populated with the French area code and will be
routed to the appropriate branch. You can assign and edit rules for Rules activities to determine how IVR
Routing directs callers through the call flow. The Rules activity is available in Voice, RAD, Management, and
Outbound call flows.

NOTE:
l Before creating a Success branch, configure a rule that will contain the conditions for a successful

match. For information on rules and configuring rules, see "Configuring rules" on page 469.
l If the call is evaluated against multiple routing rules, first routing rule to bematched will set the variable

values.
l For general information on working with activities including adding, deleting, and editing activities, see

"Configuring common activity options" on page 485.

Adding and editing rules for Rules activities
To assign a rule to a Rules activity:
 1. In the Call flows Canvas, right-click the Rules activity and select Configure Rules.

The Rules dialog box opens.
 2. From theAvailable members pane, select the rule to assign to the Rule activity and click the > button.
 3. Click OK.

NOTE:
l Rules are evaluated in the order they appear in the selected list. IVR Routing will evaluate all

rules in order to find amatch. It will not stop at the first match.
l You can only configure one Success branch per Rules activity.

 4. To edit a rule assigned to a Rules activity, right-click the activity and select Configure Rules.
 5. Change the rule assigned to the branch.
 6. To enable reporting for this branch, in the Properties pane, select theReportable check box.
 7. Click OK.
 8. On the ribbon, click Save.
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Configuring the Schedule activity
The Schedule activity branches call flows based on date and time conditions, enabling a call flow to respond
to a contact center’s business hours and holiday closures. For example, you can use the Schedule activity to
route customers calling after hours to an after-hours voicemail andmenu. The Schedule activity reduces call
flow clutter by providing “Open” and “Closed” branching conditions within a single call flow. You can add time,
day of the week, holiday, and other date conditions to Schedule activities to determine how IVR Routing
directs callers through the call flow. The Schedule activity is available in Voice, RAD, Outbound, and
Management call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Adding and modifying time and day of the week conditions for Schedule
activities
Adding time and day of week conditions to a Schedule activity specifies when calls are routed to queues
based on a call center’s business hours.

To add or modify a time and day of the week condition for a Schedule activity
 1. In the Call flows Canvas, right-click the Schedule activity and select Add a schedule condition.

The Schedule Dialog box opens.
 2. AfterName, type the name of the schedule condition.
 3. At the top of the dialog box, click Add and select Time from the first drop-down list.
 4. Using the second drop-down list, type your contact center’s Start time (hh/mm/ss) andEnd Time

(hh/mm/ss) and click OK.
 5. To addmore time conditions follow steps 3-4.
 6. To add a day of the week condition, at the top of the dialog box, click Add and select DOW from the first

drop-down list.
 7. Under <Value>, specify the days of the week your contact center is open by selecting the checkboxes

for those days, and click OK.
 8. To addmore Day of theWeek conditions follow steps 6-7.
 9. To import schedule conditions, click the Import button and navigate to a *.csv file.
 10. To export schedule conditions, click theExport button and navigate to a *.csv file.

NOTE:
l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.

 11. To test the conditions, underUtilities, enter time and date information and click Test.
If the test is successful, Pass will appear beside the Test button.
If the test is not successful, Fail will appear beside the Test button.

 12. To enable reporting, select theEnable reporting for this Branch check box.
 13. To delete a queue condition, from the drop-down list to the left of the condition, select Delete.
 14. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the

dialog box open to create new branches.
 15. To edit schedule conditions, on the Call flows Canvas, right-click the branch and select Edit schedule

condition.
 16. On the ribbon, click Save.
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Adding and modifying date or holiday conditions for Schedule activities
Adding date and holiday conditions to a Schedule activity specifies when calls are routed to a branch designed
to handle calls then the contact center is closed. Use date conditions to specify exceptional days your contact
center is closed. Add holiday conditions to specify Holiday closures.

To add andmodify a date or holiday condition for a Schedule activity
 1. Right-click the Schedule activity and select Add a schedule condition.

The Schedule Condition Designer opens.
 2. AfterName, type the name of the schedule condition.
 3. At the top of the dialog box, click Add and select Date from the first drop-down list.
 4. Using the second drop-down list, specify the date the contact center is closed and click OK.

If your contact center is regularly closed on this date, enable theReoccur every year checkbox.
 5. To addmore dates the contact center is closed, follow steps 3-4.
 6. To add a holiday condition, click theAdd button and select Holiday from the first drop-down list.
 7. After <Select a holiday>, select the check box beside the holiday and click OK.
 8. To addmore holidays follow steps 6-7.
 9. To import schedule conditions, click the Import button and navigate to a *.csv file.
 10. To export schedule conditions, click theExport button and navigate to a *.csv file.

NOTE:
l Conditions on a single line and separated by a commawill be added to a single branch.
l Conditions onmultiple lines and separated by a commawill be added tomultiple branches.

 11. To test the conditions, underUtilities, enter the dates and click Test.
If the test is successful, Pass will appear beside the Test button.
If the test is not successful, Fail will appear beside the Test button.

 12. To enable reporting, select theEnable reporting for this Branch check box.
 13. To delete a queue condition, from the drop-down list to the left of the condition select Delete.
 14. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the

dialog box open to create new branches.
 15. To edit schedule conditions, on the Call flows Canvas, right-click the branch and select Edit Schedule.
 16. On the ribbon, click Save.

Grouping schedule conditions in Schedule activities
You can group conditions in Schedule activities using the “Group AND” or “GroupOR” buttons in the Schedule
Condition Designer. Grouping conditions by “Group AND”means that every queue condition specifiedmust
bemet to route the call to the Success branch. Grouping conditions by “GroupOR”means that only one of the
queue conditions specifiedmust bemet to route the call to the Success branch.

NOTE:
l The “Group AND” and “GroupOR” buttons will be disabled unless you have at least two conditions to

group.
l “Group AND” is the default grouping for the Schedule activity.

To group conditions in a Schedule activity
 1. Right-click the Schedule activity and select Add a schedule condition.
 2. Select the conditions to group and click theGroup AND orGroup OR buttons.

NOTE: To groupmultiple rows, press Ctrl and click to the right of the second column for each row.
 3. To add a condition to an existing group, from the drop-down list to the left of And orOr, select Add.
 4. To ungroup a group of conditions, from the drop-down list to the left of And orOr, select Ungroup.
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 5. To remove one condition from a group, from the drop-down list to the left of the condition row, select
Ungroup.

 6. Click OK to create the branch or click Add to add the current branch to the call flow while leaving the
dialog box open to create new branches.

 7. On the ribbon, click Save.

Configuring the Set Device Mode of Operation activity
The Set DeviceMode of Operation activity changes themode of operation for a specific device from Normal
to Emergency or vice-versa. These devices include

l Hunt Groups
l Extensions

For example, if only one of the IVR Routing’s extensions is experiencing emergency conditions, you can use
the Set DeviceMode of Operation to put that port into Emergency mode without affecting the entire system’s
operations. The Set DeviceMode of Operations activity is available in Management call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring properties for Set Device Mode of Operation activities
To configure the properties for a Set DeviceMode of Operation activity
 1. In the Call flows Canvas, select the Set DeviceMode of Operation activity.
 2. In the Properties pane, afterDevice Type, select a device type from the drop-down list.

NOTE:
l Device type refers to the type of device checked when searching a dialable number.
l Dialable number refers to the digit or series of digits a caller dials to reach an agent at an

extension.
 3. To set the call variable containing the device dialable number, after Input Variable, click the… button.

The Select a variable dialog box opens.
 4. Select an input variable and click OK.
 5. AfterMode of operation, select eitherNormal orEmergency from the drop-down list.
 6. To enable reporting on the activity or a branch, select the activity or branch and select theReportable

check box.
 7. On the ribbon, click Save.

Configuring the Set System Mode of Operation activity
The Set SystemMode of Operation activity changes themode of operation for IVR Routing from Normal to
Emergency and vice-versa. For example, if the contact center is closed due to weather you can use the Set
SystemMode of Operation Activity to change IVR Routing to Emergency mode and route all call flows in
accordance with an emergency plan. The Set SystemMode of Operation activity is available in Management
call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.
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Configuring properties for Set System Mode of Operation activities
To configure properties for a Set SystemMode of Operation activity
 1. In the Call flows Canvas, select the Set SystemMode of Operation activity.
 2. In the Properties pane, afterMode of Operation, select eitherNormal orEmergency from the drop-

down list.
 3. To enable reporting on the activity or a branch, select the activity or branch and select theReportable

check box.
 4. On the ribbon, click Save.

Configuring the Set Variables activity
The Set Variables activity enables IVR Routing to take values generated within a call flow or static,
predefined values and use them to populate variables for use later in the same call flow. For example, you can
use the Set Variables activity to populate a variable with a caller’s choice of service language. IVR Routing
can use this information later in the call flow to direct callers to a queue with service in the appropriate
language. You can determine the variables to be populated in Set Variables activities. The Set Variables
activity is available in Voice, RAD, Outbound, andManagement call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Populating variables in Set Variables activities
To populate a variable in a Set Variables activity
 1. In the Call flows Canvas, right-click the Set Variables activity and select Set Variables.

The Set Variables dialog box opens.
 2. AfterName, type a name for the activity.
 3. Click Add to add a new variable to be populated.
 4. In the first column, select a variable from the drop-down list and click OK.
 5. In the second column, type a value or select a value from one of the tabs in the drop-down list.

NOTE: Tabs appearing in the second column vary based on the variable you select in the first column.
 6. Click OK.
 7. To add a new variable row, at the top of the dialog box, click Add.
 8. To delete a row, from the drop-down list to the left of the variable row, select Delete.
 9. Click OK.
 10. On the ribbon, click Save.

Configuring the Subroutine activity
The Subroutine activity represents a set of call flow steps that IVR Routing presents to a caller. You can use
the Subroutine activity to reuse portions of call flows across multiple call flows. For example, if a call flow has
multiple DNIS activities, you can use a Subroutine activity to present the samemenu through each DNIS
activity. Making changes to the Subroutine activity will change all DNIS conditions, enabling you to present
the samemenu through different conditions using a single point of administration. You can assign IVR
Routing’s default management subroutine to the activity, or build a subroutine to assign to the activity. The
Subroutine activity is available in Voice, Management, andOutbound call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.
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Assigning subroutines to Subroutine activities
IVR Routing provides a default management subroutine. To build other subroutines see "Building subroutines"
on page 458.

To assign a subroutine to a Subroutine activity
 1. In the Call flows Canvas, select theManagement activity.
 2. In the Properties pane, afterSubroutine, click the… button.

The Select a subroutine or variable window opens.
 3. To assign a subroutine, click theSubroutines tab and select a subroutine to assign to the activity.
 4. To assign a call variable, click theVariables tab and select a call variable to assign to the activity.
 5. To create a new call variable, under theCall variable tab, click theAdd button and follow the

corresponding steps in "Adding new devices toMake Call destinations" on page 503.
 6. Click OK.
 7. In the Properties pane, from the drop-down list afterActivity, select the activity to which the Goto

returns callers.
NOTE:You can only select a Goto activity if the Subroutine activity is nested within another activity.
For more information, see "Configuring the Goto activity" on page 499.

 8. Select theReset Repeat Count check box to give callers an unlimited number of attempts to enter
information.

 9. On the ribbon, click Save.

Configuring the Swap Prompt activity
The Swap Prompt activity enables you to swap the contents of one prompt with the contents of another
prompt in IVR Routing. For example, if an emergency greeting informs customers that the contact center is
closed due to bad weather, in the event of an earthquake you can use Swap Prompt to change the contents of
the emergency greeting. The Swap Prompt activity enables you to provide specialized prompts within a single
call flow without inserting additional activities. You can set the prompts to be exchanged in Swap Prompt
activities from existing prompts in IVR Routing or from prompts that you create. The Swap Prompt activity is
available in Management call flows.

NOTE:
l If you have switched the contents of one prompt with another, youmay eventually need to switch the

contents of prompts back again.
l For general information on working with activities including adding, deleting, and editing activities, see

"Configuring common activity options" on page 485.

Setting prompts to be exchanged in Swap Prompt activities
To set the prompts to be exchanged in a Swap Prompt activity
 1. In the Call flows Canvas, select the Swap Prompt activity.
 2. In the Properties pane, afterSource Prompt, click the… button.

The Select a prompt dialog box opens.
NOTE: The source prompt is the prompt that will be used to replace the target prompt.

 3. Select a prompt and click OK.
 4. After Target prompt, click the… button.

NOTE: The target prompt is the prompt that will be swapped with the source prompt.
 5. Select a prompt and click OK.
 6. To add a source or target prompt, click theAdd button and follow the steps under "Adding prompts to

Play activities" on page 507.
 7. On the ribbon, click Save.
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Configuring the Transfer activity
The Transfer activity transfers a caller to a specified endpoint, enabling you to send callers to a queue, queue
group, call variable, or other specified destination. For example, you can use a Transfer activity to route calls
across queues. You can configure the options for how and where a call is transferred, and add new devices to
Transfer activities. Transfer activity is available in Voice andOutbound call flows.

NOTE: For general information on working with activities including adding, deleting, and editing activities, see
"Configuring common activity options" on page 485.

Configuring options and adding devices to Transfer activities
To configure options and add devices to a Transfer activity
 1. In the Call flows Canvas, select the Transfer activity
 2. To instruct the activity to hold calls transferred to busy lines, in the Properties Pane, select theCamp

On Busy check box.
 3. AfterDestination, click the… button.
 4. The Select a device dialog box appears.
 5. Select a destination from one of the following tabs and click OK.

l Extension
l Queue
l QueueGroup
l Call Variable

 6. To add a new device, click Add.
 7. To add an extension, follow the corresponding steps in "Adding extensions" on page 440.
 8. To add a new queue, follow the corresponding steps in "Configuring queues" on page 445.

NOTE:
l To configure a new queue for web callbacks, see "Enabling callbacks" on page 462.
l To configure a new queue for UPiQ, see"Configuring UPiQ options" on page 448.

 9. To add a new queue group, follow the corresponding steps in "Adding and editing branching conditions
for Queue activities" on page 514.

 10. To add a call variable, follow the corresponding steps in "Adding new devices toMake Call destinations"
on page 503.

 11. To append outbound calls with a prefix digit, select theExternal Transfer check box.
The prefix digits appended to external transfers are defined on themedia server.

 12. After Transfer Type, select Blind orSupervised from the drop-down list.
NOTE:Blind transfers immediately transfer calls, freeing the port for a new call. Supervised transfers
mean the call is kept on hold while being transferred. Callers cannot hear the phone ringing during the
transfer unless the transfer time exceeds the timeout.

 13. To set the duration that a call is put on hold during a transfer, after Timeout (sec), type the number of
seconds allotted for the transfer.

 14. To enable reporting, select theReportable check box.
 15. On the ribbon, click Save.
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IVR Routing call flow samples
Version 6.0.2 includes a variety of sample call flows. These call flow samples are based on common business
scenarios. They not only demonstrate how IVR Routing can be used to efficiently direct calls to appropriate
queues but, because they can be imported directly into your IVR Routing application, they save you the time
of creating your own introductory call flows.

The sample call flows create a basis upon which you add elements to fully customize your IVR Routing
solution. For example, if you want to be able to access a database of customer phone numbers, you will need
to create the database andmake it available to your call flow. Each sample call flow description below
includes recommendations for call flow configuration optimization.

Generic prompt messages are included for applicable call flow samples.

Version 6.0.2 gives you access to the following five sample call flows:
l Schedule with Mode of Operation andMenu
l ANI and DNIS condition with uniquemenus and a callback option
l Schedule condition followed by DNIS and Language with menus
l Management Plan call flow
l Outbound call flow with Excel

Each sample call flow contains Menu activities. TheMenu activity prompts callers with messages and
manages routing based on caller input. Besides the options you configure and add in theMenu, there are three
default branches included in all Menu activities: Timeout, Invalid, and Failure. These branches cannot be
deleted and function as follows:

l Timeout:Calls are routed to this option if the caller does not respond to a request within the time limit
allowed, as configured for theMainMenu in the Properties pane, under Options. A default timeout
message plays and the caller is returned to theMainMenu. You configure the number of times the call
is returned to theMainMenu, after failing to respond to a request within the set time limit. If the caller
exceeds the number of attempts, the call proceeds to the Failure branch.

l Invalid: This branch works similarly to the Timeout branch except that it channels callers that have
entered invalid response digits. There is a default Invalid numbermessage that plays.

l Failure:Calls are routed to this branch if themaximum Timeout or Invalid attempts are reached. Calls
that enter the Failure branch are, in most samples, transferred to the Operator. If the Operator is
unavailable, the call proceeds to the Hang up activity. If you want amessage to play in this branch, you
must configure and add one.

NOTE:After importing the sample call flows and assigning them to ports they will be “live” in your system.
Any modifications to the call flows will affect your IVR Routing system. For example, if you put a port into
Emergency Mode using the SampleManagement Plan call flow that port will indeed go into Emergency Mode.
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Importing IVR Routing sample call flows
In order to have access to the sample call flows youmust import them from the folder in which they are stored
when you download our software.

To import IVR Routing sample call flows
 1. In YourSite Explorer, click Visual Workflow Manager=>Call flows.

The Call flows pane opens.
 2. Click the Import button.

The Select a .xoml file window opens.
 3. Navigate to the .xoml file you want to import and click Open.

NOTE: The sample call flows are located in C:\Program Files\prairieFyre Software
Inc\CCM\Ivr\Sample Callflows.

 4. On the ribbon, click Save.

NOTE:
l After importing a call flow, youmust configure your own prompts and connect the call flow to devices

that are specific to your system. If the prompts you configure or the connections youmake to devices
are invalid, a red exclamationmark icon displays on the Call Flows Canvas indicating a validation error.
Selecting the relevant activity and clicking the exclamationmark icon indicates the specific errors you
must correct.

l Youmust associate a completed call flow to extensions or hunt groups in order to make them go "live"
in your system. For more information see "Associating call flows to extensions or hunt groups" on page
454.

l When you initially load the sample call flows, you will see red exclamationmark icons indicating where
youmust correct validation errors. Each sample call flow description explains what youmust configure
in order to correct the validation error and save the call flow.

Associating sample call flows to extensions or hunt groups
After you import a sample IVR Routing call flow, youmust associate it to extensions or hunt groups in order to
make the call flow go "live" in your system. For more information, see "Associating call flows to extensions or
hunt groups" on page 454.

Sample Schedule with Mode of Operation and Menu
This call flow instructs IVR Routing to direct calls that arrive during business hours, in normal conditions, to
the appropriate queues based on the caller’s selection of menu options. Calls arriving during business hours
when the contact center is closed due to emergency conditions are routed to an Emergency branch where
they hear an emergency message explaining why the contact center is closed. Calls arriving outside business
hours are routed to a Closed branch where they hear a prompt informing them that the contact center is
closed.

This call flow:
l Makes customers aware of business hours and channels their calls as applicable
l Enables calls to be routed during emergency closures, for example, in extremeweather conditions
l Routes callers to the appropriate queues, based on customer digit selection

Figure 17 - 8 displays this call flow as it appears when first imported.
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Figure 17 - 8 Schedule with Mode of Operation and Menu

Description
The first step in this call flow is an Answer activity. The Answer activity tells the port to answer the call. Until
this condition is met, the caller hears ringing.

Next in the call flow sequence is the Schedule condition (Mon-Fri, 9-5). There are two branches, Open and
Closed, each containing activities, within the Schedule. A check is done to confirm that the date and time of
the call falls within business hours (set as Monday – Friday, 9 AM – 5 PM).

If the call arrives outside of business hours, then the call is routed to the Closed branch, a ClosedMessage
plays, and the call proceeds to the Hang up activity. The Hang up activity ends the call flow and disconnects
the call. If you do not have a Hang up activity, the call will continue through the call flow until it reaches the
end of all possible actions, at which point it will wait in silence until the port resets.

If the call arrives within business hours, then the call is routed to the Open branch and theMode of Operation
activity is confirmed. The system checks if the ports or hunt groups assigned to the call flow are in Normal
mode or Emergency mode. If they are found to be in Emergency mode, the Emergency Message plays and
the call is directed to the Hang up activity. If they are found to be in Normal mode, the call proceeds to the
MainMenu activity.
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TheMainMenu activity prompts callers with messages andmanages routing based on caller input. In this
example, theMainMenu activity has been configured with three options and customers are prompted to press
whichever option suits their needs. IVR Routing then directs the caller to the appropriate queue based on the
number they pressed.

The three numbered options in theMainMenu activity were addedmanually to this sample call flow and
complete the following actions:

l Option 1: Transfers the caller directly to the Support Queue
l Option 2: Transfers the caller directly to the Sales Queue
l Option 3:Plays the Hours of OperationMessage

Options 1 and 2 have a Failure branch. If the transfer destination is unavailable, the caller is routed to the
Operator. We recommend you set up the Failure branch to redirect calls to a dependable, available endpoint.

The last step in this call flow is the Hang up activity. We recommend you end call flows with a Hang up
activity to prevent errant calls from resting at the end of the call flow and tying up the port until it can reset and
disconnect the call.

Additional configuration required
To get your call flow sample up and running, youmust:

l Associate the call flow to a port (extension) or a hunt group. See "Associating call flows to extensions
or hunt groups" on page 454.

l Configure Properties for Transfer Activities. In this sample, the Operator and the Sales and Support
queue destination information needs to be added. To do this, simply right-click the Transfer activity in
the call flow and specify the Destination in the Properties pane.

l Create prompts (messages) as needed. For example, in this call flow, generic prompts are included for
the GreetingMessage, ClosedMessage, Emergency Message, and Hours of OperationMessage. If
you want to customize thesemessages, you will need to create your own and add them to the call flow.

Sample ANI and DNIS condition with unique Menus and a
callback option
This call flow instructs IVR Routing to direct calls to appropriate queues based on the caller’s telephone
number (ANI), the number the caller dialed to reach the contact center (DNIS), and caller-entered responses
tomenu options. Themenu options are unique to each branch, meaning that callers are presented with
different menu options based on where their call originated or the number they dialed to reach the contact
center. In addition, the customer is offered the option of requesting a callback rather than waiting in queue for
an agent. In this example, callers are routed based on their customer status (derived from their ANI) or based
on the number they called to reach your contact center, either the Enterprise Business Level or Entry Level
Business Software contact number.
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This call flow:
l Shows you how to channel callers to queues based on the area from which they are calling. This type of

call routing could be beneficial if, for example, you have a sales promotion that is targeted toward
particular geographical markets, callers from those areas would be directed to a queue with promotional
RADs and agents who have been trained to sell products specifically related to the current promotion.
Another useful application for this call flow could be for companies who offer services that are specific
to a certain area. For example, a flooring installation company with offices in cities across the country
could direct callers based on the city from which they are calling to agents who book in-home flooring
consultations.

l Demonstrates how you can set up your IVR Routing system using ANIs to help route customers with
specific needs to the agents most suited to assist them. In this sample, a VIP customer calls in and is
recognized as such by their ANI, which you have added to the ANI list. They are automatically
transferred to an experienced agent with advanced customer relation skills.

l Allows you to send callers to queues based on the number they dialed to access your contact center.
This enables callers to bemore accurately routed to the services in which they aremost interested. In
this sample, callers are channeled to either the Enterprise Business Level or Entry Level Business
Software queue based on the number they called to reach you.

l Gives callers the option of leaving amessage and receiving a callback rather than waiting in queue.
Customer satisfaction is improved when callers are offered this enhanced level of control. In addition,
the call center operates more smoothly as some calls are diverted during busier periods to be handled
during less busy hours.

Figure 17 - 9 displays this call flow as it appears when first imported.

Figure 17 - 9 Sample ANI and DNIS Condition with unique Menus and Callback option
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Description
The first step in this call flow is an Answer activity. The Answer activity tells the port to answer the call. Until
this condition is met, the caller hears ringing.

Following the Answer activity, is an ANI condition that checks the caller’s phone number. We recommend
placing the ANI condition near the beginning of the call flow as you can use this activity to initially filter calls
based on whatever parameters work best for you, for example, you could filter based on VIP status or,
conversely, based on a list of customers with a heightened need for immediate support, such as those with a
recent history of dissatisfaction with your product. By filtering these calls based on ANI, you can configure the
subsequent call flow sequence to channel these calls to queues that are best suited to their needs.

Within the ANI condition, there are three branches that evaluate the ANI and branch the call based on the
results. In this example, the caller is branched, based on ANI, either to the Elevated Support Line branch, VIP
Customers branch, or a NoMatch branch. The Elevated Support Line branch (in this example, used for
customers that are in need of immediate, skilled support, as they are currently experiencing difficulties with
your product) and the VIP Customers branch each contain a Failure branch which routes the caller to the
Operator if the transfer destination is unavailable. We recommend you set up the Failure branch to redirect
calls to a dependable, available endpoint.

If the ANI is unrecognized (NoMatch), the systemmoves on to check the DNIS (the number the customer
called to reach the contact center).

Within the DNIS condition, there are three branches that evaluate the DNIS and branch the call based on the
results. In this example, the caller is branched, based on DNIS, either to the Enterprise Business Level Menu,
the Entry Level Business SoftwareMenu, or a NoMatch branch.

The Enterprise Business Level Menu prompts callers with messages andmanages routing based on caller
input. In this example, it has been configured with two options and customers are prompted to press
whichever option suits their needs. IVR Routing then directs the caller to the appropriate queue based on the
number they pressed.

The two numbered options in the Enterprise Business Level Menu activity were addedmanually to this
sample call flow and complete the following actions:

l Option 1: Transfers the caller directly to the Support Queue
l Option 2: Transfers the caller directly to the Sales Queue

Options 1 and 2 have a Failure branch. If the transfer destination is unavailable, the call goes to the Hang up
activity.

The Entry Level Business SoftwareMenu activity prompts callers with messages andmanages routing based
on caller input. In this example, it has been configured with two options and customers are prompted to press
whichever option suits their needs. IVR Routing then directs the caller to the appropriate queue based on the
number they pressed.
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A Queue Condition has been added to this branch to enable the callback request option. In this case, the
Queue Condition checks if more than five calls are waiting in queue and if this is the case, the caller is offered
the option of requesting a callback rather than waiting in queue. You can alter this Queue Condition as needed.
In the Offer Callback Menu, you configure amessage that informs the customer about current call volume and
wait times, based on the queue condition you set. There is a Default Voice Callback Plan included with this
sample call flow. You can either use the default or create your own callback plan. For more information about
callback plans, see "Adding callback plans" on page 456.

If the customer declines the request for a callback, the call flow progresses to the Entry Level Business
SoftwareMenu.

The two numbered options in the Entry Level Business SoftwareMenu were addedmanually to this sample
call flow and complete the following actions:

l Option 1: Transfers the caller directly to the Support Queue
l Option 2: Transfers the caller directly to the Sales Queue

Options 1 and 2 have a Failure branch. If the transfer destination is unavailable, the call goes to the Hang up
activity.

If the DNIS is unrecognized, the caller is routed down the NoMatch branch and, subsequently, the Operator.

The last step in this call flow is the Hang up activity. We recommend you end call flows with a Hang up
activity to prevent errant calls from resting at the end of the call flow and tying up the port until it can reset and
disconnect the call.

Additional configuration required
To get your call flow sample up and running, youmust:

l Associate the call flow to a port (extension) or a hunt group. See "Associating call flows to extensions
or hunt groups" on page 454.

l Configure properties for all Transfer activities. For example, the Operator and the Sales and Support
queue destination information needs to be added. To do this, simply right-click the Transfer activity in
the call flow and specify the Destination in the Properties pane.

l In addition, for the Default Voice Callback Plan, youmust designate ports that you want to use for
callbacks as callback ports (extension type: port 5020 IP).

l Create prompts (messages) as needed. Generic prompts are included in this call flow but if you want to
customize thesemessages, you will need to create your own and add them to the call flow.

Sample Schedule condition followed by DNIS and Language with
Menus
This call flow instructs IVR Routing to direct calls that arrive on standard work days, during business hours, to
language-specific queues based on the number the caller dialed. Callers are routed to a single menu, which
presents prompts in the appropriate language.

This call flow enables you to:
l Configure schedule conditions to route calls based on predefined holidays
l Offer services in more than one language based on the number dialed to reach your contact center
l Use the same Prompt but make it available to all configured languages

Figure 17 - 10 displays this call flow as it appears when first imported.
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Figure 17 - 10 Schedule condition followed by DNIS and Language with Menus

Description
The first step in this call flow is an Answer activity. The Answer activity tells the port to answer the call. Until
this condition is met, the caller hears ringing.

Next in the call flow sequence is the Schedule condition. There are three branches, Holidays, Mon-Fri, 8-5,
and NoMatch. Placing the Holiday branch on the far-left of the call flow ensures that this branch is checked
first. If it is determined that the call is being received on a predefined holiday, a ClosedMessage plays and the
call proceeds to the Hang up activity.

NOTE:Youmust configure the call flow to check whether it is a holiday before checking whether it is within
business hours. If a call enters the system between 8 AM and 5 PM on aMonday that is a statutory holiday
and you check the business hour schedule first, the system will erroneously determine that the call center is
open and the call will proceed through the call flow, even though your office is closed.

If it is not a holiday, a check is done to confirm if the date and time of the call falls within business hours (set
as Monday – Friday, 8 AM – 5 PM). If the call arrives within business hours, the call is routed to the DNIS
check. If the call arrives outside of business hours, it is routed to the NoMatch branch and a ClosedMessage
plays. The call then proceeds to the Hang up activity. The Hang up activity ends the call flow and disconnects
the call. If you do not have a Hang up activity, the call will continue through the call flow until it reaches the
end of all possible actions, at which point it will wait in silence until the port resets.

If the call passes the Schedule criteria, it continues to the DNIS activity. This call flow sample contains three
DNIS, each one representing a different language (French, English, andGerman, in this case). According to
the DNIS, the call is routed through the appropriate Language activity to aMenu. TheMenu is the same for
each DNIS and has the same Prompt. The Prompt contains .wav files that are specific to each language.
Depending on which language activity the call was channeled through, thematching language .wav file will
play. This enables reuse of the same Prompt regardless of the number of language activities that are
configured. If there is no DNIS match, the call flows to the NoMatch branch and is transferred to the Operator.

As noted above, theMenu options are the same for each DNIS – only the Language is different. The two
numbered options in theMenu activity (MainMenu) were addedmanually to this sample call flow and
complete the following actions:

l Option 1: Transfers the caller directly to the Support Queue
l Option 2: Plays the Shipping Instructions Message

Option 1 has a Failure branch. If the transfer destination is unavailable, the call goes to the Hang up activity.
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The last step in this call flow is the Hang up activity. We recommend you end call flows with a Hang up
activity to prevent errant calls from resting at the end of the call flow and tying up the port until it can reset and
disconnect the call.

Additional configuration required
To get your call flow sample up and running, youmust:

l Associate the call flow to a port (extension) or a hunt group. See "Associating call flows to extensions
or hunt groups" on page 454.

l Configure properties for all Transfer activities. For example, the Support queue destination information
needs to be added. To do this, simply right-click the Transfer activity in the call flow and specify the
Properties in the Properties pane.

l Create prompts (messages) as needed. Generic prompts are included in this call flow but if you want to
customize thesemessages, you will need to create your own and add them to the call flow.

Sample Management Plan call flow
This call flow enables authorized callers to remotely perform management operations on their IVR Routing
application. For example, authorized callers can switch the IVR RoutingMode of Operation between Normal
and Emergency mode andmodify the prompts that callers hear.

This call flow:

l Enables you to change over from Normal to Emergency mode if extremeweather conditions or other
events force the temporary, unforeseen closure of your contact center. In such situations, it is often
desirable and sometimes necessary tomake such changes from a remote location.

l Allows authorized users tomake changes to the IVR Routing system from remote locations. For
example, you canmodify incoming caller options and record new prompts using a phone. This is useful
when a commute to the site is either inconvenient or not possible.

Figure 17 - 11 displays theManagement Subroutine, which is configured as part of theManagement Plan call
flow.

Figure 17 - 11 Management Plan call flow

Description
The first step in this call flow is an Answer activity. The Answer activity tells the port to answer the call. Until
this condition is met, the caller hears ringing.

The next step in the call flow sequence is theManagement activity. A default Management Subroutine has
been assigned to theManagement activity. The Default Management Subroutine allows you to record
Prompts or set theMode of Operation. You can either use this Subroutine or create your own.
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If you open the Default Management Subroutine, you will see the first step is entering theManagement
Password. The authorized user calls the port and enters their password (in this sample, 1234) in order to
access theManagement Plan call flow.

The next step in the call flow is the Record Prompts or Set Mode of OperationMenu. Within this Menu activity
there are two, numbered options that were addedmanually and complete the following actions:

l Option 1:Record prompts or record new greeting
l Option 2:Select 1 for System; 2 for Device

If you press Option 1 in the Record Prompts or Set Mode of OperationMenu, you can record new prompts or
record new greetings and swap prompts from one position to another within a call flow.

Press Option 1 to record a Prompt. If, after recording a Prompt, you want to continue recording Prompts, press
1 to record, press 2 to exit, or press any other key to return to the Record prompts or record new greeting
(activityMenu7 in the call flow).

If you press Option 2, you can record a new Greeting or swap a Prompt. For example, you can record an
Emergency ClosedMessage during an emergency situation and then swap it for a traditional OpenMessage
once the emergency has been resolved.

If you press Option 2 in the Record Prompts or Set Mode of OperationMenu, you can set the SystemMode of
Operation to either Emergency or Normal mode. If you select 1 (for system) you are affecting theMode of
Operation for all hunt groups and ports. If you select 2 (for device) you are affecting only the devices for which
you enter a reporting number (individual hunt groups or ports).

The last step in this call flow is the Hang up activity. We recommend you end call flows with a Hang up
activity to prevent errant calls from resting at the end of the call flow and tying up the port until it can reset and
disconnect the call.

Additional configuration required
This sample is configured as a standalone call flow which would require a dedicated port or hunt group. You
can use it in this way but we recommend you incorporate theManagement Plan call flow into your main call
flow(s). There are various ways to do this. For example, you could use an ANI condition that refers to a list of
authorized user numbers and gives them the option, when they call in, of accessing theManagement Plan.
You can alternatively add a DNIS condition and give users the appropriate number to call in to access the
Management Plan. If your call flow has an ANI or DNIS branch, you can add theManagement Plan ANI or
DNIS branch as an additional branch in that location of the call flow. Themenu option for accessing the
Management Plan should be hidden (unadvertised) meaning that it is not mentioned in your greetingmessage.
The authorized user would input a set code to access theManagement Plan.

CAUTION:After importing this sample call flow, it is “live” within your existing system. For example, if you
put a port into Emergency Mode that port will indeed go into Emergency Mode.
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Sample Outbound call flow with Excel
This call flow queries a data provider, in this case an Excel spreadsheet, to retrieve customer contact
information. The call flow then uses the contact information tomake outbound calls to customers. If a call is
not answered by the customer or if the line is busy, IVR Routing continues to attempt the call until it is
connected. If the customer answers the ringing line or the call goes to the customer’s voicemail the call flow
updates the call status as “Completed” and the customer will not be called again. Customers who answer the
outbound call are directed to amenu presenting them with routing options.

This call flow enables:
l Contact centers to make outbound calls to customers by accessing an internal database

Figure 17 - 12 displays this call flow as it appears when first imported.

Figure 17 - 12 Outbound call flow with Excel

Description
This sample call flow uses an Excel spreadsheet, called OutboundSample.xlsx. This file is located in the IVR
folder on the Enterprise Server. You populate the Excel sheet with customer phone numbers that you access
while making outbound calls.

The first step in this call flow is the Schedule condition. There are two branches, Open Hours 9-5 and No
Match. If calls are executed during business hours, they progress to the Query. If calls are executed outside
of configured business hours the call flow routes to the NoMatch branch and then to the Hang up activity.
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If during business hours, the call flow progresses to the Query. TheQuery references the Data Provider (in
this case, Default Outbound Provider). In this sample, the Data Provider refers to the Excel sheet of customer
phone numbers that is mentioned above. This Excel sheet has two columns – one for the customer’s phone
number and one for the customer’s status. The Excel sheet and the Query can bemodified as needed.

The first Query action is to run a Select statement to pull the first number with an “Incomplete” status to call.
The Select Query either goes to the Success branch (if it successfully finds/selects a customer phone
number) or to the Failure branch if no customer phone number is found. When the call enters the Failure
branch an email is sent to managers advising them that no “Incomplete” calls remain in the database Excel
sheet. Access to this functionality requires you to first configure the SMTP Server and the email template
used for this example.

If an “Incomplete” status call is selected, the call flow progresses to the Success branch and theWrite
statement executes, which changes the customer’s status from “Incomplete” to “In Progress”, preventing
other ports from simultaneously calling the same customer.

When theQuery successfully pulls a customer phone number, it proceeds to theMake Call activity. The
Make Call activity has a destination set for LastQueryResult, meaning it will dial the phone number that the
Query pulled from the Excel spreadsheet.

TheMake Call activity has several branches. When you successfully connect to a customer, the call goes
down the Success branch, a query is executed and the customer status is updated to “Completed”, ensuring
that number is not called again. Following this action, the customer is presented with two options. They can
choose to either be transferred to a queue to speak to an agent or listen to amessage for more information. For
example, you could record amessage with details about a current sales promotion.

If there is no answer, a Query is executed and the customer status is updated to “No Answer”, meaning that
when this number is selected from the list the next time, the system will attempt to call it again.

If there is a busy signal (Destination Busy), a Query is executed and the customer status is updated to “Busy”,
meaning that when this number is selected from the list the next time, the system will attempt to call it again.

If the number is not in service (Invalid Destination), a Query is executed and the customer status is updated to
“Invalid”, meaning that when this number is selected from the list the next time, the system will not attempt to
call it again.

If theMake Call fails due to an issue with the telephone system, an email is sent to themanager(s) advising
them of the communication failure. Access to this functionality requires you to first configure the SMTP
Server and the email template used for this example.

The last step in this call flow is the Hang up activity. We recommend you end call flows with a Hang up
activity to prevent errant calls from resting at the end of the call flow and tying up the port until it can reset and
disconnect the call.
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Additional configuration required
To get your call flow sample up and running, youmust:

l Associate the call flow to a port (extension). This call flow type cannot be assigned to a hunt group. See
"Associating call flows to extensions or hunt groups" on page 454.

l Configure properties for all Transfer activities. For example, the Transfer to queue destination
information needs to be added. To do this, simply right-click the Transfer activity in the call flow and
specify the Properties in the Properties pane.

l Create prompts (messages) as needed. Generic prompts are included in this call flow but if you want to
customize thesemessages, you will need to create your own and add them to the call flow.

l In order to make the call flow active, youmust select “Always Run” in the Properties Pane, under Call
Flow. If you want to end the call flow activity, deselect this option.

l We recommend adding a queue condition in the Success branch of this call flow so callers are directed
to the queue only if, for example, a sufficient number of agents are available to take their call or the
number of calls waiting in the queue is not excessive. Rather thanmaking the caller wait to speak to an
agent in this situation, it might be preferable to instead play the “Play more information on offer”
message.

l We suggest adding a queue condition following the Schedule condition that sets calling times for the
optimum times of the day, for example, youmight only want to make outbound calls between 3 PM and
7 PM. By setting a condition in this way, you can ensure that you have sufficient agents available
during that time to handle calls.

IVR Routing complex call flow configuration
The following section describes how to configure two intricate call flows. You can use these instructions to
create the call flows as described or as an educational exercise from which you can learn to build your own
customized, unique call flows. Before attempting to configure these call flows youmust be familiar with IVR
Routing and able to proficiently configure intermediate to advanced level call flows using Visual Workflow
Manager.

This document shows you how to construct:
l Outbound call flow: An outbound call flow that returns abandoned calls on a priority basis according to

customer status
l Dial Active Directory call flow: A call flow that uses a LDAP connection to aWindows Active

Directory domain to retrieve phone numbers and transfer the caller to the retrieved extension

Outbound call flow configuration
This example demonstrates how to build an outbound call flow that returns abandoned calls on a priority basis
according to customer status. This call flow makes use of the delay activity, populates custom variables with
a specific format type, demonstrates enhanced email activity by adding attachments, and sends custom
variable information to agents via enhanced screen pop.

Consider the following scenario:

Problem:A busy order desk is having trouble keeping up with customer requests. As a result, they are
dealing with a high number of abandoned calls. Their customers are sorted into three priority levels: gold,
silver, and bronze. Goldmember callers are considered the highest priority and the order desk is obligated to
return their calls expediently in order to meet service level agreements. Each day a SQL table is populated
with all of the abandoned calls from the previous day including the customer’s priority levels. All gold
customers must be called back.
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Solution: The following outbound call flow is configured to search for customer numbers based on priority
level, thus ensuring gold-level customer calls are returned expediently. In addition, customers are given
options that can expedite call handling, resulting in amore efficient use of agent resources. For example, if
callers are offered choices, besides the option of connecting with an agent, of being sent a PDF of their order
status or listening to amessage describing their balance and due date, some caller’s needs would be satisfied
without having to speak to an agent. If callers choose to speak to an agent, specific caller information, for
example, their status, is delivered to the agent via a screen pop display when the agent connects to the call.

Figure 17 - 13 depicts the final, post-configuration version of the Outbound call flow example described here.

Figure 17 - 13 Oubound call flow

Configuring a database provider
The first step in creating this call flow is to determine the source from where you will retrieve the numbers to
call back. Typically the outbound call list is stored in a SQL database or an Excel spreadsheet. In this
example, the following table was created in a SQL database. The example SQL database used in this sample
call flow is named abandoned_caller. (See Table 17 - 3.)

NOTE:We recommend following standard database design practices when setting up your database. The
example database referred to in this document is for demonstration purposes only.

Table 17 - 3 SQL database example for abandoned caller list

ID [Level] CallerID UserName Balance EMail

100 Gold 3001 Dave 21.32 dave@prairiefyre.com

101 Silver 6132221212 James 201.55 james@prairiefyre.com

102 Bronze 6135990000 Curtis 30 curtis@praireifyre.com
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ID LastBill DueDate Processing Contacted FailedAttempt

100 \\share\bills\100bill.docx April 20, 2012 0 false NULL

101 \\share\bills\100bill.docx September 1, 2012 0 false NULL

102 \\share\bills\100bill.docx Dec 12, 2012 0 false NULL

The SQL data types used for this example are shown in Figure 17 - 14.

Figure 17 - 14 SQL data types

The columns Processing andContacted are added to the table to assist with call processing, as follows. The
outbound call flow executes in an always-run fashion. If there are records present in the database and
outbound ports are available, calls will be executed constantly. The processing column is used to flag a call as
in progress. When a call is in progress, it means that the outbound port is currently calling that number. After
the outbound call flow has completed, the contacted column is set to true. This process ensures callers, once
contacted, are not called back.

A FailedAttempt column is added to indicate the reason the attempt to call failed, for example, due to No
Answer, Destination Busy, or Invalid Destination. Figure 17 - 15 displays an example of failed attempts as
they display in the call flow.

Figure 17 - 15 Failed attempt example
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Youmust configure a database provider to supply outbound call records to the Outbound call flow. This
example uses aMicrosoft SQL server as a data provider and names the data provider Abandon DB. See
"Adding aMicrosoft SQL server as a data provider" on page 474.

Creating outbound ports
Outbound call flows and IVR Routing callbacks are both executed by the existing prairieFyre IVR Outbound
Service. However, ports are not shared between outbound call flows and callback call flows; their execution is
independent and both features can live side by side and function with or without each other. Callback port
5020 IP is used to process IVR Routing callbacks andOutbound port 5020 IP is used to process outbound call
flows.

Refer to the procedure "Adding extensions" on page 440 and add the appropriate number of outbound ports. If
you have any questions regarding the number of ports you require, contact the Systems Engineering Team.

Defining variables
Before creating the call flow, define the variables that it will use. For this example, we have created the
following variables from the above SQL database example table. Ensure the “Send to Screen Pop” check box
is selected if you want customer-relevant database information to be available in a screen pop display for
agents upon call receipt. (See Figure 17 - 16.)

Figure 17 - 16 Suggested variable configuration
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Creating an outbound call flow
Now that you have populated the table in the SQL database with abandoned contact information, added a
database provider and outbound ports, and created applicable variables, you can create the outbound call
flow.

To create an outbound call flow
 1. In YourSite Explorer, click Visual Workflow Manager=>Call flows.
 2. Click Add and select Outbound as the call flow type from the drop-down list.
 3. In theProperties pane, configure the call flow properties as needed.

NOTE: Tomake the call flow active, select theAlways run check box. When you no longer want the
call flow to be active, deselect this option.

 4. Click Save.

Configuring the outbound call flow for abandoned contacts
The first steps in configuring the outbound call flow for use with abandoned contacts are to add aQuery
activity, a Make Call activity, and a Hang up activity. TheMake Call activity is used to place calls to external
phone numbers that are typically stored in a data source, such as a SQL database or an Excel spreadsheet.
TheQuery activity is used to retrieve the numbers from the database that are then stored in a variable which is
accessed by theMake Call activity when dialing. TheMake Call activity determines the location of themedia
server and provides the correct formatting for the external phone number before placing the call. In this
example, the query looks for gold-level customers that require a return call.

To configure the outbound call flow for abandoned contacts
 1. Add aQuery activity and aHang up activity into the Call flows Canvas.
 2. Right-click theQuery activity and select Edit Database Provider.
 3. Select theAbandon DB database provider created earlier.
 4. Click OK.
 5. Right-click theQuery activity and select Edit Query Definition.
 6. UnderQuery type, select Advanced Query and, underSettings, enter the following SQL query(1):

SELECT top 1 * from dbo.abandoned_caller where level = ‘gold’ and processing = ‘0’ and contacted =
‘False’
UPDATE dbo.abandoned_caller set processing = 1 where id in (select top 1 id from dbo.abandoned_
caller where level = ‘gold’ and processing = ‘0’)

 7. On theVariable Assignment tab, assign the appropriate variables to the parameters returned from the
query(2).
Figure 17 - 17 displays steps 5-7.
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Figure 17 - 17 Creating the advanced SQL query

 8. In theSuccess branch of theQuery activity, add aMake Call activity.
See Figure 17 - 18.

Figure 17 - 18 Make Call activity
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 9. Select theMake Call activity and configure the properties in theProperties pane.
 10. For this example, besideDestination, select the variable <<OB_CallerID>> and click OK.
 11. Select theExternal Call check box to indicate that these calls are external to the PBX. Outbound

dialing digits are appended when dialing externally.
NOTE:Outbound dialing digits must be programmed in YourSite Explorer for themedia server upon
which the outbound ports reside. This is configured in YourSite Explorer=>Media servers=>Location
tab.

Configuring the branches of the Make Call activity
If the query is successful, the outbound number variable will populate. The caller is then offered the option to
speak with an agent, receive an email with account details, or listen to amessage that includes their account
balance and due date. If the query is unsuccessful, for example, if you are set up to call back gold-level callers
and there are none available in the SQL database table, the failure branch is followed.

In the Success branch of theMake Call activity three actions are performed: Delay, Menu, andQuery. See
Figure 17 - 19.

Figure 17 - 19 Branches of the Make Call activity

To configure the success branch of theMake Call activity
 1. In theSuccess branch of theMake Call activity, add and configure properties for aDelay activity.

The Delay action is used to give the customer time to answer the phone and greet the caller. The delay
value is set in seconds.

 2. Following theDelay activity, add aMenu activity.
 3. Right-click theMenu activity and add the three digit options as follows: 1. Speak with Agent, 2. Mail

Last Record, and 3. Listen to balance and due date.
The customer will be able to select 1 to speak to an agent, 2 to receive an email containing their most
recent account information, or 3 to hear amessage regarding their account balance and due date.
See Figure 17 - 20.

Figure 17 - 20 Menu activity options



Contact Center Solutions User Guide

- 544 -

 4. Add a Transfer activity under option 1, anEmail activity under option 2, and aPlay activity under option
3.

 5. Configure theProperties for the Transfer activity. Be sure to set theDestination to an ACD path.
 6. Configure theProperties for theEmail activity. Select the SMTP Server address from the SMTP

servers that were configured in YourSite Explorer during the software installation process.
For more information, see "Configuring the SMTP Server" on page 73.

 7. Right-click theEmail activity and select Edit Email Template.
 8. Right-click in theConfigure email templatewindow to see a list of available variables.

NOTE: To ensure the email is sent to the customer, use the variables that were populated previously
with the query action.
See Figure 17 - 21.

Figure 17 - 21 Configuring the email template

 9. Configure theProperties for thePlay activity.
 10. Right-click thePlay activity and select Greeting prompts=>Add a new prompt.

The Prompt window opens.
You will configure the activity to play two custom .wav files and two prompts. The customer will hear
their account balance and due date, based on the variables you associate with the prompts.

 11. Select theVariables tab.
See Figure 17 - 22.
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Figure 17 - 22 Configuring the Play activity

In this example, the OB_Balance variable is set as type ‘Date Time’ and the variable OB_Balance is set
as type ‘Dollars’. These variables have an associated format type. The variable type ‘Date Time’ must
be formatted to suit the variable populated from the database query. The available options display in
Figure 17 - 23.

Figure 17 - 23 Date format options

 12. SelectMMDDYYY as theDate Format for the due date variable (OB_DueDate).
NOTE: The balance due variable (OB_Balance) can have eitherCurrency Format selected. The
currency format is only used when writing data to a database.

 13. Configure the exception branches, Timeout, Invalid, and Failure, as needed.
 14. As a final step in configuring the success branch of theMake Call activity, under theMenu activity, add

aQuery activity.
This query updates the SQL table to indicate that the call has been completed, ensuring that number is
not called again.
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To configure the failure branch of theMake Call activity
 1. UnderNo Answer, add and configure aQuery activity that updates the customer status in the database

to “No Answer” when the customer does not answer the call. The next time this number is selected
from the list, the system will attempt to call it again.

 2. UnderDestination Busy, add and configure aQuery activity that updates the customer status in the
database to “Destination Busy” when the busy signal is encountered. The next time this number is
selected from the list, the system will attempt to call it again.

 3. Under Invalid Destination, add and configure aQuery activity that updates the customer status in the
database to “Invalid” when the number called is out of service. The next time this number is selected
from the list, the system will not attempt to call it.

 4. Under Failure, add and configure aSubroutine activity that advises the Administrator when there are
problems with the call flow.
Adding this subroutine is recommended in order to help error proof the call flow.

After configuring the outbound call flow, associate it to a port. An outbound call flow cannot be associated to a
hunt group. See "Associating call flows to extensions or hunt groups" on page 454.

Dial Active Directory call flow configuration
This section demonstrates how to build a call flow that uses an LDAP connection to aWindows Active
Directory domain to retrieve phone numbers and transfer the caller to the retrieved extension.

This example is composed of amain call flow and a subroutine that contains an LDAP query. The caller is
presented with amenu that prompts them to enter the extension of the party they wish to reach. If they know
the extension they can dial it at any time or they can dial by name (by pressing 1) or choose to speak to the
operator (by pressing 0). When the caller chooses option 1, the call flow is directed to the Dial By Active
Directory (DialByAD) subroutine. Subroutines are recommended when a call process contains many
activities or repeating tasks. In this case, the DialByAD subroutine contains several activities. Segregating it
from themain call flow simplifies the process.

Figure 17 - 24 depicts the final, post-configuration version of the Dial Active Directory call flow.

Figure 17 - 24 Dial Active Directory call flow

Figure 17 - 25 depicts the final, post-configuration version of the DialByAD subroutine.
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Figure 17 - 25 DialByAD subroutine

Preliminary configuration
Before creating the call flow, youmust configure the required variables and prompts.
Create the following list of variables along with their associated variable type. (See Figure 17 - 26.)

Figure 17 - 26 Required variables

After creating the variables, configure applicable prompts as shown in Table 17 - 4.
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Table 17 - 4 Required prompts

Prompt Name Script

DialAD –MainMenu Thank you for calling. If you know the extension of the party you wish to
reach, dial it now. To dial by name, press 1. For operator assistance,
press 0.

DialAD –Name from Dialpad Using your touchtone keypad, please type the last name of the person
you wish to reach, followed by the pound (#) sign.

DialAD –Did youmean ...

NOTE: This prompt
references the variable
DAD_TempWav created
earlier

<DAD_TempWav> If this is the person you want to reach, press 1. If
not, press star (*).

Creating the main Dial Active Directory call flow
Now that you have created the variables and prompts, you can create themain Dial Active Directory call flow.
 1. In YourSite Explorer, click Visual Workflow Manager=>Call flows.
 2. Click Add and select Voice as the call flow type from the drop-down list.
 3. In theProperties pane, configure the call flow properties as needed.
 4. Add anAnswer activity and aHang up activity onto the Call flows canvas.
 5. After theAnswer activity, add aMenu activity.
 6. Click Save.

The next step in creating the Dial Active Directory call flow is configuring theMenu activity.

To configure theMenu activity
 1. Select theMenu activity on the Call flows Canvas and, in theProperties pane, configure theMenu

properties.
 2. Enter an appropriateName for themenu and add aPrompt to play a greetingmessage to the caller

(DialAD –MainMenu, as shown in Table 17 - 4).
See Figure 17 - 27 for suggested configuration settings.
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Figure 17 - 27 Main Menu activity properties configuration

 3. Right-click theMenu activity and add the three digit options as follows: 1 - Dial by AD, 0 - Operator,
andAny Characters.
NOTE: The DTMFMulti Digit Delay function allows the system to wait for one second (default value)
after hearing the first DTMF tone from the caller to see if another digit will be pressed before processing
the call.

 4. In theProperties pane, configure theMenu options.
NOTE: It is important to give eachmenu option branch an appropriate name as doing so simplifies the
troubleshooting process when interpreting log files.
See Figure 17 - 28.
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Figure 17 - 28 Menu option configuration

 5. In the 0 – Operator and theAny Characters branches of themenu options, add a Transfer activity.
 6. Right-click the Transfer activity that follows 0 – Operator and select Destination.
 7. In theProperties pane, afterDestination, type the extension that reaches the operator in your

organization.
 8. Right-click the Transfer activity that follows Any Characters and select Destination.
 9. Configure theDestination as the call variable <<LastMenuCollectedDigits>>.

This sets the entry that is received by theMenu activity as the transfer point.
 10. Name the Timeout, Invalid, and Failure branches of theMenu activity according to best practices.

Use the nomenclature br<PARENT_MENU><OPT>.
Following this naming convention simplifies the troubleshooting process when searching through log
files. See Table 17 - 5 for an example of best practice naming conventions.

 11. Click Save.

Table 17 - 5 Best practice naming convention example

Menu branch Naming convention

Timeout brmnMain1OPTTIME

Invalid brmnMain1OPTINV

Failure brmnMain1OPTFAIL

Now that themain Dial Active Directory call flow has been configured, the DialByAD subroutinemust be
configured and added to the overall call flow.
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Configuring the DialByAD subroutine
If the caller knows the last name of the person they are trying to reach, they enter thematching digits in their
dial pad. The dial pad compare feature is used to support this search function. The first step in being able to
access this functionality is to collect the digits. This is done via a Collect Digits activity within the subroutine.

To configure the DialByAD subroutine
 1. Click Subroutines=>Add=>Voice.
 2. In theProperties pane, afterName, typeDialByAD.
 3. Add aCollect Digits activity to the subroutine.
 4. Select theCollect Digits activity and, in theProperties pane, afterName, typeGet Last Name and

afterSystem Name, type cdGetLastName.
 5. Configure theGoTo activities in the Timeout and Invalid branches to return to theGet Last Name

Collect Digits activity.
See Figure 17 - 29.

Figure 17 - 29 Collect Digits activity

 6. Name theSuccess, Timeout, Invalid, and Failure branches according to best practices, as shown in
Table 17 - 6.

Table 17 - 6 Best practice naming convention example

Menu branch Naming convention

Success brcdGetLastNameSUCC

Timeout brcdGetLastNameTIME

Invalid brcdGetLastNameINV

Failure brcdGetLastNameFAIL
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 7. Right-click theGet Last NameCollect Digits activity and select Edit Variable Settings.
The Collect Digits settings window opens.

 8. Select the appropriate options for each value in the Collect Digits settings window.
TheVariable should be unique to this call flow and be of the Variable TypeNumber. In this case, the
variable <<DAD_Ext-Lookup>> is used.
NOTE: This example uses a greeting that asks the caller to enter the last name of the person they are
trying to reach by using their dial pad and pressing pound (#) when finished. The settings and greeting
verbiage you choose are dependent on your environment and needs.

 9. Click OK.
 10. Click Save to save the subroutine.

This example performs a lookup based on the last name of the employee in Active Directory. However, the
procedure can easily be converted to use the first name or a different value altogether. When a caller
successfully enters digits they are branched down the Success branch in the Collect Digits activity. In the
Success branch, a Query to Active Directory is inserted to search for the requested employee. Prior to this
action, a new data provider must be created.

Configuring the LDAP data provider
To configure the LDAP data provider
 1. Click Data providers=>Add and select LDAP from the drop-down list.
 2. Enter the appropriate settings for the Active Directory domain, including a user with read access.
 3. Click Test Connection to attempt to connect to the domain.

This example connects to a local domain labeled "PFSE Domain".
 4. Click Save.

Configuring the Active Directory LDAP query
This example queries based on the employee’s last name and returns their extension to which the call is then
transferred. The Last Name, Display name, and Telephone number fields from the user object in Active
Directory are accessed. In addition, the objects will return a .wav file so the names can be read back to the
caller. It is suggested that each employee record their name to use as a customized .wav file. In this example,
the customized employee name .wav files are stored in the Telephones tab in Active Directory. Note that this
locationmust be accessible from the IVR Routing instance performing the query and readback. See Figure 17
- 30.
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Figure 17 - 30 Customized .wav file storage in Active Directory

To configure the Active Directory LDAP query
 1. Add aQuery activity to theSuccess branch of theGet Last NameCollect Digits activity.
 2. Select theQuery activity and, in theProperties pane, enter an appropriateName andSystem Name.

This example uses "Get User from AD – PFSE.LOCAL" and "qrPFSEAD" respectively.
 3. Name theSuccess and Failure branches in adherence with best practices. In this case, Success:

brqPFSEADSUCC and Failure: brqrPFSEADFAIL.
 4. Right-click theQuery activity and select Edit Database Provider.
 5. In theSelect Connectionwindow, choose the appropriate provider.

This example uses PFSE Domain.
 6. Right-click theQuery activity and select Edit Query Definition.
 7. UnderQuery Type, select Advanced Query and, underSettings, enter the following query: select

info,telephoneNumber,CN from 'LDAP://PFSE.LOCAL where objectClass='user' AND sn =
'@LastName'.
An advanced query is necessary in this example to enable the return of multiple variables. If there was
only a need for a single variable, a simple query would suffice.

 8. Click Execute.
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 9. In theParameterswindow, select theValue of ‘76’ for@LastName and select theUse Dialpad
Compare check box.
The value of ‘76’ is translated into the following when using the dialpad compare feature: p, pn, Po, Q,
Qm, Qn, Qo, R, Rm, Rn, Ro, S, Sm, Sn, So.

 10. Click Run.
The command runs and the Database Lookup window for the AdvancedQuery opens.

 11. Confirm correct configuration by clicking the Test Results tab and checking the info column to ensure
the expected result(s) were returned.

 12. In theVariable Assignment tab, select appropriate variables for the returned values.
In this example, CN is used for the common name of the Active Directory object (display name in
Active Directory) and telephoneNumber for the extension of the user being queried. The information
from the Telephones tab is also returned as it contains the location of the .wav file to be played. (See
Figure 17 - 31.)

Figure 17 - 31 Variable assignment

 13. In theParameter Assignment tab, select the variable that was populated in the Collect Digits activity,
‘cdGetLastName’. In this case, DAD_Ext-Lookup.
Configuring the parameter assignment with a variable replaces the query with the appropriate run-time
information. (See Figure 17 - 32.)

Figure 17 - 32 Parameter Assignment

Configuring the Success branch of the query
Now that information has been retrieved via the LDAP query, the process loops through the results until the
correct one is found. The customized employee name .wav file is played and the caller is asked if that is the
individual they want to reach. Once the correct name is found, the caller is transferred to that destination and
the call flow is terminated.



IVR Routing complex call flow configuration

- 555 -

To configure the Success branch of the query
 1. Add aMenu activity into theSuccess branch of theQuery activity (Get User from AD –

PFSE.LOCAL).
 2. Select theMenu activity and, in theProperties pane, enter appropriate information for theName and

System Name.
This example uses "Did youmean…?" and "mnDidYouMeanQ", respectively.

 3. UnderPrompt, in theProperties pane, select Existing Prompt from the drop-down list and choose the
prompt calledDialAD – Did you mean …

 4. Right-click theMenu activity and add a digit option for 1.
 5. Name theMenu branches in accordance with best practices, as shown in Table 17 - 7.

Table 17 - 7 Best practice naming convention example

Menu branch Naming convention

1 brmnDidYouMeanQOPT1

Timeout brmnDidYouMeanQTIME

Invalid brmnDidYouMeanQINV

Failure brmnDidYouMeanQFAIL

 6. In the Failure branch, addHang up activity
 7. In the Timeout and Invalid branches, remove the default Play andGoTo activities.
 8. Removing these activities ensures that if the returned employee extension is not the correct one, the

parent Query activity will move on to the next result found and offer it to the caller instead.
 9. In the Digit option 1 branch, add aPlay activity, a Transfer activity, and aHang up activity.
 10. Name the activities, according to best practices, as shown in Table 17 - 8.

Table 17 - 8 Option 1 activity naming example

Activity Name System Name

Play Transferring your call pfTransferring

Transfer Xfr To Extension xfrToExt

Transfer Branch Failure brxfrToExtFAIL

Hang up Hangup After Transfer hgTransfer

 11. Choose an applicable prompt for thePlay activity.
This example uses a prompt called “DAD – Transferring” that plays a .wav file that says: “Transferring
your call now.”

 12. Right-click the Transfer activity and select Destination.
 13. In theSelect a devicewindow, select Call variable and choose the appropriate variable assigned in

the LDAP query.
 14. Click Save.
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Pre-configured messages and prompts
Table 17 - 9 contains a list of pre-configuredmessages and prompts.
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Table 17 - 9 IVR Routing pre-configured messages and prompts

Message or prompt

Connecting now CB-en-US-Agent-
Connecting.wav

8Khz
mono
Mulaw

You have a voice callback request CB-en-US-AgentGreeting.wav 8Khz
mono
Mulaw

To listen to the caller's message, press 1. To place this call, press 2.
To requeue this request press 3. To reject this request, press 4. To
hear this information again, press 5.

CB-en-US-Agen-
tInstructions.wav

8Khz
mono
Mulaw

Please wait while the call is established CB-en-US-Agent-
PreConnect.wav

8Khz
mono
Mulaw

Your request has been canceled. Goodbye. CB-en-US-AgentRejected.wav 8Khz
mono
Mulaw

Your request has been requeued. Goodbye. CB-en-US-AgentRequeue.wav 8Khz
mono
Mulaw

You have a voice callback request. CB-en-US-Cal-
lersMessage.wav

8Khz
mono
Mulaw

Your request has been canceled. Goodbye. CB-en-US-Can-
celConfirmation.wav

8Khz
mono
Mulaw

Your request has been canceled. Goodbye. CB-en-US-ClientCancelled.wav 8Khz
mono
Mulaw

The callback could not be established. CB-en-US-ClientFailure.wav 8Khz
mono
Mulaw

You have a voice callback request. CB-en-US-ClientGreeting.wav 8Khz
mono
Mulaw

Press 1 to confirm your recording, or press any digit other digit to try
again.

CB-en-US-Clien-
tRecordingConfirm.wav

8Khz
mono
Mulaw
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Message or prompt

At the tone, please record your name. When you are finished record-
ing, press 1.

CB-en-US-Clien-
tRecordMessage.wav

8Khz
mono
Mulaw

To submit this callback request, press 1. To cancel this request and
leave the system, please press the star key.

CB-en-US-Clien-
tRequestConfirmation.wav

8Khz
mono
Mulaw

Please enter a telephone number where you can be reached, fol-
lowed by the pound sign.

CB-en-US-Enter-
PhoneNumber.wav

8Khz
mono
Mulaw

To submit this callback request, press one. To cancel this request
and leave the system, please press the star key.

CB-en-US-Incom-
ingSubmissionMenu.wav

8Khz
mono
Mulaw

To submit this callback request, press one. To cancel this request
and leave the system, please press the star key.

CB-en-US-Instructions.wav 8Khz
mono
Mulaw

The phone number entered was invalid. Please try again. CB-en-US-Inval-
idPhoneNumber.wav

8Khz
mono
Mulaw

The date and time entered was invalid. CB-en-US-Inval-
idpreferredTime.wav

8Khz
mono
Mulaw

Enter the time or date and time you want to be called back at. CB-en-US-PreferredTime.wav 8Khz
mono
Mulaw

The callback request has been successfully submitted. CB-en-US-Sub-
mitConfirmation.wav

8Khz
mono
Mulaw

You have entered... CB-en-US-You-
HaveEntered.wav

8Khz
mono
Mulaw

...if this is correct, press one. If this is not correct, please press the
star key.

CB-en-US-You-
HaveEnteredConfirm.wav

8Khz
mono
Mulaw
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Message or prompt

Please enter your management password. mgmt-en-US1 - Instruc-
tions.wav

8Khz
mono
Mulaw

The password you have entered is incorrect. mgmt-en-US2 - Invalid pass-
word.wav

8Khz
mono
Mulaw

To record system prompts, press one. To change the system's oper-
atingmode, press two.

mgmt-en-US3 -Mainmenu.wav 8Khz
mono
Mulaw

Begin speaking after the tone. When finished, press any digit. mgmt-en-US4 - Recording
instructions.wav

8Khz
mono
Mulaw

To keep this recording, press any digit. Press star or pound to delete
this recording.

mgmt-en-US5 - Recording play-
back instructions.wav

8Khz
mono
Mulaw

Playing back recording. mgmt-en-US6 - Recording play-
back.wav

8Khz
mono
Mulaw

Recording has been saved. mgmt-en-US7 - Recording
saved.wav

8Khz
mono
Mulaw

Recording deleted. mgmt-en-US8 - Recording delet-
ed.wav

8Khz
mono
Mulaw

Press one to change the system's operatingmode, or press two to
change the operatingmode of a specific port group.

mgmt-en-US9 - Emergency
Instructions.wav

8Khz
mono
Mulaw

Press one to set the system to emergency mode, or press two to set
the system to normal mode.

mgmt-en-US10 - Set system
emergency instructions.wav

8Khz
mono
Mulaw

Please enter the reporting number for the port group you would like to
change.

mgmt-en-US11 - Port group
emergency instructions.wav

8Khz
mono
Mulaw

Your port groups are now operating in emergency mode. mgmt-en-US12 - System emer-
gency mode set.wav

8Khz
mono
Mulaw
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Message or prompt

Your port groups are now operating in normal mode. mgmt-en-US13 - System normal
mode set.wav

8Khz
mono
Mulaw

The port group you have entered does not exist. mgmt-en-US14 - Invalid port
group.wav

8Khz
mono
Mulaw

Exitingmanagement activity. mgmt-en-US15 - Exit man-
agement activity.wav

8Khz
mono
Mulaw

Normal mode. mgmt-en-US16 - Normal
mode.wav

8Khz
mono
Mulaw

Emergency mode. mgmt-en-US17 - Emergency
mode.wav

8Khz
mono
Mulaw

...is now operating in emergency mode. mgmt-en-US18 - Port group
emergency mode.wav

8Khz
mono
Mulaw

...is now operating in normal mode. mgmt-en-US19 - Port group nor-
mal mode.wav

8Khz
mono
Mulaw

...is currently operating in normal mode. Press one to change this
port group to operate in emergency mode.

mgmt-en-US20 - Confirm port
group emergency mode.wav

8Khz
mono
Mulaw

...is currently operating in emergency mode. Press one to change
this port group to operate in normal mode.

mgmt-en-US21 - Confirm port
group normal mode.wav

8Khz
mono
Mulaw

All our representatives are busy helping other callers. Your call will
be answered as an agent becomes available.

en-US1 - All of our rep-
resentatives are busy.wav

8Khz
mono
Mulaw

Goodmorning and thank you for calling. All our representatives are
busy helping other callers. Your call will be answered as an agent
becomes available.

en-US2 -Mainmenu instruc-
tions.wav

8Khz
mono
Mulaw

Good afternoon and thank you for calling. All our representatives are
busy helping other callers. Your call will be answered as an agent
becomes available.

en-US3 - Good afternoon, thank
you for calling.wav

8Khz
mono
Mulaw
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Message or prompt

Thank you for calling. Based on current call volume, the expected
wait time is...

en-US4 - Based on current call
volume, expected wait time.wav

8Khz
mono
Mulaw

Thank you for calling. Due to the unusually high number of calls, the
expected wait time is...

en-US5 - High number of calls,
expected wait time.wav

8Khz
mono
Mulaw

Thank you for calling. The current wait times are between 5 and 10
minutes. Please continue to hold tomaintain your call priority. We
thank you for your patience.

en-US6 - Current wait time
between 5-10minutes.wav

8Khz
mono
Mulaw

Thank you for calling. Due to the unusually high number of calls, the
current wait times are greater than 10minutes. Please continue to
hold tomaintain your call priority. We thank you for your patience.

en-US7 - Current wait time
greater than 10minutes.wav

8Khz
mono
Mulaw

That option is not available. en-US8 - That option is not avail-
able.wav

8Khz
mono
Mulaw

Thank you for calling. Our offices are now closed. Please call back
Monday to Friday.

en-US9 - Offices are
closed.wav

8Khz
mono
Mulaw

Thank you for calling. Our offices are now closed for the holiday.
Please call back Monday to Friday between the hours of 8am and
5pm.

en-US10 - Offices are closed for
holidays.wav

8Khz
mono
Mulaw

Thank you for calling. We are currently experiencing an unusually
high number of calls. Your call will be answered as soon as an agent
is available. We thank you for your patience.

en-US11 - Unusually high vol-
ume of calls.wav

8Khz
mono
Mulaw

You have entered... en-US12 - You have
entered.wav

8Khz
mono
Mulaw

...if this is correct, press one. If this is not correct, please press the
star key.

en-US13 - If correct Press 1, if
not correct press star.wav

8Khz
mono
Mulaw

Please wait while the call is established. en-US14 - Please wait until call
is established.wav

8Khz
mono
Mulaw

Connecting now. en-US15 - Connecting now.wav 8Khz
mono
Mulaw
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Message or prompt

Your call is being routed. Onemoment please. en-US16 - Call being routed.wav 8Khz
mono
Mulaw

Thank you for calling. Your call will be answered in as soon as an
agent becomes available.

en-US17 - Your call will be
answered when agent becomes
available.wav

8Khz
mono
Mulaw

That selection is invalid. en-US18 - Selection is inval-
id.wav

8Khz
mono
Mulaw

The number of callers waiting is... en-US19 - Number of callers
waiting is.wav

8Khz
mono
Mulaw

Your position in queue is... en-US20 - Your position in
queue is.wav

8Khz
mono
Mulaw

The longest call waiting is... en-US21 - Longest call waiting
is.wav

8Khz
mono
Mulaw

Goodbye. en-US22 - Goodbye.wav 8Khz
mono
Mulaw
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Chapter 18

Intelligent Queue

Using Intelligent Queue
Intelligent Queue functionality

Planning the number of ports you require
Understanding the call flow process

Setting up Intelligent Queue
Callback and recording plans

Maintaining Intelligent Queue and Contact Center
 Management
Web callback

Viewing theWebCallback example page
Customizing yourWeb callback page

Troubleshooting Intelligent Queue issues
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Intelligent Queue
Intelligent Queue is an all-in-one, scalable, web-based, integrated voice processing solution providing static
messaging, intelligent messaging, voice and web callbacks, call recording, enhanced routing, reporting
capabilities, and caller-entered digit screen pop when integrated with Contact Center Screen Pop.

Intelligent Queue is an optional application that works with Contact Center Management. Contact Center
Management provides real-time statistics (required for queue conditional messaging) and historical reporting
of Intelligent Queue activity (Call detail reporting option). It supports the G729 codec with a voice compression
rate of 1/8. The compression optimizes network bandwidth so that networked branches of a company can
communicatemore quickly and efficiently with each other.

Intelligent Queue is easily and effectively managed through a web-based interface with .wav file recordings.
Administrators dynamically configure the application ports and features of Intelligent Queue from an Internet
Explorer browser. This flexibility makes the system highly responsive to the needs of the contact center
manager.

Using Intelligent Queue
TheGetting started section provides information on licensing, registering, and upgrading Intelligent Queue.

Registering and Activating Intelligent Queue
Before you register Intelligent Queue, ensure you have your site key available. The site key is the five-digit
number located in your product fulfillment email.

Youmust contact prairieFyre Software technical support at 613-599-0045 (North American customers) or your
approvedMitel vendor (for customers residing in Latin America, Europe, theMiddle East, Africa, and Asia
Pacific) to register and activate your Intelligent Queue software.

Registration can be completed online or offline. Upon registration, prairieFyre will issue you a key to license
your Intelligent Queue software and aMOSS password you will require during the activation process.

Registering your Intelligent Queue software
To register your Intelligent Queue software

 1. Contact prairieFyre Software technical support at 613-599-0045 (North American customers) or your
approvedMitel vendor (for customers residing in Latin America, Europe, theMiddle East, Africa, and
Asia Pacific), and provide the technical support representative with the five digit site key located in your
product fulfillment email.
prairieFyre will issue you a license key and aMOSS password. Ensure you write this information down
as it is required during the activation process.

 2. InWindows, navigate to theMitel program folder and select Intelligent Queue=>Intelligent Queue
License Client.
The Registration dialog box opens.
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 3. If you have an active Internet connection, click Register Online. See "Registering online" on page 565.
If you do not have an active Internet connection, click Register Offline. See "Registering offline" on
page 565.

Registering online
NOTE: To ensure you are able to register online, any firewalls and proxies must be configured to allow traffic
over port 80 to IP address 72.1.218.40.

To register Intelligent Queue online
 1. InWindows, navigate to theMitel program folder and select Intelligent Queue=>Intelligent Queue

License Client.
 2. Click Register Online.
 3. Type the License Key in the Online Registry form and click OK.

Your Intelligent Queue software is registered automatically. When complete, the Online Registration:
Successfully Licensedmessage opens.

 4. Click OK and close the Registration window.

Registering offline
If you do not have access to the Internet or if you cannot access our license server, you can register offline.
After you register offline, the License Client application will register a seven-day demo license while you wait
for your license file from prairieFyre Software.

To register Intelligent Queue offline
 1. InWindows, navigate to theMitel program folder and select Intelligent Queue=>Intelligent Queue

License Client.
The Registration window opens.

 2. Click Register Offline.
 3. Type the License Key in the Offline Registry form and click OK.

TheOffline Registration engine generates the IQ.dlsc file in your Intelligent Queue install folder.
 4. Locate the IQ.dlsc file and email it to the Technical Support representative.

He will sign the IQ.dlsc file electronically and send it back to you.
 5. Replace the existing IQ.dlsc file with the signed copy.

Registering a seven-day demo license
With the seven-day demo license you receive 24 ports, callbacks, and CDR so you can continue using
Intelligent Queue. However, you should replace the demo license file before the seven days expire to ensure
you have continuous access. After you replace the demo license with your license the only the purchased
options will be enabled.

To register Intelligent Queue offline
 1. Launch the Intelligent Queue License Utility by navigating to theMitel program folder and selecting

Intelligent Queue=>Intelligent Queue License Utility.
The Registration window opens.

 2. Click the Install Demo button.
 3. Start Intelligent Queue by navigating to theMitel program folder and selecting Intelligent

Queue=>Intelligent Queue.
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Activating your Intelligent Queue software
To activate your Intelligent Queue software
 1. Open Intelligent Queue.
 2. Log in to Intelligent Queue usingmitel / setup as the default username and password.

The PurchasedOptions page opens.
 3. UnderSystem License, enter theMitel Options (MOSS) Password provided to you during the

registration process.
 4. UnderSystem Options, select the Intelligent Queue bundle and options you have purchased.
 5. Click Save.

Upgrading an existing license
If you are upgrading from Intelligent Queue Version 3.1.x to Version 5.x, youmust upgrade your license.
Before you start the license upgrade, you will need a new MOS password. If you do not have it, contact
prairieFyre Software Inc.Technical Support at 613-599-0045 and select option 3 (North American customers)
or your approvedMitel vendor (for customers residing in Latin America, Europe, theMiddle East, Africa, and
Asia Pacific).

To upgrade an existing Intelligent Queue license
 1. Log on to Intelligent Queue with the default user name and password:

l Username: mitel
l Password: setup

 2. Click Administration=>Purchased options.
The Purchased options window opens.

 3. Verify your Mitel Product Key matches theMOSS Options sheet.
 4. AfterEnter the Mitel Options Password, type theMOS password you received for the license

upgrade.
 5. Enter your system options.
 6. Click Save.

If the information you entered is correct, menu items will open. Themenu items correspond to your
purchased options. If you entered incorrect information, the Incorrect select window opens and you will
need to correct your system options entries.

Intelligent Queue functionality
In general terms, the functionality that the Intelligent Queue offers can be broken down into the following core
and optional behaviors.

Incoming call handling
Incoming call handling behaviors cover the conditions and actions that are triggered when a call is received,
such as informationmessaging, interactive trees, and routing.

Music on hold
Music on hold describes themusic subsystem and how it behaves.

System administration
System administration covers the system behaviors that are related to configuring andmaintaining Intelligent
Queue.
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Optional functionality
Callback processing
Callback processing addresses all the behaviors that occur between the callback request by the customer to
the processing of the callback by an ACD agent. Callbacks consist of two parts: intelligent call processing
that stems from interactive tree choices and callback processing that requires dedicated ports based on
volume.

Agent call recording
Agent call recording addresses the behavior of the quality monitoring feature.

Call detail reporting
Call detail reporting allows the system to report on the activity of Intelligent Queue through Contact Center
Management.

Caller-entered digits
Caller-entered digits addresses how the caller can enter digits for identification purposes with screen pop on
the agent’s desktop through integration with Contact Center Screen Pop.

Core functionality
Intelligent Queue consists of the following core functionality:

Incoming call handling
Intelligent Queue defines port behavior dynamically, based on call properties, schedule, current queue
conditions, and operatingmode.

Music on hold
You can use Intelligent Queue as amusic on hold source for your telephone system using a PC sound card, if
equipped. Intelligent Queue plays music through the sound card using a rotating (loop) playlist. Music sources
for the playlist include any or all of the following: audio CD, stored .wav file, and storedMP3 file. The playlist
can includemusic or prerecorded informationmessages.

The behavior begins when themusic engine is started, either by theWindows service or via the user interface.
A user with Intelligent Queue administrator rights can start or stop themusic engine from the user interface.
Once started, themusic engine will loop through the play list, playing continuously until it is stopped.

System administration
Intelligent Queue enables you to record announcements or change the Emergency Mode status using the
phone. When you record new system prompts, they are stored in a temporary inbox folder until you name the
message and assign it to an action or message plan via theWeb interface.

System administration includes starting/stopping the engines and event logging.

Incoming call handling
The action an Intelligent Queue port takes when a call is received is defined by an action plan. A call’s action
plan depends on the conditions defined for the port group.
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Incoming call handling conditions
When a call is detected at an Intelligent Queue port, the system consults its database to determine which are
defined for that port. Conditions are defined in the user interface and act as a decision tree structure. Each port
or group of ports has a set of conditions that determine which action plan applies to the current call. If no
conditions are defined, or no defined conditions aremet, the port uses a default action plan. Action plan
selection starts when a call is first detected on the Intelligent Queue port and is completed before the call is
answered.

Multiple conditions can be applied to each port, and any condition can lead to another subcondition or action
plan. The order in which the conditions are defined in the user interface determines the order that the
conditions are applied to a call.

An Intelligent Queue port uses the following conditions to determine an action plan:

Caller’s telephone number (ANI)
The system compares a callers’s telephone number to a list (ANI map) of telephone numbers or digit patterns.
If a match is detected, the defined action plan or subcondition is applied.

The number dialed by the caller (DNIS)
The number that is presented to the telephone system as the dialed digits can be used as a condition.

Redirection number
If applicable, the original destination of the call can be used as a condition for determining the action plan. The
original destination is the number from which the call was diverted, forwarded, or transferred (unsupervised
transfers). For ACD interflow, this device is the ACD path from where the call came.

Day of the year
Any specific date can be defined as a condition. You can apply a subcondition, such as time of day, to make
the conditionmore specific.

Day of the week
Any specific day of the week can be defined as a condition. You can apply a subcondition, such as time of
day, to make the conditionmore specific.

Time of day
A specific time period can be defined as a condition. You can specify the start and end times for which the
condition is valid.

Number of calls in queue
If you have Contact Center Management, you can use the total number of calls waiting in a queue or queue
group, at the time the call begins to ring on the Intelligent Queue port, as a condition for applying an action plan
to a call. The system queries Contact Center Management at decision time to determine the current queue
conditions.

Queue waiting times
If you have Contact Center Management, you can use the longest amount of time that a caller has been
waiting in a queue or queue group, at the time the call begins to ring on the Intelligent Queue port, as a
condition for applying an action plan to a call. The system queries Contact Center Management at decision
time to determine the current queue conditions.
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Operating mode
The current operatingmode of the system or of a port group can be either Normal or Emergency. An Intelligent
Queue administrator can place the call flows in Emergency mode to force all calls on a port to use a predefined
Emergency action plan. This would typically be due to an unforeseen temporary closure of a contact center,
as in the case of a natural disaster.

Incoming call handling action plans (messaging, callback, and routing)
All calls are eventually handled by an action plan. An action plan is a set of call handling instructions that
defines how tomanage a specific call. The relationship between conditions and action plans is that conditions
define which action plan is chosen for a specific call. If no conditions aremet, a default action plan is used to
handle the call. An action plan begins upon selection and carries a call for the duration of its existence within
Intelligent Queue.

An action plan can be defined as any of the following call handling types:

Do nothing (default)
This is the default type for any action plan.

Play a message
The Intelligent Queue port answers the offered call and plays a predefined .wav file that is determined by the
condition. Messages can be static, prerecorded phrases or complex messages made up of a set of
concatenated phrases. Complex messages can include queue condition values, such as number of callers in
queue, call load, and longest waiting call in queue.

NOTE: This is the only type of action plan that can be used if the port is defined as a RAD port. In this case,
the Intelligent Queue port(s) used to play the RAD would be dedicated.

Redirect the call
The call is not answered and is redirected to a predefined destination. Since the call is not answered, no
message is played to the caller, and the caller is unaware of the redirection.

Transfer the call
The Intelligent Queue port answers the call. Once answered, an optional greeting can be played for the caller
and then the call blind transfers to a predefined destination.

Interact with the caller
This type of action plan uses a predefined Interactive Tree that is configured to offer choices to the caller. The
caller makes their selections using their keypad to navigate to the information or destination that they desire.
You can define each digit on the keypad (0-9,*,#) as an option that can perform any one of the following
functions: play amessage, transfer a call, leave a voice callback, collect digits, manage the system, offer a
submenu, go to another choice, repeat the choices, offer Voice callback.

Offer voice callback
The Intelligent Queue port answers the offered call and then prompts the caller for information required by a
predefined voice callback structure.
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Collect digits
This optionmust be purchased and in use on the PBX where Intelligent Queue resides. This option would
prompt the caller to enter a digit string, such as an account number. This account number would be sent to the
ACD agent that eventually answers the call, for screen pop into a desktop application. The number of digits
can be pre-defined, or can be terminated by a digit, such as #, or by a pre-defined duration of silence.

Manage the system
The Intelligent Queue port answers the offered call and then prompts the caller for a password. The caller
enters the password using their keypad. Once the password is validated, Intelligent Queue allows the caller to
record system prompts or change the system’s operatingmode (Emergency or Normal mode) using their
telephone. When a caller chooses to record new system prompts, Intelligent Queue stores the prompts in a
temporary “Inbox” folder. Themessage is named and assigned to an action plan or message list. When the
caller chooses to change the system’s operatingmode, the change is immediate and will be reflected when
Intelligent Queue receives the next call.

Music on hold
You can use Intelligent Queue as amusic on hold source for your telephone system using a PC sound card, if
equipped. Intelligent Queue plays music through the sound card using a rotating (loop) playlist. Music sources
for the playlist include any or all of the following: audio CD, stored .wav file, and storedMP3 file. The playlist
can includemusic or prerecorded informationmessages.

The behavior begins when themusic engine is started, either by theWindows service or via the user interface.
A user with Intelligent Queue administrator rights can start or stop themusic engine from the user interface.
Once started, themusic engine will loop through the play list, playing continuously until it is stopped.

System administration
You can configure andmanage Intelligent Queue through the web-based user interface. The first step is to
authenticate the user name and password. This user name/password combination defines the user’s access
level. Users will generally be granted selected permissions, while administrators will grant themselves full
permissions.Intelligent Queue can run onmultiple servers simultaneously. Whenmultiple instances of
Intelligent Queue are running at once, the system and user IDs are shown at the top right of the user interface
to help users identify which system they aremaking changes to.

Starting/stopping the engines
Themessaging engines start automatically when the operating system is started. You canmanually start or
stop the engines from Services in the Control Panel or through a dialog in the user interface.

Event logging
Event logging is applicable to all incoming and outgoing calls. Event logging begins when a call is first
detected and ends when a transfer terminates the call or hangs up. Each log contains a self-describing record
of the event.

The following events will cause an event to be logged:
l Call received

When a call first enters Intelligent Queue, the system logs all known properties of the call.
l Action plan selected

When Intelligent Queue selects an action plan for a call, the system logs the action plan, as well as the
selection criteria.
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l System action
The system logs all actions taken by the Intelligent Queue port.

l Caller action
The system logs all actions taken by a caller while connected to an Intelligent Queue port.

l Agent action
The system logs the actions that an agent takes while in a callback.

l Callback
The system logs all actions and events of a callback.

Optional functionality
Intelligent Queue consists of four types of optional functionality:

Callback processing
Intelligent Queue processes callbacks on a first in/first out basis. Upon receipt of a callback request, agents
listen to the caller’s message, then either place the call, requeue the request, or reject the request.

Agent call recording
Agent call recording is used for quality monitoring. Intelligent Queue enables you to access administrative
screens and record agents based on agent IDs or extensions.

Call detail reporting
Call detail reporting enables the system to report on Intelligent Queue call activity.

Caller-entered digits
Caller-entered digits enable callers to enter digits with their keypad for identification purposes.

Callback processing
Callback processing consists of

l Voice callback requests
l Web callback requests

Intelligent Queue processes callback requests in a continuous loop using the ports that are dedicated to
callback processing. Each callback queue on the telephone system needs to be created, identifying the group
and priority for the callbacks. Each callback request is submitted with a callback action plan. This structure
defines the ACD path to attempt, the client’s telephone number, the client’s name, the greeting to be played,
queue thresholds, and the language in which the call should be processed. Intelligent Queue processes
callbacks on a ’first in/first out’ basis, but each call has amaximum number of attempts and a retry interval. If
the client does not answer the call, the system requeues the callback request to amaximum number of
attempts. Intelligent Queue will not attempt the callback again until the retry interval has been exceeded.
However, if the callback request reaches a customer’s voicemailbox, the agent can then leave a voicemail
message.

Each callback structure also defines themaximum amount of time the callback port will wait for an agent to
answer, before requeuing the call andmoving to the next request. Upon receipt of a callback request, agents
can listen to the caller’s message, place the call, requeue the request, or reject the request. Callback requests
can be viewed, prioritized, deleted, changed, or executed immediately from the user interface by a user with
administrator privileges.
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Voice callback request
Voice callback allows a caller to request an agent callback instead of staying on the line. You can create
distinct callback profiles based on the type of callback. These profiles enable the agent to understand the
origin of the callback request by providing a specific callback greeting to the customer and an introduction to
the agent.

A voice callback request prompts the caller for the following information:
l A telephone number at which they can be contacted
l The caller’s name (recorded as a .wav file for playback by an ACD agent)
l A confirmation to submit the request

Once the caller provides the information, Intelligent Queue hangs up and records the request in the database
for processing.

Web callback request
Web callback allows a customer to request an agent callback via theWeb. The customer completes aWeb
callback request on an HTML/ASP page that is designed and hosted by the Intelligent Queue customer.
Intelligent Queue then submits the information to the database for callback processing.

A web callback request prompts the caller for the following information:
l The telephone number at which they can be contacted
l The customer’s name (presented as a Text To Speech (TTS) rendition to the ACD agent)
l The target ACD path

Intelligent Queue then submits the information to the database for callback processing.

Agent call recording
Call recording, for quality monitoring purposes, requires that ports be dedicated as recording ports to ensure
availability and to avoid call collisions with incoming calls. Intelligent Queue administration initiates this
functionality and saves all recordings as .wav files.

Using Intelligent Queue, a user with sufficient rights enters an agent ID or extension number to request that a
current call, or the next call received, be recorded. An agent that is being recorded cannot bemonitored by
anyone else at the same time. Once the recording completes, the user can access the recording with
Intelligent Queue Administration to view the success or failure of the request and to play, export, or delete the
recording.

Please check your municipal, provincial/state, and federal laws governing the use of call recording. Agent call
recording is for "ad hoc" recording, and not for recording all agent calls.

Call detail reporting
The Call detail reporting option requires Contact Center Management (version 5 or higher) andMicrosoft Excel
to generate reports. Call detail reporting allows the system to report on the activity of Intelligent Queue. For
example, you can generate a report that lists the choices callers aremaking in the interactive trees. This
option helps you tomake decisions about future call handling and processes, with an eye to continually
improving service and effectiveness. You can create reports based on selections made by in-queue callers to
navigate through Intelligent Queue.
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Planning the number of ports you require
NOTE:

l System requirements change based on the number and type of ports you add.
l Youmust be a registered user to access Mitel OnLine. First time users will be prompted to register and

create a username and password which can be used on all subsequent visits

It is important that you carefully plan the total number of each port type you require before you configure
Intelligent Queue. Visit the Contact Center Portal onMitel OnLine to view the Intelligent Queue port sizing tool
(Excel spreadsheet). Port usage is inherently tied to the amount of traffic that the queues will be getting, as
well as from the frequency of updates, and length of themessages played during the updates. The best way to
determine the number required is to use the Intelligent Queue port sizing tool .

If an action plan calls for RAD messaging, a dedicated port is required. The number of RAD ports required is
based on the volume of calls and of distinct messaging sequences. If an action plan requires one-to-one
interaction, the number of ports required is based on volume.

To access the Intelligent Queue port sizing tool
l Browse to:

http://www.prairiefyre.com/wp-content/rscs/documentation/IntelligentQueuePortSizingUtility.xls.

Types of ports
The type of port(s) you assign to the call flow determines what happens when the caller presses a telephone
digit. Generally, messaging ports shouldmake up the largest percentage of ports. If you do not have voice
callback, you do not need callback ports.

Intelligent Queue uses several types of ports:

Messaging ports
Messaging ports are used for all incoming calls to Intelligent Queue. Messaging ports provide one-to-one
interaction with the caller through interactive trees, messaging, routing, and taking callback requests.
Messages can be either static or dynamic if you have Contact Center Management. Every messaging port is
dynamic unless it is defined as a RAD (Recorded Announcement Device) on the communications system. A
RAD port is a dedicated port that plays the samemessage for up to 50 callers simultaneously.

Management ports
Management ports are a type of messaging port used for emergency and prompts.

Callback ports
Callback ports are dedicated ports used for the outbound portion of callback requests. This type of port
executes the callback with the ACD Agent.

Recording ports
Recording ports are dedicated ports used by supervisors to record ACD calls for quality monitoring purposes.
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Updated position in queue ports
Updated position in queue ports are ports used for the Updated position in queuemessage. A port can play
more than one updated position in queuemessage, however, it sends that message to one caller at a time
only.

NOTE: In order to use Updated position in queue, youmust enable all HCI options on Class of Service
Assignment form 1 (COS 1). See theMitel Intelligent Queue Installation Guide.

Types of messaging ports
Several factors affect the number of messaging ports you require for your Intelligent Queue system:

l the type of messaging: RAD or intelligent messaging (interactive trees)
l the nature of themessage
l the length of themessage
l the number of callers to whom you want to play an Updated position in queuemessage RAD

messaging ports

When programmed on your telephone system as a RAD, Intelligent Queue ports are dedicated to a distinct
messaging sequence. The Class of Service (COS) given to each RAD port has the Recorded Announcement
Device option enabled in the COS. When configured as a RAD, the Intelligent Queue port does not receive
any of the audio or DTMF digits entered by a caller. The telephone system processes the DTMF input instead
of passing the digits to Intelligent Queue.

An Intelligent Queue port that is programmed as a RAD can play messages to callers who are waiting in an
ACD path. The primary function of a RAD is to supply messages to up to 50 incoming calls simultaneously.
This feature is beneficial to companies that want to supply general announcements. Each RAD (or distinct
messaging sequence) requires a dedicated port, a directory number, and its ownClass of Service. The
number of RAD ports in a system depends upon the number of distinct announcements required by the
customer and the call volume.

Up to 50 callers can listen to one RAD simultaneously. Any caller routed to a busy RAD is put on hold until the
recording is finished. When the port clears down, the RAD is seized and all waiting callers receive the
announcement. All calls maintain their position in the incoming queue, either while listening to the RAD or
while queued for service. If an agent becomes free while a caller is listening to a RAD, Intelligent Queue
routes the caller to that agent immediately.

RAD port conditions
RAD ports are not as flexible as intelligent messaging ports and require dedicated ports on Intelligent Queue.
RADs play for up to 50 people at a time, making it impossible to use some of the conditions that make other
ports flexible.

You can apply the following conditions to RAD ports to make themmore flexible:
l Schedule conditions (time of day, day of week, day of year)
l Queue conditions
l Emergency conditions
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You cannot apply the following conditions to RAD ports, because there are up to 50 different callers on the call
at once:

l ANI conditions
l DNIS conditions
l Redirection conditions

The number of Intelligent Queue RAD ports that you require depends on the number of distinct messaging
sequences that you require in your ACD environment, as well as basic traffic requirements. The following
ACD path example requires three Intelligent Queue ports for RAD messaging.

The first port in this scenario identifies the department that the caller has reached. There are two departments
offered (Sales and Support), so the system requires two distinct messages. In both ACD paths, the second
message that a caller hears is a generic, please hold type of message that can be shared between the paths.
Only one port is required for the commonmessage. However, the number of ports requiredmight increase
based on volume.

Intelligent Queue can use a RAD port for the PBX Auto Attendant, because the DTMF is processed by the
PBX. For example, a caller might hear themessage, “If you know the extension of the person you wish to
reach, please dial it now.”

Intelligent call processing ports
When you use an intelligent call processing port, Intelligent Queue handles a single caller at a time. The
amount of time that the port is in use depends on the options given to a caller. You can configure intelligent
messaging ports to execute the following actions: play messages, accept callback requests, collect digits,
manage the system, offer a submenu, go to another point in the tree, replay the greeting, or route callers to
predefined destinations (queue/voicemail/extension). The action the system takes depends on the following
conditions: ANI, DNIS, redirection, schedule, queue conditions, and systemmode. When the port is used to
accept callback requests, Intelligent Queue collects the caller’s information on the intelligent messaging port,
but the actual processing of the callback takes place on a separate, dedicated callback port.

Callback processing ports
Callback ports are Intelligent Queue ports that are dedicated to processing all of the collected callback
requests based on a callback plan. Callbacks are action plans that can be associated with each individual
request, rather than with a predefined port. When an agent answers, the system gives the agent the option to
listen to themessage or place the call. Once the agent places the call, the callback port begins processing the
next request in the database. The number of callback ports required depends on the expected number of
callback requests to be processed.

Recording ports
Recording ports are Intelligent Queue ports that are dedicated to quality monitoring. You can initiate call
recording from the Intelligent Queue user interface. Using Intelligent Queue, a supervisor enters an Agent ID,
extension number, or Agent Group ID to request that the current call or the next call received be recorded.
Once the recording completes, the system notifies the user of the success (or failure) of the request, as well
as the file namewith which the call recording has been stored.
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Updated position in queue ports
A port can play more than one updated position in queuemessage, however, it sends that message to one
caller at a time only. Updated position in queue ports are Intelligent Queue ports that are dedicated to
continually informing customers of their current position in queue. Intelligent Queue tells customers their
queue position when they first enter queue and keeps customers updated throughout their wait as their
position changes. For example, Intelligent Queue states “Three” when the customer is third in line to be
answered. As the customer’s position in queue changes, Intelligent Queue will continue to update the
customer, stating “Two” and then “One.” You add a .wav file to play in front of the position provided by
Intelligent Queue and you configure how often Intelligent Queue will update the customer. For example, “You
are caller number” “Three” can be configured to play once every minute. You specify the number of customers
Intelligent Queue will inform of their Updated position in queue, keeping in mind that each call requires a port.

NOTE: In order to use Updated position in queue, youmust enable all HCI options on Class of Service
Assignment form 1 (COS 1). See the Intelligent Queue Installation Guide.

Types of messages
You can program ports on Intelligent Queue as either RAD or interactive ports. Youmust consider how the
ports are programmed on the system as well as call volumewhen determining the number of ports required.
The number of required RAD ports is based on the number of dedicated ports per distinct messaging
sequence and call volume. The number of required interactive ports is based on how many telephones are
programmed on the system as a device (telephone) and the call volume.

The type of themessage played by a port also has an effect on the number of ports required by Intelligent
Queue. If themessage is generic in nature and can be shared by several applications, the system requires
fewer ports. For instance, if a RAD port plays themessage, “Please hold tomaintain your call priority,” then
more than one ACD group can use this port. If themessage is more specific, a new port is required. For
example, only a sales ACD group would use a RAD port that plays themessage, “Please hold to speak with a
sales representative.”

With Intelligent Queue, you can combine different types of messages within amessaging plan:

Interactive tree messages
Interactive trees play advancedmessages that are played before a caller enters the queue. An initial message
greets callers and lists their options. The caller selects from the options by pressing a telephone digit. The
caller can then navigate throughmultiple options to arrive at the information or ACD path that best suits their
needs.

RAD messages
RAD messages are basic in-queuemessages. Intelligent Queue plays RAD messages to greet callers and
provide advertisements or information while callers wait for an agent. These are “Thank you for holding” type
messages. Messages must be .wav files. Music can be .wav or MP3 files or an external music source such
as an audio CD.

Time in queue messages
NOTE: If you have Contact Center Management version 4.x, and you want to use time in queuemessaging,
youmust have the Client Component Pack installed before you install Intelligent Queue.
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Time in queuemessages are played to a caller while in queue. They are based on real-time ACD statistics,
such as the expected wait time before the call is answered.

This is how Intelligent Queue calculates the expected wait time: If there are agents available: ExpectedWait
Time = (Average Talk Time for the Queue x Calls Waiting in the Queue) / Available Agents, and if there are no
agents available: ExpectedWait Time = Average Time to Answer for the Queue

Updated position in queue messages
Updated position in queuemessages are played to a caller while in queue. They inform customers of their
initial queue position, and keep them informed of their position as it changes, at preset intervals.

Intelligent Queue Updated position in queue will provide the position but will not provide themessage. If you
want the callers in queue to hear amessages, for example, “Your call will be answered next” or “You are in
position...“ youmust record themessage.
See "Recording voice prompts" on page 632.

Length of messages
You should consider the length of themessage that callers hear when determining the number of ports the
system requires. If all of the ports are busy playingmessages to callers, new callers have to wait until the
previous message finishes before they are answered.

Intelligent Queue has no restriction on the length of themessage files, however, the PBX does. Youmust
program the length of themessage in the PBX Class of Service (COS).

Number of ports purchased
The number of Intelligent Queue ports you have purchased is shown on theMitel Options sheet and in the
Intelligent Queue Administrationmenu. Intelligent Queue supports amaximum of 60 IP ports per PBX.

Understanding the call flow process
Mitel ACD, an advanced automatic call distribution feature package that is fully integrated with Mitel
enterprise communications platforms, provides the following capabilities:

l Route calls to themost appropriate group(s)
l Queue and prioritize callers
l Distribute calls fairly within a group—longest idle or highest skilled agent gets the call
l Automatically reroute or expand the availability of agents based on current queue conditions
l Network multiple contact centers together
l In-queuemessaging

Mitel’s ACD functionality allows contact centers to distribute incoming calls to the longest idle agent or the
agents with the highest skill level.

Each ACD agent receives a unique agent ID number. The agent ID number is similar to a telephone directory
number and can be assigned a name in the telephone directory.

You can use agent groups to group agents according to their line of business. Up to four agent groups can be
programmed to an ACD queue. You can assign agent groups to one or more queues. Each queue supports up
to four RAD messages, with the last being replayed as often as required, based on wait time.
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Creating call flows
You can use Intelligent Queue to help determine where each call should go (ACD queue) and what each caller
will hear.

To create a call flow
 1. Assign conditions and actions.

l Define conditions (ANI, DNIS, emergency, queue, redirection and schedule conditions)
l Define actions (callbacks, digit collection, interactive trees, management, messaging and routing)

 2. Assign call flows to port groups.

The ACD queue
The ACD queue is a flexible call routingmethod that provides the information required for handling incoming
calls. The ACD queue controls the resources used, the order in which resources are encountered, and the
timing of the steps. Calls are queued for an agent group based on the call priority and order of arrival at that
path. Queuing is the same for new calls and overflow calls. If an agent group is not available, the system
routes calls to an alternative agent group or "interflows" to another destination. Up to 256 ACD queues are
supported, including one primary agent group and three overflow agent groups per queue.

Queue priority
Each ACD queue is assigned a priority level in the range of one to 64, with one being the highest.

Agent groups
An agent group consists of a logical grouping of agents trained to support a particular type of call. All queues
are routed to one primary agent group and up to three overflow groups. Intelligent Queue supports up to 64
different agent groups to handle incoming ACD traffic.

Call flow
Typically, you program the ACD to ensure that the first call to arrive is routed to the longest idle agent or the
agent with the highest skill level. If multiple agents are free when an ACD call is presented to a group, the
system sends the call to the longest idle agent. Idle time is calculated from completion of an agent’s last ACD
call.

A caller should never receive a busy tone from an available queue. Intelligent Queue handles an incoming
ACD call with the following actions: the caller receives a ringback tone, the RAD timer starts, the interflow
timer programmed in the queue starts, the overflow timer for the primary group in the queue starts, the call
goes to the longest idle/highest skilled agent.

When a trunk picks up a call, it forwards it through to a group of agents handling calls or to another answering
point. The call arrives at the ACD queue of an agent group. The length of time the caller waits in queue is the
queue time. While waiting in queue, the caller listens to product features, announcements, or other messages
provided by a RAD. The caller can wait in queue for an available agent, leave a voicemail message, or
abandon the call by hanging up, depending on how Intelligent Queue and the telephone system have been
programmed.

When an agent is available, the customer connects immediately to the agent. When no agent is available, the
caller automatically queues to the primary agent group in the queue. In both cases, the caller’s communication
path remains unaffected and the caller remains listening to its ringback tone, RAD ormusic on hold. The caller
receives a ringback tone until the first RAD answers, an agent answers, interflow occurs, or the caller hangs
up.
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Overflowing calls
A queue contains one primary agent group and can have up to three overflow groups. The overflow groups
provide backup resources to the primary agent group to ensure that service level goals aremet. Calls that
overflow maintain their position in queue. Agent group overflow timers determine how long a call waits before
overflowing.

Intelligent Queue places an ACD call that is not answered immediately in a queue. If an agent does not pick
up the call after a set amount of time (the overflow time), the system places the call in the queue of another
agent group, in addition to keeping it in the first group. The first available agent in either group handles the call.
The overflow feature limits the delay for callers by queuing calls against two or more agent groups.

Interflowing calls
You can program the telephone system to direct a call to voicemail or to another answering point. The
interflow timer runs independently of the overflow timer. If the interflow timer expires, the system removes the
call from the queue and redirects it to another answering point, such as a trunk or voicemail.

Interflow is a time- or load-based feature that takes an ACD call out of the queue and routes it to the interflow
answer point (if one is programmed). A call that interflows to another queue adopts the priority of the => queue
and does not look back for an agent to become available from the initial queue in the following instances: the
new queue has Interflow to this path uses this path priority set toYes in its Path Assignment form, or the call
interflows from a queue that has a priority of 64.

Otherwise, the call’s priority does not change.

Setting up Intelligent Queue
This section includes information on

l Administration procedures
l Configuring ports, PBX settings, Contact Center Management settings, Music Manager, and Updated

position in queue
l Managing actions
l Managing conditions
l Managing call flows
l Managing port groups
l Viewing the status of a queue

Administration procedures
In this section, you will learn how to

l Log on and off as an administrator
l Enter your purchased options
l Set up administrator and user permissions
l Change systemmodes
l Change passwords
l Set up the automatic backup
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Logging on and off for the first time (Administrator)

CAUTION:Your toolbars and your firewall might interfere with your ability to view Intelligent Queue. Ensure
you have turned off any pop-up blockers found on your tool bars, andmade the Intelligent Queue site an
exception on your firewall. To turn off theMicrosoft Pop-up Blocker, click Tools=>Pop-up Blocker=>Turn Off
Pop-up Blocker.

Once the installation completes successfully, you can log on to the Intelligent Queue server for the first time.
The initial logon opens the System options window, which requires you to select your purchased options and
enter the number of licensed ports. Consult your MOSS Options Sheet, enter your Mitel Options password
(MOP), and save the settings.

To log on to Intelligent Queue from the server computer
 1. In Internet Explorer, type http://[your server address]/Intelligent Queue.

The Login window opens.
NOTE:Alternatively, you can launch the application from the Start menu.

 2. After Login, typemitel.
NOTE:mitel is the default user name you will use until you set up your administrator account. You will
need to create your own user account as "mitel" is proprietary. After you create an administrator’s
account and log out, you can log back on with your new account information.

 3. AfterPassword, type setup.
 4. Click OK.

The Initial setup window opens.
 5. Click OK.

The Purchased options window opens.
See "Entering your purchased options" on page 581.
NOTE:After you save your options, your Mitel Options password becomes the password for theMitel
account.

Logging off
To log off Intelligent Queue

l Click Logout in the toolbar.
The login page opens.

Logging on as an administrator after initial setup
To log on to Intelligent Queue from the server computer
 1. In Internet Explorer, type http://[your server address]/Intelligent Queue

The Login window opens.
NOTE:Alternatively, you can launch the application from the Start menu.

 2. After Login, type the user name you created during initial setup.
 3. AfterPassword, type the password that you created during initial setup.
 4. Click OK to launch Intelligent Queue.
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Entering your purchased options
To enter your purchased options
 1. AfterSelect the product key, verify your Mitel Product Key matches theMOSS Options Sheet.

NOTE:YourMitel Product Key is entered by default.
 2. Using your MOSS Options Sheet, enter your Mitel Options password, the system options and the

number of ports you purchased.
 3. Click Save. If the information you entered is correct, menu items will open. Themenu items correspond

to your purchased options. If the information you entered is not correct, the Incorrect selection window
opens.

 4. If you entered incorrect information, click OK to return to thePurchased Optionswindow to correct
your entries.

 5. Click Save.

Setting up administrator and user permissions
Only an administrator should create user accounts. First, create an administrator account with all
permissions, including theManage user accounts permission. Then, create user accounts with selected
permissions.

Creating an administrator account
To create an administrator account with full permissions
 1. Click Administration=>Manage users.
 2. Type a user name and password.

NOTE: The user name and password are case sensitive.
 3. Re-type the password for confirmation.
 4. Click Select all to give the account full permissions.

NOTE:Allow login and View system status are selected by default for every user.
 5. Click Save.

Intelligent Queue adds the user name to the Users list.

After you create an administrator account, you can create user accounts.

Creating a user account
To create a user account with selected permissions
 1. Click Administration=>Manage users.
 2. Type a user name and password.

NOTE: The user name and password are case sensitive.
 3. Re-type the password for confirmation.
 4. Select the permissions you want to assign to the user account.

NOTE:Allow login and View system status are selected by default for every user. If you select
Configure ports, Manage port groups will be selected by default.

 5. Click Save.
Intelligent Queue adds the user name to the Users list.
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Changing system modes
A user with the proper permissions can control the operatingmode of Intelligent Queue. The operatingmode
determines incoming call handling. If the system or port group is operating in a normal state, Intelligent Queue
handles the call according to its assigned call flow conditions. If the system or port group is operating in
Emergency mode, the system ignores the assigned conditions and follows a special call flow.

To change systemmodes
 1. Click Administration=>System mode.
 2. Select a systemmode.

l InNormal state, port groups follow a normal call flow pattern, except for port groups that have been
placed into an emergency call flow pattern.If the systemmode is in Normal state, Intelligent Queue
checks the port group to see if it is in an Emergency state.

l InEmergency state, port groups follow an emergency call flow pattern.The emergency call flow is
followed without checking the state of the port groups.

 3. UnderNormal state andEmergency state, select individual or multiple port groups, and then click the
appropriate arrow tomove your port groups between Normal and Emergency states:
l Click >> to move all Normal state port groups into Emergency state.
l Click > to add selected Normal state port groups into Emergency state.
l Click < to add selected Emergency state port groups into Normal state.
l Click << to move all Emergency state port groups into Normal state.

 4. Click Save.

Changing passwords
Once logged in, any user can change their own password. However, if a user forgets their password and is
unable to log on, only an administrator can clear the password field of that user account and enable the user to
log on and change their password. Alternatively, the administrator can assign a password to the user and
enable the user to log on and change their password.

NOTE:Only users with theManage user accounts permission can access theManage users menu item.

To change your user password
 1. Click Administration=>Change password.

The Change password window opens. The Current user name field is populated by default.
 2. Type your old password.
 3. Type a new password.
 4. Re-type the new password for confirmation.
 5. Click Save.

If a user forgets their password and is unable to log in, they can contact an administrator to clear the password
field. The user can then log on to Intelligent Queue and create a new password. Alternatively, the
administrator can assign a password to the user. The user can log on with that password and change it to a
new password.

To clear the password field of a user account
 1. Click Administration=>Manage users.

NOTE:Youmust have administrator privileges, including theManage user accounts permission, to
access this option.

 2. UnderUser name, type the name of a user or select a name from the list.
The Change password button is enabled.
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 3. Click Change password.
 4. Clear thePassword field.
 5. Click Save.

The user can now log on using their login name and no password. After logging on, they create a new
password for themselves in the Change password window.

Setting up the automatic database backup
NOTE:Maintenance Servicemust be running to perform the automatic backups.

Intelligent Queue introduces automatic database backups in Version 5.2. Besides being able to configure the
interval of the backups, you can also configure the time of day at which the backup occurs, and the number of
files you want Intelligent Queue to keep. The automatic backup is performed by theMaintenance Service.

The automatic backup files are kept in the Intelligent Queue installation directory, under Data\Automatic
Backups\ directory. Unless the user changes the default installation folder, the application installs in the
directory C:\Program Files\Mitel\6160. The files are named Autobackup_<day of week>, <date>.xml., for
example, Autobackup_Sunday, December 24, 2006.xml.

TheGlobalSettings.xml file controls when and if the automatic backup occurs. In the GlobalSettings.xml file,
you will see the following <AUTOBACKUP> section.

<AUTOBACKUP>
<ENABLED>true</ENABLED>
<INTERVAL>2</INTERVAL>
<TIMEOFDAY>3:00</TIMEOFDAY>
<MAX_BACKUP>50</MAX_BACKUP>

</AUTOBACKUP>

Enabling the automatic backup
To enable the automatic backup
 1. In the Intelligent Queue installation directory, under \XML\Config\, locate theGlobalSettings.xml file.
 2. Between theENABLED tags, type true.

Disabling the automatic backup
To disable the automatic backup
 1. In the Intelligent Queue installation directory, under \XML\Config\, locate theGlobalSettings.xml file.
 2. Between theENABLED tags, type false.

Assigning the interval of the automatic backups
You can configure the interval of the backups. We recommend the default interval of every two days, but you
can configure Intelligent Queue to perform backups more often or less often.

l Select 1
Intelligent Queue will back up the database once every day.

l Select 2
Intelligent Queue will back up the database once every two days.

l Select 3
Intelligent Queue will back up the database once every three days, etc.
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To assign the interval of the automatic backups
 1. In the Intelligent Queue installation directory, under \XML\Config\, locate theGlobalSettings.xml file.
 2. Between the INTERVAL tags, type a number.

The number represents the number of days between automatic backups.

Assigning the time of day of the automatic backup
NOTE:When assigning the time of day, youmust use the 24 hour clock, for example, 22:00 represents 10:00
P.M.

To assign the time of day of the automatic backup
 1. In the Intelligent Queue installation directory, under \XML\Config\, locate theGlobalSettings.xml file.
 2. Between the TIMEOFDAY tags, type the time at which the automatic backup will occur, using the 24

hour clock.

Assigning the number of backup files to keep
NOTE: Intelligent Queue, by default, keeps 50 backup files. Each file represents 1 backup, so 50 files equals
50 backups. Only themost current files are kept.

To assign the number of backup files to keep
 1. In the Intelligent Queue installation directory, under \XML\Config\, locate theGlobalSettings.xml file.
 2. Between theMAX_BACKUP tags, type the number of backup files you want to keep.

Each time you backup you produce one file.

Configuring ports
NOTE: If you add or remove ports after the initial installation, you need to restart the services on the System
status window. See the Intelligent Queue Installation Guide or "Viewing system status" on page 617 for more
information about restarting the system.

You initially configure ports outside of Intelligent Queue, which reads the registry for the PBX, extension
number and port group. From within Intelligent Queue, you can add editorial comments to each port.

To configure your ports
 1. Click Configure=>Ports.

The Configure Ports window opens.
 2. Verify the extension numbers are correct for each port.

NOTE: The extension numbers must be present and correct.
 3. To add a comment for a particular port, click Edit in the appropriate row.

A text box opens underComment. Edit is replaced by Update and Cancel.
 4. Type a comment in theComment text box and click Update to save the comment.
 5. To navigate throughmultiple pages of listings, click Previous orNext.

Configuring PBX settings
Intelligent Queue version 5 supports multiple PBXs configured on the same system. Although your PBX
settings are populated at login, you can configure each PBX on the PBX Settings window.
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Manually configuring PBX settings
Tomanually configure your PBX settings
 1. Click Configure=>PBX settings.

The PBX settings window opens.
 2. If themedia server type is SX-200 ICP, underSX-200 ICP, select the check box across from themedia

server.
If you have an SX-200 ICP, and do not select the check box, the Intelligent Queue system will not
connect to the SX-200 ICP server.
If you have changed to an SX-200 ICP from a different type of media server, you need to restart the
services for the new setting to take effect.
See "Viewing system status" on page 617.

 3. Click Ping to test a PBX connection.
The ping results open in the Results box.

 4. Click Edit in the appropriate row to add or edit a silent monitor code, ARS digits, external digits, and a
media name for a PBX.

 5. Click Update.
 6. Click Save.

NOTE:When you save PBX settings, the Intelligent Queue services require at least 20 seconds to
save your changes to the server. The length of time is based on the complexity of the call flows. You
can continue working during this period.

Configuring Contact Center Management settings
If you have installed both Contact Center Management and Client Component Pack, configure your Contact
Center Management settings.

To configure your Contact Center Management settings
 1. Click Configure=>Contact Center Management settings.

The Settings tab opens.
 2. AfterAddress, type the host name or IP address of the Contact Center Management server.
 3. AfterPort, the port of the Contact Center Management server number is shown by default.
 4. Click Ping to test your Contact Center Management connection.
 5. Click Save to save your IP address and port configuration.
 6. To query a queue/path, underContact Center Management queue/path, select a queue/path from the

list box.
 7. Click Get queue statistics.

Results displays the number of agents in queue.
 8. Click Refresh queue to refresh the list box.
 9. Click Clear results to clear the Results box.

Configuring Music Manager
Intelligent Queue uses Music Manager to uploadmusic files and configure playlists from those files. Music
Manager plays a continuous loop of the playlist in the background of Intelligent Queue. Themusic in a playlist
is what callers hear when they are on hold. After callers hear amessage, Intelligent Queue places them in a
queue where they hear the playlist until an agent answers the telephone. The playlist can contain CD songs,
MP3 files and/or .wav files. The play list can includemusic or pre-recorded informationmessages.
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To create a playlist
 1. Click Configure=>Music Manager.

The Play List tab opens.
 2. AfterMedia type, select a file type.
 3. To add a track to the playlist, select one of more tracks from the list box and click >.

NOTE:You can select multiple files by holding down theCtrl key while selecting files. To select a
range of files, hold down theShift key, select the file at the top of the range and then select the file at
the bottom of the range. All files in between will be selected.

 4. Repeat steps 2 and 3 to add other media types to the playlist.
NOTE:Within theWindows environment, you can also copy multiple music files into themusic folder.
If you accepted the default settings during installation, the default path name to your music folder is
Program Files\Mitel Networks\Intelligent Queue\Music

 5. To navigate through the playlist, click Previous orNext.
 6. To delete a file from the playlist, click Remove beside the track name you wish to delete.
 7. Click theUpload files tab to select files to upload to the server.
 8. Click Browse to navigate to a file you want to upload.
 9. Click Add to add the file to the Upload file list.
 10. If you want to remove a file you added to the list, click Remove.
 11. If you want to remove all files you added to the list, click Remove all.
 12. To save the list of files to the server, click Upload.
 13. Click theVolume tab to adjust the volume of music on hold.
 14. For each volume level type, click the appropriate radio button (10 is loudest) under each level. Tomute a

sound type, selectMute beneath the appropriate volume level.
NOTE: TheMaster volume level increases/decreases the system volume. When you adjust the
volume of music on hold, you are also adjusting the server volume.

Disabling Windows sounds
Windows sounds play through themusic on the playlist. If you use the Intelligent Queue server as amusic on
hold source, youmust disable these sounds.

To disableWindows sounds
 1. InWindows, navigate to theControl Panel.
 2. Double-click Sounds and Multimedia.
 3. Click theSounds tab.
 4. UnderScheme, click No Sounds.
 5. Click Apply.
 6. Click OK.

Preventing CDs from starting automatically
You do not want your CD-ROM to start automatically, because if you insert a CD while music on hold is on,
the caller will hear both themusic from the playlist andmusic from the CD. Youmust alter the registry to
disable the AutoRun feature.

To disable the AutoRun feature
 1. In the registry, navigate toHKEY_LOCAL_

MACHINE\System\CurrentControlSet\Services\CDRom.
 2. Set theAutoRun value to 0.

In addition, you canmanually prevent a CD from running by pressing the Shift key when you close the CD
tray.
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Removing a music file from the play list
To remove amusic file from the play list
 1. Click Configure=>Music Manager.

The Play List tab opens.
 2. UnderPlay List, select themusic file(s) you want to remove from the playlist.
 3. Click Remove to remove the selected files from the playlist. Click Remove all to clear the entire

playlist.

Adjusting music volume
You can adjust the volume of the .wav or .mp3message files, the volume of the CD, or the system volume
level.

To adjust themusic volume
 1. Click Configure=>Music Manager.

The Play List tab opens.
 2. Click theVolume tab.

The Volumewindow opens.
 3. For each volume type, click the appropriate radio button (10 is loudest) to set the volume level. Tomute

a sound type, selectMute beneath the appropriate volume level.
NOTE: TheMaster volume level increases/decreases the system volume. When you adjust the
volume of music on hold, you are also adjusting the server volume.

Configuring Updated position in queue
CAUTION:

l In order to use Updated position in queue, youmust enable all HCI options on Class of Service
Assignment form 1 (COS 1). See the Intelligent Queue Installation Guide.

l Updated position in queuemessages for the queuemust be programmed to play less frequently than
RAD messages for the queue, otherwise, the RAD messages will not play. The Updated position in
queuemessage frequency is configured in Intelligent Queue. Click Configure=>Updated position in
queue. The RAD message frequency is programmed on the switch.
See "Receiving an Updated position in queuemessage" on page 652.

l In amulti-PBX scenario, a queue will play Updated position in queuemessages only when the port
group and the queues are on the same PBX. For example: PBX A has both Port Group 1 andQueue 1.
PBX B has no port group but has Queue 2. You can play Updated position in queuemessages on
Queue 1. You cannot play Updated position in queuemessages onQueue 2 because no ports are
available. Youmust add an Updated position in queue port group to PBX B, restart the system from the
Intelligent Queue Status>System Status page, and then create an Updated position in queue port group
for PBX B.

Updated position in queue definitions:

Available queues
Available queues are all of the queues in your contact center. All queues are programmed in Contact Center
Management. See "Configuring Contact Center Management settings" on page 585.

Monitored queues
Monitored queues are the queues for which callers will receive updated positionmessages.
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Disabled
Selecting Disabled prevents the callers from receiving the updated positionmessage.

Do not inform callers if their positions in queue drop
If a caller’s position in queue drops, because higher priority callers arrive in queue, do not inform the caller. The
caller will continue to hear the highest position obtained. For example, a caller who was third in queue, who
dropped to seventh in queue, will continue to hear “You are caller number three.”

Initial delay to update callers in queue
Initial delay to update caller in queue is the duration between when callers arrived in queue and when they are
informed of their queue position. For example, if you configure five seconds, Intelligent Queue informs callers
of their initial position five seconds after they arrive in queue.

Frequency to update callers in queue
Frequency to update callers in queue is the duration after the start of the previous message, when callers are
informed of their updated positions. For example, if you configure twominutes, Intelligent Queue informs
callers of their updated positions every twominutes. The initial update occurs twominutes after the start of
the previous message.

Maximum position to report
Maximum position to report is the number of callers who will receive the updated positionmessage.

Default message plan for positions
The default message plan is the plan used to inform callers of their position in queue. For example, “You are in
position five.”

Before you configure Updated position in queue messages
Before you can configure an Updated position in queuemessage, youmust

l Ensure you are connected to Contact Center Management.
The connection to Contact Center Management provides Intelligent Queue with real-time data. When
you are connected the list of queues is available on the Updated position window.
(Configure=>Updated position in queue.) See "Configuring Contact Center Management settings" on
page 585.

l Ensure amedia server, site, and Updated position in queue are configured in Contact Center
Management.
To create amedia server, site, and queue, see the YourSite chapter of theContact Center Solutions
User Guide.

l Configure telephone system settings.
Updated position in queue functionality is dependent on the information provided by Contact Center
Management, so youmust ensure you are pointing to the correct PBX. For example, if themedia server
in Contact Center Management is named “London” not 10.1.1.123, you need to ensure the PBX
Intelligent Queue is pointing to is “London” and not 10.1.1.123. See "Configuring PBX settings" on page
584.

l Create a Updated position in queue port group.
An Updated position in queue port groupmust be configured on themedia server on which the queue
resides. For example, if the updated position in queue is on 10.1.1.123, you need to create an Updated
position in queue port group on 10.1.1.123 as well, and assign ports to it. See "Managing port groups:
updated position in queue, messaging, callback, and recording ports" on page 615.
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Configuring Updated position in queue for all queue positions
To configure an Updated position in queuemessage for all queue positions
 1. Click Configure=>Updated position in queue.
 2. AfterAvailable queues, select a queue from the list for which you want to provide callers with updated

positions in queue.
 3. Click Add.

The queue will open under Monitored queues.
 4. AfterMonitored Queues, if you have selectedmore than one queue, drag the queues to arrange them

by priority, the top queue being the highest priority queue.
 5. Select the queue for which you want to provide an updated positionmessage.
 6. After Initial delay to update callers in queue, select the number of minutes/seconds after which the

caller arrives in queue, before the caller is informed of his position.
For example, you can configure Intelligent Queue to inform callers of their position five seconds after
they arrive in queue.

 7. After Frequency to update callers in queue, select the number of minutes/seconds after the start of
the previous message, that callers will hear their updated position.
For example, you can configure Intelligent Queue to inform callers of their updated positions every two
minutes. The initial update occurs twominutes after the start of the previous message.

 8. AfterDefault message plan for positions, select themessage plan, previously configured, to use as
the updated positionmessage. For example, "You are in position five."
Intelligent Queue Updated position in queue will provide the position but will not provide themessage. If
you want the callers in queue to hear amessages, for example, "Your call will be answered next" or
"You are in position..." youmust record themessage.
See "Recording voice prompts" on page 632.

 9. AfterMaximum position to report, type the number of callers in each queue whowill receive the
updates.

 10. Click Save.

After you have configured a default message that will play to all queues, you can optionally configure a unique
message for specific queue positions.

Configuring Updated position in queue for specific queue positions
To configure an Updated position in queuemessage for specific queue positions
 1. Click Configure=>Updated position in queue.
 2. Click theView and edit individual positions tab.
 3. Select the position. For example, select Position 1.
 4. Click Edit.

The default message, configured on the Settings tab, is displayed. Youmust edit themessage plan to
add themessage you want to play for specific queue positions.
Intelligent Queue Updated position in queue will provide the position but will not provide themessage. If
you want the callers in queue to hear amessages, for example, "Your call will be answered next" or
"You are in position..." youmust record themessage.
See "Recording voice prompts" on page 632.

 5. UnderRange programming, afterAssign the following message plan, select themessage plan.
 6. After from the positions, select the position with the highest priority for which themessage will be

played.
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 7. After to, select the position with the lowest priority for which themessage will be played.
If themessage is unique to just one position, then select the same position twice. For example, if the
message "Your call will be answered next" is unique to the position in priority one, then select "from the
positions 1 to 1 inclusive."

 8. Click Save.

Creating action plans
An action plan is a set of call handling instructions that defines how tomanage a specific call. An action plan
begins upon selection and carries a call for the duration of its existence within Intelligent Queue. This section
details how to configure the following types of action plans:

l Unverified collected digits
l Verified collected digits
l Interactive tree
l Messaging
l Emergency messaging
l Management
l Routing

NOTE:When you save an action plan, the Intelligent Queue services require at least 20 seconds to save your
changes to the server. The length of time depends on the complexity of the call flows in the action plan. You
can continue working during this period.

Creating unverified collected digits plans
You can use the unverified collected digits plan in conjunction with Contact Center Screen Pop only. Digits
are collected by Intelligent Queue and transferred to Contact Center Screen Pop to process.

The unverified collected digits option prompts the caller to enter a digit string, such as an account number. The
account number is sent to the desktop PC of the ACD agent who eventually answers the call. The number of
digits can be predefined or can be terminated by a digit, such as #, or by a predefined duration of silence.

To create an unverified collected digits plan
 1. Click Manage=>Actions=>Unverified collected digits.
 2. UnderPlan Name, type a new plan name or select an existing plan.
 3. AfterGreeting message, select a greetingmessage from the list box.
 4. After Terminating digit, type a digit the caller can press to indicate they have nomore digits to enter.

The terminating digit is optional.
 5. Type themaximum number of digits to be collected.
 6. AfterNo digit timeout, type the number of seconds the caller has between DTMF digit keypresses

before the system times out.
 7. Click Save.
 8. Click theAction to take tab.
 9. AfterDigits collected, select an action to take if digits are successfully collected.

l If you click None, control will return to the call flow.If the collect digits plan was invoked from an
interactive tree, themenu is played. If the collect digits plan was assigned as the action, the call
hangs up.

l If you click Action, select an action plan type (message, routing, or interactive tree) and then select
an action plan from the list box.The selected action plan will be followed if digits are successfully
collected.

 10. AfterNo digits collected, select an action to take if digits are not collected.
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l If you click None, control will return to the call flow.If the collect digits plan was invoked from an
interactive tree, themenu is played. If the collect digits plan was assigned as the action, the call
hangs up.

l If you click Action, select an action plan type (message, routing, or interactive tree) and then select
an action plan from the list box.The selected action plan will be followed if digits are successfully
collected.

 11. Click Save to save your configuration, or click New to clear the fields and create a new unverified
collected digits plan.

To delete an unverified collected digits plan
 1. Click Manage=>Actions=>Unverified collected digits.
 2. UnderPlans, select a plan.
 3. Click Delete.

NOTE:A confirmation dialog box will ask you to confirm before deleting an unverified collected digits
plan. If you try to delete an unverified collected digits plan with associated plans, amore detailed
confirmation box will open that allows you to view the associated plans before you can proceed with the
deletion. Deleting the selected plan will only remove the reference to the associated plans.

Creating verified collected digits plans
NOTE: Intelligent Queue cannot read words. For Verified collected digits action plans, youmust use string
values that represent numbers. (String values are numbers that are not mathematically manipulated.) Ensure
that all columns included in your SQL statement are string type columns. If you do not use string type
columns, the query will not run successfully. The readback values must also be strings, between -
999,999.999 and 999,999.999.

Intelligent Queue can respond to callers' inquiries in one of four ways: produce an action based on a true
response, produce an action based on a false response, send the caller to a dialable number, or read back
digits/values.

After customers press telephone digits, Intelligent Queue can read back the digits and read values accessed
from a database in all supported language (US English, UK English, NA French, EU French, EU Spanish, LA
Spanish, or Dutch). Dollars, cents, euros, pence, pounds, negative numbers, and decimal numbers, although
supported in all languages, are provided in US English and UK English only. Youmust record your own .wav
files if you want them in additional languages.

Digit read back
If you want your customers to hear a number one digit at a time, Intelligent Queue now gives you that option.
Generally, digit read back is preferred for phone numbers and account numbers. Instead of reading back “nine
hundred eighty-seven,” Intelligent Queue digit read back states “nine, eight, seven.” Digit read back is
available in all supported languages.

Digit read back for verification
With an advanced verified collected digits query, Intelligent Queue verifies the digits customers press. For
example, after pressing the digits of an extension, customers will hear “You have entered nine, eight, seven.”
You can configure Intelligent Queue to permit customers to change their digit selection after read back.
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Database value read back
Intelligent Queue, using the verified collected digits action plan, compares digits customers press to a list in a
database. For example, you create a database table that contains two columns: the customers' account
numbers and the customers' bank balances. Next you create a verified collected digits action plan that
collects the account numbers. The advanced query first checks the account numbers column. If the account
numbers column contains the digits pressed, the query checks the account balance for that row and Intelligent
Queue will audibly state the customer's account balance. “Your account balance is nine hundred eighty-
seven.”

Previously collected digits
With Previously collected digits, customers dial the requested digits just once, but can perform many actions
that depend on the digits. For example, customers who provide a bank account number once can perform
many future actions which depend upon that account number, without having to reenter the account number
again.

You can create a verified collected digits plan in four steps:
 1. Select the type of collected digits
 2. Configure ODBC database parameters
 3. Select an action to take

Before you create a verified collected digits plan, youmust create anODBC (Open Database Connectivity)
connection to a valid data source.

Creating ODBC connections
When you create a verified collected digits plan, you specify a data source against which Intelligent Queue
compares the collected digits. To connect to a data source, youmust first create anODBC connection.
Intelligent Queue officially supports three data source formats:

l SQLServer
l Microsoft Access
l Microsoft Excel

Creating an ODBC connection for SQL Server
To create anODBC connection for SQL Server
 1. InWindows, navigate to theControl Panel.
 2. Double-click Administrative Tools.
 3. Double-click Data Sources (ODBC).

TheODBC Data Source Administrator window opens.
 4. Click theSystem DSN tab.
 5. Click Add.

The Create New Data Source window opens.
 6. Select SQL Server and click Finish.

The Create a New Data Source to SQL Server window opens.
 7. Specify your ODBC data source information and click Next.

Your SQL Server can be local or remote.
 8. ClickWith SQL Server authentication using a login ID and password entered by the user.
 9. Verify the Login ID and Password are valid for the database you selected in the previous window.
 10. Click Next.
 11. Check Change the default database to and select a database from the list.
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 12. Click Next.
 13. Click Finish.
 14. If you want to test your ODBC connection, click Test Data Source. Otherwise, click OK to complete

the ODBC setup.
TheODBC connection is now available on the System DNS tab.
NOTE: It is highly recommended you test the ODBC connection before using it with Intelligent Queue.

Creating an ODBC connection for Microsoft Access
To create anODBC connection for Microsoft Access
 1. InWindows, navigate to theControl Panel.
 2. Double-click Administrative Tools.
 3. Double-click Data Sources (ODBC).

TheODBC Data Source Administrator window opens.
 4. Click theSystem DSN tab.
 5. Click Add.

The Create New Data Source window opens.
 6. SelectMicrosoft Access Driver.
 7. Click Finish.

TheODBC Microsoft Access Setup window opens.
 8. Specify a data source name.
 9. Click Select.
 10. Browse to the Access database you want to use and click OK.
 11. Click OK to complete the ODBC setup.

Creating an ODBC connection for Microsoft Excel
If you useMicrosoft Excel as your data source, you need to specify which section of the spreadsheet will be
used as the database “table.”

To format a spreadsheet for use with Intelligent Queue
 1. Open the spreadsheet you want to format.
 2. Highlight the region of the spreadsheet you want to define as a table.

NOTE: The first row in the regionmust be the column names.
 3. Click Insert=>Name=>Define.

The Define Namewindow opens.
 4. Type the name for the region you highlighted.

The name you type is the database table name of the region.
 5. Click OK.

To create an ODBC connection for Microsoft Excel
NOTE: If the IQ server is not on the same Active Directory as the computer hosting the excel file, the ODBC
connection will be invalid.
 1. InWindows, navigate to theControl Panel.
 2. Double-click Administrative Tools.
 3. Double-click Data Sources (ODBC).

TheODBC Data Source Administrator window opens.
 4. Click theSystem DSN tab.
 5. Click Add.

The Create New Data Source window opens.
 6. SelectMicrosoft Excel Driver.
 7. Click Finish.

TheODBC Microsoft Excel Setup window opens.
 8. Specify a data source name.
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 9. Click Select Workbook.
 10. Browse to the Excel document you want to use and click OK.
 11. Click OK to complete the ODBC setup.

Selecting the type of collected digits
The Parameters tab specifies the type of digits you will be collecting: ANI, DNIS, a user-entered digit string,
or a previously collected digit string. If you select ANI or DNIS, Intelligent Queue will automatically collect
these digits from the call detail information.

With a Previously collected digit string, customers dial the requested digits just once, but can perform many
actions that depend on the digits. For example, customers who provide a bank account number once can
perform many future actions which depend upon that account number, without having to reenter the account
number again.

To select the type of collected digits
 1. Click Manage=>Actions=>Verified collected digits.

The Verified collected digits window and the Parameters tab opens.
 2. UnderPlan name, type a new plan name or select an existing verified collected digits plan from

Plans.
 3. If you want to collect the digits of the telephone number of the caller, select ANI.
 4. If you want to collect the digits of the telephone number the caller dialed, select DNIS.
 5. If you want to prompt the user to type a digit string, select User collected digits, or if you want to use

digits the user already typed, select Previously Collected Digits.
NOTE:You can program one type of message to follow another type of message. For example, you
can team the confirmation and the instructionmessage, so that Intelligent Queue reads back the
digits dialed by the caller, and then gives the caller the option to continue by pressing 1, or to correct
the digits dialed by pressing STAR.
Configure the following options:
l Greeting message

Select amessage that prompts the user to enter digits.
l Confirmation message

Select amessage that confirms the digits dialed, for example, “You have entered...”
l Instruction message

Select amessage that instructs the customer to dial digits, for example, “Press 1 to confirm,
STAR to retry.” The caller gets a preset number of attempts to retry after which, an error
message plays and Intelligent Queuemoves the call to the fail path.

l Terminating digit
Type a digit the caller can press to indicate they have nomore digits to enter

l Maximum digits to be collected
Type themaximum number of digits to be collected for the digit string.

l No digit timeout (seconds)
Type the number of seconds the caller has between DTMF digit keypresses before the system
times out.

l Number of attempts
Type the number of attempts to press a valid digit a caller is allowed before Intelligent Queue
moves the call to the fail path.

l Timeout message
Select amessage that plays if a user does not press a digit within the time you specified in the
No digit timeout option.

l Message to be played before retrying
Select amessage that plays before the caller retries pressing digits.
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l Error message
Select amessage that plays when the caller fails to enter a valid digit string within themaximum
number of attempts.

 6. Click Save.

Readback parameters
The Readback Parameters tab specifies Verified Collected Digits readback information.
NOTE:

l Dollars, cents, euros, pence, pounds, negative numbers, and decimal numbers, although supported in
all languages, are provided in US English and UK English only. Youmust record your own .wav files if
you want them in additional languages.
See "Recording voice prompts" on page 632.

l To view a list of readback .wav file names, such as Dollars.wav, see Table 18 - 10. Dollars, cents,
euros, pence, pounds, negative numbers, and decimal numbers, although supported in all languages,
are provided in US English and UK English only. Youmust record your own .wav files if you want them
in additional languages. The files are located in the following directory: \\Voice\language\System\.
There are ten language folders: US English, UK English, NA French, EU French, EU Spanish, LA
Spanish, Dutch, Brazilian Portuguese, SimplifiedMandarin Chinese, and Italian. See "Recording voice
prompts" on page 632.

To select the type of collected digits
 1. Click Manage=>Actions=>Verified collected digits.

Select the Readback Parameters tab.
 2. Configure the following options:

l Readback language
Select the language Intelligent Queue uses to respond to customer queries.

l Gender of the word following the number
If themessage will be in a language where numbers can be either feminine or masculine, select
the appropriate gender of the number, depending on the word following the number. The word
following the number will be the readback variable unless you have selected “Number” as the
readback variable.

l Readback variable
Select the readback variable, such as dollar, euro, pound, number (for example the amount “nine
hundred, eighty-seven”), or digit (for example, the account number “nine, eight, seven”).

l Response message
Select amessage that is a response to the customers request, for example, “Your account
balance is...”

l Response instruction message
Select amessage that both provides a response to the customer’s request and instructs the
customer to dial digits, for example “Press 1 to confirm. Press STAR to retry.”

 3. Click Save.

Configuring ODBC database parameters
TheODBC Parameters tab specifies the database used in the collected digits verification and the parameters
used to define the query.

Intelligent Queue enables you to verify the collected digits using either a simple or an advanced query. The
simple query configuration prompts you for a database table and column. Intelligent Queue automatically
creates a query based on this information that compares the collected digits to all the values in the column.
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An advanced query configuration requires you to write your own query using SQL. An advanced query is more
complicated to configure than the simple query but it provides more options when evaluating collected digits.

NOTE: The collected digits are saved as strings so the values you compare them against must also be
strings. Verify that any columns included in your SQL statement are string type columns. If you do not use
string type columns, the query will not run successfully. There are workarounds to this, particularly with the
advanced query, but we recommend you use string values to avoid errors.

Configuring a simple query
For an action plan with a simple query, you enter a database table name, a column name, and optionally, a
readback column name. After Intelligent Queue receives a collected digit string, it compares the value with all
the values in the database column. If the value exists anywhere in the column, the query returns a value of
True and the appropriate action follows, as selected in theQuery returned true section on theAction to take
tab. If the value does not exist, the query returns a value of False, and the action selected in theQuery
returned false section of theAction to take tab follows.

To configure a simple query
 1. In theVerified collected digits window, select theODBC Parameters tab.
 2. AfterODBC Database system DSN, select the data source you want to use to verify the collected

digits.
NOTE: The data sourcemust be on the same domain/work group as the Intelligent Queue server.

 3. Type a valid user name and password for the data source you selected.
 4. AfterQuery type, select Simple.
 5. AfterDatabase table name, select the database table that contains the data you want to use to verify

the collected digits.
For example, select the table that has all of the bank account information.

 6. AfterDatabase column name, select the column in the selected table that contains the data you want
to use to verify the collected digits.
For example, select the column that has the bank account numbers.
NOTE: The database column typemust be a string type column.

 7. AfterRead Back Column Name, which is optional, you can select the column in the selected table that
contains the data you want the system to read back.
For example, Intelligent Queue uses the system prompts to audibly state the bank account balance.
NOTE: If you have selected a ConfirmationMessage or an InstructionMessage on the Parameters tab,
and you then leave the Database Read Back ColumnName blank, Intelligent Queue will audibly state
the digits dialed by the caller, for example, the bank account number. If you have not selected a
ConfirmationMessage or an InstructionMessage on the Parameters tab, and you leave the Database
Read Back ColumnName blank, Intelligent Queue will not read back anything.

 8. After Test with (ANI/DNIS/User collected digits) equal to, you can type a value to use in a test query
of your table and column name options.
CAUTION: You should test the query before you save the plan. If the query is not valid, the call
defaults to the False path on the Action to take tab.

 9. If you want to test your database configuration options, click Test query.
If the value you typed in Test with does not exist in the database, or the database information is
incorrect, the query returns a False value.

 10. Click Save.
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Configuring an advanced query
An action plan with an advanced query gives youmore flexibility in verifying digits, but it also requires that you
have a working knowledge of SQL. In addition to returning string values of True or False, the advanced query
can return a value that consists of a string of numbers or symbols (0-9,#,*) one to seven characters in length.
This string defines a transfer destination for the call.

The advanced query can also return a second piece of information in addition to True, False, or Dialable
Number. Returning extra information with the result set allows supervisors and agents to view this information
in the Contact Center Client software before the call is answered. Attaching Collected Information to the call
is done by populating the second column of the result set with a string containing the prefix "PFCOLLECTED
INFO|" followed by the information you want to associate with the call.

Example 1: Blind Transfer

The following example illustrates the benefit of using an advanced query instead of a simple query. Suppose
your company has several important customers that you want to route to a high priority queue whenever they
call your contact center. You would also like to add their warranty status to the call. You create a database
table that contains a columnwith the customer’s telephone number (ANI column), a columnwith the
customer’s warranty status, and a column that contains a queue number (Queue column).

Next, you create a verified collected digits action plan that collects the ANI digits (the telephone number of the
caller) of a call. With a simple query, you can only determine whether the collected digits exist (True) in the
ANI column or not (False).

With an advanced query, you have another option. The advanced query first checks the ANI column to
determine whether the collected digits exist or not. If the value exists, the query checks the Queue column in
that row. If the Queue column contains a number, the query returns that value as well as the warranty status
and the call is immediately transferred (a blind transfer) to that queue. Using Interactive Visual Queue the
supervisors are able to see the warranty status under the Collected Info column. Based on this information the
supervisor could reroute the call to a sales queue if the warranty status is set to Expired. Upon receiving the
call the agent is able to see the warranty status in the screen pop of Contact Center PhoneSet Manager or
Contact Center Softphone before answering the call. Intelligent Queue handles return values of True or False
the sameway it does with the simple query, by consulting theAction to take tab.

Please note that this is just one example of how you can use advanced query. As long as your query returns a
true, false, or string value, the SQL statement can be as simple or complex as you want.

Example 2: Readback

Confirm the callers input in any language supported by Intelligent Queue
With an advanced verified collected digits query, Intelligent Queue can now verify the digits customers press,
and give customers the option to subsequently adjust their digit selection. For example, after pressing the
digits of an extension, customers will hear “You have entered 1234." After readback, if customers want to
change their selection, they may.
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Read back a value returned by the database query
Suppose you want your customers to be able to check their bank balances without needing to talk to a person.
You create a database table that contains two columns: the customer’s account number and the customer’s
bank balance. Next you create a verified collected digits action plan that collects the account number. The
advanced query first checks the account number column. If the account number column contains the digits
dialed, the query checks the account balance for that row. Intelligent Queue, using the system prompts, will
audibly state the customer’s account balance.

NOTE: The verified collected digits action plan can only query a string value that represents a positive integer.
It cannot read words, or complex numbers. It can read decimal numbers in a two query process by using the
previously collected digits input method. Verify that all columns included in your SQL statement are string
type columns. If you do not use string type columns, the query will not run successfully. The return values
must also be strings. The four possible return values are True, False, the read back value, or a dialable
number.

To configure an advanced query
 1. In theVerified collected digitswindow, select theODBC Parameters tab.
 2. AfterODBC Database system DSN, select the database you want to use to verify the collected digits.
 3. Type a valid user name and password for the database you selected.
 4. AfterQuery type, select Advanced.
 5. AfterAction, select Blind Transfer or Read Back.

If you want the call to be immediately transferred to the extension dialed, you select Blind Transfer.
If you want Intelligent Queue to read the digits in the database, you select Read Back.

 6. AfterDefine your query, type an SQL statement that compares the collected digit value to a database
value.
NOTE:You can click Insert the variable as a shortcut when typing the full variable name in the text
box.

 7. If you want to test your database configuration options, click Test query.
 8. After Test with (ANI/DNIS/User collected digits) equal to, you can type a value to use in a test query

of your SQL statement.
CAUTION:You should test the query before you save the plan. If the query is not valid, the call
defaults to the False path on the Action to take tab.

 9. If you want to test your database configuration options, click Test query.
If the value you typed in Test with does not exist in the database, or the database information is
incorrect, the query returns a False value.

 10. Click Save.

Selecting an action to take
TheAction to take tab specifies the type of action or subcondition the verified collected digits action plan
follows, based on whether the query returns a string value of True or False.

To select an action
 1. In theVerified collected digitswindow, select theAction to take tab.
 2. AfterQuery returned true, select an action to take if the digits pass verification.

l If you select None, control will return to the call flow.If the verified collected digits plan was invoked
from an interactive tree, themenu is played.If the verified collected digits plan was assigned as the
action, the call hangs up.

l If you select Action, select an action type and then select an action plan from the list box.The
selected action plan will be followed if the digits are successfully verified.
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l If you select Condition, select a condition type and then select a condition plan for the list box.The
selected condition plan will be followed if the digits are successfully verified.

 3. AfterQuery returned false, select an action to take if the digits fail verification.
l If you select None, control will return to the call flow.If the verified collected digits plan was invoked

from an interactive tree, themenu is played.If the verified collected digits plan was assigned as the
action, the call hangs up.

l If you select Action, select an action type and then select an action plan from the list box.The
selected action plan will be followed if the digits fail verification.

l If you select Condition, select a condition type and then select a condition plan for the list box.The
selected condition plan will be followed if the digits fail verification.

 4. Click Save.

Writing advanced queries
This section includes two examples of SQL queries you can use with advanced query on the ODBC
Parameters tab. In each example, $USER_COLLECTED_DIGITS refers to the digits Intelligent Queue
collected.

Query that dials the customer’s phone number
SELECT PhoneNumber FROMCustomerWHERE ID = $USER_COLLECTED_DIGITS

Intelligent Queue collects a customer ID, runs the query, and if the customer ID is found, that customer’s
phone number is dialed. If the customer does not exist, the query returns a value of ’False.’

Query, within more than one table, with only one possible return value and Collected
Information
SELECT Extension, Warranty Status FROM Employee, CustomerWHERE Customer.EmployeeID =
Employee.EmployeeID AND Customer.ID = $USER_COLLECTED_DIGITS

Intelligent Queue collects a customer ID. The query searched both Employee and Customer tables. If the
Customer ID exists on the Customer table, and that customer’s EmployeeID exists on the Employee table,
the employee’s extension is dialed.

Creating interactive tree plans
Interactive trees are reusable sets of choices and functions that you present to a caller in order to help them
find the information or functionality for which they are searching. Intelligent Queue plays menus for callers,
who thenmake their selection using the telephone’s DTMF keypad. As of Intelligent Queue Version 5.2, an
interactive tree can be assigned tomultiple actions, conditions, and other interactive trees. Previously, you
could assignmultiple actions only.

The AnswerMenu is themainmenu and offers callers their starting choices. Each digit from amenu (0-9, *, #)
can be defined as an option.

DTMF options
Intelligent Queue includes the following DTMF options.

Callback Action
This option activates a predefined voice callback action plan. After the callback plan completes, the call is
terminated.
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Unverified Collect Digits Action
This option prompts the caller to enter a digit string, such as an account number. The system sends this
number to the ACD agent who answers the call, resulting in a screen pop on a desktop application. The
number of digits can be predefined or can be terminated by a digit (such as #) or a predefined duration of
silence.

Go To (another DTMF option) Action
This option takes the caller to a predefined location (DTMF option) elsewhere in the tree.

Management Action
This option activates aManage system action plan. This choice is a hidden option reserved for administrators
and is not typically advertised in themenu greeting. Once the caller selects this option, the same password
rules apply as in aManage system action plan.

Play Message Action
This option plays a predefined informationmessage (.wav file), and then the caller returns to themenu from
which the choice was made.

Replay Greeting Action
This option replays the previous menu greeting.

Submenu Action
This option plays a new menu for callers, giving themmore choices (DTMF options) defined by the digits 0-9,
*, and #. An interactive tree can have an unlimited number of submenus. Eachmenu has a defined “no-digit”
action that the call performs if the caller fails to press a digit. Eachmenu has an invalid digit action that the call
performs if the caller presses an undefined digit. Themenu also defines how many attempts to press a valid
digit are allowed before the “no digit” or invalid digit actions are taken.

Transfer Action
This option defines a routing plan that plays a greeting for the caller and then blind transfers the call to a
predefined destination.

Verified Collected Digits Action
The verified collected digits plan is similar to the unverified collected digits plan since both plans can prompt
the user to enter a digit string, such as an account number. The verified collected digits plan can also collect
the ANI or DNIS from an incoming call. The verified collected digits plan then compares the collected digits to
a list in a database. You can configure the plan to take one action if the value exists in the database and
another action if the value does not exists.

ANI Condition
The system compares a callers’s telephone number to a list (ANI map) of telephone numbers or digit patterns.
If a match is detected, the defined action plan or subcondition is applied.

DNIS Condition
The number that is presented to the telephone system as the dialed digits can be used as a condition.
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Queue Condition
l Number of calls in queue If you have Contact Center Management, you can use the total number of

calls waiting in a queue or queue group, at the time the call begins to ring on the Intelligent Queue port,
as a condition for applying an action plan to a call. The system queries Contact Center Management at
decision time to determine the current queue conditions.

l Queue waiting times If you have Contact Center Management, you can use the longest amount of time
that a caller has been waiting in a queue or queue group, at the time the call begins to ring on the
Intelligent Queue port, as a condition for applying an action plan to a call. The system queries Contact
Center Management at decision time to determine the current queue conditions.

Redirection Condition
If applicable, the original destination of the call can be used as a condition for determining the action plan. The
original destination is the number from which the call was diverted, forwarded, or transferred (unsupervised
transfers). For ACD interflow, this device is the ACD path from where the call came.

Schedule Condition
l Day of the year Any specific date can be defined as a condition. You can apply a subcondition, such

as time of day, to make the conditionmore specific.
l Day of the weekAny specific day of the week can be defined as a condition. You can apply a

subcondition, such as time of day, to make the conditionmore specific.
l Time of dayA specific time period can be defined as a condition. You can specify the start and end

times for which the condition is valid.

Emergency Condition
The current operatingmode of the system or of a port group can be either Normal or Emergency. An Intelligent
Queue administrator can place the call flows in Emergency mode to force all calls on a port to use a predefined
Emergency action plan. This would typically be due to an unforeseen temporary closure of a contact center,
as in the case of a natural disaster.

Interactive Tree
Interactive trees are reusable sets of choices and functions that you present to a caller in order to help them
find the information or functionality for which they are searching. Intelligent Queue plays menus for callers,
who thenmake their selection using the telephone’s DTMF keypad. As of Intelligent Queue Version 5.2, an
interactive tree can be assigned tomultiple actions, conditions, and other interactive trees.

Creating interactive trees
Creating an interactive tree involves the following steps.
 1. Plan your interactive tree.
 2. Associate a DTMF action with each digit that you plan to use in your mainmenu and any submenus you

create.
 3. Select each DTMF action in the Interactive Tree, configure it, and then save your DTMF options.

NOTE:Save the DTMF option for each DTMF. Once you save the tree, make sure there are no red
DTMF options left to configure. Unconfigured options are displayed in red. Configured options are
displayed in black.

 4. Save the interactive tree plan.
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To create an Interactive Tree
 1. Plan your interactive tree according to your needs.
 2. SelectManage=>Actions=>Interactive Tree.

TheConstruct a Tree tab opens by default.
NOTE:WhenDTMF options are created, theConfigure DTMF Option tab opens automatically. To
return to theConstruct a Tree tab, click themainAnswer Menu or any submenus in the tree and then
click theConstruct a Tree tab.

 3. In thePlan Name field, create a relevant plan name. This field is required before you can continue.
 4. Build your tree structure by clicking on the corresponding drop-down box beside each digit and selecting

one of the following actions/conditions/interactive tree for each DTMF digit.
 5. Continue to assign actions to each telephone digit in any submenus you create.

NOTE:DTMF Actions which have yet to be configured are displayed in red. Configured DTMF Actions
are displayed in black.

 6. After you create your tree structure, click Answer (Main Menu) and configure the options that will
govern themenu.
The Configure DTMFOption tab opens.
See Figure 18 - 1.

Figure 18 - 1 Configure DTMF Options tab

 7. To rename theAnswer (Main Menu)DTMFOption, type a new name underDTMF Option Details.
 8. Click Save DTMF Option after configuring each option.
 9. Select your DTMFOptions: Greeting, # of attempts, Timeout (sec), No digit, Invalid digit, Error

message, Transfer call, and Force Greeting.
See Table 18 - 1.
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Option Action Taken

Greeting Plays themain greeting when a call is received.

# of attempts Defines the number of attempts to press the correct digit a caller is allowed
before one of the following actions is taken by Intelligent Queue:
Error message is played
(if the Error message option is selected)
Call is transferred;
(if the Transfer call option is selected)
System hangs up.
(if Hang up is selected by default)

Timeout (seconds) Defines the length of time the system will wait for a DTMF response before
timing out.
NOTE: Each timeout registers as one attempt.

No digit Plays amessage that no digit has been entered.

Invalid digit Plays amessage that an invalid digit has been entered.
NOTE: Each invalid digit registers as one attempt.

Error message Plays amessage when the number of attempts exceeds the limit set in the
# of attempts option.

Force greeting Forces the caller to listen to the greeting before the caller can transfer to a
selection offered on themenu.

Table 18 - 1 DTMF options

 10. If you select # of attempts and Timeout, you can accept the default values or specify your own.
NOTE: The # of attempts and Timeout fields are required for the interactive tree to function properly.

 11. If you select Transfer call, Hang up is the default setting.
NOTE: The Transfer call option will be executed only if selected and if the number of attempts has been
exceeded.

 12. After you configure theAnswer (Main Menu) DTMF Option Details, click Save DTMF Option.
 13. Continue to configure each of the following options under theAnswer (Main Menu) and any submenus

you’ve created: Callback, Collect Digits, Go To, Management, Play Message, Replay Greeting, Sub
Menu, and Transfer.

 14. To change the name of a DTMF option, type a new name in the text field.
 15. Remember to click Save DTMF Option after configuring each DTMFOption.
 16. Click Save once again to save the tree structure.

Setting up messaging plans
Intelligent Queue answers a call and plays a predefined .wav file. Messages can be prerecorded phrases
(static), or messages that aremade up of a set of concatenated phrases (dynamic). Dynamic messages
deliver queue statistics and are usually combined with static messages.

NOTE:You set upmessaging plans before you set upmanagement plans.
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To create amessage plan
 1. Click Manage=>Actions=>Message.

The CreateMessage Plan tab opens.
 2. Click New.
 3. UnderPlan Name, type a unique plan name.
 4. AfterSelect a folder, select the language of themessage you want to create.
 5. AfterPre-recorded phrase, select a pre-recorded phrase and click Insert.
 6. If you want to create a dynamic message that displays queue statistics:

l AfterContact Center Management Queue/Path, select a path.
l Click Refresh queue at anytime to refresh the field.
l AfterQueue Condition, select a queue statistic.
l Click Insert.
NOTE: If you are using French or Spanish phrases, afterGender of the noun, select the gender of the
noun that Queue Condition quantifies. For example, in the French phrase “La temps d’attende est
estime a uneminute” (The estimated wait time is oneminute), select the gender ofminute to ensure the
number, in this case une, uses the correct gender.

 7. Tomove amessage up or down in theMessage List, select themessage and click the up or down
arrow.
NOTE: The phrases are played in the order you list them. ThePlay value represents the static part of
themessage, for example, "The longest call waiting is ...". TheSay value represents the dynamic part
of themessage (the value of the statistic) retrieved from the Remote Server (as long the Contact
Center Management server is running and configured).

 8. To delete amessage string, in theMessage list box, click the string and click the X icon.
 9. Click Save to save themessage plan.
 10. Click New to clear the fields and create another message plan.

Tomanagemessages
 1. From theManage=>Actions=>Messagewindow, click theManage Files tab.
 2. Select a language folder from the drop-down list box.

NOTE:With Intelligent Queue, you can create language folders. If you accepted the default settings
during installation, the default path will be Program Files\Mitel Networks\Intelligent Queue\Voice\US
English. You can create a new directory on the Intelligent Queue server, such as Program Files\Mitel
Networks\Intelligent Queue\Voice\Latin. If you are also playing dynamic messages, you will need to
add system files (1.wav, 2.wav, ...), such as Program Files\Mitel Networks\Intelligent
Queue\Voice\Latin\System.

 3. Click a .wav file to select it, and then click Rename to enter a new name for themessage on the server,
or click Delete to removemessages from the language directory.

 4. Click Save.

To upload files
 1. From theManage=>Actions=>Messagewindow, click theUpload Files tab.
 2. Select the appropriate language folder from the drop-down list box.

US English is selected by default.
 3. Click Browse to navigate to the directory containingmessages that have been created.
 4. Click a .wav file to select it and click Add to add the selected file to the Upload File List.

NOTE: Intelligent Queue requires .wav files to be in a specific format.
See "Recording voice prompts" on page 632 for more information.
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 5. Click Remove to remove any file from the Upload File List. Click Remove all to remove all files from
the Upload File List.

 6. Click Upload.
NOTE:You can upload onemessage file at a time. You can, however, copy multiple messages files
directly into the appropriate language directory.

Configuring emergency messaging
You can configure Intelligent Queue to enable supervisors to call in and activate emergency messaging over
the phone from remote locations.

To configure Intelligent Queue so that supervisors can activate emergency messaging over the phone you
must
 1. Set up amanagement plan
 2. Set up an emergency message plan
 3. Set up an emergency call flow
 4. Apply the emergency call flow to your port group.

Supervisors can then activate emergency messaging over the phone. See "Activating emergency messaging
over the phone" on page 607.

Setting up an emergency message plan
To set up an emergency message plan
 1. Click Manage=>Actions=>Message.
 2. Click New.
 3. UnderPlan name, type a unique plan name.
 4. AfterSelect a folder, select the language of themessage you want to create.
 5. AfterPre-recorded phrase, select a pre-recorded emergency message phrase and click Insert.
 6. Click Save to save themessage plan.

Setting up an emergency call flow
To set up an emergency call flow
 1. Click Manage=>Call flows.
 2. UnderCall flow name, type a unique call flow name.
 3. Click theDefault action tab.
 4. Select Action.
 5. AfterChoose an action, select amessage plan type.
 6. AfterSelect a plan, select the emergency message plan you created.
 7. Select theCheck the box if this call flow is used in an emergency state check box to designate the

call flow as an emergency call flow.
 8. Click Save.

Applying the call flow to your port group
To apply the call flow to your port group
 1. Click Manage=>Port groups.
 2. UnderPort groups, select the port group to which you will apply the emergency message plan.
 3. UnderAssign call flows, afterEmergency state, select the emergency call flow you created.
 4. Click Save.
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Setting up management plans
You can configure amanagement plan for your interactive tree that allows supervisors to call in and interact
with Intelligent Queue over the phone. After you configure amanagement plan (assign ports for future use),
supervisors can call in and put messaging port groups into Emergency mode (or back into Normal mode) and
can recordmessages over the phone from remote locations. When you configure amanagement plan, you
need to enable theChanging system mode via phone option. This enables supervisors to call in and invoke
the plan over the phone.

NOTE:You set upmessaging plans before you set upmanagement plans.

To set up amanagement plan
 1. Click Manage=>Actions=>Management.
 2. AfterPlan name, type a new plan name or select an existing plan.
 3. On theSettings tab, underRecord Prompts, afterRecording Prompts via phone is, select Enabled

to allow a supervisor to record prompts over the phone.
 4. After <drive>, type the destination you wish to save the recordings to.

CAUTION: Typing 0 enables the supervisor to record infinitely longmessages which can consume
large amounts of hard drive space.

 5. AfterRecording Timeout (seconds), type the time limit within which the supervisor must record the
message (in seconds).
The default value is 120 seconds. The value can range from 1 to 3600 seconds.
When determining the duration of themessage remember that the longer themessage, themore port
resources are used.

 6. Type the name of the subdirectory where the files you record will be saved. If you accept Inbox as the
default setting, any files that you record will be saved to the Inbox folder of Voice.The default path is
C:\Program Files\Mitel Networks\Intelligent Queue\Voice\Inbox.

 7. UnderChange system mode, afterChanging system mode via phone is, select Enabled to permit
supervisors to put selected port groups into Normal mode or Emergency mode over the phone.

 8. UnderAvailable Messaging Port Groups, select the port groups that can be placed into Emergency
mode, by moving them from theAvailable messaging port groups box, to theSelected messaging
port groups box.

l Click >> to add all port groups to the list.
l Click > to add a selected port group to the list.
l Click < to remove a selected port group from the list.
l Click << to remove all port groups from the list.

Defining the messages within your management plan
To define themessages within your management plan
 1. On theManage=>Actions=>Managementwindow, click theOptions tab.
 2. AfterPassword prompt, select amessage plan to prompt the caller to enter a password using their

DTMF keypad.
 3. AfterManagement menu, select amessage plan to offer menu options to callers.

Please consult Table 18 - 2 for a sampleManagement Plan configuration.
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To do the following... Press this digit

Record system prompts 1

Change the systemmode 2

If you have chosen to change the systemmode:

Change the system into Normal Mode 1

Change the system into Emergency Mode 2

Table 18 - 2 Sample management plan configuration

 4. AfterRecording instructions, select amessage plan to provide recording instructions that allow
callers to record system prompts

 5. AfterRecording completed message, select amessage plan to provide amessage to callers that their
recording has completed.

 6. AfterChange system mode instructions, select amessage plan to provide instructions on how to
change the system’s operatingmode using the telephone keypad.

 7. AfterNormal mode selected message, select amessage plan to specify amessage that plays when
the system is placed into Normal Mode.

 8. AfterEmergency mode selected message, select amessage plan to specify amessage that plays
when the system is placed into Emergency Mode.

 9. After Invalid digit, select amessage plan to specify themessage that plays when an invalid digit is
pressed.

 10. AfterPassword access, type a password that is comprised of digits (0-9, *, #) and related to the
Telephone User Interface (TUI) of your telephone.

 11. AfterDigit timeout, type a number (of seconds) the system will wait for a DTMF response before
timing out.
The default is 5 seconds.

 12. Click Save.

Activating emergency messaging over the phone
To activate emergency messaging remotely over the phone
 1. Using your telephone, dial into the Intelligent Queue server management port group.
 2. Type your user name and password.
 3. Listen to themessage options and press the number indicated to change your systemmode.
 4. When you are prompted to specify themessagemode, press the number indicated to activate the

emergency mode.

Setting up routing plans
Three types of routing plans allow you to route calls to another queue path or extension.

l Redirectedmeans the call is not answered, no greeting plays, and the call immediately redirects. For
example, a call might be redirected if the number of calls waiting in queue is exceeded.

l Blind transfer means the call is answered, a greeting is played (optional), and the call is transferred to
the destination. After transferring, the extension performing the transfer hangs up and does not wait to
determine the outcome of the call. The advantage of a blind transfer is that the immediate release to the
PBX frees the port for a new call.
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l Supervised transfer means the call is answered, and then put on hold while being transferred. The
advantage of a supervised transfer is that, because they are on hold, customers cannot hear the phone
ringing during the transfer. However, if the Timeout expires (the duration that the call is kept on hold)
before the call is transferred, the caller can hear the phone ringing during the transfer. The Intelligent
Queue port is not available to take a new call until the Timeout expires or the destination answers the
call.

To create a routing plan
 1. SelectManage=>Actions=>Routing.

The Routing parameters window opens.
 2. UnderPlan name, type a new plan name or click an existing plan underPlans.
 3. To redirect a call immediately without playing amessage

l Click Redirect.
l AfterRouting destination, type an extension number.

 4. To perform a blind transfer
l Click Blind.
l Select a greeting from the drop-down list box (if desired).
l AfterRouting destination, type an extension number.

 5. To perform a supervised transfer
l Click Supervised.
l Select a greeting from the drop-down list box (if desired).
l AfterRouting destination, type an extension number.
l After Timeout (seconds), type themaximum duration the call will be placed on hold (between 10-

1000 seconds).

Managing Conditions: Assigning conditions to call flows
NOTE:

l Do not use the same condition for both the condition and the subcondition. This will create loops within
your conditions. For example, you will create a loop if you select a weekday plan as your condition, a
time plan as your subcondition, and then the weekday plan as another subcondition.

l When you save a condition, the Intelligent Queue services require at least 20 seconds to save your
changes to the server. The length of time is based on the complexity of the call flows in the condition.
You can continue working during this period.

Under every type of condition, you can create a new condition, delete a condition, or save the current
condition. If a condition is matched or met, the condition is true. If a condition is not matched or met, the
condition is false. You can select from three courses of action:

l You can do nothing, which forces Intelligent Queue to go back to the call flow and test for the next
condition.

l You can select to perform an action, which terminates the call flow.
l You can select a subcondition to be tested (and override the default action in a condition that is false).

To view the actual conditions present for a particular call, view the call logs. This will also help you to
define/refine the conditions.

Creating ANI conditions
The Automatic Number Identification (ANI) is the number from which a call originates. ANI can represent a
telephone number and an area code, for example.
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The ANI condition compares an incoming call on an associated port group to a list of defined digit patterns. If
an ANI patternmatches, the associated action follows. Otherwise, the default action for a plan executes. If
the default action of a plan is set to None, control returns to the call flow and the next condition is tested.

l If the condition is met (True), an action or subcondition that is defined and associated with the ANI plan
occurs.

l If the condition is not met (False), a default condition or action that is defined and associated with the
ANI plan occurs.

To create an ANI pattern
 1. SelectManage=>Conditions=>ANI.

The ANI Conditions tab opens by default.
 2. Type a new plan name, or click an existing ANI plan to populate thePlan Name field.
 3. UnderANI Pattern, type digits from 0-9, *, and ?.

The * can be used at the end of a digit string or together at the beginning and end of a digit string, to
match any number of digits. You cannot use the asterisk as a leading or embedded wildcard as this will
cause an error. The ? can be used anywhere in the digit string tomatch one digit. (See Table 18 - 3.)

Digits
Entered

Would match the following digits ...

*416 Will cause an error.

41*6 Will cause an error.

416* 416 ’555555555 ...’, 416 ’123’, 416 ’0’, et cetera

?416 ’1’ 416, ’2’ 416, ’3’ 416, ’4’ 416, ’5’ 416, ’6’ 416, et cetera
It would not match ’11’ 416, as ? can only represent one digit.

41?6 41 ’1’ 6, 41 ’2’ 6, 41 ’3’ 6, 41 ’4’ 6, et cetera

416? 416 ’5’, 416 ’7’, 416 ’2’, et cetera

Table 18 - 3 Wildcard examples

 4. Click > to add it to the ANI Pattern List.
 5. Click Remove to delete any ANI patterns from the list.
 6. After you have configured your ANI condition, click Save.
 7. Click theAction to take tab.
 8. AfterCondition Matched, select an action to take if the ANI patternmatches.

l If you select None, control returns to the call flow and the next condition is tested.
l If you select Action, select an action type and then select an action plan from the list box.
l If you select Condition, select a condition type and then select a condition plan from the list box.

 9. AfterDefault Action, select an action to take if the ANI pattern does not match.
l If you select None, control returns to the call flow and the next condition is tested.
l If you select Action, select an action type and then select an action plan from the list box.
l If you select Condition, select a condition type and then select a condition plan from the list box.

 10. Click Save to save your configuration, New to clear the fields and create a new ANI plan, orDelete to
remove an ANI plan.
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NOTE: If you click Delete, a confirmation dialog box will ask you to confirm before deleting an ANI
Plan. If you try to delete an ANI plan with associated plans, amore detailed confirmation box opens that
allows you to view the associated plans, before you can proceed with the deletion. Deleting the
selected plan will only remove the reference to the associated plan.

Creating DNIS conditions
Dialed Number Identification Service (DNIS) is the digits dialed or the number called into the telephone
system, including any extensions.

The DNIS condition compares the digits dialed to the DNIS pattern list. If a patternmatches, the associated
action follows. Otherwise, the default action for the plan executes. If the default action of the plan is set to
None, control returns to the call flow and the next condition is tested.

l If the condition is met (True), an action or subcondition that is defined and associated with the DNIS
plan occurs.

l If the condition is not met (False), a default condition or action that is defined and associated with the
DNIS plan occurs.

To create a DNIS Plan
 1. SelectManage=>Conditions=>DNIS.

The DNIS Conditions tab opens by default.
 2. Type a new plan name, or click an existing DNIS Plan to populate thePlan Name field.
 3. UnderDNIS Pattern, enter digits from 0-9, *, and ?.

The * can be used only at the end of a digit string tomatch any number of digits. You cannot use the
asterisk as a leading or embedded wildcard as this will cause an error. The ? can be used anywhere in
the digit string tomatch one digit.

 4. Click => to add it to the DNIS Pattern List.
 5. Click Remove to delete any DNIS patterns from the list.
 6. After you have configured your DNIS condition, click Save.
 7. Click theAction to take tab.
 8. AfterCondition Matched, select an action to take if the DNIS patternmatches.

l If you select None, control returns to the call flow and the next condition is tested.
l If you select Action, select an action type and then select an action plan from the list box.
l If you select Condition, select a condition type and then select a condition plan from the list box.

 9. AfterDefault Action, select an action to take if the DNIS pattern does not match.
l If you select None, control returns to the call flow and the next condition is tested.
l If you select Action, select an action type and then select an action plan from the list box.
l If you select Condition, select a condition type and then select a condition plan from the list box.

 10. Click Save to save your configuration, New to clear the fields and create a new DNIS plan, orDelete to
remove a DNIS plan.

Creating emergency conditions
An emergency condition does not put the system or any port groups into Emergency mode. It provides the
flexibility to execute an action or test another condition if an emergency condition is required.

If the emergency condition’s operatingmode is set to Emergency, the associated action occurs. Otherwise,
the default action of the plan executes. If the default action of the plan is set to None, control returns to the call
flow and the next condition is tested.
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To create an Emergency Plan
 1. SelectManage=>Conditions=>Emergency.

TheEmergency conditions tab opens by default.
 2. Enter a new plan name or click an existing plan to populate thePlan Name field.
 3. Select one of the following operatingmodes:

l Normal follows a default action.
l Emergency follows an associated action.

 4. After you have configured your emergency condition, click Save.
 5. Click theAction to take tab.
 6. AfterCondition Matched, select an action to take if the Emergency condition is true.

l If you select None, control returns to the call flow and the next condition is tested.
l If you select Action, select an action type and then select an action plan from the list box.
l If you select Condition, select a condition type and then select a condition plan from the list box.

 7. AfterDefault Action, select an action to take if the Emergency condition is false.
l If you select None, control returns to the call flow and the next condition is tested.
l If you select Action, select an action type and then select an action plan from the list box.
l If you select Condition, select a condition type and then select a condition plan from the list box.

 8. Click Save to save your configuration, New to clear the fields and create a new Emergency plan, or
Delete to remove an Emergency plan.

Creating queue conditions
The queue condition checks theNumber of calls waiting, Longest wait time, Path DND (DoNot Disturb),
Agents available, Call load, and Agents idle conditions. If any of these conditions exceed the tolerance
entered, then the condition is true, and the associated action occurs. Otherwise, the default action of the plan
executes. If the default action of the plan is set toNone, control returns to the call flow and the next condition
is tested.

l If the condition is met (True), an action or subcondition that is defined and associated with the queue
plan occurs.

l If the condition is not met (False), a default condition or action that is defined and associated with the
queue plan occurs.

NOTE: The Call Load statistic uses the following formulas: if there are one or more agents available, Call
Load = Calls Waiting / Agents Available. If there are 0 agents available, Call Load = Calls Waiting.
To create a queue plan
 1. SelectManage=>Conditions=>Queue.

TheQueue conditions tab opens by default.
 2. Type a new plan name or click an existing plan to populate thePlan Name field.
 3. Select one of the following conditions:

l Number of calls waiting
l Longest wait time
l Path DND (DoNot Disturb)
l Agents available
l Call Load

 4. Enter theMaximum Number of Calls.
If themaximum is exceeded, the condition is true and the associated action will be followed, otherwise,
the default action will be executed.
l If you select None, then control is passed back to the call flow where the next condition will be

tested.
 5. Select a Contact Center Management Queue/Path from the drop-down list box.
 6. Click Refresh Queue to refresh the Contact Center Management Queue/Path drop-down list box.
 7. After you have configured your queue condition, click Save.
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 8. Click theAction to take tab.
 9. UnderCondition Matched, select None, Action, orCondition. None is selected by default.

l If you select None, control is passed back to the call flow where the next condition will be tested.
l If you select Action, select an Action and then select an Action Plan from the drop-down list boxes.

The selected action will be followed if the condition is matched, and therefore, true.
l If you select Condition, select a condition and then select a plan from the drop-down list boxes.
l The selected sub-condition will be followed if the condition is matched, and therefore, true.

 10. Repeat the previous step forDefault Action.
 11. Click Save.

Creating redirection conditions
The redirection condition checks to see if the call was redirected from another queue or device against the
patterns in the Redirection list. If a patternmatches, the associated action occurs. Otherwise, the default
action of the plan executes. If the default action of the plan is set toNone, control returns to the call flow and
the next condition is tested.

To create a Redirection Plan
 1. SelectManage=>Conditions=>Redirection. TheRedirection conditions tab opens by default.
 2. Enter a new plan name or click an existing plan to populate thePlan Name field.
 3. UnderRedirection Pattern, enter digits from 0-9, *, and ?

The * can only be used at the end of a digit string tomatch any number of digits. You cannot use the
asterisk as a leading or embedded wildcard as this will cause an error. The ? can be used anywhere in
the digit string tomatch one digit.

 4. Click => to add it to theRedirection Pattern List.
 5. Click Remove to delete any redirection patterns from the list.
 6. After you have configured your redirection condition, click Save.
 7. Click theAction to take tab.
 8. UnderCondition Matched, select None, Action, orCondition. None is selected by default.

l If you select None, control is passed back to the call flow where the next condition will be tested.
l If you select Action, select an Action and then select an Action Plan from the drop-down list boxes.

The selected action will be followed if the condition is matched, and therefore, true.
l If you select Condition, select a condition and then select a plan from the drop-down list boxes.

The selected sub-condition will be followed if the condition is matched, and therefore, true.
 9. Repeat the previous step forDefault Action.
 10. Click Save.

Creating schedule conditions
There are three different schedule plans to configure. You can configure schedules to offer different options,
based on the following values:

l Time of day
l Day of the week
l Specific calendar dates

If a condition is true
The Time schedule checks the current time. If the current time is between the start and stop times, the
condition is true, and the associated action occurs.

TheDay schedule checks the current day of the week. If the day is selected, the condition is true, and the
associated action occurs.
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TheDate schedule checks the current date. If the date is selected, the condition is true, and the associated
action occurs.

If a condition is not matched
If the condition does not match, the default action of the plan executes. If the default action of the plan is set to
None, control returns to the call flow and the next condition is tested.

Overview of schedule plan creation
l Create a Date schedule, create an action to take, and save it.
l Create a Day schedule, create an action to take, and save it.
l Create a Time schedule, create an action to take, and save it.

To create a schedule plan
 1. SelectManage=>Conditions=>Schedule. TheSchedule conditions tab opens by default.
 2. Enter a new plan name or click an existing plan to populate thePlan Name field.

Select one of the following schedule types:
l Time Schedule (checks to see whether the current time falls between start and stop times)
l Day Schedule (checks to see whether the current day matches a selected day, Monday through

Sunday)
l Date Schedule (checks to see whether the current datematches selected dates)

 3. Configure the schedule type you have selected:
l For a Time schedule, enter the start and stop times.
l For a Day schedule, select the appropriate day or days.
l For a Date schedule, click the hyperlinks to change themonth and click the appropriate dates

within the selectedmonth. The present month is selected by default. You can go back one
month, or advance onemonth in the calendar year. To delete any dates you have selected, click
Remove.

 4. Check Callback test condition if you want to use this schedule plan as a test condition for a Callback
plan. If you want to use this as a callback condition, you will only be able to select from other Schedule
Plans that are used for callback conditions.

 5. After you have configured your schedule condition, click Save.
 6. Click theAction to take tab.
 7. UnderCondition Matched, select None, Action, orCondition. None is selected by default.

l If you select None, control is passed back to the call flow where the next condition will be
tested.

l If you select Action, select an Action and then select an Action Plan from the drop-down list
boxes. The selected action will be followed if the condition is matched, and therefore, true.

l If you select Condition, select a Condition and then select a plan from the drop-down list boxes.
The selected sub-condition will be followed if the condition is matched, and therefore, true.

 8. Repeat the previous step forDefault Action.
 9. Click Save to save your configuration. Click New to clear the fields and create a new Schedule Plan.

Click Delete to remove a Schedule Plan.

Managing call flows
Essentially, a call flow is created from the bottom up. When you plan to create a call flow, think in terms of
first assigning actions to conditions, then conditions to call flows, and finally, call flows to port groups.
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Themessaging engine that handles the call tests the conditions for a call flow. If the current test condition is
false, the engine returns to the call flow to test the next condition. If all conditions are false, a default action for
the call flow occurs. The default action also occurs if none of the conditions in the call flow result in an action.
If the engine tests for a default action and you have not configured a default action, the call terminates.

Overview of creating a call flow
The creation of a call flow consists of the following steps:

l Assigning actions or subconditions to conditions
l Assigning conditions to call flows
l Assigning call flows to port groups

As you create a call flow, you can save your conditions and then select and review the entire call flow in order
to revise it.

To create a call flow
 1. SelectManage=>Call Flows. The Build Call Flow tab opens by default.
 2. Enter a new name or select an existing call flow to populate the Call Flow Name field.
 3. Select a Condition from the drop-down list box. View the related plans in the Select a Plan field.
 4. Assign Conditions to call flows:

l Click Add to add the selected conditions to the end of call flow.
l Click Add All to add all of the conditions listed to the end of the call flow.
l Click Insert to insert the selected conditions above the selected call flow condition.
l Click Insert All to insert all of the conditions listed above the selected call flow condition.

 5. To change the order of your call flow, click a call flow condition and then click the up or down arrow to
move the position of the item up or down in the call flow.

 6. Click theX icon beside theCall Flow Conditions text box to delete an item from the call flow.
 7. Click theDefault Action tab.
 8. Under DEFAULT ACTION, select None orAction. None is selected by default.

The default action will be followed if none of the conditions in the call flow result in an action.
l If None is accepted, the call will be terminated.
l If you select Action, select an Action and then select an Action Plan from the drop-down list boxes.

 9. Under EMERGENCY CALL FLOW, check the box if the call flow is to be used when the system or port
group is in an emergency mode.

 10. After you have set the parameters of your plan, click Save to save your configuration. Click New to
clear the fields and create a new Collect Digits Plan. Click Delete to remove a Collect Digits Plan.

 11. To browse selected call flow Conditions, click themagnifying glass in the upper right corner of the Call
Flow Conditions field.

 12. Select any condition or action to view its particulars.
See Table 18 - 4 for themeanings of icons and text colors used in the expanded view.

Symbol Meaning Meaning of Text Color

Condition Selected conditions are displayed in black, including the ’do nothing’
condition.
If no condition has been selected for ConditionMatched, text is displayed
in red.

Action Selected actions are displayed in blue, including ’do nothing’ action.
If no action has been selected for Default Action, text is displayed in red.

Table 18 - 4 Call flow condition legend
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Symbol Meaning Meaning of Text Color

Circular
reference error

Please review your selection to avoid the creation of a loop.

Managing port groups: updated position in queue, messaging,
callback, and recording ports
A port can only be assigned to one port group. The behavior of the port depends on the behavior assigned to
the port group. You configure port groups inManage=>Port Groups.

You can configure four types of ports:
l Updated position in queue ports.
l Messaging ports handle incoming calls to the PBX.
l Callback ports handle outgoing callback calls from the agents to the callers.
l Recording ports handle the recording of calls between agents and callers.

You need to configuremost of your ports as messaging ports. You also need to configure at least one updated
position in queue port, one callback port and at least one recording port, if you purchased these options. You
can record one agent at a time on one recording port. If you want to recordmore than one agent at a time, you
need to assignmore than one of your ports as a recording port.

NOTE:When you save a port group, the Intelligent Queue services require at least 20 seconds to save your
changes to the server. The length of time is based on the complexity of the call flows in the port groups. You
can continue working during this period.

Configuring an updated position in queue port group
To configure an updated position in queue port group
 1. SelectManage=>Port Groups. The Configure tab opens by default.
 2. Enter a new name or select an existing Port Group to populate the Port Group Name field.
 3. Select UPiQ underPORT BEHAVIOR.
 4. Accept the default setting of 2,000milliseconds (2 seconds) for the Audio Guard Timer.

NOTE: The Audio Guard Timer reflects the timing of themessages. To adjust the timing, enter a
number which is higher or lower than the default setting.

 5. Click Configure=>Updated Position in Queue.
 6. Select the queue tomonitor from theAvailable Queues drop-downmenu.
 7. Click Add.
 8. Click theAssign Ports tab.
 9. Select a port or ports from the list of Available Ports.Click

>> to add all available Ports to the Port Group.Click
> to add selected Ports to the Port Group.Click
< to remove selected Ports from the Port Group.Click
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>> to remove all Ports from the Port Group.Click
Make All Ports Available to clear the port selections and begin again. This will remove all ports from
all Port Groups, not just the selected Port Group.

 10. After you have finished assigning ports to port groups, click Save.

Configuring a messaging port group
To configure amessaging port group
 1. SelectManage=>Port Groups. The Configure tab opens by default.
 2. Enter a new name or select an existing Port Group to populate the Port Group Name field.
 3. SelectMessaging under PORT BEHAVIOR.
 4. Accept the default setting of 2,000milliseconds (2 seconds) for the Audio Guard Timer.

NOTE: The Audio Guard Timer reflects the timing of themessages. To adjust the timing, enter a
number which is higher or lower than the default setting.

 5. Assign Call Flows using the drop-down list boxes afterNormal State andEmergency State under
ASSIGN CALL FLOWS.

 6. Under EMERGENCY STATE, select Check the box to place the port group in an emergency state
if required.
NOTE: This will already be checked if you have placed the selected port group in Emergency State
underAdministration=>System Mode. If you deselect it and click Save, the systemmodewill return
to Normal State.

 7. Click theAssign Ports tab.
 8. Select a port or ports from the list of Available Ports.Click

>> to add all available Ports to the Port Group.Click
> to add selected Ports to the Port Group.Click
< to remove selected Ports from the Port Group.Click
>> to remove all Ports from the Port Group.Click
Make All Ports Available to clear the port selections and begin again. This will remove all ports from
all Port Groups, not just the selected Port Group.

 9. After you have finished assigning ports to port groups, click Save.

Configuring a callback port group
To configure a callback port group
 1. SelectManage=>Port Groups. The Configure tab opens by default.
 2. Enter a new name or select an existing Port Group to populate the Port Group Name field.
 3. Select Callback as the Port Behavior.
 4. Assign Call Flows to Normal and Emergency States using the drop-down list boxes.
 5. Check Emergency State to place the port group in an emergency state, if required.

NOTE: This will already be checked if you have placed the selected port group in Emergency State
underAdministration=>System Mode. If you deselect it and click Save, the systemmodewill return
to Normal State.

 6. Click theAssign Ports tab.
 7. Select a port or ports from the list of Available Ports.Click

>> to add all available Ports to the Port Group.Click
> to add selected Ports to the Port Group.Click
< to remove selected Ports from the Port Group.Click
>> to remove all Ports from the Port Group.Click
Make All Ports Available to clear the port selections and begin again.

 8. After you have finished assigning ports to port groups, click Save.
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Configuring a recording port group
To configure a recording port group
 1. SelectManage=>Port Groups. The Configure tab opens by default.
 2. Enter a new name or select an existing Port Group to populate the Port Group Name field.
 3. Select Recording as the Port Behavior.

If you are supportingmore than one PBX with Intelligent Queue, select the destination PBX.
 4. Select a port group for the PBX.Only ports from this PBX can be used and they will only be able to record

ports from that PBX.
 5. Click theAssign Ports tab.
 6. Select a port or ports from the list of Available Ports.Click

>> to add all available Ports to the Port Group.Click
> to add selected Ports to the Port Group.Click
< to remove selected Ports from the Port Group.Click
>> to remove all Ports from the Port Group.Click
Make All Ports Available to clear the port selections and begin again.

 7. After you have finished assigning ports to port groups, click Save.

Viewing system, port, and callback queue status
In this section, you will learn how to

l View system status
l View port status
l View callback queue status

Viewing system status
The System status window opens after you log on to Intelligent Queue. The System status window displays
the current status (Started or Stopped) of all Intelligent Queue services. The Emergency status section of the
System status window indicates the current systemmode: Emergency or Normal.

NOTE:Before logging on (after initial setup), ensure that the services have been started. If you log on before
the services have started, the system status will not be accurate.

To view system status
 1. Select Status=>System Status.
 2. Click Start to restart a stopped service.
 3. Click Stop to stop a running service.
 4. AfterPort Groups under EMERGENCY STATUS, click the number to view the port groups that are in

Emergency mode.
 5. To restart the services, click theRestart Systems button. You can also use this button to re-establish a

Contact Center Management connection, if a connection is configured.

Viewing port status
To view port status
 1. Select Status=>Port Status. The Select Ports tab opens by default.
 2. Choose to view the status of all Port Groups or selected Port Groups. Only port groups with assigned

ports will be displayed.
Click View All to view the port status for all port groups.
Click View Selected to view the port status for selected Port Groups
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 3. Choose to view the status of all Ports or selected Ports. Only ports assigned to port groups will be
displayed.Click
View All to view the port status for all portsClick
View Selected to view the port status for selected ports

 4. Click thePort Status tab to view your selection.
 5. To navigate throughmultiple pages of listings, click Previous orNext.
 6. Click Stop to stop Intelligent Queue from displaying port status information. Click Continue to allow the

application to continue to display port status information.

Viewing callback queue status
You can view andmanage callback queues in Status=>Callback queue. The four tabs within the Callback
queue status window display data for Current, Completed, Incomplete, and All callbacks. Intelligent Queue
lists callbacks in order of priority and latest date.

The possible callback queue status states, with their explanations, are as follows:
l NEW_REQUEST - starting state
l WAITING_FOR_SCHEDULE - The callback schedule condition was not met, so waiting
l WAITING_FOR_QUEUE - The queue condition was not met, so waiting
l WAITING_FOR_AGENT_NO_ANSWER -When the callback engine dialed the agent, the agent did

not answer
l WAITING_FOR_AGENT_BUSY -When the callback engine dialed the agent, the agent’s line was

busy
l WAITING_FOR_CLIENT_NO_ANSWER -When the callback engine dialed the customer, the

customer did not answer
l WAITING_FOR_CLIENT_BUSY -When the callback engine dialed the customer, the customer’s line

was busy
l AGENT_REQUEUED - The agent used the requeue option when the callback was offered to them
l IN_PROGRESS - The callback is currently being processed (This happens initially and then it

transitions to another state)
l AGENT_REJECTED - The agent rejected the callback when the callback was offered to the agent
l EXPIRED - The callback engine tried to contact the client themaximum number of times and will not

try again
l FAILED_INVALID_AGENT_DESINTATION - The agent destination was invalid (for example, it was

an invalid path number)
l FAILED_INVALID_CLIENT_DESTINATION - The client destination was invalid (for example, they left

a phone number with only six numbers)
l FAILED - General error
l COMPLETE - The callback is complete
l DIALING_CLIENT - The system is currently dialing the client

To view callback queue status
 1. Select Status=>Callback Queue. The Current Callbacks tab opens by default.
 2. Click the appropriate tab to view the status of the following:

l Click theCurrent callbacks tab to view current callback queues. You can change the priority of the
callback request using the list box.

l Click theCompleted callbacks tab to view successful callbacks.
l Click the Incomplete callbacks tab to view failed callback requests. You can click Requeue to

requeue a failed callback.
l Click theAll callbacks tab to view a snapshot of all callback queues.

 3. To navigate throughmultiple callback pages, click Previous orNext.
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 4. Click an individual callback to view the following particulars:
l Caller’s name
l Caller’s phone number
l Customer’s IP Address (if the callback you selected is aWebCallback)
l Message (click the hyperlink to listen to the recorded .wav file)

 5. Click Select All to select all the displayed callbacks. Click Unselect All to de-select all the displayed
callbacks.

 6. Click Refresh to refresh the callback queue listing.
To delete an individual callback listing or selected callbacks, click Delete.

Callback and recording plans
This section includes information on

l Managing outgoing calls
l Managing recording plans

Managing outgoing calls: Voice and Web Callbacks
In this section, you will learn how to

l Set up callback plans
l Assign caller messages to callback plans
l Assign agent messages to callback plans
l Assign agent options to callback plans
l Set callback plan parameters

Overview of voice and web callbacks
Callback requests allow Intelligent Queue to wait in queue for an agent, on a caller’s behalf. The system can
take callback requests from a voice call, from aweb page, or the requests can be generated by a third party
business application. A reusable callback action plan in the user interface defines the inputs that are required
for a request.

Callback call processing
Intelligent Queue processes callback requests in a continuous loop using each of the ports that are dedicated
to callback processing. Each callback request is submitted with a call "profile". This profile is an action plan
that defines the ACD path to attempt, the client’s telephone number, the client’s name, queue thresholds to
adhere to, and the language in which the call should be processed. The system processes calls in the order
that they are received, but each call has amaximum number of attempts and a retry interval. If the client does
not answer the call, the callback request requeues to amaximum number of attempts. The system does not
attempt the callback until the retry interval is exceeded. Each callback structure also defines themaximum
amount of time the callback port will wait for an agent to answer, before requeuing the call andmoving on to
the next request.

Upon receipt of a callback request, agents can listen to the caller’s message, place the call, requeue, or reject
the request.

A user with administrative privileges can view, prioritize, requeue, and delete callback requests from the user
interface.
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Voice callback requests
A voice callback request can ask the caller for the following information:

l A telephone number at which they can be contacted
l The caller’s name (recorded as a .wav file for playback by an ACD agent)
l A confirmation to submit the request

Once the caller provides the information, Intelligent Queue hangs up and records the request in the database
for processing.

For voice callbacks, you need to assign both caller messages and agent messages to your callback plans.

Web callback requests
A customer completes aWeb callback request on an HTML/ASP page that is designed and hosted by the
Intelligent Queue customer. You can see an example of a sample web page at Start=>Programs=>Mitel
Networks=>Intelligent Queue=>Intelligent Queue DotNet Webcallback Example. A customer who wants to
receive a callback from an ACD Agent fills out the following required information on the web form:

l The telephone number at which they can be contacted
l The customer’s name (presented as a TTS rendition to the ACD agent)
l The target ACD path

Intelligent Queue then submits the information to the database for callback processing.

ForWeb callbacks, you need to assign only agent messages (not caller messages) to your callback plans.

Campaign callback requests
Campaign callback requests are requests that are originated by a business application used by an Intelligent
Queue customer. A customer canmake callback requests directly to Intelligent Queue by submitting a new
record in the database. If the record includes the required information, the request is processed in the callback
queue. The Campaign table of the database is password-protected to ensure that only authenticated
applications can generate requests.

Configuring web callbacks in Windows Server 2003
NOTE:Web callbacks are not supported in virtualized environments.

To configure web callbacks inWindows Server 2003
 1. Log on to the Intelligent Queue server.
 2. Browse to the Intelligent Queue installation directory (<drive>:\Program Files\Mitel Networks\6160).
 3. Copy theWebCallbackExample folder to a folder on your IIS Server.
 4. Tomodify the web callback page to display your company logo and slogan, see “Customizing yourWeb

Callback page” on page 466.
 5. On the Intelligent Queue server, click Start=>Administrative Tools=>Internet Information Services

(IIS) Manager.
 6. Expand <computer_name> (local computer).
 7. Expand theWeb Sites folder.
 8. Right-click Default Web Site and select New=>Virtual Directory...

The Virtual Directory CreationWizard opens.
 9. Click Next >.
 10. UnderAlias, typewebcallback and click Next >.
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 11. Browse to the VBDotNet folder (<drive>:\Program Files\Mitel
Networks\6160\WebCallbackExamples\VBDotNet) and click OK.

 12. Click Next >.
 13. UnderAllow the following permissions, select Run scripts (such as ASP) andExecute (such as

ISAPI applications or CGI) and click Next >.
 14. Click Finish.
 15. Browse to the VBDotNet folder (<drive>:\Program Files\Mitel

Networks\6160\WebCallbackExamples\VBDotNet) and openWeb.config.
 16. In the string value=“http//localhost/6160/CallbackWebService.asmx”, replace localhostwith the

computer name or the IP address of the Intelligent Queue server.
 17. In the string value=“webCallback”, replace webCallback with the name of the callback plan you

configured in Intelligent Queue.
 18. Click File=>Save and close theWeb.config file.

Configuring web callbacks in Windows Server 2008
NOTE:Web callbacks are not supported in virtualized environments.

To configure web callbacks inWindows Server 2008
 1. Log on to the Intelligent Queue server.
 2. Browse to the Intelligent Queue installation directory (<drive>:\Program Files\Mitel Networks\6160).
 3. Copy theWebCallbackExample folder to a folder on your IIS Server.
 4. Tomodify the web callback page to display your company logo and slogan, see “Customizing yourWeb

Callback page” on page 466.
 5. On the Intelligent Queue server, click Start=>Administrative Tools=>Internet Information Services

(IIS) Manager.
 6. Expand <computer_name> (local computer).
 7. Expand theSites folder.
 8. Right-click Default Web Site and select Add Virtual Directory...

The Add Virtual Directory dialog box opens.
 9. UnderAlias type webcallback.
 10. UnderPhysical path: browse to <drive>:\Program Files\Mitel

Networks\6160\WebCallbackExamples\VBDotNet and click OK.
 11. Browse to the VBDotNet folder (<drive>:\Program Files\Mitel

Networks\6160\WebCallbackExamples\VBDotNet) and openWeb.config.
 12. In the string value=“http//localhost/6160/CallbackWebService.asmx”, replace localhostwith the

computer name or the IP address of the Intelligent Queue server.
 13. In the string value=“webCallback”, replace webCallback with the name of the callback plan you

configured in Intelligent Queue.
 14. Click File=>Save and close theWeb.config file.

Setting up callback plans
For voice callbacks, assign caller messages and then proceed to assign agent messages to your callback
plans.

To create a callback plan
 1. SelectManage=>Actions=>Callback. The Conditions tab opens by default.
 2. UnderPlan Name, enter a new plan name or click an existing Callback Plan underPlans to populate

thePlan Name field.



Contact Center Solutions User Guide

- 622 -

 3. UnderSchedule Condition, click Allow callbacks anytime, no schedule restrictions apply to
allow callbacks anytime.The Schedule Plan drop-down list box is disabled. However, if you wish to
attach a Schedule Plan to your Callback Plan, leave the check box unchecked and select a schedule
you have created from the Schedule Plan drop-down list box.

 4. UnderQueue Conditions, click Allow callbacks anytime, no queue restrictions apply to allow
callbacks anytime, regardless of queue designation.The Contact Center Management Queue/Path
drop-down list box, theMaximum calls waiting threshold and theMaximum longest call waiting
threshold check boxes are disabled. However, if you wish to assign a queue condition to your Callback
Plan, leave the check box unchecked and select a queue path from the Contact Center Management
Queue/Path drop-down list box.

 5. If you have not selectedAllow callbacks anytime, no queue restrictions apply, you will be able to
set thresholds for themaximum number of calls waiting and themaximum longest call waiting, if
required.

 6. To set theMaximum number of calls waiting threshold, select Check against the maximum calls
waiting threshold and enter a number in theMaximum calls waiting threshold field.If the number of
calls meets or exceeds the number you have entered, Intelligent Queue will not perform a callback. If
the number of calls is lower than the number you have entered, Intelligent Queue will perform a
callback.

 7. To set theMaximum longest call waiting threshold, check Check against the maximum longest call
waiting threshold and enter a number in theMaximum longest call waiting threshold (seconds) field.If
the number of seconds meets or exceeds the number you entered, Intelligent Queue will not perform a
callback. If the number of calls is lower than the number you have entered, then Intelligent Queue will
perform a callback.

 8. To perform a check for an available agent before submitting the callback to the queue, check Check
against the agents idle threshold and enter a number in theMinimum agents idle threshold field. If
the number of idle agents meets or exceeds the threshold number, Intelligent Queue will submit the
callback to the queue. If the number of idle agents is lower than the threshold value, Intelligent Queue
will not submit the callback to the queue.

Assigning caller messages to callback plans
For voice callbacks, first assign caller messages and then agent messages to your callback plans. You do not
need to assign caller messages forWeb callbacks.

To assign caller messages to callback plans
 1. From theManage=>Actions=>Callbackwindow, click theMessages tab. TheMessages tab opens.
 2. Click theCaller Messages sub tab.The Caller Message sub tab opens.
 3. UnderCaller Messages, define themessages that a caller will receive when requesting a callback,

using the drop-down list boxes.
 4. AfterPrompt for Telephone Number, select aMessage Plan you have created to enable callers to

hear amessage prompting them to leave their phone number. The static message you select could be,
"Please use your telephone keypad to enter your seven-digit phone number, followed by the # (pound)
key", for example.

 5. Make your selections from the two drop-down list boxes afterConfirm Telephone Number.
l Step 1: Select the first pre-recorded phrase. The static message you select could be, "You have

entered ...", for example.
l Step 2: Select the second pre-recorded phrase. The static message you select could be, "Is this

number correct? Press 1 for yes. Press 2 for no."
 6. Select the playback language in which the caller’s DTMF selection will be played back. US English is

selected by default.
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 7. AfterRecord a Message, select aMessage Plan you have created to enable callers to leave a
message. The static message you select could be, "Please leave amessage after the tone", for
example.

 8. AfterRequest Confirmation, select aMessage Plan you have created to enable callers to hear a
confirmationmessage. The static message you select could be, "Press 1 to Save your Callback
Request. Press 2 to Cancel your Callback Request", for example. Saving the callback request submits
it to the database. Cancelling the callback request means it will not be submitted to the database.

 9. AfterRequest Submitted, select aMessage Plan you have created to enable callers to hear the
message that their callback request has been submitted. The static message you select could be,
"Your request has been successfully submitted", for example.

 10. AfterRequest Cancelled, select aMessage Plan you have created to enable callers to hear the
message that they have successfully cancelled their callback request. The static message you select
could be, "You have successfully cancelled your request", for example.

Assigning agent messages to callback plans
For voice callbacks, once you have assigned caller messages, proceed to assign agent messages to your
callback plans. ForWeb callbacks, proceed directly to assign agent messages to your callback plans.

To Assign Agent Messages to Callback Plans
 1. From theManage=>Actions=>Callbackwindow, click the Messages tab. TheMessages tab opens.
 2. Click theAgent Messages sub tab.The

Agent Messages sub tab opens.
 3. UnderAgent Messages, define themessages that agents will hear when establishing a callback, using

the drop-down list boxes.
 4. AfterAgent Greeting, select aMessage Plan you have created to allow agents to hear a greeting once

a connection to an agent is established.The default message for a Voice Callback Request (18.wav) is,
"You have a Voice Callback request."The default message for aWebCallback Request (19.wav) is,
"You have aWebCallback request."

 5. AfterAgent Instruction, select aMessage Plan you have created to offer menu selection to agents.
The default message (20.wav) is, "To listen to the caller’s message, press 1. To place this call, press 2.
To requeue this request, press 3. To reject this request, press 4. To hear these options again, press star
(*)."

 6. AfterAgent Connecting, select aMessage Plan you have created to allow agents to hear that the call
is being established. The default message (22.wav) is, “Please wait while the call is established.”

 7. AfterClient Greeting, select aMessage Plan you have created to allow callers to hear amessage that
they are being connected to an agent. The default message (26.wav) is, "You have a callback. We are
connecting you to an agent now".

 8. AfterClient Failure, select aMessage Plan you have created to allow agents to hear that the callback
could not be established. The default message (27.wav) is, "The callback could not be established."

 9. AfterAgent Rejected, select aMessage Plan you have created to allow callers to hear amessage
confirming that they have successfully cancelled their callback request.The default message (29.wav)
is, "Your request has been cancelled. Goodbye."

 10. AfterAgent Requeue, select aMessage Plan you have created to allow callers to hear amessage that
they are being redirected to an available queue.

 11. AfterAgent Pre-Connect, select aMessage Plan you have created to allow callers to hear amessage
before being connected.
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Assigning agent options to callback plans
After you have assigned agent messages for either voice orWeb callbacks, you will need to assign agent
options to your callback plans.

To assign Agent Options to Callback Plans
 1. From theManage=>Actions=>Callbackwindow, click theAgent Options tab.

The Agent Options tab opens.
 2. Select a DTMF digit (0-9, *, #) that agents will type to invoke each of the following options:

l Listen to caller’s message/name. The default digit is 1.
l Connect to the telephone number. The default digit is 2.
l Requeue the callback request. The default digit is 3.
l Reject the callback request (to delete the callback request from the queue). The default digit is 4.
l Replay the agent instructionmessage. The default digit is 5.

Setting callback plan parameters
To set callback plan parameters
 1. From theManage=>Actions=>Callbackwindow, click theParameters tab.
 2. AfterCallback destination, type the extension number or hunt group number to connect to an agent.

If you are supportingmore than one PBX with Intelligent Queue, select the callback destination PBX.
CAUTION: Typing 0 enables the caller to record infinitely longmessages which can consume large
amounts of hard drive space.

 3. AfterClient Recording Timeout (seconds), type the time limit within which the caller must record the
callback message (in seconds).
The default value is 600 seconds. The value can range from 1 to 3600 seconds.

 4. AfterNo answer timeout for agent, type the time limit (in seconds) a callback port will wait for an
agent to answer.
The default is 120 seconds.

 5. AfterNo answer timeout for clients, type the time limit (in seconds) a callback port will wait for a client
to answer.
The default is 15 seconds.

 6. AfterNumber of attempts to contact client, type themaximum number of times Intelligent Queue will
attempt to return the client’s call.
The default is three times.

 7. AfterRetry interval between contacting client, type a number (of minutes).
The default is 30minutes.

 8. AfterMinimum number of digits required to place an external call, type a number.
The default is 7.

 9. After Leading digit(s) required to call back external clients, type the digit required to access an
external phone line, if required.
The default is 9.

 10. AfterMinimum number of digits required for a valid callback, type a number.
The default is 7.

 11. Select theOn requeue, retain original callback date/time stamp check box to prioritize callbacks by
the original date and time of the callback.
NOTE: The oldest callbacks will always be offered to agents before newer callbacks, regardless of
requeue.
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 12. ForWeb Callbacks, type the number of calls that the system will consider to be toomany to process a
callback to a queue afterMaximum number of simultaneous callback requests from single IP
address. Alternatively, select theCheck box for unlimited callback requests from a single IP
address.
NOTE:Mitel Networks Corporation recommends that you type amaximum number to avoid being
flooded by simultaneous callbacks from a single IP Address.

 13. Click Save to save your configuration. Click New to clear the fields and create a new Callback Plan.
Click Delete to remove a Callback Plan.

Managing recording plans
Call recording for quality monitoring purposes was introduced in Intelligent Queue version 3. This feature
requires that ports be dedicated as recording ports to ensure availability and to avoid call collisions with
incoming calls. You can initiate call recording from the Intelligent Queue user interface.

Using Intelligent Queue, a user with sufficient rights enters an Agent ID, extension number, or Agent Group ID
to request that a current call, or the next call received, be recorded. Once the recording completes, the system
notifies the user of the success (or failure) of the request, as well as the file namewith which the call recording
has been stored.

Please note the following conditions of the Agent call recording option:
l Only SUPERSET telephones with the ACD Silent Monitoring - Accept option enabled in their Class of

Service can be recorded.
l An agent can only be recorded by one supervisor at a time.
l Recording is denied on a broker’s call, because any agent who has a call on soft hold cannot be

recorded.
l Agent call recording is not permitted on a non-prime line.
l A SUPERCONSOLE 1000 or SUPERSET 7000 console cannot be recorded.
l Networked ACD does not support agent call recording of remote agent subgroups from the Distributor

system.
l Agent call recording is not supported onMSDN networks.

To record an agent
 1. SelectManage=>Recordings. The Recording Queue tab opens by default.
 2. UnderDirectory number, type the directory number you wish to record
 3. Select the port group that uses the directory number.
 4. Click Record.
 5. UnderRecording Queue, view the recordings in queue. To navigate throughmultiple pages of listings,

click Previous orNext.
 6. To remove a recording from a queue, click Remove.
 7. To terminate the recording of a call, click theStop button.
 8. Click theDownload Recordings tab to play or download a recording.
 9. Follow the on-screen instructions:To play a recording, left click a recording to select it.To download a

recording from the server and save it to your local hard drive, right-click a recording, select Save Target
As..., and select a folder to which the recording will be saved.

 10. Recordings are saved in a Recordings folder. Provided you accepted the default settings during
installation, the folder can be found at the following location: Program Files\Mitel Networks\Intelligent
Queue\Recordings

 11. Click theCompleted Requests tab to view completed or failed recordings.
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Maintaining Intelligent Queue and Contact Center
Management
This section includes information on

l Adding an Intelligent Queuemedia server to Contact Center Management
l Using Network Monitor with Intelligent Queue
l Configuring Intelligent Queue devices
l Creating reports
l Using Reporter

Adding an Intelligent Queue media server to Contact Center
Management
To add an Intelligent Queuemedia server
 1. Click YourSite=>Enterprise.
 2. AfterName, type the name of themedia server.
 3. AfterSite, select the site where this media server resides.
 4. After This media server is installed on the computer you have named, select the computer on

which themedia server is installed.
 5. Click Save.

Using Network Monitor with Intelligent Queue
You can use Network Monitor (located in Contact Center Client) to provide information on the status of real-
time data collection on your Intelligent Queuemedia server. Network Monitor can verify if alarms are enabled
for your media servers and if themedia servers are reporting any alarms.

The following list includes some of the alarms Network Monitor provides:
l SQLServer down
l Messaging Service down
l Recording Service down
l Callback Service down
l Music Service down
l Mitel IP Service down
l No audio
l Bad audio file detected
l MiTAI down
l Low disk space on installation drive
l Invalid agent destination for callback detected

To configure Network Monitor for use with Intelligent Queue, youmust
 1. Add an Intelligent Queuemedia server to Contact Center Management.

See "Adding an Intelligent Queuemedia server to Contact Center Management" on page 626.
 2. Configure the data collection settings for the Intelligent Queuemedia server.
 3. Configure Contact Center Management settings in Intelligent Queue.

For more information on using Network Monitor, see "Network Monitor" on page 343.
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Configuring data collection settings for Intelligent Queue media servers
To configure the data collection settings for an Intelligent Queuemedia server
 1. Open Contact Center Management and click YourSite=>Enterprise.
 2. Expand the Enterprise Configuration tree and select the Intelligent Queuemedia server you want to

configure.
 3. Select theData collection tab.
 4. Select IP address and type the IP address of your Intelligent Queue server.
 5. Click Save.

Configuring Contact Center Management settings in Intelligent Queue
To configure your Contact Center Management settings
 1. Open Intelligent Queue and click Configure=>Contact Center Management Settings.
 2. AfterAddress, type the IP address of your Contact Center Management server.
 3. Click Save.

Resolving Network Monitor alarms
WhenNetwork Monitor detects an alarm, it provides a general description of the alarm. Though the types of
alarms can vary, you can resolvemany alarms with the followingmethods:

l If a service is down, restart the service that is down.
l View the Intelligent Queue log in Event Viewer for more specific details about the alarm.

See "Viewing event logs" on page 646.

For more information on troubleshooting Intelligent Queue alarms in Network Monitor, see "Recording voice
prompts" on page 632.

Configuring Intelligent Queue devices
NOTE:Youmust have the Intelligent Queue application and an Intelligent Queuemedia server at your site
before you can view the Intelligent Queue option on the YourSite Configurationmenu.

Intelligent Queue Smart Choice layers
You can configure your ports to act as options or Smart Choicemessage trees. Each option plays a user-
definedmessage and transfers the caller to a user-defined destination, or allows the customer to create a
voice callback, if this option has been purchased.

Viewing Intelligent Queue Smart Choice layers in the YourSite database
To view Intelligent Queue Smart Choice layers in the YourSite database

l Click YourSite=>Configuration=>Intelligent Queue=>Smart Choice=>Smart Choice layer
The Intelligent Queue Smart Choice layer window opens.
UnderName, the Intelligent Queue Smart Choice layer names are listed.
UnderReporting, the Intelligent Queue Smart Choice layer reporting numbers are listed.
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Adding Intelligent Queue Smart Choice layer groups to the YourSite
database
To add an Intelligent Queue Smart Choice layer group to the YourSite database
 1. Click YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart

Choice=>Intelligent Queue Smart Choice layer group.
The Smart Choice layer group window opens.

 2. Click Add.
 3. AfterReporting, type the reporting number of the Smart Choice layer group.
 4. AfterName, type the name of the Smart Choice layer group.

Adding Intelligent Queue Smart Choice layers to an Intelligent Queue
Smart Choice layer group
To add Intelligent Queue Smart Choice layers to an Intelligent Queue Smart Choice layer group
 1. Click YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart

Choice=>Intelligent Queue Smart Choice layer group.
The Smart Choice layer group window opens.

 2. Across from the record of the Smart Choice layer group just created, click Members.
 3. UnderAvailable members, select the check boxes of themembers you want to add to the group and

click >>.
 4. Click Save.

Intelligent Queue ports
In this section, you will learn how to use Intelligent Queue ports.

Viewing Intelligent Queue ports in the YourSite database
To view Intelligent Queue ports in the YourSite database
 1. Click YourSite=>Configuration=>Intelligent Queue Smart Choice=>Intelligent Queue Smart

Choice port
The Intelligent Queue Smart Choice port window opens.

 2. UnderMedia server, themedia server associated with each Intelligent Queue port is listed.
 3. UnderReporting number, the Intelligent Queue port reporting numbers are listed.
 4. UnderName, the Intelligent Queue port names are listed.
 5. UnderDialable number, the dialable numbers are listed.

Adding Intelligent Queue port groups to the YourSite database
To add an Intelligent Queue port group to the YourSite database
 1. Click YourSite=>Configuration=>Intelligent Queue Smart Choice=>Intelligent Queue Smart

Choice port group.
The Intelligent Queue Smart Choice port group window opens.

 2. Select Add.
 3. AfterReporting number, type the Intelligent Queue port group reporting number.
 4. AfterName, type the Intelligent Queue port group name.
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Adding Intelligent Queue ports to an Intelligent Queue port group
To add Intelligent Queue ports to an Intelligent Queue port group
 1. Click YourSite=>Configuration=>Intelligent Queue Smart Choice=>Intelligent Queue Smart

Choice port group.
The Intelligent Queue Smart Choice port group window opens.

 2. Across from the record of the Intelligent Queue Smart Choice port group just created, click Members.
The Edit Intelligent Queue Smart Choice port groupmembers window opens.

 3. UnderAvailable Intelligent Queue Smart Choice ports, select the check box of themember you
want to add to the group and click >>.

Intelligent Queue exit codes
Exit Codes trigger each exit from a queue or from the auto attendant. They apply to Smart Choicemessage
queues, RAD queues, and routing queues.

Viewing Intelligent Queue Smart Choice layer exit codes in the YourSite
database
To view Intelligent Queue Smart Choice layer exit codes in the YourSite database

l Click YourSite=>Configuration=>Intelligent Queue=>Intelligent Queue Smart Choice layer exit
code.
The Intelligent Queue Smart Choice layer exit code window appears.
Under Reporting number, the Intelligent Queue exit code reporting numbers are listed.
Under Name, the Intelligent Queue exit code names are listed.

Creating reports
Youmust have Contact Center Management (version 4 or greater), a Contact Center Management Enterprise
Node license, and Excel to view reports. They all must be installed prior to installing Intelligent Queue.

Before you can produce a report
The Intelligent Queue server must point to both of the following:

l Contact Center Management server
l Contact Center Management Enterprise Node (requires the Enterprise Node license)

The Contact Center Management database automatically synchronizes with the paths, ports, and exits
information provided by Intelligent Queue. From the real-time SMDR and ACD, Intelligent Queue data is
generated that drives the reports.

NOTE: If you want to produce reports on agents (Intelligent Queue ports), youmust create unique employee
IDs and then associate these employee IDs to the agents.

Report types
The reports are found at www.prairiefyre.com (requires Internet Explorer 6 or greater). You can create two
types of reports: Smart Choice Layer reports and Smart Choice Port reports.
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Smart Choice reports
The Smart Choice reports consist of the following types:

l Smart Choice Layer Reports
Smart Choice Layer reports provide statistics on layer use.

l Smart Choice Layer Group by Layer
l Smart Choice Layer Group by Exit Code
l Smart Choice Layer Group by Layer by Exit Code

l Smart Choice Port Report
Smart Choice Port reports provide statistics on the calls routed through ports associated with Smart
Choicemessaging.

l Smart Choice Port Group Performance by Port

Smart Choice Layer Group by Layer
The Smart Choice Layer Group by Layer report shows call statistics for each layer associated to the layer
group. (See Table 18 - 5.)

Report Field Description

Total calls entering layer the total number of calls that reach the layer in the decision tree

Total number of repeats the total number of repeats that occurred on this layer

Total true calls entering calls the number of distinct calls entering the layer

Total calls exiting layer the total number of calls that exit the layer to go to another layer or
answering point (path, extension, or voicemailbox)

Total calls terminating in layer the total number of calls abandoned on the layer

Total duration in layer (hh:mm:ss) the total duration of calls, from the time they enter the layer to the time
they exit the layer

Average duration in layer
(hh:mm:ss)

the average duration for calls in the layer, from the time they enter the
layer to the time they exit the layer

Table 18 - 5 Smart Choice Layer Group by Layer

NOTE: The prairieFyreMaintenanceManager deletes ANI records that are 15 days or older each night at 2:00
A.M. In addition, ANI records are deleted chronologically when the number of records in the database exceeds
10,000.

Smart Choice Layer Group by Exit Code
The Smart Choice Layer Group by Exit Code report shows calls statistics for each exit code selected inside a
layer. Smart Choice Layer Group by Exit Code report provides the following information: (See Table 18 - 6.)

Report Field Description

Total count the total number of calls that leave the layer group by selected code

Table 18 - 6 Smart Choice Layer Group by Exit
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Report Field Description

Total duration (hh:mm:ss) the total duration of calls, from the time they are picked up by the port to
the time they exit the layer

Average duration (hh:mm:ss) the average duration of calls, from the time they are picked up by the
port to the time they exit the layer

Total the total of each of the columns

Smart Choice Layer Group by Layer by Exit Code
The Smart Choice Layer Group by Layer by Exit Code report shows calls statistics for each exit code
selected inside a layer, for each layer associated to the layer group.

Smart Choice Layer Group by Exit Code report provides the following information. (See Table 18 - 7.)

Report Field Description

Exit code number the number of the exit code

Exit code name the name of the exit code

Total count the total number of calls that leave the layer group by selected code

Total duration (hh:mm:ss) the total duration of calls, from the time they are picked up by the port to
the time they exit the layer

Average duration (hh:mm:ss) the average duration of calls, from the time they are picked up by the
port to the time they exit the layer

Table 18 - 7 Smart Choice Layer Group by Layer by Exit Code

Smart Choice Port Group Performance by Port
The Smart Choice Port Group Performance by Port report shows call statistics for each port associated with
the Smart Choice Tree selected. (See Table 18 - 8.)

Report Field Description

Total Smart Choice calls the total number of calls that reach the layer that are Smart Choice
(automated attendant guided) calls

Total duration (hh:mm:ss) the total duration of calls, from the time they are picked up by the
port to the time they exit the layer

Average duration (hh:mm:ss) the average duration of calls, from the time they are picked up by the
port to the time they exit the layer

Table 18 - 8 Smart Choice Port Group Performance by Port
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Report Field Description

Averagemenu choices per call the average number of menu choices callers select while in the
Smart Choice tree

Total calls ending in Smart Choice the total number of callers that hang up while in the Smart Choice
tree

Total calls transferred out from Smart
Choice

the total number of calls that are transferred out of the Smart Choice
tree to another answering point such as Path or Extension

Recording voice prompts
You can record unique messages, use the providedmessages (in US English, UK English, NA French, EU
French, EU Spanish, LA Spanish, Dutch) or replace voice prompts provided by Intelligent Queue with your
ownmessages. Your .wav files must have the following format:

l Bitrate: 64 kbps
l Audio sample size: 8 bit
l Channels: 1 (mono)
l Audio sample rate: 8kHz
l Audio format: CCITT u-Law

We suggest you keepmessages short. The longer themessage, the greater the number of ports the system
requires. If all of the ports are busy playingmessages to callers, new callers have to wait until the previous
message finishes before they are answered.

Recording messages
There are two ways to record Intelligent Queuemessages: use amicrophone or a telephone. The quality of the
messages is higher if you recordmessages with amicrophone, rather than a telephone.

Recording messages with a microphone
To recordmessages with amicrophone, follow the directions that comewith your recording software. Save
the audio files in the .wav format. Intelligent Queue requires a specific type of .wav file. To convert them to the
format that Intelligent Queue requires, see "Converting .wav files" on page 633.

Recording messages with a phone, using Intelligent Queue
To record amessage with a phone
 1. On theManage=>Actions=>Managementwindow, click theOptions tab.
 2. AfterRecording prompts via phone is... select Enabled.
 3. Click Save.
 4. If you have set up your management plan, skip to step 6. If you have not, see "Setting upmanagement

plans" on page 606.
See "Defining themessages within your management plan" on page 606.

 5. On your phone, dial your password to enter Intelligent Queue.
 6. Press 1 to record amessage.
 7. Record your message.
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 8. Press any number to stop recording amessage.
Your recordedmessages, by default, are saved under the Voice folder, Inbox. The name of the
recordedmessage is: month, day, year, hour, minute, second.wav. For example, 11-2-2006 - 8hr 28m
46s.wav.

 9. Locate the recordedmessage and click on it to listen to themessage.
 10. If you want to keep themessage, rename themessage to somethingmeaningful now. For example, if it

is the greeting, rename it “Greeting.” Or, if you want to replace a voice prompt provided with Intelligent
Queue, re-name themessage you recorded with the name of themessage you want to replace.

 11. Move themessage to the appropriate locationC:\Program Files\Mitel Networks\Intelligent
Queue\Languages\[Language Name].

 12. Design your call flow.
See "Managing call flows" on page 613.

Converting .wav files
If you created your voice recordings on an external source, youmust convert your .wav files to the format
Intelligent Queue requires.

To convert .wav files to the correct format
 1. Click Start=>Programs=>Accessories=>Entertainment=>Sound Recorder.

The Sound Recorder window opens.
 2. Click File=>Open and select the file you want to convert.
 3. Click Open.
 4. Click File=>Save As.

The Save As window opens.
 5. Click Change.

The Sound Selection window opens.
 6. After Format, select CCITT u-Law.
 7. AfterAttributes, select 8.000 kHz, 8 Bit, Mono 7 kb/sec.
 8. Click OK.
 9. If you do not want to overwrite the original file, change the file name.
 10. AfterSave as type, verify that Sounds (*.wav) is selected.
 11. Click Save.

Readback .wav file names
Dollars, cents, euros, pence, pounds, negative numbers, and decimal numbers, although supported in all
languages, are provided in US English and UK English only. Youmust record your own .wav files if you want
them in additional languages. The files are located in the following directory: \\Voice\language\System\. There
are ten language folders: US English, UK English, NA French, EU French, EU Spanish, LA Spanish, Dutch,
Brazilian Portuguese, SimplifiedMandarin Chinese, and Italian. See "Recording voice prompts" on page 632.
(See Table 18 - 9).

.wav files Example

Dollars.wav (plural) For example “two dollars.”

Dollars-singular.wav For example “one dollar.”

Table 18 - 9 Smart Choice Port Group Performance by Port
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.wav files Example

Cents.wav (plural) For example “two cents.”

Cents-singular.wav For example “one euro.”

Euros.wav (plural) For example “two euros.”

Euros-singular.wav For example “one euro.”

Negative.wav For example “negative three.”

Pence.wav (plural) For example “two pence.” (When you record the .wav file, youmust
save it as Pence.wav and Pence-singular. wav to be used in both
the singular and plural instance.)

Pence-singular.wav For example, one pence. (When you record the .wav file, youmust
save it to be used in both the singular and plural instance.)

Point.wav For example “point 45."

Pounds.wav (plural) For example “two pounds.”

Pounds-singular.wav For example “one pound.”

Recorded phrases
The phrases are located inC:\Program Files\Mitel Networks\Intelligent Queue\Languages\[Language
Name]. You can enter amessage defined using the Voice Prompts tab.

NOTE: The UK English .wav file scripts are identical to the US English .wav file scripts. (See Table 18 - 10.)

File
Name

Script

FR-1.wav Tous nos représentants sont présentement occupés. On vous répondra dès qu'un d'entre eux
sera disponible.

FR-2.wav Bonjour! Merci de votre appel. Tous nos représentants sont présentement occupés. On vous
répondra dès qu'un d'entre eux sera disponible.

FR-3.wav ***Exact same recording as FR-2***

FR-4.wav Merci de votre appel. En raison du nombre d’appel actuel, le temps d’attente sera d’environ...

FR-5.wav Merci de votre appel. En raison du nombre d’appel exceptionnellement élevé, le temps d’attente
sera d’environ...

Table 18 - 10 Included .wav files
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File
Name

Script

FR-6.wav Minute

FR-7.wav Merci de votre appel. Le temps d’attente est présentement de cinq à dix minutes. Veuillez
patienter pour conserver votre priorité d’appel. Merci de votre compréhension.

FR-8.wav Merci de votre appel. En raison du nombre d’appel exceptionnellement élevé, le temps d’attente
excède dix minutes. Veuillez patienter pour conserver votre priorité d’appel. Merci de votre
compréhension.

FR-9.wav Cette option n’est pas disponible.

FR-10.wav Merci de votre appel. Nos bureaux sont présentement fermés. Veuillez rappeler du lundi au
vendredi de 8h à 17h.

FR-11.wav Merci de votre appel. Nos bureaux sont présentement fermés en raison du jour férié. Veuillez
rappeler du lundi au vendredi de 8h à 17h.

FR-12.wav Merci de votre appel. En raison du nombre d’appel exceptionnellement élevé, on vous répondra
dès qu’un représentant sera disponible. Merci de votre compréhension.

FR-13.wav Veuillez composer un numéro de téléphone où vous joindre, suivi du carré.

FR-14.wav Vous avez composé le...

FR-15.wav Si ce numéro est exact, faites le un. Autrement faites l’étoile.

FR-16.wav Veuillez enregistrer votre nom après la tonalité. Lorsque vous aurez terminé l’enregistrement,
faites le un.

FR-17.wav Pour soumettre cette demande de rappel, faites le un. Pour l’annuler et quitter le système, faites
l’étoile.

FR-18.wav Vous avez une demande de rappel vocale.

FR-19.wav Vous avez une demande de rappel internet.

FR-20.wav Pour écouter le message de l’appelant, faites le un. Pour écouter cet appel, faites le deux. Pour
replacer cette demande en file d’attente, faites le trois. Pour la rejeter, faites le quatre. Pour
écouter ces options de nouveau, faites l’étoile.

FR-21.wav Pour écouter le nom de l’appelant, faites le un. Pour écouter cet appel, faites le deux. Pour
replacer cette demande en file d’attente, faites le trois. Pour la rejeter, faites le quatre. Pour
écouter ces options de nouveau, faites l’étoile.

FR-22.wav Veuillez patienter pendant que nous effectuons l’appel.

FR-23.wav Connexion en cours.

FR-24.wav Il y a d’autres demandes de rappel.
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File
Name

Script

FR-25.wav Il n’y a pas de demande de rappel en attente.

FR-26.wav Votre rappel. Nous vous communiquons à un représentant maintenant.

FR-27.wav Le rappel n’a pu être établi.

FR-28.wav Votre appel est acheminé. Unmoment s’il vous plait.

FR-29.wav Votre demande a été annulée. Au revoir.

FR-30.wav Merci de votre appel. On vous répondra dès qu’un représentant sera disponible. Au revoir.

FR-31.wav Veuillez s’il vous plait composer votre mot de passe de gestionnaire.

FR-32.wav Pour enregistrer les invitations du système, composez le un. Pour changer le mode d’opération
de ce système, composez le deux.

FR-33.wav Commencez à parler après la tonalité. Quand vous aurez terminé, appuyez sur n’importe quelle
touche.

FR-34.wav Enregistrement terminé. Votre enregistrement a été sauvegardé dans votre boîte de réception.

FR-35.wav Pour configurer vos ports d’accès, enmode normal, composez le un. Pour les configurer en
mode d’urgence, composez le deux.

FR-36.wav Vos faisceaux d’accès fonctionnent maintenant enmode normal.

FR-37.wav Vos faisceaux d’accès fonctionnent maintenant enmode d’urgence.

FR-38.wav Cette sélection n’est pas valide.

FR-39.wav Le nombre d’appelants en attente est de...

FR-40.wav Votre rang dans la file d’attente est...

FR-41.wav Votre demande a étémise dans la file d’attente...

FR-42.wav D’attente la plus longue est de...

NA-1.wav All of our representatives are busy helping other callers. Your call will be answered as soon as
an agent becomes available.

NA-2.wav Goodmorning, and thank you for calling. All of our representatives are busy helping other
callers. Your call will be answered as soon as an agent becomes available.

NA-3.wav Good afternoon, and thank you for calling. All of our representatives are busy helping other
callers. Your call will be answered as soon as an agent becomes available.

NA-4.wav Thank you for calling. Based on current call volumes, the expected wait time is...
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File
Name

Script

NA-5.wav Thank you for calling. Due to the unusually high number of calls, the expected wait time is...

NA-6.wav ...minutes.

NA-7.wav Thank you for calling. The current wait times are between 5 and 10minutes. Please continue to
hold tomaintain your call priority. We thank you for your patience.

NA-8.wav Thank you for calling. Due to the unusually high volume of calls, the current wait times are
greater than 10minutes. Please continue to hold tomaintain your call priority. We thank you for
your patience.

NA-9.wav That option is not available.

NA-10.wav Thank you for calling. Our offices are now closed. Please call back Monday to Friday.

NA-11.wav Thank you for calling. Our offices are now closed for the holiday. Please call back Monday to
Friday, between the hours of 8 A.M. and 5 P.M.

NA-12.wav Thank you for calling. We are currently experiencing an unusually high volume of calls. Your call
will be answered as soon as an agent becomes available. We thank you for your patience.

NA-13.wav Please enter a telephone number where you can be reached, followed by the pound sign.

NA-14.wav You have entered...

NA-15.wav If this is correct, press one. If this is not correct, please press the star key.

NA-16.wav At the tone, please record your name. When you have finished recording, press one.

NA-17.wav To submit this callback request, press one. To cancel this request and leave the system,
please press the star key.

NA-18.wav You have a voice callback request.

NA-19.wav You have aWeb callback request.

NA-20.wav To listen to the caller’s message, press one. To place this call, press 2. To requeue this
request, press 3. To reject this request, press 4. To hear these options again, press star.

NA-21.wav To listen to the caller’s name, press one. To place this call, press 2. To requeue this request,
press 3. To reject this request, press 4. To hear these options again, press star.

NA-22.wav Please wait while the call is established.

NA-23.wav Connecting now.

NA-24.wav There are additional callback requests.

NA-25.wav There are no outstanding callback requests.



Contact Center Solutions User Guide

- 638 -

File
Name

Script

NA-26.wav You have a callback. We are connecting you to an agent now.

NA-27.wav The callback could not be established.

NA-28.wav Your call is being routed. Onemoment please.

NA-29.wav Your request has been cancelled. Goodbye.

NA-30.wav Thank you for calling. Your call will be answered as soon as an agent becomes available.

NA-31.wav Please enter your management password.

NA-32.wav To record system prompts, press 1. To change the system’s operatingmode, press 2.

NA-33.wav Begin speaking after the tone. When finished, press any digit.

NA-34.wav Recording complete. Your recording has been saved in your inbox.

NA-35.wav To put your ports in normal mode, press 1. To put your ports in Emergency mode, press 2.

NA-36.wav Your port groups are now operating in normal mode.

NA-37.wav Your port groups are now operating in emergency mode.

NA-38.wav That selection is invalid.

NA-39.wav The number of calls waiting is...

NA-40.wav Your position in queue is...

NA-41.wav Your request has been requeued...

NA-42 The longest call waiting is...

Web Callback
WithWebCallback, callers can submit callback requests from the company website. Each caller must type a
telephone number, name, and time framewithin which the call should be returned. You can download an
example of aWebCallback page and edit it for use by company. (See Figure 18 - 2.)

Viewing the Web Callback example page
You can view theWebCallback example page at
<installation_drive>:\ Files\Mitel Networks\6160\WebCallbackExamples\VBDotNet.
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Customizing your Web Callback page
You edit elements of theWebCallback example to create your own customizedWebCallback page.

You can edit the following files
l Header.aspx
l Footer.aspx
l Styles.aspx
l Web.config
l WebCallback.aspx
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Figure 18 - 2 Web Callback

Customizing the header
In the example, the header consists of theMitel logo and the words “Intelligent Queue.”

To edit the header image
 1. Create a .gif image to replace theMitel header.
 2. UnderWebCallback\IMAGES folder, save the file as header_product_mitel_iq.gif.

The new image will replace theMitel header.
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Customizing the footer
In the example, the footer consists of theMitel logo with the words “It’s about YOU.”

To edit the footer image
 1. Create an gif image to replace theMitel footer.
 2. UnderWebCallback\IMAGES folder, save the file as MitelLogo_ABOUT_YOU_20percent.jpg.

The new image will replace theMitel footer.

Customizing the Cascading Style Sheet
The Cascading Style Sheet (CCS) defines how HTML elements are displayed. CCS enables you to control
the style and layout of multipleWeb pages all at once.

To edit the CCS
 1. OpenStyles.css.
 2. Edit the heading and body font sizes and styles, or spacing.
 3. Click Save.

Customizing the Web configuration
This is the configuration file for theWebCallback page. Review the following settings to ensure theWeb
Callbacks function properly.

The following settings are used in theWebCallback example. (See Figure 18 - 3.)

Figure 18 - 3 Web Callback example.

To edit theWeb configuration
 1. OpenWeb.config.
 2. If you use SSL, add an s after http in <add key="WebCallbackService.CallbackWebService"

value="http://localhost/6160/CallbackWebService.asmx"/> andmodify localhost to what was
specified in the CSR request under CommonName (CN).

 3. After “WebCallbackService.CallbackWebService” value=” ensure it states your Intelligent Queue
website address.
The default value provided is correct unless you changed the default name of the virtual directory when
you installed Intelligent Queue.
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 4. After “Web Callback Plan Name” value=” replacewebCallbackwith the name of the callback plan
you defined in Intelligent Queue.
The plan will be executed when the user submits aWeb callback.

 5. After “YourCountryCode” value=” replace 1 with your country code.
 6. After “IDDInternationalDialingPrefix” value=” replace 011with the international prefix your company

uses as part of the telephone number to return the callback.
This value is used only when the callback request destination IDD is different from your IDD.

 7. Click Save.

Customizing the content of the Web Callback page
You can change the content of theWebCallback page to reflect your business, however, below is a list of
critical elements that youmust not change or remove. (See Table 18 - 11.)

Variable Function

txtName This is the text box for the client’s name.

RequiredFieldNameValidator This is the required field validator for txtName.

txtPhoneNumber This is the text box for the phone number.

phoneNumberRegexValidator This validates whether the value in txtPhoneNumber is a valid
phone number.

RequiredFieldPhoneNumberValidator This is the required field validator for txtPhoneNumber.

nonNorthAmericanNumberRegexValidator This validates whether the value in txtPhoneNumber is a valid
phone number outside of north America.

rblLongDistance This is the radio button list for choosing whether the phone
number is long distance.

RequiredFieldLongDistanceValidator This is the required field validator to ensure the user has said
Yes or No to whether the phone number entered is long
distance.

lblCountryCode This is the corresponding label for ddlCountryCode drop down
list and this can not be deleted because it’s visibility is toggled
based on if you choose yes or no to whether the call is long
distance or not. However, the label’s text can be changed to
say anything.

ddlCountryCode This is the drop down list for the country codes.

ddlPriority This is the drop down list to select the priority of the callback.

rlbExpire This is the radio button list for choosing whether this callback
should expire.

Table 18 - 11 Critical elements that must not be changed or removed
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Variable Function

lstHours This is the list box for selecting the value for the number of
hours till this callback expires.

btnSubmit This is the submit button.

btnNewRequest This is the ‘clear form’ button.

ValidationSummary This is where any validation errors or submit errors will be
displayed.

To edit WebCallback page content
 1. OpenWebCallback.aspx.
 2. Edit the content.
 3. Click Save.

Troubleshooting Intelligent Queue issues
This section includes information on troubleshooting

l The database
l Event logs
l Web access to Intelligent Queue
l Intelligent Queuemusic and telephony services
l Intelligent Queue installation from a local or shared hard drive
l Updated position in queue
l Internet ExplorerWebControls

See Table 18 - 12.

Problem Reason Possible Solution

"Invalid username and
password" when
logging in with the
default username and
password.

The passwordmight be
incorrect.

Double check the password with attention to the
use of upper and lower cases.

The RAD message
does not play the
completemessage
file.

The Answer Plus Message
Length Timer and the
expected Offhook Timer in the
Class of Service Options
Assignment form are
incorrect.

See "Configuring ports" on page 584.
See "Types of messages" on page 576 and
"Length of messages" on page 577.

The ACD paths are
not shown under Time
in Queue settings of

You have not purchased
Contact Center Management

Purchase the application.

Table 18 - 12 Troubleshooting
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Problem Reason Possible Solution

RAD ports in
Administration.

version 5 and the Time in
QueueOption.

Intelligent Queue and Contact
Center Management are not
communicating.

Type the correct IP address for the Contact
Center Management server if Intelligent Queue is
a remote installation.
See "Configuring Contact Center Management
settings" on page 585.
The host name should be found if the server
address is entered correctly.

Intelligent Queue and Contact
Center Management are
located on different subnets.

Type the gateway information in your TCP/IP
properties. Test your connection to the gateway
with the ping utility.

The ACD paths are
not shown in themenu
when creating a
Queue plan.

The Time In Queue Settings
were not applied.

See "To create a queue plan" on page 611.

Nomessages will be
shown under my plans
when defining
messaging plans.

You have not associated any
messages with this plan.

See "Setting upmessaging plans" on page 603.

You do not have audio
or DTMF reception, or
your ports do not
work.

The Intelligent Queue Server
must be on the same subnet
as the PBX.

Put the Intelligent Queue Server on the same
subnet as the PBX.

Troubleshooting using the configuration wizard
You can perform the following actions using the configuration wizard. (See Table 18 - 13.)

Action Reason

Re-register DLLs Music volume cannot be controlled.

Log cleanup Logs are taking up toomuch hard drive space.

Database cleanup Database errors.

IIS Reconfiguration Website errors.

Restart all Intelligent Queue services Severe telephony issues or the database will not refresh.

Table 18 - 13 Troubleshooting using the configuration wizard
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Action Reason

Port enumeration Ports are added. See "Configuring ports" on page 584.

Databasemigration Database upgrade.

Establishing a connection to the database
If you try to start Intelligent Queue and are unable to establish a connection to the database, the Database
Error window opens. (See Figure 18 - 4.)

Figure 18 - 4 Database Error window

There are a couple of ways to troubleshoot the database.
l Using the Control Panel to verify that SQL Server has been started
l Viewing the tray icon to verify that SQL Server has started

Scenario 1: Using Control Panel to verify SQL Server has started
To verify that SQL Server has started
 1. From the Start Menu, select Settings/Control Panel/Administrative Tools/Services.
 2. Scroll down toMSSQLSERVER and verify that the service has started.

NOTE: The start icon in the toolbar has been disabled.
The Services window opens with MSSQLSERVER started.
See Figure 18 - 5.

 3. To start, stop, or restart the service, click the corresponding icons in the toolbar. Or click theAction
menu, and then click the appropriate icon from within the dialog box.
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Figure 18 - 5 Services window with MSSQLSERVER started

Scenario 2: Viewing the tray icon to verify SQL Server has started
To verify that SQL Server has started
 1. Locate the SQL Server Service icon in your tray.

l A tower icon with a green arrow means that the service is running.
l A tower icon with a red squaremeans that the service has stopped.

 2. Double-click the tray icon or right-click to select Open SQL Server Service Manager menu.
If the SQL Server is running, the SQL Services are running window appears.
If the SQL Server is not running, the SQL Services have stopped window appears.
NOTE:Accept the default selection toAuto-start service when OS starts.

Viewing event logs
From the Control Panel, you can access the following Administrative Tools:

l Event Viewer
l Internet Services Manager
l Services

Logging events
Event Viewer is used to view andmanage logs of system, application, and security events on your computer.
Event Viewer gathers information about hardware and software problems, andmonitors Windows security
events.

To view logs
 1. Click Status=>Log Viewer
 2. Click theCall Logs tab.

The Call Logs tab appears.

Event logging applies to all incoming and outgoing calls on the Intelligent Queue system. Logging begins when
a call is first detected and ends when the call is terminated by transfer, or hang-up. Each log contains a plain
English record of the event. The following events will cause an event to be logged:
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Call Received
When a call is first received by Intelligent Queue, all known properties of the call will be logged, including the
following properties: the date/time stamp of the call, caller’s telephone number, digits dialed, redirection
information, caller’s name, and the Intelligent Queue port that received the call.

For 5000/Axxess configurations that use CT Gateway, time stamps are based on the Enterprise Server’s PC
clock. If the 5000/Axxess configuration includes Remote Servers, then time stamps are based on the Remote
Server’s PC clock. For the 3300 ICP, time stamps are based on the telephone system clock.

Action Plan Selected
Once an action plan has been selected, the plan, as well as the selection criteria used, will be written to the
logs.

System Action
All actions taken by the Intelligent Queue port will be written as logs. System actions include any function that
affect the call, such as answering or redirecting a call, playing or recording amessage, beginning a transfer,
dialing or hanging up.

Caller Action
All actions taken by a caller while connected to an Intelligent Queue port will be logged. Caller actions include
the following: pressing a DTMF digit, and recording a voicemessage.

Agent Action
The actions that an agent takes during a callback will be logged. Agent actions include the following:
answering, hanging up, and pressing a digit.

Callback Action/ Callback Event
All Callback actions/ events will be logged including the following: Agent Attempted, Agent Accepted, Agent
Rejected, Agent Re-queued, Caller Attempted, Caller Answered, Callback Connected, Callback Failed (and
the reason the callback failed).

Gaining Web access to Intelligent Queue
You can use the Internet Services Manager to manage your Internet Information Services (IIS) which enables
web access to Intelligent Queue. Intelligent Queue is a web-based application and IIS is theWindows
component that makes it easy to publish information and bring business applications to theWeb. With IIS,
you can create a strong platform for network applications and communications.

If you are having difficulty gainingWeb access to Intelligent Queue, troubleshoot your IIS:
 1. From the Start Menu, click Settings/Control Panel/Administrative Tools/Internet Services

Manager.
 2. Verify that your PC is connected.

See Figure 18 - 6.
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Figure 18 - 6 Internet Information Services window with connected PC

 3. Click the PC to expand the tree view
 4. Verify whether the Default FTP Site, Web Site, and SMTP Virtual Server are running.

See Figure 18 - 7.

Figure 18 - 7 Internet Information Services window with defaults

 5. Click any of these defaults and click the Intelligent Queue folder to view the details. The Intelligent
Queue folder contains the same files as theWebroot folder.
See Figure 18 - 8.
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Figure 18 - 8 Internet Information Services window with Intelligent Queue folder expanded

Troubleshooting the login
Inability to see the login window when launching Intelligent Queuemight be the result of one or more of the
following problems:

l If you are seeing a page of HTML code instead of the login window, you will need to use to the aspnet_
regiis.exe tool.

l If you are seeing a white page instead of the login window, you need to verify that the ASP.NET State
Service is present and running.
NOTE:You can havemultiple versions of the .NET framework on your PC. The versions are located in
the following directory: systemroot\Microsoft.NET\Framework\v1.x.xxxx. Intelligent Queue tests for
the presence of version 1.14322.

Using the aspnet_regiis.exe tool
 1. InWindows, open the command prompt window.
 2. At the > prompt, type in cd C:\WINNT\Microsoft.NET\Framework\v1.1.4322 and press Enter.

NOTE: If your System Drive is on another drive, the installation would have defaulted to that drive.
 3. At the > prompt, type in aspnet_regiis.exe -i.

See Figure 18 - 9.
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Figure 18 - 9 Running the aspnet_regiis.exe tool

Verifying the ASP.NET State Service
During installation, the Intelligent Queue setup application tests for the presence of the ASP.Net State
Service. If it is missing, an error message appears.

If ASP.NET State Service is not installed
This error represents a potential problem with the .NET framework. Some possible solutions are as follows:

l Restart the PC
l Open the Services control panel and check for the presence of ASP.NET State Service. Start the

service if required.
l If you are unable to find theASP.NET State Service, youmight want to remove the .NET Framework

and reinstall it.

If ASP.NET State Service is not started
During installation, the Intelligent Queue setup application changes the ASP.NET State Service startupmode
to Automatic. When the user restarts the PC after the installation, the ASP.NET Service should start
automatically. If it does not, use the following procedure to start ASP.NET:
 1. Open the Services Control Panel.
 2. Look for the ASP.NET State Service.
 3. Start the service.
 4. Change the startup type to "Automatic" if required.

If ASP.NET State Service cannot be started due to error message “Could not start
ASP.NET State Service”
See the followingMicrosoft Knowledge Base article:

l http://support.microsoft.com/default.aspx?scid=kb;en-us;827189

Setting the Intelligent Queue Web session timer
The Intelligent QueueWeb session timer default value is fiveminutes. After fiveminutes of inactivity, you will
be logged out.

NOTE: TheWeb session timer valuemust be between 1 and 20minutes.
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To increase theWeb session timer threshold value
 1. Browse to <Intelligent Queue Installation folder>\XML\CONFIG\.
 2. OpenGlobalSetttings.xml.
 3. Locate the <SESSION_TIMEOUT>5</SESSION_TIMEOUT> tag.
 4. Change theWeb session timer from the default (5) to a value you specify.

NOTE: TheWeb session timer valuemust be entered inminutes.
 5. Save the file.

Using the Services tool
You can use the Services tool to manage the Intelligent QueueMusic and Telephony Services on your
computer, to set recovery actions to take place if a service fails, and to create custom names and
descriptions for services so that you can easily identify them.

Services are used tomanage the services on your computer, set recovery actions to take place if a service
fails, and to create custom names and descriptions for services that are easily identifiable.

To troubleshoot Intelligent QueueMusic and Telephony Services
 1. InWindows, navigate toServices.
 2. Select Settings/Control Panel/Administrative Tools/Services.
 3. View the IQR3Music and IQR3 Telephony and verify that they are running.
 4. You can click the appropriate icon in the taskbar to start, stop, or restart the services.

NOTE:Pause is not supported in Intelligent Queue Release 3.0.
See Figure 18 - 10.

Figure 18 - 10 Services window with Music and Telephony services started

Installing Intelligent Queue from a shared or local drive
If you attempt to install Intelligent Queue from a shared or local drive, youmight experience the following
issues.
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Scenario 1: Receiving a System IO Error
If you are installing Intelligent Queue from a directory with a long path or a path namewhich includes spaces,
youmight receive a System IO Error which will halt the installation.

Solution: Use a short directory namewithout spaces, such as C:\6160Install.

Scenario 2: Being unable to install Microsoft .Net Framework
If theMicrosoft .Net Framework is not present when you are installing Intelligent Queue and a popup appears
asking if you want to install it now, the installation of theMicrosoft .Net Framework might not initialize when
you click Yes.

Solution: Run the dotnetfx.exe from the NetFramework directory.

Receiving an Updated position in queue message
If your caller does not receive an Updated position in queuemessage, it could be because of one of the
following two reasons:

l There are toomany Updated position in queuemessages for the switch to process.
l There are not enough ports to provide amessage to each caller who is programmed to receive a

Updatedmessage in queue.

There are too many Updated position in queue messages
The number of Updated position in queuemessages (tap internal calls) your switch can handle is 1500 or less.
If the number of Updated position in queuemessages exceeds the recommended number, somemessages
will be delayed or might not play at all. You will need to reduce the number of Updated position in queue
messages, or increase the number of ports.

There are not enough ports
If you do not have an adequate number of ports to run Intelligent Queue, as programed, your callers might not
receive Updated position in queuemessages. Intelligent Queue provides queues with the greatest priority
ports first. If you run out of ports, it is queues with lower priorities that would not receive the Updated position
in queuemessages.

If Updated position in queue is running low on ports you will receive an error message. If you run out of ports
you will receive a critical error message. In the event that you receive either of thesemessages, you can take
one of the following actions tomakemore ports available:

l Purchasemore ports as required.
l Decrease the frequency of queue updates.
l Decrease the number of users updated in the queue.
l Reduce the number of queues beingmonitored.
l Reduce the number of Updated position in queuemessages.
l Reassign ports to Updated position in queue.

You can use the port sizing tool to determine the number of ports you require to run Intelligent Queue. See
"Planning the number of ports you require" on page 573.
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Your callers hear only a position, not a message
If your callers hear only their position in queue, for example, “3” or “2,” you did not record the Updated position
in queuemessage. Intelligent Queue Updated position in queue will provide the position but will not provide
themessage. If you want the callers in queue to hear amessages, for example, “Your call will be answered
next” or “You are in position...” youmust record themessage. See "Recording voice prompts" on page 632.

Updated Position in Queue and RAD messages do not play when
expected
Updated Position in Queue logic is handled directly by Intelligent Queue whereas RAD logic is handled by the
telephone system; therefore there is an inherent limitation when combining the two technologies. Updated
Position in Queue functionality interferes with the way a RAD operates. To prevent the interference, when
Updated Position in Queue and RAD messages are played for the same queue, youmust program the initial
Updated Position in Queuemessage to play before the first RAD message, and subsequent Updated Position
in Queuemessages to play after the last RAD message.

Configure Intelligent Queuemessages in the following order:
 1. Updated Position in Queue 1: 5 seconds
 2. RAD1: 20 seconds
 3. RAD2: 20 seconds
 4. RAD3: 30 seconds
 5. Updated Position in Queue 2: 2minutes

Removing Internet Explorer WebControls from a workstation
To remove the Internet ExplorerWebControls from aworkstation, perform the following
 1. InWindows, navigate to theControl Panel.
 2. Double-click Add/Remove Programs.
 3. In the Add/Remove Programs properties dialog box, select Internet Explorer WebControls and then

click Add/Remove. The InstallShield wizard will appear.
 4. Select Remove and click Next. The uninstall wizard will then remove the Internet Explorer

WebControls.
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Workforce Scheduling
Workforce Scheduling is an optional application that works in conjunction with Contact Center Management
and theMitel 3300 ICP, SX-200 ICP, 5000 CP, and Axxess. You configure employees in YourSite Explorer
and schedule them withWorkforce Scheduling. Using historical data from Contact Center Management,
Workforce Scheduling forecasts the number of employees required tomeet your contact center's Service
Level objectives. UsingWorkforce Scheduling, you can build schedules with forecast information. If you enter
employee payroll information in YourSite Explorer, Workforce Scheduling can use this information for
scheduling and budgeting purposes.

To install Workforce Scheduling, select theWorkforce Scheduling option in Client Role Selector.

NOTE: In order to access Workforce Scheduling, you require theMay manageWorkforce Scheduling security
role. For more information on configuring security roles, see "Creating and applying security roles" on page
178.

UsingWorkforce Scheduling in conjunction with Contact Center Management, you can
l Customize schedules
l Forecast scheduling requirements
l Match an employee’s skills to those skills required for jobs in each schedule
l View the distribution of employees across each schedule
l Print schedule reports

There are two optional applications that work in conjunction withWorkforce Scheduling: Schedule Adherence
and Employee Portal. For more information on these applications, see "Schedule Adherence" on page 693 and
"Employee Portal" on page 699.

Before installing Workforce Scheduling
Before you install and runWorkforce Scheduling or view Schedule Adherencemonitors in Contact Center
Client, youmust enable remote SQL Server connections and grant SQL Server permissions toWorkforce
Scheduling users.

Enabling remote SQL Server connections
To enable remote SQL Server 2005 connections
 1. On the Enterprise Server, in theMicrosoft SQL Server 2005 program folder, navigate to theSQL

Surface Area Configuration tool.
 2. UnderConfigure Surface Area for localhost, click Surface Area Configuration for Services and

Connections.
 3. Expand the <SQL Server name> tree to Database Engine and select Remote Connections.
 4. Select Local and remote connections.
 5. Select Using both TCP/IP and named pipes.
 6. Expand theSQL Server Browser tree and select Service.
 7. AfterStartup type, select Automatic.
 8. Click Apply.
 9. Click Start.
 10. Click OK.
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To enable remote SQL Server 2008 or remote SQL Server 2012 connections
 1. On the Enterprise Server, in theMicrosoft SQL Server 2008 or theMicrosoft SQL Server 2012

program folder, navigate to theSQL Server Configuration Manager.
 2. Under SQL Server ConfigurationManager (Local), expand SQL Server Network Configuration and click

Protocols for <SQL Server instance name>.
 3. In the right pane, right-click Named Pipes and click Enable.
 4. In the right pane, right-click TCP/IP and click Enable.
 5. UnderSQL Server Configuration Manager (Local), click SQL Server Services.
 6. In the right pane, right-click SQL Server (<SQL Server instance name>) and click Restart.
 7. In the right pane, right-click SQL Server Browser and click Properties.
 8. Click theService tab and afterStart Mode, select Automatic.
 9. Click Apply.
 10. Click OK.
 11. In the right pane, right-click SQL Server Browser and click Start.

Granting SQL Server permissions
NOTE:

l If your enterprise uses remote SQL and SQL Authentication, you can skip this step, because the
required credentials are provided during the configuration of Contact Center Management

l If you do not currently have a copy of Microsoft SQL Server Management Studio installed, you can
download a free copy from http://www.microsoft.com/downloads/details.aspx?FamilyId=C243A5AE-
4BD1-4E3D-94B8-5A0F62BF7796&displaylang=en

To grant SQL Server 2005 permissions
 1. InWindows, open theMicrosoft SQL Server 2005 program folder and go toSQL Server Management

Studio.
 2. Connect to the desired SQL Server.
 3. In the left pane, expand theSecurity tree and select Logins.
 4. If the desired user is not listed, right-click Logins and select New Login.
 5. After Login name, type the name of the new user.

Optionally, click Search to search for the user name.
 6. If you have users configured in groups on your domain, you can optionally add the group to add all users

at once.
If you want to grant SQL Server permissions to a domain group, youmust click Search, click Object
Types, and select the Groups check box.

 7. Click User Mapping.
 8. UnderUsers Mapped to this login, select CCMData.
 9. Click OK.
 10. UnderDatabase role membership for: CCMData, select db_owner.
 11. Click OK.
 12. Repeat steps 5-11 for all Workforce Scheduling users.

To grant SQL Server 2008 or SQL Server 2012 permissions
 1. InWindows, open theMicrosoft SQL Server 2008 or theMicrosoft SQL Server 2012 program folder

and go toSQL Server Management Studio.
 2. Connect to the desired SQL Server.
 3. In the left pane, expand theSecurity tree and select Logins.
 4. If the desired user is not listed, right-click Logins and select New Login.
 5. After Login name, type the name of the new user.

Optionally, click Search to search for the user name.
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 6. If you have users configured in groups on your domain, you can optionally add the group to add all users
at once.
If you want to grant SQL Server permissions to a domain group, youmust click Search, click Object
Types, and select the Groups check box.

 7. Click User Mapping.
 8. UnderUsers Mapped to this login, select CCMData.
 9. Click OK.
 10. UnderDatabase role membership for: CCMData, select db_owner.
 11. Click OK.
 12. Repeat steps 5-11 for all Workforce Scheduling users.

Upgrading from Contact Center Scheduling to Workforce
Scheduling
NOTE:

l Before you upgrade toWorkforce Scheduling Version 6.0.2 from Contact Center Scheduling Version
5.3 or earlier, we recommend you backup your configuration data and store it on a shared storage drive
or CD-ROM/DVD-ROM.

l After upgrading from Contact Center Scheduling toWorkforce Scheduling, youmay need to delete
extra holidays that are added to the database during the upgrade. For example, if you previously had
three holidays configured in Contact Center Scheduling for Canada Day (July 1 2007, 2008, and 2009),
you would have four holidays configured after the upgrade (the three previously configured holidays plus
the default holiday configured inWorkforce Scheduling).

If you were previously using Contact Center Scheduling Version 5.3 or earlier, when you upgrade to
Workforce Scheduling Version 6.0.2, your schedule configuration data and scheduled shifts previously
created in Contact Center Scheduling are automatically re-created inWorkforce Scheduling.

Installing Workforce Scheduling
NOTE:Workforce Scheduling can only be installed on client computers that are part of the sameWindows
domain as the SQL Server.

To useWorkforce Scheduling, youmust first install Contact Center Management Version 6.0.2. Workforce
Scheduling is installed during the installation of Contact Center Management Version 6.0.2. To install
Workforce Scheduling on a client computer, youmust install Client Component Pack. You then install
Workforce Scheduling and can then begin configuring scheduling options.

To install Workforce Scheduling
 1. In Contact Center Management, click Help=>Software downloads/Installations.
 2. To install Client Component Pack, click Client Component Pack.
 3. Follow the steps in the wizard to install Client Component Pack.
 4. On a client computer, open theClient Role Selector.
 5. Using aSupervisor orPower User role, installWorkforce Scheduling.
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Using Workforce Scheduling
Before you start usingWorkforce Scheduling read the following sections on how to

l View theWorkforce Scheduling user interface
l Understand forecasting concepts
l Understand theWorkforce Scheduling process

Viewing the Workforce Scheduling user interface
Figure 19 - 1 displays scheduling information, such as the employees who are scheduled, employee shift start
and end times, the time interval shift totals, and the shift details for each employee.

NOTE: The Scheduling and Forecasting buttons in the Tools>Administration window are used to toggle
between these two views.

TheWorkforce Scheduling user interface is comprised of the following panes:
l People pane
l Time bar pane
l Totals pane
l Schedule details pane
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Figure 19 - 1 Scheduler window

People pane
The people pane is located in the upper-left portion of the scheduler window. The people pane lists the
employees included in the schedules you are viewing. (See Figure 19 - 2.)

Figure 19 - 2 People pane

Time bar pane
The time bar pane is located in the upper-right portion of the scheduler window. The time bar pane displays a
time bar for each scheduled employee. Time bars display the shifts, breaks, jobs, time off, and unavailable
periods for employees listed in the people pane. You can view the time bar pane in the following time intervals:
6 hours, 12 hours, 1 day, 2 days, 1 week, 2 weeks, and 1month. (See Figure 19 - 3.)
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You can view previous or upcoming dates using the horizontal scroll bar under the time bar pane. If you reach
the end of themonth and want to view dates for the next month, you can click the arrow on the scroll bar to
load the schedule for the next month (as indicated by the red square in the following image).

Figure 19 - 3 Time bar pane

Totals pane
The totals pane appears when you select event totals to view. The totals pane is located in the center of the
scheduler window. Each value represents the total number of employees scheduled for an event. (See Figure
19 - 4.)

Figure 19 - 4 Totals pane

You can view the following event totals:

Forecasted
The Forecasted total displays after you apply a forecast to the schedule. This total represents the forecasted
number of employees required to handle contact requests andmeet the Service Level objectives you specify.
You can optionally adjust the Forecasted total in the totals pane. See "Modifying forecast totals in the event
totals pane" on page 688.

Scheduled
TheScheduled total represents the number of employees scheduled for the time you are viewing.
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On break
TheOn break total represents the number of employees scheduled for a break at a specific time.

On ACD Job
TheOnACD Job total represents the number of employees scheduled to perform ACD work.

On Non-ACD Job
TheOnNon-ACD Job total represents the number of employees scheduled to perform non-ACD work.

At work
TheAt work total represents the number of employees scheduled to handle contact requests.

Over/Under
TheOver/Under total represents the difference between the number of employees at work compared to the
number of employees forecasted. A value of 4means 4 additional employees are working compared to the
forecasted requirement. A value of (4) means 4 fewer employees are working compared to the forecasted
requirement. When you book annual leave for employees, you can preview the result on shift coverage by
using the over / under function, before updating changes.

Overtime
TheOvertime total represents the number of employees scheduled to perform overtime work.

Schedule details pane
The schedule details pane is located at the bottom of the scheduler window. It displays details on scheduled
employees. You canmodify the start and end times of scheduled events in the schedule details pane. For
example, you can adjust the length of a scheduled break. See "Modifying event times and notes in the
schedule details pane" on page 688. (See Figure 19 - 5.)

Figure 19 - 5 Schedule details pane

You can sort the information in the schedule details pane by organizing the headings. The schedule details
column headings are as follows:

l Employee name—the employee to which the specified time event is scheduled
l Schedule—the schedule to which the specified time event is scheduled
l Event type—the events to which the specified time event is scheduled
l Start date—the start date of each scheduled event. You canmodify this parameter in the schedule

details pane. Changes are immediately reflected in the time bar pane
l Start time—the start time of each scheduled event. You canmodify this parameter in the schedule

details pane. Changes are immediately reflected in the time bar pane
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l End time—the end time of each scheduled event. You canmodify this parameter in the schedule
details pane. Changes are immediately reflected in the time bar pane

l Paid hours—the total number of paid hours for the scheduled shift
l Budget—the total cost of the scheduled shift
l Notes—the notes on scheduled events you enter in this field

Understanding forecasting concepts
Workforce Scheduling assists you in scheduling employees for work and holiday periods. It offers an
integrated forecasting component that uses historical data to partially automate the scheduling process.
Scheduling is not entirely automated. Youmay have tomodify employee schedules and enter shift and
employee variables manually after creating a schedule based on forecasted data.

You schedule employees so the number of incoming calls at any given time typically exceeds the number of
employees currently available. This ensures callers experience a slight delay before employees answer their
calls. The expected number of incoming calls forecasted for the time of day and day of the week influence
scheduling decisions when trying to find the right balance between call volume and available staff.

For detailed information on forecasting variables and how to improve forecasting accuracy, see "Step #3
Forecast the Call Load" on page 23.

For detailed information on Service Level variables and how to calculate the Service Level Percent, see
"Understanding the Service Level" on page 17.

Understanding the Workforce Scheduling process
The flowchart in Figure 19 - 6 provides an overview of how to schedule employees withWorkforce
Scheduling, such as adding employees to a schedule, configuring schedule parameters, and building a
schedule.

You configure employees, agent IDs, agent groups, queues, queue groups, overtime types, time off types,
holidays, and skills in YourSite Explorer. After you configure these devices, youmust decide if you will use
forecasted data to build your schedules. When you build a schedule inWorkforce Scheduling using forecasted
data, we recommend you associate the schedule with the queue group you will use to perform the forecast.
Youmust ensure that the employees you want to schedule are associated with the queue group you associate
to the schedule. In Contact Center Management, youmust associate the agent IDs with agent groups,
associate the agent groups to queues, and associate the queues to the queue group associated with the
schedule. This is recommended so employees in the schedule align with forecasted data. You can optionally
associate a schedule to a queue group with different employees, which can be useful for scheduling a new
group of employees based on the forecasted data of other employees.

As soon as you start Workforce Scheduling, you can begin creating your schedules. After you log in, you are
asked to create or select a schedule. You create a schedule by assigning it a name. If you are using a forecast
to build the schedule, you associate the schedule with a queue group.

After you create the schedule, you configure schedule parameters, such as shifts, breaks, jobs, and
scheduling preferences/options for each employee.



Contact Center Solutions User Guide

- 663 -

You can automate the schedule building process with the Schedule Builder tool. It helps you quickly build a
schedule, with or without a forecast. If you build schedules using forecasted data, we recommend you use
Schedule Builder. Alternately, you can build a schedulemanually. This involves inserting or removing events
(shifts, breaks, jobs, time off, unavailable periods) andmaking events recur. You canmanually build a
schedule based on forecast totals in the Totals pane. After you build a schedule using Schedule Builder, you
may need tomake a few adjustments.
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Figure 19 - 6 Scheduling with Workforce Scheduling

Workforce Scheduling and your contact center
UsingWorkforce Scheduling, you can schedule your employees to best suit your contact center needs. You
can

l Customize schedules for your contact center groups
l Forecast scheduling requirements
l Match employee skills to the skills required for each schedule
l View the distribution of employees across schedules
l Print schedule reports
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For information on scheduling considerations, and how to calculate the Shrinkage Factor and optimize
scheduling, see "Step #5 Schedule agents" on page 28.

UsingWorkforce Scheduling, you can create schedules for your contact center using a variety of options.
Depending on your contact center, some options may bemore suitable than others. To help your company
useWorkforce Schedulingmost effectively, we have created configuration scenarios that describe how to
implement Workforce Scheduling, based on the type of scheduling used in your contact center.

EachWorkforce Scheduling configuration scenario provides a description of the schedulingmethod and an
example of contact centers that typically use that method. Each scenario also provides some tips on how to
configureWorkforce Scheduling for each style of scheduling. The scenarios include the following scheduling
configurations:

l Assigned shift
l Availability
l Rotational
l Forecast

Assigned shift-based scheduling configuration scenario
The assigned shift schedulingmethod uses fixed shifts staffed by employees who are permanently assigned
to specific shifts. Contact centers that use assigned shift scheduling have consistent call volumes.
Employees are primarily full-time staff and are guaranteed a specific number of hours of employment per
week. Typically, you plan a schedule three to six months in advance with assigned shift scheduling.

Contact centers ideal for assigned shift scheduling
Assigned shift scheduling is best suited to contact centers that have a steady and predictable call volume,
such as a contact center that runs a conventional “nine to five” operation. Examples of contact centers that
use assigned shift scheduling include banks and government offices.

To configureWorkforce Scheduling for an assigned shift scheduling environment
l Create fixed shifts
l Use shift names that describe a shift's purpose, such as "9 to 5 shift" or "1st shift"
l Usemass recurrence to repeat scheduled events for multiple weeks
l Configure employee hours using shift assignment by day of week

Availability-based scheduling configuration scenario
The availability schedulingmethod uses fixed shifts, but unlike assigned shift scheduling, the employees that
work a given shift are not permanently attached to that shift. Contact centers that use availability scheduling
fill shifts using a pool of employees.

A contact center supervisor sets staff availability based on day of week and time of day. When staffing a shift,
the supervisor can assign any employee who is listed as available for that date and time to the shift. Typically,
you plan a schedule two to four weeks in advance when you use availability scheduling.

Contact centers ideal for availability scheduling
Availability scheduling is best suited to contact centers driven by shifts, such as hotels or companies that
focus on catalog sales. These contact centers have a specific number of shifts that can be filled by any
qualified employees who are available. This type of schedule is frequently used with contact centers that
operate 24/7.
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To configureWorkforce Scheduling for an availability scheduling environment
l Primarily use fixed shifts, but do not assign employees to specific shifts
l Assign employees all of the possible shifts they can work
l Set employee availability by day of week and time of day
l Use filters to assign the best employee available for a shift, based on skill set, seniority, or personal

priority number

Rotational-based scheduling configuration scenario
The rotational schedulingmethod consists of two or more unique schedules that recur at defined intervals. For
example, if a contact center rotates four schedules, the week one schedule repeats in week five, week nine,
and so on. The rotational schedulingmethod enables contact center schedules to be consistent in the long-
term, while allowing shifts to vary from week to week.

Contact centers ideal for rotational scheduling
Rotational scheduling is best suited to contact centers that require specific employees to cover unique
periods of time, such as medical clinics that are open on weekends. If each contact center employee is
required to work one weekend amonth, a rotational schedule can ensure an even distribution of weekend work
for each employee.

To configureWorkforce Scheduling for a rotational scheduling environment
l Primarily use assigned shifts with defined employees. The staff changes from one schedule rotation to

the next ensure fair coverage on nights, weekends, and holidays
l Recur the shifts multiple times based on the number of rotations
l Manually track and adjust which employees are assigned to each rotation; Workforce Scheduling does

not create a balanced schedule so you will need tomake changes if you want to ensure the schedule is
fair

l Optionally use rotational scheduling in conjunction with other schedule types. For example, create a
schedule that uses the assigned shift method to cover Monday to Friday shifts and a second schedule
that uses the rotational shift method to cover shifts such as weekends or holidays

Forecast-based scheduling configuration scenario
The forecast schedulingmethod references historical data to create schedules. Contact centers that use
forecast scheduling have call volumes that can change considerably over relatively short periods of time,
resulting in inconsistent scheduling.

Forecast scheduling provides more flexibility than other schedulingmethods since shifts are not defined. A
contact center that uses forecast scheduling does not have a fixed staff or fixed hours, as both change based
on the expected call volume. Typically, you plan a schedule one to two weeks in advance with forecast
scheduling.
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Contact centers ideal for forecast scheduling
Forecast scheduling is best suited to contact centers driven by call volume, such as companies that focus on
sales campaigns, promotions, or seasonal sales.

To configureWorkforce Scheduling for a forecast scheduling environment
l Generate historical data specific to the type of event you are scheduling (for example, to create a

schedule for a winter sales campaign, use historical data from a previous winter campaign)
l Create shifts with flexible start and end times to provide Schedule Builder with the greatest number of

options when populating the shifts with employees
l Remember that shift variables, such as start/end times and breaks, will vary for employees on a day-to-

day basis
l Due to the variety of shift start and end times, create breaks based on the Time to qualify variable
l Do not configure availability or shift assignment

Before you start scheduling
You useWorkforce Scheduling in conjunction with YourSite Explorer. Before you can schedule employees
withWorkforce Scheduling, youmust add and configure them in YourSite Explorer.

To configure employee information for scheduling
 1. Select the employee or employees you want to configure.
 2. Specify the employee role.

See "Configuring employee roles" on page 164.
 3. Specify employee work hours.

See "Configuring employee work hours" on page 164.
 4. Specify employment status.

See "Configuring employment status" on page 164.
 5. Specify employee payroll information.

See "Configuring employee payroll information" on page 164.
 6. Assign shifts to the employee.

See "Assigning shifts to employees" on page 677.
 7. Specify employee availability.

See "Configuring employee availability" on page 165.
 8. Specify time off information

See "Configuring employee time off" on page 165.
 9. Specify employee skills

See "Configuring employee skills" on page 166.

Before you canmake schedules inWorkforce Scheduling, youmust configure the following scheduling
options in YourSite Explorer
 1. Holidays

See "Configuring holidays" on page 166.
 2. Overtime types

See "Configuring overtime types" on page 167.
 3. Time off types

See "Configuring time off types" on page 167.
 4. Skills

See "Configuring skills" on page 168.
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Selecting a scheduling method
You can build schedules inWorkforce Scheduling:

l Using a forecast
l Manually

The setup you require depends on the schedulingmethod you choose. If you incorporate forecast data when
you build a schedule, youmust build the schedule using Schedule Builder.

Scheduling using forecast data
NOTE:When you use forecast data to build a schedule, you can apply historical data from any queue or
queue group to the schedule. It is not necessary to use historical data from the queue group with which the
schedule is associated. Forecast data is simply the number of required agents. It can be used in schedules
which are not associated with a queue or queue group.

Before you build a schedule using a forecast, as a best practice, we recommend you associate your schedule
with a queue group. You should also ensure that the employees to be scheduled are associated with this
queue group.

In YourSite, you
 1. Associate the agent IDs with an agent group.

See "Associating agents with agent groups (in YourSite Explorer)" on page 134.
 2. Associate the agent group with a queue.

See "Associating agent groups with queues (in YourSite Explorer)" on page 137.
 3. Associate the queue with the queue group (that you will associate with the schedule).

See "Associating queues with queue groups (in the Contact Center Management website)" on page
148.

Scheduling manually
You have themost flexibility when you build a schedulemanually. However, this can be time consuming if
youmust schedule a large number of employees or if youmust create a schedule covering a long time period
where shift assignments do not recur. You can also usemanual scheduling to tweak schedules you build with
Schedule Builder. See "Creating and adjusting schedules manually" on page 685.

Schedule setup and customization
NOTE: In order to access Workforce Scheduling, you require theMay manageWorkforce Scheduling security
role. For more information on configuring security roles, see "Creating and applying security roles" on page
178.

In order to build a schedule inWorkforce Scheduling, whether you build your schedule with forecasting or you
build it manually, youmust perform the following tasks to set up and customize your schedule:
 1. Start YourSite Explorer.
 2. Configure employees, overtime types, time off types, holidays, and skills.
 3. Start Workforce Scheduling.
 4. Configure schedule options.
 5. Configure shifts, breaks, and jobs.
 6. Assign shifts to schedules.
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 7. Assign shifts to employees.
 8. Specify scheduling preferences/options for each employee in the schedule.
 9. Specify schedule warnings.

Starting Workforce Scheduling on a client computer
To log on toWorkforce Scheduling
 1. OpenWorkforce Scheduling.

The Login window appears.
 2. Type your user name and password.
 3. Verify or type the IP address of the Enterprise Server.
 4. Optionally, select theRemember my credentials check box.
 5. Click Login.

The first time you log on, or if you have not created any schedules, the scheduler window appears. See
"Configuring schedule options" on page 669.
Otherwise, if schedules exist, the Load schedule window appears.
See "Loading schedules" on page 685.

Configuring schedule options
NOTE:

l If you associate a schedule with a queue group, only those employees included in the selected queue
group can be configured in the schedule. (Agents aremembers of agent groups, which are associated
with queues that aremembers of queue groups.)

l If you do not associate a schedule with a queue group, you can schedule any employee whose profile
enables you to schedule them inWorkforce Scheduling. See "Adding employees" on page 123.

Before you can build a schedule, either manually or using Schedule Builder, youmust create a new schedule.

On the New Schedule window, youmust:
l Name the schedule
l Associate the schedule with a queue or queue group (optional)
l Add employees to the schedule
l Configure business hours for the schedule
l Activate/Deactivate the schedule

You can create new schedules and configure all Workforce Scheduling options using the Schedule wizard.
Optionally, use the Schedule tool to add, delete, rename, and activate/deactivate schedules. Within the
Schedule configuration window, you can click Apply at any time to apply changes to the schedule without
closing the Schedule configuration window.

Configuring scheduling options using the Schedule wizard
You can create new schedules and configure all Workforce Scheduling options using the Schedule wizard.

To configure scheduling options using the Schedule wizard
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule wizard.
 3. Follow the steps in the Schedule wizard to configure schedules, business hours, employees,

fixed/variable shifts, fixed/variable breaks and jobs, and fixed/variable shift assignments.
 4. Click Finish.
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Creating schedules
To create a schedule
 1. On the Applicationmenu or ribbon, click New schedule.
 2. AfterSchedule name, type a name for the schedule.
 3. UnderEmployee association, select eitherAll employees, Employees associated with this queue

group only, orEmployees associated with this queue only.
l If you select Employees associated with this queue group, select a queue group from the list.
l If you select Employees associated with this queue, select a queue from the list.

 4. If this schedule will be an active schedule, select the This schedule is active check box. Otherwise,
select the This schedule is used for planning purposes only check box.

 5. Click OK.
 6. Select the check boxes of the employees to add to the schedule.
 7. Click OK.

Adding employees to schedules
Schedules that contain fewer than 100 employees are easiest to manage. Each employee should belong to
one active schedule only. However, if employees belong tomore than one schedule, you can still view the
shifts for which they are scheduled.

To add an employee to a schedule
 1. Click theConfiguration tab.
 2. In theSchedules group, click Select employees.
 3. AfterSchedule, select a schedule.
 4. If you want to group employees in the list by supervisor, select theGroup by supervisor check box.
 5. Select the check boxes of the employees to add to the schedule.
 6. Click OK.

Configuring business hours for schedules
You can specify different business hours for each schedule. By default, you are warned if you try to schedule
shifts outside business hours.

To configure the business hours of a schedule
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, select Schedules.
 4. UnderSchedules, select the schedule tomodify.
 5. After First day of the schedule week, specify the day that the schedule will begin.
 6. AfterAnnual calendar start date, specify the date the calendar year begins.

The information in this field is used to calculate annual minimum andmaximum hours for employees.
January 1st is the default date.

 7. Specify business hours for the schedule.
l If you want to schedule employees 24 hours a day, seven days a week, under Business hours, click

Open 24/7.
l AfterOpen, select the check boxes of the days of the week to schedule.
l After From, specify the start times for each day of the week to schedule.
l After To, specify the end times for each day of the week to schedule.

 8. Click OK.
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Renaming schedules
You can rename a schedule without losing any information associated with the schedule.

To rename a schedule
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. UnderSchedules, select the schedule to rename.
 4. Click Rename.
 5. AfterName, type a new name for the schedule.
 6. Click Rename.
 7. Click OK.

Deleting schedules
CAUTION:Deleting a schedule deletes all of the information associated with that schedule. This cannot be
undone.

To delete a schedule
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. UnderSchedules, select the schedule to delete.
 4. Click Delete.
 5. Click Yes.
 6. Click OK.

Activating / De-activating schedules
You can activate or deactivate a schedule at any time. Deactivating schedules is useful for performing “what-
if” scenarios, for seasonal schedules, and for retaining schedules to be used at a later time.

To activate or deactivate a schedule
 1. On the Applicationmenu or ribbon, click Activate / Deactivate.

The Activate / Deactivate Schedule dialog box opens.
 2. Select the schedule that you want to activate / deactivate.
 3. You can loadmultiple active schedules. However, if you load an inactive schedule, all other schedules

close.
 4. Click Activate to activate an inactive schedule or Deactivate to deactivate an active schedule.
 5. Click Close.
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Configuring shifts
A shift represents work hours on a given day for an employee. You can assign shifts to specific employees for
any day of the week. You can create several shifts for one or more schedules. There are two types of shifts:
fixed shifts and variable shifts. Fixed shifts have a fixed start time and duration. Variable shifts are based on
the following shift variables:

l Typical hours—the number of work hours for the shift
l Minimum hours—theminimum number of hours for the shift
l Maximum hours—themaximum number of hours for the shift
l Minimum start—the time of day after which the shift must start
l Maximum start—the time of day by which the shift must start
l Color—the color in which the shift appears in the time bar pane

You configure the following shift options using the Schedule tool:
l Add fixed shifts
l Add variable shifts
l Rename shifts
l Delete shifts

Adding fixed shifts
To add a fixed shift
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Shifts.
 4. In the right pane, click the Fixed Shifts tab.
 5. In the right pane, click Add.
 6. AfterName, type a name for the fixed shift.
 7. Click Create.
 8. UnderStart time, type the start time of the fixed shift.
 9. UnderDuration, type the duration of the fixed shift.
 10. UnderColor, select a color for the fixed shift.
 11. Click OK.

Adding variable shifts
To add a variable shift
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Shifts.
 4. In the right pane, click theVariable Shifts tab.
 5. In the right pane, click Add.
 6. AfterName, type a name for the variable shift.
 7. Click Create.
 8. UnderMinimum hours, type theminimum number of hours in a day you can schedule the shift.
 9. Under Typical hours, type the typical number of hours in a day you can schedule the shift.
 10. UnderMaximum hours, type themaximum number of hours in a day you can schedule the shift.
 11. UnderMinimum start, type the time of day after which the shift must start.
 12. UnderMaximum start, type the time of day by which the shift must start.
 13. UnderColor, select a color for the variable shift.
 14. Click OK.
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Renaming shifts
You can rename fixed/variable shifts without losing any information associated with the shifts.

To rename a shift
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. Click theShifts tab.
 4. If you want to rename a fixed shift, click the Fixed shifts tab. Otherwise, to rename a variable shift,

click theVariable shifts tab.
 5. UnderName, click the name of the shift to rename.
 6. Type a new name for the shift.
 7. Click OK.

Deleting shifts
CAUTION: Deleting a shift deletes all of the instances of that shift, including those inserted in schedules.

To delete a shift
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. Click theShifts tab.
 4. If you want to delete a fixed shift, click the Fixed shifts tab. Otherwise, to delete a variable shift, click

theVariable shifts tab.
 5. UnderName, select the shift to delete.
 6. Click Delete.
 7. Click Yes.

Configuring breaks
You configure the following break options using the Schedule tool:

l Add fixed breaks
l Add variable breaks
l Rename breaks
l Delete breaks

Examples of common breaks aremorning break, lunch, afternoon break, and dinner break.

Adding fixed breaks
To add a fixed break
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Breaks.
 4. In the right pane, click the Fixed Breaks tab.
 5. Click Add.
 6. AfterName, type a name for the break.
 7. Click Create.
 8. If the break is a paid break, enable the check box under Is paid.
 9. UnderStart time, type the time at which the break must start.
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 10. UnderDuration, type the amount of time allotted for the break.
 11. UnderColor, select a color for the break.
 12. Click Ok.

Adding variable breaks
To add a variable break
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Breaks.
 4. In the right pane, click theVariable Breaks tab.
 5. Click Add.
 6. AfterName, type a name for the variable break.
 7. Click Create.
 8. UnderDuration, type the amount of time allotted for the break.
 9. If the break is a paid break, select the check box underPaid.
 10. Under Time to qualify, type theminimum duration of a shift before you can schedule the break.
 11. UnderMust start time, type the amount of time from the beginning of the shift that employees must

work before they are entitled to the break.
 12. UnderMust end time, type the amount of time from the beginning of the shift by which employees must

complete the break.
 13. UnderMinimum time before end of shift, type the amount of time before the end of the shift that the

break must end.
 14. UnderColor, select a color for the shift.
 15. Click OK.

Renaming breaks
You can rename a break without losing any information associated with the break.

To rename a break
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Breaks.
 4. If you want to rename a fixed break, in the left pane, click the Fixed Breaks tab. Otherwise, to rename a

variable break, click theVariable Breaks tab.
 5. UnderName, click the name of the break to rename.
 6. Type a new name for the break.
 7. Click OK.

Deleting breaks
CAUTION: Deleting a break deletes all of the instances of the break, including those inserted in schedules.

To delete a break
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. If you want to delete a fixed break, in the left pane, click Fixed shifts. Otherwise, to delete a variable

break, click Variable shifts.
 4. Click theBreaks tab.
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 5. UnderName, select the name of the break to delete.
 6. Click Yes.
 7. Click OK.

Configuring jobs
Use jobs in a schedule to differentiate the non-ACD tasks that employees perform. You create jobs for a
specific shift. If the job requires a specific set of skills, you can associate skills to jobs. After you associate
skills to jobs, you can compare the skill (and skill level) of the employees to the skill required to perform a job.
This will ensure the employees you schedule have the appropriate skills for their assigned jobs.

You configure the following job options using the Schedule tool:
l Add fixed jobs
l Add variable jobs
l Rename jobs
l Delete jobs

Adding fixed jobs
To add a job for a fixed shift
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Jobs.
 4. In the right pane, click the Fixed Jobs tab.
 5. Click Add.
 6. AfterName, type the name of the job.
 7. Click Create.
 8. If the job involves work on ACD calls, ensure the check box under Is ACD is selected.
 9. UnderStart time, type the time at which the jobmust start.
 10. UnderDuration, type the duration of the job.
 11. UnderColor, select a color for the job.
 12. Click OK.

Adding variable jobs
To add a job for a variable shift
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Jobs.
 4. In the right pane, click theVariable Jobs tab.
 5. Click Add.
 6. AfterName, type the name of the job.
 7. Click Create.
 8. If the job involves work on ACD calls, ensure the check box under Is ACD is selected.
 9. UnderColor, select a color for the job.
 10. Click OK.
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Renaming jobs
You can rename a job without losing any information associated with the job.

To rename a job
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Jobs.
 4. If you want to rename a fixed job, click the Fixed Jobs. Otherwise, to rename a variable job, click the

Variable Jobs tab.
 5. UnderName, click the name of the job to rename.
 6. Type a new name for the job.
 7. Click OK.

Deleting jobs
CAUTION: Deleting a job deletes all of the instances of the job, including where it is inserted in schedules.

To delete a job
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Jobs.
 4. If you want to delete a fixed job, click the Fixed Jobs. Otherwise, to delete a variable job, click the

Variable Jobs tab.
 5. UnderName, select the name of the job to delete.
 6. Click Delete.
 7. Click Yes.

Adding breaks or jobs to shifts
To add a break or a job to a shift
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. Click Assignments.
 4. In the right pane, click theBreaks and Jobs tab.
 5. UnderShifts, select the shift for which you will add shifts to.
 6. UnderBreaks, select the break to add to a shift.
 7. Click > to assign the break to the shift.
 8. Under Jobs, select the job to add to a shift.
 9. Click > to assign the job to the shift.
 10. Click OK.

Removing breaks and jobs from shifts
To remove a break or a job from a shift
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. Click Assignments.
 4. In the right pane, click theBreaks and Jobs tab.
 5. UnderShifts, select the shift for which you will remove breaks/jobs from.
 6. UnderBreaks, select the break to remove from the shift.
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 7. Click < to remove the break from the shift.
 8. Under Jobs, select the job to remove from the shift.
 9. Click < to remove the job from the shift.
 10. Repeat steps 5-9 to remove additional breaks and/or jobs from shifts.
 11. Click OK.

Assigning shifts to schedules
NOTE: Schedule Builder uses the shifts you assign, combined with the employees’ availability and shift
assignment, to schedule shifts (or variations of them).

To assign shifts to schedules
 1. Click theConfiguration tab.
 2. In theSchedules group, click Schedule.
 3. In the left pane, click Assignments.
 4. In the right pane, click theShifts tab.
 5. UnderSchedules, select the schedule to which you will add shifts.
 6. Under Fixed Shifts, select the fixed shift to add to the schedule.
 7. Click > to assign the shift to the schedule.
 8. UnderVariable Shifts, select the variable shift to add to the schedule.
 9. Click > to assign the shift to the schedule.
 10. Repeat steps 6-9 for each shift you want to add to a schedule.
 11. Click OK.

Assigning shifts to employees
To assign a shift to an employee
 1. Click theConfiguration tab.
 2. In theSchedules group, click Configure employees.
 3. In the left pane, underSchedules, select the schedule containing the employee(s) to which you will

assign shifts.
 4. UnderEmployees, select the employee to which you will add shifts.
 5. UnderShift Assignment, select the check boxes of the shifts that will be available to this employee.
 6. Repeat steps 4-6 for each employee to which you will assign shifts.
 7. Click OK.

Configuring event display preferences
Tomake events easy to identify at a glance, you can specify how you want to display the scheduled events.

You can specify the following event display preferences:
l Time bar content display—provides descriptions, notes, or icons for scheduled events in the time bar

pane
l Smallest scheduling interval—the smallest increment with which you insert events into the time bar

pane
l Default shift color—the color for all of the shifts in the time bar pane. To override the default shift

color, see "Configuring shifts" on page 672
l Default break color—the color for all of the breaks in the time bar pane. To override the default break

color, see "Renaming breaks" on page 674
l Default job color—the color for all of the jobs in the time bar pane. To override the default job color,

see "Configuring jobs" on page 675
l Default time off color—the color for all of the time off types in the time bar pane. To override the

default job color, see "Configuring time off types" on page 167
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l Unavailable color—the color for unavailable periods in the time bar pane
l Tool tip display—provides event information in tool tips on the time bar pane. The tool tip appears as a

series of brackets depending on the information criteria you select
l Time display—the time format of the time bar pane. For example, 3 o’clock in the afternoon appears as

3 P.M. if you select 12 Hours, or 15 if you select 24 Hours

Configuring the time bar display
You can select from the following three time bar display options:

l Icon—refers to the icons of the scheduled shifts, time off events, and unavailable periods in the time
bar pane

l Type name—refers to the names of the scheduled jobs in the time bar pane
l Type notes—refers to the notes of the scheduled jobs in the time bar pane

To specify how events display in the time bar
 1. On the applicationmenu, click Preferences.
 2. Click theDisplay tab.
 3. Under Time bar content display, select the time bar content to display for Shifts, Jobs, Breaks, Time

off, and Unavailable periods.
 4. Click OK to save and close the Preferences window.

Configuring the smallest scheduling time interval
By default, events are snapped to the time bar grid in 30minute increments. However, you can adjust the
snap-to-grid interval to 5, 15, 30, or 60minutes. Set the smallest scheduling time interval to theminimum
number of minutes you want to insert events into a schedule. For example, if you select 15minutes as the
smallest scheduling interval, you cannot insert events for an employee in increments smaller than 15minutes.

The default scheduling interval is 15minutes, which we recommend, as changing this to a smaller interval will
increase the amount of time it takes for Schedule Builder to build schedules.

To configure the smallest scheduling time interval
 1. On the applicationmenu, click Preferences.
 2. Click theGeneral tab.
 3. UnderScheduling preferences, afterSmallest scheduling interval, select the snap-to-grid time

interval.
 4. If you want to prevent the user frommanually making any change that would trigger a warning, select the

Warnings are hard limits for the user check box.
 5. Click OK to save and close the Preferences window.

To prevent users from manually making changes that trigger warnings
You can configureWorkforce Scheduling to prevent users frommaking changes that trigger warnings.

To prevent users frommanually making changes that trigger warnings
 1. On the applicationmenu, click Preferences.
 2. Click theGeneral tab.
 3. Select theWarnings are hard limits for the user check box.
 4. Click OK to save and close the Preferences window.
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Configuring the default colors on the time bar
To configure the default colors used for events on the time bar
 1. On the applicationmenu, click Preferences.
 2. Click theDisplay tab.
 3. UnderDefault time bar colors, afterDefault shift color, select a color.
 4. Repeat step 3 forDefault break color, Default job color, Default time off color, andUnavailable

color.
 5. Click OK to save and close Preferences window.

Configuring the time format
There are two time formats you can select from: the 24 hour international format or the 12 hour format which
uses A.M. and P.M. to indicatemorning and afternoon. For example, 3 o’clock in the afternoon appears as 15
if you select the 24 hour time format or 3 P.M. if you select the 12 hour time format.

To configure the time format
 1. On the applicationmenu, click Preferences.
 2. Click theGeneral tab.
 3. AfterHour format, select either 12 hours or 24 hours.
 4. Click OK.

Configuring tool tip display
You can specify the following information in tool tips for shifts, jobs, breaks, time off events, unavailable
periods, and shadow events:

l Schedule name—provides the name of the schedule in which the event appears.
l Is recurring—displays if the event recurs.
l Type—provides the name of the event.
l Type name—states if the event is a shift, job, break, time off event, unavailable period, or shadow

event.
l Start/End Time—provides the start and end time of the event.
l Event Notes—provides any notes from the detail grid for the event.

To configure the tool tip display
 1. On the applicationmenu, click Preferences.
 2. Click theDisplay tab.
 3. Under Tool tip display, select the check boxes for the tool tips to display.
 4. Click OK.

Configuring warnings
Warnings notify you when you try to schedule events outside of your scheduling parameters.

You can set the following warnings:
l Schedule warnings
l Shift warnings
l Break warnings
l Job warnings
l Overtime warnings
l TimeOff warnings
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l Employee scheduling warnings
l Schedule Builder warnings
l Employee selection warnings

To configure warnings
 1. On the applicationmenu, click Preferences.
 2. Click theWarnings tab.
 3. Ensure the check boxes of the warnings you want to configure are selected.

See Table 19 - 1.
 4. Click OK.

Warning Description

Scheduling work on company
holidays

notifies you when events are scheduled on company holidays

Scheduling work outside business
hours

notifies you when you try to schedule events outside of your contact
center’s business hours

When scheduling outside employee's
availability

notifies you when you try to schedule employees who are not
available at the specified time

Violates length of service
qualifications

notifies you when an employee has worked fewer or moremonths
required to qualify for a specific type of time off

Exceeds accrued hours notifies you when an employee is scheduled for more time off hours
than is available to that employee at that time

Exceeds maximum scheduling limit notifies you when an employee is scheduled for more time off hours
than specified for that type of time off

Less thanminimum scheduling limit notifies you when an employee is scheduled for fewer time off hours
than specified for that type of time off

Employee does not have required
skills

notifies you when an employee does not have the required skills for
the job for which they are scheduled

Exceeds daily maximum work hours notifies you when an employee is scheduled for more hours in a day
than defined by the parameter for that shift

Below daily minimum work hours notifies you when an employee is scheduled for fewer hours in a day
than defined by the parameter for that shift

Exceeds weekly maximum work
hours

notifies you when an employee is scheduled for more hours in a
week than defined by the parameter for that shift

Below weekly minimum work hours notifies you when an employee is scheduled for fewer hours in a
week than defined by the parameter for that shift

Exceeds yearly maximum work hours notifies when an employee is scheduled for more than the annual

Table 19 - 1 Warnings
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Warning Description

maximum hours required

Below yearly minimum work hours notifies you when an employee is scheduled for less than the annual
minimum hours required

Start time outside of specified range notifies you when an employee’s shift is scheduled to start before
(minimum) or after (maximum) the parameters defined for that shift

Within minimum time between shifts notifies you when an employee is scheduled to start another shift too
soon following the one previously completed

Below hours worked to qualify notifies you when an employee is scheduled for a break before
working enough hours after the last break in that shift to qualify for
another break

Starting before earliest start time notifies you when an employee is scheduled for the first break in a
shift before a break can be taken

End after latest end time notifies you when an employee is scheduled for the last break in a
shift after a break can be taken

Removing an employee from a
schedule

notifies you when you attempt to delete an employee from the
schedule

Accepting a generated schedule notifies you when you attempt to save a schedule you have built

Scheduled shift will cause overtime notifies you when a shift qualifies an employee for overtime

Schedule creation
You can create and customize schedules inWorkforce Scheduling using specific parameters that suit the
needs of your contact center. You can build schedules manually or with the Schedule Builder tool. Schedule
Builder automates the schedule building process. It uses pre-defined employee and schedule options to
create schedules. See "Schedule setup and customization" on page 668.

Schedule Builder helps you build a schedule with or without forecast data. However, youmust use the
Schedule Builder if you want to build a schedule with forecast data. See "Forecasting tool" on page 293.

You can also usemanual scheduling tomodify schedules you build with Schedule Builder. See "Creating and
adjusting schedules manually" on page 685.

NOTE:After you generate a schedule with Schedule Builder, youmust accept or reject schedule changes
before you can generate another schedule.

Schedule Builder uses the following parameters to create a schedule automatically:
l Date/time range
l Shifts
l Breaks
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l Forecast data
l Business hours
l Employees
l Employee scheduling preferences
l Scheduling options
l Shift options
l Schedule algorithm options

Building schedules with Schedule Builder
NOTE:After you generate a schedule with Schedule Builder, youmust accept or reject schedule changes
before you can generate another schedule.

To build a schedule with Schedule Builder
 1. Click the Tools tab
 2. In the Schedule Builder group, click Manual.
 3. UnderSchedule name, select a schedule.
 4. Specify the scheduling parameters on each tab of the Schedule Builder tool.
 5. Click Build.

A dialog box appears reminding you that changes to the schedule will not be committed to the database
until you click Accept Schedule.

 6. Click OK.
The Accept Schedule and Reject Schedule buttons appear in the toolbar.

 7. Verify the schedule.
 8. Make any requiredmodifications manually.
 9. Click Accept schedule to save the new schedule.

NOTE:
l After you click Accept Schedule, the schedule is live in the database and the Accept Schedule

button disappears. If you click Reject Schedule, the automatically generated schedule and any
manual modifications are deleted from the schedule. See "Creating and adjusting schedules
manually" on page 685.

l If there are any conflicts, a dialog box appears stating the number of conflicts. You cannot save a
schedule with conflicts. Click Yes to delete the conflicts and accept the schedule, or click No to
adjust the schedule. When you have resolved the conflicts, click Accept Schedule again to save
the schedule.

Configuring the date and time range
To configure the date and time range for a schedule using Schedule Builder
 1. InSchedule Builder, click theGeneral tab.
 2. UnderDates and times, on theDate / Time tab, select the date range of the schedule.
 3. Under Time, select eitherUse business hours, 24/7, orCustom.
 4. If you selectedCustom in the previous step, select the time the schedule starts and ends each day.
 5. If you want to exclude dates from the schedule, click theExclusion tab.
 6. Hold downCTRL and then click the dates to exclude.
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Scheduling shifts
To schedule shifts using Schedule Builder
 1. InSchedule Builder, click theGeneral tab.
 2. UnderSchedule/Optimize, select theShifts check box.
 3. UnderEvent selection, on theShift selection tab, select the check boxes of the shifts to add to the

schedule.
 4. Click theShift, Break, & Job options tab.
 5. UnderShift options, specify how shifts will be distributed.

l If you want to count existing shifts when determining the number of employees to be scheduled,
select the The Schedule Builder counts existing shifts when determining the number of
employees which must be scheduled check box.

l If you want to optimize existing unlocked shifts, select theAllow Schedule Builder to optimize
existing unlocked shifts check box.

l If you want to optimize existing locked shifts, select theAllow Schedule Builder to optimize
existing locked shifts check box.

l If you want to schedule unassigned shifts for times when there are not enough employees available
to satisfy the scheduling requirements, select theGenerate unassigned shifts when not enough
employees are available to satisfy the schedule requirements check box.

l If you want to ignore employee shifts assignments when building the schedule, select the Ignore
employee shift assignments check box.

Scheduling breaks
To schedule breaks using Schedule Builder
 1. InSchedule Builder, click theGeneral tab.
 2. UnderSchedule/Optimize, select theBreaks check box.
 3. UnderEvent selection, on theBreak selection tab, select the check boxes of the break types to add to

the schedule.
 4. Click theShift, Break, & Job options tab.
 5. UnderSchedule/Optimize breaks, select the check boxes of the shift types to apply breaks.
 6. If you want to schedule employees to cover for breaks, select theCover for breaks check box.
 7. UnderDistribution, specify how breaks will be distributed.

l If you want to reduce the number of concurrent breaks, select Reduce the number of concurrent
breaks.

l If you want to distribute breaks using a fixed offset, select Schedule breaks and specify the
number of minutes apart.

Scheduling jobs

To schedule jobs using Schedule Builder
 1. InSchedule Builder, click theGeneral tab.
 2. UnderSchedule/Optimize, select the Fixed Jobs check box.
 3. UnderEvent selection, on the Fixed Job selection tab, select the check boxes of the job types to add

to the schedule.
 4. Click theShift, Break, & Job options tab.
 5. UnderSchedule fixed jobs on, select the check boxes of the job types to apply shifts.
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Generating schedules with forecast data
To build a schedule with forecast data using Schedule Builder
 1. InSchedule Builder, click theGeneral tab.
 2. UnderSchedule Builder method, afterMethod, select Forecasted data.
 3. If you want fewer employees scheduled than are forecasted, move the slider towards Under schedule.
 4. If you want more employees scheduled than are forecasted, move the slider towards Over schedule.
 5. If you want to adjust the number of forecasted employees, next to Increase/decrease the number of

forecasted employees by, enter a number.

Generating schedules without forecast data
To build a schedule without forecast data using Schedule Builder
 1. InSchedule Builder, click theGeneral tab.
 2. UnderSchedule Builder method, afterMethod, select Explicit.
 3. AfterNumber of employees to schedule, enter a number.
 4. If you want fewer employees scheduled than are forecasted, move the slider towards Under schedule.
 5. If you want more employees scheduled than are forecasted, move the slider towards Over schedule.

Generating schedules for your entire workforce
To build a schedule for your entire workforce using Schedule Builder, regardless of employee availability
 1. InSchedule Builder, click theGeneral tab.
 2. UnderSchedule Builder method, afterMethod, select Entire workforce.
 3. If you want to enable employee filtering, select theEnable employee filtering check box.

Selecting employees
To select the employees you want to schedule using Schedule Builder
 1. InSchedule Builder, click theEmployee filtering tab.
 2. If you want to filter employees by agent group, underAgent group, select the check boxes of the agent

groups to schedule.
 3. If you want to filter employees by their skills, underSkill, select the check boxes of the required skills.

Otherwise, skip to step 6.
 4. Under the list of available skills, select an operand.

l If the employees must have a skill level greater or equal to the skill level required, select >=.
l If the employees must have a skill level lower or equal to the skill level required, select <=.
l If the employees must have a skill level exactly equal to the skill level required, select =.

 5. If you want to filter employees by name, underSelect employees with this name, type an employee’s
name.

 6. If you want to select specific employees, underSelected employees, select the check boxes of the
employees to schedule.

 7. Click theEmployee sorting tab.
NOTE:Youmust configure the employee payroll information in order to select the seniority and pay rate
parameters.

 8. If you want to prioritize how shifts are distributed to employees, select theUse employee sorting
check box, and select the criteria with which to sort employees.

 9. If you want to assign or edit employee priority numbers, underEmployee priority, select an employee.
 10. UnderPriority, type a personal priority number.
 11. Click theOverrides tab.
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 12. If you want to override employee work hour preferences, underWork hours, select the check boxes to
override daily work hours, weekly work hours, and theminimum time between shifts.

 13. If you want to override employee availability, underAvailability, select the check boxes to override
employee availability and unavailable events currently applied to the schedule.

 14. If you want to override scheduled time off, under Time off, select theOverride time off events
currently applied to the schedule check box.

Configuring scheduling options
To configure schedule options Schedule Builder uses to create a schedule
 1. InSchedule Builder, click theAdvanced options tab.
 2. UnderSchedule algorithm performance, specify the settings Schedule Builder will use to build the

schedule.
 3. If you want to optimize break distribution, underOptimization types, select theOptimize break

distribution check box.
 4. If you want to optimize shift placement, select theOptimize shift placement check box.
 5. If you want to optimize shift size, select theOptimize shift size check box.
 6. If you want to balance the distribution of employee shifts over the week, select theBalance over the

week check box.
Selecting this option ensures that Schedule Builder does not completely fill the requirements of the first
few days of the schedule and understaff employee requirements by the end of the week.

Creating and adjusting schedules manually
You can create entire schedules manually. However, if youmust schedule a large number of employees it can
be quite complicated and time consuming. Schedule Builder automates the process and builds schedules for
you. You canmanually adjust schedules created with Schedule Builder. You can create and adjust schedules
manually in the following ways:

l Load a schedule
l Populate a schedule with events
l Drop insert an event
l Drag insert an event
l Recur an event
l Mass recur an event
l Mass delete an event
l Mass apply time off
l Modify a forecast total
l Modify event times or notes

Loading schedules
NOTE: Your access rights determine which schedules you can view, modify, or manage.

To load a schedule
 1. On the Applicationmenu or ribbon, click Load schedules.
 2. UnderPlease select the schedule(s) you want to download, select the schedule(s) to load.
 3. If you want to load all schedules, select theSelect all check box.
 4. Click Load.
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Populating schedules with events
NOTE:

l Your access rights determine which schedules you can view, modify, or manage.
l For ease of use and accuracy when inserting events, select a schedule view of less than 1 week

(View=>Schedule View) prior to insertion.

You canmanually insert the following events into a schedule:
l Shifts
l Breaks
l Jobs
l Time off
l Unavailable periods

You can insert events in a schedule by either dropping or dragging them on an employee’s time line on the time
bar pane. You can optionally drop insert breaks or jobs into already existing fixed shifts. Drop inserting events
is most useful for fixed events, as the duration of the shift is predefined. Drag inserting events is most useful
for variable shifts, as the duration can vary depending on the defined parameters for a specific event.

NOTE: To accommodate for last minute scheduling changes, you can optionally schedule time off and
unavailable events in themiddle of scheduled shifts or schedule a shift in themiddle of time off and
unavailable events.

Drop inserting events
To drop insert an event
 1. Click the Insert tab.
 2. Click Drop.
 3. UnderEvent, select the event to add to the schedule.
 4. UnderSchedule, select the schedule to add events to.
 5. UnderEvent name, select the name of the event to add to the schedule.
 6. On the time bar pane, click the employee’s time line to insert the event .

The event is added to the schedule.
 7. Repeat steps 3-6 for every event to add to the schedule.

Drag inserting events
NOTE: Drag insert is not available in the 1month schedule view.

To drag insert an event
 1. Click the Insert tab.
 2. Click Drag.
 3. UnderEvent, select the event to add to the schedule.
 4. UnderSchedule, select the schedule to add events to.
 5. UnderEvent name, select the name of the event to add to the schedule.
 6. On the time bar pane, click the employee’s time line and drag the cursor from the start time to the end of

the event.
 7. Repeat steps 3-6 for every event to add to the schedule.
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Recurring events
You can recur shifts, time off, and unavailable events.

Tomake an event recur
 1. On the time bar pane, on the employee’s time line, right-click the event to recur.
 2. Click Recurring.
 3. Click Daily,Weekly,Monthly, orYearly recurring.
 4. Specify the pattern and range of the recurrence.
 5. Click OK.

Mass recurring events
You can use theMass recurrence wizard to createmultiple recurrences for several events automatically. The
wizard allows you tomass recur shifts, time off, and unavailable periods based on either a daily or weekly
template.

NOTE:Manual or mass deletion is required to remove the generated events.

Tomass recur events
 1. Click the Tools tab.
 2. In theBulk operations group, click Recurrence.

TheMass Recurrence wizard opens.
 3. Click Next.
 4. Follow the steps in the wizard to specify the parameters of the events to mass recur.
 5. Click Finish.
 6. Click Yes.

Mass deleting events
You can delete one or more scheduled events (shifts, time off periods, unavailable periods, breaks, and jobs)
at a time with theMass delete option. Only the selected events are deleted from the schedules.

Tomass delete scheduled events
 1. Click the Tools tab.
 2. In theBulk operations group, click Delete.
 3. Specify the date range affected, event types to delete, and the schedules to delete events from.
 4. Click OK.

Mass applying time off
You can apply time off to any or all agents in a schedule simultaneously.

Tomass apply time off
 1. Click the Tools tab.
 2. In theBulk Operations group, click Time Off.

The Timeoff Mass Insert dialog box opens.
 3. Select a schedule from theSchedules drop-down list.
 4. Hold downCTRL and then click the agents to which you want to apply the time off type. If you want to

select all agents, click Select All.
 5. Under Time off, select the time off type from the list.
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 6. Select the start and end dates, days of the week, and start and end times for the time off type.
 7. After selecting the time off time, selectMark remaining periods of the day as unavailable if you

want the hours outside of the start and end times to be unavailable for scheduling.
 8. Click OK.

Modifying forecast totals in the event totals pane
If you build schedules with forecast data, you can adjust the forecast totals on the event totals pane. On the
events totals pane, you can change forecast totals in time intervals as small as 15minutes. The schedule
view you select determines the time interval of the forecast totals. See "Changing the time interval of the time
bar pane" on page 690.

For example, if you select the 8 hour schedule view, you can change the forecast data in 15minute intervals.
However, if you select the 1 day schedule view, you can change the forecast data in 1 hour time intervals.
When you change the forecast data in an interval larger than 15minutes and then change the view to smaller
intervals, you will notice that the change applies to each of the smaller intervals.

NOTE: Schedule Builder uses the latest forecast data to calculate the number of employees required.

To change the forecast totals in the events totals pane
 1. After Totals, click +.
 2. Select the Forecast check box and the check boxes of any other event totals to view.
 3. Click -.
 4. Click theView tab.
 5. UnderSchedule view, select a time interval.

See Table 19 - 2.
 6. Click the + before Forecasted to expand the forecast tree.

The event totals for the loaded schedules appear.
NOTE:You can use the Tab key to select cells to the right, and the Shift+Tab keys to select cells to the
left.

 7. Click a cell in the forecast event total grid and type the new forecast total for this time interval.

Modifying event times and notes in the schedule details pane
The changes youmake to event start times and end times in the schedule details pane are immediately
reflected in the time bar pane.

Tomodify the start and end times of events in the schedule details pane
 1. On the schedule details pane, click the start or end time of an event.
 2. Type the new time.

The new time is immediately reflected in the time bar pane.
 3. Repeat for any other event times tomodify.

Tomodify the start and end times of events in the time bar pane
 1. Click the Insert tab.
 2. Click Select.
 3. On the time bar pane, select the event to modify.
 4. Drag and drop the event to adjust its start and end times.

The new time is immediately reflected in the time bar pane.
 5. Repeat for any other event times tomodify.
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To add/edit a note for a scheduled employee
 1. On the schedule details pane, click the note field for an employee.
 2. Click the ... button.

The Notes editor appears.
 3. Type/edit a note.
 4. Click OK.

Schedule distribution
You can specify viewing preferences, specify access rights to schedules, and run and print reports.

Viewing schedules
You can specify how you view the time bar pane. Use the scroll bar to view other days and times in the
schedule. If you reach the end of themonth and want to view dates for the next month, you can click the arrow
on the scroll bar to load the schedule for the next month. By default, events you insert into a schedule are
snapped to the grid in 30minute increments.

To view a specific date
 1. From any tab inWorkforce Scheduling, click Select date.
 2. Click the date to view.

The time bar will display the date you selected to view.

Viewing scheduled events
NOTE: If employees belong tomore than one schedule and you are viewing only one of the schedules to
which the employees belong, any events scheduled in the other schedule will appear as a shadow event (grey
bar) in the time bar view.

You select how event time bars appear inConfiguration=>Preferences. You can isolate shifts, time off, and
unavailability to view them separately in the time bar pane. Youmust view breaks and jobs with shifts. You
cannot isolate breaks and jobs in the time bar pane. See "Configuring event display preferences" on page 677.

To view shifts
l On theView tab, in theShow/Hide group, select theShift check box.

To view jobs
l On theView tab, in theShow/Hide group, select the Job check box.

To view breaks
l On theView tab, in theShow/Hide group, select theBreak check box.

To view time off
l On theView tab, in theShow/Hide group, select the Time off check box.

To view unavailable periods
l On theView tab, in theShow/Hide group, select theUnavailable check box.

To view shadow events
l On theView tab, in theShow/Hide group, select theShadow check box.
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Changing the time interval of the time bar pane
You can view schedules in the time bar pane over 8 hour, 12 hour, 1 day, 2 day, 1 week, 2 week, or 1month
time intervals. The default view is the 12 hour view.

To change the time interval in the time bar pane to one week
 1. Click theView tab.
 2. In theView options group, underSchedule view, select the interval to view.
 3. Optionally, underGroup view, select Supervisor to group employees in the time bar pane by schedule.

Viewing event totals
Event totals represent the total number of employees for an event. You can view event totals in 15minute, 30
minute, 1 hour, 4 hour, or 1 day time intervals. Table 19 - 2 displays the event total time intervals that
correspond to the schedule views.

Schedule view Event totals time interval

8 hour 15minute

12 hour 30minute

1 day 1 hour

2 day 4 hour

1 week 1 day

2 week 1 day

1month 1 day

Table 19 - 2 Schedule views and corresponding event
total time intervals

You can select from the following event totals:

Forecast—appears only after you have applied a forecast to a schedule. This total represents the number of
employees required tomeet your specified Service Level objectives.

Scheduled—represents the number of employees scheduled at that time

Over/Under—represents the excess (over) or inadequate (under) number of employees scheduled when
compared to the number of employees forecasted.

On Break—represents the number of employees scheduled for a break at a certain time

ACD Jobs—represents the number of employees scheduled to perform ACD jobs

Non-ACD Jobs—represents the number of employees scheduled to perform non-ACD jobs
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At work—represents the number of employees scheduled to handle contact requests

Overtime—represents the number of employees scheduled for overtime

To view event totals
 1. In the Totals pane, click +.
 2. Select the check boxes of the event totals to view.
 3. Click -.

The totals pane appears with the event totals you selected.

Viewing schedule details
To group information in the schedule details pane

l On the schedule details pane, drag and drop the column header to organize to theDrag a column
header here to group by that column area on the window.

To sort information in the schedule details pane alphabetically
l On the schedule details pane, click the header of the column to sort alphabetically.

To filter information in the schedule details pane
 1. On the schedule details pane, click the arrow on a column header.
 2. Select the filter criteria.

Synchronizing views
You can synchronize the people pane, time bar pane, and totals pane with the order of the information in the
schedule details pane. Once you have organized the details of your schedules (sorting, filtering, and grouping)
in the schedule details pane, synchronize views to reflect the order you have selected. For information on how
to sort, filter, or group schedule details, see "Viewing schedule details" on page 691.

To synchronize views
 1. Click theView tab.
 2. Select theSynchronize time bar view with details view check box.
 3. Optionally, select theVertical scrolling check box.

Running schedule reports
TheWorkforce Scheduling reports are produced inMicrosoft Excel format. Youmust run and print the
followingWorkforce Scheduling reports from Contact Center Management. See theContact Center Solutions
Enterprise Edition Reports Guide for more information.

You can produce on-demand reports and scheduled reports for the following reports:
l Detailed Schedule by Employee with Totals
l Schedule by Employee by TimeOff by Day of Week
l Employee Configuration
l Summary Schedule by Employee
l Totals Pane
l Work Hours Summary Schedule by Employee
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Running on-demand reports
To run an on-demand report
 1. In Contact Center Management, click Reporter=>Workforce Scheduling=>Schedules.
 2. UnderReport type, select a report.
 3. AfterDevice type, select one of the following:

l Employee— only the employees selected will appear in the report
l Supervisor— only the employees associated with the selected supervisor will appear in the

report
l Employee group— only the employees who aremembers of the selected employee group will

appear in the report
l Schedule— only the employees associated with the selected schedule will appear in the report

 4. Select one or more devices from the table.
 5. UnderStart date, select the start date of the report.
 6. UnderEnd date, select the end date of the report.
 7. Optionally, click the Filter tab and specify the report filter options for theWorkforce Scheduling report.
 8. Click theAdvanced tab.
 9. If you want to create a separate report for each day in the selected date range, select theCreate one

report for each day in the selected date range check box.
 10. AfterReport output language, select the language for the report.
 11. AfterReader type, select eitherExcel orPDF.
 12. If you want to email the report, underExcel distribution, select theEmail the report to check box and

specify the contact group, contact, and/or email address.
 13. If you want to print the report, select thePrint the report check box.
 14. Click Submit.

Running scheduled reports
If you need the same reports at the same time on a regular basis, you can scheduleWorkforce Scheduling
reports to run at a specific time of day, such as:

l Every day
l On a specific day of the week
l On the first or last day of themonth
l Each weekday

You can run scheduled reports to span the following time frames:
l Current or previous day
l Previous five or seven days, including or excluding the run day
l Current month to date
l Previous month
l Current year to date
l From a given start date to the current date
l Next five days to six months, including the run day

NOTE:Youmust create a report schedule before you can add reports to it.
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Creating report schedules
To create a report schedule
 1. In Contact Center Management, click Reporter=>Scheduled reports.
 2. Click theWorkforce Scheduling report schedules tab.
 3. Click Next.
 4. AfterSchedule name, type the name of the report schedule.
 5. AfterSchedule will run, select when the schedule will run.
 6. After at, select the time of day.
 7. AfterReports time span, select the time frame the report will cover.
 8. Click theDistribution tab.
 9. Select the groups to which you will email scheduling reports.
 10. Click Save.
 11. Click Add a report.
 12. Click theWorkforce Scheduling tab.
 13. Click Workforce Scheduling scheduled reports.
 14. AfterReport type, select a report.
 15. AfterSchedule, select a schedule.
 16. AfterEmployee select an employee.
 17. Optionally, click the Filter tab and specify the report filters options for theWorkforce Scheduling report.
 18. Click theAdvanced tab.
 19. AfterOutput language, select the language for the report.
 20. Click Save orExecute now.

Modifying report schedules
Tomodify a report schedule (for example, add a report)
 1. In Contact Center Management, click Reporter=>Scheduled reports.
 2. AfterSelect a schedule, select a schedule.
 3. Click Manage schedule properties.
 4. Click theProperties tab andmodify when the schedule runs the reports.
 5. Click theDistribution tab andmodify how the reports are distributed.
 6. Click theReports tab andmodify the reports included in the schedule.
 7. Click Save.

Schedule Adherence
Mitel Schedule Adherence is an optional application that works in conjunction with Contact Center
Management andWorkforce Scheduling. Schedule Adherence resides in the Contact Center Client real-time
monitors and enables you to view the real-time state of contact center employees scheduled inWorkforce
Scheduling. Schedule Adherence compares the current activities of employees to the configured schedule
and alerts you in real time when employees are out of adherence. Employees are considered out of adherence
if they are early or late for their scheduled events or if they are not performing scheduled activities.

Schedule Adherence is made available inWorkforce Scheduling and Contact Center Client when you are
licensed for Contact Center Management, Workforce Scheduling, and Schedule Adherence.
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Once you have configured a schedule inWorkforce Scheduling, you
l Configure adherence preferences inWorkforce Scheduling
l View adherencemonitors in Contact Center Client
l Set adherence alarms on the Employee State by Position/Timemonitors (optional)
l Run reports on employee adherence to scheduled activities

Configuring adherence preference
You can configure adherence thresholds for shifts, breaks, and jobs. You can set parameters for each event
type to suit the needs of your business. You select employee states and assign them to relevant events and
specify event time tolerance levels. You can optionally configure groups of employee states and then
associate them to relevant employee events.

NOTE:
l Schedule Adherence will handle two or more overlapping adherence thresholds in one of the following

ways. If only one of the events is valid for the current employee state, that event will be used. If more
than one event is valid for the current employee state, the first event, using start time, will be used.

l If no states are specified for an event type, all states will be considered in adherence.

Configuring adherence parameters
To configure adherence parameters
 1. InWorkforce Scheduling, click theConfiguration tab.
 2. In theAdherence group, click Adherence Configuration.

The Adherence Parameters window opens.
 3. In the left pane, expand the event type list and select the event to which you want to add relevant

adherence states.
 4. UnderEvent start tolerance (hh:mm), specify the times before and after which an employee state will

be reported on as out of adherence.
 5. UnderEvent end tolerance (hh:mm), specify the times before and after which an employee state will

be reported on as out of adherence.
 6. UnderAvailable states, select the states which are relevant for the specified event type and click > to

move the state to theAssigned states list.
 7. Repeat steps 2-6 for each event type for which you want to configure adherence parameters.
 8. Click OK.

Configuring state groups
To configure a state group
 1. InWorkforce Scheduling, click theConfiguration tab.
 2. In theAdherence group, click State groups.

The State groups window opens.
 3. Click Add.
 4. Type a name for the state group and click Create.
 5. UnderAvailable states, select the states that are relevant for the state group and click > to move the

state to theAssigned states list.
 6. Repeat steps 2-5 for each state group you want to configure.
 7. Click OK.
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Viewing adherence monitors in Contact Center Client
Schedule Adherence includes two Contact Center Client monitors that enable you tomonitor employee
adherence to schedules in real time. The Schedule Adherencemonitors alarm on employees who are not
adhering to schedules based on the thresholds you specify inWorkforce Scheduling and the alarms you
configure in Contact Center Client. You can optionally set adherence alarms on the Employee State by
Position/Timemonitors.

Adherence Detail Grid monitor
The Adherence Detail Grid monitor provides a drill-down view of employee scheduled activities, expected
states, and event totals. It enables you to easily compare expected employee states and actual employee
states in real time.

There are three levels to the Adherence Detail Grid monitor. The first level provides a high level overview of
employee adherence. The second level has two grids. The first lists all of the embedded events (breaks and
jobs) for the shift and the associated adherence information. The second grid lists the out of adherence record
for the shift. The final level has only one grid, which represents the out of adherence record for the embedded
events.

You can set Adherence Detail Grid alarms based on the following variables:
l Out of adherence
l Scheduled
l Expected states
l Actual state
l Actual start
l Current out of adherence
l Total out of adherence
l Shift time
l % out of adherence

Table 19 - 3 details provides column heading definitions for the Adherence Detail Grid monitor.
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Table 19 - 3 Adherence Detail Grid monitor headings

Heading Definition

Employee the name of the employee beingmonitored

Is in Adherence the check box is enabled when the employee is adhering to the schedule

Scheduled the type of event (shift, break, or job) the employee is performing, whether in
or out of adherence

Expected States the employee states that are relevant for the type of scheduled activity the
employee is scheduled to perform

Actual State the current employee state. If this is one of the expected states, the
employee is adhering to the schedule

Scheduled Start the time at which the employee is scheduled to start the scheduled activity

Actual Start the time at which the employee started the scheduled activity. This column
may be blank if the employee has not come into adherence for the scheduled
event

Scheduled End the time at which the scheduled event is to end

Current Out Of Adherence the amount of time the employee has been out of adherence for the
scheduled activity. This columnwill be blank if the employee is adhering to
the schedule

Total Out Of Adherence the total amount of time the employee has been out of adherence for all
scheduled activities for the current shift

Shift Time the duration of time the employee has been working the current shift

% Out Of Adherence the percent of time the employee has been out of adherence for the elapsed
portion of the scheduled shift

Shift the name of the shift for which the employee is scheduled

Embedded the name of the embedded event type (break or job)

Start the time at which the employee went out of adherence

End the time at which the employee came back into adherence

To open the Adherence Detail Grid monitor
 1. Click theReal Time tab in the Contact Center Client ribbon.
 2. From the drop-down arrow in theAdherence column, select Detail Grid.

The Add/Remove device IDs window opens.
 3. Select theEmployees orSchedules for which you want to review Adherence.
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 4. Click OK.
The Adherence Details monitor opens.
See Figure 19 - 7.

Figure 19 - 7 Adherence Detail Grid monitor

To set an Adherence Detail Grid monitor alarm
 1. Right-click the Adherence Detail Grid monitor and click Set Alarms.

NOTE:You can select the Apply the alarm thresholds to all devices displayed on themonitor option to
apply the threshold settings for performance variables across all employees. Alternatively, you can
select Apply the alarm thresholds to a specific list of devices to apply the threshold settings for
performance variables to a list of employees.

 2. If you selectedApply the alarm thresholds to a specific list of devices, underDevices, select the
employee(s) to which you want to apply the alarm thresholds.

 3. Under Performance variables, select the performance variable to which you want to set an alarm.
 4. UnderAlarm threshold, click Add a threshold and specify the font color, background, sound, pop-up,

bring to front, and email alarm options you want to apply to the alarm threshold.
 5. Click OK.

Adherence Timebars monitor
The Adherence Timebars monitor provides a schedule time bar, based on the employee time bar and event
colors configured inWorkforce Scheduling, for each employee's scheduled activities. The current time is
identified by a green line on the employee time bar and past events are shaded purple.

You can set Adherence Timebar alarms based on the following variables:
l Shift out of adherence
l Break out of adherence
l Job out of adherence
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To open the Adherence Timebar monitor
 1. Click theReal Time tab in the Contact Center Client ribbon.
 2. From the drop-down arrow in theAdherence column, select Timebars.

The Add/Remove device IDs window opens.
 3. UnderSchedules, select a schedule to include in themonitor or underEmployees, select the

employees tomonitor.
 4. Click OK.

The Adherence Timebars monitor opens.
See Figure 19 - 8.

Figure 19 - 8 Adherence Timebars monitor

To set an Adherence Timebar monitor alarm
 1. Right-click the Adherence Timebar monitor and click Set Alarms.

NOTE:You can select the Apply the alarm thresholds to all devices displayed on themonitor option to
apply the threshold settings for performance variables across all employees. Alternatively, you can
select Apply the alarm thresholds to a specific list of devices to apply the threshold settings for
performance variables to a list of employees.

 2. If you selectedApply the alarm thresholds to a specific list of devices, underDevices, select the
employee(s) to which you want to apply the alarm thresholds.

 3. UnderPerformance variables, select the performance variable to which you want to set an alarm.
 4. UnderAlarm threshold, click Add a threshold and specify the background, sound, pop-up, bring to

front, and email alarm options you want to apply to the alarm threshold.
 5. Click OK.

Employee State by Position/Time monitors
You can now optionally alarm on employees who are not adhering to schedules on the Employee State by
Position/Timemonitors.

To set an adherence alarm on the Employee State by Position/Timemonitors
 1. Right-click an Employee State by Position/Timemonitor and click Set Alarms.

NOTE:You can select the Apply the alarm thresholds to all devices displayed on themonitor option to
apply the threshold settings for performance variables across all employees. Alternatively, you can
select Apply the alarm thresholds to a specific list of devices to apply the threshold settings for
performance variables to a list of employees.

 2. If you selectedApply the alarm thresholds to a specific list of devices, underDevices, select the
employee(s) to which you want to apply the alarm thresholds.

 3. UnderPerformance variables, select the performance variable to which you want to set an alarm.
 4. UnderAlarm threshold, click Add a threshold and specify the background, sound, pop-up, bring to

front, and email alarm options you want to apply to the alarm threshold.
 5. Click OK.
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Running adherence reports
The Schedule Adherence reports are produced inMicrosoft Excel format. Youmust run and print the following
Schedule Adherence reports from Contact Center Management. See theContact Center Solutions Enterprise
Edition Reports Guide for more information.

You can produce on-demand reports and scheduled reports for the following reports:
l Employee and EmployeeGroup Adherence Trace
l EmployeeGroup TimeOut of Adherence by Employee by Day of Week
l EmployeeGroup TimeOut of Adherence by Day of Month
l EmployeeGroup Adherence by Period

You run Schedule Adherence reports in the Contact Center Management website, under
Reporter=>Schedule Adherence.

Employee Portal
Mitel Employee Portal enables employees to view and trade shifts online and request changes to schedules
for time off, shifts, and availability. Employee Portal enables schedulers to view employee requests, perform
what-if scenarios, quickly approve or deny requests, and automatically update schedules.

Employee Portal is made available inWorkforce Scheduling and the web-based user interface when you are
licensed for Contact Center Management, Workforce Scheduling, and Employee Portal.

Employee Portal is available only to employees who have the correct permissions configured in YourSite
Security. The following permissions currently exist:

l May access Employee Portal
l May trade shifts
l May trade time off
l May request changes to availability

For specific details on configuring employee roles and security options, see .

Employee functionality
Using Employee Portal, employees can

l View their currently scheduled shifts and the shifts of other employees who share their schedule
l View messages from supervisors and employees and receive updates about the status of their

requests on the home page
l Offer shifts to the bulletin board for other employees to take or trade
l Remove shifts from the bulletin board
l Propose to take shifts from the bulletin board
l Propose to trade shifts from the bulletin board
l Accept or reject employee proposals to take or trade your shift
l Request time off
l Request changes to your availability
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The Employee Portal home page provides links to the bulletin board, view and offer your scheduled shifts for
take or trade, view your pending offers, request time off, and request availability changes. Any Employee
Portal alerts that require your attention also display on the home page. These include

l You have approved shift requests
l You have denied shift requests
l You have shift requests pending supervisor approval
l You have shift proposals pending your acceptance
l You have shift proposals pending acceptance or that have been rejected
l You have time off requests pending supervisor approval
l You have notes regarding your availability

If a home page alert is red, it requires your attention. Click View to view the alert and any employee or
supervisor notes in detail.

Starting Employee Portal
To start Employee Portal
 1. OpenEmployee Portal.
 2. Type your username and password.
 3. Click Log on.

Creating a desktop shortcut to Employee Portal
To create a desktop shortcut to Employee Portal
 1. OpenEmployee Portal.
 2. Enter your login credentials and click Log on.
 3. Drag and drop the Employee Portal web address from the address bar to your computer desktop.

Viewing currently scheduled shifts
To view your currently scheduled shifts
 1. In Employee Portal, click My shifts.
 2. If you want to view shifts starting on a specific calendar day, select the start date from the calendar.
 3. Optionally, to view the break and job details for a specific shift, underDetails, click Select.

Viewing the shifts of other employees in your schedule
You can view the shifts for other employees in your schedule to help you determine potential shift swaps.

To view the shifts of other employees in your schedule
 1. Click My Schedules.
 2. To view shifts starting on a specific day, select the start date from the calendar.
 3. Click Select next to the employee for which you want to view the shift.

The break and job details for the shift display below.

Offering shifts for other employees to take or trade
You can offer shifts to the bulletin board for other employees to take or trade. You can remove shifts from the
bulletin board at any time as long as no employees have proposed to take or trade the shift. Shifts that have
already begun cannot be posted to the bulletin board for other employees to take or trade.
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To offer a shift for other employees to take or trade
 1. Click Offer my shifts.
 2. Next to the shift you want to offer for other employees to take or trade, click Select.

The shift details display.
 3. Click Continue.
 4. Optionally, type a note to accompany your offer.
 5. Click Submit.

Removing shifts from the bulletin board
You can remove shifts from the bulletin board at any time as long as no employees have proposed to take or
trade the shift. If a proposal has beenmade, you will need to reject it first before you can remove the shift from
the bulletin board.

To remove a shift from the bulletin board
 1. Click My pending offers.
 2. Next to the shift you want to remove from the bulletin board, click Select.

The shift details display.
 3. Click Continue.

The shift offer is removed from the bulletin board.

Proposing to take shifts
To propose to take a shift
 1. Click Bulletin board.
 2. Next to the shift you want to take, click Select.

The shift details display.
 3. Click Continue.
 4. Click Next.
 5. Optionally, add a note to accompany your proposal.
 6. Click Next.
 7. Click Submit.

Proposing to trade shifts
To propose to trade a shift
 1. Click Bulletin board.
 2. Next to the shift you want to take, click Select.

The shift details display.
 3. Next to the shift you want to propose for trade, click Select.
 4. Optionally, add a note to accompany your proposal.
 5. Click Next.
 6. Click Submit.
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Accept or reject an employee proposal to take or trade your shift
To accept or reject an employee proposal to take or trade your shift
 1. On the Employee Portal home page, next toYou have <#> shift proposals pending your

acceptance, click View.
The Proposals window displays.

 2. Next to the proposal you want to view, click Select.
The proposal details display with any relevant employee notes.

 3. Click Accept to accept the proposed shift change. Otherwise, click Reject to reject the proposed shift
change.

Requesting time off
To request time off
 1. Click Request time off.

The Request time off window displays, including a list of any time off you have already scheduled.
 2. Click Request time off.
 3. Select a time off type from the list.
 4. Click Next.
 5. Specify the time off start and end times.
 6. Click Next.
 7. Optionally, add a note to accompany the time off request.
 8. Click Next.

The time off request summary displays.
 9. Click Submit.

Requesting availability changes
NOTE: You can click Clear request at any time to reset the Request availability change window to your
currently configured availability.

To request an availability change
 1. Click Request availability change.

The Request availability change window displays with your current availability.
 2. If you need to change existing availability, underUpdate current availability, select a day of the week

and click Remove. Otherwise, continue to step 3.
 3. UnderChange availability, specify the dates and times you are available to work.

l AfterDay of week, specify the day of week you are available.
l If you are only available during certain hours, select Part of the day, and specify the times at which

you are available.
l If you are available to work at any time during the day, select Full day.

 4. Click Add to add the new availability to the request.
 5. You can optionally select a currently configured availability day or time in theUpdate current

availability list and click Remove to remove it from the list.
NOTE: The Add button is for adding new availability to the Update current availability list only and not
for replacing specific dates and times from the currently configured availability list.

 6. Optionally, underEmployee note, add a note to accompany your request.
 7. Click Accept.

The Confirm availability change window displays.
 8. Specify the date that your requested availability will take effect.
 9. Click Submit.
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Supervisor functionality
Using Employee Portal, supervisors can

l View employee scheduling requests
l Preview the effect of approving or denying employee shift change requests
l Approve or deny employee proposals to take or trade shifts
l Approve or deny employee requests for time off
l Approve or deny employee requests for availability changes

Handling employee scheduling requests
NOTE: If you attempt to approve an employee's request for time off for a period where a schedule has yet to
be built, time off will not be decremented properly and the time off will be entered as an unavailable event in
the schedule.

To view, approve, or deny employee scheduling requests
 1. OpenWorkforce Scheduling.
 2. Log on toWorkforce Scheduling.
 3. Load an active schedule.
 4. Click theEmployee Portal tab.
 5. Click the Request mode icon.
 6. In the details pane, click theShift changes, Time off, andAvailability tabs to view any employee

scheduling requests pending your approval.
 7. Next toApprove, click the + to view the scheduling request details.
 8. If you are viewing the Shift change tab, click View timebar to view the scheduled shift.
 9. In the Employee requests group, click Preview to view the effect of approving the request.
 10. In the Employee requests group,

l Click Approve to approve the request.
l Click Deny to deny the request.
The schedule is automatically updated and employees are notified of the schedule request status.

Employee Portal reports
The Employee Portal reports are produced inMicrosoft Excel format. Youmust run and print the following
Employee Portal reports from Contact Center Management. See theContact Center Solutions Enterprise
Edition Reports Guide for more information.

The following reports are available with Employee Portal:
l Employee Portal Availability Requests

Provides a detailed summary of employee requests for availability changes
l Employee Portal Time Off Requests

Provides a detailed summary of employee requests for time off
l Employee Portal Shift Requests

Provides a detailed summary of employee requests to take or trade shifts
l Employee Portal Shift Change Status

Provides a detailed summary employee requests that have been approved or denied

You run Employee Portal reports in the Contact Center Management website, under Reporter=>Workforce
Scheduling=>Employee Portal.
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Chapter 20

Traffic Analysis

Using Traffic Analysis
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Traffic Analysis
Traffic Analysis is an optional application that works with Call Accounting and Contact Center Solutions.
Traffic Analysis works in conjunction with the 3300 ICP telephone system.

In order to have summarized data for Traffic Analysis reports youmust wait until the nightly maintenance
routine runs the summary (at midnight each night). The data for these reports is derived from the traffic
stream. Traffic Analysis reports are not available in real-time.

For detailed information about traffic reports, refer to theContact Center Solutions Reports Guide. Traffic
reports provide call statistics on DTMF receivers, route lists, route plans, routes, and trunks. You can create
the following on-demand and scheduled traffic reports:

l Attendant Console Traffic by Interval report
l Attendant Traffic by Interval
l Attendant Group Traffic by Interval
l DTMF Receiver Group Traffic by Interval
l Route List Traffic by Interval
l Route Plan Traffic by Interval
l Route Traffic by Interval
l Trunk Traffic by Interval
l Trunk Busy Hour Traffic by Day of theWeek
l Trunk and Trunk Group Traffic Usage by Day of theWeek
l Trunk GroupOutgoing Traffic by Interval
l Trunk GroupOutgoing Traffic Usage by Day of theWeek
l Trunk GroupOutgoing Busy Hour Traffic by Day of theWeek

Using Traffic Analysis
Before you generate Traffic Analysis reports youmust configure data collection for Traffic Analysis.

To configure data collection for Traffic Analysis
 1. Set up the telephone systems to collect traffic data
 2. Configure themedia servers in Contact Center Management for traffic data collection

(YourSite=>Enterprise).

Setting up telephone systems to collect traffic data
You can collect traffic data from a 3300 ICP telephone system over TCP/IP.

Setting up the 3300 ICP
Youmust specify traffic data options on the 3300 ICP Traffic Options Assignment form in order to collect
traffic data and produce reports with the Traffic Analysis application.
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The Traffic Options Assignment form is a form-drivenmethod to obtain time-based traffic reports on telephone
system usage. You can generate reports that cover attendant usage, channel utilization, system activity, data
station usage, delay to dial tone, extension-to-extension calls, feature usage, and trunk use.

NOTE:
l You can define up to six different time slots.
l If the start and stop time are blank while the time slot is active, an error message is displayed when the

commit operation is attempted; in this case, the changes will not be committed.
l No two traffic slot stops should be less than 5minutes apart. This time is required for the system time

to generate the previous report.
l Making changes to the data in this form and recommitting interrupts a traffic report that is running.

Programming the Traffic Options Assignment form
To program the Traffic Options Assignment form
 1. Log onto the 3300 ICP telephone system.
 2. Browse to the Traffic Options Assignment form.
 3. Click Change.
 4. Configure the traffic options as described in Table 20 - 1.

Option Value

Time Slot Active Select Yes to start a traffic session at the time specified in Start
Time field and finish at the Stop Time field for each of up to six
different slots. The report is resumed the next day at the same time.
Select No to suspend the traffic report for the associated time slot.
The traffic report will not run until Yes is entered and the form
recommitted. Default is No. There can be no overlapping of ACTIVE
time slots. Select: Yes

Start Time
(-Hours, -Minutes)

Select the time the traffic report is to start running. Default is blank.
The start timemust be assigned for active time slots; it can be blank
for inactive time slots. If the start time equals the stop time then the
time period is 24 hours. Select: 00:00

Stop Time
(-Hours, -Minutes)

Select the stop time for the report. If the session is to run for 24
hours, enter the same time as the start time. Default is Blank. The
stop timemust be assigned for active time slots; it can be blank for
inactive time slots. If the start time equals the stop time then the time
period is 24 hours. Select: 24:00

Period Length Select the length of time(15, 30, or 60minutes) that data is to be
collected for the session before a traffic report is formatted and
output. Default is 60minutes. Select: 15

Usage Units Select the type of units the report will use. Default is Erlangs. Select:
Erlangs

Autoprint Select Yes to spool the traffic report to the printer assigned to this

Table 20 - 1 3300 ICP Traffic Options Assignment form
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Option Value

function in the Application Logical Port Assignment form. Default is
No. Wewill be using the LPR1 Port 1754 to output traffic.
Select: Yes

Maximum Number of Traffic Files Enter themaximum number of traffic reports to be stored in disk.
Default is 10. Select: 10

Sections to include in Traffic Report Select Yes to enable the collection of data for each resource group
you want to include in the traffic report. The default is No.

Route Plans Yes

Route Lists Yes

Routes Yes

Trunk Groups Yes

Trunks Yes

Links No

Groups of Links No

Channels No

DTMF Receivers Yes

Data Transceivers No

ModemGroups No

Data Station Groups No

Attendant Groups Yes

Attendant Consoles Yes

Attendants Yes

Assigning ports
Youmust assign a port to the 3300 ICP to output traffic data.

To enable traffic data output
 1. Log on to the 3300 ICP telephone system.
 2. Browse toApplication Logical Port Assignment.
 3. Select Traffic Report Port.
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 4. Click Change.
 5. UnderPort Physical Name, type LPR1.
 6. Click Save.

Verifying the traffic output
Before you configure traffic collection settings for the 3300 ICP, verify traffic data is being output through port
1754.

To verify traffic is being output through port 1754.
 1. Click Start=>Programs=>Accessories=>Communication=>Hyperterminal.
 2. AfterName, type Traffic.
 3. Click OK.
 4. AfterHost address, type the IP address of the 3300 ICP
 5. After Port number, type 1754.
 6. AfterConnect using, select TCP/IP.
 7. Click OK.
 8. Wait the interval time you selected in the Traffic Options Assignment, for example 15, 30 or 60minutes.

The traffic should then output to your screen.
 9. After the output is complete, you can disconnect and close the hyper terminal window.

Configuring media servers in YourSite
Youmust configure traffic collection settings in YourSite for themedia servers from which you collect traffic
data.

3300 ICP
You do not require a dataset to collect traffic data from a 3300 ICP. The traffic data is directed to the printer
port, 1754, on the 3300 ICP telephone system. See "Configuring data collection settings for 3300 ICP media
servers" on page 78.

Verifying traffic data is saved on the Enterprise Server
To verify the traffic collection for the 3300 ICP
 1. Double click the Contact Center Management Enterprise Server icon on your desktop.
 2. Using an administrative username and password, log on to the Contact Center Management website.
 3. Click YourSite=>Enterprise.
 4. Expand the tree of the site for which you want to configure traffic options.
 5. Click a 3300 ICPmedia server.
 6. Click theData Collection tab.
 7. Verify the Traffic Analysis check box is selected and the port is 1754.
 8. Wait the interval time you selected in the Traffic Options Assignment, for example 15, 30 or 60minutes.
 9. On the Enterprise Server, browse to <drive letter:>\program files\prairieFyre Software

Inc.\CCM\Data Directory\Node_0X.
This is the directory of themedia server for which you configured traffic options.
You should see a new file with the following naming convention, TYYYYMMDD.txt. For example,
T20050127.txt, where YYYY is the year, MM is themonth, and DD is the day.

 10. Double-click the file to open it and view the traffic data.
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Chapter 21

Multimedia Contact Center

Statement of support for social media integration
UsingMultimedia Contact Center
Multimedia Contact Center options
Multimedia Contact Center options in Outlook
Agent actions
Contact management
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Multimedia Contact Center
Multimedia Contact Center distributes emails, SMS messages, chats (customer-initiated, Internet-based chat
sessions), and faxes to contact center agents, and tracks handling across media types. Agents access
Multimedia Contact Center fromMicrosoft Outlook. When your corporate email server is aMicrosoft
Exchange Server, agents view bothMultimedia Contact Center andMicrosoft Office Outlook email inboxes in
one window.

NOTE: TheMultimedia Contact Center plug-in is not supported for use with Mitel Border Gateway.

Before you useMultimedia Contact Center for the first time on your client computer, youmust
 1. Install Client Component Pack.

See "Installing Client Component Pack using an administrative procedure" on page 38.
 2. Run Client Role Selector.

See "Using the Client Role Selector to select your Contact Center Client role" on page 40.
 3. Start Contact Center Management and configure security options for Multimedia Contact Center.

See "Starting Contact Center Management" on page 37.
 4. Start YourSite Explorer to configure all devices that are not configured in Contact Center Management.

To see where specific devices are configured, refer to "Configuration" on page 52.
 5. Start Contact Center Client and log on and then log off.

See "Starting Contact Center Client" on page 191.
 6. Start Outlook and log on toMultimedia Contact Center.

See "StartingMultimedia Contact Center on a client computer" on page 712.
 7. In Outlook, specify real-time server connection parameters for Multimedia Contact Center.

See "Verifying real-time server connection parameters" on page 713.

Statement of support for social media integration
Multimedia Contact Center offers integration with third-party social mediamonitoring applications to provide
uniform, knowledgeable, and responsivemessaging to social media sites, industry blogs and wikis,
knowledge bases, and forums. Using a third-party social mediamonitoring application, businesses can use
advanced text analytics to detect relevant key words and phrases on social media sites and send notifications
to a skilledMultimedia Contact Center agent who can respond accordingly. This enables businesses to
protect and promote their brand by identifying demoting, promoting, and influencing your business while
measuring andmanaging the agent activity while they are responding to social media posts using the
advanced real time and reporting capabilities of Multimedia Contact Center. For example, you could designate
a specific agent (acting as representative of your company) to handle social media responses, set a service
level objective on social media responses, and thenmonitor and report on that agent’s handling of social
media responses usingMultimedia Contact Center.

TheMultimedia Contact Center Social Media integration leverages existing Contact Center andMultimedia
Contact Center infrastructure tominimize startup costs. Customers only need an account with a third-party
social media application to integrate with Multimedia Contact Center.

A case study was recently performed with Mitel Multimedia Contact Center and Yupiq, a social media
application that monitors and filters social media sites for relevant posts and activity which can then
distributed toMultimedia Contact Center agents and/or queues to review the posts and respond as
necessary. UsingMultimedia Contact Center, in conjunction with Yupiq, enables businesses to:
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l Monitor corporate public Facebook Fan pages and LinkedIn sites
l Report tweets on Twitter that match filter conditions
l Specify public email addresses where Facebook, LinkedIn, and Twitter posts are sent
l Distribute social media posts to agents who can respond to posts
l Generate reports on social media posts handled by agents

While the Social Media integration for Multimedia Contact Center has currently been validated with Yupiq,
more third-party social media partners are planned to be announced in future releases of Contact Center
Solutions software.

Using Multimedia Contact Center
You useMultimedia Contact Center in conjunction with Contact Center Management. Multimedia Contact
Center integrates all media types in Contact Center Management for multimedia reporting and real-time
monitoring. Before you useMultimedia Contact Center youmust configure options in Contact Center
Management, YourSite Explorer, andOutlook.

Multimedia Contact Center options
Youmust configure enterprise settings, relevant devices, Network Monitor, schedules, and security before
you can useMultimedia Contact Center. For information on how to configure your system, see
"Configuration" on page 52.

Ensure you configure the followingMultimedia Contact Center options:
l Multimedia Contact Center Email, SMS, WebChat, and/or Fax media servers, and queues and queue

groups.
See "Adding aMultimedia Contact Center Email media server" on page 89.
NOTE:Before you configure user settings youmust disassociate email addresses before applying
them toMultimedia Contact Center queues.
See "Adding employee groups" on page 130.

l Multimedia Contact Center user settings for employees.
See "EmployeeQuick Setup" on page 113.

l Employee personal details.
See "Adding employees" on page 123.

l Multimedia Contact Center Email, SMS, WebChat, and Fax queues.
See "Adding queues" on page 135.

When you configure agent IDs, you can use the same agent ID across voice, email, SMS, chat, and/or fax
media types. For example, you could add Agent 1000 and associate Agent 1000 with voice, email, SMS, chat
and/or fax media types.

If you want each of your employees to have only one agent ID, then youmust set up your contact center as
described in Configuration scenario 1. See "Configuration scenario 1" on page 97. If you want your employees
to have an agent ID for each agent group to which they belong, then youmust set up your contact center as
described in Configuration scenario 2. See "Configuration scenario 2" on page 99.

Disassociating email addresses
If you want the same company email addresses that you used prior to purchasingMultimedia Contact Center,
for example, support@yourcompany.com, to arrive in your Multimedia Contact Center agent inboxes, then
youmust first disassociate the email addresses from their original associations. Once they are disassociated,
you can then configure these email addresses for Multimedia Contact Center.
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To disassociate an email address
 1. InWindows, navigate toMicrosoft Exchange and openActive Directory Users and Computers.
 2. Expand the tree until you see theUsers folder.
 3. Click theUsers folder.

The Users folder opens.
 4. In the right pane, double-click Support.

The Support window opens.
 5. Click theEmail Addresses tab.
 6. Select support@yourcompany.com.
 7. Click Edit.
 8. Change support@yourcompany.com to support1@yourcompany.com.
 9. Click OK.
 10. Click OK.
 11. Close theActive Directory Users and Computers window.

Starting Multimedia Contact Center on a client computer
NOTE:

l The first time you start Outlook, you will be asked if theMultimedia Contact Center plug-in should be
installed each time you start Outlook. Select the Yes check box.

l Youmust configure real-time server parameters in order to be able to log in as aMultimedia Contact
Center agent. See "Verifying real-time server connection parameters" on page 713.

To log on toMultimedia Contact Center
 1. Click theOutlook desktop icon.

TheMultimedia Contact Center login window opens.
NOTE:You use the same user name and password to start Multimedia Contact Center as you do to
start Contact Center Management.

 2. Type your user name and password.
See Figure 21 - 1.

Figure 21 - 1 Multimedia agent login

 3. Select the check box beside the agent IDs to which you are logging on, for one or moremedia types.
 4. Select theSave as default check box.
 5. Click Log On.

Outlook starts and displays your Multimedia Contact Center inbox (Agent Inbox).
See Figure 21 - 2.
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Figure 21 - 2 Agent Inbox

Multimedia Contact Center options in Outlook
Before you useMultimedia Contact Center, you configureMultimedia Contact Center options in Outlook:

l Real-time server connection parameters
l Startup options
l Arrival options
l Agent Inbox columns

Verifying real-time server connection parameters
The real-time server connection parameters specify the IP address and port number used by Multimedia
Contact Center. Multimedia Contact Center uses the same IP address as the Enterprise Server and the same
port number as Contact Center Client.

To verify Multimedia Contact Center Server connection parameters
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.

See Figure 21 - 3.
 2. Under IP address, type the IP address of the Enterprise Server.

You can find the IP address under YourSite=>Enterprise on the Enterprise tab.
 3. UnderPort number, type the real-time port number.

You can find the real-time port number under YourSite=>Enterprise, on the Enterprise tab.
CAUTION: If you select SSL, ensure the IP address is the one you used when applying the SSL
certificate.

 4. If you use Secure Socket Layer, select SSL.
 5. Click OK.
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Figure 21 - 3 Multimedia Contact Center tab

Configuring Multimedia Contact Center startup options
You can specify Outlook displays

l Multimedia Contact Center shortcuts
l TheMultimedia Contact Center agent login window when you start Outlook
l The Agent Inbox instead of your Personal Inbox when you start Outlook

Displaying shortcuts
TheMultimedia Contact Center shortcuts window lists shortcuts to your Personal Inbox and Agent inbox.
When you click the Agent Desktop shortcut, Outlook displays two panes.

l Personal Inbox displays emails you receive from friends and colleagues.
l Agent Inbox displays ACD emails, SMS messages, chats, faxes (contacts) you receive from

customers.

To display Multimedia Contact Center shortcuts
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. UnderMultimedia Contact Center startup options, select theDisplay Multimedia Contact Center

shortcuts check box.
 3. Click OK.
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Displaying the agent login window
You can specify theMultimedia Contact Center agent login window is displayed when you start Outlook. On
the agent login window, you select an agent login ID for eachmedia type to which you are logging on.

To specify theMultimedia Contact Center agent login window opens when you start Outlook
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. UnderMultimedia Contact Center startup options, select theDisplay login form check box.
 3. Click OK.

Configuring which inbox opens when you start Outlook
When you start Outlook you can scroll up or down in theMail Folders pane to view your inboxes.

To specify your Agent Inbox opens when you start Outlook
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. UnderMultimedia Contact Center startup options, select theGo to my Agent Inbox folder check

box.
 3. Click OK.

Displaying real-time queue statistics
You can specify that Outlook displays a toolbar of real-time ACD queue statistics.

To view real-time ACD queue statistics in Outlook
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. UnderMultimedia Contact Center startup options, select theDisplay real-time queue statistics

check box.
 3. Click OK.

Configuring Multimedia Contact Center arrival options
You can specify arrival options for contacts so you are notified when ACD contacts arrive in your inbox: you
can configure Outlook to open on top of all other applications and play unique sound files when contacts
arrive.

Displaying Outlook as your top window when contacts arrive
NOTE: You can apply this option to email/SMS, chat, and fax media types only.

To specify Outlook opens on top of all other open applications when emails arrive
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. Click theEmail arrival options tab, Chat arrival options tab, or Fax arrival options tab.
 3. Select theMake Outlook my top window check box.
 4. Select the unless an email is active check box.
 5. If you want to apply this option to email/SMS, chat, and fax contacts, click Apply settings to all tabs.
 6. Click OK.
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Directing ACD contacts to your Agent Inbox
NOTE: You can apply this option to email/SMS, chat, and fax media types only.

To specify ACD contacts are sent to your Agent Inbox
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. Click theEmail Arrival Options tab, Chat Arrival Options tab, or Fax Arrival Options tab.
 3. Select theGo to my Agent Inbox when an email/SMS/chat/fax arrives check box.
 4. Select the and when it is finished check box.
 5. If you want to apply this option to email/SMS, chat, and fax contacts, click Apply Settings to All

Tabs.
 6. Click OK.

Configuring contact arrival sounds
NOTE: You can apply this option to email/SMS, chat, multi-chat, and fax media types only.

To specify aMultimedia Contact Center contact arrival sound file
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. Click theEmail Arrival Options tab, Chat Arrival Options tab,Multi-Chat Options, or Fax Arrival

Options tab.
 3. Select theAudibly notify me check box.
 4. Select the every check box and select the number of seconds.
 5. Click Advanced.
 6. Select thePlay sound for new message check box.
 7. If you want to play a beep, click Play beep and specify the tone and select the number of times the beep

will repeat. Otherwise, click Play wav file and click the ellipses button and select the file.
 8. Click OK.
 9. If you want to apply this option to email/SMS, chat, and fax contacts, click Apply Settings to All

Tabs.
 10. Click OK.

To specify aMultimedia Contact Center multi-chat contact arrival sound file
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. Click Advanced.

TheMulti chat options window opens.
 3. Select thePlay sound for new message check box.
 4. If you want to play a beep, click Play Beep and specify the tone and select the number of times the

beep will repeat. Otherwise, click Play Wave File and click the ellipses button and select the file.
 5. Click OK.
 6. Click OK.
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Checking spelling
NOTE: You can apply this option to email/SMS, multi-chat, and fax media types only.

To specify Outlook checks the spelling of emails, SMS messages, and faxes before you send them
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. Click theEmail Arrival Options tab, Chat Arrival Options tab, or Fax Arrival Options tab.
 3. Select theCheck spelling before sending check box.
 4. If you want to apply this option to email, SMS messages, and fax contacts, click Apply Settings to All

Tabs.
 5. Click OK.

Replying to faxes with the original fax request
NOTE: You can apply this option to fax only.

To include part or all of the original fax request when you reply to a fax
 1. In Outlook, click Tools=>Options and select theMultimedia Contact Center tab.
 2. Click the Fax Arrival Options tab.
 3. Select theWhen replying, send back check box.
 4. Click first and specify the number of pages of the original fax to include. Otherwise, if you want to

include all pages of the original fax, click all pages.
 5. Click OK.

Customizing the Agent Inbox columns
If you right-click the gray bar below Agent Inbox, and select Field Chooser, then select PF6150MCC.ACD,
you can select column headers for the Agent Inbox. You drag and drop the columns you want to display.
prairieFyre recommends you add the Ticket Number column header to the Agent Inbox.

The Field Chooser Forms list consists of the following column headers for email.
l From lists the name of the person who emailed you.
l NoReply Needed has a check box you enable if you want to remove a unopened email from your Agent

Inbox.
l Queue ID lists the email address the customer used to contact your business

(support@prairieFyre.com) and the queue that we have assigned to that email address (P505).
l Last State Change lists the date (YYYY-MM-DD) the email last changed.
l Multimedia Contact Center status lists the status of the email. Arrival status is 1, reply status is 2, and

hold status is 3.
l Client ID lists customer (client) IDs. A client ID is assigned to a client the first time the client emails

your company. The client keeps the same ID for as long as he does business with your company. You
cannot manually select client IDs.

l Agent ID lists the email agent ID of the agent who receives the email request.
l Ticket Number lists a unique number for each email.
l Subject lists the subject for each email.
l Received lists the date and time the email arrived in the Agent Inbox.
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The Field chooser forms list consists of the following column headers forWebChat.
l Client Chat Name is the name that the customer enters on the chat request form to initiate a chat

session with your company.
l Rand (Random) ID number is a randomly generated number used by Multimedia Contact Center for

tracking. The agent does not need this number. The agent needs the Session ID number to track the
chat message.

l Session ID number is the number the agent uses to track the chat message. It is similar to the ticket
number used for email contacts.

Agent actions
Agents useMultimedia Contact Center to control their availability to receive contacts, handle contacts, create
and useMultimedia Contact Center templates, and view agent and queue statistics.

Performing agent actions
The Agent actions toolbar menu includes the following submenus:

Employee Control
You can log an agent on or off of all of themedia types to which the agent is logged on and set or removeMake
Busy Reason Codes for all of themedia types to which the agent is logged on.

The Reconnect to the real-time server command reconnects you to the Enterprise Server should you become
disconnected. When you click Reconnect to the real-time server, theMultimedia Contact Center login window
opens.

Voice, Email/SMS, Chat, and Fax Actions
You can Log an agent on or off of themedia type selected and set or removeMake Busy Reason Codes for
themedia type selected.

Force Forward
If an agent is responding to a contact receives a second contact, the agent can click Force Forward to place
themselves in Make Busy and requeue the second contact (so it can be handled by another agent). For
example, if an agent handling a call receives a chat request, the agent can click Force Forward to requeue the
chat.

NOTE: If you accidentally close Outlook, Multimedia Contact Center requeues any contacts waiting in your
Agent Inbox.

Logging on
Multimedia agents can log on and off of email/SMS, chat, fax, and voice queues individually or
simultaneously. Using Employee Control, agents can configure default logins that log them on to specific
media types using specific IDs. See "Logging in tomultiple media types" on page 719.
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Logging in to multiple media types
To log in to voice, email/SMS, chat, and/or fax
 1. In Outlook, click Agent Actions=>Employee Control=>Log On=>Log On (Custom).
 2. Select the check boxes of the agent IDs to which you will log on.
 3. Select theSave as default check box.
 4. Click Log On.

TheOutlook toolbar displays the IDs you used to log in, and the duration of time you have been logged
in, for eachmedia type.
See Figure 21 - 4.

Figure 21 - 4 Logging in to multiple media types

Logging in to one media type at a time
To log in to voice, email/SMS, chat, or fax
 1. In Outlook, click Agent Actions=>Chat Actions/Email Actions/Fax Actions/Voice Actions=>Log

On.
 2. Select the check box of the agent ID to which you are logging on, for themedia type currently selected.
 3. Click Log On.

TheOutlook toolbar displays the agent ID and the duration of time you are logged on to themedia type
selected.

Setting Make Busy Reason Codes
Multimedia agents can set and removeMake Busy Reason Codes for email/SMS, chat, fax, and voice
individually or simultaneously. Using Employee control, agents can set Make Busy for multiple media types
simultaneously. See "SettingMake Busy Reason Codes for multiple media types" on page 719.

Alternatively, you can set Make Busy for email/SMS, chat, fax, and voice individually. See "SettingMake
Busy Reason Codes for onemedia type at a time" on page 720.

Setting Make Busy Reason Codes for multiple media types
To set Make Busy Reason Codes across multiple media types

l In Outlook, click Agent Actions=>Employee Control=>Set Make Busy=>Break1.
Outlook places the agent IDs to which you are logged on, in Make Busy.
See Figure 21 - 5.
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Figure 21 - 5 Setting Make Busy

Setting Make Busy Reason Codes for one media type at a time
To set Make Busy Reason Codes for individual media types

l In Outlook, click Agent Actions=>Chat Actions/Email Actions/Fax Actions=>Set Make
Busy=>Break1.
Outlook places the agent ID to which you are logged in, in Make Busy, for themedia type selected.

Requeuing contacts
To requeue a contact (place it back in the queue to be handled by another agent)
 1. In Outlook, select yourAgent Inbox and the email/SMS, chat or fax contact to be requeued.
 2. Click Agent Actions=>Force Forward.
 3. Click OK.

Contact management
NOTE: The times required to handle contacts differ across media types. Youmust configure the agent
requeue time, hold time, and interflow time for each email, SMS, chat, and fax queue. See "Adding queues" on
page 135 to configure handling times.

TheMultimedia Contact Center agent handling features include

Replying to contacts
The Reply command displays a window in which you type a response or select a response template. The
window provides agent handling options (for example, Account Codes, Hold, Transfer, No Reply Needed).

Applying Account Codes
The Account Codes command tags an email, Webchat, SMS, or fax contact with an Account Code (for
example, to identify what service or product a customer is requesting, or to indicate if the customer is happy
with the service). You can tag a contact with multiple account codes.

Placing contacts on Hold
The Hold command places an email, SMS, or fax contact on hold while you gather information or respond to
another contact.

Transferring contacts
The Transfer command transfers an email, SMS, or fax contact to an another agent, to an external email
address (a non-Multimedia Contact Center agent), or to a queue.
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Setting No Reply Needed
The NoReply Needed command tags an email, SMS, or fax contact withNoReply Needed or Junk Mail. If an
agent receives an email, SMS, or fax from a customer and no response is required, the agent can tag the
contact withNoReply Needed. The NoReply Needed tag enables you to generate reports showing the
contact as having been received, but not requiring a response. If an agent receives an email, SMS, or fax from
an unsolicited sales organization, the agent can tag the contact with Junk Mail. The system removes contacts
tagged with Junk Mail from the ACD Calls Offered and ACD Calls Handled pools so they are excluded from
the reports.

Viewing a client’s history
The Client history tab displays a client’s contact history.

Creating and using Multimedia Contact Center templates
You can create a folder of response templates (standard company responses to frequently asked questions).
You can use templates to optimize productivity, reduce response times, and ensure quality with uniform
responses when you reply to email, SMS, and chat contacts.

Creating templates
To create a template
 1. In Outlook, click the Folder List button below the left pane to view a list of Outlook folders.
 2. Expand the Public Folder list, right-click All Public Folders, and select New Folder.

The Create New Folder window opens.
 3. UnderName, typeMultimedia Contact Center templates.
 4. Click OK.

TheMultimedia Contact Center templates folder opens in the All Public Folders, folder.
 5. On the toolbar next toNew, click the down arrow.
 6. Select Post in This Folder.

The Untitled - Discussion window opens.
 7. AfterSubject, type the name of the queue for which you are creating the template (for example, type

Support).
 8. Type a response in the template.
 9. Click Post.

Using templates
To select a template and reply to a contact
 1. In Outlook, select your Agent Inbox and double-click an unanswered contact to select it.
 2. Click Reply.

The Reply window opens.
 3. Click Select Template.
 4. Click the Folder List button below the left pane to view a list of Outlook folders.
 5. Expand the Public Folder list, click All Public Folders, and click Multimedia Contact Center

templates.
 6. UnderMultimedia Contact Center templates, double-click a template to select it.

The template information opens in the body of your message.
 7. Type any additional information required.
 8. Click Send.
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Replying to emails/SMS messages
To reply to an email/SMS message
 1. In Outlook, double-click an email/SMS message in your Agent Inbox to open it.
 2. Click Reply.

The Reply window opens.
 3. Type a response and/or double-click a response template to insert the content into the body of the

email/SMS message.
 4. Click Send.

Replying to chats
To reply to a chat
 1. In Outlook, double-click a chat request in your Agent Inbox to open it.
 2. Click Reply.

See Figure 21 - 6.
 3. Type a response and/or double-click a response template to insert the content into the body of the email.

See "Creating and usingMultimedia Contact Center templates" on page 721.
 4. Click Send.

Figure 21 - 6 Chat reply

To chat with multiple people
 1. In Outlook, while you have a chat open in the chat window, click a second chat to open it.
 2. Click the chat tabs to switch between the chat sessions.

NOTE:You can click View longest waiting client to open the chat window of the client who has been
waiting the longest for a chat reply.
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Viewing faxes
When you open a fax contact in Outlook, it will open in theMultimedia Contact Center fax viewer. Within fax
viewer, you can control the following options:

l Zoom
Enables the user to zoom in and out of the selected page view.

l Thumbnail viewer
Enables the user to preview pages in the left pane of the fax viewer.

l Page selector
Enables the user to select which page of the fax will display in the right pane of the fax viewer.

l Thumbnail toggle
Enables the user to show/hide the thumbnail pane.

l Print
Enables the user to quickly print the fax document to the default printer.

l Magnifier
Enables the user to zoom in to a specific section of the fax, which can be useful for viewing small text
or smeared sections of the faxed document.

Replying to faxes
To reply to a contact
 1. In Outlook, double-click a fax in your Agent Inbox to open it.
 2. Click Reply.

The Reply window opens.
 3. Type a response.

You can reply by email, SMS, or fax.
 4. Click Send..

Tagging contacts with Account Codes
You configure Account Codes in YourSite Explorer. See "AddingMake Busy Reason Codes" on page 158.

To tag a contact with an Account Code
 1. In Outlook, double-click a contact in your Agent Inbox to open it.
 2. Click Reply.

The Reply window opens.
 3. Click Account Codes.
 4. Select the check box of the Account Code to be applied.
 5. Click Submit.



Contact Center Solutions User Guide

- 724 -

Placing contacts on hold
If you cannot answer a contact immediately, you can place it on hold temporarily. You can still receive other
contacts while the initial contact is on hold. When you are ready to answer the contact, you select it, respond
to it, and send it as you would a new contact.

To hold a contact
 1. In Outlook, double-click a contact in your Agent Inbox to open it.
 2. Click Reply.

The Reply window opens.
 3. Click Hold.

The agent state icon changes to indicate the agent is holding the contact.
See Figure 21 - 7.

Figure 21 - 7 Hold

Transferring contacts
To transfer a contact to an agent
 1. In Outlook, double-click a contact in your Agent Inbox to open it.
 2. Click Reply.

The Reply window opens.
 3. Click Transfer.

TheMultimedia Contact Center transfer window opens.
 4. Select the check box of the Agent ID to which you are transferring the contact.
 5. Click Transfer.
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Setting No Reply Needed
To set No Reply Needed
 1. In Outlook, double-click a contact in your Agent Inbox to open it.
 2. Click Reply.

The Reply window opens.
 3. Click No Reply Needed.

TheMultimedia Contact Center Outlook Plug-in window opens.
 4. Click Yes.

Viewing client history
A client history record displays case numbers, ticket numbers, and transcript for a case. You can view client
history on the Client history tab of eachMultimedia Contact Center contact.

The Client history tab displays contact history in the following ways
l All correspondence associated with the current case
l The entire history of all contacts, from and to customers
l The history of a specific contact (you request by typing themessage ID of the contact)
l The transcript of the current message

Viewing current case history
To view all correspondence associated with the current case
 1. In Outlook, double-click a contact in your Agent Inbox.
 2. Click theClient history tab.
 3. Click Display current case.

The case and transcript numbers for the current case are highlighted.

Viewing entire contact history
To view the entire history of all contacts
 1. In Outlook, double-click a contact in your Agent Inbox.
 2. Click theClient history tab.
 3. Click Display entire history.

Viewing a specific contact history
To view a specific email, SMS, chat, or fax
 1. In Outlook, double-click a contact in your Agent Inbox.
 2. Click theClient history tab.
 3. Click Display specific email/SMS/chat/fax.
 4. Type themessage ID, proceeded by pf (for example, pf0000000029).
 5. Click OK.
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Chapter 22

Contact Center Management

Remote Servers

Collecting data with Remote Servers
Creating remote IVRRouting instances
Monitoring activity and viewing alarms
Viewing ACD/SMDRdata collection
Updating Remote Servers
Displaying enterprise-wide statistics
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Contact Center Management Remote Servers
A Remote Server enables you to perform many of the functions of the Enterprise Server without having to
install an additional Enterprise Server or upgrade your licensing. You can configure and administer Remote
Servers in YourSite Explorer.

Remote Servers enable you to
l Collect, stream, and buffer ACD/SMDR data to the Enterprise Server. This enables enterprise-wide

reporting while protecting data from loss if the link between the Enterprise and Remote Servers goes
down.

l Create a remote IVR Routing instance.This enables IVR Routing instances to continue to function if
they lose access to the primary database or site.

l Monitor prairieFyre services activity and collect data on alarms
l View the status of data collection on the Remote Server.
l Update Remote Servers automatically following the upgrade of the Enterprise Server.
l Display real-time performance statistics and text messages from the Remote Server on LED wall

signs.

For information on installing Remote Servers, see theContact Center Solutions Installation Guide. For
information on Remote Server hardware and software requirements, see theContact Center Solutions and
Call Accounting System Engineering Guide.

Collecting data with Remote Servers
Remote Servers enable you to collect and stream ACD/SMDR data frommedia servers, facilitating
enterprise-widemonitoring and reporting. A Remote Server’s ability to buffer data prevents data loss should
the link to Enterprise Server go down.

Remote Servers collect and stream ACD/SMDR data frommedia servers to the Enterprise Server over
TCP/IP. The Enterprise Server gathers, summarizes, and writes the data to a SQL database for monitoring
and reporting purposes.

Should the link to the Enterprise Server go down, Remote Servers will buffer ACD/SMDR data until
communication is restored and the data can be streamed. Note that if the link between the Enterprise Server
and a Remote Server goes down, themanagers and supervisors cannot view real-time data from the Remote
Server until the connection is restored.

NOTE:
l You require a Contact Center Network License to collect data using a Remote Server. For more

information, see theContact Center Solutions and Call Accounting System Engineering Guide.
l A single Remote Server can collect ACD/SMDR data from up to 65 voicemedia servers. If you are

attempting to collect data frommore than 65 PBXs with a single Remote Server, youmust contact
prairieFyre Technical Support at 613-599-0045 (North American customers) or your approvedMitel
vendor (for customers residing in Latin America, Europe, theMiddle East, Africa, and Asia pacific) for
guidance.
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Creating remote IVR Routing instances
Creating remote IVR Routing instances enables call flows to continue to operate if the connection to the
Enterprise Server goes down, minimizing call disruption.

For information on how to install IVR Routing on Remote Servers, see theContact Center Solutions
Installation Guide.

NOTE:If the connection from Remote Servers to the Enterprise Server goes down, loss of real-time
connectivity affects all call flow components that depend on data derived from real-time queue statistics
including queue condition activities, Updated Position in Queue (UPiQ)messages, and prompts based on
real-time statistics.

Monitoring activity and viewing alarms
The Remote Server canmonitor its performance and notify the Enterprise Server when server states surpass
configured alarm thresholds. You configure alarm thresholds and view alarms for Remote Servers in YourSite
Explorer. For more information on server-side alarms, see "Monitoring and alarming subsystem" on page 171.

Viewing ACD/SMDR data collection
Using Network Monitor in Contact Center Client on a Remote Server enables you to view the status of real-
time ACD/SMDR data collection from the Remote Server. You can also use Network Monitor to view alarms
that themedia server is reporting. For more information on using Network Monitor, see "Network Monitor" on
page 343.

Updating Remote Servers
Remote Servers will automatically update when the Enterprise Server is upgraded, if you have configured the
Enterprise Server accordingly. For more information, see "Configuring the Enterprise Server settings" on page
71.

Displaying enterprise-wide statistics
WallBoarder is an application that displays real-time performance statistics and text messages from the
Enterprise Server on one or more LED reader boards. You can runWallBoarder on Remote Servers to keep
agents and employees throughout your contact center aware of enterprise-wide statistics and key messages.
For more information, see "WallBoarder" on page 249.
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Chapter 23

CTI Developer Toolkit

CTI Developer Toolkit sample applications
Best practices for custom development
Common user scenarios and source code examples
Troubleshooting CTI Developer Toolkit issues
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CTI Developer Toolkit
NOTE:

l CTI Developer Toolkit is currently supported for use with the 3300 ICP only.
l If you require the calculations used to populate Contact Center Management and Call Accounting

reports to use in your custom application built with the CTI Developer Toolkit, a subset of these
calculations can be found in the Advanced Data Access Guide, which can be found at
ftp://www.prairiefyre.com/support/download-software/.

Mitel Computer Telephony Integration (CTI) Developer Toolkit is a programmable .NET C#Dynamic-link
library (DLL) that can be used in any .NET 4.0 application or website. The CTI Developer Toolkit completes
themigration fromMitel Agent Portal to Mitel Contact Center Screen Pop.

The CTI Developer Toolkit is offered in two forms: server side and client side license. The server side license
provides the ability to insert custom real-time IVR collected data to each incoming call. It also uses the
Contact Center Screen Pop infrastructure to deliver third-party data to agent desktops (using either the client
side license or Contact Center PhoneSet Manager). The client side license provides basic telephony
functions (answer, hang up, transfer, and hold), provides agent control (such as set/removeMake Busy) and
delivers caller information such as ANI, DNIS, Collected Digits, and call notes in real time as calls arrive. The
client side licensemay be used to display information in CRM, Microsoft Outlook, or custom applications.

If you want to route or screen pop on digits or other data sets collected from a third-party IVR, youmust
adhere to the following conditions:

l Youmust have a CTI Developer Toolkit Server license
l The third-party vendor must be aMitel MSA Development partner. As aMitel MSA Development

partner, they must have completed aMiTAI (API) integration that allows them to pass the collected
digits or other data set, along with a unique call ID provided by this API, enablingMitel's Contact Center
software to associate the collected digits to a particular call with unique call ID matching.

l If you want to route or screen pop on ANI or DNIS or on digits collected within theMitel IVR, the above
are not required.

For installation information and procedures, see theContact Center Management Installation Guide.

NOTE:Once you have installed the CTI Developer Toolkit, typically to <installation_drive>:\Program
Files\prairieFyre Software Inc\CTI Developer Toolkit, you can access the DLLs required to create customized
applications in the CTI Developer Toolkit\Redist folder. Youmust include the entire Redist folder with your
final compiled custom application or it will not function properly.

The CTI Developer Toolkit includes a number of sample applications, including source code, that can be used
to test CTI Developer Toolkit functionality. For a complete overview of the sample applications included, see
"CTI Developer Toolkit sample applications" on page 735.
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The CTI Developer Toolkit is currently available with the following functionality:
l Connect and disconnect from the Contact Center Management Enterprise Server with user

authentication
l Retrieve devices from the Contact Center Management configuration database, based on all

l All agent devices for the user currently logged on to the system
l All agent devices associated with employees
l All extensions
l All queues

l Set real-timemonitors on agents, extensions, and queues to receive notification when
l A call is received (including call detail information)
l A device state changes (for example, idle, ACD, and hold)

l Set phonemonitors on agents and extensions to receive notification when
l A call is received (including call detail notification)
l A call is made
l A call is cleared
l A call is transferred
l A call is conferenced
l A call is established
l A call fails

l Control a device (for example, set/remove DoNot Disturb or Make Busy)
l Make calls from agent or extension devices
l Place calls on hold
l Retrieve calls that are on hold
l Remove calls from queues
l Redirect calls from queues to agents/extensions
l Transfer or conference calls between agent and extension devices
l Clear calls for agent and extension devices
l Add call detail information from third-party IVRs and dialers. This information is available to client

applications in the Call Received event

Table 23 - 1 lists themajor areas of functionality exposed with each version of the CTI Developer Toolkit. The
version specified indicates themost recent version, including any service packs available to customers.
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Table 23 - 1 Supported functionality by version

Functional Area Version
5.4

Version
5.5

Version
5.6

Version
5.7

Version
5.8

Version
6.0.2

Application events

l Connection state
changes

x x x x x x

l Configuration
loaded

x x x x

Device Information

l Get all devices x x x x x x

l Get all extension x x x x x x

l Get all agents x x x x x x

l Get all queues x x x x

l Get agents by
login

x x x x x x

l Get agents for all
employees

x x x x x x

Device events1

l Device state
changed

x x x x x x

Voice events2

l Call info received x x x x x x

l Call delivered x x x x x

l Call received x x x x x

l Call cleared x x x x x

l Call transferred x x x x

l Call established x x x x

l Call failed x x x x

l Call diverted x x x
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Functional Area Version
5.4

Version
5.5

Version
5.6

Version
5.7

Version
5.8

Version
6.0.2

l Call originated x x x

l Call retrieved x x x

Extension events

l Extension state
changed

x x x x

Agent events

l Agent state
changed

x x x x

Queue events

l Queue Now
statistics

x x x x

l Queue totals
statistics

x x x x

l Interactive
Visual Queue
delta

x x x x

l Interactive
Visual Queue
snapshots

x x x x

Voice control3

l Make call x x x x x x

l Clear call x x x x x x

l Answer call x x x x x

l Hold call x x x x x

l Retrieve held call x x x x x

l Conference call x x x x x

l Transfer call x x x x x

l Make
consultation call

x x x
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Functional Area Version
5.4

Version
5.5

Version
5.6

Version
5.7

Version
5.8

Version
6.0.2

l Transfer
consultation call

x x x

l Cancel
consultation call

x x x

l Trade call x

Agent control

l Login x4 x x x x x 5

l Logout x x x x x x 5

l Set Make Busy x x x x x x

l RemoveMake
Busy

x x x x x x

l Set Do Not
Disturb

x x x x x x

l Remove DoNot
Disturb

x x x x x x

l Cancel work
timer

x x x x x x

l Cancel reseize
timer

x 6

l Conference call x x x x x

Queue control

l Redirect call x x x x

l Remove call x x x x

IVR integration

l Add call detail7 x x x x x

1 Device events are supported byall device types.
2 Voice events are supported byextension and agent devices
3 Voice control is supported byextension and agent devices.
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4Only hot deskagent logins are supported in Version 5.4. Both hot desking and traditional agent logins are supported with Version 5.5
SP1 or greater.
5 SupportsExternal hot deskagent and External hot deskuser functionality.
6 The Cancel reseize timer agent control function requiresExternal hot deskagent functionality.
7 The AddCallDetailmethod requiresa CTI Developer Toolkit server license.

NOTE: The CTI Developer Toolkit may also be referred to as the prairieFyre.CallControl.Toolkit namespace
throughout this chapter and in the CHM help file documentation, as the CHM help file included with the CTI
Developer Toolkit is sourced from the source code, which refers to the namespace by this name.

Table 23 - 2 lists and describes the top level classes available with the CTI Developer Toolkit.

Table 23 - 2 Primary object classes

Class Description

DeviceManager This class contains functionality to manage the connection to the Enterprise Server
and provides access to configured agents, extensions, and queues.

Device This abstract class includes the core properties for all device types. Objects of this
class may not be directly instantiated.

Voice This class is derived from the Device class and serves as the base class for the
agent and extension classes. It includes properties and functionality that is specific
to devices with voice characteristics.

Agent This class is derived from the Voice class. It represents both traditional ACD and
hot desking agents. Specialized functionality handled in this class includes agent
control operations, such as agent login and set/removeMake Busy.

Extension This class is derived from the Voice class. It represents configured extensions.

Queue This class is derived from the Device class. It represents configured queues. It
includes properties and functionality that is specific to the queue device. Specialized
functionality handled in this class includes set/remove DoNot Disturb, redirect call,
and remove call.

CTI Developer Toolkit sample applications
There are currently four sample applications, including source code, that are included with the CTI Developer
Toolkit.

Device Monitor
The DeviceMonitor sample application provides a graphical user interface that enables developers to connect
to the Contact Center Solutions Enterprise Server, retrieve a list of devices, perform agent control activities
on the retrieved devices (for example, login/logout, set/removeMake Busy, etc.), perform call control
activities (for example, make call, answer call, clear call, etc.), and retrieve call event notifications. (See
Figure 23 - 1.)
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Figure 23 - 1 Device Monitor sample application

To use the CTI Developer Toolkit DeviceMonitor sample application
 1. InWindows, navigate to theCTI Developer Toolkit and openDevice Monitor.
 2. Click File=>Connect.
 3. Type the IP address of the Enterprise Server, user name, and password and click OK.
 4. Click Devices and select one of the following options:

l Retrieve agents for current login
l Retrieve agents for all employees
l Retrieve all agents
l Retrieve all extensions
l Retrieve all queues
l Retrieve all devices

 5. Once the devices you selected have loaded, you perform actions on the selected device(s) by clicking
Actions and selecting an available action or by right-clicking and selecting an available action from
the list:
l Set monitor=>Phone, Real time, All
l Removemonitor=>Phone, Real time, All
l Login
l Logout
l Set Make Busy
l RemoveMake Busy
l Set DND
l Remove DND
l Cancel work timer
l Make call
l Answer call
l Hold call
l Retrieve call
l Transfer call
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l Conference call
l Clear call
l Add call notes
l Make consultation call
l Transfer consultation call
l Cancel consultation call
l Trade call

Queue Monitor
TheQueueMonitor sample application displays the functionality and support for queue device types included
with the CTI Developer Toolkit. TheQueueMonitor application is similar to the optional Interactive Visual
Queuemonitor that is housed in Contact Center Client. It enables developers to connect to the Contact
Center Solutions Enterprise Server, load a set of queues, and view real-time call activity (calls entering and
exiting queues) and queue statistics (for example, calls waiting, number of agents available, longest waiting,
etc.). (See Figure 23 - 2.)

Figure 23 - 2 Queue monitor sample application

To use the CTI Developer Toolkit QueueMonitor sample application
 1. InWindows, navigate to theCTI Developer Toolkit and openQueue Monitor.
 2. Click File=>Connect.
 3. Type the IP address of the Enterprise Server, user name, and password and click OK.
 4. Click Actions.
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 5. Select one or more queues to open.
 6. Click OK.

If you selectedmultiple queues, you can toggle between them using the tabs at the bottom of the queue
monitor.

 7. Once the queues you selected have loaded, you perform actions on the selected device(s) by clicking
Actions and selecting an available action or by right-clicking and selecting an available action from the
list:
l Open queue
l Close queue
l Set DND
l Remove DND
l Redirect call
l Remove call

Console Call Monitor
The ConsoleMonitor sample application displays call received information for either single or multiple agents
or extensions in a simple console application window. It is intended to be a very brief example, with little error
handling, that can be used to demonstrate the basics of coding screen pop displays.

To use the CTI Developer Toolkit ConsoleCallMonitor sample application
 1. InWindows, open the command prompt window.
 2. Type cd "<installation_drive>:\Program Files\prairieFyre Software Inc\CTI Developer

Toolkit\Samples\ConsoleCallMonitor\bin" and click Enter.
 3. TypeConsoleCallMonitor.exe Device Number/Telephone System IP Address/Type and click

Enter.
The ConsoleCallMonitor application takes multiple parameters in the following form, Device
Number/Telephone System IP Address/Type. For example, 2000/10.1.1.1/Agent
1800/10.1.1.10/Extension would invoke agent 2000 on telephone system 10.1.1.1 and extension 1800
on telephone system 10.1.1.10.

Console Queue Monitor
The ConsoleQueueMonitor sample application displays information on calls entering/exiting queues and
queue statistics in a simple console application window. Similar to the Console Call Monitor application, it
represents aminimal set of code required to build a real-time queuemonitoring application.

To use the CTI Developer Toolkit Console QueueMonitor sample application
 1. InWindows, open the command prompt window.
 2. Type cd "<installation_drive>:\Program Files\prairieFyre Software Inc\CTI Developer

Toolkit\Samples\ConsoleQueueMonitor\bin" and click Enter.
 3. TypeConsoleQueueMonitor.exe Queue/Telephone System IP Address and click Enter.

The ConsoleQueueMonitor application takes multiple parameters, in the following form:
Queue/Telephone System IP Address. For example: P200/10.1.1.1 P180/10.1.1.10 would invoke
monitoring calls on two queues, queue P200 on telephone system 10.1.1.1 and queue P180 on
telephone system 10.1.1.10.
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Best practices for custom development
The following best practices must always be followed when developing custom developments to work in
conjunction with Contact Center Solutions software.

l Before you begin development
l Verify that the CTI Developer Toolkit and Contact Center Solutions software are the same version

and that you are properly licensed for all desired functionality
l Verify that you have access to the Contact Center Management Enterprise Server
l Verify that the Contact Center Solutions Enterprise Server has been properly set up and configured

with the extensions, agents, and queues that you will be using with your custom application
l Verify that the telephone system(s) in your enterprise has been properly set up and configured with

the extensions, agents, and queues that you will be using with your custom application
l Verify that all pre-installation and post installation steps have been completed. See theContact

Center Management Installation Guide.
l Confirm the telephone system conforms to the guidelines stated in the Golden Rules document. In

particular, aspects of the CTI Developer Toolkit rely on the ability to set MiTAI monitors on devices.
As such, the "HCI Options" must be enabled for the Class of Service on all monitored devices. See
http://www.prairiefyre.com/wp-content/rscs/documentation/Golden%20Rules.xls

l Verify you haveMicrosoft .NET Framework Version 4.0 or greater installed on your workstation
l Verify you have an IDE installed on your workstation, either Visual Studio 2005/2008 or

SharpDevelop
l When developing custom applications and integrations

l Verify the what you are attempting to build is possible by attempting the functions from an alternate
client application, such as Contact Center Client, the DeviceMonitor sample application, or MiTAI
Browser

l Routinely check the log files of all related services, specifically the Enterprise Server, Collector, and
MiTAI Proxy Server to ensure there are no unusual or unexpected warnings or errors

l Routinely check the log files of alternative client applications for any unusual or unexpected
warnings or errors (as listed in the previous bullet)

The following best practices must always be followed when developing custom connectors to third-party
IVRs.

l Third-party IVR ports and Intelligent Queue ports must all be programmed in YourSite Explorer as an
extension type=>Messaging Port or RAD Port. When configuring the extension as a port type, the
disable real-timemonitoring option will not be configurable.

l In addition to whatever custom data your third-party IVR is sending, it must also send the same data
that Intelligent Queue does (using the same naming conventions). These are PFANI,
PFCALLERNAME, and PFDNIS. This will ensure that the existingMiTAI record linking logic within the
Contact Center Management Enterprise Server gets the correct information, which is typically at the
first controller/port

Common user scenarios and source code examples
This section details the following common user scenarios for developing custom integrations and applications
using the CTI Developer Toolkit

l Click to dial
l Call received notification
l Add call detail (using a third-party IVR)
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Click to dial
NOTE: This code sample is not included in the sample project that is included with the CTI Developer Toolkit.

The following C# code fragment provides sample source code that can be used to build a console application
with click-to-dial functionality.

static void Main()
{
DeviceManager dm = DeviceManager.Instance;
string pbxIpAddress = "10.1.1.10";
string server = "the-CCM-server-IP-address-here";
string username = "your-username-here";
string password = "your-password-here";
Voice extension;

if (!dm.Connect(server, 5024, username, password))
{
Console.WriteLine("Uable to connect to server");
return;
}

extension = dm.GetDevice("1100", pbxIpAddress, DeviceType.Extension) as Voice;

if (extension == null)
{
Console.WriteLine("Unable to retrieve extension device");
return;
}

if (!extension.SetMonitor())
{
Console.WriteLine("Unable tomonitor extension");
return;
}

extension.MakeCall("16135990045");

dm.ReleaseAllDevices();
dm.Disconnect();
Console.WriteLine("Exit application");
}

This source code will connect to the specific Enterprise Server using the supplied username and password. It
then initiates a call from extension 1100 on the telephone system with IP address 10.1.1.10 to the phone
number 16135990045.

Call received notification
The following C# code fragment shows a condensed version of the source code provided with the
ConsoleCallMonitor sample application that is shipped with the CTI Developer Toolkit.
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static void Main()
{
DeviceManager dm = DeviceManager.Instance;
string pbxIpAddress = "10.1.1.10";
string server = "the-CCM-server-IP-address-here";
string username = "your-username-here";
string password = "your-password-here";
Voice extension;

if (!dm.Connect(server, 5024, username, password))
{
Console.WriteLine("Uable to connect to server");
return;
}

extension = dm.GetDevice("1100", pbxIpAddress, DeviceType.Extension) as Voice;

if (extension == null)
{
Console.WriteLine("Unable to retrieve extension device");
return;
}

if (!extension.SetMonitor())
{
Console.WriteLine("Unable tomonitor extension");
return;
}

device.CallInfoReceived += CallInfoReceivedHandler;

Console.WriteLine("Listening for calls on extension 1100");
Console.WriteLine("Press any key to end application.");
while (!Console.KeyAvailable) ;

dm.ReleaseAllDevices();
dm.Disconnect();
Console.WriteLine("Exit application");
}

static void CallInfoReceivedHandler(object sender, CallInfoReceivedEventArgs e)
{
Console.WriteLine("-----------------------------------------------");
Console.WriteLine("Call Info Received:");
Console.WriteLine(" Caller Name : " + e.Info.CallerName);
Console.WriteLine(" Caller Number : " + e.Info.CallerNumber);
Console.WriteLine(" DNIS : " + e.Info.DNIS);
Console.WriteLine(" Collected Digits : " + e.Info.CollectedDigits);
}
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Add call detail (using a third-party IVR)
The following C# code fragment shows a condensed version of using the AddCallDetail method to toolkit
users can invoke to add custom key/value pairs into call information.

In summary, this code fragment does the following:
l Device_CallReceived is an event handler that is invoked whenever amonitored IVR extension/port

receives a call. This is needed to acquire theMiTAI Call ID which is used to link these extra information
records (--w records in ACD data files) to other call records

l When this event handler is invoked, it makes three sequential calls to the AddCallDetail method,
adding call values for the following keys: PFANI, PFCALLERNAME, and PFDNIS

l The keys used above are the ones that the default screen pop display recognizes but developers can
easily make up their own key names as well, provided they have toolkit code on the client side to pull
the custom information from the CallInfoReceivedEvent notifications

public void Device_CallReceived(object sender, CallReceivedEventArgs e)
{
Device device = sender as Device;

DeviceManager.Instance.AddCallDetail(
e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID,
"PFANI", "6135990045");

DeviceManager.Instance.AddCallDetail(
e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID,
"PFCALLERNAME", "John Smith");

DeviceManager.Instance.AddCallDetail(
e.CallingDevice.CallReferenceID, device.PBXIPAddress, device.DeviceID,
"PFDNIS", "8001");
}

Troubleshooting CTI Developer Toolkit issues
Diagnosing any issues experienced while using the CTI Developer Toolkit requires a high level of familiarity
with Contact Center Solutions and Call Accounting applications and CTI Developer Toolkit functionality. This
section details several troubleshooting tips and tricks when encountering issues with CTI Developer Toolkit
functionality.

The CTI Developer Toolkit and any custom applications created using it rely heavily on the proper
configuration and operation of the Contact Center Solutions Enterprise Server. Ensuring that the server is
operating correctly is the first diagnostic step that should be taken when troubleshooting CTI Developer
Toolkit issues. This includes:

l Verifying that the CTI Developer Toolkit and Contact Center Solutions software are the same version
and that you are properly licensed for the desired functionality

l Verifying that all pre-installation and post installation steps have been completed. See theContact
Center Management Installation Guide

l Checking the log files of all related services, specifically the Enterprise Server, Collector, andMiTAI
Proxy Server to ensure there are no unusual or unexpected warnings or errors



Troubleshooting CTI Developer Toolkit issues

- 743 -

l Attempting the same operation using an alternate client application. This can be any of the following,
depending on the underlying issue:

l Contact Center Client
l DeviceMonitor sample application
l MiTAI Browser

l Checking the log files of alternative client applications for any unusual or unexpected warnings or errors
(as listed in the previous step)

l Confirming the telephone system conforms to the guidelines stated in the Golden Rules document. In
particular, aspects of the CTI Developer Toolkit rely on the ability to set MiTAI monitors on devices. As
such, the "HCI Options" must be enabled for the Class of Service on all monitored devices. See
http://www.prairiefyre.com/wp-content/rscs/documentation/Golden%20Rules.xls

Troubleshooting specific issues
This section describes some specific problems that may be encountered when working with the CTI
Developer Toolkit and provides any recommended steps for diagnosing issues and potential solutions.

Retrieve All commands does not display any devices
If any of theRetrieve All commands in the DeviceMonitor application return an empty list of devices, there
may be a configuration problem with the IPAddress values stored in theCCMData database table named
tblEnterpriseConfig_Node.

To troubleshoot this issue, run the following SQL query and pay particular attention to values in the [IP
Address] column. This query simulates the query used by the CTI Developer Toolkit and will return a list of
agents and extensions for all voicemedia servers.

SELECT node.Name AS [Node],
node.IPAddress AS [IP Address],
'Agent' AS [Type],
device.FirstName AS [First Name],
device.LastName AS [Last Name],
device.Reporting AS [Reporting Number]
FROM tblConfig_Agent device INNER JOIN tblEnterpriseConfig_Node node
ON device.FKNode = node.Pkey INNER JOIN tblLookup_NodeType NodeType
ON node.FKNodeType = NodeType.Pkey
WHERE FKNodeFamily = 1
UNION
SELECT
node.Name AS [Node],
node.IPAddress AS [IP Address],
'Extension' AS [Type],
'' AS [First Name], -- No first name on extensions
'' AS [Last Name], -- No last name on extensions
device.Reporting AS [Reporting Number]
FROM tblConfig_Extension device INNER JOIN tblEnterpriseConfig_Node node
ON device.FKNode = node.Pkey INNER JOIN tblLookup_NodeType NodeType
ON node.FKNodeType = NodeType.Pkey
WHERE FKNodeFamily = 1
ORDER BY [Node], [Type]
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The [IP Address] values in the query results should contain the IP address of the telephone system that is
associated with the voicemedia server. If this value is incorrect or blank, use YourSite Explorer to set the IP
address to the correct value.

GetDevice method fails or returns null unexpectedly
If a custom applications calls theGetDevicemethod and returns null even though the device is valid and
programmed in Contact Center Management, theremay be a timing issue with the Connect operation. When a
custom application calls theConnectmethod in the CTI Developer Toolkit, the operation returns as soon as
an authenticated connection has been established with the Enterprise Server. However, theremay still be
some basic configuration loading occurring in the background, whichmust complete before calls toGetDevice
can be successful.

An event namedConfigurationLoaded is provided in the CTI Developer Toolkit, which is used to notify custom
applications that background configuration loading has completed. In previous versions, the DeviceMonitor
sample application used a workaroundmethod of issuing aSleepmethod call on the active thread to give
background configuration loading time to complete.

Agent control actions succeed while call control actions fail
In this scenario, agent control actions (for example, login, logout, and set/removeMake Busy) succeed, while
call control actions (for example, make call, answer call, and clear call) fail. The key difference between these
two types of operations is that call control actions require aMiTAI monitor set on the device and agent control
actions do not. Your investigation should start with an analysis of MiTAI related configuration, including:

l Verifying that theMitaiEnabled flag set properly for devices in the database
l Checking telephone system (for example, HCI Options enabled)
l Confirming the telephone system version is supported

Unable to set monitor on agent device
In some cases, using the DeviceMonitor to issue a Set Monitor operation on an agent will fail. If you have the
Errors view open in the application, it displays aMiTAI error, indicating "Operation failed: MessageTag[8]
ReturnCode [SXERR_FEATURE_NOT_ALLOWED]"
In this case, you should verify that the agent device is properly configured on the telephone system, including
HCI Options enabled for the associated Class Of Service. If the problem persists, check to see if the CTI
Developer Toolkit is Version 5.5 or earlier and if the agent is a traditional or hot desking agent. There was a
known issue settingmonitors on traditional ACD agents using the CTI Developer Toolkit that was corrected in
5.5 SP1. For earlier versions, one workaround is to set themonitor on the extension the agent logs in to.

Web service errors occurring in log files
If you encounterWeb service error messages in log files and an application built with the CTI Developer
Toolkit is experiencing errors, check to ensure that theMicrosoft.Web.Services3.dll file is present under the
Windows system directory or in the custom application directory.
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"Softphone proxy did not respond after 30 seconds" error
If you encounter this message and the Contact Center Solutions software is Version 5.5 SP2 or earlier, there
is a known licensing issue where theMiTAI Proxy Server will fail to send clients messages unless there is at
least one Contact Center Softphone or Contact Center PhoneSet Manager license in your enterprise. This
issue was corrected in version 5.5 SP3.

To work around this problem, contact prairieFyre Software technical support at 613-599-0045 (North American
customers) or your approvedMitel vendor (for customers residing in Latin America, Europe, theMiddle East,
Africa, and Asia Pacific).and have them create new license files.
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Chapter 24

Salesforce.com Connector

Using the Contact Center Salesforce.com Connector
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Salesforce.com Connector
Salesforce.com Connector is an optional client application that works in conjunction with Contact Center
Management and/or Call Accounting and requires an account with Salesforce.com (Enterprise and
Professional editions of Salesforce.com), and, optionally, Intelligent Queue or IVR Routing (for Collect Caller
Entered Digits only).

NOTE:
l Salesforce.com Connector is currently supported for use with the 3300 ICP only.
l Whether Salesforce.com is running on the cloud or on a server within your organization, agents must

have the Contact Center Salesforce.com Connector installed and running on their client computers for
Salesforce.com Connector to function properly.

l The Contact Center Salesforce.com Connector refers to the Contact Center Softphone application as it
appears in Salesforce.com.

l If you use Internet Explorer, youmust run Internet Explorer 8.0 or Internet Explorer 9.0 for
Salesforce.com Connector to function properly.

l If you use Internet Explorer 8.0 or 9.0, ensure you have enabled the "Display mixed content" option in
Internet Explorer's local intranet security settings before logging into Salesforce.com.

Salesforce.com Connector enhances the functionality of Salesforce by embedding your Mitel phone directly
into the Salesforce user interface. This improves productivity by providing fast and easy access to accounts,
contacts, cases, and other Salesforce objects directly related to incoming calls. Using Salesforce.com
Connector enables your contact center agents to perform their job functions through a single user interface.

Salesforce.com Connector is compatible with the Salesforce.comMicrosoft Outlook connector. Users can
synchronize their Salesforce.com contacts, tasks, and calendar events, associate Outlook email messages,
andmap custom fields in Salesforce.com to fields in Outlook.

Salesforce.com Connector manages interactions between the Contact Center Management server and the
hosted Salesforce.com server through the Salesforce user interface. Salesforce.com Connector offers a wide
variety of enhancements and capabilities to agents, including

l Unified login
Salesforce automatically retrieves agent IDs and extensions to enable users to log in to Contact Center
Management directly from Salesforce.com.

l Hot desking support
ACD hot desking agents and non-ACD general business hot desking extensions are supported for use
with the Salesforce.com Connector.

l Click to dial
Agents can save time and avoidmisdialed calls by using click to dial to contact customers, co-workers,
or extensions.

l Screen pop
When an external call arrives, the relevant Salesforce customer record displays on the agent’s screen.
If the call is subsequently transferred or joins a conference, the record displays on the screen of the
agent receiving the transferred call or taking part in the conference. Immediate access to customer
information increases agent productivity and improves customer satisfaction. Screen pop can be
configured to work with Automatic Number Identification (ANI), Dialed Number Identification Service
(DNIS), or Collect Caller Entered Digits (requires Intelligent Queue with the Collect Caller Entered
Digits option or IVR Routing Premium ports).
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Pertinent customer information also displays in the Salesforce user interface, for example, Caller
Name, Collect Caller Entered digits, ANI, DNIS, and any search results you configure in the Salesforce
soft phone layout. For information on configuring soft phone layouts in Salesforce.com, see theContact
Center Management Installation Guide.
NOTE: If Salesforce is not providing Collect Caller Entered Digits in a screen pop, ensure you disable
caching if you use Internet Explorer.

l Call control
Agents can save time by having all their typical desk phone functions embedded and available directly
from the Salesforce user interface. With complete customer information on the screen, agents can
quickly access alternate numbers for customers.

l Call logging capabilities
Salesforce creates call tasks when agents make or receive internal or external calls. Use call tasks to
log caller information including notes, phone numbers, and the date and time of a call. This assists
compliance with your business processes by increasing consistency and providing improved reporting.

l Make Busy codes and Wrap-up codes (ACD agents only)
Agents can place themselves in and remove themselves fromMake Busy to show their availability to
receive ACD calls. After agents indicate they are not ready for calls, they can select from a variety of
Make Busy codes that describe their activity. After finishing an ACD call, enter the work timer state
where they can select from a list of Wrap-up codes (also known as Call Classification codes) and insert
comments about the call. Supervisors can use this information to track call activity andmeasure agent
performance.
NOTE: To enable agents to complete their call logs, do not select the “Cancel work timer once code is
entered” check box in the Queues pane in YourSite Explorer. This enables an agent to stay in the work
timer state and enter call log information until they click the Done button in their Contact Center
Salesforce.com Connector. See "Configuring queues" on page 445.

Using the Contact Center Salesforce.com Connector
This section explains how to log into your Contact Center Salesforce.com Connector and discusses
operations you can perform once logged in.

Logging into your Contact Center Salesforce.com Connector
The Contact Center Salesforce.com Connector refers to the Contact Center Softphone application as it
appears in Salesforce.com. To integrate with Salesforce.com, youmust first open Contact Center Client and
load the Contact Center Salesforce.com Connector toolbar. This sets theMiTAI monitor on the extension and
indicates to the telephone system that the extension is ready tomake and receive calls. Following this action,
you canminimize Contact Center Client and log in, log out, and perform all call control activities from within
the Salesforce.com client.
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NOTE:
l The Salesforce.com Connector must be running before logging into the Salesforce.com website.

Before logging into the Salesforce.com website, verify the Salesforce.com Connector is running in the
system tray on your computer (next to the clock and volume controls). If the icon is displayed, the
Salesforce.com Connector is open.

l If you are using a desk phone, you do not need to open Contact Center Client before loading the
Contact Center Salesforce.com Connector toolbar.

l Your login for Salesforce.com is different than the login used for the Contact Center Salesforce.com
Connector.

l The Contact Center Salesforce.com Connector is located in the left pane of the Salesforce user
interface and appears only when you are assigned to a call center in Salesforce.

l If an employee is unlicensed, they will not be able to log in to the Contact Center Salesforce.com
 Connector through Salesforce. For more information on employee licensing, see theContact Center
Solutions and Call Accounting System Engineering Guide.

To log into your Contact Center Salesforce.com Connector
 1. Start Internet Explorer and type http://login.salesforce.com/.
 2. In the Login pane, type your Salesforce.com User Name andPassword, and click Login.

See Figure 24 - 1.

Figure 24 - 1 Salesforce.com login pane

After you log in, the Contact Center Salesforce.com Connector will initialize in the top-left section of the
Salesforce.com webpage. (See Figure 24 - 2.)
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 3. If you receive amessage asking if you want to see the page content that was delivered securely, click
No.
NOTE: Clicking Yes or closing the window will disable the Contact Center Salesforce.com Connector.

Figure 24 - 2 The initializing pane

 4. Type your call centerUsername, Password, Agent ID, andExtension.
NOTE: If you do not have an agent ID associated with your employee ID, you will not have ACD
functionality. However, you can continue to log in and use your desk phone or soft phone from within
Salesforce for non-ACD calls.

 5. To set Salesforce to remember your Contact Center Salesforce.com Connector login credentials every
time you log into Salesforce, enable theRemember me check box.
See Figure 24 - 3.

Figure 24 - 3 The login pane
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 6. Click Log In.
The Contact Center Salesforce.com Connector will display "Logged In" when you are logged in as an
ACD agent.
See Figure 24 - 4.

Figure 24 - 4 The "Logged In" status display

If no agent ID was provided with the login credentials and you are not logged in as an ACD agent, the
Contact Center Salesforce.com Connector functions as a soft phone and displays "Ready for Calls".
(See Figure 24 - 5.)

Figure 24 - 5 The "Ready for Calls" status display

To automatically log into your call center when logging into Salesforce
 1. In Salesforce, click your username and select Setup.
 2. UnderPersonal Setup, select Call Center Settings =>My SoftPhone Settings.
 3. Enable theAutomatically log into your call center when logging into salesforce.com checkbox.
 4. Click Save.

Salesforce.com Connector functionality
NOTE:

l If using a true soft phone, youmust first open Contact Center Client, click View => Soft phone and
configure soft phone options. Youmust keep Contact Center Client running in the background as you
use Salesforce. If you are using a desk phone there is no need to open Contact Center Client.

l Caller ANI/DNIS information is not included when you transfer a call between telephone systems.
When you transfer a call between telephone systems, the ANI/DNIS information that displays in the
screen pop for the receiving agent is that of the transferring agent, not the caller.
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You can use Salesforce.com Connector to perform the following functions:

l Dial phone numbers
Dial a phone number by clicking Line 1, entering the number into the Contact Center Salesforce.com
Connector and clicking Dial. (See Figure 24 - 6.)

Figure 24 - 6 Dialpad

Alternatively, dial by clicking the icon next to a phone number associated with a contact, lead, activity,
account, or any other phone field you have created. (See Figure 24 - 7.) ACD agents can dial by clicking
on available employee or extension links. You can also dial numbers using the dial pad on your desk
phone.

Figure 24 - 7 The icon to dial a contact, lead, activity, account, or other phone field
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l Answer phone calls
Answer a phone call by clicking Answer or using your desk phone. If the caller's number is in your
Salesforce database, their customer information page appears. Salesforce.com Connector supports
one incoming line per user. (See Figure 24 - 8.)

Figure 24 - 8 Answer

l Place callers on hold
Place callers on hold by clicking Hold. Retrieve the call by clicking Retrieve from Hold. (See Figure 24 -
9.)

Figure 24 - 9 Retreive From Hold
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l Perform one-step transfers (cold transfers)
A one-step transfer (cold transfer) is when you transfer a caller without speaking to the third party
destination first. Transfer a call directly to another number without speaking to the third party by clicking
Transfer, entering the third party’s phone number or extension, and clicking One Step Transfer to
complete the transfer. (See Figure 24 - 10.)

Figure 24 - 10 One-Step Transfer

l Perform initiated transfers (warm transfer)
An initiated transfer (or warm transfer) is when you place a caller on hold and speak to the third party
destination before transferring the call. To transfer a call directly to another number and speak with the
third party before transferring the call, click Initiate Transfer. Speak with the third party and once the call
is ready to be transferred click Complete Transfer to connect the caller and remove yourself from the
call.
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l Initiate conference calls
Initiate a conference call by clicking the Conference button while on a call, entering the phone number
to join to the conference and clicking Initiate Conference. Your caller is placed on hold while you dial the
third party to be added to the call. (See Figure 24 - 11.)

Figure 24 - 11 Initiate Conference
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Once you have connected to the third party number, click Complete Conference to place all three
parties on the same line. (See Figure 24 - 12.)

Figure 24 - 12 Complete Conference

l Ending calls
End a call by clicking End Call. (See Figure 24 - 13.)

Figure 24 - 13 End Call
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l Set make busy codes (ACD agents only)
To set aMake Busy code, click on the arrow in the agent state bar and select Not Ready for Calls. (See
Figure 24 - 14.) Make Busy codes are entered in YourSite Explorer and should bemaintained by your
YSE Administrator.

Figure 24 - 14 Not Ready for Calls

Select from the list of available Make Busy codes. (See Figure 24 - 15.)

Figure 24 - 15 Make Busy codes
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You will now appear as unavailable for calls. (See Figure 24 - 16.)

Figure 24 - 16 Agent Status

Remove theMake Busy code andmake yourself available for calls again by clicking Ready for Calls in
the agent state bar. (See Figure 24 - 17.)

Figure 24 - 17 Ready for Calls
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l Create new leads while on calls
Once you have answered an internal/external call, the Contact Center Salesforce.com Connector will
display a New Lead button. Click the New Lead button to open a new lead and auto-populate the Lead
phone number field with the caller’s phone number. (See Figure 24 - 18.)

Figure 24 - 18 New Lead
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l Relate Salesforce records to a call activity task
You can associate up to two records to a call. From the Related To list in the call log area, select the
Account, Opportunity, or Case to which you will associate the call. To associate a Contact or Lead to
the call, select it from the Name drop-down list in the call log area. (See Figure 24 - 19.)

Figure 24 - 19 Call Log and Related To

NOTE: The Related To record cannot be selected when Name is set to a Lead.

l Search on outbound calls
Search results for outbound calls display in the Contact Center Salesforce.com Connector user
interface, but do not generate screen pops.
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l Tag calls with account codes
Click on Show Account Codes to display a list of available Account Codes, then click on the account
code link that you want to apply. (See Figure 24 - 20.)

Figure 24 - 20 Account Codes

l Set wrap-up codes (ACD agents only)
When an external ACD call ends, select an appropriateWrap-up code (also known as a Call
Classification code) from the Call Result list of the Current Call Log window.

l Attach comments to a call
Attach comments to a call by typing text into the Comments field. When the call ends, the comments
are automatically saved. (See Figure 24 - 21.)
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Figure 24 - 21 Attach comments to call

Call log information can be accessed from either theMy Calls Today section of the soft phone or by
scrolling to the Active History section of an object in Salesforce. (See Figure 24 - 22.)

Figure 24 - 22 Activity History
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l View recent call activity
Access recent call activities by clicking Last Call or My Calls Today. To edit one of the last call
activities created, click the Last Calls arrow in the Contact Center Salesforce.com Connector and enter
the new comments you would like to add before clicking the Save button. ClickingMy Calls Today will
take you to theMy Calls Today webpage where you can view all Call Activities that have been created
for the entire day. (See Figure 24 - 23.)

NOTE: If call duration is not accurately displayed inMy Calls Today, runWindows Update and install
themost recent updates on your work stations. For more information on runningWindows Update, see
theContact Center Management Installation Guide.

Figure 24 - 23 Call history

l Edit completed call logs
Call logs are automatically created for all external calls an agent makes or receives. Edit a call log by
clicking on the link to the call. (See Figure 24 - 24.)

Figure 24 - 24 Edit call logs
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l Search on outbound calls
Search results for outbound calls display in the Contact Center Salesforce.com Connector user
interface within Salesforce, but do not generate screen pops. Enter the phone number into the dial pad
and click Dial. The search will return results in the Contact Center Salesforce.com Connector interface.
You can click Account, Contact, etc. to view the details of the search result. (See Figure 24 - 25.)

Figure 24 - 25 Search on outbound calls display



- 765 -

Contact Center Solutions terms and definitions

Abandoned call
An abandoned call is a call that the caller ends before the call reaches an agent.

Account Code
Account Codes are classifiers that can be applied to call records and used to identify unique attributes about
the caller or call for individual departments, projects, or services to generate reports on them. As well, they
can be used by agents as classification codes for incoming calls. Account codes can be verified, non-verified,
fixed length, or forced.

See Classification Codes, Fixed Length Account Codes, Forced Account Codes, Non-Verified Account
Codes, Verified Account Codes.

ACD (Automatic Call Distribution)
ACD (Automatic Call Distribution) is a call distributionmechanism that distributes calls to a pool of available
agents, typically to the first available agent or the agent who has been idle the longest. ACD can also be
configured to distribute calls based on skills or preferred customers.

ACD (state)
ACD is an agent state applied to an agent while they are handling an ACD call.

ACD calls handled
SeeCalls Handled.

ACD calls interflowed
See Interflow.

ACD calls offered
SeeCalls offered.

ACD calls requeued
SeeCalls requeued.

ACD handling time
ACD handling time is a parameter for Contact Center Management that provides the sum of all evens from
answer to hang up of an ACD call.

Active Directory
Active Directory is a directory service created by Microsoft that is used for managing a domain. In Contact
Center Solutions, Active Directory is synchronized with YourSite Explorer to align Active Directory security
groups and users with Contact Center Solutions employees and employee groups within selected
organizational units.

Agent
An agent is a contact center employee configured on the telephony system to receive ACD calls with an agent
ID.

Contact Center Solutions terms and definitions
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Agents available
Agents available is a real-time statistic indicating the current number of agents who are logged in and not in
Make Busy or Do Not Disturb. If an agent is configured as a part of an agent group and is logged in, the agent
is counted as available, even if they are not present in that agent group. This statistic can be used as a queue
condition in IVR Routing.

ANI (Automatic Number Identification)
ANI (Automatic Number Identification) is a service that provides receivers of telephone calls with the caller
information. ANI is used to create screen pops for agents, providing caller information or to route calls by
caller phone numbers.

Answering points
An answering point is a single point of communication available to callers where they can contact a contact
center or an agent , such as a queue, voicemail, or extension.

ASA
See Average Speed of Answer

Average Speed of Answer
Average Speed of Answer (ASA) is an ACD statistic measuring how long the average caller waits on hold in
queue before their call is answered by an agent.

Auto-acknowledgement
An auto-acknowledgement is aMultimedia Contact Center-configured response received by customers after
contacting a contact center via email or chat.

Average abandon time
The average abandon time is the average number of seconds callers wait in queue before they abandon a call.

Blocked call
A blocked call is a call that is unable to get into the contact center's telephone system because there are no
trunks available. The caller receives a busy signal.

Busy hour
Busy hour is a statistic that highlights the busiest hour of operation of a business day.

Call abandoned parameter
The Call abandoned parameter is a queue configuration that defines short abandoned calls, determining what
abandoned calls are included as abandoned in call statistics. The default the short abandon is configured at 6
seconds.

Call flow
Call flows are programed pathways using the IVR Routing application that control how calls coming into a
contact center are handled, including how they are routed, themessages and prompts they hear, and the input
options provided to a caller.
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Call routing
Call routing is the set of instructions configured in Contact Center Solutions to automate themovement of
calls to their intended answering points.

Call type
Call type categorizes calls agents receive, enabling them to be looked up in SMDR Inspector. Call types
include ACD or non-ACD, abandoned, interflowed, requeued, unavailable, or outbound.

Callback
Callback is an optional feature of telephone systems that enables callers who are unable to reach an agent in
a contact center to be called back by the contact center. Contact Center Solutions and IVR Routing offer
several methods of providing callbacks, including Call me back, voice callbacks, web callbacks, and abandon
callbacks.

Calls abandoned
Calls abandoned is a report field detailing the total number of calls that abandoned in queue or while the phone
was still ringing at the agents' extensions. Calls abandoned ignores calls that were abandoned before the
short abandoned parameter had been passed.

See Abandoned calls.

Calls abandoned (long)
Calls abandoned (long) are abandoned calls where the caller hung up after the short abandon parameter had
been passed. By default, the short abandon is configured to be 6 seconds.

Calls abandoned (short)
Calls abandoned (short) are abandoned calls where the caller hung up before the short abandon parameter had
been passed and are not included in the call statistics.

Calls answered
SeeCalls handled.

Calls handled
A handled call is a call that has been picked up and answered by an agent. A call that listens to in-queue RAD
messages is not considered handled until it is answered by an agent.

Calls interflowed
See Interflow

Calls offered
1) Call offered are all calls received, regardless of how they are handled or routed, including calls handled and
both short and long abandoned calls.

2) Calls offered is a forecasting parameter used to determine the agent requirement for a contact center’s
Service Level percent and Service Level time targets through applying the Erlang C equation to the estimated
Call Load and average ACD Handling Time.

Contact Center Solutions terms and definitions
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Calls requeued
Requeued calls are all calls replaced back into the same queue and offered to another agent when an agent
receives an ACD call and fails to answer it after a pre-configured number of rings.

Calls waiting
Calls waiting is the number of callers in a queue waiting for an agent to become available, including those
listening toMusic on hold or queue announcements.

Camp on
Camp on is a notification tool that enables callers to notify an employee, who is currently on a call, that they
are waiting to be answeredl. The employee is notified by a series of audible beeps.

Classification codes
Classification codes are classifiers appended to calls to categorize them, enabling reporting to examine
specific categories of calls, such as those relating to specific products or services.

Clustered environment
A clustered environment is a network environment wheremultiple telephone systems are linked together to
function as a single system.

Computer Telephony Integration
Computer Telephony Integration (CTI) are technologies that merge computer functions and telephone
systems, enabling PC-based telephone systems to deliver functions such as synchronized voice and data
delivery, voice and data conferencing, automatic information retrieval for calls, caller-basedmessaging and
routing, and desktop productivity tools.

CTI
SeeComputer Telephony Integration

Customer Relationship Management
Customer Relationship Management (CRM) is amodel for customermanagement that relies on technology to
streamline andmanage interactions with customers.

Date stamp
SeeDate/Time stamp.

Date/Time stamp
A date/time stamp is an indicator attached to a record or statistic detailing when it was created.

Delayed call
A delayed call is a call that has been placed into an ACD queue to wait for an available agent because it
cannot be immediately handled by an agent.

Dialable number
The dialable number is a digit or series of digits dialed by a caller to reach an answering point, such as an
agent , an extension, a queue, or voicemail.
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Dialed Number Identification Service (DNIS)
Dialed Number Identification Service (DNIS) is a telecommunication service that identifies the phone
numbers dialed by inbound callers. DNIS can be used to route calls, enabling contact centers managing
multiple product lines or businesses to direct calls into the appropriate product or business queue.

Division
A division is a grouping of several employee or extension groups that enable a single report to be run for
several groups simultaneously.

DND
SeeDoNot Disturb (state).

DNIS
SeeDialed Number Identification Service.

Do Not Disturb (state)
DoNot Disturb (DND) is an agent presence state that disables the agent's extension to prevent any calls from
being routed to that extension.

Employee
An employee is a person who is employed by an organization and configured as an employee in Contact
Center Solutions so that they have access to Contact Center Solution applications andmay have their
associated devices reported on.

Enterprise
An enterprise is both the single site where the Enterprise Server is installed and all the connected branch
offices that comprise a company.

Enterprise Server
The Enterprise Server is the central server upon which Contact Center Solutions is installed and from which
Contact Center Solutions runs.

Erlang
An Erlang is a unit of measure for telephone traffic equal to one hour or 3,600 seconds of telephone
conversation, such as a single call lasting one hour or six calls lasting 10minutes.

Erlang B
Erlang B is an equation used to estimate the number of trunks required by a contact center.

Erlang C
Erlang C is a forecasting equation that uses historical Call Load data, Service Level Percentage, Service
Level Time, andWrap up TimeUsed to predict the resources required to keep wait times within a contact
center ‘s Service Level objective for the time interval and data range selected in a forecast.

Extension
An extension is a telephone system answering point that has a specific dialing number.

Contact Center Solutions terms and definitions
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Fixed Length Account Codes
Fixed Length Account Codes are verified and non-verified Account Codes that are automatically submitted to
the system when the correct number of digits has been entered.

Forced Account Codes
Forced Account Codes are verified and non-verified account codes that must be entered at a specific time in a
call. Forced verified account codes must be entered as soon as the phone is off the hook. Forced non-verified
Account Codes must be entered after the phone number is dialed. Systems may be configured to avoid the
requirement of entering a forced non-verified Account Code whenmaking a call that must not be charged (for
example, dialing a leading digit such as 8 tomake a call without entering an Account Code and dialing a
leading digit such as 9 tomake a call that requires an Account Code).

Grade of service
The grade of service (GOS) is ameasure of the likelihood of an attempted call receiving a busy signal. GOS
compares the number of trunks to the level of traffic and expresses the result as a decimal fraction. A GOS of
P.02, for example, indicates that a caller would have a two percent chance of receiving a busy signal.

Handled by
Handled by is the real-time statistic for the number of calls answered by the first, second, third, and fourth
answer points.

Handled %
Handled% is the real-time statistic comparing the calls handled to the calls offered.

Handling time
Handling time is themeasure of how long a call took to be handled by an agent, from when the call is
answered by the agent to when the call is finished. Handling time includes talk time, hold time, as well as
transfers and conferences on the call.

Hot desking agent
Hot desking agents are employees configured with a hot desking agent ID that enables them to sit at any
extension in a network and log on to that extension with all their regular work settings available. External hot
desking agents can hot desk remotely using any phone or headset.

Hunt group
A hunt group is a series of telephone lines grouped by the telephone system that rotates incoming calls
through the lines until an available line is found and the caller is connected.

Inbound
Inbound is a descriptive term applied to forms of contact or communication, such as calls or emails, to
indicate that it is being sent to a contact center from an external source.

Inbound calls
See Inbound.
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Interflowed
Interflow is a call flow mechanism that redirects a contact (such as a call, email, chat, or fax) waiting in a
queue to another answering point after the contact has been waiting in queue longer than the system-
configured interflow time. A contact may be interflowed repeatedly until it reaches an agent.

Interactive Voice Response
Interactive Voice Response (IVR) is a technology that enables callers to interact with a contact center’s
phone system by pressing keys or speech recognition while following IVR dialog.

Internal calls
Internal calls are calls made from within a system to other answering points within the same system.

LAN
A Local Area Network (LAN) connects multiple computers together over short distances. LANs typically
operate within a building. The computers share information, applications, and peripherals, such as printers.

Logged on
Logged on is an agent state applied to agents who have signed into the ACD system.

Logged off
Logged off is an agent state applied to agents who have signed out of the ACD system.

Longest waiting
Longest waiting is the duration, in minutes and seconds, of the call that has been waiting the longest in queue.

Make Busy (state)
Make Busy is an agent presence state applied to prevent an agent who is busy from receiving ACD calls.
While in Make Busy, an agent can receive calls dialed directly to their extension.

Media servers
A media server is a server or system, such as a telephone system, used to organize and distribute
communications (phone calls, email, etc.) throughout a contact center.

MiTAI
MiTAI is aMitel implementation of TAPI that is used to connect the telephone system/PCs running windows
to external applications, such as ACD controllers.

Mitel OPS Manager
Mitel OPS Manager is aMitel software application that provides network-wide administration and
maintenance for MCD, 3300, and SX-2000 Network Elements or Nodes.

Non ACD (state)
Non ACD is an agent state that is applied to an agent handling a non-ACD call or making a call.

Non-verified Account Codes
Non-Verified Account Codes are numbers entered onto the SMDR record for billing and call management.
During a call, non-verified Account Codes can be entered as often a required.

Contact Center Solutions terms and definitions
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Outbound calls
Outbound calls are calls made from within a contact center to external answering points.

Overflow
Overflow is a call distributionmechanism that queues calls against two or more agent groups to limit the delay
faced by callers. If a call in an ACD queue is not answered after the configured Overflow time, then it is placed
into the queue of a second agent group in addition to the first queue.

PBX
See Telephone system.

Pooling principle
The pooling principle refers to the increased contact center efficiency gained by consolidating contact center
resources.

Port
A port is a communications endpoint in Contact Center Solutions used to link services.

Probability of delay
The probability of delay is a statistic that measures the likelihood of a call being delayed in the ACD queue,
comparing the number of agents/extensions to the level of traffic carried by the trunks.

PSTN
See Public Switched Telephone Network.

Public Switched Telephone Network (PSTN)
The Public Switched Telephone Network is a global collection of Central Offices (CO) interconnected by long
distance telephone switching systems.

Quality of service
Quality of service is a reflection of an agent's ability to provide excellent assistance to each customer. Quality
of service can be evaluated andmanaged through silent monitoring systems, IT support systems, CTI, ANI,
and DNIS.

Queue number
A queue number is the address of a queue or other answering point used in the telephone system. The
programming associated with the queue number defines the routing and timing options available to the call.

Queue unavailable
1) Queue unavailable is a routing option that reroutes calls to a queue answer point if the queue is unavailable
due to no agents logged on or if a supervisor puts the path into Do Not Disturb.

2) Queue unavailable is a real-time statistic that counts how many calls were re-rerouted to other queues due
to the queue being unavailable.

RAD
SeeRecorded announcement device.
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Readerboard
SeeWall sign.

Real-time adherence
Adherence refers to whether or not agents are performing the activities for which they are scheduled.
Workforcemanagement tools enable supervisors to be notified of discrepancies between agents' work
schedules and the actual activities they perform.

Reason Code
Reason codes are descriptive classifiers applied toMake Busy and DoNot Disturb agent states to provide
more detailed information as to why the agent applied the code.

Recorded announcement device
Recorded Announcement Device is an IVR Routing feature that provides prerecordedmessages to callers
waiting in the ACD queue.

Reporting number
A reporting number is the unique number assigned by the system to contact center resources for reporting
purposes.

Service Level percent
The Service Level percent is the number of calls that are handled, abandoned, and interflowed before the
Service Level time, compared to the total number of calls handled, abandoned, and interflowed.

Service Level time
The Service Level time is the specified time used in calculating the queue service objective in conjunction
with the Service level percent, such as 80% (Service Level percent) of contacts answered within 120 seconds
(Service Level time).

Silent monitoring
Silent monitoring is a Contact Center Solutions feature that facilitates the tracking of agents' call handling
techniques by enabling supervisors to listen to the voice conversations of internal or external calls between
agents and callers without alerting either the agent or caller.

Site
A site is a physical location of a contact center with one or moremedia servers. It may be the same location
where the Enterprise Server is installed or a branch office.

Spectrum
Spectrum is a reporting feature configured for queues that provides a frequency distribution of calls
abandoned, answered, or interflowed based on a defined time scale.

SQL
SQL is a standard query language used to enter, query, and change data in a database, as well as create and
administer databases. Administration of YourSite Explorer is done usingMicrosoft's SQL Server.

Subroutines
Subroutines are portions of IVR Routing call flows that can be reused inmultiple call flows.

Contact Center Solutions terms and definitions
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Talk time
Talk time is themeasure of the time an agent spends talking to callers, excluding time spent on hold.

TCP/IP
TCP/IP is the basic communication protocol of the Internet and is used as a communication protocol in private
networks (intranets).

Telephone system
A telephone system is a private branch exchange (PBX) or business telephone switch used to process
incoming and outgoing calls to a contact center.

Time to answer
Time to answer is themeasure, in seconds, of how long an incoming call remained in queue before it was
answered. It is primarily used as an SMDR datamining criteria.

Time stamp
SeeDate/Time stamp.

True talk time
See Talk Time.

Trunk
A trunk is a communication line between two telephone systems.

Trunk load
Trunk load is the duration of time from when a trunk receives a call to when the agent finishes handling the
call and disconnects. Trunk load does not includeWrap Up Time.

Unavailable
Unavailable is an agent and employee state real-time column in Contact Center Client that includes agents
unavailable to take calls due to being in DoNot Disturb, Make Busy, Work Timer, Reseize Timer, or
Unknown.

Updated Position in Queue (UPiQ)
Updated Position in Queue (UPiQ) is a notification feature that provides messages to callers informing them
of their position in queue and keeps them informed of their position if it changes, at preset intervals.

UPiQ
SeeUpdated Position in Queue.

Verified Account Codes
Verified Account Codes are numbers entered beforemaking a call to change the Class of Service or Class of
Restriction at the station. When the call ends, the station returns to normal. Verified Account Codes can be
tracked with SMDR for long-distance billing purposes andmay be reported in Internal SMDR logs.

Wall board
SeeWall sign.
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Wall sign
A wall sign is an electronic sign used to display real-time ACD statistics to agents and supervisors in a
contact center.

WAN
Wide Area Network (WAN) connects multiple computers over a wide geographic area. WANs operate over
telephone carrier lines through bridges or routers. Router options enable communication between high speed
LAN links and slower speedWAN links, which tie LAN segments together.

Workforce management
Workforcemanagement is the scheduling of contact center agents to meet forecasted needs and the
managing of agents to ensure they adhere to their scheduled activities.

Wrap Up Time
WrapUp Time is a real-time statistic detailing the total time an agent spends in theWork Timer state.

Contact Center Solutions terms and definitions
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Multimedia Contact Center terms and definitions
Agent Requeue Time
TheAgent requeue time is the length of time a contact sits in the assigned agent’s inbox before it is re-queued
(put back into the same queue and offered to the next available agent).

When an agent receives a contact and fails to respond to the contact after X seconds, Multimedia Contact
Center places the agent in Make Busy and re-queues the contact. This re-queued contact has priority over all
others and will be the next contact message answered.

Auto-acknowledgment Message
TheAuto-acknowledgment message is a message that is automatically sent to the client upon receipt of the
clients email. For example, “Thank you for your interest in prairieFyre Software. We have received your email,
and it is being handled by one of our agents. Please expect a reply shortly.”

The responsemessage is created with the Responses tab.

Hold Requeue Timeout
The hold requeue time is the length of time an email message sits in the assigned agent’s queue before a
warning is flashed to indicate that the email message will soon be reassigned to another agent’s queue if not
answered.

Interflow Queue
The interflow queue is the queue the email message is directed to when it first arrives at a company’s email
address.

Interflow Time
The interflow is the path along which the email message is directed. The interflow time is the length of time the
email message will wait in the queue that the interflow directed it to. This ensures the email message does not
go unanswered for long.

Media Server
Themedia server is whereMultimedia Contact Center and Contact Center Management organizes and
distributes email and phone calls throughout your company. If your company is large, youmight have several
media servers.

Name
The name is the queue name. For example, the namemight beQ1.

Non Available Request Timeout
Multimedia Contact Center knows which agent answered which email. If a customer has already received a
response from an agent but has further questions, the customer’s next email is directed back to the original
agent. However, that agent might not be available. The non available request timeout time is the length of time
the email will sit in the original agent’s queue before being forwarded to another agent. If the non available
request timeout is 60minutes, and an email is sent after office hours, then the email would be forwarded to
another agent.

Multimedia Contact Center terms and definitions



Contact Center Solutions User Guide

- 777 -

Overflow Agent Group
The overflow agent group is the agent group that an email message is forwarded to because the email
message was not answered by the primary agent group within a set period of time (the overflow time). The
email message is placed in the queue of the overflow agent group in addition to keeping its place in the first
queue. The first available agent in either group answers the call.

If the email message is not answered by overflow agent group1 within the overflow time, it is placed in the
queue of overflow agent group 2 in addition to keeping its place in the first queue (primary agent group) and
second queue (overflow agent group 1). There are three possible overflow agent groups: overflow agent group
1, overflow agent group 2, and overflow agent group 3.

Overflow Time
The overflow time is the length of time an email will sit in the primary agent group queue before also being
forwarded to a overflow agent group.

Primary Agent Group
The primary agent group is the group assigned to answer a particular email message first.

Priority
Priority assigns priority to queues. The highest priority is 1, and the lowest priority is 10. This allows you to
answer queues of higher priority first.

Public Folder Name
The public folder name is the windows user name.

Public Mail Address
The public mail address is the company email address. This is the address the customers will use to email
you.

Reporting Number (for a queue)
The reporting number is assigned for reporting purposes. This report number is referenced when creating a
report about email data from a particular queue. A queue reporting numbermust start with P and have three
digits following. For example, the reporting number for a queuemight be P123.

Service Level
The term service level is the turn-around-time goal. For example, if the service level is 20minutes, the agents
provided excellent service if they can respond to all emails within 20minutes of receiving them.
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Mitel 5000/Axxess terminology compared
Table 27 - 1 compares Mitel Contact Center Solutions and telephone system terminology and the
correspondingMitel 5000/Axxess telephone system terminology and details any critical need-to-know
differences between the terms.

Mitel term 5000/Axxess
term

Definition / Differences

Media Server Media Servers are themeans by which the
customer communicates with you (for example,
anMitel 5000 or Axxess telephone system).

Queue Hunt group 5000/Axxess hunt groups are referred to as
queues when discussing routing and call
treatment options.

Agent Group Hunt group 5000/Axxess hunt groups are referred to as
agent groups when discussingmembership
roles.

Extension Endpoint (5000)
Station (Axxess)

5000/Axxess endpoints will be referred to as
extensions, except when discussing
5000/Axxess telephone system programming.

Presence Log in Presence is a new Mitel term used when agents
log in to specific queues. Previously, agents
were logged in to all queues that they were
associated with. Presence enables agents to
control the queues they are present in.

Interflow Overflow TheMitel concept of interflow is the path along
which a call is directed. The interflow time is the
time before the system removes the call from
the queue and redirects it to another answering
point. The interflow timer runs independently of
the Overflow timer.

Table 27 - 1 Mitel and 5000/Axxess terminology compared

Mitel 5000/Axxess terminology compared
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Mitel term 5000/Axxess
term

Definition / Differences

Overflow N/A While the 5000/Axxess telephone systems
have a concept of overflow, the 5000/Axxess
use of the term overflow is actually what Mitel
refers to as interflow (see above for a definition).
TheMitel concept of overflow is themechanism
that limits the delay faced by callers by queuing
calls against two or more agent groups. An ACD
call that cannot be answered immediately is
placed in an ACD queue. If the call is not
answered after a set amount of time (the
overflow time), it is placed in the ACD queue of
another agent group, in addition to keeping its
place in the first queue. The first available agent
in either group handles the call.

Recorded
Announcement Device
(RAD)

Call Routing
Announcement

A Recorded Announcement Device (RAD) is a
system that provides prerecordedmessages to
callers waiting in the ACD queue.

Reporting Number N/A The reporting number is the number assigned to
contact center resources, such as trunks,
devices, and ACD queues, for reporting
purposes.

Dialable Number Endpoint (5000)
Station (Axxess)

The dialable number is the digit or series of
digits a caller dials to reach an agent at an
extension, an ACD queue, voicemail, or some
other answering point.

Make Busy DoNot Disturb (DND) Make Busy is an agent state in which the agent
removes himself/herself from the ACD queue.
While in Make Busy, the agent does not receive
any ACD queue calls, but can receive calls
dialled directly to their extension.

Do Not Disturb (DND) DoNot Disturb (DND) DoNot Disturb (DND) is an agent state in which
the agent disables their extension to prevent any
calls from being routed there. 5000/Axxess
concept of DoNot Disturb is more aligned with
Mitel’s concept of Make Busy, where an agent
removes himself/herself from the ACD queue,
but can still receive calls dialled directly to their
extension.
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Mitel/Contact Center Solutions and Call
Accounting terminology and concepts compared
Table 28 - 1 compares Mitel telephony system concepts and terminology to Contact Center Solutions and Call
Accounting concepts and terminology and details any critical need-to-know differences between the terms.
For more information on specific terms, see "Contact Center Solutions terms and definitions" on page 765.

Contact Center
Solutions and
Call Accounting

Term

Mitel Term Definition / Differences

Agent group Agent skill group Agent group/Agent skill group is a group of
agents who handle calls from ACD paths.

Classification codes -- Contact Center Solutions and Call Accounting
treats classification codes as a type of Account
Code, which are used to categorize calls for
reporting.

Mitel does not use classification codes.

Employee / Agent Agent For Contact Center Solutions and Call Account-
ing, employees correlate to a person who works
for your organization and requires a license for
access to Contact Center Solutions and Call
Accounting applications and to have their asso-
ciated devices reported on. Mitel only rec-
ognizes agents, who have agent IDs and are
associated with agent skill groups, which enable
them to receive ACD calls from associated
queues, be seen in real-time, and be reported
on.

Extension groups -- Extension groups are a Contact Center Solu-
tions and Call Accounting feature that has no
Mitel terminology equivalent.

Media server PBX / Telephone System A telephone system is a private branch
exchange (PBX) or business telephone switch
used to process incoming and outgoing calls to
a contact center. A media server is a server or
system, such as a telephone system, used to
organize and distribute communications (phone
calls, email, etc.) throughout a contact center.

Table 28 - 1 Mitel/Contact Center Solutions and Call Accounting terminology compared

Mitel/Contact Center Solutions and Call Accounting terminology and concepts compared
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Contact Center
Solutions and
Call Accounting

Term

Mitel Term Definition / Differences

Queue Path A queue/path is an ACD tool that delays calls
rather than blocking them from entering the sys-
tem, holding them until an available agent can
handle them.

Queue groups -- Queue groups are queues grouped primarily for
reporting purposes. Contact Center Solutions
feature that has noMitel terminology equivalent.

-- Ring groups Ring groups are an unsupportedMitel feature
that provides the ability to ring all members of a
group simultaneously or sequentially.

Work timer Work timer Work timer is a feature that places an agent into
an unavailable state after completing a call to
provide them with time to complete after call
tasks before becoming available to handlemore
ACD calls. Mitel work timer is a feature on the
controller, while prairieFyre work timer is a soft-
ware feature.
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